Swebui Library

Swebui Library Document, more detials https://www.swebui.com
命名空间
命名空间 | 说明
Swebui | Swebui
Swebui.Controls | Swebui Controls
Swebui.Controls.DropdownAlert |
Swebui.ManagedThreading | Swebui Managed Threading


Swebui 命名空间

Swebui
类
 | 类 | 说明
公共类 | AssemblyReference |
公共类 | ClientPushOpenedEventArgs | 为 ClientPushOpened 事件提供数据。
公共类 | ControlStyle | 控件样式类
公共类 | DesignStyleSetting | 样式配置类
公共类 | DesignStyleType | 样式设计类型
公共类 | InvalidLayoutException | 无效的布局异常
公共类 | NetWorkHandlerArgs | 为NetWorkCallBackHandler提供数据
公共类 | ResultArgs | 为ResultHandler提供数据
公共类 | ResultArgsT | 为ResultHandler提供数据
公共类 | Setting | Smobiler 配置类
公共类 | SRDescriptionAttribute |
公共类 | StatusbarHandlerArgs | 为StatusbarCallBackHandler提供数据
公共类 | SwebClientInfo | 客户端信息
公共类 | SwebResourceManager | 资源管理类
公共类 | SwebServer | Swebui服务
公共类 | SwebSessionEventArgs | 为SwebuiSession事件提供数据。
公共类 | SwebSessionState | 客户端键值集合
公共类 | SwebUtility | 通用类
接口
 | 接口 | 说明
公共接口 | ISwebDesignService |
委托
 | 委托 | 说明
公共委托 | ClientPushOpenedEventHandler | 一个委托，它表示在客户端点击打开推送内容后要调用的方法。
公共委托 | NetWorkCallBackHandler | 一个委托，它表示客户端返回网络状态时要调用的方法。
公共委托 | ResultHandler | 一个委托，它表示基于组件API接口调用结束时要调用的方法。
公共委托 | ResultHandlerT | 一个委托，它表示基于组件API接口调用结束时要调用的方法。
公共委托 | StatusbarCallBackHandler | 一个委托，它表示客户端返回状态栏时要调用的方法。
公共委托 | SwebSessionEventHandler | 一个委托，它表示在Session处理时要调用的方法。
枚举
 | 枚举 | 说明
公共枚举 | ClientFramework | 客户端平台
公共枚举 | ClientSource | 客户端源
公共枚举 | DeveloperTraceMode | 客户端日志输出模式
公共枚举 | NetWorkType | 网络类型


AssemblyReference 类

[缺少 "T:Swebui.AssemblyReference" 的 <summary> 文档]

继承层次
SystemObject
SwebuiAssemblyReference

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class AssemblyReference
Public Class AssemblyReference

AssemblyReference 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AssemblyReference | 初始化 AssemblyReference 类的一个新实例
Top
字段
名称 | 说明
DesignInternalVersion |
DesignVersion |
SwebResourceFontEditor |
SwebResourcesDropDownEditor |
Top
参见

引用

Swebui 命名空间


AssemblyReference 构造函数

初始化 AssemblyReference 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AssemblyReference()
Public Sub New
参见

引用

AssemblyReference 类
Swebui 命名空间


AssemblyReference 字段

AssemblyReference 类型公开以下成员。

字段
名称 | 说明
DesignInternalVersion |
DesignVersion |
SwebResourceFontEditor |
SwebResourcesDropDownEditor |
Top
参见

引用

AssemblyReference 类
Swebui 命名空间


AssemblyReference.DesignInternalVersion 字段

AssemblyReferenceDesignInternalVersion 字段

[缺少 "F:Swebui.AssemblyReference.DesignInternalVersion" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DesignInternalVersion = "133.17134"
Public Const DesignInternalVersion As String = "133.17134"

字段值

类型：String
参见

引用

AssemblyReference 类
Swebui 命名空间


AssemblyReference.DesignVersion 字段

AssemblyReferenceDesignVersion 字段

[缺少 "F:Swebui.AssemblyReference.DesignVersion" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DesignVersion = ", Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"
Public Const DesignVersion As String = ", Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"

字段值

类型：String
参见

引用

AssemblyReference 类
Swebui 命名空间


AssemblyReference.SwebResourceFontEditor 字段

AssemblyReferenceSwebResourceFontEditor 字段

[缺少 "F:Swebui.AssemblyReference.SwebResourceFontEditor" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string SwebResourceFontEditor = "Swebui.Design.ResourceFontEditor, Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"
Public Const SwebResourceFontEditor As String = "Swebui.Design.ResourceFontEditor, Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"

字段值

类型：String
参见

引用

AssemblyReference 类
Swebui 命名空间


AssemblyReference.SwebResourcesDropDownEditor 字段

AssemblyReferenceSwebResourcesDropDownEditor 字段

[缺少 "F:Swebui.AssemblyReference.SwebResourcesDropDownEditor" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string SwebResourcesDropDownEditor = "Swebui.Design.SwebResourcesDropDownEditor, Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"
Public Const SwebResourcesDropDownEditor As String = "Swebui.Design.SwebResourcesDropDownEditor, Swebui.Design, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1ac7264a7cfc183"

字段值

类型：String
参见

引用

AssemblyReference 类
Swebui 命名空间


ClientFramework 枚举

客户端平台

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ClientFramework
Public Enumeration ClientFramework
成员
成员名称 | 值 | 说明
Develop | 0 | 开发版
Standard | 1 | 标准版
Enterprise | 2 | 企业版
参见

引用

Swebui 命名空间


ClientPushOpenedEventArgs 类

为 ClientPushOpened 事件提供数据。
继承层次
SystemObject
SwebuiClientPushOpenedEventArgs

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientPushOpenedEventArgs
Public Class ClientPushOpenedEventArgs

ClientPushOpenedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientPushOpenedEventArgs | 初始化 ClientPushOpenedEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Form | 获取当前显示的窗体
公共属性 | Params | 获取推送自定义参数
Top
备注
参见

引用

Swebui 命名空间


ClientPushOpenedEventArgs 构造函数

初始化 ClientPushOpenedEventArgs 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientPushOpenedEventArgs()
Public Sub New
参见

引用

ClientPushOpenedEventArgs 类
Swebui 命名空间


ClientPushOpenedEventArgs 属性

ClientPushOpenedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Form | 获取当前显示的窗体
公共属性 | Params | 获取推送自定义参数
Top
参见

引用

ClientPushOpenedEventArgs 类
Swebui 命名空间


ClientPushOpenedEventArgs.Form 属性

ClientPushOpenedEventArgsForm 属性

获取当前显示的窗体

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebForm Form { get; }
Public ReadOnly Property Form As SwebForm
    Get

属性值

类型：SwebForm

返回值

类型：SwebForm
备注
参见

引用

ClientPushOpenedEventArgs 类
Swebui 命名空间


ClientPushOpenedEventArgs.Params 属性

ClientPushOpenedEventArgsParams 属性

获取推送自定义参数

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Params { get; }
Public ReadOnly Property Params As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientPushOpenedEventArgs 类
Swebui 命名空间


ClientPushOpenedEventHandler 委托

一个委托，它表示在客户端点击打开推送内容后要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ClientPushOpenedEventHandler(
    Object sender,
    ClientPushOpenedEventArgs e
)
Public Delegate Sub ClientPushOpenedEventHandler (
    sender As Object,
    e As ClientPushOpenedEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：SwebuiClientPushOpenedEventArgs
包含事件数据的 ClientPushOpenedEventArgs
备注
参见

引用

Swebui 命名空间


ClientSource 枚举

客户端源

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ClientSource
Public Enumeration ClientSource
成员
成员名称 | 值 | 说明
App | 1 | 应用
Web | 2 | 网站
WeChat | 4 | 微信
WeWork | 8 | 微信企业
WeChatMiniProgram | 16 | 微信小程序
参见

引用

Swebui 命名空间


ControlStyle 类

控件样式类
继承层次
SystemObject
SwebuiControlStyle

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ControlStyle
Public Class ControlStyle

ControlStyle 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ControlStyle | 初始化 ControlStyle 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ControlObj | 控件实体，用于添加到PropertyGrid上
公共属性 | ControlType | 控件类型
公共属性 | Name | 控件名称
公共属性 | NodeControlStyle | 下一层包含的样式字典（允许下级）
公共属性 | NodePropertyDict | 控件样式对应的配置文件中的属性和值（由于并不想在获取配置文件时，就创建样式控件的实例，所以这里只添加在字典中）
公共属性 | NodePropertyValueDict | 控件样式对应的配置文件中的属性和实际类型的值
公共属性 | PropertyGridObj | 自定义的类型
Top
参见

引用

Swebui 命名空间


ControlStyle 构造函数

初始化 ControlStyle 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ControlStyle(
    string name,
    Type controltyp
)
Public Sub New (
    name As String,
    controltyp As Type
)

参数

name
类型：SystemString

[缺少 "M:Swebui.ControlStyle.#ctor(System.String,System.Type)" 的 <param name="name"/> 文档]

controltyp
类型：SystemType

[缺少 "M:Swebui.ControlStyle.#ctor(System.String,System.Type)" 的 <param name="controltyp"/> 文档]

参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle 属性

ControlStyle 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ControlObj | 控件实体，用于添加到PropertyGrid上
公共属性 | ControlType | 控件类型
公共属性 | Name | 控件名称
公共属性 | NodeControlStyle | 下一层包含的样式字典（允许下级）
公共属性 | NodePropertyDict | 控件样式对应的配置文件中的属性和值（由于并不想在获取配置文件时，就创建样式控件的实例，所以这里只添加在字典中）
公共属性 | NodePropertyValueDict | 控件样式对应的配置文件中的属性和实际类型的值
公共属性 | PropertyGridObj | 自定义的类型
Top
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.ControlObj 属性

ControlStyleControlObj 属性

控件实体，用于添加到PropertyGrid上

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object ControlObj { get; set; }
Public Property ControlObj As Object
    Get
    Set

返回值

类型：Object
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.ControlType 属性

ControlStyleControlType 属性

控件类型

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Type ControlType { get; set; }
Public Property ControlType As Type
    Get
    Set

返回值

类型：Type
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.Name 属性

ControlStyleName 属性

控件名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Name { get; set; }
Public Property Name As String
    Get
    Set

返回值

类型：String
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.NodeControlStyle 属性

ControlStyleNodeControlStyle 属性

下一层包含的样式字典（允许下级）

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, ControlStyle> NodeControlStyle { get; set; }
Public Property NodeControlStyle As Dictionary(Of String, ControlStyle)
    Get
    Set

返回值

类型：Dictionary String, ControlStyle
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.NodePropertyDict 属性

ControlStyleNodePropertyDict 属性

控件样式对应的配置文件中的属性和值（由于并不想在获取配置文件时，就创建样式控件的实例，所以这里只添加在字典中）

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, string> NodePropertyDict { get; set; }
Public Property NodePropertyDict As Dictionary(Of String, String)
    Get
    Set

返回值

类型：Dictionary String, String
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.NodePropertyValueDict 属性

ControlStyleNodePropertyValueDict 属性

控件样式对应的配置文件中的属性和实际类型的值

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, Object> NodePropertyValueDict { get; set; }
Public Property NodePropertyValueDict As Dictionary(Of String, Object)
    Get
    Set

返回值

类型：Dictionary String, Object
参见

引用

ControlStyle 类
Swebui 命名空间


ControlStyle.PropertyGridObj 属性

ControlStylePropertyGridObj 属性

自定义的类型

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DesignStyleType PropertyGridObj { get; set; }
Public Property PropertyGridObj As DesignStyleType
    Get
    Set

返回值

类型：DesignStyleType
参见

引用

ControlStyle 类
Swebui 命名空间


DesignStyleSetting 类

样式配置类
继承层次
SystemObject
SwebuiDesignStyleSetting

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class DesignStyleSetting
Public Class DesignStyleSetting

DesignStyleSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DesignStyleSetting | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Styles | 样式集合
Top
方法
 | 名称 | 说明
公共方法 | GetControlStyle | 根据控件类型以及控件类型中对应的控件样式名称来查找ControlStyle
公共方法 | GetNodePropertyValueDict | 根据控件类型及控件类型中对应的控件样式名称来查找NodePropertyValueDict
公共方法 | SaveData | 保存配置
Top
参见

引用

Swebui 命名空间


DesignStyleSetting 构造函数

构造函数

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DesignStyleSetting(
    string path
)
Public Sub New (
    path As String
)

参数

path
类型：SystemString
配置文件路径
参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting 属性

DesignStyleSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Styles | 样式集合
Top
参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting.Styles 属性

DesignStyleSettingStyles 属性

样式集合

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, ControlStyle> Styles { get; }
Public ReadOnly Property Styles As Dictionary(Of String, ControlStyle)
    Get

返回值

类型：Dictionary String, ControlStyle
参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting 方法

DesignStyleSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetControlStyle | 根据控件类型以及控件类型中对应的控件样式名称来查找ControlStyle
公共方法 | GetNodePropertyValueDict | 根据控件类型及控件类型中对应的控件样式名称来查找NodePropertyValueDict
公共方法 | SaveData | 保存配置
Top
参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting.GetControlStyle 方法

DesignStyleSettingGetControlStyle 方法

根据控件类型以及控件类型中对应的控件样式名称来查找ControlStyle

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ControlStyle GetControlStyle(
    string ctltypename,
    string stylename
)
Public Function GetControlStyle (
    ctltypename As String,
    stylename As String
) As ControlStyle

参数

ctltypename
类型：SystemString

[缺少 "M:Swebui.DesignStyleSetting.GetControlStyle(System.String,System.String)" 的 <param name="ctltypename"/> 文档]

stylename
类型：SystemString

[缺少 "M:Swebui.DesignStyleSetting.GetControlStyle(System.String,System.String)" 的 <param name="stylename"/> 文档]

返回值

类型：ControlStyle

[缺少 "M:Swebui.DesignStyleSetting.GetControlStyle(System.String,System.String)" 的 <returns> 文档]

参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting.GetNodePropertyValueDict 方法

DesignStyleSettingGetNodePropertyValueDict 方法

根据控件类型及控件类型中对应的控件样式名称来查找NodePropertyValueDict

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, Object> GetNodePropertyValueDict(
    string ctltypename,
    string stylename
)
Public Function GetNodePropertyValueDict (
    ctltypename As String,
    stylename As String
) As Dictionary(Of String, Object)

参数

ctltypename
类型：SystemString

[缺少 "M:Swebui.DesignStyleSetting.GetNodePropertyValueDict(System.String,System.String)" 的 <param name="ctltypename"/> 文档]

stylename
类型：SystemString

[缺少 "M:Swebui.DesignStyleSetting.GetNodePropertyValueDict(System.String,System.String)" 的 <param name="stylename"/> 文档]

返回值

类型：Dictionary String, Object

[缺少 "M:Swebui.DesignStyleSetting.GetNodePropertyValueDict(System.String,System.String)" 的 <returns> 文档]

参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleSetting.SaveData 方法

DesignStyleSettingSaveData 方法

保存配置

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveData()
Public Sub SaveData
备注
参见

引用

DesignStyleSetting 类
Swebui 命名空间


DesignStyleType 类

样式设计类型
继承层次
SystemObject
System.ComponentModelCustomTypeDescriptor
SwebuiDesignStyleType

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class DesignStyleType : CustomTypeDescriptor
Public Class DesignStyleType
    Inherits CustomTypeDescriptor

DesignStyleType 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DesignStyleType | 初始化 DesignStyleType 类的一个新实例
公共方法 | DesignStyleType(ControlStyle) | 初始化 DesignStyleType 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Copy |
公共方法 | GetProperties | (重写 CustomTypeDescriptorGetProperties.)
公共方法 | GetProperties(Attribute) | (重写 CustomTypeDescriptorGetProperties(Attribute).)
公共方法 | GetPropertyOwner | (重写 CustomTypeDescriptorGetPropertyOwner(PropertyDescriptor).)
Top
备注
参见

引用

Swebui 命名空间


DesignStyleType 构造函数

重载列表
 | 名称 | 说明
公共方法 | DesignStyleType | 初始化 DesignStyleType 类的一个新实例
公共方法 | DesignStyleType(ControlStyle) | 初始化 DesignStyleType 类的一个新实例
Top
参见

引用

DesignStyleType 类
Swebui 命名空间


DesignStyleType 构造函数

初始化 DesignStyleType 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DesignStyleType()
Public Sub New
参见

引用

DesignStyleType 类
DesignStyleType 重载
Swebui 命名空间


DesignStyleType 构造函数 (ControlStyle)

初始化 DesignStyleType 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DesignStyleType(
    ControlStyle ctlstyle
)
Public Sub New (
    ctlstyle As ControlStyle
)

参数

ctlstyle
类型：SwebuiControlStyle

[缺少 "M:Swebui.DesignStyleType.#ctor(Swebui.ControlStyle)" 的 <param name="ctlstyle"/> 文档]

参见

引用

DesignStyleType 类
DesignStyleType 重载
Swebui 命名空间


DesignStyleType 方法

DesignStyleType 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Copy |
公共方法 | GetProperties | (重写 CustomTypeDescriptorGetProperties.)
公共方法 | GetProperties(Attribute) | (重写 CustomTypeDescriptorGetProperties(Attribute).)
公共方法 | GetPropertyOwner | (重写 CustomTypeDescriptorGetPropertyOwner(PropertyDescriptor).)
Top
参见

引用

DesignStyleType 类
Swebui 命名空间


DesignStyleType.Copy 方法

DesignStyleTypeCopy 方法

[缺少 "M:Swebui.DesignStyleType.Copy(Swebui.ControlStyle)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Copy(
    ControlStyle ctlstyle
)
Public Sub Copy (
    ctlstyle As ControlStyle
)

参数

ctlstyle
类型：SwebuiControlStyle

[缺少 "M:Swebui.DesignStyleType.Copy(Swebui.ControlStyle)" 的 <param name="ctlstyle"/> 文档]

参见

引用

DesignStyleType 类
Swebui 命名空间


DesignStyleType.GetProperties 方法

DesignStyleTypeGetProperties 方法

重载列表
 | 名称 | 说明
公共方法 | GetProperties | (重写 CustomTypeDescriptorGetProperties.)
公共方法 | GetProperties(Attribute) | (重写 CustomTypeDescriptorGetProperties(Attribute).)
Top
参见

引用

DesignStyleType 类
Swebui 命名空间


DesignStyleType.GetProperties 方法

DesignStyleTypeGetProperties 方法

[缺少 "M:Swebui.DesignStyleType.GetProperties" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties()
Public Overrides Function GetProperties As PropertyDescriptorCollection

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.DesignStyleType.GetProperties" 的 <returns> 文档]

实现

ICustomTypeDescriptorGetProperties
参见

引用

DesignStyleType 类
GetProperties 重载
Swebui 命名空间


DesignStyleType.GetProperties 方法 (Attribute[])

DesignStyleTypeGetProperties 方法 (Attribute)

[缺少 "M:Swebui.DesignStyleType.GetProperties(System.Attribute[])" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties(
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    attributes As Attribute()
) As PropertyDescriptorCollection

参数

attributes
类型：SystemAttribute

[缺少 "M:Swebui.DesignStyleType.GetProperties(System.Attribute[])" 的 <param name="attributes"/> 文档]

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.DesignStyleType.GetProperties(System.Attribute[])" 的 <returns> 文档]

实现

ICustomTypeDescriptorGetProperties(Attribute)
参见

引用

DesignStyleType 类
GetProperties 重载
Swebui 命名空间


DesignStyleType.GetPropertyOwner 方法

DesignStyleTypeGetPropertyOwner 方法

[缺少 "M:Swebui.DesignStyleType.GetPropertyOwner(System.ComponentModel.PropertyDescriptor)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object GetPropertyOwner(
    PropertyDescriptor pd
)
Public Overrides Function GetPropertyOwner (
    pd As PropertyDescriptor
) As Object

参数

pd
类型：System.ComponentModelPropertyDescriptor

[缺少 "M:Swebui.DesignStyleType.GetPropertyOwner(System.ComponentModel.PropertyDescriptor)" 的 <param name="pd"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.DesignStyleType.GetPropertyOwner(System.ComponentModel.PropertyDescriptor)" 的 <returns> 文档]

实现

ICustomTypeDescriptorGetPropertyOwner(PropertyDescriptor)
参见

引用

DesignStyleType 类
Swebui 命名空间


DeveloperTraceMode 枚举

客户端日志输出模式

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum DeveloperTraceMode
Public Enumeration DeveloperTraceMode
成员
成员名称 | 值 | 说明
All | 0 | 记录所有客户端日志
Single | 1 | 仅记录客户端属性ClientTrace设置为True的客户端日志
None | 2 | 不记录客户端日志
备注
参见

引用

Swebui 命名空间


InvalidLayoutException 类

无效的布局异常
继承层次
SystemObject
SystemException
SwebuiInvalidLayoutException

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class InvalidLayoutException : Exception
Public Class InvalidLayoutException
    Inherits Exception
构造函数
 | 名称 | 说明
公共方法 | InvalidLayoutException(String) | 初始化 InvalidLayoutException 类的一个新实例
公共方法 | InvalidLayoutException(String, Exception) | 初始化 InvalidLayoutException 类的一个新实例
Top
参见

引用

Swebui 命名空间


InvalidLayoutException 构造函数

重载列表
 | 名称 | 说明
公共方法 | InvalidLayoutException(String) | 初始化 InvalidLayoutException 类的一个新实例
公共方法 | InvalidLayoutException(String, Exception) | 初始化 InvalidLayoutException 类的一个新实例
Top
参见

引用

InvalidLayoutException 类
Swebui 命名空间


InvalidLayoutException 构造函数 (String)

初始化 InvalidLayoutException 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public InvalidLayoutException(
    string message
)
Public Sub New (
    message As String
)

参数

message
类型：SystemString

[缺少 "M:Swebui.InvalidLayoutException.#ctor(System.String)" 的 <param name="message"/> 文档]

参见

引用

InvalidLayoutException 类
InvalidLayoutException 重载
Swebui 命名空间


InvalidLayoutException 构造函数 (String, Exception)

初始化 InvalidLayoutException 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public InvalidLayoutException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

参数

message
类型：SystemString

[缺少 "M:Swebui.InvalidLayoutException.#ctor(System.String,System.Exception)" 的 <param name="message"/> 文档]

innerException
类型：SystemException

[缺少 "M:Swebui.InvalidLayoutException.#ctor(System.String,System.Exception)" 的 <param name="innerException"/> 文档]

参见

引用

InvalidLayoutException 类
InvalidLayoutException 重载
Swebui 命名空间


ISwebDesignService 接口

[缺少 "T:Swebui.ISwebDesignService" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebDesignService
Public Interface ISwebDesignService

ISwebDesignService 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ProjectOutputPath |
Top
参见

引用

Swebui 命名空间


ISwebDesignService 属性

ISwebDesignService 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ProjectOutputPath |
Top
参见

引用

ISwebDesignService 接口
Swebui 命名空间


ISwebDesignService.ProjectOutputPath 属性

ISwebDesignServiceProjectOutputPath 属性

[缺少 "P:Swebui.ISwebDesignService.ProjectOutputPath" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string ProjectOutputPath { get; }
ReadOnly Property ProjectOutputPath As String
    Get

属性值

类型：String
参见

引用

ISwebDesignService 接口
Swebui 命名空间


NetWorkCallBackHandler 委托

一个委托，它表示客户端返回网络状态时要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void NetWorkCallBackHandler(
    Object sender,
    NetWorkHandlerArgs args
)
Public Delegate Sub NetWorkCallBackHandler (
    sender As Object,
    args As NetWorkHandlerArgs
)

参数

sender
类型：SystemObject
事件源
args
类型：SwebuiNetWorkHandlerArgs
包含事件数据的 NetWorkHandlerArgs
备注
参见

引用

Swebui 命名空间


NetWorkHandlerArgs 类

为NetWorkCallBackHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
SwebuiNetWorkHandlerArgs

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class NetWorkHandlerArgs : ResultArgs
Public Class NetWorkHandlerArgs
    Inherits ResultArgs

NetWorkHandlerArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | NetWorkHandlerArgs | 初始化 NetWorkHandlerArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | NetWorkType | 获取网络类型
公共属性 | WifiBSSID | 获取WIFI网络下的BSSID
公共属性 | WifiIP | 获取WIFI网络下的IP地址
公共属性 | WifiSSID | 获取WIFI网络下的SSID
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui 命名空间


NetWorkHandlerArgs 构造函数

初始化 NetWorkHandlerArgs 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public NetWorkHandlerArgs()
Public Sub New
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs 属性

NetWorkHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | NetWorkType | 获取网络类型
公共属性 | WifiBSSID | 获取WIFI网络下的BSSID
公共属性 | WifiIP | 获取WIFI网络下的IP地址
公共属性 | WifiSSID | 获取WIFI网络下的SSID
Top
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs.NetWorkType 属性

NetWorkHandlerArgsNetWorkType 属性

获取网络类型

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public NetWorkType NetWorkType { get; }
Public ReadOnly Property NetWorkType As NetWorkType
    Get

属性值

类型：NetWorkType

返回值

类型：NetWorkType
备注
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs.WifiBSSID 属性

NetWorkHandlerArgsWifiBSSID 属性

获取WIFI网络下的BSSID

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WifiBSSID { get; }
Public ReadOnly Property WifiBSSID As String
    Get

返回值

类型：String
备注
仅支持Android系统
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs.WifiIP 属性

NetWorkHandlerArgsWifiIP 属性

获取WIFI网络下的IP地址

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WifiIP { get; }
Public ReadOnly Property WifiIP As String
    Get

返回值

类型：String
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs.WifiSSID 属性

NetWorkHandlerArgsWifiSSID 属性

获取WIFI网络下的SSID

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WifiSSID { get; }
Public ReadOnly Property WifiSSID As String
    Get

返回值

类型：String
备注
仅支持Android系统
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkHandlerArgs 方法

NetWorkHandlerArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

NetWorkHandlerArgs 类
Swebui 命名空间


NetWorkType 枚举

网络类型

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum NetWorkType
Public Enumeration NetWorkType
成员
成员名称 | 值 | 说明
Wifi | 0 | WIFI
Net | 1 | 移动数据网络
None | 2 | 未获取到网络状态
备注
参见

引用

Swebui 命名空间


ResultArgs 类

为ResultHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
更多...

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ResultArgs
Public Class ResultArgs

ResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResultArgs | 初始化 ResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
 | Empty | 获取一个空的ResultArgs
公共属性 | error | 获取和设置错误信息
公共属性 | errorCode | 获取和设置错误信息编号
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息
Top
方法
 | 名称 | 说明
 | CreateErrorResultT |
 | CreateResult |
 | GetDefault |
公共方法 | setErrorInfo | 设置错误信息
Top
参见

引用

Swebui 命名空间
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClientDataResultHandlerArgs
Swebui.ControlsClientResourceGetResultArgs
Swebui.ControlsClientResourceLoadResultArgs
Swebui.ControlsClientResourceRemoveResultArgs
Swebui.ControlsClipboardResultArgs
Swebui.ControlsDatePickrSelectedEventArgs
Swebui.ControlsSwebComponentResultArgs
SwebuiNetWorkHandlerArgs
SwebuiResultArgsT
SwebuiStatusbarHandlerArgs


ResultArgs 构造函数

初始化 ResultArgs 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResultArgs()
Public Sub New
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs 属性

ResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
 | Empty | 获取一个空的ResultArgs
公共属性 | error | 获取和设置错误信息
公共属性 | errorCode | 获取和设置错误信息编号
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息
Top
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.Empty 属性

ResultArgsEmpty 属性

获取一个空的ResultArgs

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Object Empty { get; }
Public Shared ReadOnly Property Empty As Object
    Get

返回值

类型：Object
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.error 属性

ResultArgserror 属性

获取和设置错误信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string error { get; set; }
Public Property error As String
    Get
    Set

返回值

类型：String
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.errorCode 属性

ResultArgserrorCode 属性

获取和设置错误信息编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int errorCode { get; set; }
Public Property errorCode As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.isError 属性

ResultArgsisError 属性

获取一个值，该值指示是否在接口调用结果中包含错误信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool isError { get; }
Public ReadOnly Property isError As Boolean
    Get

返回值

类型：Boolean
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs 方法

ResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateErrorResultT |
 | CreateResult |
 | GetDefault |
公共方法 | setErrorInfo | 设置错误信息
Top
参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.CreateErrorResult(T) 方法

ResultArgsCreateErrorResultT 方法

[缺少 "M:Swebui.ResultArgs.CreateErrorResult``1(System.Int32,System.String)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static T CreateErrorResult<T>(
    int errorcode,
    string errorinfo
)
where T : ResultArgs

Public Shared Function CreateErrorResult(Of T As ResultArgs) (
    errorcode As Integer,
    errorinfo As String
) As T

参数

errorcode
类型：SystemInt32

[缺少 "M:Swebui.ResultArgs.CreateErrorResult``1(System.Int32,System.String)" 的 <param name="errorcode"/> 文档]

errorinfo
类型：SystemString

[缺少 "M:Swebui.ResultArgs.CreateErrorResult``1(System.Int32,System.String)" 的 <param name="errorinfo"/> 文档]

类型参数

T

[缺少 "M:Swebui.ResultArgs.CreateErrorResult``1(System.Int32,System.String)" 的 <typeparam name="T"/> 文档]

返回值

类型：T

[缺少 "M:Swebui.ResultArgs.CreateErrorResult``1(System.Int32,System.String)" 的 <returns> 文档]

参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.CreateResult 方法

ResultArgsCreateResult 方法

[缺少 "M:Swebui.ResultArgs.CreateResult(Swebui.RPC.RPCResultArgs)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static ResultArgs CreateResult(
    RPCResultArgs e
)
Public Shared Function CreateResult (
    e As RPCResultArgs
) As ResultArgs

参数

e
类型：RPCResultArgs

[缺少 "M:Swebui.ResultArgs.CreateResult(Swebui.RPC.RPCResultArgs)" 的 <param name="e"/> 文档]

返回值

类型：ResultArgs

[缺少 "M:Swebui.ResultArgs.CreateResult(Swebui.RPC.RPCResultArgs)" 的 <returns> 文档]

参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.GetDefault 方法

ResultArgsGetDefault 方法

[缺少 "M:Swebui.ResultArgs.GetDefault(System.Type)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Object GetDefault(
    Type defaultType
)
Public Shared Function GetDefault (
    defaultType As Type
) As Object

参数

defaultType
类型：SystemType

[缺少 "M:Swebui.ResultArgs.GetDefault(System.Type)" 的 <param name="defaultType"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.ResultArgs.GetDefault(System.Type)" 的 <returns> 文档]

参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs.setErrorInfo 方法

ResultArgssetErrorInfo 方法

设置错误信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void setErrorInfo(
    int errorCode,
    string error
)
Public Sub setErrorInfo (
    errorCode As Integer,
    error As String
)

参数

errorCode
类型：SystemInt32

[缺少 "M:Swebui.ResultArgs.setErrorInfo(System.Int32,System.String)" 的 <param name="errorCode"/> 文档]

error
类型：SystemString

[缺少 "M:Swebui.ResultArgs.setErrorInfo(System.Int32,System.String)" 的 <param name="error"/> 文档]

参见

引用

ResultArgs 类
Swebui 命名空间


ResultArgs(T) 类

ResultArgsT 类

为ResultHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
SwebuiResultArgsT

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ResultArgs<T> : ResultArgs

Public Class ResultArgs(Of T)
    Inherits ResultArgs

类型参数

T

[缺少 "T:Swebui.ResultArgs`1" 的 <typeparam name="T"/> 文档]

ResultArgsT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResultArgsT | 初始化 ResultArgsT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Value |
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui 命名空间


ResultArgs(T) 构造函数

ResultArgsT 构造函数

初始化 ResultArgsT 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResultArgs()
Public Sub New
参见

引用

ResultArgsT 类
Swebui 命名空间


ResultArgs(T) 属性

ResultArgsT 属性

ResultArgsT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Value |
Top
参见

引用

ResultArgsT 类
Swebui 命名空间


ResultArgs(T).Value 属性

ResultArgsTValue 属性

[缺少 "P:Swebui.ResultArgs`1.Value" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public T Value { get; set; }
Public Property Value As T
    Get
    Set

属性值

类型：T
参见

引用

ResultArgsT 类
Swebui 命名空间


ResultArgs(T) 方法

ResultArgsT 方法

ResultArgsT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ResultArgsT 类
Swebui 命名空间


ResultHandler 委托

一个委托，它表示基于组件API接口调用结束时要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ResultHandler(
    Object sender,
    ResultArgs e
)
Public Delegate Sub ResultHandler (
    sender As Object,
    e As ResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：SwebuiResultArgs
包含事件数据的 ResultArgs
备注
参见

引用

Swebui 命名空间


ResultHandler(T) 委托

ResultHandlerT 委托

一个委托，它表示基于组件API接口调用结束时要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ResultHandler<T>(
    Object sender,
    ResultArgs<T> e
)

Public Delegate Sub ResultHandler(Of T) (
    sender As Object,
    e As ResultArgs(Of T)
)

参数

sender
类型：SystemObject
事件源
e
类型：SwebuiResultArgs T
包含事件数据的 ResultArgs

类型参数

T

[缺少 "T:Swebui.ResultHandler`1" 的 <typeparam name="T"/> 文档]

参见

引用

Swebui 命名空间


Setting 类

Smobiler 配置类
继承层次
SystemObject
SwebuiSetting

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class Setting
Public Class Setting

Setting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Setting | 初始化 Setting 类的新实例。
公共方法 | Setting(String) | 根据指定的路径初始化 Setting 类的新实例。
公共方法 | Setting(String, String) | 根据指定的路径和文件名初始化 Setting 类的新实例。
Top
属性
 | 名称 | 说明
公共属性 | AmapApi | 获取或设置高德地图API
公共属性 | BaiduMapApi | 获取或设置百度地图API
公共属性 | ClientTrace | 获取和设置一个值，该值指示是否记录客户端操作日志
公共属性 | ConfigPath | 获取配置文件路径
公共属性 | DefaultAudioPath | 获取默认音频路径
公共属性 | DefaultDocumentPath | 获取默认文档路径
公共属性 | DefaultImagePath | 获取默认图片路径
公共属性 | DefaultMediaPath | 获取默认媒体路径
公共属性 | DefaultUploadPath | 获取默认上传路径
公共属性 | DefaultWebPath | 获取默认WEB路径
公共属性 | DeveloperTrace | 获取或设置客户端详细日志输出模式
公共属性 | FormStackMaxCount | 获取和设置窗体最大栈数量
公共属性 | HttpServerPort | 获取或设置服务端HTTP端口。
公共属性 | HttpsServerPort | 获取或设置服务端HTTPS端口。
公共属性 | MirrorDisable |
公共属性 | NetworkTimeOut | 获取或设置网络超时时间(秒)
公共属性 | PerformTimeSpan | 性能监测时间间隔
公共属性 | PurgingTimeSpan | 获取或设置辅助线程的轮询时间(秒)。
公共属性 | ReloadInterval |
公共属性 | ResourceDenyId | 获取和设置禁止资源访问的名称正则表达式
公共属性 | ResourceDenyLocation | 获取和设置禁止资源访问的路径正则表达式
公共属性 | Resources | 获取资源列表
公共属性 | SecurityKey | 获取和设置客户端连接时验证的安全密钥
公共属性 | SessionTimeOut | 获取或设置客户端会话超时时间(秒)
公共属性 | StartupAssembly | 获取或设置入口程序集
公共属性 | StartupForm | 获取或设置启动界面
公共属性 | SysTrace | 获取或设置是否记录进程运行日志
公共属性 | TextFontScaling | 获取和设置一个值，该值指示是否根据系统缩放文本字体大小
公共属性 | TracePrint | 获取或设置一个值，该值指示是否在VS调试时输出日志
公共属性 | WebPath |
公共属性 | WebPlayer | 获取和设置一个值，该值指示是否启用web播放器
公共属性 | WebScreenWidth | 获取或设置Web屏幕宽度
公共属性 | WebTitle | 获取或设置抬头标题
Top
方法
 | 名称 | 说明
公共方法 | InitialData | 重新初始化配置信息。
公共方法 | InitialResources | 初始化资源
公共方法 | LoadData | 从指定的文件中载入配置信息。
公共方法 | SaveData | 保存配置信息。
Top
备注
参见

引用

Swebui 命名空间


Setting 构造函数

重载列表
 | 名称 | 说明
公共方法 | Setting | 初始化 Setting 类的新实例。
公共方法 | Setting(String) | 根据指定的路径初始化 Setting 类的新实例。
公共方法 | Setting(String, String) | 根据指定的路径和文件名初始化 Setting 类的新实例。
Top
参见

引用

Setting 类
Swebui 命名空间


Setting 构造函数

初始化 Setting 类的新实例。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Setting()
Public Sub New
参见

引用

Setting 类
Setting 重载
Swebui 命名空间


Setting 构造函数 (String)

根据指定的路径初始化 Setting 类的新实例。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Setting(
    string configPath
)
Public Sub New (
    configPath As String
)

参数

configPath
类型：SystemString
配置文件路径
参见

引用

Setting 类
Setting 重载
Swebui 命名空间


Setting 构造函数 (String, String)

根据指定的路径和文件名初始化 Setting 类的新实例。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Setting(
    string configPath,
    string configFileName
)
Public Sub New (
    configPath As String,
    configFileName As String
)

参数

configPath
类型：SystemString
配置文件路径
configFileName
类型：SystemString
配置文件名
参见

引用

Setting 类
Setting 重载
Swebui 命名空间


Setting 属性

Setting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AmapApi | 获取或设置高德地图API
公共属性 | BaiduMapApi | 获取或设置百度地图API
公共属性 | ClientTrace | 获取和设置一个值，该值指示是否记录客户端操作日志
公共属性 | ConfigPath | 获取配置文件路径
公共属性 | DefaultAudioPath | 获取默认音频路径
公共属性 | DefaultDocumentPath | 获取默认文档路径
公共属性 | DefaultImagePath | 获取默认图片路径
公共属性 | DefaultMediaPath | 获取默认媒体路径
公共属性 | DefaultUploadPath | 获取默认上传路径
公共属性 | DefaultWebPath | 获取默认WEB路径
公共属性 | DeveloperTrace | 获取或设置客户端详细日志输出模式
公共属性 | FormStackMaxCount | 获取和设置窗体最大栈数量
公共属性 | HttpServerPort | 获取或设置服务端HTTP端口。
公共属性 | HttpsServerPort | 获取或设置服务端HTTPS端口。
公共属性 | MirrorDisable |
公共属性 | NetworkTimeOut | 获取或设置网络超时时间(秒)
公共属性 | PerformTimeSpan | 性能监测时间间隔
公共属性 | PurgingTimeSpan | 获取或设置辅助线程的轮询时间(秒)。
公共属性 | ReloadInterval |
公共属性 | ResourceDenyId | 获取和设置禁止资源访问的名称正则表达式
公共属性 | ResourceDenyLocation | 获取和设置禁止资源访问的路径正则表达式
公共属性 | Resources | 获取资源列表
公共属性 | SecurityKey | 获取和设置客户端连接时验证的安全密钥
公共属性 | SessionTimeOut | 获取或设置客户端会话超时时间(秒)
公共属性 | StartupAssembly | 获取或设置入口程序集
公共属性 | StartupForm | 获取或设置启动界面
公共属性 | SysTrace | 获取或设置是否记录进程运行日志
公共属性 | TextFontScaling | 获取和设置一个值，该值指示是否根据系统缩放文本字体大小
公共属性 | TracePrint | 获取或设置一个值，该值指示是否在VS调试时输出日志
公共属性 | WebPath |
公共属性 | WebPlayer | 获取和设置一个值，该值指示是否启用web播放器
公共属性 | WebScreenWidth | 获取或设置Web屏幕宽度
公共属性 | WebTitle | 获取或设置抬头标题
Top
参见

引用

Setting 类
Swebui 命名空间


Setting.AmapApi 属性

SettingAmapApi 属性

获取或设置高德地图API

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string AmapApi { get; set; }
Public Property AmapApi As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.BaiduMapApi 属性

SettingBaiduMapApi 属性

获取或设置百度地图API

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BaiduMapApi { get; set; }
Public Property BaiduMapApi As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.ClientTrace 属性

SettingClientTrace 属性

获取和设置一个值，该值指示是否记录客户端操作日志

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ClientTrace { get; set; }
Public Property ClientTrace As Boolean
    Get
    Set

属性值

类型：Boolean
默认值False

返回值

类型：Boolean
参见

引用

Setting 类
Swebui 命名空间


Setting.ConfigPath 属性

SettingConfigPath 属性

获取配置文件路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ConfigPath { get; }
Public ReadOnly Property ConfigPath As String
    Get

返回值

类型：String
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultAudioPath 属性

SettingDefaultAudioPath 属性

获取默认音频路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultAudioPath { get; }
Public ReadOnly Property DefaultAudioPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultDocumentPath 属性

SettingDefaultDocumentPath 属性

获取默认文档路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultDocumentPath { get; }
Public ReadOnly Property DefaultDocumentPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultImagePath 属性

SettingDefaultImagePath 属性

获取默认图片路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultImagePath { get; }
Public ReadOnly Property DefaultImagePath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultMediaPath 属性

SettingDefaultMediaPath 属性

获取默认媒体路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultMediaPath { get; }
Public ReadOnly Property DefaultMediaPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultUploadPath 属性

SettingDefaultUploadPath 属性

获取默认上传路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultUploadPath { get; }
Public ReadOnly Property DefaultUploadPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.DefaultWebPath 属性

SettingDefaultWebPath 属性

获取默认WEB路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultWebPath { get; }
Public ReadOnly Property DefaultWebPath As String
    Get

返回值

类型：String
参见

引用

Setting 类
Swebui 命名空间


Setting.DeveloperTrace 属性

SettingDeveloperTrace 属性

获取或设置客户端详细日志输出模式

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DeveloperTraceMode DeveloperTrace { get; set; }
Public Property DeveloperTrace As DeveloperTraceMode
    Get
    Set

属性值

类型：DeveloperTraceMode
默认值Single

返回值

类型：DeveloperTraceMode
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.FormStackMaxCount 属性

SettingFormStackMaxCount 属性

获取和设置窗体最大栈数量

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int FormStackMaxCount { get; set; }
Public Property FormStackMaxCount As Integer
    Get
    Set

属性值

类型：Int32
默认为10，最小值为1，最大值为50

返回值

类型：Int32
备注
Smobiler客户端窗体使用堆栈结构，打开界面时会压栈，关闭界面时会出栈， 设置窗体最大栈数量为了防止无限制打开窗体导致内存不释放的问题出现， 建议设置合理大小，正常业务中建议不超过5
参见

引用

Setting 类
Swebui 命名空间


Setting.HttpServerPort 属性

SettingHttpServerPort 属性

获取或设置服务端HTTP端口。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int HttpServerPort { get; set; }
Public Property HttpServerPort As Integer
    Get
    Set

属性值

类型：Int32
默认值:2324
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.HttpsServerPort 属性

SettingHttpsServerPort 属性

获取或设置服务端HTTPS端口。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int HttpsServerPort { get; set; }
Public Property HttpsServerPort As Integer
    Get
    Set

属性值

类型：Int32
默认值:0
备注
此端口不建议使用，建议使用反射代理的方式
参见

引用

Setting 类
Swebui 命名空间


Setting.MirrorDisable 属性

SettingMirrorDisable 属性

[缺少 "P:Swebui.Setting.MirrorDisable" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool MirrorDisable { get; set; }
Public Property MirrorDisable As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Setting 类
Swebui 命名空间


Setting.NetworkTimeOut 属性

SettingNetworkTimeOut 属性

获取或设置网络超时时间(秒)

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int NetworkTimeOut { get; set; }
Public Property NetworkTimeOut As Integer
    Get
    Set

属性值

类型：Int32
默认30秒

返回值

类型：Int32
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.PerformTimeSpan 属性

SettingPerformTimeSpan 属性

性能监测时间间隔

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int PerformTimeSpan { get; set; }
Public Property PerformTimeSpan As Integer
    Get
    Set

属性值

类型：Int32
小于等于0不启动性能监测

返回值

类型：Int32
备注
性能监测时间用于记录在处理时间是否大于指定的时间，如果大于指定时间，那么会在日志中输出相关业务流程
参见

引用

Setting 类
Swebui 命名空间


Setting.PurgingTimeSpan 属性

SettingPurgingTimeSpan 属性

获取或设置辅助线程的轮询时间(秒)。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int PurgingTimeSpan { get; set; }
Public Property PurgingTimeSpan As Integer
    Get
    Set

属性值

类型：Int32
默认值60秒

返回值

类型：Int32
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.ReloadInterval 属性

SettingReloadInterval 属性

[缺少 "P:Swebui.Setting.ReloadInterval" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ReloadInterval { get; set; }
Public Property ReloadInterval As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Setting 类
Swebui 命名空间


Setting.ResourceDenyId 属性

SettingResourceDenyId 属性

获取和设置禁止资源访问的名称正则表达式

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourceDenyId { get; set; }
Public Property ResourceDenyId As String
    Get
    Set

属性值

类型：String
默认不允许*号，.dll .config .pdb

返回值

类型：String
参见

引用

Setting 类
Swebui 命名空间


Setting.ResourceDenyLocation 属性

SettingResourceDenyLocation 属性

获取和设置禁止资源访问的路径正则表达式

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourceDenyLocation { get; set; }
Public Property ResourceDenyLocation As String
    Get
    Set

属性值

类型：String
默认为空

返回值

类型：String
参见

引用

Setting 类
Swebui 命名空间


Setting.Resources 属性

SettingResources 属性

获取资源列表

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, string> Resources { get; }
Public ReadOnly Property Resources As Dictionary(Of String, String)
    Get

返回值

类型：Dictionary String, String
参见

引用

Setting 类
Swebui 命名空间


Setting.SecurityKey 属性

SettingSecurityKey 属性

获取和设置客户端连接时验证的安全密钥

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string SecurityKey { get; set; }
Public Property SecurityKey As String
    Get
    Set

返回值

类型：String
如果设置验证的安全密钥后，会验证当前客户端是从当前应用的打包版本。并禁止非当前应用的打包版本连接到当前服务器。
参见

引用

Setting 类
Swebui 命名空间


Setting.SessionTimeOut 属性

SettingSessionTimeOut 属性

获取或设置客户端会话超时时间(秒)

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int SessionTimeOut { get; set; }
Public Property SessionTimeOut As Integer
    Get
    Set

属性值

类型：Int32
默认1800秒

返回值

类型：Int32
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.StartupAssembly 属性

SettingStartupAssembly 属性

获取或设置入口程序集

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string StartupAssembly { get; set; }
Public Property StartupAssembly As String
    Get
    Set

属性值

类型：String
默认值空

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.StartupForm 属性

SettingStartupForm 属性

获取或设置启动界面

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string StartupForm { get; set; }
Public Property StartupForm As String
    Get
    Set

属性值

类型：String
默认值空

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.SysTrace 属性

SettingSysTrace 属性

获取或设置是否记录进程运行日志

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool SysTrace { get; set; }
Public Property SysTrace As Boolean
    Get
    Set

属性值

类型：Boolean
默认值False

返回值

类型：Boolean
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.TextFontScaling 属性

SettingTextFontScaling 属性

获取和设置一个值，该值指示是否根据系统缩放文本字体大小

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool TextFontScaling { get; set; }
Public Property TextFontScaling As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Setting 类
Swebui 命名空间


Setting.TracePrint 属性

SettingTracePrint 属性

获取或设置一个值，该值指示是否在VS调试时输出日志

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool TracePrint { get; set; }
Public Property TracePrint As Boolean
    Get
    Set

属性值

类型：Boolean
默认值True

返回值

类型：Boolean
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.WebPath 属性

SettingWebPath 属性

[缺少 "P:Swebui.Setting.WebPath" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WebPath { get; set; }
Public Property WebPath As String
    Get
    Set

属性值

类型：String
参见

引用

Setting 类
Swebui 命名空间


Setting.WebPlayer 属性

SettingWebPlayer 属性

获取和设置一个值，该值指示是否启用web播放器

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool WebPlayer { get; set; }
Public Property WebPlayer As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Setting 类
Swebui 命名空间


Setting.WebScreenWidth 属性

SettingWebScreenWidth 属性

获取或设置Web屏幕宽度

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int WebScreenWidth { get; set; }
Public Property WebScreenWidth As Integer
    Get
    Set

属性值

类型：Int32

返回值

类型：Int32
备注
仅在PC生效，如果浏览器的宽度大于设置的值，那么会使用当前设置的值并居中显示
参见

引用

Setting 类
Swebui 命名空间


Setting.WebTitle 属性

SettingWebTitle 属性

获取或设置抬头标题

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WebTitle { get; set; }
Public Property WebTitle As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

Setting 类
Swebui 命名空间


Setting 方法

Setting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | InitialData | 重新初始化配置信息。
公共方法 | InitialResources | 初始化资源
公共方法 | LoadData | 从指定的文件中载入配置信息。
公共方法 | SaveData | 保存配置信息。
Top
参见

引用

Setting 类
Swebui 命名空间


Setting.InitialData 方法

SettingInitialData 方法

重新初始化配置信息。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void InitialData()
Public Sub InitialData
备注
参见

引用

Setting 类
Swebui 命名空间


Setting.InitialResources 方法

SettingInitialResources 方法

初始化资源

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void InitialResources()
Public Sub InitialResources
参见

引用

Setting 类
Swebui 命名空间


Setting.LoadData 方法

SettingLoadData 方法

从指定的文件中载入配置信息。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void LoadData(
    string configfilepath
)
Public Sub LoadData (
    configfilepath As String
)

参数

configfilepath
类型：SystemString

[缺少 "M:Swebui.Setting.LoadData(System.String)" 的 <param name="configfilepath"/> 文档]

参见

引用

Setting 类
Swebui 命名空间


Setting.SaveData 方法

SettingSaveData 方法

保存配置信息。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveData()
Public Sub SaveData
参见

引用

Setting 类
Swebui 命名空间


SRDescriptionAttribute 类

[缺少 "T:Swebui.SRDescriptionAttribute" 的 <summary> 文档]

继承层次
SystemObject
SystemAttribute
System.ComponentModelDescriptionAttribute
SwebuiSRDescriptionAttribute

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SRDescriptionAttribute : DescriptionAttribute
Public Class SRDescriptionAttribute
    Inherits DescriptionAttribute

SRDescriptionAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SRDescriptionAttribute | 初始化 SRDescriptionAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Description | (重写 DescriptionAttributeDescription.)
Top
参见

引用

Swebui 命名空间


SRDescriptionAttribute 构造函数

初始化 SRDescriptionAttribute 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SRDescriptionAttribute(
    string description
)
Public Sub New (
    description As String
)

参数

description
类型：SystemString

[缺少 "M:Swebui.SRDescriptionAttribute.#ctor(System.String)" 的 <param name="description"/> 文档]

参见

引用

SRDescriptionAttribute 类
Swebui 命名空间


SRDescriptionAttribute 属性

SRDescriptionAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Description | (重写 DescriptionAttributeDescription.)
Top
参见

引用

SRDescriptionAttribute 类
Swebui 命名空间


SRDescriptionAttribute.Description 属性

SRDescriptionAttributeDescription 属性

[缺少 "P:Swebui.SRDescriptionAttribute.Description" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get

属性值

类型：String
参见

引用

SRDescriptionAttribute 类
Swebui 命名空间


StatusbarCallBackHandler 委托

一个委托，它表示客户端返回状态栏时要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void StatusbarCallBackHandler(
    Object sender,
    StatusbarHandlerArgs args
)
Public Delegate Sub StatusbarCallBackHandler (
    sender As Object,
    args As StatusbarHandlerArgs
)

参数

sender
类型：SystemObject
事件源
args
类型：SwebuiStatusbarHandlerArgs
包含事件数据的 StatusbarHandlerArgs
参见

引用

Swebui 命名空间


StatusbarHandlerArgs 类

为StatusbarCallBackHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
SwebuiStatusbarHandlerArgs

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class StatusbarHandlerArgs : ResultArgs
Public Class StatusbarHandlerArgs
    Inherits ResultArgs

StatusbarHandlerArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | StatusbarHandlerArgs | 初始化 StatusbarHandlerArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | Height | 获取状态栏高度
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui 命名空间


StatusbarHandlerArgs 构造函数

初始化 StatusbarHandlerArgs 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public StatusbarHandlerArgs()
Public Sub New
参见

引用

StatusbarHandlerArgs 类
Swebui 命名空间


StatusbarHandlerArgs 属性

StatusbarHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | Height | 获取状态栏高度
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
参见

引用

StatusbarHandlerArgs 类
Swebui 命名空间


StatusbarHandlerArgs.Height 属性

StatusbarHandlerArgsHeight 属性

获取状态栏高度

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Height { get; }
Public ReadOnly Property Height As Single
    Get

返回值

类型：Single
参见

引用

StatusbarHandlerArgs 类
Swebui 命名空间


StatusbarHandlerArgs 方法

StatusbarHandlerArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

StatusbarHandlerArgs 类
Swebui 命名空间


SwebClientInfo 类

客户端信息
继承层次
SystemObject
SwebuiSwebClientInfo

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebClientInfo
Public Class SwebClientInfo

SwebClientInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebClientInfo | 初始化 SwebClientInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ClientDevTrace | 获取和设置一个值，该值表示在设置DeveloperTrace = DeveloperTraceMode.Single时，当前Client是否启用开发日志记录
公共属性 | ClientFramework | 获取客户端平台
公共属性 | ClientSource | 获取客户端来源
公共属性 | ClientTrace | 获取和设置一个值，该值表示是否启用客户端日志记录
公共属性 | CoreVersion | 获取客户端内核版本号
公共属性 | Device | 获取客户端设备名称
公共属性 | DeviceID | 获取设备编号
公共属性 | DeviceOS | 获取客户端操作系统类型
公共属性 | DeviceOSVersion | 获取客户端操作系统版本号
公共属性 | EnableStackView | 获取和设置一个值，该值表示是否启用客户端界面栈。
公共属性 | ExtraInfo | 获取扩展信息
公共属性 | HostAddress | 获取服务端地址
公共属性 | HostHttpPort | 获取服务端Http端口
公共属性 | HostTcpPort | 获取服务端TCP端口
公共属性 | HostUrl | 获取服务端Url（仅限web连接）
公共属性 | IPEndPoint | 获取客户端网络端点
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
公共属性 | Language | 获取客户端语言
公共属性 | LastDate | 获取客户端最后一次操作时间
公共属性 | ScreenDensity | 获取设备屏幕密度
公共属性 | ScreenSize | 获取设备屏幕分辨率
公共属性 | Session | 获取客户端全局数据
公共属性 | SessionID | 获取客户端会话编号
公共属性 | StartDate | 获取客户端第一次连接时间
公共属性 | StartFormType |
公共属性 | UrlQuery |
公共属性 | UserSessionID | 获取和设置用户会话编号
公共属性 | Version | 获取客户端版本号
公共属性 | WebUrl | 获取服务端完整Url地址（仅限web连接）
公共属性 | WebUserAgent | 获取Web客户端的UserAgent
Top
方法
 | 名称 | 说明
公共方法 | CallRpc | 远程调用
公共方法 | ClearSession | 清除所有会话数据
公共方法 | Exit | 关闭客户端
公共方法 | ExitAndQuit | 关闭客户端并终止服务端会话
公共方法 | GetActiveForm | 获取当前显示的窗体
 | GetCurrentClient | 获取当前调用的客户端的信息
 | GetCurrentClient(String) | 获取指定客户端会话编号的客户端的信息
 | GetCurrentClientSession | 获取当前调用的客户端的全局数据
 | GetCurrentClientSession(String) | 获取指定客户端会话编号的客户端的全局数据
 | GetCurrentClientSessionID | 获取当前调用的客户端的会话编号
 | GetCurrentUserSessionID | 获取当前调用的客户端的用户会话编号
 | GetCurrentUserSessionID(String) | 获取指定客户端会话编号的客户端用户会话编号
公共方法 | RenderFlush | 在异步更新UI时，需要调用此方法刷新客户端界面。
公共方法 | ReStart | 销毁当前界面和数据，重新开始客户端会话
公共方法 | SetWebTitle | 设置Web标题
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | Camera | 提供系统接口拍照 (由 SwebClientCameraExtension 定义。)
公共扩展器方法 | FileDownload(String) | 已重载。 下载文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | FileDownload(String, String) | 已重载。 下载文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | FileUpload | 上传文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | GetClipBoard | 获取粘贴板内容 (由 SwebClientClipBoardExtension 定义。)
公共扩展器方法 | GetGps | GPS (由 SwebClientGPSExtension 定义。)
公共扩展器方法 | JSAppend | 附加脚本 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | JSAppendUrl | 附加脚本文件 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | JSEval | 执行Js代码 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | PlayAudio | 播放音频 (由 SwebClientAuidoExtension 定义。)
公共扩展器方法 | Print | 已重载。 打印当前窗体 (由 SwebClientPrintExtension 定义。)
公共扩展器方法 | Print(String, PrintType) | 已重载。 打印 (由 SwebClientPrintExtension 定义。)
公共扩展器方法 | RedirectUrl | (由 SwebClientRedirectUrlExtension 定义。)
公共扩展器方法 | SetClipBoard | 设置粘贴板内容 (由 SwebClientClipBoardExtension 定义。)
公共扩展器方法 | SetEJControlTheme | 设置EJ2控件Theme (由 SwebClientEJControlExtension 定义。)
公共扩展器方法 | StopAudio | 停止播放音频 (由 SwebClientAuidoExtension 定义。)
Top
备注
参见

引用

Swebui 命名空间


SwebClientInfo 构造函数

初始化 SwebClientInfo 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebClientInfo()
Public Sub New
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo 属性

SwebClientInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ClientDevTrace | 获取和设置一个值，该值表示在设置DeveloperTrace = DeveloperTraceMode.Single时，当前Client是否启用开发日志记录
公共属性 | ClientFramework | 获取客户端平台
公共属性 | ClientSource | 获取客户端来源
公共属性 | ClientTrace | 获取和设置一个值，该值表示是否启用客户端日志记录
公共属性 | CoreVersion | 获取客户端内核版本号
公共属性 | Device | 获取客户端设备名称
公共属性 | DeviceID | 获取设备编号
公共属性 | DeviceOS | 获取客户端操作系统类型
公共属性 | DeviceOSVersion | 获取客户端操作系统版本号
公共属性 | EnableStackView | 获取和设置一个值，该值表示是否启用客户端界面栈。
公共属性 | ExtraInfo | 获取扩展信息
公共属性 | HostAddress | 获取服务端地址
公共属性 | HostHttpPort | 获取服务端Http端口
公共属性 | HostTcpPort | 获取服务端TCP端口
公共属性 | HostUrl | 获取服务端Url（仅限web连接）
公共属性 | IPEndPoint | 获取客户端网络端点
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
公共属性 | Language | 获取客户端语言
公共属性 | LastDate | 获取客户端最后一次操作时间
公共属性 | ScreenDensity | 获取设备屏幕密度
公共属性 | ScreenSize | 获取设备屏幕分辨率
公共属性 | Session | 获取客户端全局数据
公共属性 | SessionID | 获取客户端会话编号
公共属性 | StartDate | 获取客户端第一次连接时间
公共属性 | StartFormType |
公共属性 | UrlQuery |
公共属性 | UserSessionID | 获取和设置用户会话编号
公共属性 | Version | 获取客户端版本号
公共属性 | WebUrl | 获取服务端完整Url地址（仅限web连接）
公共属性 | WebUserAgent | 获取Web客户端的UserAgent
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ClientDevTrace 属性

SwebClientInfoClientDevTrace 属性

获取和设置一个值，该值表示在设置DeveloperTrace = DeveloperTraceMode.Single时，当前Client是否启用开发日志记录

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ClientDevTrace { get; set; }
Public Property ClientDevTrace As Boolean
    Get
    Set

属性值

类型：Boolean
true代表记录客户端开发日志，否则为false

返回值

类型：Boolean
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ClientFramework 属性

SwebClientInfoClientFramework 属性

获取客户端平台

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientFramework ClientFramework { get; }
Public ReadOnly Property ClientFramework As ClientFramework
    Get

返回值

类型：ClientFramework
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ClientSource 属性

SwebClientInfoClientSource 属性

获取客户端来源

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientSource ClientSource { get; }
Public ReadOnly Property ClientSource As ClientSource
    Get

返回值

类型：ClientSource
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ClientTrace 属性

SwebClientInfoClientTrace 属性

获取和设置一个值，该值表示是否启用客户端日志记录

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ClientTrace { get; set; }
Public Property ClientTrace As Boolean
    Get
    Set

属性值

类型：Boolean
true代表记录客户端日志，否则为false

返回值

类型：Boolean
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.CoreVersion 属性

SwebClientInfoCoreVersion 属性

获取客户端内核版本号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Version CoreVersion { get; }
Public ReadOnly Property CoreVersion As Version
    Get

属性值

类型：Version

返回值

类型：Version
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Device 属性

SwebClientInfoDevice 属性

获取客户端设备名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Device { get; }
Public ReadOnly Property Device As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.DeviceID 属性

SwebClientInfoDeviceID 属性

获取设备编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DeviceID { get; }
Public ReadOnly Property DeviceID As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.DeviceOS 属性

SwebClientInfoDeviceOS 属性

获取客户端操作系统类型

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DeviceOS { get; }
Public ReadOnly Property DeviceOS As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.DeviceOSVersion 属性

SwebClientInfoDeviceOSVersion 属性

获取客户端操作系统版本号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DeviceOSVersion { get; }
Public ReadOnly Property DeviceOSVersion As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.EnableStackView 属性

SwebClientInfoEnableStackView 属性

获取和设置一个值，该值表示是否启用客户端界面栈。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool EnableStackView { get; set; }
Public Property EnableStackView As Boolean
    Get
    Set

属性值

类型：Boolean
默认为True

返回值

类型：Boolean
备注
启用界面栈可以在客户端执行界面返回操作时，有更快的速度和更好的体验，但是在某些性能比较差的设备上，可以关闭界面栈
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ExtraInfo 属性

SwebClientInfoExtraInfo 属性

获取扩展信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, Object> ExtraInfo { get; }
Public ReadOnly Property ExtraInfo As Dictionary(Of String, Object)
    Get

返回值

类型：Dictionary String, Object
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.HostAddress 属性

SwebClientInfoHostAddress 属性

获取服务端地址

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string HostAddress { get; }
Public ReadOnly Property HostAddress As String
    Get

返回值

类型：String
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.HostHttpPort 属性

SwebClientInfoHostHttpPort 属性

获取服务端Http端口

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int HostHttpPort { get; }
Public ReadOnly Property HostHttpPort As Integer
    Get

返回值

类型：Int32
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.HostTcpPort 属性

SwebClientInfoHostTcpPort 属性

获取服务端TCP端口

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int HostTcpPort { get; }
Public ReadOnly Property HostTcpPort As Integer
    Get

返回值

类型：Int32
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.HostUrl 属性

SwebClientInfoHostUrl 属性

获取服务端Url（仅限web连接）

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string HostUrl { get; }
Public ReadOnly Property HostUrl As String
    Get

返回值

类型：String
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.IPEndPoint 属性

SwebClientInfoIPEndPoint 属性

获取客户端网络端点

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public IPEndPoint IPEndPoint { get; }
Public ReadOnly Property IPEndPoint As IPEndPoint
    Get

属性值

类型：IPEndPoint

返回值

类型：IPEndPoint
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Item 属性

SwebClientInfoItem 属性

重载列表
 | 名称 | 说明
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Item 属性 (Int32)

SwebClientInfoItem 属性 (Int32)

获取和设置指定索引的值

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set

参数

index
类型：SystemInt32

返回值

类型：Object
参见

引用

SwebClientInfo 类
Item 重载
Swebui 命名空间


SwebClientInfo.Item 属性 (String)

SwebClientInfoItem 属性 (String)

获取和设置指定键名的值

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As Object
    Get
    Set

参数

name
类型：SystemString

返回值

类型：Object
参见

引用

SwebClientInfo 类
Item 重载
Swebui 命名空间


SwebClientInfo.Language 属性

SwebClientInfoLanguage 属性

获取客户端语言

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Language { get; }
Public ReadOnly Property Language As String
    Get

返回值

类型：String
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.LastDate 属性

SwebClientInfoLastDate 属性

获取客户端最后一次操作时间

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DateTime LastDate { get; }
Public ReadOnly Property LastDate As DateTime
    Get

属性值

类型：DateTime

返回值

类型：DateTime
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ScreenDensity 属性

SwebClientInfoScreenDensity 属性

获取设备屏幕密度

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float ScreenDensity { get; }
Public ReadOnly Property ScreenDensity As Single
    Get

返回值

类型：Single
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ScreenSize 属性

SwebClientInfoScreenSize 属性

获取设备屏幕分辨率

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Size ScreenSize { get; }
Public ReadOnly Property ScreenSize As Size
    Get

返回值

类型：Size
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Session 属性

SwebClientInfoSession 属性

获取客户端全局数据

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebSessionState Session { get; }
Public ReadOnly Property Session As SwebSessionState
    Get

属性值

类型：SwebSessionState

返回值

类型：SwebSessionState
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.SessionID 属性

SwebClientInfoSessionID 属性

获取客户端会话编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string SessionID { get; }
Public ReadOnly Property SessionID As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.StartDate 属性

SwebClientInfoStartDate 属性

获取客户端第一次连接时间

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DateTime StartDate { get; }
Public ReadOnly Property StartDate As DateTime
    Get

属性值

类型：DateTime

返回值

类型：DateTime
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.StartFormType 属性

SwebClientInfoStartFormType 属性

[缺少 "P:Swebui.SwebClientInfo.StartFormType" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Type StartFormType { get; set; }
Public Property StartFormType As Type
    Get
    Set

属性值

类型：Type
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.UrlQuery 属性

SwebClientInfoUrlQuery 属性

[缺少 "P:Swebui.SwebClientInfo.UrlQuery" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, Object> UrlQuery { get; }
Public ReadOnly Property UrlQuery As Dictionary(Of String, Object)
    Get

属性值

类型：Dictionary String, Object
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.UserSessionID 属性

SwebClientInfoUserSessionID 属性

获取和设置用户会话编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string UserSessionID { get; set; }
Public Property UserSessionID As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Version 属性

SwebClientInfoVersion 属性

获取客户端版本号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get

属性值

类型：Version

返回值

类型：Version
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.WebUrl 属性

SwebClientInfoWebUrl 属性

获取服务端完整Url地址（仅限web连接）

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WebUrl { get; }
Public ReadOnly Property WebUrl As String
    Get

返回值

类型：String
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.WebUserAgent 属性

SwebClientInfoWebUserAgent 属性

获取Web客户端的UserAgent

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string WebUserAgent { get; }
Public ReadOnly Property WebUserAgent As String
    Get

返回值

类型：String
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo 方法

SwebClientInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CallRpc | 远程调用
公共方法 | ClearSession | 清除所有会话数据
公共方法 | Exit | 关闭客户端
公共方法 | ExitAndQuit | 关闭客户端并终止服务端会话
公共方法 | GetActiveForm | 获取当前显示的窗体
 | GetCurrentClient | 获取当前调用的客户端的信息
 | GetCurrentClient(String) | 获取指定客户端会话编号的客户端的信息
 | GetCurrentClientSession | 获取当前调用的客户端的全局数据
 | GetCurrentClientSession(String) | 获取指定客户端会话编号的客户端的全局数据
 | GetCurrentClientSessionID | 获取当前调用的客户端的会话编号
 | GetCurrentUserSessionID | 获取当前调用的客户端的用户会话编号
 | GetCurrentUserSessionID(String) | 获取指定客户端会话编号的客户端用户会话编号
公共方法 | RenderFlush | 在异步更新UI时，需要调用此方法刷新客户端界面。
公共方法 | ReStart | 销毁当前界面和数据，重新开始客户端会话
公共方法 | SetWebTitle | 设置Web标题
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | Camera | 提供系统接口拍照 (由 SwebClientCameraExtension 定义。)
公共扩展器方法 | FileDownload(String) | 已重载。 下载文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | FileDownload(String, String) | 已重载。 下载文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | FileUpload | 上传文件 (由 SwebClientFileExtension 定义。)
公共扩展器方法 | GetClipBoard | 获取粘贴板内容 (由 SwebClientClipBoardExtension 定义。)
公共扩展器方法 | GetGps | GPS (由 SwebClientGPSExtension 定义。)
公共扩展器方法 | JSAppend | 附加脚本 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | JSAppendUrl | 附加脚本文件 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | JSEval | 执行Js代码 (由 SwebClientJsEvalExtension 定义。)
公共扩展器方法 | PlayAudio | 播放音频 (由 SwebClientAuidoExtension 定义。)
公共扩展器方法 | Print | 已重载。 打印当前窗体 (由 SwebClientPrintExtension 定义。)
公共扩展器方法 | Print(String, PrintType) | 已重载。 打印 (由 SwebClientPrintExtension 定义。)
公共扩展器方法 | RedirectUrl | (由 SwebClientRedirectUrlExtension 定义。)
公共扩展器方法 | SetClipBoard | 设置粘贴板内容 (由 SwebClientClipBoardExtension 定义。)
公共扩展器方法 | SetEJControlTheme | 设置EJ2控件Theme (由 SwebClientEJControlExtension 定义。)
公共扩展器方法 | StopAudio | 停止播放音频 (由 SwebClientAuidoExtension 定义。)
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.CallRpc 方法

SwebClientInfoCallRpc 方法

远程调用

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CallRpc(
    string module,
    string method,
    RPCParameter parameter,
    RPCResultHandler rpcHandler
)
Public Sub CallRpc (
    module As String,
    method As String,
    parameter As RPCParameter,
    rpcHandler As RPCResultHandler
)

参数

module
类型：SystemString

[缺少 "M:Swebui.SwebClientInfo.CallRpc(System.String,System.String,Swebui.RPC.RPCParameter,Swebui.RPC.RPCResultHandler)" 的 <param name="module"/> 文档]

method
类型：SystemString
方法
parameter
类型：RPCParameter
参数
rpcHandler
类型：RPCResultHandler
回调
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ClearSession 方法

SwebClientInfoClearSession 方法

清除所有会话数据

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ClearSession()
Public Sub ClearSession
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.Exit 方法

SwebClientInfoExit 方法

关闭客户端

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Exit(
    bool withDialog = true
)
Public Sub Exit (
    Optional withDialog As Boolean = true
)

参数

withDialog (Optional)
类型：SystemBoolean
一个值，该值表示是否显示一个“是否关闭客户端”的选择框
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ExitAndQuit 方法

SwebClientInfoExitAndQuit 方法

关闭客户端并终止服务端会话

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ExitAndQuit(
    string msg = ""
)
Public Sub ExitAndQuit (
    Optional msg As String = ""
)

参数

msg (Optional)
类型：SystemString
消息通知
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetActiveForm 方法

SwebClientInfoGetActiveForm 方法

获取当前显示的窗体

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebForm GetActiveForm()
Public Function GetActiveForm As SwebForm

返回值

类型：SwebForm

[缺少 "M:Swebui.SwebClientInfo.GetActiveForm" 的 <returns> 文档]

参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetCurrentClient 方法

SwebClientInfoGetCurrentClient 方法

重载列表
名称 | 说明
GetCurrentClient | 获取当前调用的客户端的信息
GetCurrentClient(String) | 获取指定客户端会话编号的客户端的信息
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetCurrentClient 方法

SwebClientInfoGetCurrentClient 方法

获取当前调用的客户端的信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebClientInfo GetCurrentClient()
Public Shared Function GetCurrentClient As SwebClientInfo

返回值

类型：SwebClientInfo

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClient" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentClient 重载
Swebui 命名空间


SwebClientInfo.GetCurrentClient 方法 (String)

SwebClientInfoGetCurrentClient 方法 (String)

获取指定客户端会话编号的客户端的信息

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebClientInfo GetCurrentClient(
    string sessionid
)
Public Shared Function GetCurrentClient (
    sessionid As String
) As SwebClientInfo

参数

sessionid
类型：SystemString

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClient(System.String)" 的 <param name="sessionid"/> 文档]

返回值

类型：SwebClientInfo

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClient(System.String)" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentClient 重载
Swebui 命名空间


SwebClientInfo.GetCurrentClientSession 方法

SwebClientInfoGetCurrentClientSession 方法

重载列表
名称 | 说明
GetCurrentClientSession | 获取当前调用的客户端的全局数据
GetCurrentClientSession(String) | 获取指定客户端会话编号的客户端的全局数据
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetCurrentClientSession 方法

SwebClientInfoGetCurrentClientSession 方法

获取当前调用的客户端的全局数据

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebSessionState GetCurrentClientSession()
Public Shared Function GetCurrentClientSession As SwebSessionState

返回值

类型：SwebSessionState

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClientSession" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentClientSession 重载
Swebui 命名空间


SwebClientInfo.GetCurrentClientSession 方法 (String)

SwebClientInfoGetCurrentClientSession 方法 (String)

获取指定客户端会话编号的客户端的全局数据

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebSessionState GetCurrentClientSession(
    string sessionid
)
Public Shared Function GetCurrentClientSession (
    sessionid As String
) As SwebSessionState

参数

sessionid
类型：SystemString

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClientSession(System.String)" 的 <param name="sessionid"/> 文档]

返回值

类型：SwebSessionState

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClientSession(System.String)" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentClientSession 重载
Swebui 命名空间


SwebClientInfo.GetCurrentClientSessionID 方法

SwebClientInfoGetCurrentClientSessionID 方法

获取当前调用的客户端的会话编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetCurrentClientSessionID()
Public Shared Function GetCurrentClientSessionID As String

返回值

类型：String

[缺少 "M:Swebui.SwebClientInfo.GetCurrentClientSessionID" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetCurrentUserSessionID 方法

SwebClientInfoGetCurrentUserSessionID 方法

重载列表
名称 | 说明
GetCurrentUserSessionID | 获取当前调用的客户端的用户会话编号
GetCurrentUserSessionID(String) | 获取指定客户端会话编号的客户端用户会话编号
Top
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.GetCurrentUserSessionID 方法

SwebClientInfoGetCurrentUserSessionID 方法

获取当前调用的客户端的用户会话编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetCurrentUserSessionID()
Public Shared Function GetCurrentUserSessionID As String

返回值

类型：String

[缺少 "M:Swebui.SwebClientInfo.GetCurrentUserSessionID" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentUserSessionID 重载
Swebui 命名空间


SwebClientInfo.GetCurrentUserSessionID 方法 (String)

SwebClientInfoGetCurrentUserSessionID 方法 (String)

获取指定客户端会话编号的客户端用户会话编号

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetCurrentUserSessionID(
    string sessionid
)
Public Shared Function GetCurrentUserSessionID (
    sessionid As String
) As String

参数

sessionid
类型：SystemString

[缺少 "M:Swebui.SwebClientInfo.GetCurrentUserSessionID(System.String)" 的 <param name="sessionid"/> 文档]

返回值

类型：String

[缺少 "M:Swebui.SwebClientInfo.GetCurrentUserSessionID(System.String)" 的 <returns> 文档]

备注
参见

引用

SwebClientInfo 类
GetCurrentUserSessionID 重载
Swebui 命名空间


SwebClientInfo.RenderFlush 方法

SwebClientInfoRenderFlush 方法

在异步更新UI时，需要调用此方法刷新客户端界面。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RenderFlush()
Public Sub RenderFlush
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.ReStart 方法

SwebClientInfoReStart 方法

销毁当前界面和数据，重新开始客户端会话

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ReStart()
Public Sub ReStart
备注
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebClientInfo.SetWebTitle 方法

SwebClientInfoSetWebTitle 方法

设置Web标题

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SetWebTitle(
    string title
)
Public Sub SetWebTitle (
    title As String
)

参数

title
类型：SystemString
标题
参见

引用

SwebClientInfo 类
Swebui 命名空间


SwebResourceManager 类

资源管理类
继承层次
SystemObject
SwebuiSwebResourceManager

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebResourceManager
Public Class SwebResourceManager

SwebResourceManager 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebResourceManager | 初始化 SwebResourceManager 类的一个新实例
Top
属性
名称 | 说明
DefaultAudioPath | 获取默认文档路径
DefaultDocumentPath | 获取默认文档路径
DefaultImagePath | 获取默认图像路径
DefaultMediaPath | 获取默认媒体路径
DefaultUploadPath | 获取默认上传路径
DefaultWebPath | 获取默认Web资源路径
ResourceRootPath | 获取和设置资源根路径
Top
方法
名称 | 说明
GetFullPath(String) | 根据资源设置中的资源名称获取资源完整路径
GetFullPath(String, String) | 根据根路径和资源路径，获取完整路径
GetResourceFullPath(String, String) | 根据资源名称和资源路径获取完整资源路径
GetResourceFullPath(String, String, String) | 根据资源名称和资源路径获取完整资源路径
GetResourceURL(String, String) | 获取资源URL
GetResourceURL(String, String, String) | 获取资源URL
GetResourceURL(String, String, String, ResourceMode) | 获取资源URL
InitialResources | 初始化默认资源
RegisterDefaultImageResource(String, Byte) |
RegisterDefaultImageResource(String, Bitmap) |
RegisterHttpResource | 注册HttpResource
UnRegisterHttpResource |
Top
字段
名称 | 说明
DefaultAudioResourceName | 默认音频资源名称
DefaultDocumentResourceName | 默认文档资源名称
DefaultImageResourceName | 默认图片资源名称
DefaultMediaResourceName | 默认上传资源名称
DefaultUploadResourceName | 默认上传资源名称
DefaultWebAssetsResourceName |
DefaultWebResourceName | 默认Web资源名称
Top
参见

引用

Swebui 命名空间


SwebResourceManager 构造函数

初始化 SwebResourceManager 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebResourceManager()
Public Sub New
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager 属性

SwebResourceManager 类型公开以下成员。

属性
名称 | 说明
DefaultAudioPath | 获取默认文档路径
DefaultDocumentPath | 获取默认文档路径
DefaultImagePath | 获取默认图像路径
DefaultMediaPath | 获取默认媒体路径
DefaultUploadPath | 获取默认上传路径
DefaultWebPath | 获取默认Web资源路径
ResourceRootPath | 获取和设置资源根路径
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultAudioPath 属性

SwebResourceManagerDefaultAudioPath 属性

获取默认文档路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultAudioPath { get; }
Public Shared ReadOnly Property DefaultAudioPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultDocumentPath 属性

SwebResourceManagerDefaultDocumentPath 属性

获取默认文档路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultDocumentPath { get; }
Public Shared ReadOnly Property DefaultDocumentPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultImagePath 属性

SwebResourceManagerDefaultImagePath 属性

获取默认图像路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultImagePath { get; }
Public Shared ReadOnly Property DefaultImagePath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultMediaPath 属性

SwebResourceManagerDefaultMediaPath 属性

获取默认媒体路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultMediaPath { get; }
Public Shared ReadOnly Property DefaultMediaPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultUploadPath 属性

SwebResourceManagerDefaultUploadPath 属性

获取默认上传路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultUploadPath { get; }
Public Shared ReadOnly Property DefaultUploadPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultWebPath 属性

SwebResourceManagerDefaultWebPath 属性

获取默认Web资源路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string DefaultWebPath { get; }
Public Shared ReadOnly Property DefaultWebPath As String
    Get

返回值

类型：String
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.ResourceRootPath 属性

SwebResourceManagerResourceRootPath 属性

获取和设置资源根路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string ResourceRootPath { get; set; }
Public Shared Property ResourceRootPath As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager 方法

SwebResourceManager 类型公开以下成员。

方法
名称 | 说明
GetFullPath(String) | 根据资源设置中的资源名称获取资源完整路径
GetFullPath(String, String) | 根据根路径和资源路径，获取完整路径
GetResourceFullPath(String, String) | 根据资源名称和资源路径获取完整资源路径
GetResourceFullPath(String, String, String) | 根据资源名称和资源路径获取完整资源路径
GetResourceURL(String, String) | 获取资源URL
GetResourceURL(String, String, String) | 获取资源URL
GetResourceURL(String, String, String, ResourceMode) | 获取资源URL
InitialResources | 初始化默认资源
RegisterDefaultImageResource(String, Byte) |
RegisterDefaultImageResource(String, Bitmap) |
RegisterHttpResource | 注册HttpResource
UnRegisterHttpResource |
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.GetFullPath 方法

SwebResourceManagerGetFullPath 方法

重载列表
名称 | 说明
GetFullPath(String) | 根据资源设置中的资源名称获取资源完整路径
GetFullPath(String, String) | 根据根路径和资源路径，获取完整路径
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.GetFullPath 方法 (String)

SwebResourceManagerGetFullPath 方法 (String)

根据资源设置中的资源名称获取资源完整路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetFullPath(
    string resourcepath
)
Public Shared Function GetFullPath (
    resourcepath As String
) As String

参数

resourcepath
类型：SystemString
资源路径

返回值

类型：String

[缺少 "M:Swebui.SwebResourceManager.GetFullPath(System.String)" 的 <returns> 文档]

备注
参见

引用

SwebResourceManager 类
GetFullPath 重载
Swebui 命名空间


SwebResourceManager.GetFullPath 方法 (String, String)

SwebResourceManagerGetFullPath 方法 (String, String)

根据根路径和资源路径，获取完整路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetFullPath(
    string rootPath,
    string resourcePath
)
Public Shared Function GetFullPath (
    rootPath As String,
    resourcePath As String
) As String

参数

rootPath
类型：SystemString
根路径
resourcePath
类型：SystemString
资源路径

返回值

类型：String
完整路径
备注
参见

引用

SwebResourceManager 类
GetFullPath 重载
Swebui 命名空间


SwebResourceManager.GetResourceFullPath 方法

SwebResourceManagerGetResourceFullPath 方法

重载列表
名称 | 说明
GetResourceFullPath(String, String) | 根据资源名称和资源路径获取完整资源路径
GetResourceFullPath(String, String, String) | 根据资源名称和资源路径获取完整资源路径
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.GetResourceFullPath 方法 (String, String)

SwebResourceManagerGetResourceFullPath 方法 (String, String)

根据资源名称和资源路径获取完整资源路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetResourceFullPath(
    string resourceid,
    string resourcepath
)
Public Shared Function GetResourceFullPath (
    resourceid As String,
    resourcepath As String
) As String

参数

resourceid
类型：SystemString
资源编号
resourcepath
类型：SystemString
资源路径

返回值

类型：String

[缺少 "M:Swebui.SwebResourceManager.GetResourceFullPath(System.String,System.String)" 的 <returns> 文档]

备注
参见

引用

SwebResourceManager 类
GetResourceFullPath 重载
Swebui 命名空间


SwebResourceManager.GetResourceFullPath 方法 (String, String, String)

SwebResourceManagerGetResourceFullPath 方法 (String, String, String)

根据资源名称和资源路径获取完整资源路径

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetResourceFullPath(
    string resourceid,
    string resourcepath,
    string rootpath
)
Public Shared Function GetResourceFullPath (
    resourceid As String,
    resourcepath As String,
    rootpath As String
) As String

参数

resourceid
类型：SystemString
资源编号
resourcepath
类型：SystemString
资源路径
rootpath
类型：SystemString
根路径

返回值

类型：String

[缺少 "M:Swebui.SwebResourceManager.GetResourceFullPath(System.String,System.String,System.String)" 的 <returns> 文档]

备注
参见

引用

SwebResourceManager 类
GetResourceFullPath 重载
Swebui 命名空间


SwebResourceManager.GetResourceURL 方法

SwebResourceManagerGetResourceURL 方法

重载列表
名称 | 说明
GetResourceURL(String, String) | 获取资源URL
GetResourceURL(String, String, String) | 获取资源URL
GetResourceURL(String, String, String, ResourceMode) | 获取资源URL
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.GetResourceURL 方法 (String, String)

SwebResourceManagerGetResourceURL 方法 (String, String)

获取资源URL

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetResourceURL(
    string sessionid,
    string url
)
Public Shared Function GetResourceURL (
    sessionid As String,
    url As String
) As String

参数

sessionid
类型：SystemString
会话编号
url
类型：SystemString
资源路径

返回值

类型：String

[缺少 "M:Swebui.SwebResourceManager.GetResourceURL(System.String,System.String)" 的 <returns> 文档]

参见

引用

SwebResourceManager 类
GetResourceURL 重载
Swebui 命名空间


SwebResourceManager.GetResourceURL 方法 (String, String, String)

SwebResourceManagerGetResourceURL 方法 (String, String, String)

获取资源URL

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetResourceURL(
    string sessionid,
    string resourceid,
    string resourcepath
)
Public Shared Function GetResourceURL (
    sessionid As String,
    resourceid As String,
    resourcepath As String
) As String

参数

sessionid
类型：SystemString
会话编号
resourceid
类型：SystemString
资源编号
resourcepath
类型：SystemString
资源路径

返回值

类型：String
资源URL
备注
参见

引用

SwebResourceManager 类
GetResourceURL 重载
Swebui 命名空间


SwebResourceManager.GetResourceURL 方法 (String, String, String, ResourceMode)

SwebResourceManagerGetResourceURL 方法 (String, String, String, ResourceMode)

获取资源URL

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetResourceURL(
    string sessionid,
    string resourceid,
    string resourcepath,
    ResourceMode resourcemode
)
Public Shared Function GetResourceURL (
    sessionid As String,
    resourceid As String,
    resourcepath As String,
    resourcemode As ResourceMode
) As String

参数

sessionid
类型：SystemString
会话编号
resourceid
类型：SystemString
资源编号
resourcepath
类型：SystemString
资源路径
resourcemode
类型：Swebui.ControlsResourceMode
资源类型

返回值

类型：String
资源URL
备注
参见

引用

SwebResourceManager 类
GetResourceURL 重载
Swebui 命名空间


SwebResourceManager.InitialResources 方法

SwebResourceManagerInitialResources 方法

初始化默认资源

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void InitialResources(
    string defaultImagePath
)
Public Shared Sub InitialResources (
    defaultImagePath As String
)

参数

defaultImagePath
类型：SystemString

[缺少 "M:Swebui.SwebResourceManager.InitialResources(System.String)" 的 <param name="defaultImagePath"/> 文档]

备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.RegisterDefaultImageResource 方法

SwebResourceManagerRegisterDefaultImageResource 方法

重载列表
名称 | 说明
RegisterDefaultImageResource(String, Byte) |
RegisterDefaultImageResource(String, Bitmap) |
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.RegisterDefaultImageResource 方法 (String, Byte[])

SwebResourceManagerRegisterDefaultImageResource 方法 (String, Byte)

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Byte[])" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void RegisterDefaultImageResource(
    string resourceName,
    byte[] resourceData
)
Public Shared Sub RegisterDefaultImageResource (
    resourceName As String,
    resourceData As Byte()
)

参数

resourceName
类型：SystemString

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Byte[])" 的 <param name="resourceName"/> 文档]

resourceData
类型：SystemByte

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Byte[])" 的 <param name="resourceData"/> 文档]

参见

引用

SwebResourceManager 类
RegisterDefaultImageResource 重载
Swebui 命名空间


SwebResourceManager.RegisterDefaultImageResource 方法 (String, Bitmap)

SwebResourceManagerRegisterDefaultImageResource 方法 (String, Bitmap)

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Drawing.Bitmap)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void RegisterDefaultImageResource(
    string resourceName,
    Bitmap resourceData
)
Public Shared Sub RegisterDefaultImageResource (
    resourceName As String,
    resourceData As Bitmap
)

参数

resourceName
类型：SystemString

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Drawing.Bitmap)" 的 <param name="resourceName"/> 文档]

resourceData
类型：System.DrawingBitmap

[缺少 "M:Swebui.SwebResourceManager.RegisterDefaultImageResource(System.String,System.Drawing.Bitmap)" 的 <param name="resourceData"/> 文档]

参见

引用

SwebResourceManager 类
RegisterDefaultImageResource 重载
Swebui 命名空间


SwebResourceManager.RegisterHttpResource 方法

SwebResourceManagerRegisterHttpResource 方法

注册HttpResource

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string RegisterHttpResource(
    string sessionId,
    HttpResourceEntity resourceEntity
)
Public Shared Function RegisterHttpResource (
    sessionId As String,
    resourceEntity As HttpResourceEntity
) As String

参数

sessionId
类型：SystemString
会话编号
resourceEntity
类型：HttpResourceEntity
HttpResourceEntity

返回值

类型：String
返回注册资源的URL地址
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.UnRegisterHttpResource 方法

SwebResourceManagerUnRegisterHttpResource 方法

[缺少 "M:Swebui.SwebResourceManager.UnRegisterHttpResource(System.String,System.String)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static HttpResourceEntity UnRegisterHttpResource(
    string sessionId,
    string resourceKey
)
Public Shared Function UnRegisterHttpResource (
    sessionId As String,
    resourceKey As String
) As HttpResourceEntity

参数

sessionId
类型：SystemString

[缺少 "M:Swebui.SwebResourceManager.UnRegisterHttpResource(System.String,System.String)" 的 <param name="sessionId"/> 文档]

resourceKey
类型：SystemString

[缺少 "M:Swebui.SwebResourceManager.UnRegisterHttpResource(System.String,System.String)" 的 <param name="resourceKey"/> 文档]

返回值

类型：HttpResourceEntity

[缺少 "M:Swebui.SwebResourceManager.UnRegisterHttpResource(System.String,System.String)" 的 <returns> 文档]

参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager 字段

SwebResourceManager 类型公开以下成员。

字段
名称 | 说明
DefaultAudioResourceName | 默认音频资源名称
DefaultDocumentResourceName | 默认文档资源名称
DefaultImageResourceName | 默认图片资源名称
DefaultMediaResourceName | 默认上传资源名称
DefaultUploadResourceName | 默认上传资源名称
DefaultWebAssetsResourceName |
DefaultWebResourceName | 默认Web资源名称
Top
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultAudioResourceName 字段

SwebResourceManagerDefaultAudioResourceName 字段

默认音频资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultAudioResourceName = "audio"
Public Const DefaultAudioResourceName As String = "audio"

字段值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultDocumentResourceName 字段

SwebResourceManagerDefaultDocumentResourceName 字段

默认文档资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultDocumentResourceName = "document"
Public Const DefaultDocumentResourceName As String = "document"

字段值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultImageResourceName 字段

SwebResourceManagerDefaultImageResourceName 字段

默认图片资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultImageResourceName = "image"
Public Const DefaultImageResourceName As String = "image"

字段值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultMediaResourceName 字段

SwebResourceManagerDefaultMediaResourceName 字段

默认上传资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultMediaResourceName = "media"
Public Const DefaultMediaResourceName As String = "media"

字段值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultUploadResourceName 字段

SwebResourceManagerDefaultUploadResourceName 字段

默认上传资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultUploadResourceName = "upload"
Public Const DefaultUploadResourceName As String = "upload"

字段值

类型：String
备注
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultWebAssetsResourceName 字段

SwebResourceManagerDefaultWebAssetsResourceName 字段

[缺少 "F:Swebui.SwebResourceManager.DefaultWebAssetsResourceName" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultWebAssetsResourceName = "webassets"
Public Const DefaultWebAssetsResourceName As String = "webassets"

字段值

类型：String
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebResourceManager.DefaultWebResourceName 字段

SwebResourceManagerDefaultWebResourceName 字段

默认Web资源名称

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string DefaultWebResourceName = "web"
Public Const DefaultWebResourceName As String = "web"

字段值

类型：String
参见

引用

SwebResourceManager 类
Swebui 命名空间


SwebServer 类

Swebui服务
继承层次
SystemObject
SwebuiSwebServer

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public sealed class SwebServer
Public NotInheritable Class SwebServer

SwebServer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebServer | 初始化 SwebServer 类的一个新实例
Top
属性
 | 名称 | 说明
 | ServerID | 获取服务标识
公共属性 | Setting |
公共属性 | StartUpForm | 获取或设置启动Form类型。
Top
方法
 | 名称 | 说明
 | IsRegisterHttpHandler |
 | RegisterExtendHandler | 注册扩展
 | RegisterHttpHandler |
公共方法 | StartServer | 开始服务
公共方法 | StopServer | 停止服务
 | UnRegisterHttpHandler |
Top
事件
 | 名称 | 说明
公共事件 | SessionConnect | 在会话连接时发生。
公共事件 | SessionStart | 在添加会话时发生。
公共事件 | SessionStop | 在删除会话时发生。
Top
备注
参见

引用

Swebui 命名空间


SwebServer 构造函数

初始化 SwebServer 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebServer()
Public Sub New
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer 属性

SwebServer 类型公开以下成员。

属性
 | 名称 | 说明
 | ServerID | 获取服务标识
公共属性 | Setting |
公共属性 | StartUpForm | 获取或设置启动Form类型。
Top
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.ServerID 属性

SwebServerServerID 属性

获取服务标识

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string ServerID { get; }
Public Shared ReadOnly Property ServerID As String
    Get

属性值

类型：String

返回值

类型：String
备注
此标识是和服务器硬件相关，所以请勿在关键系统业务中使用此属性所提供的值
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.Setting 属性

SwebServerSetting 属性

[缺少 "P:Swebui.SwebServer.Setting" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Setting Setting { get; }
Public ReadOnly Property Setting As Setting
    Get

属性值

类型：Setting
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.StartUpForm 属性

SwebServerStartUpForm 属性

获取或设置启动Form类型。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Type StartUpForm { get; set; }
Public Property StartUpForm As Type
    Get
    Set

属性值

类型：Type
备注
Server.StartUpForm = GetType(SwebuiForm1)
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer 方法

SwebServer 类型公开以下成员。

方法
 | 名称 | 说明
 | IsRegisterHttpHandler |
 | RegisterExtendHandler | 注册扩展
 | RegisterHttpHandler |
公共方法 | StartServer | 开始服务
公共方法 | StopServer | 停止服务
 | UnRegisterHttpHandler |
Top
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.IsRegisterHttpHandler 方法

SwebServerIsRegisterHttpHandler 方法

[缺少 "M:Swebui.SwebServer.IsRegisterHttpHandler(System.String)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool IsRegisterHttpHandler(
    string command
)
Public Shared Function IsRegisterHttpHandler (
    command As String
) As Boolean

参数

command
类型：SystemString

[缺少 "M:Swebui.SwebServer.IsRegisterHttpHandler(System.String)" 的 <param name="command"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.SwebServer.IsRegisterHttpHandler(System.String)" 的 <returns> 文档]

参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.RegisterExtendHandler 方法

SwebServerRegisterExtendHandler 方法

注册扩展

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void RegisterExtendHandler(
    ExtendHandlerType extendType,
    Type handlerType
)
Public Shared Sub RegisterExtendHandler (
    extendType As ExtendHandlerType,
    handlerType As Type
)

参数

extendType
类型：ExtendHandlerType
扩展类型，每一种扩展类型仅允许注册一次
handlerType
类型：SystemType
扩展类，必须实现接口ISwebuiExtendHandler
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.RegisterHttpHandler 方法

SwebServerRegisterHttpHandler 方法

[缺少 "M:Swebui.SwebServer.RegisterHttpHandler(System.String,Swebui.Web.IHttpHandler)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void RegisterHttpHandler(
    string command,
    IHttpHandler handler
)
Public Shared Sub RegisterHttpHandler (
    command As String,
    handler As IHttpHandler
)

参数

command
类型：SystemString

[缺少 "M:Swebui.SwebServer.RegisterHttpHandler(System.String,Swebui.Web.IHttpHandler)" 的 <param name="command"/> 文档]

handler
类型：IHttpHandler

[缺少 "M:Swebui.SwebServer.RegisterHttpHandler(System.String,Swebui.Web.IHttpHandler)" 的 <param name="handler"/> 文档]

参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.StartServer 方法

SwebServerStartServer 方法

开始服务

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void StartServer()
Public Sub StartServer
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.StopServer 方法

SwebServerStopServer 方法

停止服务

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void StopServer()
Public Sub StopServer
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.UnRegisterHttpHandler 方法

SwebServerUnRegisterHttpHandler 方法

[缺少 "M:Swebui.SwebServer.UnRegisterHttpHandler(System.String)" 的 <summary> 文档]

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void UnRegisterHttpHandler(
    string command
)
Public Shared Sub UnRegisterHttpHandler (
    command As String
)

参数

command
类型：SystemString

[缺少 "M:Swebui.SwebServer.UnRegisterHttpHandler(System.String)" 的 <param name="command"/> 文档]

参见

引用

SwebServer 类
Swebui 命名空间


SwebServer 事件

SwebServer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | SessionConnect | 在会话连接时发生。
公共事件 | SessionStart | 在添加会话时发生。
公共事件 | SessionStop | 在删除会话时发生。
Top
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.SessionConnect 事件

SwebServerSessionConnect 事件

在会话连接时发生。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebSessionEventHandler SessionConnect
Public Event SessionConnect As SwebSessionEventHandler

值

类型：SwebuiSwebSessionEventHandler
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.SessionStart 事件

SwebServerSessionStart 事件

在添加会话时发生。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebSessionEventHandler SessionStart
Public Event SessionStart As SwebSessionEventHandler

值

类型：SwebuiSwebSessionEventHandler
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebServer.SessionStop 事件

SwebServerSessionStop 事件

在删除会话时发生。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebSessionEventHandler SessionStop
Public Event SessionStop As SwebSessionEventHandler

值

类型：SwebuiSwebSessionEventHandler
备注
参见

引用

SwebServer 类
Swebui 命名空间


SwebSessionEventArgs 类

为SwebuiSession事件提供数据。
继承层次
SystemObject
SwebuiSwebSessionEventArgs

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebSessionEventArgs
Public Class SwebSessionEventArgs

SwebSessionEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebSessionEventArgs | 初始化 SwebSessionEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Client | 获取事件的Client
Top
备注
参见

引用

Swebui 命名空间


SwebSessionEventArgs 构造函数

初始化 SwebSessionEventArgs 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebSessionEventArgs()
Public Sub New
参见

引用

SwebSessionEventArgs 类
Swebui 命名空间


SwebSessionEventArgs 属性

SwebSessionEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Client | 获取事件的Client
Top
参见

引用

SwebSessionEventArgs 类
Swebui 命名空间


SwebSessionEventArgs.Client 属性

SwebSessionEventArgsClient 属性

获取事件的Client

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebClientInfo Client { get; }
Public ReadOnly Property Client As SwebClientInfo
    Get

属性值

类型：SwebClientInfo

返回值

类型：SwebClientInfo
备注
参见

引用

SwebSessionEventArgs 类
Swebui 命名空间


SwebSessionEventHandler 委托

一个委托，它表示在Session处理时要调用的方法。

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void SwebSessionEventHandler(
    Object sender,
    SwebSessionEventArgs e
)
Public Delegate Sub SwebSessionEventHandler (
    sender As Object,
    e As SwebSessionEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：SwebuiSwebSessionEventArgs
包含事件数据的 SwebuiSessionEventArgs
备注
参见

引用

Swebui 命名空间


SwebSessionState 类

客户端键值集合
继承层次
SystemObject
System.Collections.SpecializedNameObjectCollectionBase
SwebuiSwebSessionState

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebSessionState : NameObjectCollectionBase
Public Class SwebSessionState
    Inherits NameObjectCollectionBase

SwebSessionState 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebSessionState | 初始化 SwebSessionState 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加指定的键和值到实例中
公共方法 | Clear | 移除所有项
公共方法 | ContainsKey | 是否包含指定名称的项
公共方法 | Remove | 移除指定键名的项
公共方法 | RemoveAt | 移除指定索引的项
Top
参见

引用

Swebui 命名空间


SwebSessionState 构造函数

初始化 SwebSessionState 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebSessionState()
Public Sub New
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState 属性

属性
 | 名称 | 说明
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
Top
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.Item 属性

SwebSessionStateItem 属性

重载列表
 | 名称 | 说明
公共属性 | ItemInt32 | 获取和设置指定索引的值
公共属性 | ItemString | 获取和设置指定键名的值
Top
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.Item 属性 (Int32)

SwebSessionStateItem 属性 (Int32)

获取和设置指定索引的值

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set

参数

index
类型：SystemInt32

返回值

类型：Object
参见

引用

SwebSessionState 类
Item 重载
Swebui 命名空间


SwebSessionState.Item 属性 (String)

SwebSessionStateItem 属性 (String)

获取和设置指定键名的值

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As Object
    Get
    Set

参数

name
类型：SystemString

返回值

类型：Object
参见

引用

SwebSessionState 类
Item 重载
Swebui 命名空间


SwebSessionState 方法

SwebSessionState 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加指定的键和值到实例中
公共方法 | Clear | 移除所有项
公共方法 | ContainsKey | 是否包含指定名称的项
公共方法 | Remove | 移除指定键名的项
公共方法 | RemoveAt | 移除指定索引的项
Top
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.Add 方法

SwebSessionStateAdd 方法

添加指定的键和值到实例中

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Add(
    string name,
    Object value
)
Public Sub Add (
    name As String,
    value As Object
)

参数

name
类型：SystemString
键名
value
类型：SystemObject
键值
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.Clear 方法

SwebSessionStateClear 方法

移除所有项

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Clear()
Public Sub Clear
参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.ContainsKey 方法

SwebSessionStateContainsKey 方法

是否包含指定名称的项

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ContainsKey(
    string name
)
Public Function ContainsKey (
    name As String
) As Boolean

参数

name
类型：SystemString

[缺少 "M:Swebui.SwebSessionState.ContainsKey(System.String)" 的 <param name="name"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.SwebSessionState.ContainsKey(System.String)" 的 <returns> 文档]

参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.Remove 方法

SwebSessionStateRemove 方法

移除指定键名的项

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Remove(
    string name
)
Public Sub Remove (
    name As String
)

参数

name
类型：SystemString

[缺少 "M:Swebui.SwebSessionState.Remove(System.String)" 的 <param name="name"/> 文档]

参见

引用

SwebSessionState 类
Swebui 命名空间


SwebSessionState.RemoveAt 方法

SwebSessionStateRemoveAt 方法

移除指定索引的项

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32

[缺少 "M:Swebui.SwebSessionState.RemoveAt(System.Int32)" 的 <param name="index"/> 文档]

参见

引用

SwebSessionState 类
Swebui 命名空间


SwebUtility 类

通用类
继承层次
SystemObject
SwebuiSwebUtility

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebUtility
Public Class SwebUtility

SwebUtility 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebUtility | 初始化 SwebUtility 类的一个新实例
Top
方法
名称 | 说明
GetJsonInstance(String) | 获取Json实例
GetJsonInstanceT(String) | 获取Json实例
GetJsonString | 获取Json字符串
GetJsonStringNull | 获取Json字符串（非空值）
Top
参见

引用

Swebui 命名空间


SwebUtility 构造函数

初始化 SwebUtility 类的一个新实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUtility()
Public Sub New
参见

引用

SwebUtility 类
Swebui 命名空间


SwebUtility 方法

SwebUtility 类型公开以下成员。

方法
名称 | 说明
GetJsonInstance(String) | 获取Json实例
GetJsonInstanceT(String) | 获取Json实例
GetJsonString | 获取Json字符串
GetJsonStringNull | 获取Json字符串（非空值）
Top
参见

引用

SwebUtility 类
Swebui 命名空间


SwebUtility.GetJsonInstance 方法

SwebUtilityGetJsonInstance 方法

重载列表
名称 | 说明
GetJsonInstance(String) | 获取Json实例
GetJsonInstanceT(String) | 获取Json实例
Top
参见

引用

SwebUtility 类
Swebui 命名空间


SwebUtility.GetJsonInstance 方法 (String)

SwebUtilityGetJsonInstance 方法 (String)

获取Json实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Object GetJsonInstance(
    string jsonstr
)
Public Shared Function GetJsonInstance (
    jsonstr As String
) As Object

参数

jsonstr
类型：SystemString
Json字符串

返回值

类型：Object

[缺少 "M:Swebui.SwebUtility.GetJsonInstance(System.String)" 的 <returns> 文档]

参见

引用

SwebUtility 类
GetJsonInstance 重载
Swebui 命名空间


SwebUtility.GetJsonInstance(T) 方法 (String)

SwebUtilityGetJsonInstanceT 方法 (String)

获取Json实例

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static T GetJsonInstance<T>(
    string jsonstr
)

Public Shared Function GetJsonInstance(Of T) (
    jsonstr As String
) As T

参数

jsonstr
类型：SystemString
Json字符串

类型参数

T
实例类型

返回值

类型：T

[缺少 "M:Swebui.SwebUtility.GetJsonInstance``1(System.String)" 的 <returns> 文档]

参见

引用

SwebUtility 类
GetJsonInstance 重载
Swebui 命名空间


SwebUtility.GetJsonString 方法

SwebUtilityGetJsonString 方法

获取Json字符串

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetJsonString(
    Object jsonobj
)
Public Shared Function GetJsonString (
    jsonobj As Object
) As String

参数

jsonobj
类型：SystemObject
Json对象

返回值

类型：String

[缺少 "M:Swebui.SwebUtility.GetJsonString(System.Object)" 的 <returns> 文档]

参见

引用

SwebUtility 类
Swebui 命名空间


SwebUtility.GetJsonStringNull 方法

SwebUtilityGetJsonStringNull 方法

获取Json字符串（非空值）

命名空间： Swebui
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetJsonStringNull(
    Object jsonobj
)
Public Shared Function GetJsonStringNull (
    jsonobj As Object
) As String

参数

jsonobj
类型：SystemObject
Json对象

返回值

类型：String

[缺少 "M:Swebui.SwebUtility.GetJsonStringNull(System.Object)" 的 <returns> 文档]

参见

引用

SwebUtility 类
Swebui 命名空间


Swebui.Controls 命名空间

Swebui Controls
类
 | 类 | 说明
公共类 | ActionButtonBase |
公共类 | ActionButtonItem |
公共类 | ActionButtonItemCollection |
公共类 | ActionButtonPressEventArgs |
公共类 | ActionMainButton |
公共类 | Animation | 动画组件
公共类 | AnimationItem | 动画元素
公共类 | AnimationItemCollection |
公共类 | AttachButton |
公共类 | AutoComplete | 带提示框的输入框
公共类 | AutoScrollParameter |
公共类 | BarcodeView | 条码控件
公共类 | BinaryResultArgs | 二进制数据
公共类 | BorderConverter | Border 类型转换
公共类 | Button | 按钮控件
公共类 | Calendar | 日历控件
公共类 | CheckBox | 复选框控件
公共类 | ChooseDatePicker | 日期选择控件
公共类 | ChooseDatePlaceholder |
公共类 | ChooseDateValue |
公共类 | ClientDataResultHandlerArgs | 为 ClientDataCallBackHandler 提供数据
公共类 | ClientResourceGetResultArgs | 为GetClientResourceHandler提供数据
公共类 | ClientResourceLoadResultArgs | 为 LoadClientResourceHandler 提供数据
公共类 | ClientResourceRemoveResultArgs | 为RemoveClientResourceHandler提供数据
公共类 | ClientResourceResultArgs | 为ClientResourceCallBack提供数据
公共类 | ClipboardResultArgs | 为ClipboardResultHandler提供数据
公共类 | ColorPropertyExtend | 颜色属性扩展
公共类 | ComboBox | 下拉列表控件
公共类 | ComboBoxItem |
公共类 | ComboBoxItemCollection |
公共类 | CustomCallBackEventArgs |
公共类 | DataSourceManager | Class DataSourceManager. This class cannot be inherited.
公共类 | DataSourceUpdateEventArgs | 为 DataSourceUpdateEventHandler 绑定提供数据
公共类 | DatePicker | 日期选择控件
公共类 | DatePickrSelectedEventArgs |
公共类 | DatePropertyExtend |
公共类 | DialogOptions | Dialog配置项
公共类 | ECharts | ECharts
公共类 | EChartsPressEventArgs | 为EChartsPress提供数据
公共类 | Editer | 富文本控件
公共类 | EditerChangedEventArgs | 为绑定提供数据
公共类 | EditerToolBarOptions |
公共类 | EnablePropertyExtend |
公共类 | FontBoldPropertyExtend |
公共类 | FontIcon | 字体图标
公共类 | FontItalicPropertyExtend |
公共类 | FontScalingPropertyExtend | 设置中的TextFontScaling属性扩展
公共类 | FontSizePropertyExtend | FontSize属性扩展
公共类 | GPSResultArgs | GPS信息
公共类 | GridSearchData |
公共类 | GridView | 数据列表
公共类 | GridViewCellSaveEventArgs | 为 GridViewCellSaveEventHandler 绑定提供数据
公共类 | GridViewColumn | GridViewColumn设置
公共类 | GridViewColumnCollection | GridViewCellSetting集合
公共类 | GridViewEditSetting | GridView编辑设置
公共类 | GridViewPageSetting | GridView编辑设置
公共类 | GridViewRowClickEventArgs | 为 GridViewRowClickEventHandler 绑定提供数据
公共类 | GridViewSaveChangeEventArgs | 为 GridViewSaveChangeEventHandler 绑定提供数据
公共类 | GridViewSelectedRowsEventArgs | 为 GridViewSelectedRowsEventHandler 绑定提供数据
公共类 | GridViewSelectionSetting | GridView选择设置
公共类 | HTMLView | 超文本控件
公共类 | Image | 图像控件
公共类 | ImageSizeModePropertyExtend |
公共类 | KeyDownEventArgs | 包含客户端点击实体按键的事件数据
公共类 | Label | 文本标签控件
公共类 | Line | 线条控件
公共类 | ListButton |
公共类 | ListView | 列表控件。
公共类 | ListViewRow | 列表控件行。
公共类 | ListViewRowCollection | 列表控件行集合
公共类 | ListViewSection | 列表区域
公共类 | ListViewSectionCollection | 列表区域集合
公共类 | ListViewTemplateBindEventArgs | 为 ListViewTemplateBindEventHandler 绑定提供数据
公共类 | LowercaseFirstPropertyExtend |
公共类 | LowercasePropertyExtend |
公共类 | MapTagView | 地理位置标签
公共类 | MapTrimView | 地点微调控件
公共类 | MapTrimViewLocationChangedEventArgs | 为MapTrimViewlocationChanged提供数据
公共类 | MapView | 地图控件
公共类 | MapViewPoint | 地图坐标
公共类 | MapViewPointCollection | 地图坐标集合
公共类 | MapViewRoute | 地图路径
公共类 | MapViewRouteCollection | 地图路径集合
公共类 | MapViewTag | 地图标签
公共类 | MapViewTagClickEventArgs | 为MapViewTagClick提供数据
公共类 | MapViewTagCollection | 地图坐标集合
公共类 | MarginConverter | 为 Margin 提供类型转换
公共类 | MarqueeLabel | 跑马灯效果文本
公共类 | MediaView | 多媒体控件
公共类 | MediaViewStateChangedEventArgs | 为StateChanged提供数据
公共类 | MenuItem |
公共类 | MenuItemCollection |
公共类 | MenuView | 菜单控件
公共类 | MenuViewItemClickEventArgs |
公共类 | MessageBoxHandlerArgs | 为MessageBoxHandler提供数据
公共类 | MessageBoxStatic | 显示可包含文本、按钮（通知并指示用户）的消息框。
公共类 | OnPaintDesignArgs | 为OnPaintDesign提供方法
公共类 | PaddingConverter | 为 Padding 提供类型转换
公共类 | PageView | 页面控件
公共类 | PageViewItem | 页面控件元素。
公共类 | PageViewItemCollection | 页面控件元素集合。
公共类 | PageViewTemplateBindEventArgs | 为 PageViewTemplateBind 绑定提供数据
公共类 | Panel | Panel 类
公共类 | PDFView | PDF控件
公共类 | PercentageCircle | 百分比圆形控件
公共类 | PopPanel |
公共类 | PopPanelItem |
公共类 | PopPanelItemCollection |
公共类 | PopPanelItemSelectEventArgs |
公共类 | Progress | 进度条控件
公共类 | PropertyChangedEventArgs | Provide event data for PropertyChangedEvent
公共类 | RelativeSizeFloatPropertyExtend | 等宽布局float类型扩展属性.
公共类 | RelativeSizeIntPropertyExtend | 等宽布局int类型扩展属性，四舍五入取值
公共类 | ResourcePropertyExtend | 资源属性扩展
公共类 | ResourceResultArgs | API资源数据
公共类 | ResourcesResultArgs | 资源数据
公共类 | ScrollPositionChangedEventArgs | 为 ScrollPositionChangedEventHandler 绑定提供数据
公共类 | SectionListView | 区域列表
公共类 | SectionListViewListViewSectionCollectionOwner |
公共类 | SectionListViewRow | 区域列表行
公共类 | SectionListViewRowCollection | 列表区域集合
公共类 | SegmentedControl | 单元控件
公共类 | ShadowPropertyChangedArgs | ShadowPropertyChangedArgs
公共类 | SignatureView | 签字控件
公共类 | Slide | 滚动条控件
公共类 | StringArrayPropertyExtend | 字符串数组属性扩展
公共类 | Svg | SVG
公共类 | SwebActionButton |
公共类 | SwebBindableControl | 数据绑定控件
公共类 | SwebCheckedControlBase |
公共类 | SwebClientAuidoExtension | 构造函数
公共类 | SwebClientCameraExtension | 构造函数
公共类 | SwebClientClipBoardExtension | 构造函数
公共类 | SwebClientEJControlExtension | 构造函数
公共类 | SwebClientFileExtension | 构造函数
公共类 | SwebClientGPSExtension | 构造函数
公共类 | SwebClientJsEvalExtension | SwebClientJsExtension
公共类 | SwebClientPrintExtension | 构造函数
公共类 | SwebClientRedirectUrlExtension | 构造函数
公共类 | SwebComponent | 组件基类
公共类 | SwebComponentCollection | Sweb组件集合
公共类 | SwebComponentResultArgs | 组件调用结果
公共类 | SwebContainerControl | 容器控件
公共类 | SwebControl | 控件
公共类 | SwebControlBase | 控件基类
公共类 | SwebControlCollection | 控件集合
公共类 | SwebControlEventArgs |
公共类 | SwebControlStyleAttribute | 控件样式描述声明
公共类 | SwebForm | 窗体
公共类 | SwebFormStatusbarConverter | 为SwebFormStatusbar提供类型转换
公共类 | SwebHandlerArgs | HandlerArgs基类
公共类 | SwebLayoutControl | 布局控件
公共类 | SwebListViewTemplateItem |
公共类 | SwebMessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。
公共类 | SwebMethodAttribute | 方法特性
公共类 | SwebModuleAttribute | 模板特性
公共类 | SwebMouseMoveEventArgs | 为 SwebMouseMoveEventHandler 绑定提供数据
公共类 | SwebMousePressEventArgs |
公共类 | SwebNativeContainerControl | 原生容器控件
公共类 | SwebNativeControl | 原生控件
公共类 | SwebNativeTextControl | 文本控件
公共类 | SwebParentControl | 父容器控件
公共类 | SwebProperty | 控件属性
公共类 | SwebPropertyBindAttribute | 属性绑定特性
公共类 | SwebPropertyExtend | 属性扩展
公共类 | SwebPropertyStyleAttribute | 属性样式
公共类 | SwebShadowProperty | SwebShadowProperty
公共类 | SwebStyleProperty | 控件样式属性
公共类 | SwebTextControl | 文本控件
公共类 | SwebTypeAttribute | 类型特性
公共类 | SwebUserControl | 自定义控件
公共类 | SwebViewCollectionT | 元素集合基类
公共类 | SwebViewCollectionBaseT | 继承自CollectionBase的集合
公共类 | SwebViewCollectionItem | 集合元素
公共类 | SwebViewCollectionShadowItem | SwebViewCollectionShadowItem
公共类 | SwebViewDictionaryTKey, TValue | 字典元素
公共类 | SwebViewObjectCollectionBaseT | 单对象集合
公共类 | SwebViewStringCollection | 字符串列表类
公共类 | SwebViewStringCollectionPropertyExtend |
公共类 | SwebViewTemplateItem | 模板类
公共类 | Switch | 开关控件
公共类 | TabPageControl |
公共类 | TabPageView | 单元页面控件
公共类 | TabPageViewChangedEventArgs |
公共类 | TabPageViewClosedEventArgs |
公共类 | TextBox | 文本框控件
公共类 | Timer | 计时器组件
公共类 | ToggledButton |
公共类 | TreeSelect | 下拉列表控件
公共类 | TreeSelectNode |
公共类 | TreeSelectNodeCollection |
公共类 | TreeSelectNodeCollectionPropertyExtend |
公共类 | TreeSelectPressEventArgs | 为TreeSelect提供数据
公共类 | TreeView | 树形菜单控件
公共类 | TreeViewNode | 属性菜单节点
公共类 | TreeViewNodeCollection | 树形菜单控件节点集合
公共类 | TreeViewOnPressEventArgs | 为TreeView提供数据
公共类 | TTS | 文字转语音控件
公共类 | WebView | 网页控件
公共类 | WebViewMessageEventArgs |
公共类 | WebViewOnLoadEventArgs | 为 WebViewOnLoadEvent 提供数据。
结构
 | 结构 | 说明
公共结构 | Border | 控件边距
公共结构 | ClientResourceGetResultArgsResourceData | 资源数据
公共结构 | Margin | 控件边距
公共结构 | Padding | 控件内边距
公共结构 | SwebFormStatusbar | 窗体状态栏
接口
 | 接口 | 说明
公共接口 | INotifyPropertyChanged | Notifies clients that a property value has changed.
公共接口 | ISwebBindableControl | 数据绑定控件接口
公共接口 | ISwebControl | 控件接口
公共接口 | ISwebDataBindableControl | 实现绑定模式的绑定控件
公共接口 | ISwebDataBindControl | 数据绑定控件接口
公共接口 | ISwebEventControl |
公共接口 | ISwebRenderControl | ISwebRenderControl
公共接口 | ISwebResourceControl | 资源控件
公共接口 | ISwebResourceDataControl | 资源数据控件
公共接口 | ISwebTemplateControl |
公共接口 | ISwebViewCollectionOwner | ISwebViewCollectionOwner
公共接口 | ISwebViewDictionaryOwnerTKey, TValue | ISwebViewDictionaryOwner
公共接口 | ISwebViewObjectCollectionOwner | ISwebViewObjectCollectionOwner
委托
 | 委托 | 说明
公共委托 | ActionButtonPressEventHandler |
公共委托 | BinaryResultCallBackHandler | 一个委托，它表示客户端返回二进制数据时要调用的方法。
公共委托 | CustomCallBackEventHandler |
公共委托 | DataSourceUpdateEventHandler | 一个委托，它表示更新数据源时要调用的方法。
公共委托 | DatePickrSelectedEventHandler |
公共委托 | EChartsPressEventHandler | 一个委托，它表示ECharts被点击时需要调用的方法。
公共委托 | FileOperationHandler | 一个委托，它表示在文件操作后要调用的方法。
公共委托 | FileUploadHandler | 一个委托，它表示在文件上传后要调用的方法。
公共委托 | FormRedirectCallBackEventHandler | 一个委托，它表示在打开给定的窗体，并在给定的窗体关闭后要调用的方法。
公共委托 | GetClientResourceHandler | 一个委托，它表示在获取客户端资源后要调用的方法。
公共委托 | GpsCallBackHandler | 一个委托，它表示在GPS请求后要调用的方法。
公共委托 | GridViewCellSaveEventHandler | 一个委托，它表示单元格编辑结束的回调。
公共委托 | GridViewRowClickEventHandler | 一个委托，它表示行点击要调用的方法。
公共委托 | GridViewSaveChangeEventHandler | 一个委托，它表示保存当前页行更改时要调用的数据。
公共委托 | GridViewSelectedRowsEventHandler | 一个委托，它表示获取选择行要调用的方法。
公共委托 | KeyDownEventHandler | 一个委托，它表示在客户端点击实体按键时要调用的方法。
公共委托 | ListViewTemplateBindEventHandler | 一个委托，它表示模板控件绑定过程要调用的方法。
公共委托 | LoadClientDataCallBackHandler | 一个委托，它表示客户端完成数据载入时要调用的方法。
公共委托 | LoadClientResourceHandler | 一个委托，它表示在载入客户端资源后要调用的方法。
公共委托 | MapTrimViewLocationChanged | 一个委托，它表示在地图上的标签移动时需要调用的方法。
公共委托 | MapViewTagClickEventHandler | 一个委托，它表示在地图上的标签被点击时需要调用的方法。
公共委托 | MediaViewStateChangedEventHandler | 一个委托，它表示状态改变后要调用的方法。
公共委托 | MenuViewItemClickEventHandler |
公共委托 | MessageBoxHandler | 一个委托，它表示在提示框点击时要调用的方法。
公共委托 | PageViewTemplateBindEventHandler | 一个委托，它表示模板控件绑定过程要调用的方法。
公共委托 | PopPanelItemSelectEventHandler |
公共委托 | PropertyChangedEventHandler | Represents the method that will handle the System.ComponentModel.INotifyPropertyChanged.PropertyChanged event raised when a property is changed on a component.
公共委托 | ReadClientDataCallBackHandler | 一个委托，它表示客户端返回读取保存在客户端上的数据时要调用的方法。
公共委托 | RemoveClientDataCallBackHandler | 一个委托，它表示客户端完成数据移除时要调用的方法。
公共委托 | RemoveClientResourceHandler | 一个委托，它表示在删除客户端资源后要调用的方法。
公共委托 | ScrollPositionChangedEventHandler | 一个委托，它表示滚动位置化时的方法。
公共委托 | SwebClientCameraExtensionHandlerRPC | 一个委托，它表示在上传后要调用的方法。
公共委托 | SwebClientClipBoardExtensionClipboardResultHandler | 一个委托，它表示粘贴板回调时要调用的方法。
公共委托 | SwebComponentOnResultHandler | 一个委托，它表示在组件结果回调后要调用的方法。
公共委托 | SwebEditerChangedHandle | 一个委托，它表示内容改变时的回调
公共委托 | SwebMouseMoveEventHandler | 一个委托，它表示鼠标移动时的方法。
公共委托 | SwebMousePressEventHandler |
公共委托 | TabPageViewChangedEventHandler |
公共委托 | TabPageViewClosedEventHandler |
公共委托 | TreeSelectTreeSelectOnPressEventHandler |
公共委托 | TreeViewTreeViewOnPressEventHandler |
公共委托 | WebViewWebViewMessageEventHandler |
公共委托 | WebViewWebViewOnLoadEventHandler |
枚举
 | 枚举 | 说明
公共枚举 | ActionButtonImageType |
公共枚举 | AnimationDirection | 动画方向
公共枚举 | AnimationEasing | 动画效果
公共枚举 | AnimationType | 动画类型
公共枚举 | AnimationValueType | 动画值类型
公共枚举 | AutoScrollType |
公共枚举 | BarcodeType |
公共枚举 | BorderStyle | 边框样式
公共枚举 | ButtonIconLocation | 图标显示位置
公共枚举 | CameraMethod | Camera 拍照模式
公共枚举 | CameraQialityMode | Camera 上传模式
公共枚举 | CheckBoxStyle | CheckBox样式
公共枚举 | ChooseDatePickerFormat | 日期形式
公共枚举 | ChooseDatePickerMode | 显示模式
公共枚举 | DataBindMode | 数据绑定模式
公共枚举 | DatePickerFormat |
公共枚举 | DatePickerMode | 日期/时间选择控件显示模式
公共枚举 | DialogAnimationType | 弹出动画样式
公共枚举 | DrawerPosition | 侧边栏出现在屏幕上的位置
公共枚举 | EChartsTheme | ECharts主题
公共枚举 | EditeListButton |
公共枚举 | EditerEditerTheme | Editer主题
公共枚举 | EditerAttachButton |
公共枚举 | EditerFontStyle |
公共枚举 | EJTheme | EJ2控件主题
公共枚举 | FontIconName |
公共枚举 | FontWeight | 字体粗细
公共枚举 | FormOrientation | 窗体横竖屏状态
公共枚举 | GeoType | 坐标类型
公共枚举 | GridViewCellType | 单元格类型
公共枚举 | GridViewEditMode | GridView编辑模式
公共枚举 | GridViewLines | 分隔线类型
公共枚举 | GridViewNewRowPosition | 添加新行的位置
公共枚举 | GridViewSelectionMode | GridView行选择模式
公共枚举 | GridViewSelectionType | GrdiView选择模式
公共枚举 | HorizontalAlignment | 水平方面
公共枚举 | ImageRepeatMode |
公共枚举 | ImageSizeMode | 图像显示样式
公共枚举 | JScriptAppendType | JS脚本添加类型
公共枚举 | JScriptType | JS脚本类型
公共枚举 | KeyboardType | 文本框键盘样式
公共枚举 | KeyCode | 客户端实体按键
公共枚举 | LayoutDirection | 主轴方向
公共枚举 | LayoutItemAlign | 侧轴元素对齐方式
公共枚举 | LayoutJustifyAlign | 主轴元素对齐方式
公共枚举 | LayoutOverflow | 布局覆盖范围
公共枚举 | LayoutPercentage | 布局百分比
公共枚举 | LayoutPosition | 布局
公共枚举 | LayoutSelfAlign | 覆盖容器定义的侧轴对齐方式
公共枚举 | LayoutSelfPosition |
公共枚举 | LayoutWrap | 布局换行
公共枚举 | MediaState | 视频状态
公共枚举 | MessageBoxButtons | 指定若干常数，用以定义 MessageBox 上将显示哪些按钮
公共枚举 | OrientationAlignment |
公共枚举 | PageSizeLoadMode | 分页数据加载模式
公共枚举 | PointerEventType | 控制当前组件是否可以作为触控事件的目标
公共枚举 | PopPanelListTheme |
公共枚举 | PopPanelPosition |
公共枚举 | PopPanelType |
公共枚举 | Predicate |
公共枚举 | PrintType |
公共枚举 | PropertyChangedSource | PropertyChangedSource
公共枚举 | ResourceMode | 资源类型
公共枚举 | ResourceType | 资源类型
公共枚举 | ReturnKeyType | 确定返回键的外观
公共枚举 | ScrollPositionType | 位置滚动类型
公共枚举 | ShowResult | 指定标识符以指示的返回值。
公共枚举 | SortOrderType | 排序类型
公共枚举 | StreamingType | 流媒体类型
公共枚举 | SwebFormStatusbarStyle | 窗体状态栏样式
公共枚举 | SwebMessageBoxPosition | 消息框显示位置
公共枚举 | SwebMouseMovePosition | 鼠标移动方式
公共枚举 | SwebPropertyBindType | 绑定类型
公共枚举 | TabPageIndicator |
公共枚举 | TextBoxValueType | TextBox 输入值类型
公共枚举 | TextDecorationLineType | 文本修饰要使用的线条类型
公共枚举 | ToastLength | Toast存续期间
公共枚举 | TTSLanguage | TTS语言
公共枚举 | VerticalAlignment | 垂直方向
公共枚举 | WebViewMixedContentMode |


ActionButtonBase 类

[缺少 "T:Swebui.Controls.ActionButtonBase" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewCollectionShadowItem
Swebui.ControlsActionButtonBase
Swebui.ControlsActionButtonItem
Swebui.ControlsActionMainButton

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ActionButtonBase : SwebViewCollectionShadowItem
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ActionButtonBase
    Inherits SwebViewCollectionShadowItem

ActionButtonBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ActionButtonBase | 初始化 ActionButtonBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ButtonCorlor |
公共属性 | IconColor |
公共属性 | ImageType |
公共属性 | ResourceID |
公共属性 | ResourcePath |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TouchOpacity |
Top
参见

引用

Swebui.Controls 命名空间


ActionButtonBase 构造函数

初始化 ActionButtonBase 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonBase()
Public Sub New
参见

引用

ActionButtonBase 类


ActionButtonBase 属性

ActionButtonBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ButtonCorlor |
公共属性 | IconColor |
公共属性 | ImageType |
公共属性 | ResourceID |
公共属性 | ResourcePath |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TouchOpacity |
Top
参见

引用

ActionButtonBase 类


ActionButtonBase.ButtonCorlor 属性

ActionButtonBaseButtonCorlor 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.ButtonCorlor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Color ButtonCorlor { get; set; }
Public Overridable Property ButtonCorlor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ActionButtonBase 类


ActionButtonBase.IconColor 属性

ActionButtonBaseIconColor 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.IconColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color IconColor { get; set; }
Public Property IconColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ActionButtonBase 类


ActionButtonBase.ImageType 属性

ActionButtonBaseImageType 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.ImageType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonImageType ImageType { get; set; }
Public Property ImageType As ActionButtonImageType
    Get
    Set

属性值

类型：ActionButtonImageType
参见

引用

ActionButtonBase 类


ActionButtonBase.ResourceID 属性

ActionButtonBaseResourceID 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.ResourceID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string ResourceID { get; set; }
Public Overridable Property ResourceID As String
    Get
    Set

属性值

类型：String
参见

引用

ActionButtonBase 类


ActionButtonBase.ResourcePath 属性

ActionButtonBaseResourcePath 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.ResourcePath" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourcePath { get; set; }
Public Property ResourcePath As String
    Get
    Set

属性值

类型：String
参见

引用

ActionButtonBase 类


ActionButtonBase.TouchOpacity 属性

ActionButtonBaseTouchOpacity 属性

[缺少 "P:Swebui.Controls.ActionButtonBase.TouchOpacity" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int TouchOpacity { get; set; }
Public Property TouchOpacity As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ActionButtonBase 类


ActionButtonImageType 枚举

[缺少 "T:Swebui.Controls.ActionButtonImageType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ActionButtonImageType
Public Enumeration ActionButtonImageType
成员
成员名称 | 值 | 说明
FontIcon | 0 |
Image | 1 |
Text | 2 |
参见

引用

Swebui.Controls 命名空间


ActionButtonItem 类

[缺少 "T:Swebui.Controls.ActionButtonItem" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewCollectionShadowItem
Swebui.ControlsActionButtonBase
Swebui.ControlsActionButtonItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ActionButtonItem : ActionButtonBase
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ActionButtonItem
    Inherits ActionButtonBase

ActionButtonItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ActionButtonItem | 初始化 ActionButtonItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ButtonCorlor | (继承自 ActionButtonBase。)
公共属性 | IconColor | (继承自 ActionButtonBase。)
公共属性 | ImageType | (继承自 ActionButtonBase。)
公共属性 | ResourceID | (继承自 ActionButtonBase。)
公共属性 | ResourcePath | (继承自 ActionButtonBase。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TextBackColor |
公共属性 | TextForeColor |
公共属性 | TextHeight |
公共属性 | TextSize |
公共属性 | TextSpace |
公共属性 | TouchOpacity | (继承自 ActionButtonBase。)
Top
参见

引用

Swebui.Controls 命名空间


ActionButtonItem 构造函数

初始化 ActionButtonItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonItem()
Public Sub New
参见

引用

ActionButtonItem 类


ActionButtonItem 属性

ActionButtonItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ButtonCorlor | (继承自 ActionButtonBase。)
公共属性 | IconColor | (继承自 ActionButtonBase。)
公共属性 | ImageType | (继承自 ActionButtonBase。)
公共属性 | ResourceID | (继承自 ActionButtonBase。)
公共属性 | ResourcePath | (继承自 ActionButtonBase。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TextBackColor |
公共属性 | TextForeColor |
公共属性 | TextHeight |
公共属性 | TextSize |
公共属性 | TextSpace |
公共属性 | TouchOpacity | (继承自 ActionButtonBase。)
Top
参见

引用

ActionButtonItem 类


ActionButtonItem.Text 属性

ActionButtonItemText 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

ActionButtonItem 类


ActionButtonItem.TextBackColor 属性

ActionButtonItemTextBackColor 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.TextBackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color TextBackColor { get; set; }
Public Property TextBackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ActionButtonItem 类


ActionButtonItem.TextForeColor 属性

ActionButtonItemTextForeColor 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.TextForeColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color TextForeColor { get; set; }
Public Property TextForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ActionButtonItem 类


ActionButtonItem.TextHeight 属性

ActionButtonItemTextHeight 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.TextHeight" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int TextHeight { get; set; }
Public Property TextHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ActionButtonItem 类


ActionButtonItem.TextSize 属性

ActionButtonItemTextSize 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.TextSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int TextSize { get; set; }
Public Property TextSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ActionButtonItem 类


ActionButtonItem.TextSpace 属性

ActionButtonItemTextSpace 属性

[缺少 "P:Swebui.Controls.ActionButtonItem.TextSpace" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int TextSpace { get; set; }
Public Property TextSpace As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ActionButtonItem 类


ActionButtonItemCollection 类

[缺少 "T:Swebui.Controls.ActionButtonItemCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase ActionButtonItem
Swebui.ControlsActionButtonItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ActionButtonItemCollection : SwebViewCollectionBase<ActionButtonItem>
Public Class ActionButtonItemCollection
    Inherits SwebViewCollectionBase(Of ActionButtonItem)

ActionButtonItemCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ActionButtonItemCollection | 初始化 ActionButtonItemCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


ActionButtonItemCollection 构造函数

初始化 ActionButtonItemCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonItemCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.ActionButtonItemCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

ActionButtonItemCollection 类


ActionButtonItemCollection 属性

ActionButtonItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

ActionButtonItemCollection 类


ActionButtonItemCollection 方法

ActionButtonItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

ActionButtonItemCollection 类


ActionButtonPressEventArgs 类

[缺少 "T:Swebui.Controls.ActionButtonPressEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsActionButtonPressEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ActionButtonPressEventArgs : EventArgs
Public Class ActionButtonPressEventArgs
    Inherits EventArgs

ActionButtonPressEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ActionButtonPressEventArgs | 初始化 ActionButtonPressEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Index |
Top
参见

引用

Swebui.Controls 命名空间


ActionButtonPressEventArgs 构造函数

初始化 ActionButtonPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonPressEventArgs(
    int index
)
Public Sub New (
    index As Integer
)

参数

index
类型：SystemInt32

[缺少 "M:Swebui.Controls.ActionButtonPressEventArgs.#ctor(System.Int32)" 的 <param name="index"/> 文档]

参见

引用

ActionButtonPressEventArgs 类


ActionButtonPressEventArgs 属性

ActionButtonPressEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Index |
Top
参见

引用

ActionButtonPressEventArgs 类


ActionButtonPressEventArgs.Index 属性

ActionButtonPressEventArgsIndex 属性

[缺少 "P:Swebui.Controls.ActionButtonPressEventArgs.Index" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

属性值

类型：Int32
参见

引用

ActionButtonPressEventArgs 类


ActionButtonPressEventHandler 委托

[缺少 "T:Swebui.Controls.ActionButtonPressEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ActionButtonPressEventHandler(
    Object sender,
    ActionButtonPressEventArgs e
)
Public Delegate Sub ActionButtonPressEventHandler (
    sender As Object,
    e As ActionButtonPressEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsActionButtonPressEventArgs
参见

引用

Swebui.Controls 命名空间


ActionMainButton 类

[缺少 "T:Swebui.Controls.ActionMainButton" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewCollectionShadowItem
Swebui.ControlsActionButtonBase
Swebui.ControlsActionMainButton

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ActionMainButton : ActionButtonBase
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ActionMainButton
    Inherits ActionButtonBase

ActionMainButton 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ActionMainButton | 初始化 ActionMainButton 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ButtonCorlor | (重写 ActionButtonBaseButtonCorlor.)
公共属性 | Degrees |
公共属性 | IconColor | (继承自 ActionButtonBase。)
公共属性 | ImageType | (继承自 ActionButtonBase。)
公共属性 | ResourceID | (重写 ActionButtonBaseResourceID.)
公共属性 | ResourcePath | (继承自 ActionButtonBase。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TouchOpacity | (继承自 ActionButtonBase。)
Top
参见

引用

Swebui.Controls 命名空间


ActionMainButton 构造函数

初始化 ActionMainButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionMainButton()
Public Sub New
参见

引用

ActionMainButton 类


ActionMainButton 属性

ActionMainButton 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ButtonCorlor | (重写 ActionButtonBaseButtonCorlor.)
公共属性 | Degrees |
公共属性 | IconColor | (继承自 ActionButtonBase。)
公共属性 | ImageType | (继承自 ActionButtonBase。)
公共属性 | ResourceID | (重写 ActionButtonBaseResourceID.)
公共属性 | ResourcePath | (继承自 ActionButtonBase。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TouchOpacity | (继承自 ActionButtonBase。)
Top
参见

引用

ActionMainButton 类


ActionMainButton.ButtonCorlor 属性

ActionMainButtonButtonCorlor 属性

[缺少 "P:Swebui.Controls.ActionMainButton.ButtonCorlor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Color ButtonCorlor { get; set; }
Public Overrides Property ButtonCorlor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ActionMainButton 类


ActionMainButton.Degrees 属性

ActionMainButtonDegrees 属性

[缺少 "P:Swebui.Controls.ActionMainButton.Degrees" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Degrees { get; set; }
Public Property Degrees As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ActionMainButton 类


ActionMainButton.ResourceID 属性

ActionMainButtonResourceID 属性

[缺少 "P:Swebui.Controls.ActionMainButton.ResourceID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ResourceID { get; set; }
Public Overrides Property ResourceID As String
    Get
    Set

属性值

类型：String
参见

引用

ActionMainButton 类


Animation 类

动画组件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebComponent
Swebui.ControlsAnimation

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class Animation : SwebComponent
Public Class Animation
    Inherits SwebComponent

Animation 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Animation | 初始化 Animation 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动播放
公共属性 | Delay | 获取和设置动画延时（毫秒）
公共属性 | DelayStagger | 获取和设置延迟交错
公共属性 | Direction | 获取和设置动画方向
公共属性 | Duration | 获取和设置动画时长（毫秒）
公共属性 | Easing | 获取和设置动画效果
公共属性 | EasingValue | 获取和设置动画效果值
公共属性 | EndDelay | 获取和设置动画结束延时（毫秒）
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Items | 获取和设置动画集合
公共属性 | Loop | 获取和设置动画循环次数
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
方法
 | 名称 | 说明
公共方法 | Pause | 暂停播放动画
公共方法 | Play | 播放动画
公共方法 | Reset | 还原动画
公共方法 | Restart | 重新开始播放动画
公共方法 | Reverse | 反向播放动画
Top
参见

引用

Swebui.Controls 命名空间


Animation 构造函数

初始化 Animation 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Animation()
Public Sub New
参见

引用

Animation 类


Animation 属性

Animation 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动播放
公共属性 | Delay | 获取和设置动画延时（毫秒）
公共属性 | DelayStagger | 获取和设置延迟交错
公共属性 | Direction | 获取和设置动画方向
公共属性 | Duration | 获取和设置动画时长（毫秒）
公共属性 | Easing | 获取和设置动画效果
公共属性 | EasingValue | 获取和设置动画效果值
公共属性 | EndDelay | 获取和设置动画结束延时（毫秒）
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Items | 获取和设置动画集合
公共属性 | Loop | 获取和设置动画循环次数
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
参见

引用

Animation 类


Animation.AutoPlay 属性

AnimationAutoPlay 属性

获取和设置一个值，该值指示是否自动播放

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool AutoPlay { get; set; }
Public Property AutoPlay As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Animation 类


Animation.Delay 属性

AnimationDelay 属性

获取和设置动画延时（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Delay { get; set; }
Public Property Delay As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

Animation 类


Animation.DelayStagger 属性

AnimationDelayStagger 属性

获取和设置延迟交错

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int DelayStagger { get; set; }
Public Property DelayStagger As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

Animation 类


Animation.Direction 属性

AnimationDirection 属性

获取和设置动画方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationDirection Direction { get; set; }
Public Property Direction As AnimationDirection
    Get
    Set

返回值

类型：AnimationDirection
参见

引用

Animation 类


Animation.Duration 属性

AnimationDuration 属性

获取和设置动画时长（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Duration { get; set; }
Public Property Duration As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

Animation 类


Animation.Easing 属性

AnimationEasing 属性

获取和设置动画效果

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationEasing Easing { get; set; }
Public Property Easing As AnimationEasing
    Get
    Set

返回值

类型：AnimationEasing
参见

引用

Animation 类


Animation.EasingValue 属性

AnimationEasingValue 属性

获取和设置动画效果值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string EasingValue { get; set; }
Public Property EasingValue As String
    Get
    Set

返回值

类型：String
参见

引用

Animation 类


Animation.EndDelay 属性

AnimationEndDelay 属性

获取和设置动画结束延时（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int EndDelay { get; set; }
Public Property EndDelay As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

Animation 类


Animation.Items 属性

AnimationItems 属性

获取和设置动画集合

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationItemCollection Items { get; }
Public ReadOnly Property Items As AnimationItemCollection
    Get

返回值

类型：AnimationItemCollection
参见

引用

Animation 类


Animation.Loop 属性

AnimationLoop 属性

获取和设置动画循环次数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Loop { get; set; }
Public Property Loop As Integer
    Get
    Set

属性值

类型：Int32
0，不循环，-1 无限循环

返回值

类型：Int32
参见

引用

Animation 类


Animation 方法

Animation 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Pause | 暂停播放动画
公共方法 | Play | 播放动画
公共方法 | Reset | 还原动画
公共方法 | Restart | 重新开始播放动画
公共方法 | Reverse | 反向播放动画
Top
参见

引用

Animation 类


Animation.Pause 方法

AnimationPause 方法

暂停播放动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Pause()
Public Sub Pause
参见

引用

Animation 类


Animation.Play 方法

AnimationPlay 方法

播放动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Play()
Public Sub Play
参见

引用

Animation 类


Animation.Reset 方法

AnimationReset 方法

还原动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Reset()
Public Sub Reset
参见

引用

Animation 类


Animation.Restart 方法

AnimationRestart 方法

重新开始播放动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Restart()
Public Sub Restart
参见

引用

Animation 类


Animation.Reverse 方法

AnimationReverse 方法

反向播放动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Reverse()
Public Sub Reverse
参见

引用

Animation 类


AnimationDirection 枚举

动画方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum AnimationDirection
Public Enumeration AnimationDirection
成员
成员名称 | 值 | 说明
Normal | 0 | 正向
Reverse | 1 | 反向
Alternate | 2 | 交替
参见

引用

Swebui.Controls 命名空间


AnimationEasing 枚举

动画效果

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum AnimationEasing
Public Enumeration AnimationEasing
成员
成员名称 | 值 | 说明
Default | 0 |
Linear | 1 | 线性
Steps | 2 | 步进
EaseInQuad | 3 |
EaseOutQuad | 4 |
EaseInOutQuad | 5 |
EaseOutInQuad | 6 |
EaseInCubic | 7 |
EaseOutCubic | 8 |
EaseInOutCubic | 9 |
EaseOutInCubic | 10 |
EaseInQuart | 11 |
EaseOutQuart | 12 |
EaseInOutQuart | 13 |
EaseOutInQuart | 14 |
EaseInQuint | 15 |
EaseOutQuint | 16 |
EaseInOutQuint | 17 |
EaseOutInQuint | 18 |
EaseInSine | 19 |
EaseOutSine | 20 |
EaseInOutSine | 21 |
EaseOutInSine | 22 |
EaseInExpo | 23 |
EaseOutExpo | 24 |
EaseInOutExpo | 25 |
EaseOutInExpo | 26 |
EaseInCirc | 27 |
EaseOutCirc | 28 |
EaseInOutCirc | 29 |
EaseOutInCirc | 30 |
EaseInBack | 31 |
EaseOutBack | 32 |
EaseInOutBack | 33 |
EaseOutInBack | 34 |
EaseInBounce | 35 |
EaseOutBounce | 36 |
EaseInOutBounce | 37 |
EaseOutInBounce | 38 |
参见

引用

Swebui.Controls 命名空间


AnimationItem 类

动画元素
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsAnimationItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class AnimationItem : SwebViewCollectionItem
Public Class AnimationItem
    Inherits SwebViewCollectionItem

AnimationItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AnimationItem | 初始化 AnimationItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Delay | 获取和设置动画延时（毫秒）
公共属性 | Duration | 获取和设置动画时长（毫秒）
公共属性 | Easing | 获取和设置动画效果
公共属性 | EasingValue | 获取和设置动画效果值
公共属性 | EndDelay | 获取和设置动画结束延时（毫秒）
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Type | 获取和设置动画类型
公共属性 | Value | 获取和设置值
公共属性 | ValueType | 获取和设置值类型
Top
参见

引用

Swebui.Controls 命名空间


AnimationItem 构造函数

初始化 AnimationItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationItem()
Public Sub New
参见

引用

AnimationItem 类


AnimationItem 属性

AnimationItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Delay | 获取和设置动画延时（毫秒）
公共属性 | Duration | 获取和设置动画时长（毫秒）
公共属性 | Easing | 获取和设置动画效果
公共属性 | EasingValue | 获取和设置动画效果值
公共属性 | EndDelay | 获取和设置动画结束延时（毫秒）
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Type | 获取和设置动画类型
公共属性 | Value | 获取和设置值
公共属性 | ValueType | 获取和设置值类型
Top
参见

引用

AnimationItem 类


AnimationItem.Delay 属性

AnimationItemDelay 属性

获取和设置动画延时（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Delay { get; set; }
Public Property Delay As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

AnimationItem 类


AnimationItem.Duration 属性

AnimationItemDuration 属性

获取和设置动画时长（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Duration { get; set; }
Public Property Duration As Integer
    Get
    Set

属性值

类型：Int32
为0代表继承自组件属性

返回值

类型：Int32
参见

引用

AnimationItem 类


AnimationItem.Easing 属性

AnimationItemEasing 属性

获取和设置动画效果

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationEasing Easing { get; set; }
Public Property Easing As AnimationEasing
    Get
    Set

返回值

类型：AnimationEasing
参见

引用

AnimationItem 类


AnimationItem.EasingValue 属性

AnimationItemEasingValue 属性

获取和设置动画效果值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string EasingValue { get; set; }
Public Property EasingValue As String
    Get
    Set

返回值

类型：String
备注
在一些动画效果上需要值，比如Step，可以设置步进值
参见

引用

AnimationItem 类


AnimationItem.EndDelay 属性

AnimationItemEndDelay 属性

获取和设置动画结束延时（毫秒）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int EndDelay { get; set; }
Public Property EndDelay As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

AnimationItem 类


AnimationItem.Type 属性

AnimationItemType 属性

获取和设置动画类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationType Type { get; set; }
Public Property Type As AnimationType
    Get
    Set

返回值

类型：AnimationType
参见

引用

AnimationItem 类


AnimationItem.Value 属性

AnimationItemValue 属性

获取和设置值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Value { get; set; }
Public Property Value As String
    Get
    Set

属性值

类型：String
支持数值，百分比

返回值

类型：String
参见

引用

AnimationItem 类


AnimationItem.ValueType 属性

AnimationItemValueType 属性

获取和设置值类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationValueType ValueType { get; set; }
Public Property ValueType As AnimationValueType
    Get
    Set

属性值

类型：AnimationValueType
可设置X,Y,Z方向的值

返回值

类型：AnimationValueType
参见

引用

AnimationItem 类


AnimationItemCollection 类

[缺少 "T:Swebui.Controls.AnimationItemCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase AnimationItem
Swebui.ControlsAnimationItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class AnimationItemCollection : SwebViewCollectionBase<AnimationItem>
Public Class AnimationItemCollection
    Inherits SwebViewCollectionBase(Of AnimationItem)

AnimationItemCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AnimationItemCollection | 初始化 AnimationItemCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


AnimationItemCollection 构造函数

初始化 AnimationItemCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AnimationItemCollection()
Public Sub New
参见

引用

AnimationItemCollection 类


AnimationItemCollection 属性

AnimationItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

AnimationItemCollection 类


AnimationItemCollection 方法

AnimationItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

AnimationItemCollection 类


AnimationType 枚举

动画类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum AnimationType
Public Enumeration AnimationType
成员
成员名称 | 值 | 说明
Rotate | 0 | 翻转
Scale | 1 | 缩放
Translate | 2 | 位置转换
参见

引用

Swebui.Controls 命名空间


AnimationValueType 枚举

动画值类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum AnimationValueType
Public Enumeration AnimationValueType
成员
成员名称 | 值 | 说明
Default | 0 | 默认
X | 1 | X方向
Y | 2 | Y方向
Z | 3 | Z方向
参见

引用

Swebui.Controls 命名空间


AttachButton 类

[缺少 "T:Swebui.Controls.AttachButton" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsAttachButton

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class AttachButton
Public Class AttachButton

AttachButton 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AttachButton | 初始化 AttachButton 类的一个新实例
公共方法 | AttachButton(ListEditerAttachButton) | 初始化 AttachButton 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

Swebui.Controls 命名空间


AttachButton 构造函数

重载列表
 | 名称 | 说明
公共方法 | AttachButton | 初始化 AttachButton 类的一个新实例
公共方法 | AttachButton(ListEditerAttachButton) | 初始化 AttachButton 类的一个新实例
Top
参见

引用

AttachButton 类


AttachButton 构造函数

初始化 AttachButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public AttachButton()
Public Sub New
参见

引用

AttachButton 类
AttachButton 重载


AttachButton 构造函数 (List(EditerAttachButton))

AttachButton 构造函数 (ListEditerAttachButton)

初始化 AttachButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public AttachButton(
    List<EditerAttachButton> data
)
Public Sub New (
    data As List(Of EditerAttachButton)
)

参数

data
类型：System.Collections.GenericList EditerAttachButton

[缺少 "M:Swebui.Controls.AttachButton.#ctor(System.Collections.Generic.List{Swebui.Controls.EditerAttachButton})" 的 <param name="data"/> 文档]

参见

引用

AttachButton 类
AttachButton 重载


AttachButton 属性

AttachButton 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

AttachButton 类


AttachButton.Data 属性

AttachButtonData 属性

[缺少 "P:Swebui.Controls.AttachButton.Data" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public List<EditerAttachButton> Data { get; }
Public ReadOnly Property Data As List(Of EditerAttachButton)
    Get

属性值

类型：List EditerAttachButton
参见

引用

AttachButton 类


AutoComplete 类

带提示框的输入框
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebTextControl
Swebui.ControlsAutoComplete

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class AutoComplete : SwebTextControl,
    ISwebRenderControl, ISwebEventControl
Public Class AutoComplete
    Inherits SwebTextControl
    Implements ISwebRenderControl, ISwebEventControl

AutoComplete 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AutoComplete | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DataSource | 获取或设置获取资源模式
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 输入框没有内容时的提示内容
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowClearButton | 是否显示清空文字按钮
公共属性 | ShowPopupButton | 是否显示下拉提示按钮
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取或设置控件文本 (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 内容更改时触发回调
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
参见

引用

Swebui.Controls 命名空间


AutoComplete 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public AutoComplete()
Public Sub New
参见

引用

AutoComplete 类


AutoComplete 属性

AutoComplete 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DataSource | 获取或设置获取资源模式
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 输入框没有内容时的提示内容
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowClearButton | 是否显示清空文字按钮
公共属性 | ShowPopupButton | 是否显示下拉提示按钮
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取或设置控件文本 (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

AutoComplete 类


AutoComplete.DataSource 属性

AutoCompleteDataSource 属性

获取或设置获取资源模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] DataSource { get; set; }
Public Property DataSource As String()
    Get
    Set

属性值

类型：String
参见

引用

AutoComplete 类


AutoComplete.Placeholder 属性

AutoCompletePlaceholder 属性

输入框没有内容时的提示内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Placeholder { get; set; }
Public Property Placeholder As String
    Get
    Set

属性值

类型：String
参见

引用

AutoComplete 类


AutoComplete.ShowClearButton 属性

AutoCompleteShowClearButton 属性

是否显示清空文字按钮

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ShowClearButton { get; set; }
Public Property ShowClearButton As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

AutoComplete 类


AutoComplete.ShowPopupButton 属性

AutoCompleteShowPopupButton 属性

是否显示下拉提示按钮

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ShowPopupButton { get; set; }
Public Property ShowPopupButton As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

AutoComplete 类


AutoComplete.Text 属性

AutoCompleteText 属性

获取或设置控件文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

AutoComplete 类


AutoComplete 方法

AutoComplete 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 内容更改时触发回调
Top
参见

引用

AutoComplete 类


AutoComplete.OnEventRaised 方法

AutoCompleteOnEventRaised 方法

内容更改时触发回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.AutoComplete.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

AutoComplete 类


AutoComplete 事件

AutoComplete 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
参见

引用

AutoComplete 类


AutoComplete.ValueChanged 事件

AutoCompleteValueChanged 事件

在值改变时时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

AutoComplete 类


AutoScrollParameter 类

[缺少 "T:Swebui.Controls.AutoScrollParameter" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsAutoScrollParameter

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class AutoScrollParameter
Public Class AutoScrollParameter

AutoScrollParameter 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AutoScrollParameter | 初始化 AutoScrollParameter 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Delay |
公共属性 | Speed |
公共属性 | StepLength |
公共属性 | Type |
Top
参见

引用

Swebui.Controls 命名空间


AutoScrollParameter 构造函数

初始化 AutoScrollParameter 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AutoScrollParameter()
Public Sub New
参见

引用

AutoScrollParameter 类


AutoScrollParameter 属性

AutoScrollParameter 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Delay |
公共属性 | Speed |
公共属性 | StepLength |
公共属性 | Type |
Top
参见

引用

AutoScrollParameter 类


AutoScrollParameter.Delay 属性

AutoScrollParameterDelay 属性

[缺少 "P:Swebui.Controls.AutoScrollParameter.Delay" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Delay { get; set; }
Public Property Delay As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

AutoScrollParameter 类


AutoScrollParameter.Speed 属性

AutoScrollParameterSpeed 属性

[缺少 "P:Swebui.Controls.AutoScrollParameter.Speed" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Speed { get; set; }
Public Property Speed As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

AutoScrollParameter 类


AutoScrollParameter.StepLength 属性

AutoScrollParameterStepLength 属性

[缺少 "P:Swebui.Controls.AutoScrollParameter.StepLength" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int StepLength { get; set; }
Public Property StepLength As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

AutoScrollParameter 类


AutoScrollParameter.Type 属性

AutoScrollParameterType 属性

[缺少 "P:Swebui.Controls.AutoScrollParameter.Type" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public AutoScrollType Type { get; set; }
Public Property Type As AutoScrollType
    Get
    Set

属性值

类型：AutoScrollType
参见

引用

AutoScrollParameter 类


AutoScrollType 枚举

[缺少 "T:Swebui.Controls.AutoScrollType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum AutoScrollType
Public Enumeration AutoScrollType
成员
成员名称 | 值 | 说明
Default | 0 |
Round | 1 |
Repeat | 2 |
Stop | 3 |
参见

引用

Swebui.Controls 命名空间


BarcodeType 枚举

[缺少 "T:Swebui.Controls.BarcodeType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum BarcodeType
Public Enumeration BarcodeType
成员
成员名称 | 值 | 说明
Code128 | 0 | Code128
QRCode | 1 | QRCode
参见

引用

Swebui.Controls 命名空间


BarcodeView 类

条码控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsBarcodeView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class BarcodeView : SwebBindableControl,
    ISwebRenderControl
Public Class BarcodeView
    Inherits SwebBindableControl
    Implements ISwebRenderControl

BarcodeView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BarcodeView | 初始化BarcodeView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BarcodeType | 获取和设置条码类型
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置条码前景色
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置条码文本
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


BarcodeView 构造函数

初始化BarcodeView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public BarcodeView()
Public Sub New
参见

引用

BarcodeView 类


BarcodeView 属性

BarcodeView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BarcodeType | 获取和设置条码类型
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置条码前景色
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置条码文本
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

BarcodeView 类


BarcodeView.BarcodeType 属性

BarcodeViewBarcodeType 属性

获取和设置条码类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public BarcodeType BarcodeType { get; set; }
Public Property BarcodeType As BarcodeType
    Get
    Set

属性值

类型：BarcodeType
参见

引用

BarcodeView 类


BarcodeView.BindDisplayValue 属性

BarcodeViewBindDisplayValue 属性

[缺少 "P:Swebui.Controls.BarcodeView.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

BarcodeView 类


BarcodeView.Color 属性

BarcodeViewColor 属性

获取和设置条码前景色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

属性值

类型：Color
参见

引用

BarcodeView 类


BarcodeView.Value 属性

BarcodeViewValue 属性

获取和设置条码文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Value { get; set; }
Public Property Value As String
    Get
    Set

属性值

类型：String
参见

引用

BarcodeView 类


BarcodeView 方法

BarcodeView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

BarcodeView 类


BarcodeView 事件

BarcodeView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

BarcodeView 类


BinaryResultArgs 类

二进制数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsResourceResultArgs
Swebui.ControlsBinaryResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class BinaryResultArgs : ResourceResultArgs
Public Class BinaryResultArgs
    Inherits ResourceResultArgs

BinaryResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BinaryResultArgs | 初始化 BinaryResultArgs 类的一个新实例
公共方法 | BinaryResultArgs(Byte, String) | 初始化 BinaryResultArgs 类的一个新实例
公共方法 | BinaryResultArgs(Byte, String, ResourceType) | 初始化 BinaryResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | Data | 获取或设置二进制数据
公共属性 | DefaultPath | 获取默认路径
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Length | 获取或设置数据长度
公共属性 | ResourceCount | 获取资源数量
公共属性 | ResourceID | 获取资源编号 (继承自 ResourceResultArgs。)
Top
方法
 | 名称 | 说明
公共方法 | SaveFile | 保存文件
公共方法 | SaveFile(String) | 保存文件
公共方法 | SaveFile(ResourceType) | 保存文件
公共方法 | SaveFile(String, ResourceType) | 保存文件
公共方法 | SaveFile(String, String) | 保存文件
 | SaveFileStatic | 保存文件
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
公共方法 | TrySaveFile | 尝试保存文件，如果未保存成功，那么返回False，如果保存成功，那么返回True
Top
备注
参见

引用

Swebui.Controls 命名空间


BinaryResultArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | BinaryResultArgs | 初始化 BinaryResultArgs 类的一个新实例
公共方法 | BinaryResultArgs(Byte, String) | 初始化 BinaryResultArgs 类的一个新实例
公共方法 | BinaryResultArgs(Byte, String, ResourceType) | 初始化 BinaryResultArgs 类的一个新实例
Top
参见

引用

BinaryResultArgs 类


BinaryResultArgs 构造函数

初始化 BinaryResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public BinaryResultArgs()
Public Sub New
参见

引用

BinaryResultArgs 类
BinaryResultArgs 重载


BinaryResultArgs 构造函数 (Byte[], String)

BinaryResultArgs 构造函数 (Byte, String)

初始化 BinaryResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public BinaryResultArgs(
    byte[] data,
    string resourceId
)
Public Sub New (
    data As Byte(),
    resourceId As String
)

参数

data
类型：SystemByte

[缺少 "M:Swebui.Controls.BinaryResultArgs.#ctor(System.Byte[],System.String)" 的 <param name="data"/> 文档]

resourceId
类型：SystemString

[缺少 "M:Swebui.Controls.BinaryResultArgs.#ctor(System.Byte[],System.String)" 的 <param name="resourceId"/> 文档]

参见

引用

BinaryResultArgs 类
BinaryResultArgs 重载


BinaryResultArgs 构造函数 (Byte[], String, ResourceType)

BinaryResultArgs 构造函数 (Byte, String, ResourceType)

初始化 BinaryResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public BinaryResultArgs(
    byte[] data,
    string resourceId,
    ResourceType datatype
)
Public Sub New (
    data As Byte(),
    resourceId As String,
    datatype As ResourceType
)

参数

data
类型：SystemByte

[缺少 "M:Swebui.Controls.BinaryResultArgs.#ctor(System.Byte[],System.String,Swebui.Controls.ResourceType)" 的 <param name="data"/> 文档]

resourceId
类型：SystemString

[缺少 "M:Swebui.Controls.BinaryResultArgs.#ctor(System.Byte[],System.String,Swebui.Controls.ResourceType)" 的 <param name="resourceId"/> 文档]

datatype
类型：Swebui.ControlsResourceType

[缺少 "M:Swebui.Controls.BinaryResultArgs.#ctor(System.Byte[],System.String,Swebui.Controls.ResourceType)" 的 <param name="datatype"/> 文档]

参见

引用

BinaryResultArgs 类
BinaryResultArgs 重载


BinaryResultArgs 属性

BinaryResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | Data | 获取或设置二进制数据
公共属性 | DefaultPath | 获取默认路径
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Length | 获取或设置数据长度
公共属性 | ResourceCount | 获取资源数量
公共属性 | ResourceID | 获取资源编号 (继承自 ResourceResultArgs。)
Top
参见

引用

BinaryResultArgs 类


BinaryResultArgs.Data 属性

BinaryResultArgsData 属性

获取或设置二进制数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public byte[] Data { get; }
Public ReadOnly Property Data As Byte()
    Get

属性值

类型：Byte

返回值

类型：Byte
备注
参见

引用

BinaryResultArgs 类


BinaryResultArgs.DefaultPath 属性

BinaryResultArgsDefaultPath 属性

获取默认路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DefaultPath { get; }
Public ReadOnly Property DefaultPath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

BinaryResultArgs 类


BinaryResultArgs.Length 属性

BinaryResultArgsLength 属性

获取或设置数据长度

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

BinaryResultArgs 类


BinaryResultArgs.ResourceCount 属性

BinaryResultArgsResourceCount 属性

获取资源数量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ResourceCount { get; }
Public ReadOnly Property ResourceCount As Integer
    Get

返回值

类型：Int32
参见

引用

BinaryResultArgs 类


BinaryResultArgs 方法

BinaryResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | SaveFile | 保存文件
公共方法 | SaveFile(String) | 保存文件
公共方法 | SaveFile(ResourceType) | 保存文件
公共方法 | SaveFile(String, ResourceType) | 保存文件
公共方法 | SaveFile(String, String) | 保存文件
 | SaveFileStatic | 保存文件
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
公共方法 | TrySaveFile | 尝试保存文件，如果未保存成功，那么返回False，如果保存成功，那么返回True
Top
参见

引用

BinaryResultArgs 类


BinaryResultArgs.SaveFile 方法

BinaryResultArgsSaveFile 方法

重载列表
 | 名称 | 说明
公共方法 | SaveFile | 保存文件
公共方法 | SaveFile(String) | 保存文件
公共方法 | SaveFile(ResourceType) | 保存文件
公共方法 | SaveFile(String, ResourceType) | 保存文件
公共方法 | SaveFile(String, String) | 保存文件
Top
参见

引用

BinaryResultArgs 类


BinaryResultArgs.SaveFile 方法

BinaryResultArgsSaveFile 方法

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveFile()
Public Sub SaveFile
备注
参见

引用

BinaryResultArgs 类
SaveFile 重载


BinaryResultArgs.SaveFile 方法 (String)

BinaryResultArgsSaveFile 方法 (String)

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveFile(
    string resourceid
)
Public Sub SaveFile (
    resourceid As String
)

参数

resourceid
类型：SystemString
资源名
备注
参见

引用

BinaryResultArgs 类
SaveFile 重载


BinaryResultArgs.SaveFile 方法 (ResourceType)

BinaryResultArgsSaveFile 方法 (ResourceType)

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveFile(
    ResourceType resType
)
Public Sub SaveFile (
    resType As ResourceType
)

参数

resType
类型：Swebui.ControlsResourceType
资源类型
备注
资源类型代表了不同的UploadPath对应的目录
参见

引用

BinaryResultArgs 类
SaveFile 重载


BinaryResultArgs.SaveFile 方法 (String, ResourceType)

BinaryResultArgsSaveFile 方法 (String, ResourceType)

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveFile(
    string resourceid,
    ResourceType resType
)
Public Sub SaveFile (
    resourceid As String,
    resType As ResourceType
)

参数

resourceid
类型：SystemString
资源名称
resType
类型：Swebui.ControlsResourceType
资源类型
备注
>资源类型代表了不同的UploadPath对应的目录
参见

引用

BinaryResultArgs 类
SaveFile 重载


BinaryResultArgs.SaveFile 方法 (String, String)

BinaryResultArgsSaveFile 方法 (String, String)

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SaveFile(
    string resourceid,
    string resourcepath
)
Public Sub SaveFile (
    resourceid As String,
    resourcepath As String
)

参数

resourceid
类型：SystemString
资源名
resourcepath
类型：SystemString
资源路径
备注
参见

引用

BinaryResultArgs 类
SaveFile 重载


BinaryResultArgs.SaveFileStatic 方法

BinaryResultArgsSaveFileStatic 方法

保存文件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void SaveFileStatic(
    byte[] data,
    string resourceid,
    string resourcepath
)
Public Shared Sub SaveFileStatic (
    data As Byte(),
    resourceid As String,
    resourcepath As String
)

参数

data
类型：SystemByte
文件数据
resourceid
类型：SystemString
文件名
resourcepath
类型：SystemString
保存路径
备注
参见

引用

BinaryResultArgs 类


BinaryResultArgs.TrySaveFile 方法

BinaryResultArgsTrySaveFile 方法

尝试保存文件，如果未保存成功，那么返回False，如果保存成功，那么返回True

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool TrySaveFile(
    string resourceid = "",
    string resourcepath = ""
)
Public Function TrySaveFile (
    Optional resourceid As String = "",
    Optional resourcepath As String = ""
) As Boolean

参数

resourceid (Optional)
类型：SystemString
文件名，不赋值的情况下，默认为从客户端上传的文件名
resourcepath (Optional)
类型：SystemString
保存路径，不赋值的情况下，默认为当前系统中的默认路径

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.BinaryResultArgs.TrySaveFile(System.String,System.String)" 的 <returns> 文档]

备注
参见

引用

BinaryResultArgs 类


BinaryResultCallBackHandler 委托

一个委托，它表示客户端返回二进制数据时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void BinaryResultCallBackHandler(
    Object sender,
    BinaryResultArgs e
)
Public Delegate Sub BinaryResultCallBackHandler (
    sender As Object,
    e As BinaryResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsBinaryResultArgs
包含事件数据的 BinaryResultArgs
参见

引用

Swebui.Controls 命名空间


Border 结构

控件边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[SerializableAttribute]
[TypeConverterAttribute(typeof(BorderConverter))]
public struct Border
<SerializableAttribute>
<TypeConverterAttribute(GetType(BorderConverter))>
Public Structure Border

Border 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Border(Single) | 构造函数
公共方法 | Border(Single, Single, Single, Single) | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
字段
名称 | 说明
Empty |
Top
备注
参见

引用

Swebui.Controls 命名空间


Border 构造函数

重载列表
 | 名称 | 说明
公共方法 | Border(Single) | 构造函数
公共方法 | Border(Single, Single, Single, Single) | 构造函数
Top
参见

引用

Border 结构


Border 构造函数 (Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Border(
    float all
)
Public Sub New (
    all As Single
)

参数

all
类型：SystemSingle
所有边距
备注
参见

引用

Border 结构
Border 重载


Border 构造函数 (Single, Single, Single, Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Border(
    float left,
    float top,
    float right,
    float bottom
)
Public Sub New (
    left As Single,
    top As Single,
    right As Single,
    bottom As Single
)

参数

left
类型：SystemSingle
左边距
top
类型：SystemSingle
上边距
right
类型：SystemSingle
右边距
bottom
类型：SystemSingle
下边距
备注
参见

引用

Border 结构
Border 重载


Border 属性

Border 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
参见

引用

Border 结构


Border.All 属性

BorderAll 属性

获取或设置所有边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float All { get; set; }
Public Property All As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Border 结构


Border.Bottom 属性

BorderBottom 属性

获取或设置下边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Bottom { get; set; }
Public Property Bottom As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Border 结构


Border.Left 属性

BorderLeft 属性

获取或设置左边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Left { get; set; }
Public Property Left As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Border 结构


Border.Right 属性

BorderRight 属性

获取或设置右边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Right { get; set; }
Public Property Right As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Border 结构


Border.Top 属性

BorderTop 属性

获取或设置上边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Top { get; set; }
Public Property Top As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Border 结构


Border 方法

Border 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
参见

引用

Border 结构


Border.ToString 方法

BorderToString 方法

[缺少 "M:Swebui.Controls.Border.ToString" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ToString()
Public Overrides Function ToString As String

返回值

类型：String

[缺少 "M:Swebui.Controls.Border.ToString" 的 <returns> 文档]

参见

引用

Border 结构


Border 运算符

Border 类型公开以下成员。

运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
参见

引用

Border 结构


Border.Equality 运算符

BorderEquality 运算符

Implements the operator = operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator ==(
    Border lhs,
    Border rhs
)
Public Shared Operator = (
    lhs As Border,
    rhs As Border
) As Boolean

参数

lhs
类型：Swebui.ControlsBorder
The LHS.
rhs
类型：Swebui.ControlsBorder
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Border 结构


Border.Inequality 运算符

BorderInequality 运算符

Implements the operator <> operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator !=(
    Border lhs,
    Border rhs
)
Public Shared Operator <> (
    lhs As Border,
    rhs As Border
) As Boolean

参数

lhs
类型：Swebui.ControlsBorder
The LHS.
rhs
类型：Swebui.ControlsBorder
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Border 结构


Border 字段

Border 类型公开以下成员。

字段
名称 | 说明
Empty |
Top
参见

引用

Border 结构


Border.Empty 字段

BorderEmpty 字段

[缺少 "F:Swebui.Controls.Border.Empty" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static readonly Border Empty
Public Shared ReadOnly Empty As Border

字段值

类型：Border
参见

引用

Border 结构


BorderConverter 类

Border 类型转换
继承层次
SystemObject
System.ComponentModelTypeConverter
Swebui.ControlsBorderConverter

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class BorderConverter : TypeConverter
Public Class BorderConverter
    Inherits TypeConverter

BorderConverter 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BorderConverter | 初始化 BorderConverter 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
备注
参见

引用

Swebui.Controls 命名空间


BorderConverter 构造函数

初始化 BorderConverter 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public BorderConverter()
Public Sub New
参见

引用

BorderConverter 类


BorderConverter 方法

BorderConverter 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
参见

引用

BorderConverter 类


BorderConverter.CanConvertFrom 方法

BorderConverterCanConvertFrom 方法

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

sourceType
类型：SystemType

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="sourceType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.CanConvertTo 方法

BorderConverterCanConvertTo 方法

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.BorderConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.ConvertFrom 方法

BorderConverterConvertFrom 方法

[缺少 "M:Swebui.Controls.BorderConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.BorderConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.BorderConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.BorderConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.ConvertTo 方法

BorderConverterConvertTo 方法

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="value"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.BorderConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.CreateInstance 方法

BorderConverterCreateInstance 方法

[缺少 "M:Swebui.Controls.BorderConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Public Overrides Function CreateInstance (
    context As ITypeDescriptorContext,
    propertyValues As IDictionary
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="context"/> 文档]

propertyValues
类型：System.CollectionsIDictionary

[缺少 "M:Swebui.Controls.BorderConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="propertyValues"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.BorderConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.GetCreateInstanceSupported 方法

BorderConverterGetCreateInstanceSupported 方法

[缺少 "M:Swebui.Controls.BorderConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetCreateInstanceSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.BorderConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.GetProperties 方法

BorderConverterGetProperties 方法

[缺少 "M:Swebui.Controls.BorderConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="context"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.BorderConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="value"/> 文档]

attributes
类型：SystemAttribute

[缺少 "M:Swebui.Controls.BorderConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="attributes"/> 文档]

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.Controls.BorderConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderConverter.GetPropertiesSupported 方法

BorderConverterGetPropertiesSupported 方法

[缺少 "M:Swebui.Controls.BorderConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.BorderConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.BorderConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

BorderConverter 类


BorderStyle 枚举

边框样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum BorderStyle
Public Enumeration BorderStyle
成员
成员名称 | 值 | 说明
Solid | 0 | 实线
Dotted | 1 | 点状线
Dashed | 2 | 虚线
参见

引用

Swebui.Controls 命名空间


Button 类

按钮控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsButton

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Button : SwebBindableControl, ISwebRenderControl,
    ISwebEventControl
Public Class Button
    Inherits SwebBindableControl
    Implements ISwebRenderControl, ISwebEventControl

Button 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Button | 构建函数
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取和设置控件的前景色，用于显示文本。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | IconLocation | 获取和设置控件图标位置
公共属性 | IconName | 获取和设置控件图标
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | LineHeight | 获取或设置行高
公共属性 | LineThrough | 获取或设置文本中划线
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | NumberOfLines | 获取或设置控件水平方向
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取或设置一个值，该值指示是否触发离开和进入事件。
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectBackgroundColor | 获取和设置鼠标悬停在button上时背景颜色。
公共属性 | SelectColor | 获取和设置鼠标悬停在button上时文字颜色。
公共属性 | SelectTextDecorationLine | 获取和设置鼠标悬停在button上时下划线类型。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取或设置与此控件关联的文本。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Underline | 获取或设置文本下划线
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | Click | 在按钮点击时发生。
公共事件 | MouseEnter | 鼠标进入button位置时触发。
公共事件 | MouseLeave | 鼠标离开button位置时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Button 构造函数

构建函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Button()
Public Sub New
参见

引用

Button 类


Button 属性

Button 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取和设置控件的前景色，用于显示文本。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | IconLocation | 获取和设置控件图标位置
公共属性 | IconName | 获取和设置控件图标
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | LineHeight | 获取或设置行高
公共属性 | LineThrough | 获取或设置文本中划线
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | NumberOfLines | 获取或设置控件水平方向
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取或设置一个值，该值指示是否触发离开和进入事件。
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectBackgroundColor | 获取和设置鼠标悬停在button上时背景颜色。
公共属性 | SelectColor | 获取和设置鼠标悬停在button上时文字颜色。
公共属性 | SelectTextDecorationLine | 获取和设置鼠标悬停在button上时下划线类型。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取或设置与此控件关联的文本。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Underline | 获取或设置文本下划线
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Button 类


Button.BindDisplayValue 属性

ButtonBindDisplayValue 属性

获取和设置绑定控件默认绑定值

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

Button 类


Button.Bold 属性

ButtonBold 属性

获取或设置文本粗体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button.Enabled 属性

ButtonEnabled 属性

获取或设置一个值，该值指示是否已启用该控件。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button.FontFamily 属性

ButtonFontFamily 属性

获取和设置控件字体。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string FontFamily { get; set; }
Public Property FontFamily As String
    Get
    Set

属性值

类型：String
参见

引用

Button 类


Button.FontSize 属性

ButtonFontSize 属性

获取或设置控件字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

Button 类


Button.ForeColor 属性

ButtonForeColor 属性

获取和设置控件的前景色，用于显示文本。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Button 类


Button.HorizontalAlignment 属性

ButtonHorizontalAlignment 属性

获取或设置控件水平方向

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set

属性值

类型：HorizontalAlignment
参见

引用

Button 类


Button.IconLocation 属性

ButtonIconLocation 属性

获取和设置控件图标位置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ButtonIconLocation IconLocation { get; set; }
Public Property IconLocation As ButtonIconLocation
    Get
    Set

属性值

类型：ButtonIconLocation
参见

引用

Button 类


Button.IconName 属性

ButtonIconName 属性

获取和设置控件图标

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string IconName { get; set; }
Public Property IconName As String
    Get
    Set

属性值

类型：String
参见

引用

Button 类


Button.Italic 属性

ButtonItalic 属性

获取或设置文本斜体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button.LineHeight 属性

ButtonLineHeight 属性

获取或设置行高

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float LineHeight { get; set; }
Public Property LineHeight As Single
    Get
    Set

属性值

类型：Single
参见

引用

Button 类


Button.LineThrough 属性

ButtonLineThrough 属性

获取或设置文本中划线

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool LineThrough { get; set; }
Public Property LineThrough As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button.NumberOfLines 属性

ButtonNumberOfLines 属性

获取或设置控件水平方向

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int NumberOfLines { get; set; }
Public Property NumberOfLines As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Button 类


Button.RaiseMouseEvent 属性

ButtonRaiseMouseEvent 属性

获取或设置一个值，该值指示是否触发离开和进入事件。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool RaiseMouseEvent { get; set; }
Public Property RaiseMouseEvent As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button.SelectBackgroundColor 属性

ButtonSelectBackgroundColor 属性

获取和设置鼠标悬停在button上时背景颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectBackgroundColor { get; set; }
Public Property SelectBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Button 类


Button.SelectColor 属性

ButtonSelectColor 属性

获取和设置鼠标悬停在button上时文字颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectColor { get; set; }
Public Property SelectColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Button 类


Button.SelectTextDecorationLine 属性

ButtonSelectTextDecorationLine 属性

获取和设置鼠标悬停在button上时下划线类型。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TextDecorationLineType SelectTextDecorationLine { get; set; }
Public Property SelectTextDecorationLine As TextDecorationLineType
    Get
    Set

属性值

类型：TextDecorationLineType
参见

引用

Button 类


Button.Text 属性

ButtonText 属性

获取或设置与此控件关联的文本。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

Button 类


Button.Underline 属性

ButtonUnderline 属性

获取或设置文本下划线

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Underline { get; set; }
Public Property Underline As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Button 类


Button 方法

Button 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Button 类


Button 事件

Button 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Click | 在按钮点击时发生。
公共事件 | MouseEnter | 鼠标进入button位置时触发。
公共事件 | MouseLeave | 鼠标离开button位置时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Button 类


Button.Click 事件

ButtonClick 事件

在按钮点击时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler Click
Public Event Click As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

Button 类


Button.MouseEnter 事件

ButtonMouseEnter 事件

鼠标进入button位置时触发。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event SwebMouseMoveEventHandler MouseEnter
Public Event MouseEnter As SwebMouseMoveEventHandler

值

类型：Swebui.ControlsSwebMouseMoveEventHandler
备注
参见

引用

Button 类


Button.MouseLeave 事件

ButtonMouseLeave 事件

鼠标离开button位置时触发。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event SwebMouseMoveEventHandler MouseLeave
Public Event MouseLeave As SwebMouseMoveEventHandler

值

类型：Swebui.ControlsSwebMouseMoveEventHandler
备注
参见

引用

Button 类


ButtonIconLocation 枚举

图标显示位置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum ButtonIconLocation
Public Enumeration ButtonIconLocation
成员
成员名称 | 值 | 说明
Left | 0 | 图标在左侧
Right | 1 | 图标在右侧
参见

引用

Swebui.Controls 命名空间


Calendar 类

日历控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsCalendar

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Calendar : SwebControl, ISwebRenderControl,
    ISwebEventControl
Public Class Calendar
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl

Calendar 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Calendar | 初始化Calendar类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DayForeColor | 获取和设置显示月份的日期字体颜色
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisabledDayForeColor | 获取和设置不在显示月份的日期字体颜色
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectDate | 获取或设置选择日期
公共属性 | SelectDateBackColor | 获取和设置选择日期背景颜色
公共属性 | SelectDateForeColor | 获取和设置选择日期字体颜色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TodayForeColor | 获取和设置当前日期字体颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WeekForeColor | 星期行字体颜色
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | DateChanged |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Calendar 构造函数

初始化Calendar类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Calendar()
Public Sub New
参见

引用

Calendar 类


Calendar 属性

Calendar 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DayForeColor | 获取和设置显示月份的日期字体颜色
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisabledDayForeColor | 获取和设置不在显示月份的日期字体颜色
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectDate | 获取或设置选择日期
公共属性 | SelectDateBackColor | 获取和设置选择日期背景颜色
公共属性 | SelectDateForeColor | 获取和设置选择日期字体颜色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TodayForeColor | 获取和设置当前日期字体颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WeekForeColor | 星期行字体颜色
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Calendar 类


Calendar.DayForeColor 属性

CalendarDayForeColor 属性

获取和设置显示月份的日期字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color DayForeColor { get; set; }
Public Property DayForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar.DisabledDayForeColor 属性

CalendarDisabledDayForeColor 属性

获取和设置不在显示月份的日期字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color DisabledDayForeColor { get; set; }
Public Property DisabledDayForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar.SelectDate 属性

CalendarSelectDate 属性

获取或设置选择日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime SelectDate { get; set; }
Public Property SelectDate As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

Calendar 类


Calendar.SelectDateBackColor 属性

CalendarSelectDateBackColor 属性

获取和设置选择日期背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectDateBackColor { get; set; }
Public Property SelectDateBackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar.SelectDateForeColor 属性

CalendarSelectDateForeColor 属性

获取和设置选择日期字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectDateForeColor { get; set; }
Public Property SelectDateForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar.TodayForeColor 属性

CalendarTodayForeColor 属性

获取和设置当前日期字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TodayForeColor { get; set; }
Public Property TodayForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar.WeekForeColor 属性

CalendarWeekForeColor 属性

星期行字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color WeekForeColor { get; set; }
Public Property WeekForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Calendar 类


Calendar 方法

Calendar 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Calendar 类


Calendar 事件

Calendar 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | DateChanged |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Calendar 类


Calendar.DateChanged 事件

CalendarDateChanged 事件

[缺少 "E:Swebui.Controls.Calendar.DateChanged" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler DateChanged
Public Event DateChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

Calendar 类


CameraMethod 枚举

Camera 拍照模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum CameraMethod
Public Enumeration CameraMethod
成员
成员名称 | 值 | 说明
ImageFromAlbum | 0 | 直接打开文件夹
MultiImage | 1 | 多图上传
VideoFromAlbum | 2 | 获取文件夹中的视频
参见

引用

Swebui.Controls 命名空间


CameraQialityMode 枚举

Camera 上传模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum CameraQialityMode
Public Enumeration CameraQialityMode
成员
成员名称 | 值 | 说明
Original | 0 | 原画上传
Compress | 1 | 压缩上传
参见

引用

Swebui.Controls 命名空间


CheckBox 类

复选框控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebCheckedControlBase
Swebui.ControlsCheckBox

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class CheckBox : SwebCheckedControlBase, ISwebRenderControl,
    ISwebEventControl
Public Class CheckBox
    Inherits SwebCheckedControlBase
    Implements ISwebRenderControl, ISwebEventControl

CheckBox 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CheckBox | 初始化CheckBox类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (继承自 SwebCheckedControlBase。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态 (继承自 SwebCheckedControlBase。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (继承自 SwebCheckedControlBase。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | (继承自 SwebCheckedControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | ImageType | 获取和设置checkbox样式
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TintColor | 获取和设置样式颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | CheckedChanged | (继承自 SwebCheckedControlBase。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


CheckBox 构造函数

初始化CheckBox类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public CheckBox()
Public Sub New
参见

引用

CheckBox 类


CheckBox 属性

CheckBox 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (继承自 SwebCheckedControlBase。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态 (继承自 SwebCheckedControlBase。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (继承自 SwebCheckedControlBase。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | (继承自 SwebCheckedControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | ImageType | 获取和设置checkbox样式
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TintColor | 获取和设置样式颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

CheckBox 类


CheckBox.BackColor 属性

CheckBoxBackColor 属性

[缺少 "P:Swebui.Controls.CheckBox.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

CheckBox 类


CheckBox.Border 属性

CheckBoxBorder 属性

[缺少 "P:Swebui.Controls.CheckBox.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

CheckBox 类


CheckBox.BorderColor 属性

CheckBoxBorderColor 属性

[缺少 "P:Swebui.Controls.CheckBox.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

CheckBox 类


CheckBox.BorderRadius 属性

CheckBoxBorderRadius 属性

[缺少 "P:Swebui.Controls.CheckBox.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

CheckBox 类


CheckBox.BorderStyle 属性

CheckBoxBorderStyle 属性

[缺少 "P:Swebui.Controls.CheckBox.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

CheckBox 类


CheckBox.ImageType 属性

CheckBoxImageType 属性

获取和设置checkbox样式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public CheckBoxStyle ImageType { get; set; }
Public Property ImageType As CheckBoxStyle
    Get
    Set

属性值

类型：CheckBoxStyle
参见

引用

CheckBox 类


CheckBox.TintColor 属性

CheckBoxTintColor 属性

获取和设置样式颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TintColor { get; set; }
Public Property TintColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

CheckBox 类


CheckBox 方法

CheckBox 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

CheckBox 类


CheckBox 事件

CheckBox 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | CheckedChanged | (继承自 SwebCheckedControlBase。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

CheckBox 类


CheckBoxStyle 枚举

CheckBox样式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum CheckBoxStyle
Public Enumeration CheckBoxStyle
成员
成员名称 | 值 | 说明
Square | 0 | 方式
Circular | 1 | 圆形
参见

引用

Swebui.Controls 命名空间


ChooseDatePicker 类

日期选择控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsChooseDatePicker

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ChooseDatePicker : SwebBindableControl,
    ISwebRenderControl, ISwebEventControl
Public Class ChooseDatePicker
    Inherits SwebBindableControl
    Implements ISwebRenderControl, ISwebEventControl

ChooseDatePicker 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ChooseDatePicker | 初始化 ChooseDatePicker 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Disabled | 获取和设置是否禁止点击
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | ForeColor | 获取和设置字体颜色
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Format | 获取和设置是否禁止点击
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxDate | 获取和设置最大日期
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinDate | 获取和设置最小日期
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Mode | 获取和设置日期/时间显示模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 获取和设置水印文本
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置Value
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
参见

引用

Swebui.Controls 命名空间


ChooseDatePicker 构造函数

初始化 ChooseDatePicker 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePicker()
Public Sub New
参见

引用

ChooseDatePicker 类


ChooseDatePicker 属性

ChooseDatePicker 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Disabled | 获取和设置是否禁止点击
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | ForeColor | 获取和设置字体颜色
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Format | 获取和设置是否禁止点击
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxDate | 获取和设置最大日期
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinDate | 获取和设置最小日期
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Mode | 获取和设置日期/时间显示模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 获取和设置水印文本
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置Value
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

ChooseDatePicker 类


ChooseDatePicker.BindDisplayValue 属性

ChooseDatePickerBindDisplayValue 属性

[缺少 "P:Swebui.Controls.ChooseDatePicker.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

ChooseDatePicker 类


ChooseDatePicker.Disabled 属性

ChooseDatePickerDisabled 属性

获取和设置是否禁止点击

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Disabled { get; set; }
Public Property Disabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

ChooseDatePicker 类


ChooseDatePicker.FontSize 属性

ChooseDatePickerFontSize 属性

获取和设置字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

ChooseDatePicker 类


ChooseDatePicker.ForeColor 属性

ChooseDatePickerForeColor 属性

获取和设置字体颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

ChooseDatePicker 类


ChooseDatePicker.Format 属性

ChooseDatePickerFormat 属性

获取和设置是否禁止点击

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePickerFormat Format { get; set; }
Public Property Format As ChooseDatePickerFormat
    Get
    Set

属性值

类型：ChooseDatePickerFormat
参见

引用

ChooseDatePicker 类


ChooseDatePicker.MaxDate 属性

ChooseDatePickerMaxDate 属性

获取和设置最大日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MaxDate { get; set; }
Public Property MaxDate As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

ChooseDatePicker 类


ChooseDatePicker.MinDate 属性

ChooseDatePickerMinDate 属性

获取和设置最小日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MinDate { get; set; }
Public Property MinDate As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

ChooseDatePicker 类


ChooseDatePicker.Mode 属性

ChooseDatePickerMode 属性

获取和设置日期/时间显示模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePickerMode Mode { get; set; }
Public Property Mode As ChooseDatePickerMode
    Get
    Set

属性值

类型：ChooseDatePickerMode
参见

引用

ChooseDatePicker 类


ChooseDatePicker.Placeholder 属性

ChooseDatePickerPlaceholder 属性

获取和设置水印文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePlaceholder Placeholder { get; set; }
Public Property Placeholder As ChooseDatePlaceholder
    Get
    Set

属性值

类型：ChooseDatePlaceholder
参见

引用

ChooseDatePicker 类


ChooseDatePicker.Value 属性

ChooseDatePickerValue 属性

获取和设置Value

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDateValue Value { get; set; }
Public Property Value As ChooseDateValue
    Get
    Set

属性值

类型：ChooseDateValue
参见

引用

ChooseDatePicker 类


ChooseDatePicker 方法

ChooseDatePicker 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
参见

引用

ChooseDatePicker 类


ChooseDatePicker.OnEventRaised 方法

ChooseDatePickerOnEventRaised 方法

[缺少 "M:Swebui.Controls.ChooseDatePicker.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.ChooseDatePicker.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

ChooseDatePicker 类


ChooseDatePicker 事件

ChooseDatePicker 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
参见

引用

ChooseDatePicker 类


ChooseDatePicker.ValueChanged 事件

ChooseDatePickerValueChanged 事件

在值改变时时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

ChooseDatePicker 类


ChooseDatePickerFormat 枚举

日期形式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum ChooseDatePickerFormat
Public Enumeration ChooseDatePickerFormat
成员
成员名称 | 值 | 说明
Y | 0 | 年
YM | 1 | 年月
YMD | 2 | 年月日
参见

引用

Swebui.Controls 命名空间


ChooseDatePickerMode 枚举

显示模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum ChooseDatePickerMode
Public Enumeration ChooseDatePickerMode
成员
成员名称 | 值 | 说明
DateRange | 0 | 显示年月日时间段
DateTimeRange | 1 | 显示年月日和小时时间段
TimeRange | 2 | 显示小时时间段
参见

引用

Swebui.Controls 命名空间


ChooseDatePlaceholder 类

[缺少 "T:Swebui.Controls.ChooseDatePlaceholder" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsChooseDatePlaceholder

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ChooseDatePlaceholder
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ChooseDatePlaceholder

ChooseDatePlaceholder 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ChooseDatePlaceholder | 初始化 ChooseDatePlaceholder 类的一个新实例
公共方法 | ChooseDatePlaceholder(String, String) | 初始化 ChooseDatePlaceholder 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BeginPlaceholder | 开始日期框水印
公共属性 | EndPlaceHolder | 结束日期框水印
Top
参见

引用

Swebui.Controls 命名空间


ChooseDatePlaceholder 构造函数

重载列表
 | 名称 | 说明
公共方法 | ChooseDatePlaceholder | 初始化 ChooseDatePlaceholder 类的一个新实例
公共方法 | ChooseDatePlaceholder(String, String) | 初始化 ChooseDatePlaceholder 类的一个新实例
Top
参见

引用

ChooseDatePlaceholder 类


ChooseDatePlaceholder 构造函数

初始化 ChooseDatePlaceholder 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePlaceholder()
Public Sub New
参见

引用

ChooseDatePlaceholder 类
ChooseDatePlaceholder 重载


ChooseDatePlaceholder 构造函数 (String, String)

初始化 ChooseDatePlaceholder 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDatePlaceholder(
    string beginPlaceHolder,
    string endPlaceHolder
)
Public Sub New (
    beginPlaceHolder As String,
    endPlaceHolder As String
)

参数

beginPlaceHolder
类型：SystemString

[缺少 "M:Swebui.Controls.ChooseDatePlaceholder.#ctor(System.String,System.String)" 的 <param name="beginPlaceHolder"/> 文档]

endPlaceHolder
类型：SystemString

[缺少 "M:Swebui.Controls.ChooseDatePlaceholder.#ctor(System.String,System.String)" 的 <param name="endPlaceHolder"/> 文档]

参见

引用

ChooseDatePlaceholder 类
ChooseDatePlaceholder 重载


ChooseDatePlaceholder 属性

ChooseDatePlaceholder 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BeginPlaceholder | 开始日期框水印
公共属性 | EndPlaceHolder | 结束日期框水印
Top
参见

引用

ChooseDatePlaceholder 类


ChooseDatePlaceholder.BeginPlaceholder 属性

ChooseDatePlaceholderBeginPlaceholder 属性

开始日期框水印

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string BeginPlaceholder { get; set; }
Public Property BeginPlaceholder As String
    Get
    Set

属性值

类型：String
备注
当Mode设置为TimeRanges时，只显示BeginPlaceHolder
参见

引用

ChooseDatePlaceholder 类


ChooseDatePlaceholder.EndPlaceHolder 属性

ChooseDatePlaceholderEndPlaceHolder 属性

结束日期框水印

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string EndPlaceHolder { get; set; }
Public Property EndPlaceHolder As String
    Get
    Set

属性值

类型：String
参见

引用

ChooseDatePlaceholder 类


ChooseDateValue 类

[缺少 "T:Swebui.Controls.ChooseDateValue" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsChooseDateValue

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ChooseDateValue
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ChooseDateValue

ChooseDateValue 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ChooseDateValue | 初始化 ChooseDateValue 类的一个新实例
公共方法 | ChooseDateValue(NullableDateTime, NullableDateTime) | 初始化 ChooseDateValue 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BeginDate |
公共属性 | EndDate |
Top
参见

引用

Swebui.Controls 命名空间


ChooseDateValue 构造函数

重载列表
 | 名称 | 说明
公共方法 | ChooseDateValue | 初始化 ChooseDateValue 类的一个新实例
公共方法 | ChooseDateValue(NullableDateTime, NullableDateTime) | 初始化 ChooseDateValue 类的一个新实例
Top
参见

引用

ChooseDateValue 类


ChooseDateValue 构造函数

初始化 ChooseDateValue 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDateValue()
Public Sub New
参见

引用

ChooseDateValue 类
ChooseDateValue 重载


ChooseDateValue 构造函数 (Nullable(DateTime), Nullable(DateTime))

ChooseDateValue 构造函数 (NullableDateTime, NullableDateTime)

初始化 ChooseDateValue 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ChooseDateValue(
    DateTime? start,
    DateTime? end
)
Public Sub New (
    start As DateTime?,
    end As DateTime?
)

参数

start
类型：SystemNullable DateTime

[缺少 "M:Swebui.Controls.ChooseDateValue.#ctor(System.Nullable{System.DateTime},System.Nullable{System.DateTime})" 的 <param name="start"/> 文档]

end
类型：SystemNullable DateTime

[缺少 "M:Swebui.Controls.ChooseDateValue.#ctor(System.Nullable{System.DateTime},System.Nullable{System.DateTime})" 的 <param name="end"/> 文档]

参见

引用

ChooseDateValue 类
ChooseDateValue 重载


ChooseDateValue 属性

ChooseDateValue 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BeginDate |
公共属性 | EndDate |
Top
参见

引用

ChooseDateValue 类


ChooseDateValue.BeginDate 属性

ChooseDateValueBeginDate 属性

[缺少 "P:Swebui.Controls.ChooseDateValue.BeginDate" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime? BeginDate { get; set; }
Public Property BeginDate As DateTime?
    Get
    Set

属性值

类型：Nullable DateTime
参见

引用

ChooseDateValue 类


ChooseDateValue.EndDate 属性

ChooseDateValueEndDate 属性

[缺少 "P:Swebui.Controls.ChooseDateValue.EndDate" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime? EndDate { get; set; }
Public Property EndDate As DateTime?
    Get
    Set

属性值

类型：Nullable DateTime
参见

引用

ChooseDateValue 类


ClientDataResultHandlerArgs 类

为 ClientDataCallBackHandler 提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClientDataResultHandlerArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientDataResultHandlerArgs : ResultArgs
Public Class ClientDataResultHandlerArgs
    Inherits ResultArgs

ClientDataResultHandlerArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientDataResultHandlerArgs | 初始化 ClientDataResultHandlerArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Key | 客户端数据键
公共属性 | Value | 客户端数据值
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui.Controls 命名空间


ClientDataResultHandlerArgs 构造函数

初始化 ClientDataResultHandlerArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientDataResultHandlerArgs()
Public Sub New
参见

引用

ClientDataResultHandlerArgs 类


ClientDataResultHandlerArgs 属性

ClientDataResultHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Key | 客户端数据键
公共属性 | Value | 客户端数据值
Top
参见

引用

ClientDataResultHandlerArgs 类


ClientDataResultHandlerArgs.Key 属性

ClientDataResultHandlerArgsKey 属性

客户端数据键

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Key { get; }
Public ReadOnly Property Key As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientDataResultHandlerArgs 类


ClientDataResultHandlerArgs.Value 属性

ClientDataResultHandlerArgsValue 属性

客户端数据值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Value { get; }
Public ReadOnly Property Value As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientDataResultHandlerArgs 类


ClientDataResultHandlerArgs 方法

ClientDataResultHandlerArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientDataResultHandlerArgs 类


ClientResourceGetResultArgs 类

为GetClientResourceHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClientResourceGetResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientResourceGetResultArgs : ResultArgs
Public Class ClientResourceGetResultArgs
    Inherits ResultArgs

ClientResourceGetResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientResourceGetResultArgs | 初始化 ClientResourceGetResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取资源数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Resouces | 获取资源列表
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui.Controls 命名空间


ClientResourceGetResultArgs 构造函数

初始化 ClientResourceGetResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceGetResultArgs()
Public Sub New
参见

引用

ClientResourceGetResultArgs 类


ClientResourceGetResultArgs 属性

ClientResourceGetResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取资源数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Resouces | 获取资源列表
Top
参见

引用

ClientResourceGetResultArgs 类


ClientResourceGetResultArgs.Count 属性

ClientResourceGetResultArgsCount 属性

获取资源数量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

ClientResourceGetResultArgs 类


ClientResourceGetResultArgs.Resouces 属性

ClientResourceGetResultArgsResouces 属性

获取资源列表

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceGetResultArgsResourceData[] Resouces { get; }
Public ReadOnly Property Resouces As ClientResourceGetResultArgsResourceData()
    Get

属性值

类型：ClientResourceGetResultArgsResourceData

返回值

类型：ClientResourceGetResultArgsResourceData
备注
参见

引用

ClientResourceGetResultArgs 类


ClientResourceGetResultArgs 方法

ClientResourceGetResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientResourceGetResultArgs 类


ClientResourceGetResultArgs.ResourceData 结构

ClientResourceGetResultArgsResourceData 结构

资源数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public struct ResourceData
Public Structure ResourceData

ClientResourceGetResultArgsResourceData 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceID | 资源名称
公共属性 | ResourceSize | 资源大小
公共属性 | ResrouceDate | 资源创建时间
Top
备注
参见

引用

Swebui.Controls 命名空间


ResourceData 属性

ClientResourceGetResultArgsResourceData 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceID | 资源名称
公共属性 | ResourceSize | 资源大小
公共属性 | ResrouceDate | 资源创建时间
Top
参见

引用

ClientResourceGetResultArgsResourceData 结构


ClientResourceGetResultArgs.ResourceData.ResourceID 属性

ClientResourceGetResultArgsResourceDataResourceID 属性

资源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourceID { get; set; }
Public Property ResourceID As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientResourceGetResultArgsResourceData 结构


ClientResourceGetResultArgs.ResourceData.ResourceSize 属性

ClientResourceGetResultArgsResourceDataResourceSize 属性

资源大小

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ResourceSize { get; set; }
Public Property ResourceSize As Integer
    Get
    Set

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

ClientResourceGetResultArgsResourceData 结构


ClientResourceGetResultArgs.ResourceData.ResrouceDate 属性

ClientResourceGetResultArgsResourceDataResrouceDate 属性

资源创建时间

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DateTime ResrouceDate { get; set; }
Public Property ResrouceDate As DateTime
    Get
    Set

属性值

类型：DateTime

返回值

类型：DateTime
备注
参见

引用

ClientResourceGetResultArgsResourceData 结构


ClientResourceLoadResultArgs 类

为 LoadClientResourceHandler 提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClientResourceLoadResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientResourceLoadResultArgs : ResultArgs
Public Class ClientResourceLoadResultArgs
    Inherits ResultArgs

ClientResourceLoadResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientResourceLoadResultArgs | 初始化 ClientResourceLoadResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 载入总数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceID | 当前载入资源名称
公共属性 | ResourcePath | 当前载入资源路径
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui.Controls 命名空间


ClientResourceLoadResultArgs 构造函数

初始化 ClientResourceLoadResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceLoadResultArgs()
Public Sub New
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceLoadResultArgs 属性

ClientResourceLoadResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 载入总数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceID | 当前载入资源名称
公共属性 | ResourcePath | 当前载入资源路径
Top
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceLoadResultArgs.Count 属性

ClientResourceLoadResultArgsCount 属性

载入总数量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceLoadResultArgs.ResourceID 属性

ClientResourceLoadResultArgsResourceID 属性

当前载入资源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourceID { get; }
Public ReadOnly Property ResourceID As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceLoadResultArgs.ResourcePath 属性

ClientResourceLoadResultArgsResourcePath 属性

当前载入资源路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourcePath { get; }
Public ReadOnly Property ResourcePath As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceLoadResultArgs 方法

ClientResourceLoadResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientResourceLoadResultArgs 类


ClientResourceRemoveResultArgs 类

为RemoveClientResourceHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClientResourceRemoveResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientResourceRemoveResultArgs : ResultArgs
Public Class ClientResourceRemoveResultArgs
    Inherits ResultArgs

ClientResourceRemoveResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientResourceRemoveResultArgs | 初始化 ClientResourceRemoveResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 删除的资源数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui.Controls 命名空间


ClientResourceRemoveResultArgs 构造函数

初始化 ClientResourceRemoveResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceRemoveResultArgs()
Public Sub New
参见

引用

ClientResourceRemoveResultArgs 类


ClientResourceRemoveResultArgs 属性

ClientResourceRemoveResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 删除的资源数量
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientResourceRemoveResultArgs 类


ClientResourceRemoveResultArgs.Count 属性

ClientResourceRemoveResultArgsCount 属性

删除的资源数量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

ClientResourceRemoveResultArgs 类


ClientResourceRemoveResultArgs 方法

ClientResourceRemoveResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientResourceRemoveResultArgs 类


ClientResourceResultArgs 类

为ClientResourceCallBack提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsClientResourceResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ClientResourceResultArgs : SwebComponentResultArgs
Public Class ClientResourceResultArgs
    Inherits SwebComponentResultArgs

ClientResourceResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClientResourceResultArgs | 初始化 ClientResourceResultArgs 类的一个新实例
公共方法 | ClientResourceResultArgs(DictionaryString, String) | 初始化 ClientResourceResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Resources | 获取资源字典。key=[资源名称] value=[资源路径]
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


ClientResourceResultArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | ClientResourceResultArgs | 初始化 ClientResourceResultArgs 类的一个新实例
公共方法 | ClientResourceResultArgs(DictionaryString, String) | 初始化 ClientResourceResultArgs 类的一个新实例
Top
参见

引用

ClientResourceResultArgs 类


ClientResourceResultArgs 构造函数

初始化 ClientResourceResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceResultArgs()
Public Sub New
参见

引用

ClientResourceResultArgs 类
ClientResourceResultArgs 重载


ClientResourceResultArgs 构造函数 (Dictionary(String, String))

ClientResourceResultArgs 构造函数 (DictionaryString, String)

初始化 ClientResourceResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ClientResourceResultArgs(
    Dictionary<string, string> resource
)
Public Sub New (
    resource As Dictionary(Of String, String)
)

参数

resource
类型：System.Collections.GenericDictionary String, String

[缺少 "M:Swebui.Controls.ClientResourceResultArgs.#ctor(System.Collections.Generic.Dictionary{System.String,System.String})" 的 <param name="resource"/> 文档]

参见

引用

ClientResourceResultArgs 类
ClientResourceResultArgs 重载


ClientResourceResultArgs 属性

ClientResourceResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Resources | 获取资源字典。key=[资源名称] value=[资源路径]
Top
参见

引用

ClientResourceResultArgs 类


ClientResourceResultArgs.Resources 属性

ClientResourceResultArgsResources 属性

获取资源字典。key=[资源名称] value=[资源路径]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, string> Resources { get; }
Public ReadOnly Property Resources As Dictionary(Of String, String)
    Get

返回值

类型：Dictionary String, String
参见

引用

ClientResourceResultArgs 类


ClientResourceResultArgs 方法

ClientResourceResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClientResourceResultArgs 类


ClipboardResultArgs 类

为ClipboardResultHandler提供数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsClipboardResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ClipboardResultArgs : ResultArgs
Public Class ClipboardResultArgs
    Inherits ResultArgs

ClipboardResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClipboardResultArgs | 获取ClipboardResultArgs实例
公共方法 | ClipboardResultArgs(String) | 获取ClipboardResultArgs实例
Top
属性
 | 名称 | 说明
公共属性 | Data | 获取粘贴板数据
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


ClipboardResultArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | ClipboardResultArgs | 获取ClipboardResultArgs实例
公共方法 | ClipboardResultArgs(String) | 获取ClipboardResultArgs实例
Top
参见

引用

ClipboardResultArgs 类


ClipboardResultArgs 构造函数

获取ClipboardResultArgs实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ClipboardResultArgs()
Public Sub New
参见

引用

ClipboardResultArgs 类
ClipboardResultArgs 重载


ClipboardResultArgs 构造函数 (String)

获取ClipboardResultArgs实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ClipboardResultArgs(
    string data
)
Public Sub New (
    data As String
)

参数

data
类型：SystemString

[缺少 "M:Swebui.Controls.ClipboardResultArgs.#ctor(System.String)" 的 <param name="data"/> 文档]

参见

引用

ClipboardResultArgs 类
ClipboardResultArgs 重载


ClipboardResultArgs 属性

ClipboardResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data | 获取粘贴板数据
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClipboardResultArgs 类


ClipboardResultArgs.Data 属性

ClipboardResultArgsData 属性

获取粘贴板数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Data { get; }
Public ReadOnly Property Data As String
    Get

属性值

类型：String
参见

引用

ClipboardResultArgs 类


ClipboardResultArgs 方法

ClipboardResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ClipboardResultArgs 类


ColorPropertyExtend 类

颜色属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsColorPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ColorPropertyExtend : SwebPropertyExtend
Public Class ColorPropertyExtend
    Inherits SwebPropertyExtend

ColorPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ColorPropertyExtend | 初始化 ColorPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间
Swebui.ControlsSwebPropertyExtend


ColorPropertyExtend 构造函数

初始化 ColorPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ColorPropertyExtend()
Public Sub New
参见

引用

ColorPropertyExtend 类


ComboBox 类

下拉列表控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebTextControl
Swebui.ControlsComboBox

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ComboBox : SwebTextControl, ISwebRenderControl,
    ISwebEventControl, ISwebViewCollectionOwner
Public Class ComboBox
    Inherits SwebTextControl
    Implements ISwebRenderControl, ISwebEventControl, ISwebViewCollectionOwner

ComboBox 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ComboBox | 初始化ComboBox类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | Items | 获取菜单元素集合。
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder |
公共属性 | PopupHeight |
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectKey |
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowClearButton |
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SortOrder |
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 内容更改时触发回调
公共方法 | SetSelectItem | 设置默认项
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时发生
Top
参见

引用

Swebui.Controls 命名空间


ComboBox 构造函数

初始化ComboBox类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ComboBox()
Public Sub New
参见

引用

ComboBox 类


ComboBox 属性

ComboBox 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | Items | 获取菜单元素集合。
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder |
公共属性 | PopupHeight |
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectKey |
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowClearButton |
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SortOrder |
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

ComboBox 类


ComboBox.Items 属性

ComboBoxItems 属性

获取菜单元素集合。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ComboBoxItemCollection Items { get; }
Public ReadOnly Property Items As ComboBoxItemCollection
    Get

属性值

类型：ComboBoxItemCollection
参见

引用

ComboBox 类


ComboBox.Placeholder 属性

ComboBoxPlaceholder 属性

[缺少 "P:Swebui.Controls.ComboBox.Placeholder" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Placeholder { get; set; }
Public Property Placeholder As String
    Get
    Set

属性值

类型：String
参见

引用

ComboBox 类


ComboBox.PopupHeight 属性

ComboBoxPopupHeight 属性

[缺少 "P:Swebui.Controls.ComboBox.PopupHeight" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PopupHeight { get; set; }
Public Property PopupHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ComboBox 类


ComboBox.SelectKey 属性

ComboBoxSelectKey 属性

[缺少 "P:Swebui.Controls.ComboBox.SelectKey" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string SelectKey { get; }
Public ReadOnly Property SelectKey As String
    Get

属性值

类型：String
参见

引用

ComboBox 类


ComboBox.ShowClearButton 属性

ComboBoxShowClearButton 属性

[缺少 "P:Swebui.Controls.ComboBox.ShowClearButton" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ShowClearButton { get; set; }
Public Property ShowClearButton As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

ComboBox 类


ComboBox.SortOrder 属性

ComboBoxSortOrder 属性

[缺少 "P:Swebui.Controls.ComboBox.SortOrder" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SortOrderType SortOrder { get; set; }
Public Property SortOrder As SortOrderType
    Get
    Set

属性值

类型：SortOrderType
参见

引用

ComboBox 类


ComboBox.Text 属性

ComboBoxText 属性

[缺少 "P:Swebui.Controls.ComboBox.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

ComboBox 类


ComboBox 方法

ComboBox 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 内容更改时触发回调
公共方法 | SetSelectItem | 设置默认项
Top
参见

引用

ComboBox 类


ComboBox.OnEventRaised 方法

ComboBoxOnEventRaised 方法

内容更改时触发回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.ComboBox.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

ComboBox 类


ComboBox.SetSelectItem 方法

ComboBoxSetSelectItem 方法

设置默认项

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void SetSelectItem(
    ComboBoxItem item
)
Public Sub SetSelectItem (
    item As ComboBoxItem
)

参数

item
类型：Swebui.ControlsComboBoxItem

[缺少 "M:Swebui.Controls.ComboBox.SetSelectItem(Swebui.Controls.ComboBoxItem)" 的 <param name="item"/> 文档]

参见

引用

ComboBox 类


ComboBox 事件

ComboBox 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时发生
Top
参见

引用

ComboBox 类


ComboBox.ValueChanged 事件

ComboBoxValueChanged 事件

在值改变时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

ComboBox 类


ComboBoxItem 类

[缺少 "T:Swebui.Controls.ComboBoxItem" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsComboBoxItem

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ComboBoxItem : SwebViewCollectionItem
Public Class ComboBoxItem
    Inherits SwebViewCollectionItem

ComboBoxItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ComboBoxItem | 初始化 ComboBoxItem 类的一个新实例
公共方法 | ComboBoxItem(String, String) | 初始化 ComboBoxItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Id | 获取和设置菜单元素编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
参见

引用

Swebui.Controls 命名空间


ComboBoxItem 构造函数

重载列表
 | 名称 | 说明
公共方法 | ComboBoxItem | 初始化 ComboBoxItem 类的一个新实例
公共方法 | ComboBoxItem(String, String) | 初始化 ComboBoxItem 类的一个新实例
Top
参见

引用

ComboBoxItem 类


ComboBoxItem 构造函数

初始化 ComboBoxItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ComboBoxItem()
Public Sub New
参见

引用

ComboBoxItem 类
ComboBoxItem 重载


ComboBoxItem 构造函数 (String, String)

初始化 ComboBoxItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ComboBoxItem(
    string id,
    string text
)
Public Sub New (
    id As String,
    text As String
)

参数

id
类型：SystemString

[缺少 "M:Swebui.Controls.ComboBoxItem.#ctor(System.String,System.String)" 的 <param name="id"/> 文档]

text
类型：SystemString

[缺少 "M:Swebui.Controls.ComboBoxItem.#ctor(System.String,System.String)" 的 <param name="text"/> 文档]

参见

引用

ComboBoxItem 类
ComboBoxItem 重载


ComboBoxItem 属性

ComboBoxItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Id | 获取和设置菜单元素编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
参见

引用

ComboBoxItem 类


ComboBoxItem.Id 属性

ComboBoxItemId 属性

获取和设置菜单元素编号

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Id { get; set; }
Public Property Id As String
    Get
    Set

属性值

类型：String
参见

引用

ComboBoxItem 类


ComboBoxItem.Text 属性

ComboBoxItemText 属性

[缺少 "P:Swebui.Controls.ComboBoxItem.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

ComboBoxItem 类


ComboBoxItemCollection 类

[缺少 "T:Swebui.Controls.ComboBoxItemCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase ComboBoxItem
Swebui.ControlsComboBoxItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ComboBoxItemCollection : SwebViewCollectionBase<ComboBoxItem>
Public Class ComboBoxItemCollection
    Inherits SwebViewCollectionBase(Of ComboBoxItem)

ComboBoxItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


ComboBoxItemCollection 属性

ComboBoxItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

ComboBoxItemCollection 类


ComboBoxItemCollection 方法

ComboBoxItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

ComboBoxItemCollection 类


CustomCallBackEventArgs 类

[缺少 "T:Swebui.Controls.CustomCallBackEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsCustomCallBackEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class CustomCallBackEventArgs : EventArgs
Public Class CustomCallBackEventArgs
    Inherits EventArgs

CustomCallBackEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CustomCallBackEventArgs | 初始化 CustomCallBackEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Params |
Top
参见

引用

Swebui.Controls 命名空间


CustomCallBackEventArgs 构造函数

初始化 CustomCallBackEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public CustomCallBackEventArgs()
Public Sub New
参见

引用

CustomCallBackEventArgs 类


CustomCallBackEventArgs 属性

CustomCallBackEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Params |
Top
参见

引用

CustomCallBackEventArgs 类


CustomCallBackEventArgs.Params 属性

CustomCallBackEventArgsParams 属性

[缺少 "P:Swebui.Controls.CustomCallBackEventArgs.Params" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Params { get; }
Public ReadOnly Property Params As Object
    Get

属性值

类型：Object
参见

引用

CustomCallBackEventArgs 类


CustomCallBackEventHandler 委托

[缺少 "T:Swebui.Controls.CustomCallBackEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void CustomCallBackEventHandler(
    Object sender,
    CustomCallBackEventArgs e
)
Public Delegate Sub CustomCallBackEventHandler (
    sender As Object,
    e As CustomCallBackEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsCustomCallBackEventArgs
参见

引用

Swebui.Controls 命名空间


DataBindMode 枚举

数据绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum DataBindMode
Public Enumeration DataBindMode
成员
成员名称 | 值 | 说明
BindOnly | 0 | 仅执行绑定但不更新数据源
BindUpdate | 1 | 执行绑定并更新到数据源
参见

引用

Swebui.Controls 命名空间


DataSourceManager 类

Class DataSourceManager. This class cannot be inherited.
继承层次
SystemObject
Swebui.ControlsDataSourceManager

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public sealed class DataSourceManager
Public NotInheritable Class DataSourceManager

DataSourceManager 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DataSourceManager | 初始化 DataSourceManager 类的一个新实例
Top
方法
名称 | 说明
GetDataSource | Gets the data source.
GetDataSourceDataMember | Gets the data source data member.
GetDataSourceDataSource | Gets the data source data source.
GetPropertyValue(Object, String) |
GetPropertyValue(Object, String, String) |
GetPropertyValues |
Top
参见

引用

Swebui.Controls 命名空间


DataSourceManager 构造函数

初始化 DataSourceManager 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DataSourceManager()
Public Sub New
参见

引用

DataSourceManager 类


DataSourceManager 方法

DataSourceManager 类型公开以下成员。

方法
名称 | 说明
GetDataSource | Gets the data source.
GetDataSourceDataMember | Gets the data source data member.
GetDataSourceDataSource | Gets the data source data source.
GetPropertyValue(Object, String) |
GetPropertyValue(Object, String, String) |
GetPropertyValues |
Top
参见

引用

DataSourceManager 类


DataSourceManager.GetDataSource 方法

DataSourceManagerGetDataSource 方法

Gets the data source.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static IEnumerable GetDataSource(
    Object dataSource1,
    string dataMember
)
Public Shared Function GetDataSource (
    dataSource1 As Object,
    dataMember As String
) As IEnumerable

参数

dataSource1
类型：SystemObject
The data source1.
dataMember
类型：SystemString
The data member.

返回值

类型：IEnumerable
IEnumerable.
异常
异常 | 条件
Exception | ListSource Without DataMembers! or ListSource Missing DataMember " + dataMember + "!
参见

引用

DataSourceManager 类


DataSourceManager.GetDataSourceDataMember 方法

DataSourceManagerGetDataSourceDataMember 方法

Gets the data source data member.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetDataSourceDataMember(
    Object dataSource1,
    string dataMember
)
Public Shared Function GetDataSourceDataMember (
    dataSource1 As Object,
    dataMember As String
) As String

参数

dataSource1
类型：SystemObject
The data source1.
dataMember
类型：SystemString
The data member.

返回值

类型：String
System.String.
参见

引用

DataSourceManager 类


DataSourceManager.GetDataSourceDataSource 方法

DataSourceManagerGetDataSourceDataSource 方法

Gets the data source data source.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetDataSourceDataSource(
    Object dataSource1,
    string dataMember
)
Public Shared Function GetDataSourceDataSource (
    dataSource1 As Object,
    dataMember As String
) As String

参数

dataSource1
类型：SystemObject
The data source1.
dataMember
类型：SystemString
The data member.

返回值

类型：String
System.String.
参见

引用

DataSourceManager 类


DataSourceManager.GetPropertyValue 方法

DataSourceManagerGetPropertyValue 方法

重载列表
名称 | 说明
GetPropertyValue(Object, String) |
GetPropertyValue(Object, String, String) |
Top
参见

引用

DataSourceManager 类


DataSourceManager.GetPropertyValue 方法 (Object, String)

DataSourceManagerGetPropertyValue 方法 (Object, String)

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Object GetPropertyValue(
    Object container,
    string propName
)
Public Shared Function GetPropertyValue (
    container As Object,
    propName As String
) As Object

参数

container
类型：SystemObject

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String)" 的 <param name="container"/> 文档]

propName
类型：SystemString

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String)" 的 <param name="propName"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String)" 的 <returns> 文档]

参见

引用

DataSourceManager 类
GetPropertyValue 重载


DataSourceManager.GetPropertyValue 方法 (Object, String, String)

DataSourceManagerGetPropertyValue 方法 (Object, String, String)

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String,System.String)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetPropertyValue(
    Object container,
    string propName,
    string format
)
Public Shared Function GetPropertyValue (
    container As Object,
    propName As String,
    format As String
) As String

参数

container
类型：SystemObject

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String,System.String)" 的 <param name="container"/> 文档]

propName
类型：SystemString

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String,System.String)" 的 <param name="propName"/> 文档]

format
类型：SystemString

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String,System.String)" 的 <param name="format"/> 文档]

返回值

类型：String

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValue(System.Object,System.String,System.String)" 的 <returns> 文档]

参见

引用

DataSourceManager 类
GetPropertyValue 重载


DataSourceManager.GetPropertyValues 方法

DataSourceManagerGetPropertyValues 方法

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValues(System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Dictionary<string, Object> GetPropertyValues(
    Object container
)
Public Shared Function GetPropertyValues (
    container As Object
) As Dictionary(Of String, Object)

参数

container
类型：SystemObject

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValues(System.Object)" 的 <param name="container"/> 文档]

返回值

类型：Dictionary String, Object

[缺少 "M:Swebui.Controls.DataSourceManager.GetPropertyValues(System.Object)" 的 <returns> 文档]

参见

引用

DataSourceManager 类


DataSourceUpdateEventArgs 类

为 DataSourceUpdateEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsDataSourceUpdateEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class DataSourceUpdateEventArgs : EventArgs
Public Class DataSourceUpdateEventArgs
    Inherits EventArgs

DataSourceUpdateEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DataSourceUpdateEventArgs | 创建 DataSourceUpdateEventArgs 实例
Top
属性
 | 名称 | 说明
公共属性 | BindableControl | 获取更新的控件
公共属性 | BindDisplayValue | 获取更新的值
公共属性 | TemplateItem | 获取模板项
Top
参见

引用

Swebui.Controls 命名空间


DataSourceUpdateEventArgs 构造函数

创建 DataSourceUpdateEventArgs 实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DataSourceUpdateEventArgs(
    SwebViewCollectionItem templateItem,
    ISwebDataBindableControl bindableControl
)
Public Sub New (
    templateItem As SwebViewCollectionItem,
    bindableControl As ISwebDataBindableControl
)

参数

templateItem
类型：Swebui.ControlsSwebViewCollectionItem
模板项
bindableControl
类型：Swebui.ControlsISwebDataBindableControl
更新控件
参见

引用

DataSourceUpdateEventArgs 类


DataSourceUpdateEventArgs 属性

DataSourceUpdateEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindableControl | 获取更新的控件
公共属性 | BindDisplayValue | 获取更新的值
公共属性 | TemplateItem | 获取模板项
Top
参见

引用

DataSourceUpdateEventArgs 类


DataSourceUpdateEventArgs.BindableControl 属性

DataSourceUpdateEventArgsBindableControl 属性

获取更新的控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ISwebDataBindableControl BindableControl { get; }
Public ReadOnly Property BindableControl As ISwebDataBindableControl
    Get

返回值

类型：ISwebDataBindableControl
参见

引用

DataSourceUpdateEventArgs 类


DataSourceUpdateEventArgs.BindDisplayValue 属性

DataSourceUpdateEventArgsBindDisplayValue 属性

获取更新的值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object BindDisplayValue { get; }
Public ReadOnly Property BindDisplayValue As Object
    Get

返回值

类型：Object
参见

引用

DataSourceUpdateEventArgs 类


DataSourceUpdateEventArgs.TemplateItem 属性

DataSourceUpdateEventArgsTemplateItem 属性

获取模板项

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollectionItem TemplateItem { get; }
Public ReadOnly Property TemplateItem As SwebViewCollectionItem
    Get

返回值

类型：SwebViewCollectionItem
参见

引用

DataSourceUpdateEventArgs 类


DataSourceUpdateEventHandler 委托

一个委托，它表示更新数据源时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void DataSourceUpdateEventHandler(
    Object sender,
    DataSourceUpdateEventArgs e
)
Public Delegate Sub DataSourceUpdateEventHandler (
    sender As Object,
    e As DataSourceUpdateEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsDataSourceUpdateEventArgs
包含事件数据的 DataSourceUpdateEventArgs
参见

引用

Swebui.Controls 命名空间


DatePicker 类

日期选择控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsDatePicker

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class DatePicker : SwebBindableControl, ISwebRenderControl,
    ISwebEventControl
Public Class DatePicker
    Inherits SwebBindableControl
    Implements ISwebRenderControl, ISwebEventControl

DatePicker 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DatePicker | 初始化 DatePicker 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enable | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Format | 获取或设置时间格式
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxDate | 获取和设置可以选择的最大日期
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaximumDateTime | 获取最大日期值
公共属性 | MinDate | 获取和设置可以选择的最小日期
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MinimumDateTime | 获取最小日期值。
公共属性 | Mode | 获取和设置日期/时间模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置当前日期/时间
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
字段
名称 | 说明
MaxDateTime |
MinDateTime |
Top
参见

引用

Swebui.Controls 命名空间


DatePicker 构造函数

初始化 DatePicker 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePicker()
Public Sub New
参见

引用

DatePicker 类


DatePicker 属性

DatePicker 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enable | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Format | 获取或设置时间格式
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxDate | 获取和设置可以选择的最大日期
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaximumDateTime | 获取最大日期值
公共属性 | MinDate | 获取和设置可以选择的最小日期
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MinimumDateTime | 获取最小日期值。
公共属性 | Mode | 获取和设置日期/时间模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取和设置当前日期/时间
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

DatePicker 类


DatePicker.BindDisplayValue 属性

DatePickerBindDisplayValue 属性

[缺少 "P:Swebui.Controls.DatePicker.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

DatePicker 类


DatePicker.DisplayFormat 属性

DatePickerDisplayFormat 属性

[缺少 "P:Swebui.Controls.DatePicker.DisplayFormat" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string DisplayFormat { get; set; }
Public Overrides Property DisplayFormat As String
    Get
    Set

属性值

类型：String
参见

引用

DatePicker 类


DatePicker.Enable 属性

DatePickerEnable 属性

获取或设置一个值，该值指示是否已启用该控件。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Enable { get; set; }
Public Property Enable As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

DatePicker 类


DatePicker.FontSize 属性

DatePickerFontSize 属性

获取和设置控件字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

DatePicker 类


DatePicker.ForeColor 属性

DatePickerForeColor 属性

获取或设置控件的前景色，用于显示文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DatePicker 类


DatePicker.Format 属性

DatePickerFormat 属性

获取或设置时间格式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePickerFormat Format { get; set; }
Public Property Format As DatePickerFormat
    Get
    Set

属性值

类型：DatePickerFormat
参见

引用

DatePicker 类


DatePicker.HorizontalAlignment 属性

DatePickerHorizontalAlignment 属性

获取或设置控件水平方向

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set

属性值

类型：HorizontalAlignment
参见

引用

DatePicker 类


DatePicker.MaxDate 属性

DatePickerMaxDate 属性

获取和设置可以选择的最大日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MaxDate { get; set; }
Public Property MaxDate As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

DatePicker 类


DatePicker.MaximumDateTime 属性

DatePickerMaximumDateTime 属性

获取最大日期值

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MaximumDateTime { get; }
Public ReadOnly Property MaximumDateTime As DateTime
    Get

属性值

类型：DateTime
参见

引用

DatePicker 类


DatePicker.MinDate 属性

DatePickerMinDate 属性

获取和设置可以选择的最小日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MinDate { get; set; }
Public Property MinDate As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

DatePicker 类


DatePicker.MinimumDateTime 属性

DatePickerMinimumDateTime 属性

获取最小日期值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MinimumDateTime { get; }
Public ReadOnly Property MinimumDateTime As DateTime
    Get

属性值

类型：DateTime
参见

引用

DatePicker 类


DatePicker.Mode 属性

DatePickerMode 属性

获取和设置日期/时间模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePickerMode Mode { get; set; }
Public Property Mode As DatePickerMode
    Get
    Set

属性值

类型：DatePickerMode
参见

引用

DatePicker 类


DatePicker.Value 属性

DatePickerValue 属性

获取和设置当前日期/时间

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

属性值

类型：DateTime
参见

引用

DatePicker 类


DatePicker 方法

DatePicker 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
参见

引用

DatePicker 类


DatePicker.OnEventRaised 方法

DatePickerOnEventRaised 方法

[缺少 "M:Swebui.Controls.DatePicker.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.DatePicker.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

DatePicker 类


DatePicker 事件

DatePicker 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在值改变时时发生
Top
参见

引用

DatePicker 类


DatePicker.ValueChanged 事件

DatePickerValueChanged 事件

在值改变时时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

DatePicker 类


DatePicker 字段

DatePicker 类型公开以下成员。

字段
名称 | 说明
MaxDateTime |
MinDateTime |
Top
参见

引用

DatePicker 类


DatePicker.MaxDateTime 字段

DatePickerMaxDateTime 字段

[缺少 "F:Swebui.Controls.DatePicker.MaxDateTime" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static DateTime MaxDateTime
Public Shared MaxDateTime As DateTime

字段值

类型：DateTime
参见

引用

DatePicker 类


DatePicker.MinDateTime 字段

DatePickerMinDateTime 字段

[缺少 "F:Swebui.Controls.DatePicker.MinDateTime" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static DateTime MinDateTime
Public Shared MinDateTime As DateTime

字段值

类型：DateTime
参见

引用

DatePicker 类


DatePickerFormat 枚举

[缺少 "T:Swebui.Controls.DatePickerFormat" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum DatePickerFormat
Public Enumeration DatePickerFormat
成员
成员名称 | 值 | 说明
Y | 0 | Mode为Date时格式
YM | 1 | Mode为Date时格式
YMD | 2 | Mode为Date时格式
YMDHM | 3 | Mode为DateTime时格式
YMDHMS | 4 | Mode为DateTime时格式
H | 5 | Mode为Time时格式
HM | 6 | Mode为Time时格式
HMS | 7 | Mode为Time时格式
参见

引用

Swebui.Controls 命名空间


DatePickerMode 枚举

日期/时间选择控件显示模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum DatePickerMode
Public Enumeration DatePickerMode
成员
成员名称 | 值 | 说明
Time | 0 | 仅时间
Date | 1 | 仅日期
DateTime | 2 | 日期和日期
备注
参见

引用

Swebui.Controls 命名空间


DatePickrSelectedEventArgs 类

[缺少 "T:Swebui.Controls.DatePickrSelectedEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsDatePickrSelectedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class DatePickrSelectedEventArgs : ResultArgs
Public Class DatePickrSelectedEventArgs
    Inherits ResultArgs

DatePickrSelectedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DatePickrSelectedEventArgs(DatePickerMode, DateTime) | 构造方法
公共方法 | DatePickrSelectedEventArgs(DatePickerMode, DateTime, DateTime, DateTime) | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | MaxDate | 获取可以选择最大日期
公共属性 | MinDate | 获取可以选择最小日期
公共属性 | Mode | 获取日期/时间模式
公共属性 | Value | 获取当前日期/时间
Top
方法
 | 名称 | 说明
公共方法 | SetCurrentDateInternal |
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


DatePickrSelectedEventArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | DatePickrSelectedEventArgs(DatePickerMode, DateTime) | 构造方法
公共方法 | DatePickrSelectedEventArgs(DatePickerMode, DateTime, DateTime, DateTime) | 构造方法
Top
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs 构造函数 (DatePickerMode, DateTime)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePickrSelectedEventArgs(
    DatePickerMode datePickerMode,
    DateTime dateTime
)
Public Sub New (
    datePickerMode As DatePickerMode,
    dateTime As DateTime
)

参数

datePickerMode
类型：Swebui.ControlsDatePickerMode
日期/时间模式
dateTime
类型：SystemDateTime
当前日期/时间
参见

引用

DatePickrSelectedEventArgs 类
DatePickrSelectedEventArgs 重载


DatePickrSelectedEventArgs 构造函数 (DatePickerMode, DateTime, DateTime, DateTime)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePickrSelectedEventArgs(
    DatePickerMode datePickerMode,
    DateTime dateTime,
    DateTime maxdate,
    DateTime mindate
)
Public Sub New (
    datePickerMode As DatePickerMode,
    dateTime As DateTime,
    maxdate As DateTime,
    mindate As DateTime
)

参数

datePickerMode
类型：Swebui.ControlsDatePickerMode
日期/时间模式
dateTime
类型：SystemDateTime
当前日期/时间
maxdate
类型：SystemDateTime
可以选择最小日期
mindate
类型：SystemDateTime
可以选择最大日期
参见

引用

DatePickrSelectedEventArgs 类
DatePickrSelectedEventArgs 重载


DatePickrSelectedEventArgs 属性

DatePickrSelectedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | MaxDate | 获取可以选择最大日期
公共属性 | MinDate | 获取可以选择最小日期
公共属性 | Mode | 获取日期/时间模式
公共属性 | Value | 获取当前日期/时间
Top
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs.MaxDate 属性

DatePickrSelectedEventArgsMaxDate 属性

获取可以选择最大日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MaxDate { get; }
Public ReadOnly Property MaxDate As DateTime
    Get

属性值

类型：DateTime
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs.MinDate 属性

DatePickrSelectedEventArgsMinDate 属性

获取可以选择最小日期

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime MinDate { get; }
Public ReadOnly Property MinDate As DateTime
    Get

属性值

类型：DateTime
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs.Mode 属性

DatePickrSelectedEventArgsMode 属性

获取日期/时间模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DatePickerMode Mode { get; }
Public ReadOnly Property Mode As DatePickerMode
    Get

属性值

类型：DatePickerMode
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs.Value 属性

DatePickrSelectedEventArgsValue 属性

获取当前日期/时间

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DateTime Value { get; }
Public ReadOnly Property Value As DateTime
    Get

属性值

类型：DateTime
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs 方法

DatePickrSelectedEventArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | SetCurrentDateInternal |
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventArgs.SetCurrentDateInternal 方法

DatePickrSelectedEventArgsSetCurrentDateInternal 方法

[缺少 "M:Swebui.Controls.DatePickrSelectedEventArgs.SetCurrentDateInternal(System.DateTime)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void SetCurrentDateInternal(
    DateTime date
)
Public Sub SetCurrentDateInternal (
    date As DateTime
)

参数

date
类型：SystemDateTime

[缺少 "M:Swebui.Controls.DatePickrSelectedEventArgs.SetCurrentDateInternal(System.DateTime)" 的 <param name="date"/> 文档]

参见

引用

DatePickrSelectedEventArgs 类


DatePickrSelectedEventHandler 委托

[缺少 "T:Swebui.Controls.DatePickrSelectedEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void DatePickrSelectedEventHandler(
    Object sender,
    DatePickrSelectedEventArgs e
)
Public Delegate Sub DatePickrSelectedEventHandler (
    sender As Object,
    e As DatePickrSelectedEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsDatePickrSelectedEventArgs
参见

引用

Swebui.Controls 命名空间


DatePropertyExtend 类

[缺少 "T:Swebui.Controls.DatePropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsDatePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class DatePropertyExtend : SwebPropertyExtend
Public Class DatePropertyExtend
    Inherits SwebPropertyExtend

DatePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DatePropertyExtend | 初始化 DatePropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


DatePropertyExtend 构造函数

初始化 DatePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DatePropertyExtend()
Public Sub New
参见

引用

DatePropertyExtend 类


DialogAnimationType 枚举

弹出动画样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum DialogAnimationType
Public Enumeration DialogAnimationType
成员
成员名称 | 值 | 说明
None | 0 | 无动画
Fade | 1 | 淡出
Slide | 2 | 从边缘显现
参见

引用

Swebui.Controls 命名空间


DialogOptions 类

Dialog配置项
继承层次
SystemObject
Swebui.ControlsDialogOptions

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class DialogOptions
Public Class DialogOptions

DialogOptions 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DialogOptions | 初始化一个类型为 DialogOptions 的实例。
公共方法 | DialogOptions(LayoutJustifyAlign) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding) | 初始化一个类型为 DialogOptions 的实例。
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding, Boolean) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding, Boolean, DialogAnimationType) | 初始化一个类型为 DialogOptions 的实例.
Top
属性
 | 名称 | 说明
公共属性 | AnimationType | 获取和设置弹出动画样式
公共属性 | BackColor | 获取和设置背景色。
公共属性 | JustifyAlign | 获取和设置主轴对齐方向
公共属性 | Padding | 获取和设置控件内边距。
公共属性 | TouchClosed | 获取和设置一个值，该值指示是否点击空白区域时关闭Dialog。
Top
参见

引用

Swebui.Controls 命名空间


DialogOptions 构造函数

重载列表
 | 名称 | 说明
公共方法 | DialogOptions | 初始化一个类型为 DialogOptions 的实例。
公共方法 | DialogOptions(LayoutJustifyAlign) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding) | 初始化一个类型为 DialogOptions 的实例。
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding, Boolean) | 初始化一个类型为 DialogOptions 的实例.
公共方法 | DialogOptions(LayoutJustifyAlign, Color, Padding, Boolean, DialogAnimationType) | 初始化一个类型为 DialogOptions 的实例.
Top
参见

引用

DialogOptions 类


DialogOptions 构造函数

初始化一个类型为 DialogOptions 的实例。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions()
Public Sub New
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 构造函数 (LayoutJustifyAlign)

初始化一个类型为 DialogOptions 的实例.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions(
    LayoutJustifyAlign justifyAlign
)
Public Sub New (
    justifyAlign As LayoutJustifyAlign
)

参数

justifyAlign
类型：Swebui.ControlsLayoutJustifyAlign
主轴对齐方向
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 构造函数 (LayoutJustifyAlign, Color)

初始化一个类型为 DialogOptions 的实例.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions(
    LayoutJustifyAlign justifyAlign,
    Color backColor
)
Public Sub New (
    justifyAlign As LayoutJustifyAlign,
    backColor As Color
)

参数

justifyAlign
类型：Swebui.ControlsLayoutJustifyAlign
主轴对齐方向
backColor
类型：System.DrawingColor
背景色
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 构造函数 (LayoutJustifyAlign, Color, Padding)

初始化一个类型为 DialogOptions 的实例。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions(
    LayoutJustifyAlign justifyAlign,
    Color backColor,
    Padding padding
)
Public Sub New (
    justifyAlign As LayoutJustifyAlign,
    backColor As Color,
    padding As Padding
)

参数

justifyAlign
类型：Swebui.ControlsLayoutJustifyAlign
主轴对齐方向
backColor
类型：System.DrawingColor
背景色
padding
类型：Swebui.ControlsPadding
控件内边距
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 构造函数 (LayoutJustifyAlign, Color, Padding, Boolean)

初始化一个类型为 DialogOptions 的实例.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions(
    LayoutJustifyAlign justifyAlign,
    Color backColor,
    Padding padding,
    bool touchClosed
)
Public Sub New (
    justifyAlign As LayoutJustifyAlign,
    backColor As Color,
    padding As Padding,
    touchClosed As Boolean
)

参数

justifyAlign
类型：Swebui.ControlsLayoutJustifyAlign
主轴对齐方向
backColor
类型：System.DrawingColor
背景色
padding
类型：Swebui.ControlsPadding
控件内边距
touchClosed
类型：SystemBoolean
当设置为 true 时，点击空白区域关闭Dailog
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 构造函数 (LayoutJustifyAlign, Color, Padding, Boolean, DialogAnimationType)

初始化一个类型为 DialogOptions 的实例.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogOptions(
    LayoutJustifyAlign justifyAlign,
    Color backColor,
    Padding padding,
    bool touchClosed,
    DialogAnimationType animationType
)
Public Sub New (
    justifyAlign As LayoutJustifyAlign,
    backColor As Color,
    padding As Padding,
    touchClosed As Boolean,
    animationType As DialogAnimationType
)

参数

justifyAlign
类型：Swebui.ControlsLayoutJustifyAlign
主轴对齐方向
backColor
类型：System.DrawingColor
背景色
padding
类型：Swebui.ControlsPadding
控件内边距
touchClosed
类型：SystemBoolean
当设置为 true 时，点击空白区域关闭Dailog
animationType
类型：Swebui.ControlsDialogAnimationType
弹出动画样式
参见

引用

DialogOptions 类
DialogOptions 重载


DialogOptions 属性

DialogOptions 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AnimationType | 获取和设置弹出动画样式
公共属性 | BackColor | 获取和设置背景色。
公共属性 | JustifyAlign | 获取和设置主轴对齐方向
公共属性 | Padding | 获取和设置控件内边距。
公共属性 | TouchClosed | 获取和设置一个值，该值指示是否点击空白区域时关闭Dialog。
Top
参见

引用

DialogOptions 类


DialogOptions.AnimationType 属性

DialogOptionsAnimationType 属性

获取和设置弹出动画样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DialogAnimationType AnimationType { get; set; }
Public Property AnimationType As DialogAnimationType
    Get
    Set

属性值

类型：DialogAnimationType
参见

引用

DialogOptions 类


DialogOptions.BackColor 属性

DialogOptionsBackColor 属性

获取和设置背景色。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DialogOptions 类


DialogOptions.JustifyAlign 属性

DialogOptionsJustifyAlign 属性

获取和设置主轴对齐方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public LayoutJustifyAlign JustifyAlign { get; set; }
Public Property JustifyAlign As LayoutJustifyAlign
    Get
    Set

属性值

类型：LayoutJustifyAlign
The justify align.
参见

引用

DialogOptions 类


DialogOptions.Padding 属性

DialogOptionsPadding 属性

获取和设置控件内边距。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Padding Padding { get; set; }
Public Property Padding As Padding
    Get
    Set

属性值

类型：Padding
The padding.
参见

引用

DialogOptions 类


DialogOptions.TouchClosed 属性

DialogOptionsTouchClosed 属性

获取和设置一个值，该值指示是否点击空白区域时关闭Dialog。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool TouchClosed { get; set; }
Public Property TouchClosed As Boolean
    Get
    Set

属性值

类型：Boolean
true 点击空白区域关闭Dialog; 否则, false.
参见

引用

DialogOptions 类


DrawerPosition 枚举

侧边栏出现在屏幕上的位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum DrawerPosition
Public Enumeration DrawerPosition
成员
成员名称 | 值 | 说明
Left | 0 | 从屏幕左边滑出
Right | 1 | 从屏幕右边滑出
参见

引用

Swebui.Controls 命名空间


ECharts 类

ECharts
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsECharts

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ECharts : SwebNativeControl, ISwebEventControl
Public Class ECharts
    Inherits SwebNativeControl
    Implements ISwebEventControl

ECharts 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ECharts | 初始化 ECharts 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoShowInterval | 获取与设置动态显示tooltip的间隔时间，单位ms（在tooltipAutoShow为true时有效）
公共属性 | AutoShowLoopSeries | 获取与设置是否循环显示tooltip （tooltipAutoShow为true时有效）
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | CustomThemeName | 获取与设置theme自定义主题名称
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Option | 获取与设置option
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Theme | 获取与设置Thenme
公共属性 | ThemeJson | 获取与设置theme自定义主题内容
公共属性 | TooltipAutoShow | 获取与设置是否动态显示tooltip
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 事件回调
Top
事件
 | 名称 | 说明
公共事件 | EChartsPress | 在被点击时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


ECharts 构造函数

初始化 ECharts 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ECharts()
Public Sub New
参见

引用

ECharts 类


ECharts 属性

ECharts 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoShowInterval | 获取与设置动态显示tooltip的间隔时间，单位ms（在tooltipAutoShow为true时有效）
公共属性 | AutoShowLoopSeries | 获取与设置是否循环显示tooltip （tooltipAutoShow为true时有效）
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | CustomThemeName | 获取与设置theme自定义主题名称
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Option | 获取与设置option
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Theme | 获取与设置Thenme
公共属性 | ThemeJson | 获取与设置theme自定义主题内容
公共属性 | TooltipAutoShow | 获取与设置是否动态显示tooltip
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

ECharts 类


ECharts.AutoShowInterval 属性

EChartsAutoShowInterval 属性

获取与设置动态显示tooltip的间隔时间，单位ms（在tooltipAutoShow为true时有效）

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int AutoShowInterval { get; set; }
Public Property AutoShowInterval As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

ECharts 类


ECharts.AutoShowLoopSeries 属性

EChartsAutoShowLoopSeries 属性

获取与设置是否循环显示tooltip （tooltipAutoShow为true时有效）

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AutoShowLoopSeries { get; set; }
Public Property AutoShowLoopSeries As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

ECharts 类


ECharts.CustomThemeName 属性

EChartsCustomThemeName 属性

获取与设置theme自定义主题名称

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string CustomThemeName { get; set; }
Public Property CustomThemeName As String
    Get
    Set

属性值

类型：String
参见

引用

ECharts 类


ECharts.Option 属性

EChartsOption 属性

获取与设置option

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Option { get; set; }
Public Property Option As String
    Get
    Set

属性值

类型：String
参见

引用

ECharts 类


ECharts.Theme 属性

EChartsTheme 属性

获取与设置Thenme

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EChartsTheme Theme { get; set; }
Public Property Theme As EChartsTheme
    Get
    Set

属性值

类型：EChartsTheme
参见

引用

ECharts 类


ECharts.ThemeJson 属性

EChartsThemeJson 属性

获取与设置theme自定义主题内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ThemeJson { get; set; }
Public Property ThemeJson As String
    Get
    Set

属性值

类型：String
参见

引用

ECharts 类


ECharts.TooltipAutoShow 属性

EChartsTooltipAutoShow 属性

获取与设置是否动态显示tooltip

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool TooltipAutoShow { get; set; }
Public Property TooltipAutoShow As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

ECharts 类


ECharts 方法

ECharts 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 事件回调
Top
参见

引用

ECharts 类


ECharts.OnEventRaised 方法

EChartsOnEventRaised 方法

事件回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.ECharts.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

ECharts 类


ECharts 事件

ECharts 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | EChartsPress | 在被点击时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

ECharts 类


ECharts.EChartsPress 事件

EChartsEChartsPress 事件

在被点击时触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EChartsPressEventHandler EChartsPress
Public Event EChartsPress As EChartsPressEventHandler

值

类型：Swebui.ControlsEChartsPressEventHandler
参见

引用

ECharts 类


EChartsPressEventArgs 类

为EChartsPress提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsEChartsPressEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class EChartsPressEventArgs : EventArgs
Public Class EChartsPressEventArgs
    Inherits EventArgs

EChartsPressEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EChartsPressEventArgs | 初始化 EChartsPressEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ComponentIndex | 点击项数据源索引
公共属性 | ComponentSubType | 图表类型
公共属性 | ComponentType | Component类型
公共属性 | Data | 点击项数据
公共属性 | DataIndex | 点击项 数据索引
公共属性 | Error | 错误信息
公共属性 | PressedName | 点击项图表名称
公共属性 | Selected | 图表
Top
参见

引用

Swebui.Controls 命名空间


EChartsPressEventArgs 构造函数

初始化 EChartsPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EChartsPressEventArgs()
Public Sub New
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs 属性

EChartsPressEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ComponentIndex | 点击项数据源索引
公共属性 | ComponentSubType | 图表类型
公共属性 | ComponentType | Component类型
公共属性 | Data | 点击项数据
公共属性 | DataIndex | 点击项 数据索引
公共属性 | Error | 错误信息
公共属性 | PressedName | 点击项图表名称
公共属性 | Selected | 图表
Top
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.ComponentIndex 属性

EChartsPressEventArgsComponentIndex 属性

点击项数据源索引

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int ComponentIndex { get; set; }
Public Property ComponentIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.ComponentSubType 属性

EChartsPressEventArgsComponentSubType 属性

图表类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ComponentSubType { get; set; }
Public Property ComponentSubType As String
    Get
    Set

属性值

类型：String
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.ComponentType 属性

EChartsPressEventArgsComponentType 属性

Component类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ComponentType { get; set; }
Public Property ComponentType As String
    Get
    Set

属性值

类型：String
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.Data 属性

EChartsPressEventArgsData 属性

点击项数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set

属性值

类型：Object
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.DataIndex 属性

EChartsPressEventArgsDataIndex 属性

点击项 数据索引

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int DataIndex { get; set; }
Public Property DataIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.Error 属性

EChartsPressEventArgsError 属性

错误信息

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Error { get; set; }
Public Property Error As String
    Get
    Set

属性值

类型：String
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.PressedName 属性

EChartsPressEventArgsPressedName 属性

点击项图表名称

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string PressedName { get; set; }
Public Property PressedName As String
    Get
    Set

属性值

类型：String
参见

引用

EChartsPressEventArgs 类


EChartsPressEventArgs.Selected 属性

EChartsPressEventArgsSelected 属性

图表

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Dictionary<string, Object> Selected { get; set; }
Public Property Selected As Dictionary(Of String, Object)
    Get
    Set

属性值

类型：Dictionary String, Object
参见

引用

EChartsPressEventArgs 类


EChartsPressEventHandler 委托

一个委托，它表示ECharts被点击时需要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void EChartsPressEventHandler(
    Object sender,
    EChartsPressEventArgs e
)
Public Delegate Sub EChartsPressEventHandler (
    sender As Object,
    e As EChartsPressEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsEChartsPressEventArgs
包含事件数据的 EChartsPressEventArgs
参见

引用

Swebui.Controls 命名空间


EChartsTheme 枚举

ECharts主题

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EChartsTheme
Public Enumeration EChartsTheme
成员
成员名称 | 值 | 说明
Custom | 0 |
Light | 1 |
Dark | 2 |
参见

引用

Swebui.Controls 命名空间


EditeListButton 枚举

[缺少 "T:Swebui.Controls.EditeListButton" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EditeListButton
Public Enumeration EditeListButton
成员
成员名称 | 值 | 说明
Ordered | 0 |
Bullet | 1 |
Check | 2 |
参见

引用

Swebui.Controls 命名空间


Editer 类

富文本控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsEditer

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Editer : SwebControl, ISwebRenderControl,
    ISwebEventControl
Public Class Editer
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl

Editer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Editer | 构建函数
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DefaultDelta | 获取或设置文本。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PlaceHolder | 获取或设置水印文本。注：不支持动态更改
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Theme | 获取或设置主题。注：不支持动态更改
公共属性 | ToolbarOptions | 获取或设置toolbar。注：不支持动态更改
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | ClearStack | 清除操作堆栈,即后续无法通过undo撤销
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Redo | 取消撤销内容
公共方法 | Save | 保存富文本内容,此方法执行成功后触发onChange事件
公共方法 | Undo | 撤销上一步操作
公共方法 | UpdateDelta | 更新内容
Top
事件
 | 名称 | 说明
公共事件 | EditerChanged | 内容改变时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Editer 构造函数

构建函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Editer()
Public Sub New
参见

引用

Editer 类


Editer 属性

Editer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DefaultDelta | 获取或设置文本。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PlaceHolder | 获取或设置水印文本。注：不支持动态更改
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Theme | 获取或设置主题。注：不支持动态更改
公共属性 | ToolbarOptions | 获取或设置toolbar。注：不支持动态更改
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Editer 类


Editer.DefaultDelta 属性

EditerDefaultDelta 属性

获取或设置文本。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object[] DefaultDelta { get; set; }
Public Property DefaultDelta As Object()
    Get
    Set

属性值

类型：Object
参见

引用

Editer 类


Editer.PlaceHolder 属性

EditerPlaceHolder 属性

获取或设置水印文本。注：不支持动态更改

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string PlaceHolder { get; set; }
Public Property PlaceHolder As String
    Get
    Set

属性值

类型：String
参见

引用

Editer 类


Editer.Theme 属性

EditerTheme 属性

获取或设置主题。注：不支持动态更改

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EditerEditerTheme Theme { get; set; }
Public Property Theme As EditerEditerTheme
    Get
    Set

属性值

类型：EditerEditerTheme
参见

引用

Editer 类


Editer.ToolbarOptions 属性

EditerToolbarOptions 属性

获取或设置toolbar。注：不支持动态更改

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EditerToolBarOptions ToolbarOptions { get; }
Public ReadOnly Property ToolbarOptions As EditerToolBarOptions
    Get

属性值

类型：EditerToolBarOptions
参见

引用

Editer 类


Editer 方法

Editer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ClearStack | 清除操作堆栈,即后续无法通过undo撤销
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Redo | 取消撤销内容
公共方法 | Save | 保存富文本内容,此方法执行成功后触发onChange事件
公共方法 | Undo | 撤销上一步操作
公共方法 | UpdateDelta | 更新内容
Top
参见

引用

Editer 类


Editer.ClearStack 方法

EditerClearStack 方法

清除操作堆栈,即后续无法通过undo撤销

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ClearStack()
Public Sub ClearStack
参见

引用

Editer 类


Editer.Redo 方法

EditerRedo 方法

取消撤销内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Redo()
Public Sub Redo
参见

引用

Editer 类


Editer.Save 方法

EditerSave 方法

保存富文本内容,此方法执行成功后触发onChange事件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Save()
Public Sub Save
参见

引用

Editer 类


Editer.Undo 方法

EditerUndo 方法

撤销上一步操作

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Undo()
Public Sub Undo
参见

引用

Editer 类


Editer.UpdateDelta 方法

EditerUpdateDelta 方法

更新内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void UpdateDelta(
    Object[] data
)
Public Sub UpdateDelta (
    data As Object()
)

参数

data
类型：SystemObject

[缺少 "M:Swebui.Controls.Editer.UpdateDelta(System.Object[])" 的 <param name="data"/> 文档]

参见

引用

Editer 类


Editer 事件

Editer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | EditerChanged | 内容改变时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Editer 类


Editer.EditerChanged 事件

EditerEditerChanged 事件

内容改变时触发。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event SwebEditerChangedHandle EditerChanged
Public Event EditerChanged As SwebEditerChangedHandle

值

类型：Swebui.ControlsSwebEditerChangedHandle
备注
参见

引用

Editer 类


Editer.EditerTheme 枚举

EditerEditerTheme 枚举

Editer主题

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EditerTheme
Public Enumeration EditerTheme
成员
成员名称 | 值 | 说明
Snow | 0 |
Bubble | 1 |
参见

引用

Swebui.Controls 命名空间


EditerAttachButton 枚举

[缺少 "T:Swebui.Controls.EditerAttachButton" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EditerAttachButton
Public Enumeration EditerAttachButton
成员
成员名称 | 值 | 说明
Link | 0 |
Image | 1 |
Video | 2 |
Formula | 3 |
参见

引用

Swebui.Controls 命名空间


EditerChangedEventArgs 类

为绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsEditerChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class EditerChangedEventArgs : EventArgs
Public Class EditerChangedEventArgs
    Inherits EventArgs

EditerChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EditerChangedEventArgs | 初始化 EditerChangedEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

Swebui.Controls 命名空间


EditerChangedEventArgs 构造函数

初始化 EditerChangedEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EditerChangedEventArgs(
    Object[] data
)
Public Sub New (
    data As Object()
)

参数

data
类型：SystemObject

[缺少 "M:Swebui.Controls.EditerChangedEventArgs.#ctor(System.Object[])" 的 <param name="data"/> 文档]

参见

引用

EditerChangedEventArgs 类


EditerChangedEventArgs 属性

EditerChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

EditerChangedEventArgs 类


EditerChangedEventArgs.Data 属性

EditerChangedEventArgsData 属性

[缺少 "P:Swebui.Controls.EditerChangedEventArgs.Data" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object[] Data { get; }
Public ReadOnly Property Data As Object()
    Get

属性值

类型：Object
参见

引用

EditerChangedEventArgs 类


EditerFontStyle 枚举

[缺少 "T:Swebui.Controls.EditerFontStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EditerFontStyle
Public Enumeration EditerFontStyle
成员
成员名称 | 值 | 说明
Bold | 0 |
Italic | 1 |
Underline | 2 |
Strike | 3 |
参见

引用

Swebui.Controls 命名空间


EditerToolBarOptions 类

[缺少 "T:Swebui.Controls.EditerToolBarOptions" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsEditerToolBarOptions

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class EditerToolBarOptions
Public Class EditerToolBarOptions

EditerToolBarOptions 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EditerToolBarOptions | 初始化 EditerToolBarOptions 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Align |
公共属性 | AttachButtons |
公共属性 | BackGoundColor |
公共属性 | Clean |
公共属性 | Color |
公共属性 | Font |
公共属性 | Header |
公共属性 | ListButtons |
公共属性 | ToggledButtons |
Top
方法
名称 | 说明
DefaultOption |
Top
参见

引用

Swebui.Controls 命名空间


EditerToolBarOptions 构造函数

初始化 EditerToolBarOptions 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public EditerToolBarOptions()
Public Sub New
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions 属性

EditerToolBarOptions 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Align |
公共属性 | AttachButtons |
公共属性 | BackGoundColor |
公共属性 | Clean |
公共属性 | Color |
公共属性 | Font |
公共属性 | Header |
公共属性 | ListButtons |
公共属性 | ToggledButtons |
Top
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.Align 属性

EditerToolBarOptionsAlign 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.Align" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Align { get; set; }
Public Property Align As String()
    Get
    Set

属性值

类型：String
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.AttachButtons 属性

EditerToolBarOptionsAttachButtons 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.AttachButtons" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public AttachButton AttachButtons { get; set; }
Public Property AttachButtons As AttachButton
    Get
    Set

属性值

类型：AttachButton
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.BackGoundColor 属性

EditerToolBarOptionsBackGoundColor 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.BackGoundColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color[] BackGoundColor { get; set; }
Public Property BackGoundColor As Color()
    Get
    Set

属性值

类型：Color
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.Clean 属性

EditerToolBarOptionsClean 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.Clean" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Clean { get; set; }
Public Property Clean As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.Color 属性

EditerToolBarOptionsColor 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.Color" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color[] Color { get; set; }
Public Property Color As Color()
    Get
    Set

属性值

类型：Color
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.Font 属性

EditerToolBarOptionsFont 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.Font" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Font { get; set; }
Public Property Font As String()
    Get
    Set

属性值

类型：String
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.Header 属性

EditerToolBarOptionsHeader 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.Header" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object[] Header { get; set; }
Public Property Header As Object()
    Get
    Set

属性值

类型：Object
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.ListButtons 属性

EditerToolBarOptionsListButtons 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.ListButtons" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ListButton ListButtons { get; set; }
Public Property ListButtons As ListButton
    Get
    Set

属性值

类型：ListButton
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.ToggledButtons 属性

EditerToolBarOptionsToggledButtons 属性

[缺少 "P:Swebui.Controls.EditerToolBarOptions.ToggledButtons" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ToggledButton ToggledButtons { get; set; }
Public Property ToggledButtons As ToggledButton
    Get
    Set

属性值

类型：ToggledButton
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions 方法

EditerToolBarOptions 类型公开以下成员。

方法
名称 | 说明
DefaultOption |
Top
参见

引用

EditerToolBarOptions 类


EditerToolBarOptions.DefaultOption 方法

EditerToolBarOptionsDefaultOption 方法

[缺少 "M:Swebui.Controls.EditerToolBarOptions.DefaultOption" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static EditerToolBarOptions DefaultOption()
Public Shared Function DefaultOption As EditerToolBarOptions

返回值

类型：EditerToolBarOptions

[缺少 "M:Swebui.Controls.EditerToolBarOptions.DefaultOption" 的 <returns> 文档]

参见

引用

EditerToolBarOptions 类


EJTheme 枚举

EJ2控件主题

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum EJTheme
Public Enumeration EJTheme
成员
成员名称 | 值 | 说明
Light | 0 |
Dark | 1 |
参见

引用

Swebui.Controls 命名空间


EnablePropertyExtend 类

[缺少 "T:Swebui.Controls.EnablePropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsEnablePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class EnablePropertyExtend : SwebPropertyExtend
Public Class EnablePropertyExtend
    Inherits SwebPropertyExtend

EnablePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EnablePropertyExtend | 初始化 EnablePropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


EnablePropertyExtend 构造函数

初始化 EnablePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public EnablePropertyExtend()
Public Sub New
参见

引用

EnablePropertyExtend 类


FileOperationHandler 委托

一个委托，它表示在文件操作后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void FileOperationHandler(
    Object sender,
    ResultArgs e
)
Public Delegate Sub FileOperationHandler (
    sender As Object,
    e As ResultArgs
)

参数

sender
类型：SystemObject
e
类型：SwebuiResultArgs
参见

引用

Swebui.Controls 命名空间


FileUploadHandler 委托

一个委托，它表示在文件上传后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void FileUploadHandler(
    Object sender,
    BinaryResultArgs e
)
Public Delegate Sub FileUploadHandler (
    sender As Object,
    e As BinaryResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsBinaryResultArgs
参见

引用

Swebui.Controls 命名空间


FontBoldPropertyExtend 类

[缺少 "T:Swebui.Controls.FontBoldPropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsFontBoldPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class FontBoldPropertyExtend : SwebPropertyExtend
Public Class FontBoldPropertyExtend
    Inherits SwebPropertyExtend

FontBoldPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FontBoldPropertyExtend | 初始化 FontBoldPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


FontBoldPropertyExtend 构造函数

初始化 FontBoldPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public FontBoldPropertyExtend()
Public Sub New
参见

引用

FontBoldPropertyExtend 类


FontIcon 类

字体图标
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsFontIcon

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class FontIcon : SwebBindableControl, ISwebRenderControl
Public Class FontIcon
    Inherits SwebBindableControl
    Implements ISwebRenderControl

FontIcon 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FontIcon | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置默认绑定值。 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontName | 获取和设置字体名称。
公共属性 | ForeColor | 获取和设置控件的前景色，用于显示文本。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResourceID | 获取和设置资源名称。
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


FontIcon 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public FontIcon()
Public Sub New
参见

引用

FontIcon 类


FontIcon 属性

FontIcon 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置默认绑定值。 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontName | 获取和设置字体名称。
公共属性 | ForeColor | 获取和设置控件的前景色，用于显示文本。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResourceID | 获取和设置资源名称。
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

FontIcon 类


FontIcon.BindDisplayValue 属性

FontIconBindDisplayValue 属性

获取和设置默认绑定值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

FontIcon 类


FontIcon.FontName 属性

FontIconFontName 属性

获取和设置字体名称。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public FontIconName FontName { get; set; }
Public Property FontName As FontIconName
    Get
    Set

属性值

类型：FontIconName
参见

引用

FontIcon 类


FontIcon.ForeColor 属性

FontIconForeColor 属性

获取和设置控件的前景色，用于显示文本。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

FontIcon 类


FontIcon.ResourceID 属性

FontIconResourceID 属性

获取和设置资源名称。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourceID { get; set; }
Public Property ResourceID As String
    Get
    Set

属性值

类型：String
参见

引用

FontIcon 类


FontIcon 方法

FontIcon 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

FontIcon 类


FontIcon 事件

FontIcon 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

FontIcon 类


FontIconName 枚举

[缺少 "T:Swebui.Controls.FontIconName" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum FontIconName
Public Enumeration FontIconName
成员
成员名称 | 值 | 说明
FontAwesome | 0 |
参见

引用

Swebui.Controls 命名空间


FontItalicPropertyExtend 类

[缺少 "T:Swebui.Controls.FontItalicPropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsFontItalicPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class FontItalicPropertyExtend : SwebPropertyExtend
Public Class FontItalicPropertyExtend
    Inherits SwebPropertyExtend

FontItalicPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FontItalicPropertyExtend | 初始化 FontItalicPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


FontItalicPropertyExtend 构造函数

初始化 FontItalicPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public FontItalicPropertyExtend()
Public Sub New
参见

引用

FontItalicPropertyExtend 类


FontScalingPropertyExtend 类

设置中的TextFontScaling属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsFontScalingPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class FontScalingPropertyExtend : SwebPropertyExtend
Public Class FontScalingPropertyExtend
    Inherits SwebPropertyExtend

FontScalingPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FontScalingPropertyExtend | 初始化 FontScalingPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


FontScalingPropertyExtend 构造函数

初始化 FontScalingPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public FontScalingPropertyExtend()
Public Sub New
参见

引用

FontScalingPropertyExtend 类


FontSizePropertyExtend 类

FontSize属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsFontSizePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class FontSizePropertyExtend : SwebPropertyExtend
Public Class FontSizePropertyExtend
    Inherits SwebPropertyExtend

FontSizePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FontSizePropertyExtend | 初始化 FontSizePropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


FontSizePropertyExtend 构造函数

初始化 FontSizePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public FontSizePropertyExtend()
Public Sub New
参见

引用

FontSizePropertyExtend 类


FontWeight 枚举

字体粗细

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum FontWeight
Public Enumeration FontWeight
成员
成员名称 | 值 | 说明
Normal | 0 |
Bold | 1 |
W100 | 2 |
W200 | 3 |
W300 | 4 |
W400 | 5 |
W500 | 6 |
W600 | 7 |
W700 | 8 |
W800 | 9 |
W900 | 10 |
参见

引用

Swebui.Controls 命名空间


FormOrientation 枚举

窗体横竖屏状态

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum FormOrientation
Public Enumeration FormOrientation
成员
成员名称 | 值 | 说明
Unlock | 0 | 自动旋转
Portrait | 1 | 竖屏
Landscape | 2 | 横屏
LandscapeLeft | 3 | 左横屏
LandscapeRight | 4 | 右横屏
参见

引用

Swebui.Controls 命名空间


FormRedirectCallBackEventHandler 委托

一个委托，它表示在打开给定的窗体，并在给定的窗体关闭后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void FormRedirectCallBackEventHandler(
    SwebForm sender,
    Object args
)
Public Delegate Sub FormRedirectCallBackEventHandler (
    sender As SwebForm,
    args As Object
)

参数

sender
类型：Swebui.ControlsSwebForm
事件源
args
类型：SystemObject
包含事件数据的 args
备注
参见

引用

Swebui.Controls 命名空间


GeoType 枚举

坐标类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GeoType
Public Enumeration GeoType
成员
成员名称 | 值 | 说明
GCJ_02 | 0 | 火星坐标系
BD_09 | 1 | 百度坐标系
参见

引用

Swebui.Controls 命名空间


GetClientResourceHandler 委托

一个委托，它表示在获取客户端资源后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void GetClientResourceHandler(
    Object sender,
    ClientResourceGetResultArgs e
)
Public Delegate Sub GetClientResourceHandler (
    sender As Object,
    e As ClientResourceGetResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientResourceGetResultArgs
包含事件数据的 ClientResourceGetResultArgs
备注
参见

引用

Swebui.Controls 命名空间


GpsCallBackHandler 委托

一个委托，它表示在GPS请求后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void GpsCallBackHandler(
    Object sender,
    GPSResultArgs e
)
Public Delegate Sub GpsCallBackHandler (
    sender As Object,
    e As GPSResultArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsGPSResultArgs
参见

引用

Swebui.Controls 命名空间


GPSResultArgs 类

GPS信息
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsGPSResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GPSResultArgs : SwebComponentResultArgs
Public Class GPSResultArgs
    Inherits SwebComponentResultArgs

GPSResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GPSResultArgs | 初始化 GPSResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Latitude | 坐标纬度
公共属性 | Location | 坐标信息
公共属性 | Longitude | 坐标经度
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


GPSResultArgs 构造函数

初始化 GPSResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GPSResultArgs()
Public Sub New
参见

引用

GPSResultArgs 类


GPSResultArgs 属性

GPSResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | Latitude | 坐标纬度
公共属性 | Location | 坐标信息
公共属性 | Longitude | 坐标经度
Top
参见

引用

GPSResultArgs 类


GPSResultArgs.Latitude 属性

GPSResultArgsLatitude 属性

坐标纬度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

GPSResultArgs 类


GPSResultArgs.Location 属性

GPSResultArgsLocation 属性

坐标信息

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Location { get; set; }
Public Property Location As String
    Get
    Set

属性值

类型：String
参见

引用

GPSResultArgs 类


GPSResultArgs.Longitude 属性

GPSResultArgsLongitude 属性

坐标经度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

GPSResultArgs 类


GPSResultArgs 方法

GPSResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

GPSResultArgs 类


GridSearchData 类

[缺少 "T:Swebui.Controls.GridSearchData" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsGridSearchData

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridSearchData
Public Class GridSearchData

GridSearchData 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridSearchData | 初始化 GridSearchData 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Field |
公共属性 | Predicate |
公共属性 | SearchValue |
Top
参见

引用

Swebui.Controls 命名空间


GridSearchData 构造函数

初始化 GridSearchData 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridSearchData()
Public Sub New
参见

引用

GridSearchData 类


GridSearchData 属性

GridSearchData 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Field |
公共属性 | Predicate |
公共属性 | SearchValue |
Top
参见

引用

GridSearchData 类


GridSearchData.Field 属性

GridSearchDataField 属性

[缺少 "P:Swebui.Controls.GridSearchData.Field" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Field { get; set; }
Public Property Field As String
    Get
    Set

属性值

类型：String
参见

引用

GridSearchData 类


GridSearchData.Predicate 属性

GridSearchDataPredicate 属性

[缺少 "P:Swebui.Controls.GridSearchData.Predicate" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Predicate Predicate { get; set; }
Public Property Predicate As Predicate
    Get
    Set

属性值

类型：Predicate
参见

引用

GridSearchData 类


GridSearchData.SearchValue 属性

GridSearchDataSearchValue 属性

[缺少 "P:Swebui.Controls.GridSearchData.SearchValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] SearchValue { get; set; }
Public Property SearchValue As String()
    Get
    Set

属性值

类型：String
参见

引用

GridSearchData 类


GridView 类

数据列表
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsGridView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridView : SwebControl, ISwebRenderControl,
    ISwebEventControl, ISwebDataBindControl
Public Class GridView
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl, ISwebDataBindControl

GridView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridView | 构建函数
Top
属性
 | 名称 | 说明
公共属性 | AllowFiltering | 获取和设置一个值，该值指示是否允许过滤
公共属性 | AllowPaging | 获取和设置一个值，该值指示是否在页脚处显示分页器
公共属性 | AllowSorting | 获取和设置是否点击表头排序
公共属性 | AllowTextWrap | 获取和设置是否允许自动换行
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 数据绑定类型
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | Columns | 获取和设置GridView列
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | EditSetting | 获取和设置GridView 的编辑设置
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置文字大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GridLines | 获取和设置分隔线
公共属性 | HeaderHeight | 获取和设置表头高度
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageSetting | 分页设置
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | RowClickEventRaise | 获取和设置一个值，该值指示是否触发行点击
公共属性 | RowHeight | 获取和设置Row高度
公共属性 | RowWidth | 获取和设置Row宽度
公共属性 | SelectBackgroundColor | 获取和设置选中行背景颜色
公共属性 | SelectionSetting | 获取和设置GridView的选择设置
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | AddRows | 添加行
公共方法 | CancelChange | 取消修改 注：在点击OK时触发事件
公共方法 | DataBind | 数据绑定
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | GetSelectedRows | 获取选择的行
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnDataSourceUpdate | 数据更新
公共方法 | Reload | 刷新数据
公共方法 | RemoveRow | 删除行
公共方法 | SaveChange | 保存修改 注：在点击OK时触发事件
公共方法 | SearchRow | 搜索符合给定条件的行
公共方法 | UpdateRows | 更新行
Top
事件
 | 名称 | 说明
公共事件 | CellSave | 在编辑框修改结束时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | RowCancel | 在用户取消行更改时触发
公共事件 | RowClick | 在用户点击行的时候触发
公共事件 | RowSave | 在用户保存当前页行更改数据时触发
Top
参见

引用

Swebui.Controls 命名空间


GridView 构造函数

构建函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridView()
Public Sub New
参见

引用

GridView 类


GridView 属性

GridView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowFiltering | 获取和设置一个值，该值指示是否允许过滤
公共属性 | AllowPaging | 获取和设置一个值，该值指示是否在页脚处显示分页器
公共属性 | AllowSorting | 获取和设置是否点击表头排序
公共属性 | AllowTextWrap | 获取和设置是否允许自动换行
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 数据绑定类型
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | Columns | 获取和设置GridView列
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | EditSetting | 获取和设置GridView 的编辑设置
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置文字大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GridLines | 获取和设置分隔线
公共属性 | HeaderHeight | 获取和设置表头高度
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageSetting | 分页设置
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | RowClickEventRaise | 获取和设置一个值，该值指示是否触发行点击
公共属性 | RowHeight | 获取和设置Row高度
公共属性 | RowWidth | 获取和设置Row宽度
公共属性 | SelectBackgroundColor | 获取和设置选中行背景颜色
公共属性 | SelectionSetting | 获取和设置GridView的选择设置
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

GridView 类


GridView.AllowFiltering 属性

GridViewAllowFiltering 属性

获取和设置一个值，该值指示是否允许过滤

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowFiltering { get; set; }
Public Property AllowFiltering As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridView 类


GridView.AllowPaging 属性

GridViewAllowPaging 属性

获取和设置一个值，该值指示是否在页脚处显示分页器

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowPaging { get; set; }
Public Property AllowPaging As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridView 类


GridView.AllowSorting 属性

GridViewAllowSorting 属性

获取和设置是否点击表头排序

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowSorting { get; set; }
Public Property AllowSorting As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridView 类


GridView.AllowTextWrap 属性

GridViewAllowTextWrap 属性

获取和设置是否允许自动换行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowTextWrap { get; set; }
Public Property AllowTextWrap As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridView 类


GridView.BindMode 属性

GridViewBindMode 属性

数据绑定类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DataBindMode BindMode { get; set; }
Public Property BindMode As DataBindMode
    Get
    Set

属性值

类型：DataBindMode

实现

ISwebDataBindControlBindMode
参见

引用

GridView 类


GridView.Color 属性

GridViewColor 属性

获取和设置文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

属性值

类型：Color
参见

引用

GridView 类


GridView.Columns 属性

GridViewColumns 属性

获取和设置GridView列

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewColumnCollection Columns { get; }
Public ReadOnly Property Columns As GridViewColumnCollection
    Get

属性值

类型：GridViewColumnCollection
参见

引用

GridView 类


GridView.DataMember 属性

GridViewDataMember 属性

获取或设置数据源名称

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string DataMember { get; set; }
Public Property DataMember As String
    Get
    Set

属性值

类型：String

实现

ISwebDataBindControlDataMember
参见

引用

GridView 类


GridView.DataSource 属性

GridViewDataSource 属性

获取或设置表格数据源

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object DataSource { get; set; }
Public Property DataSource As Object
    Get
    Set

属性值

类型：Object

实现

ISwebDataBindControlDataSource
参见

引用

GridView 类


GridView.EditSetting 属性

GridViewEditSetting 属性

获取和设置GridView 的编辑设置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewEditSetting EditSetting { get; }
Public ReadOnly Property EditSetting As GridViewEditSetting
    Get

属性值

类型：GridViewEditSetting
参见

引用

GridView 类


GridView.FontSize 属性

GridViewFontSize 属性

获取和设置文字大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

GridView 类


GridView.GridLines 属性

GridViewGridLines 属性

获取和设置分隔线

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewLines GridLines { get; set; }
Public Property GridLines As GridViewLines
    Get
    Set

属性值

类型：GridViewLines
参见

引用

GridView 类


GridView.HeaderHeight 属性

GridViewHeaderHeight 属性

获取和设置表头高度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int HeaderHeight { get; set; }
Public Property HeaderHeight As Integer
    Get
    Set

属性值

类型：Int32
备注
配置此属性会影响所有gridView的表头高度
参见

引用

GridView 类


GridView.PageSetting 属性

GridViewPageSetting 属性

分页设置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewPageSetting PageSetting { get; }
Public ReadOnly Property PageSetting As GridViewPageSetting
    Get

属性值

类型：GridViewPageSetting
参见

引用

GridView 类


GridView.RowClickEventRaise 属性

GridViewRowClickEventRaise 属性

获取和设置一个值，该值指示是否触发行点击

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool RowClickEventRaise { get; set; }
Public Property RowClickEventRaise As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridView 类


GridView.RowHeight 属性

GridViewRowHeight 属性

获取和设置Row高度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int RowHeight { get; set; }
Public Property RowHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

GridView 类


GridView.RowWidth 属性

GridViewRowWidth 属性

获取和设置Row宽度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int RowWidth { get; set; }
Public Property RowWidth As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

GridView 类


GridView.SelectBackgroundColor 属性

GridViewSelectBackgroundColor 属性

获取和设置选中行背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectBackgroundColor { get; set; }
Public Property SelectBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

GridView 类


GridView.SelectionSetting 属性

GridViewSelectionSetting 属性

获取和设置GridView的选择设置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSelectionSetting SelectionSetting { get; }
Public ReadOnly Property SelectionSetting As GridViewSelectionSetting
    Get

属性值

类型：GridViewSelectionSetting
参见

引用

GridView 类


GridView 方法

GridView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddRows | 添加行
公共方法 | CancelChange | 取消修改 注：在点击OK时触发事件
公共方法 | DataBind | 数据绑定
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | GetSelectedRows | 获取选择的行
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnDataSourceUpdate | 数据更新
公共方法 | Reload | 刷新数据
公共方法 | RemoveRow | 删除行
公共方法 | SaveChange | 保存修改 注：在点击OK时触发事件
公共方法 | SearchRow | 搜索符合给定条件的行
公共方法 | UpdateRows | 更新行
Top
参见

引用

GridView 类


GridView.AddRows 方法

GridViewAddRows 方法

添加行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void AddRows(
    Object data
)
Public Sub AddRows (
    data As Object
)

参数

data
类型：SystemObject

[缺少 "M:Swebui.Controls.GridView.AddRows(System.Object)" 的 <param name="data"/> 文档]

参见

引用

GridView 类


GridView.CancelChange 方法

GridViewCancelChange 方法

取消修改 注：在点击OK时触发事件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void CancelChange()
Public Sub CancelChange
参见

引用

GridView 类


GridView.DataBind 方法

GridViewDataBind 方法

数据绑定

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void DataBind(
    params Object[] params
)
Public Sub DataBind (
    ParamArray params As Object()
)

参数

params
类型：SystemObject

[缺少 "M:Swebui.Controls.GridView.DataBind(System.Object[])" 的 <param name="params"/> 文档]

实现

ISwebDataBindControlDataBind(Object)
参见

引用

GridView 类


GridView.GetSelectedRows 方法

GridViewGetSelectedRows 方法

获取选择的行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void GetSelectedRows(
    GridViewSelectedRowsEventHandler handler
)
Public Sub GetSelectedRows (
    handler As GridViewSelectedRowsEventHandler
)

参数

handler
类型：Swebui.ControlsGridViewSelectedRowsEventHandler
选择行回调
参见

引用

GridView 类


GridView.OnDataSourceUpdate 方法

GridViewOnDataSourceUpdate 方法

数据更新

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnDataSourceUpdate(
    DataSourceUpdateEventArgs e
)
Public Sub OnDataSourceUpdate (
    e As DataSourceUpdateEventArgs
)

参数

e
类型：Swebui.ControlsDataSourceUpdateEventArgs

[缺少 "M:Swebui.Controls.GridView.OnDataSourceUpdate(Swebui.Controls.DataSourceUpdateEventArgs)" 的 <param name="e"/> 文档]

实现

ISwebDataBindControlOnDataSourceUpdate(DataSourceUpdateEventArgs)
参见

引用

GridView 类


GridView.Reload 方法

GridViewReload 方法

刷新数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Reload(
    Object data
)
Public Sub Reload (
    data As Object
)

参数

data
类型：SystemObject

[缺少 "M:Swebui.Controls.GridView.Reload(System.Object)" 的 <param name="data"/> 文档]

参见

引用

GridView 类


GridView.RemoveRow 方法

GridViewRemoveRow 方法

删除行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void RemoveRow()
Public Sub RemoveRow
参见

引用

GridView 类


GridView.SaveChange 方法

GridViewSaveChange 方法

保存修改 注：在点击OK时触发事件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void SaveChange()
Public Sub SaveChange
参见

引用

GridView 类


GridView.SearchRow 方法

GridViewSearchRow 方法

搜索符合给定条件的行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void SearchRow(
    List<GridSearchData> searchdata
)
Public Sub SearchRow (
    searchdata As List(Of GridSearchData)
)

参数

searchdata
类型：System.Collections.GenericList GridSearchData

[缺少 "M:Swebui.Controls.GridView.SearchRow(System.Collections.Generic.List{Swebui.Controls.GridSearchData})" 的 <param name="searchdata"/> 文档]

参见

引用

GridView 类


GridView.UpdateRows 方法

GridViewUpdateRows 方法

更新行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void UpdateRows(
    int[] indexs,
    Object data
)
Public Sub UpdateRows (
    indexs As Integer(),
    data As Object
)

参数

indexs
类型：SystemInt32

[缺少 "M:Swebui.Controls.GridView.UpdateRows(System.Int32[],System.Object)" 的 <param name="indexs"/> 文档]

data
类型：SystemObject

[缺少 "M:Swebui.Controls.GridView.UpdateRows(System.Int32[],System.Object)" 的 <param name="data"/> 文档]

参见

引用

GridView 类


GridView 事件

GridView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | CellSave | 在编辑框修改结束时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | RowCancel | 在用户取消行更改时触发
公共事件 | RowClick | 在用户点击行的时候触发
公共事件 | RowSave | 在用户保存当前页行更改数据时触发
Top
参见

引用

GridView 类


GridView.CellSave 事件

GridViewCellSave 事件

在编辑框修改结束时触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event GridViewCellSaveEventHandler CellSave
Public Event CellSave As GridViewCellSaveEventHandler

值

类型：Swebui.ControlsGridViewCellSaveEventHandler
参见

引用

GridView 类


GridView.RowCancel 事件

GridViewRowCancel 事件

在用户取消行更改时触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler RowCancel
Public Event RowCancel As EventHandler

值

类型：SystemEventHandler
参见

引用

GridView 类


GridView.RowClick 事件

GridViewRowClick 事件

在用户点击行的时候触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event GridViewRowClickEventHandler RowClick
Public Event RowClick As GridViewRowClickEventHandler

值

类型：Swebui.ControlsGridViewRowClickEventHandler
参见

引用

GridView 类


GridView.RowSave 事件

GridViewRowSave 事件

在用户保存当前页行更改数据时触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event GridViewSaveChangeEventHandler RowSave
Public Event RowSave As GridViewSaveChangeEventHandler

值

类型：Swebui.ControlsGridViewSaveChangeEventHandler
参见

引用

GridView 类


GridViewCellSaveEventArgs 类

为 GridViewCellSaveEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsGridViewCellSaveEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridViewCellSaveEventArgs : EventArgs
Public Class GridViewCellSaveEventArgs
    Inherits EventArgs

GridViewCellSaveEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewCellSaveEventArgs | 初始化 GridViewCellSaveEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ColumnName | 修改单元格列名
公共属性 | RowData | 当前行原始数据
公共属性 | Value | 修改内容
Top
参见

引用

Swebui.Controls 命名空间


GridViewCellSaveEventArgs 构造函数

初始化 GridViewCellSaveEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewCellSaveEventArgs()
Public Sub New
参见

引用

GridViewCellSaveEventArgs 类


GridViewCellSaveEventArgs 属性

GridViewCellSaveEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnName | 修改单元格列名
公共属性 | RowData | 当前行原始数据
公共属性 | Value | 修改内容
Top
参见

引用

GridViewCellSaveEventArgs 类


GridViewCellSaveEventArgs.ColumnName 属性

GridViewCellSaveEventArgsColumnName 属性

修改单元格列名

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ColumnName { get; set; }
Public Property ColumnName As String
    Get
    Set

属性值

类型：String
参见

引用

GridViewCellSaveEventArgs 类


GridViewCellSaveEventArgs.RowData 属性

GridViewCellSaveEventArgsRowData 属性

当前行原始数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Dictionary<string, Object> RowData { get; set; }
Public Property RowData As Dictionary(Of String, Object)
    Get
    Set

属性值

类型：Dictionary String, Object
参见

引用

GridViewCellSaveEventArgs 类


GridViewCellSaveEventArgs.Value 属性

GridViewCellSaveEventArgsValue 属性

修改内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

属性值

类型：Object
参见

引用

GridViewCellSaveEventArgs 类


GridViewCellSaveEventHandler 委托

一个委托，它表示单元格编辑结束的回调。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void GridViewCellSaveEventHandler(
    Object sender,
    GridViewCellSaveEventArgs e
)
Public Delegate Sub GridViewCellSaveEventHandler (
    sender As Object,
    e As GridViewCellSaveEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsGridViewCellSaveEventArgs
包含事件数据的 GridViewCellSaveEventArgs
参见

引用

Swebui.Controls 命名空间


GridViewCellType 枚举

单元格类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewCellType
Public Enumeration GridViewCellType
成员
成员名称 | 值 | 说明
View | 0 | 默认显示
Checkbox | 1 | 选择框
Edit | 2 | 编辑框
Image | 3 | 图片
参见

引用

Swebui.Controls 命名空间


GridViewColumn 类

GridViewColumn设置
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsGridViewColumn

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class GridViewColumn : SwebViewCollectionItem
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class GridViewColumn
    Inherits SwebViewCollectionItem

GridViewColumn 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewColumn | 初始化 GridViewColumn 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayMember | 列对应数据库数据
公共属性 | HeaderText | 标题内容
公共属性 | IsPrimaryKey | 获取和设置一个值，该值是否为主列
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TextAlign | 获取和设置一个值，该值指示文本对齐
公共属性 | Type | 列类型
公共属性 | Width | 获取和设置一个值，该值指示列宽度
Top
参见

引用

Swebui.Controls 命名空间


GridViewColumn 构造函数

初始化 GridViewColumn 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewColumn()
Public Sub New
参见

引用

GridViewColumn 类


GridViewColumn 属性

GridViewColumn 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayMember | 列对应数据库数据
公共属性 | HeaderText | 标题内容
公共属性 | IsPrimaryKey | 获取和设置一个值，该值是否为主列
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | TextAlign | 获取和设置一个值，该值指示文本对齐
公共属性 | Type | 列类型
公共属性 | Width | 获取和设置一个值，该值指示列宽度
Top
参见

引用

GridViewColumn 类


GridViewColumn.DisplayMember 属性

GridViewColumnDisplayMember 属性

列对应数据库数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string DisplayMember { get; set; }
Public Property DisplayMember As String
    Get
    Set

属性值

类型：String
参见

引用

GridViewColumn 类


GridViewColumn.HeaderText 属性

GridViewColumnHeaderText 属性

标题内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string HeaderText { get; set; }
Public Property HeaderText As String
    Get
    Set

属性值

类型：String
参见

引用

GridViewColumn 类


GridViewColumn.IsPrimaryKey 属性

GridViewColumnIsPrimaryKey 属性

获取和设置一个值，该值是否为主列

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool IsPrimaryKey { get; set; }
Public Property IsPrimaryKey As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewColumn 类


GridViewColumn.TextAlign 属性

GridViewColumnTextAlign 属性

获取和设置一个值，该值指示文本对齐

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HorizontalAlignment TextAlign { get; set; }
Public Property TextAlign As HorizontalAlignment
    Get
    Set

属性值

类型：HorizontalAlignment
参见

引用

GridViewColumn 类


GridViewColumn.Type 属性

GridViewColumnType 属性

列类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewCellType Type { get; set; }
Public Property Type As GridViewCellType
    Get
    Set

属性值

类型：GridViewCellType
参见

引用

GridViewColumn 类


GridViewColumn.Width 属性

GridViewColumnWidth 属性

获取和设置一个值，该值指示列宽度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Width { get; set; }
Public Property Width As Single
    Get
    Set

属性值

类型：Single
参见

引用

GridViewColumn 类


GridViewColumnCollection 类

GridViewCellSetting集合
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase GridViewColumn
Swebui.ControlsGridViewColumnCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridViewColumnCollection : SwebViewCollectionBase<GridViewColumn>
Public Class GridViewColumnCollection
    Inherits SwebViewCollectionBase(Of GridViewColumn)

GridViewColumnCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewColumnCollection | 初始化 GridViewColumnCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


GridViewColumnCollection 构造函数

初始化 GridViewColumnCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewColumnCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.GridViewColumnCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

GridViewColumnCollection 类


GridViewColumnCollection 属性

GridViewColumnCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

GridViewColumnCollection 类


GridViewColumnCollection 方法

GridViewColumnCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

GridViewColumnCollection 类


GridViewEditMode 枚举

GridView编辑模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewEditMode
Public Enumeration GridViewEditMode
成员
成员名称 | 值 | 说明
Nomal | 0 |
Dialog | 1 |
Batch | 2 |
参见

引用

Swebui.Controls 命名空间


GridViewEditSetting 类

GridView编辑设置
继承层次
SystemObject
Swebui.ControlsGridViewEditSetting

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class GridViewEditSetting
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class GridViewEditSetting

GridViewEditSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewEditSetting | 初始化 GridViewEditSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowAdding | 获取和设置一个值，该值指示是否允许添加新行
公共属性 | AllowDeleting | 获取和设置一个值，该值指示是否允许删除行
公共属性 | AllowEditing | 获取和设置一个值，该值指示是否允许在现有的记录中更新
公共属性 | NewRowPosition | 获取和设置一个值，该值指示添加新行的位置
Top
参见

引用

Swebui.Controls 命名空间


GridViewEditSetting 构造函数

初始化 GridViewEditSetting 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewEditSetting()
Public Sub New
参见

引用

GridViewEditSetting 类


GridViewEditSetting 属性

GridViewEditSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowAdding | 获取和设置一个值，该值指示是否允许添加新行
公共属性 | AllowDeleting | 获取和设置一个值，该值指示是否允许删除行
公共属性 | AllowEditing | 获取和设置一个值，该值指示是否允许在现有的记录中更新
公共属性 | NewRowPosition | 获取和设置一个值，该值指示添加新行的位置
Top
参见

引用

GridViewEditSetting 类


GridViewEditSetting.AllowAdding 属性

GridViewEditSettingAllowAdding 属性

获取和设置一个值，该值指示是否允许添加新行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowAdding { get; set; }
Public Property AllowAdding As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewEditSetting 类


GridViewEditSetting.AllowDeleting 属性

GridViewEditSettingAllowDeleting 属性

获取和设置一个值，该值指示是否允许删除行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowDeleting { get; set; }
Public Property AllowDeleting As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewEditSetting 类


GridViewEditSetting.AllowEditing 属性

GridViewEditSettingAllowEditing 属性

获取和设置一个值，该值指示是否允许在现有的记录中更新

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewEditSetting 类


GridViewEditSetting.NewRowPosition 属性

GridViewEditSettingNewRowPosition 属性

获取和设置一个值，该值指示添加新行的位置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewNewRowPosition NewRowPosition { get; set; }
Public Property NewRowPosition As GridViewNewRowPosition
    Get
    Set

属性值

类型：GridViewNewRowPosition
参见

引用

GridViewEditSetting 类


GridViewLines 枚举

分隔线类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewLines
Public Enumeration GridViewLines
成员
成员名称 | 值 | 说明
Both | 0 |
None | 1 |
Horizontal | 2 |
Vertical | 3 |
Default | 4 |
参见

引用

Swebui.Controls 命名空间


GridViewNewRowPosition 枚举

添加新行的位置

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewNewRowPosition
Public Enumeration GridViewNewRowPosition
成员
成员名称 | 值 | 说明
Top | 0 |
Bottom | 1 |
参见

引用

Swebui.Controls 命名空间


GridViewPageSetting 类

GridView编辑设置
继承层次
SystemObject
Swebui.ControlsGridViewPageSetting

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class GridViewPageSetting
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class GridViewPageSetting

GridViewPageSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewPageSetting | 初始化 GridViewPageSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CurrentPage | 获取和设置一个值，该值指示当前页码
公共属性 | EnableQueryString | 获取和设置一个值，该值指示是否传递页面信息
公共属性 | PageCount | 获取和设置一个值，该值指示显示的页面数
公共属性 | PageSize | 获取和设置一个值，该值指示每页显示的记录数
公共属性 | PageSizeSelector | 获取和设置一个值，该值指示是否以下拉框显示页码
Top
参见

引用

Swebui.Controls 命名空间


GridViewPageSetting 构造函数

初始化 GridViewPageSetting 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewPageSetting()
Public Sub New
参见

引用

GridViewPageSetting 类


GridViewPageSetting 属性

GridViewPageSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CurrentPage | 获取和设置一个值，该值指示当前页码
公共属性 | EnableQueryString | 获取和设置一个值，该值指示是否传递页面信息
公共属性 | PageCount | 获取和设置一个值，该值指示显示的页面数
公共属性 | PageSize | 获取和设置一个值，该值指示每页显示的记录数
公共属性 | PageSizeSelector | 获取和设置一个值，该值指示是否以下拉框显示页码
Top
参见

引用

GridViewPageSetting 类


GridViewPageSetting.CurrentPage 属性

GridViewPageSettingCurrentPage 属性

获取和设置一个值，该值指示当前页码

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int CurrentPage { get; set; }
Public Property CurrentPage As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

GridViewPageSetting 类


GridViewPageSetting.EnableQueryString 属性

GridViewPageSettingEnableQueryString 属性

获取和设置一个值，该值指示是否传递页面信息

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool EnableQueryString { get; set; }
Public Property EnableQueryString As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewPageSetting 类


GridViewPageSetting.PageCount 属性

GridViewPageSettingPageCount 属性

获取和设置一个值，该值指示显示的页面数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PageCount { get; set; }
Public Property PageCount As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

GridViewPageSetting 类


GridViewPageSetting.PageSize 属性

GridViewPageSettingPageSize 属性

获取和设置一个值，该值指示每页显示的记录数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PageSize { get; set; }
Public Property PageSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

GridViewPageSetting 类


GridViewPageSetting.PageSizeSelector 属性

GridViewPageSettingPageSizeSelector 属性

获取和设置一个值，该值指示是否以下拉框显示页码

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool PageSizeSelector { get; set; }
Public Property PageSizeSelector As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewPageSetting 类


GridViewRowClickEventArgs 类

为 GridViewRowClickEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsGridViewRowClickEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridViewRowClickEventArgs : EventArgs
Public Class GridViewRowClickEventArgs
    Inherits EventArgs

GridViewRowClickEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewRowClickEventArgs | 初始化 GridViewRowClickEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CurrentRow | 获取和设置点击的当前行。
Top
参见

引用

Swebui.Controls 命名空间


GridViewRowClickEventArgs 构造函数

初始化 GridViewRowClickEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewRowClickEventArgs()
Public Sub New
参见

引用

GridViewRowClickEventArgs 类


GridViewRowClickEventArgs 属性

GridViewRowClickEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CurrentRow | 获取和设置点击的当前行。
Top
参见

引用

GridViewRowClickEventArgs 类


GridViewRowClickEventArgs.CurrentRow 属性

GridViewRowClickEventArgsCurrentRow 属性

获取和设置点击的当前行。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Dictionary<string, Object> CurrentRow { get; set; }
Public Property CurrentRow As Dictionary(Of String, Object)
    Get
    Set

属性值

类型：Dictionary String, Object
参见

引用

GridViewRowClickEventArgs 类


GridViewRowClickEventHandler 委托

一个委托，它表示行点击要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void GridViewRowClickEventHandler(
    Object sender,
    GridViewRowClickEventArgs e
)
Public Delegate Sub GridViewRowClickEventHandler (
    sender As Object,
    e As GridViewRowClickEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsGridViewRowClickEventArgs
包含事件数据的 GridViewRowClickEventArgs
参见

引用

Swebui.Controls 命名空间


GridViewSaveChangeEventArgs 类

为 GridViewSaveChangeEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsGridViewSaveChangeEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridViewSaveChangeEventArgs : EventArgs
Public Class GridViewSaveChangeEventArgs
    Inherits EventArgs

GridViewSaveChangeEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewSaveChangeEventArgs | 初始化 GridViewSaveChangeEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CurrentPageRows | 获取和设置当前页数据 。
Top
参见

引用

Swebui.Controls 命名空间


GridViewSaveChangeEventArgs 构造函数

初始化 GridViewSaveChangeEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSaveChangeEventArgs()
Public Sub New
参见

引用

GridViewSaveChangeEventArgs 类


GridViewSaveChangeEventArgs 属性

GridViewSaveChangeEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CurrentPageRows | 获取和设置当前页数据 。
Top
参见

引用

GridViewSaveChangeEventArgs 类


GridViewSaveChangeEventArgs.CurrentPageRows 属性

GridViewSaveChangeEventArgsCurrentPageRows 属性

获取和设置当前页数据 。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public List<Dictionary<string, Object>> CurrentPageRows { get; set; }
Public Property CurrentPageRows As List(Of Dictionary(Of String, Object))
    Get
    Set

属性值

类型：List Dictionary String, Object
参见

引用

GridViewSaveChangeEventArgs 类


GridViewSaveChangeEventHandler 委托

一个委托，它表示保存当前页行更改时要调用的数据。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void GridViewSaveChangeEventHandler(
    Object sender,
    GridViewSaveChangeEventArgs e
)
Public Delegate Sub GridViewSaveChangeEventHandler (
    sender As Object,
    e As GridViewSaveChangeEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsGridViewSaveChangeEventArgs
包含事件数据的 GridViewSaveChangeEventArgs
参见

引用

Swebui.Controls 命名空间


GridViewSelectedRowsEventArgs 类

为 GridViewSelectedRowsEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsGridViewSelectedRowsEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class GridViewSelectedRowsEventArgs : EventArgs
Public Class GridViewSelectedRowsEventArgs
    Inherits EventArgs

GridViewSelectedRowsEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewSelectedRowsEventArgs | 初始化 GridViewSelectedRowsEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | SelectedRows | 获取和设置选择的行。
Top
参见

引用

Swebui.Controls 命名空间


GridViewSelectedRowsEventArgs 构造函数

初始化 GridViewSelectedRowsEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSelectedRowsEventArgs()
Public Sub New
参见

引用

GridViewSelectedRowsEventArgs 类


GridViewSelectedRowsEventArgs 属性

GridViewSelectedRowsEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | SelectedRows | 获取和设置选择的行。
Top
参见

引用

GridViewSelectedRowsEventArgs 类


GridViewSelectedRowsEventArgs.SelectedRows 属性

GridViewSelectedRowsEventArgsSelectedRows 属性

获取和设置选择的行。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public List<Dictionary<string, Object>> SelectedRows { get; set; }
Public Property SelectedRows As List(Of Dictionary(Of String, Object))
    Get
    Set

属性值

类型：List Dictionary String, Object
参见

引用

GridViewSelectedRowsEventArgs 类


GridViewSelectedRowsEventHandler 委托

一个委托，它表示获取选择行要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void GridViewSelectedRowsEventHandler(
    Object sender,
    GridViewSelectedRowsEventArgs e
)
Public Delegate Sub GridViewSelectedRowsEventHandler (
    sender As Object,
    e As GridViewSelectedRowsEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsGridViewSelectedRowsEventArgs
包含事件数据的 GridViewSelectedRowsEventArgs
参见

引用

Swebui.Controls 命名空间


GridViewSelectionMode 枚举

GridView行选择模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewSelectionMode
Public Enumeration GridViewSelectionMode
成员
成员名称 | 值 | 说明
Row | 0 | 行
Cell | 1 | 单元格
Both | 2 | 行和单元格
参见

引用

Swebui.Controls 命名空间


GridViewSelectionSetting 类

GridView选择设置
继承层次
SystemObject
Swebui.ControlsGridViewSelectionSetting

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class GridViewSelectionSetting
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class GridViewSelectionSetting

GridViewSelectionSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GridViewSelectionSetting | 初始化 GridViewSelectionSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowColumnSelection | 获取和设置一个值，该值指示是否允许选择列
公共属性 | CheckBoxOnly | 获取和设置一个值，该值指示是否仅允许通过CheckBox选择
公共属性 | PersistSelection | 获取和设置一个值，该值指示是否持久选择
公共属性 | SelectionMode | 获取和设置行选择模式
公共属性 | SelectionType | 选择模式
公共属性 | SimpleMultiRowSelection | 获取和设置一个值，该值指示是否允许执行多选和选中行回调
Top
参见

引用

Swebui.Controls 命名空间


GridViewSelectionSetting 构造函数

初始化 GridViewSelectionSetting 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSelectionSetting()
Public Sub New
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting 属性

GridViewSelectionSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowColumnSelection | 获取和设置一个值，该值指示是否允许选择列
公共属性 | CheckBoxOnly | 获取和设置一个值，该值指示是否仅允许通过CheckBox选择
公共属性 | PersistSelection | 获取和设置一个值，该值指示是否持久选择
公共属性 | SelectionMode | 获取和设置行选择模式
公共属性 | SelectionType | 选择模式
公共属性 | SimpleMultiRowSelection | 获取和设置一个值，该值指示是否允许执行多选和选中行回调
Top
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.AllowColumnSelection 属性

GridViewSelectionSettingAllowColumnSelection 属性

获取和设置一个值，该值指示是否允许选择列

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AllowColumnSelection { get; set; }
Public Property AllowColumnSelection As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.CheckBoxOnly 属性

GridViewSelectionSettingCheckBoxOnly 属性

获取和设置一个值，该值指示是否仅允许通过CheckBox选择

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool CheckBoxOnly { get; set; }
Public Property CheckBoxOnly As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.PersistSelection 属性

GridViewSelectionSettingPersistSelection 属性

获取和设置一个值，该值指示是否持久选择

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool PersistSelection { get; set; }
Public Property PersistSelection As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.SelectionMode 属性

GridViewSelectionSettingSelectionMode 属性

获取和设置行选择模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As GridViewSelectionMode
    Get
    Set

属性值

类型：GridViewSelectionMode
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.SelectionType 属性

GridViewSelectionSettingSelectionType 属性

选择模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GridViewSelectionType SelectionType { get; set; }
Public Property SelectionType As GridViewSelectionType
    Get
    Set

属性值

类型：GridViewSelectionType
参见

引用

GridViewSelectionSetting 类


GridViewSelectionSetting.SimpleMultiRowSelection 属性

GridViewSelectionSettingSimpleMultiRowSelection 属性

获取和设置一个值，该值指示是否允许执行多选和选中行回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool SimpleMultiRowSelection { get; set; }
Public Property SimpleMultiRowSelection As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

GridViewSelectionSetting 类


GridViewSelectionType 枚举

GrdiView选择模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum GridViewSelectionType
Public Enumeration GridViewSelectionType
成员
成员名称 | 值 | 说明
Single | 0 | 单行
Multiple | 1 | 多行
参见

引用

Swebui.Controls 命名空间


HorizontalAlignment 枚举

水平方面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum HorizontalAlignment
Public Enumeration HorizontalAlignment
成员
成员名称 | 值 | 说明
Left | 0 | 左
Center | 1 | 中
Right | 2 | 右
Justify | 3 | 两端对齐
备注
参见

引用

Swebui.Controls 命名空间


HTMLView 类

超文本控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsHTMLView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class HTMLView : SwebNativeControl
Public Class HTMLView
    Inherits SwebNativeControl

HTMLView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | HTMLView | 初始化 HTMLView 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HTML | 获取与设置HTML
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TextSelectable | 获取与设置是否允许修改文本内容
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | URI | 获取与设置HTML
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


HTMLView 构造函数

初始化 HTMLView 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HTMLView()
Public Sub New
参见

引用

HTMLView 类


HTMLView 属性

HTMLView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HTML | 获取与设置HTML
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TextSelectable | 获取与设置是否允许修改文本内容
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | URI | 获取与设置HTML
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

HTMLView 类


HTMLView.HTML 属性

HTMLViewHTML 属性

获取与设置HTML

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string HTML { get; set; }
Public Property HTML As String
    Get
    Set

属性值

类型：String
参见

引用

HTMLView 类


HTMLView.TextSelectable 属性

HTMLViewTextSelectable 属性

获取与设置是否允许修改文本内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool TextSelectable { get; set; }
Public Property TextSelectable As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

HTMLView 类


HTMLView.URI 属性

HTMLViewURI 属性

获取与设置HTML

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string URI { get; set; }
Public Property URI As String
    Get
    Set

属性值

类型：String
参见

引用

HTMLView 类


HTMLView 方法

HTMLView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

HTMLView 类


HTMLView 事件

HTMLView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

HTMLView 类


Image 类

图像控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsImage

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Image : SwebBindableControl, ISwebRenderControl,
    ISwebResourceControl
Public Class Image
    Inherits SwebBindableControl
    Implements ISwebRenderControl, ISwebResourceControl

Image 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Image | 初始化 Image 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResouceData |
公共属性 | ResourceContentType |
公共属性 | ResourceID |
公共属性 | ResourceMode |
公共属性 | ResourcePath | 获取或设置图像资源路径
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SizeMode |
公共属性 | SourceHotReadload | 同名图片是否刷新
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
公共属性 | Zooming |
公共属性 | ZoomingResouceData |
公共属性 | ZoomingResourceID |
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetHttpResourceEntity |
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Refresh | 重新加载资源
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Image 构造函数

初始化 Image 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Image()
Public Sub New
参见

引用

Image 类


Image 属性

Image 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResouceData |
公共属性 | ResourceContentType |
公共属性 | ResourceID |
公共属性 | ResourceMode |
公共属性 | ResourcePath | 获取或设置图像资源路径
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SizeMode |
公共属性 | SourceHotReadload | 同名图片是否刷新
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
公共属性 | Zooming |
公共属性 | ZoomingResouceData |
公共属性 | ZoomingResourceID |
Top
参见

引用

Image 类


Image.BindDisplayValue 属性

ImageBindDisplayValue 属性

[缺少 "P:Swebui.Controls.Image.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

Image 类


Image.DisplayFormat 属性

ImageDisplayFormat 属性

[缺少 "P:Swebui.Controls.Image.DisplayFormat" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string DisplayFormat { get; set; }
Public Overrides Property DisplayFormat As String
    Get
    Set

属性值

类型：String
参见

引用

Image 类


Image.Padding 属性

ImagePadding 属性

[缺少 "P:Swebui.Controls.Image.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

Image 类


Image.ResouceData 属性

ImageResouceData 属性

[缺少 "P:Swebui.Controls.Image.ResouceData" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public byte[] ResouceData { get; set; }
Public Property ResouceData As Byte()
    Get
    Set

属性值

类型：Byte
参见

引用

Image 类


Image.ResourceContentType 属性

ImageResourceContentType 属性

[缺少 "P:Swebui.Controls.Image.ResourceContentType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourceContentType { get; set; }
Public Property ResourceContentType As String
    Get
    Set

属性值

类型：String

实现

ISwebResourceControlResourceContentType
参见

引用

Image 类


Image.ResourceID 属性

ImageResourceID 属性

[缺少 "P:Swebui.Controls.Image.ResourceID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourceID { get; set; }
Public Property ResourceID As String
    Get
    Set

属性值

类型：String

实现

ISwebResourceControlResourceID
参见

引用

Image 类


Image.ResourceMode 属性

ImageResourceMode 属性

[缺少 "P:Swebui.Controls.Image.ResourceMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ResourceMode ResourceMode { get; set; }
Public Property ResourceMode As ResourceMode
    Get
    Set

属性值

类型：ResourceMode

实现

ISwebResourceControlResourceMode
参见

引用

Image 类


Image.ResourcePath 属性

ImageResourcePath 属性

获取或设置图像资源路径

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourcePath { get; set; }
Public Property ResourcePath As String
    Get
    Set

属性值

类型：String

实现

ISwebResourceControlResourcePath
参见

引用

Image 类


Image.SizeMode 属性

ImageSizeMode 属性

[缺少 "P:Swebui.Controls.Image.SizeMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ImageSizeMode SizeMode { get; set; }
Public Property SizeMode As ImageSizeMode
    Get
    Set

属性值

类型：ImageSizeMode
参见

引用

Image 类


Image.SourceHotReadload 属性

ImageSourceHotReadload 属性

同名图片是否刷新

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool SourceHotReadload { get; set; }
Public Property SourceHotReadload As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Image 类


Image.Zooming 属性

ImageZooming 属性

[缺少 "P:Swebui.Controls.Image.Zooming" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Zooming { get; set; }
Public Property Zooming As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Image 类


Image.ZoomingResouceData 属性

ImageZoomingResouceData 属性

[缺少 "P:Swebui.Controls.Image.ZoomingResouceData" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public byte[] ZoomingResouceData { get; set; }
Public Property ZoomingResouceData As Byte()
    Get
    Set

属性值

类型：Byte
参见

引用

Image 类


Image.ZoomingResourceID 属性

ImageZoomingResourceID 属性

[缺少 "P:Swebui.Controls.Image.ZoomingResourceID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ZoomingResourceID { get; set; }
Public Property ZoomingResourceID As String
    Get
    Set

属性值

类型：String
参见

引用

Image 类


Image 方法

Image 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetHttpResourceEntity |
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Refresh | 重新加载资源
Top
参见

引用

Image 类


Image.GetHttpResourceEntity 方法

ImageGetHttpResourceEntity 方法

[缺少 "M:Swebui.Controls.Image.GetHttpResourceEntity(Swebui.Web.HttpResourceMessage)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HttpDataResourceEntity GetHttpResourceEntity(
    HttpResourceMessage message
)
Public Function GetHttpResourceEntity (
    message As HttpResourceMessage
) As HttpDataResourceEntity

参数

message
类型：HttpResourceMessage

[缺少 "M:Swebui.Controls.Image.GetHttpResourceEntity(Swebui.Web.HttpResourceMessage)" 的 <param name="message"/> 文档]

返回值

类型：HttpDataResourceEntity

[缺少 "M:Swebui.Controls.Image.GetHttpResourceEntity(Swebui.Web.HttpResourceMessage)" 的 <returns> 文档]

参见

引用

Image 类


Image.Refresh 方法

ImageRefresh 方法

重新加载资源

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh
参见

引用

Image 类


Image 事件

Image 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Image 类


ImageRepeatMode 枚举

[缺少 "T:Swebui.Controls.ImageRepeatMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ImageRepeatMode
Public Enumeration ImageRepeatMode
成员
成员名称 | 值 | 说明
Repeat | 0 |
NoRepeat | 1 |
RepeatX | 2 |
RepeatY | 3 |
参见

引用

Swebui.Controls 命名空间


ImageSizeMode 枚举

图像显示样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ImageSizeMode
Public Enumeration ImageSizeMode
成员
成员名称 | 值 | 说明
Default | 0 | 图像不会放大. 如果大于视图面积, 那么会缩小图像, 使其完全可见.
Cover | 1 | 在保持图片宽高比的前提下缩放图片，直到宽度和高度都大于等于容器视图的尺寸.
Zoom | 2 | 在保持图片宽高比的前提下缩放图片，直到宽度和高度都小于等于容器视图的尺寸.
Stretch | 3 | 拉伸图片且不维持宽高比，直到宽高都刚好填满容器.
备注
参见

引用

Swebui.Controls 命名空间


ImageSizeModePropertyExtend 类

[缺少 "T:Swebui.Controls.ImageSizeModePropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsImageSizeModePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ImageSizeModePropertyExtend : SwebPropertyExtend
Public Class ImageSizeModePropertyExtend
    Inherits SwebPropertyExtend

ImageSizeModePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ImageSizeModePropertyExtend | 初始化 ImageSizeModePropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


ImageSizeModePropertyExtend 构造函数

初始化 ImageSizeModePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ImageSizeModePropertyExtend()
Public Sub New
参见

引用

ImageSizeModePropertyExtend 类


INotifyPropertyChanged 接口

Notifies clients that a property value has changed.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface INotifyPropertyChanged
Public Interface INotifyPropertyChanged

INotifyPropertyChanged 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes.
Top
参见

引用

Swebui.Controls 命名空间


INotifyPropertyChanged 事件

INotifyPropertyChanged 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes.
Top
参见

引用

INotifyPropertyChanged 接口


INotifyPropertyChanged.PropertyChanged 事件

INotifyPropertyChangedPropertyChanged 事件

Occurs when a property value changes.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
event PropertyChangedEventHandler PropertyChanged
Event PropertyChanged As PropertyChangedEventHandler

值

类型：Swebui.ControlsPropertyChangedEventHandler
参见

引用

INotifyPropertyChanged 接口


ISwebBindableControl 接口

数据绑定控件接口

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebBindableControl : ISwebControl
Public Interface ISwebBindableControl
    Inherits ISwebControl

ISwebBindableControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。
公共属性 | DataMember | 获取和设置值绑定字段。
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。
公共属性 | DisplayMember | 获取和设置显示绑定字段。
公共属性 | Name | 获取或设置控件的名称。 (继承自 ISwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定
Top
参见

引用

Swebui.Controls 命名空间


ISwebBindableControl 属性

ISwebBindableControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。
公共属性 | DataMember | 获取和设置值绑定字段。
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。
公共属性 | DisplayMember | 获取和设置显示绑定字段。
公共属性 | Name | 获取或设置控件的名称。 (继承自 ISwebControl。)
Top
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.BindDataValue 属性

ISwebBindableControlBindDataValue 属性

获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
Object BindDataValue { get; set; }
Property BindDataValue As Object
    Get
    Set

返回值

类型：Object
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.BindDisplayValue 属性

ISwebBindableControlBindDisplayValue 属性

获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
Object BindDisplayValue { get; set; }
Property BindDisplayValue As Object
    Get
    Set

返回值

类型：Object
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.DataMember 属性

ISwebBindableControlDataMember 属性

获取和设置值绑定字段。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string DataMember { get; set; }
Property DataMember As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.DisplayFormat 属性

ISwebBindableControlDisplayFormat 属性

获取和设置根据 DisplayMember 做数据绑定时的格式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string DisplayFormat { get; set; }
Property DisplayFormat As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.DisplayMember 属性

ISwebBindableControlDisplayMember 属性

获取和设置显示绑定字段。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string DisplayMember { get; set; }
Property DisplayMember As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebBindableControl 接口


ISwebBindableControl 方法

ISwebBindableControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定
Top
参见

引用

ISwebBindableControl 接口


ISwebBindableControl.BindData 方法

ISwebBindableControlBindData 方法

数据绑定

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
bool BindData(
    Object data
)
Function BindData (
    data As Object
) As Boolean

参数

data
类型：SystemObject
绑定的数据

返回值

类型：Boolean
返回一个值，该值指示是否已经对data进行了绑定，如果返回True，调用此方法的数据绑定操作不再对data进行处理，否则进行处理。
参见

引用

ISwebBindableControl 接口


ISwebControl 接口

控件接口

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebControl
Public Interface ISwebControl

ISwebControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Name | 获取或设置控件的名称。
Top
参见

引用

Swebui.Controls 命名空间


ISwebControl 属性

ISwebControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Name | 获取或设置控件的名称。
Top
参见

引用

ISwebControl 接口


ISwebControl.Name 属性

ISwebControlName 属性

获取或设置控件的名称。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string Name { get; set; }
Property Name As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebControl 接口


ISwebDataBindableControl 接口

实现绑定模式的绑定控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebDataBindableControl : ISwebBindableControl
Public Interface ISwebDataBindableControl
    Inherits ISwebBindableControl

ISwebDataBindableControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 ISwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。 (继承自 ISwebBindableControl。)
公共属性 | BindMode | 获取和设置数据的绑定模式
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 ISwebBindableControl。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 ISwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 ISwebBindableControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 ISwebBindableControl。)
Top
参见

引用

Swebui.Controls 命名空间


ISwebDataBindableControl 属性

ISwebDataBindableControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 ISwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。 (继承自 ISwebBindableControl。)
公共属性 | BindMode | 获取和设置数据的绑定模式
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 ISwebBindableControl。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 ISwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 ISwebBindableControl。)
Top
参见

引用

ISwebDataBindableControl 接口


ISwebDataBindableControl.BindMode 属性

ISwebDataBindableControlBindMode 属性

获取和设置数据的绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
DataBindMode BindMode { get; set; }
Property BindMode As DataBindMode
    Get
    Set

返回值

类型：DataBindMode
参见

引用

ISwebDataBindableControl 接口


ISwebDataBindableControl 方法

ISwebDataBindableControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 ISwebBindableControl。)
Top
参见

引用

ISwebDataBindableControl 接口


ISwebDataBindControl 接口

数据绑定控件接口

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebDataBindControl
Public Interface ISwebDataBindControl

ISwebDataBindControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | DataMember | 获取和设置数据源名称
公共属性 | DataSource | 获取和设置数据源
Top
方法
 | 名称 | 说明
公共方法 | DataBind | 数据绑定
公共方法 | OnDataSourceUpdate | 触发数据源更新
Top
参见

引用

Swebui.Controls 命名空间


ISwebDataBindControl 属性

ISwebDataBindControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | DataMember | 获取和设置数据源名称
公共属性 | DataSource | 获取和设置数据源
Top
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl.BindMode 属性

ISwebDataBindControlBindMode 属性

获取和设置绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
DataBindMode BindMode { get; set; }
Property BindMode As DataBindMode
    Get
    Set

返回值

类型：DataBindMode
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl.DataMember 属性

ISwebDataBindControlDataMember 属性

获取和设置数据源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string DataMember { get; set; }
Property DataMember As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl.DataSource 属性

ISwebDataBindControlDataSource 属性

获取和设置数据源

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
Object DataSource { get; set; }
Property DataSource As Object
    Get
    Set

返回值

类型：Object
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl 方法

ISwebDataBindControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataBind | 数据绑定
公共方法 | OnDataSourceUpdate | 触发数据源更新
Top
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl.DataBind 方法

ISwebDataBindControlDataBind 方法

数据绑定

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void DataBind(
    params Object[] params
)
Sub DataBind (
    ParamArray params As Object()
)

参数

params
类型：SystemObject
数据绑定参数
参见

引用

ISwebDataBindControl 接口


ISwebDataBindControl.OnDataSourceUpdate 方法

ISwebDataBindControlOnDataSourceUpdate 方法

触发数据源更新

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void OnDataSourceUpdate(
    DataSourceUpdateEventArgs e
)
Sub OnDataSourceUpdate (
    e As DataSourceUpdateEventArgs
)

参数

e
类型：Swebui.ControlsDataSourceUpdateEventArgs
为数据源更新提供数据
参见

引用

ISwebDataBindControl 接口


ISwebEventControl 接口

[缺少 "T:Swebui.Controls.ISwebEventControl" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebEventControl
Public Interface ISwebEventControl

ISwebEventControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | OnEventRaised |
Top
参见

引用

Swebui.Controls 命名空间


ISwebEventControl 方法

ISwebEventControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | OnEventRaised |
Top
参见

引用

ISwebEventControl 接口


ISwebEventControl.OnEventRaised 方法

ISwebEventControlOnEventRaised 方法

[缺少 "M:Swebui.Controls.ISwebEventControl.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void OnEventRaised(
    SwebControlEventArgs args
)
Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.ISwebEventControl.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

参见

引用

ISwebEventControl 接口


ISwebRenderControl 接口

ISwebRenderControl

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebRenderControl
Public Interface ISwebRenderControl

ISwebRenderControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | RenderTypeName | 获取RenderType类型
Top
参见

引用

Swebui.Controls 命名空间


ISwebRenderControl 属性

ISwebRenderControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | RenderTypeName | 获取RenderType类型
Top
参见

引用

ISwebRenderControl 接口


ISwebRenderControl.RenderTypeName 属性

ISwebRenderControlRenderTypeName 属性

获取RenderType类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string RenderTypeName { get; }
ReadOnly Property RenderTypeName As String
    Get

返回值

类型：String
参见

引用

ISwebRenderControl 接口


ISwebResourceControl 接口

资源控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebResourceControl
Public Interface ISwebResourceControl

ISwebResourceControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceContentType | 获取和设置资源Content-Type(Mime-Type)
公共属性 | ResourceID | 获取和设置资源编号
公共属性 | ResourceMode | 获取和设置资源类型
公共属性 | ResourcePath | 获取和设置资源路径
Top
参见

引用

Swebui.Controls 命名空间


ISwebResourceControl 属性

ISwebResourceControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceContentType | 获取和设置资源Content-Type(Mime-Type)
公共属性 | ResourceID | 获取和设置资源编号
公共属性 | ResourceMode | 获取和设置资源类型
公共属性 | ResourcePath | 获取和设置资源路径
Top
参见

引用

ISwebResourceControl 接口


ISwebResourceControl.ResourceContentType 属性

ISwebResourceControlResourceContentType 属性

获取和设置资源Content-Type(Mime-Type)

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string ResourceContentType { get; set; }
Property ResourceContentType As String
    Get
    Set

返回值

类型：String
备注
为空时，如果Resource为文件类型，会从文件类型中获取Content-Type 如果是二进制类型时，会统一为application/octet-stream
参见

引用

ISwebResourceControl 接口


ISwebResourceControl.ResourceID 属性

ISwebResourceControlResourceID 属性

获取和设置资源编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string ResourceID { get; set; }
Property ResourceID As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebResourceControl 接口


ISwebResourceControl.ResourceMode 属性

ISwebResourceControlResourceMode 属性

获取和设置资源类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
ResourceMode ResourceMode { get; set; }
Property ResourceMode As ResourceMode
    Get
    Set

返回值

类型：ResourceMode
参见

引用

ISwebResourceControl 接口


ISwebResourceControl.ResourcePath 属性

ISwebResourceControlResourcePath 属性

获取和设置资源路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
string ResourcePath { get; set; }
Property ResourcePath As String
    Get
    Set

返回值

类型：String
参见

引用

ISwebResourceControl 接口


ISwebResourceDataControl 接口

资源数据控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebResourceDataControl : ISwebResourceControl
Public Interface ISwebResourceDataControl
    Inherits ISwebResourceControl

ISwebResourceDataControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceContentType | 获取和设置资源Content-Type(Mime-Type) (继承自 ISwebResourceControl。)
公共属性 | ResourceData | 获取和设置资源数据
公共属性 | ResourceID | 获取和设置资源编号 (继承自 ISwebResourceControl。)
公共属性 | ResourceMode | 获取和设置资源类型 (继承自 ISwebResourceControl。)
公共属性 | ResourcePath | 获取和设置资源路径 (继承自 ISwebResourceControl。)
Top
参见

引用

Swebui.Controls 命名空间


ISwebResourceDataControl 属性

ISwebResourceDataControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ResourceContentType | 获取和设置资源Content-Type(Mime-Type) (继承自 ISwebResourceControl。)
公共属性 | ResourceData | 获取和设置资源数据
公共属性 | ResourceID | 获取和设置资源编号 (继承自 ISwebResourceControl。)
公共属性 | ResourceMode | 获取和设置资源类型 (继承自 ISwebResourceControl。)
公共属性 | ResourcePath | 获取和设置资源路径 (继承自 ISwebResourceControl。)
Top
参见

引用

ISwebResourceDataControl 接口


ISwebResourceDataControl.ResourceData 属性

ISwebResourceDataControlResourceData 属性

获取和设置资源数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
byte[] ResourceData { get; set; }
Property ResourceData As Byte()
    Get
    Set

返回值

类型：Byte
参见

引用

ISwebResourceDataControl 接口


ISwebTemplateControl 接口

[缺少 "T:Swebui.Controls.ISwebTemplateControl" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebTemplateControl
Public Interface ISwebTemplateControl

ISwebTemplateControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateControl |
Top
方法
 | 名称 | 说明
公共方法 | SetTemplateControl |
Top
参见

引用

Swebui.Controls 命名空间


ISwebTemplateControl 属性

ISwebTemplateControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateControl |
Top
参见

引用

ISwebTemplateControl 接口


ISwebTemplateControl.TemplateControl 属性

ISwebTemplateControlTemplateControl 属性

[缺少 "P:Swebui.Controls.ISwebTemplateControl.TemplateControl" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
SwebUserControl TemplateControl { get; set; }
Property TemplateControl As SwebUserControl
    Get
    Set

属性值

类型：SwebUserControl
参见

引用

ISwebTemplateControl 接口


ISwebTemplateControl 方法

ISwebTemplateControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | SetTemplateControl |
Top
参见

引用

ISwebTemplateControl 接口


ISwebTemplateControl.SetTemplateControl 方法

ISwebTemplateControlSetTemplateControl 方法

[缺少 "M:Swebui.Controls.ISwebTemplateControl.SetTemplateControl(Swebui.Controls.SwebUserControl)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void SetTemplateControl(
    SwebUserControl control
)
Sub SetTemplateControl (
    control As SwebUserControl
)

参数

control
类型：Swebui.ControlsSwebUserControl

[缺少 "M:Swebui.Controls.ISwebTemplateControl.SetTemplateControl(Swebui.Controls.SwebUserControl)" 的 <param name="control"/> 文档]

参见

引用

ISwebTemplateControl 接口


ISwebViewCollectionOwner 接口

ISwebViewCollectionOwner

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebViewCollectionOwner
Public Interface ISwebViewCollectionOwner

ISwebViewCollectionOwner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 添加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemPropertyChanged | 元素属性修改
公共方法 | ItemRemove | 删除元素
公共方法 | Refresh | 刷新元素
Top
参见

引用

Swebui.Controls 命名空间


ISwebViewCollectionOwner 方法

ISwebViewCollectionOwner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 添加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemPropertyChanged | 元素属性修改
公共方法 | ItemRemove | 删除元素
公共方法 | Refresh | 刷新元素
Top
参见

引用

ISwebViewCollectionOwner 接口


ISwebViewCollectionOwner.ItemAdd 方法

ISwebViewCollectionOwnerItemAdd 方法

添加元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemAdd(
    SwebViewCollectionItem item
)
Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem
元素
参见

引用

ISwebViewCollectionOwner 接口


ISwebViewCollectionOwner.ItemClear 方法

ISwebViewCollectionOwnerItemClear 方法

清除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemClear()
Sub ItemClear
参见

引用

ISwebViewCollectionOwner 接口


ISwebViewCollectionOwner.ItemPropertyChanged 方法

ISwebViewCollectionOwnerItemPropertyChanged 方法

元素属性修改

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem
元素
e
类型：Swebui.ControlsShadowPropertyChangedArgs
属性
参见

引用

ISwebViewCollectionOwner 接口


ISwebViewCollectionOwner.ItemRemove 方法

ISwebViewCollectionOwnerItemRemove 方法

删除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem
元素
itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.ISwebViewCollectionOwner.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

参见

引用

ISwebViewCollectionOwner 接口


ISwebViewCollectionOwner.Refresh 方法

ISwebViewCollectionOwnerRefresh 方法

刷新元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void Refresh()
Sub Refresh
参见

引用

ISwebViewCollectionOwner 接口


ISwebViewDictionaryOwner(TKey, TValue) 接口

ISwebViewDictionaryOwnerTKey, TValue 接口

ISwebViewDictionaryOwner

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebViewDictionaryOwner<TKey, TValue>

Public Interface ISwebViewDictionaryOwner(Of TKey, TValue)

类型参数

TKey
Key
TValue
Value

ISwebViewDictionaryOwnerTKey, TValue 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 增加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemRemove | 删除元素
公共方法 | ItemSet | 设置元素
Top
参见

引用

Swebui.Controls 命名空间


ISwebViewDictionaryOwner(TKey, TValue) 方法

ISwebViewDictionaryOwnerTKey, TValue 方法

ISwebViewDictionaryOwnerTKey, TValue 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 增加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemRemove | 删除元素
公共方法 | ItemSet | 设置元素
Top
参见

引用

ISwebViewDictionaryOwnerTKey, TValue 接口


ISwebViewDictionaryOwner(TKey, TValue).ItemAdd 方法

ISwebViewDictionaryOwnerTKey, TValueItemAdd 方法

增加元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemAdd(
    TKey key,
    TValue value
)
Sub ItemAdd (
    key As TKey,
    value As TValue
)

参数

key
类型：TKey
键
value
类型：TValue
值
参见

引用

ISwebViewDictionaryOwnerTKey, TValue 接口


ISwebViewDictionaryOwner(TKey, TValue).ItemClear 方法

ISwebViewDictionaryOwnerTKey, TValueItemClear 方法

清除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemClear()
Sub ItemClear
参见

引用

ISwebViewDictionaryOwnerTKey, TValue 接口


ISwebViewDictionaryOwner(TKey, TValue).ItemRemove 方法

ISwebViewDictionaryOwnerTKey, TValueItemRemove 方法

删除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemRemove(
    TKey key
)
Sub ItemRemove (
    key As TKey
)

参数

key
类型：TKey
键
参见

引用

ISwebViewDictionaryOwnerTKey, TValue 接口


ISwebViewDictionaryOwner(TKey, TValue).ItemSet 方法

ISwebViewDictionaryOwnerTKey, TValueItemSet 方法

设置元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemSet(
    TKey key,
    TValue value
)
Sub ItemSet (
    key As TKey,
    value As TValue
)

参数

key
类型：TKey
键
value
类型：TValue
值
参见

引用

ISwebViewDictionaryOwnerTKey, TValue 接口


ISwebViewObjectCollectionOwner 接口

ISwebViewObjectCollectionOwner

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public interface ISwebViewObjectCollectionOwner
Public Interface ISwebViewObjectCollectionOwner

ISwebViewObjectCollectionOwner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 添加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemRemove | 删除元素
公共方法 | ItemValueChanged | 元素属性修改
公共方法 | Refresh | 刷新元素
Top
参见

引用

Swebui.Controls 命名空间


ISwebViewObjectCollectionOwner 方法

ISwebViewObjectCollectionOwner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd | 添加元素
公共方法 | ItemClear | 清除元素
公共方法 | ItemRemove | 删除元素
公共方法 | ItemValueChanged | 元素属性修改
公共方法 | Refresh | 刷新元素
Top
参见

引用

ISwebViewObjectCollectionOwner 接口


ISwebViewObjectCollectionOwner.ItemAdd 方法

ISwebViewObjectCollectionOwnerItemAdd 方法

添加元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemAdd(
    Object item
)
Sub ItemAdd (
    item As Object
)

参数

item
类型：SystemObject
元素
参见

引用

ISwebViewObjectCollectionOwner 接口


ISwebViewObjectCollectionOwner.ItemClear 方法

ISwebViewObjectCollectionOwnerItemClear 方法

清除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemClear()
Sub ItemClear
参见

引用

ISwebViewObjectCollectionOwner 接口


ISwebViewObjectCollectionOwner.ItemRemove 方法

ISwebViewObjectCollectionOwnerItemRemove 方法

删除元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemRemove(
    Object item,
    int itemIndex
)
Sub ItemRemove (
    item As Object,
    itemIndex As Integer
)

参数

item
类型：SystemObject
元素
itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.ISwebViewObjectCollectionOwner.ItemRemove(System.Object,System.Int32)" 的 <param name="itemIndex"/> 文档]

参见

引用

ISwebViewObjectCollectionOwner 接口


ISwebViewObjectCollectionOwner.ItemValueChanged 方法

ISwebViewObjectCollectionOwnerItemValueChanged 方法

元素属性修改

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void ItemValueChanged(
    Object item,
    Object oldItem
)
Sub ItemValueChanged (
    item As Object,
    oldItem As Object
)

参数

item
类型：SystemObject
元素
oldItem
类型：SystemObject
原元素
参见

引用

ISwebViewObjectCollectionOwner 接口


ISwebViewObjectCollectionOwner.Refresh 方法

ISwebViewObjectCollectionOwnerRefresh 方法

刷新元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
void Refresh()
Sub Refresh
参见

引用

ISwebViewObjectCollectionOwner 接口


JScriptAppendType 枚举

JS脚本添加类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum JScriptAppendType
Public Enumeration JScriptAppendType
成员
成员名称 | 值 | 说明
Header | 0 | 头部
Body | 1 | 内容
参见

引用

Swebui.Controls 命名空间


JScriptType 枚举

JS脚本类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum JScriptType
Public Enumeration JScriptType
成员
成员名称 | 值 | 说明
Script | 0 | 脚本
Module | 1 | 模块
参见

引用

Swebui.Controls 命名空间


KeyboardType 枚举

文本框键盘样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum KeyboardType
Public Enumeration KeyboardType
成员
成员名称 | 值 | 说明
Default | 0 | 系统默认
EmailAddress | 1 | 电子邮箱
Numeric | 2 | 数字
PhonePad | 3 | 拨号
备注
参见

引用

Swebui.Controls 命名空间


KeyCode 枚举

客户端实体按键

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum KeyCode
Public Enumeration KeyCode
成员
成员名称 | 值 | 说明
Back | 0 | 后退
Menu | 1 | 菜单
Enter | 2 |
备注
参见

引用

Swebui.Controls 命名空间


KeyDownEventArgs 类

包含客户端点击实体按键的事件数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsKeyDownEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class KeyDownEventArgs : EventArgs
Public Class KeyDownEventArgs
    Inherits EventArgs

KeyDownEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | KeyDownEventArgs | 初始化 KeyDownEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | KeyCode | 获取KeyCode
Top
备注
参见

引用

Swebui.Controls 命名空间


KeyDownEventArgs 构造函数

初始化 KeyDownEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public KeyDownEventArgs()
Public Sub New
参见

引用

KeyDownEventArgs 类


KeyDownEventArgs 属性

KeyDownEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | KeyCode | 获取KeyCode
Top
参见

引用

KeyDownEventArgs 类


KeyDownEventArgs.KeyCode 属性

KeyDownEventArgsKeyCode 属性

获取KeyCode

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public KeyCode KeyCode { get; }
Public ReadOnly Property KeyCode As KeyCode
    Get

属性值

类型：KeyCode

返回值

类型：KeyCode
备注
参见

引用

KeyDownEventArgs 类


KeyDownEventHandler 委托

一个委托，它表示在客户端点击实体按键时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void KeyDownEventHandler(
    Object sender,
    KeyDownEventArgs e
)
Public Delegate Sub KeyDownEventHandler (
    sender As Object,
    e As KeyDownEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsKeyDownEventArgs
包含事件数据的 e
备注
参见

引用

Swebui.Controls 命名空间


Label 类

文本标签控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebTextControl
Swebui.ControlsLabel

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Label : SwebTextControl, ISwebRenderControl
Public Class Label
    Inherits SwebTextControl
    Implements ISwebRenderControl

Label 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Label | 初始化 Label 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | LineHeight | 获取或设置行高
公共属性 | LineThrough | 获取或设置文本中划线
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | NumberOfLines | 获取和设置一个值，该值指示显示的行数
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Underline | 获取或设置文本下划线
公共属性 | VerticalAlignment | 获取和设置一个值，该值指示文本垂直对齐方式
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Label 构造函数

初始化 Label 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Label()
Public Sub New
参见

引用

Label 类


Label 属性

Label 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | LineHeight | 获取或设置行高
公共属性 | LineThrough | 获取或设置文本中划线
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | NumberOfLines | 获取和设置一个值，该值指示显示的行数
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Underline | 获取或设置文本下划线
公共属性 | VerticalAlignment | 获取和设置一个值，该值指示文本垂直对齐方式
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Label 类


Label.FontFamily 属性

LabelFontFamily 属性

获取和设置控件字体。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string FontFamily { get; set; }
Public Property FontFamily As String
    Get
    Set

属性值

类型：String
参见

引用

Label 类


Label.LineHeight 属性

LabelLineHeight 属性

获取或设置行高

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float LineHeight { get; set; }
Public Property LineHeight As Single
    Get
    Set

属性值

类型：Single
参见

引用

Label 类


Label.LineThrough 属性

LabelLineThrough 属性

获取或设置文本中划线

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool LineThrough { get; set; }
Public Property LineThrough As Boolean
    Get
    Set

属性值

类型：Boolean
备注
LineThrough和Underline仅能支持一个，并且优先支持Underline
参见

引用

Label 类


Label.NumberOfLines 属性

LabelNumberOfLines 属性

获取和设置一个值，该值指示显示的行数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int NumberOfLines { get; set; }
Public Property NumberOfLines As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Label 类


Label.Text 属性

LabelText 属性

[缺少 "P:Swebui.Controls.Label.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

Label 类


Label.Underline 属性

LabelUnderline 属性

获取或设置文本下划线

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Underline { get; set; }
Public Property Underline As Boolean
    Get
    Set

属性值

类型：Boolean
备注
LineThrough和Underline仅能支持一个，并且优先支持Underline
参见

引用

Label 类


Label.VerticalAlignment 属性

LabelVerticalAlignment 属性

获取和设置一个值，该值指示文本垂直对齐方式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public VerticalAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set

属性值

类型：VerticalAlignment
参见

引用

Label 类


Label 方法

Label 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Label 类


Label 事件

Label 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Label 类


LayoutDirection 枚举

主轴方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutDirection
Public Enumeration LayoutDirection
成员
成员名称 | 值 | 说明
Row | 0 | 水平
Column | 1 | 垂直
参见

引用

Swebui.Controls 命名空间


LayoutItemAlign 枚举

侧轴元素对齐方式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutItemAlign
Public Enumeration LayoutItemAlign
成员
成员名称 | 值 | 说明
FlexStart | 0 | 元素在侧轴的起始位置靠齐
FlexEnd | 1 | 元素在侧轴的结束位置靠齐
Center | 2 | 元素在侧轴的中间位置靠齐
Stretch | 3 | 元素在侧轴方向被拉伸到与容器相同的高度或宽度
参见

引用

Swebui.Controls 命名空间


LayoutJustifyAlign 枚举

主轴元素对齐方式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutJustifyAlign
Public Enumeration LayoutJustifyAlign
成员
成员名称 | 值 | 说明
FlexStart | 0 | 元素在主轴的起始位置靠齐
FlexEnd | 1 | 元素在主轴的结束位置靠齐
Center | 2 | 元素在主轴的中间位置靠齐
SpaceBetween | 3 | 元素平均地分布在主轴中。第一个伸缩项目一行中的最开始位置，最后一个伸缩项目在一行中最终点位置。
SpaceAround | 4 | 元素平均地分布在主轴中。两端保留一半的空间。
参见

引用

Swebui.Controls 命名空间


LayoutOverflow 枚举

布局覆盖范围

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutOverflow
Public Enumeration LayoutOverflow
成员
成员名称 | 值 | 说明
Auto | 0 | 自动
Hidden | 1 | 隐藏
Visible | 2 | 可见
None | 9 | 不设置
参见

引用

Swebui.Controls 命名空间


LayoutPercentage 枚举

布局百分比

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutPercentage
Public Enumeration LayoutPercentage
成员
成员名称 | 值 | 说明
None | 1 | 不启用
Left | 2 | 左
Top | 4 | 上
Right | 8 | 右
Bottom | 16 | 下
Width | 32 | 宽度
Height | 64 | 高度
Padding | 128 | 内边距
Margin | 256 | 外边距
参见

引用

Swebui.Controls 命名空间


LayoutPosition 枚举

布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutPosition
Public Enumeration LayoutPosition
成员
成员名称 | 值 | 说明
Absolute | 1 | 绝对布局
Relative | 2 | 相对布局
参见

引用

Swebui.Controls 命名空间


LayoutSelfAlign 枚举

覆盖容器定义的侧轴对齐方式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutSelfAlign
Public Enumeration LayoutSelfAlign
成员
成员名称 | 值 | 说明
Auto | 0 | 元素跟随容器的对齐方式。
FlexStart | 1 | 元素向侧轴起点对齐
FlexEnd | 2 | 元素向侧轴终点对齐
Center | 3 | 元素在侧轴居中, 如果控件在侧轴上的高度高于其容器，那么在两个方向上溢出距离相同
Stretch | 4 | 元素在侧轴方向被拉伸到与容器相同的高度或宽度
参见

引用

Swebui.Controls 命名空间


LayoutSelfPosition 枚举

[缺少 "T:Swebui.Controls.LayoutSelfPosition" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutSelfPosition
Public Enumeration LayoutSelfPosition
成员
成员名称 | 值 | 说明
Inherit | 0 | 继承自父类
Absolute | 1 | 绝对布局
Relative | 2 | 相对布局
参见

引用

Swebui.Controls 命名空间


LayoutWrap 枚举

布局换行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum LayoutWrap
Public Enumeration LayoutWrap
成员
成员名称 | 值 | 说明
Wrap | 0 | 容器控件中的子控件如果超出容器空间时，换行
NoWrap | 1 | 容器控件中的子控件如果超出容器空间时，不换行
参见

引用

Swebui.Controls 命名空间


Line 类

线条控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsLine

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Line : SwebControl, ISwebRenderControl
Public Class Line
    Inherits SwebControl
    Implements ISwebRenderControl

Line 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Line | 初始化 Line 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | OrientationAlignment |
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Line 构造函数

初始化 Line 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Line()
Public Sub New
参见

引用

Line 类


Line 属性

Line 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | OrientationAlignment |
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Line 类


Line.OrientationAlignment 属性

LineOrientationAlignment 属性

[缺少 "P:Swebui.Controls.Line.OrientationAlignment" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public OrientationAlignment OrientationAlignment { get; set; }
Public Property OrientationAlignment As OrientationAlignment
    Get
    Set

属性值

类型：OrientationAlignment
参见

引用

Line 类


Line.Padding 属性

LinePadding 属性

[缺少 "P:Swebui.Controls.Line.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

Line 类


Line 方法

Line 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Line 类


Line 事件

Line 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Line 类


ListButton 类

[缺少 "T:Swebui.Controls.ListButton" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsListButton

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ListButton
Public Class ListButton

ListButton 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListButton | 初始化 ListButton 类的一个新实例
公共方法 | ListButton(ListEditeListButton) | 初始化 ListButton 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

Swebui.Controls 命名空间


ListButton 构造函数

重载列表
 | 名称 | 说明
公共方法 | ListButton | 初始化 ListButton 类的一个新实例
公共方法 | ListButton(ListEditeListButton) | 初始化 ListButton 类的一个新实例
Top
参见

引用

ListButton 类


ListButton 构造函数

初始化 ListButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ListButton()
Public Sub New
参见

引用

ListButton 类
ListButton 重载


ListButton 构造函数 (List(EditeListButton))

ListButton 构造函数 (ListEditeListButton)

初始化 ListButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ListButton(
    List<EditeListButton> data
)
Public Sub New (
    data As List(Of EditeListButton)
)

参数

data
类型：System.Collections.GenericList EditeListButton

[缺少 "M:Swebui.Controls.ListButton.#ctor(System.Collections.Generic.List{Swebui.Controls.EditeListButton})" 的 <param name="data"/> 文档]

参见

引用

ListButton 类
ListButton 重载


ListButton 属性

ListButton 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

ListButton 类


ListButton.Data 属性

ListButtonData 属性

[缺少 "P:Swebui.Controls.ListButton.Data" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public List<EditeListButton> Data { get; }
Public ReadOnly Property Data As List(Of EditeListButton)
    Get

属性值

类型：List EditeListButton
参见

引用

ListButton 类


ListView 类

列表控件。
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsListView
Swebui.ControlsSectionListView

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListView : SwebLayoutControl, ISwebDataBindControl,
    ISwebTemplateControl, ISwebViewCollectionOwner
Public Class ListView
    Inherits SwebLayoutControl
    Implements ISwebDataBindControl, ISwebTemplateControl, ISwebViewCollectionOwner

ListView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListView | 初始化 ListView 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | ColumnNum | 获取和设置列数
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FooterControl | 获取和设置页脚控件
公共属性 | FooterControlName | 获取和设置页脚控件布局
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HeaderControl | 获取和设置页眉控件
公共属性 | HeaderControlName | 获取和设置页眉控件布局
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | PageSize | 获取或设置一个值，该值指示当前控件的数据页大小，当前绑定数据大于PageSize设定的值时，第一次只会显示PageSize设定值的数据量，会根据PageSize加载剩余数据量
公共属性 | PageSizeBackColor | 获取和设置数据页加载文本背景颜色
公共属性 | PageSizeLoadCompleteText | 获取和设置数据页加载完成文本
公共属性 | PageSizeLoadMode | 获取和设置PageSize加载模式
公共属性 | PageSizeLoadText | 获取和设置数据页加载文本
公共属性 | PageSizeTextColor | 获取和设置数据页加载文本颜色
公共属性 | PageSizeTextHeight | 获取和设置数据页面加载文本高度
公共属性 | PageSizeTextSize | 获取和设置数据页加载文本大小
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。
公共属性 | RaiseReachEnd | 获取和设置是否可触发上划底部事件。
公共属性 | RaiseRefresh | 获取和设置是否可触发下拉刷新事件。
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Rows | 获取ListViewRowCollection
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示是否启用容器滚动。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowSplitLine | 获取和设置一个值，该值指示是否显示单元格之间的分隔线
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SplitLineColor | 获取和设置单元格之间的分隔线颜色
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置模板控件。
公共属性 | TemplateControlName | 获取和设置模板控件名称
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | AutoScroll |
公共方法 | DataBind | 数据绑定。
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewRow | 添加行。
公共方法 | NewRow(Object) | 添加行。
公共方法 | NewRow(Object, String, Object) | 添加行。
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate |
公共方法 | ScrollTo | 滚动到指定位置
公共方法 | ScrollToIndex | 滚动到指定行
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll |
公共方法 | UpdateRow | 更新行。
Top
事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。
公共事件 | PositionChanged | 在位置变化时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在上划到底部时发生。
公共事件 | Refresh | 在用户下拉刷新时发生。
公共事件 | RowBind | 在行绑定后发生。
公共事件 | RowBinding | 在行绑定时发生。
Top
参见

引用

Swebui.Controls 命名空间


ListView 构造函数

初始化 ListView 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListView()
Public Sub New
参见

引用

ListView 类


ListView 属性

ListView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | ColumnNum | 获取和设置列数
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FooterControl | 获取和设置页脚控件
公共属性 | FooterControlName | 获取和设置页脚控件布局
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HeaderControl | 获取和设置页眉控件
公共属性 | HeaderControlName | 获取和设置页眉控件布局
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | PageSize | 获取或设置一个值，该值指示当前控件的数据页大小，当前绑定数据大于PageSize设定的值时，第一次只会显示PageSize设定值的数据量，会根据PageSize加载剩余数据量
公共属性 | PageSizeBackColor | 获取和设置数据页加载文本背景颜色
公共属性 | PageSizeLoadCompleteText | 获取和设置数据页加载完成文本
公共属性 | PageSizeLoadMode | 获取和设置PageSize加载模式
公共属性 | PageSizeLoadText | 获取和设置数据页加载文本
公共属性 | PageSizeTextColor | 获取和设置数据页加载文本颜色
公共属性 | PageSizeTextHeight | 获取和设置数据页面加载文本高度
公共属性 | PageSizeTextSize | 获取和设置数据页加载文本大小
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。
公共属性 | RaiseReachEnd | 获取和设置是否可触发上划底部事件。
公共属性 | RaiseRefresh | 获取和设置是否可触发下拉刷新事件。
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Rows | 获取ListViewRowCollection
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示是否启用容器滚动。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowSplitLine | 获取和设置一个值，该值指示是否显示单元格之间的分隔线
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SplitLineColor | 获取和设置单元格之间的分隔线颜色
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置模板控件。
公共属性 | TemplateControlName | 获取和设置模板控件名称
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

ListView 类


ListView.BindMode 属性

ListViewBindMode 属性

获取和设置绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DataBindMode BindMode { get; set; }
Public Property BindMode As DataBindMode
    Get
    Set

返回值

类型：DataBindMode

实现

ISwebDataBindControlBindMode
参见

引用

ListView 类


ListView.ColumnNum 属性

ListViewColumnNum 属性

获取和设置列数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ColumnNum { get; set; }
Public Property ColumnNum As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

ListView 类


ListView.DataMember 属性

ListViewDataMember 属性

获取或设置数据源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DataMember { get; set; }
Public Property DataMember As String
    Get
    Set

属性值

类型：String

返回值

类型：String

实现

ISwebDataBindControlDataMember
备注
参见

引用

ListView 类


ListView.DataSource 属性

ListViewDataSource 属性

获取或设置表格数据源

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object DataSource { get; set; }
Public Property DataSource As Object
    Get
    Set

属性值

类型：Object

返回值

类型：Object

实现

ISwebDataBindControlDataSource
备注
参见

引用

ListView 类


ListView.FooterControl 属性

ListViewFooterControl 属性

获取和设置页脚控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl FooterControl { get; set; }
Public Property FooterControl As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl
参见

引用

ListView 类


ListView.FooterControlName 属性

ListViewFooterControlName 属性

获取和设置页脚控件布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string FooterControlName { get; set; }
Public Property FooterControlName As String
    Get
    Set

返回值

类型：String
备注
仅在窗体第一次或重新载入时生效，如果设置了FooterControl，那么设置此属性无效
参见

引用

ListView 类


ListView.HeaderControl 属性

ListViewHeaderControl 属性

获取和设置页眉控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl HeaderControl { get; set; }
Public Property HeaderControl As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl
参见

引用

ListView 类


ListView.HeaderControlName 属性

ListViewHeaderControlName 属性

获取和设置页眉控件布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string HeaderControlName { get; set; }
Public Property HeaderControlName As String
    Get
    Set

返回值

类型：String
备注
仅在窗体第一次或重新载入时生效，如果设置了HeaderControl，那么设置此属性无效
参见

引用

ListView 类


ListView.Horizontal 属性

ListViewHorizontal 属性

获取和设置一个值，该值指示是否水平滑动

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Horizontal { get; set; }
Public Property Horizontal As Boolean
    Get
    Set

属性值

类型：Boolean
水平滑动设置为 true，否则为 flase

返回值

类型：Boolean
参见

引用

ListView 类


ListView.Layout 属性

ListViewLayout 属性

[缺少 "P:Swebui.Controls.ListView.Layout" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutPosition Layout { get; set; }
Public Overrides Property Layout As LayoutPosition
    Get
    Set

属性值

类型：LayoutPosition
参见

引用

ListView 类


ListView.Padding 属性

ListViewPadding 属性

[缺少 "P:Swebui.Controls.ListView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

ListView 类


ListView.PageSize 属性

ListViewPageSize 属性

获取或设置一个值，该值指示当前控件的数据页大小，当前绑定数据大于PageSize设定的值时，第一次只会显示PageSize设定值的数据量，会根据PageSize加载剩余数据量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int PageSize { get; set; }
Public Overridable Property PageSize As Integer
    Get
    Set

属性值

类型：Int32

返回值

类型：Int32
备注
参见

引用

ListView 类


ListView.PageSizeBackColor 属性

ListViewPageSizeBackColor 属性

获取和设置数据页加载文本背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Color PageSizeBackColor { get; set; }
Public Overridable Property PageSizeBackColor As Color
    Get
    Set

返回值

类型：Color
参见

引用

ListView 类


ListView.PageSizeLoadCompleteText 属性

ListViewPageSizeLoadCompleteText 属性

获取和设置数据页加载完成文本

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string PageSizeLoadCompleteText { get; set; }
Public Overridable Property PageSizeLoadCompleteText As String
    Get
    Set

返回值

类型：String
参见

引用

ListView 类


ListView.PageSizeLoadMode 属性

ListViewPageSizeLoadMode 属性

获取和设置PageSize加载模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageSizeLoadMode PageSizeLoadMode { get; set; }
Public Property PageSizeLoadMode As PageSizeLoadMode
    Get
    Set

返回值

类型：PageSizeLoadMode
参见

引用

ListView 类


ListView.PageSizeLoadText 属性

ListViewPageSizeLoadText 属性

获取和设置数据页加载文本

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string PageSizeLoadText { get; set; }
Public Overridable Property PageSizeLoadText As String
    Get
    Set

返回值

类型：String
参见

引用

ListView 类


ListView.PageSizeTextColor 属性

ListViewPageSizeTextColor 属性

获取和设置数据页加载文本颜色

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Color PageSizeTextColor { get; set; }
Public Overridable Property PageSizeTextColor As Color
    Get
    Set

返回值

类型：Color
参见

引用

ListView 类


ListView.PageSizeTextHeight 属性

ListViewPageSizeTextHeight 属性

获取和设置数据页面加载文本高度

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int PageSizeTextHeight { get; set; }
Public Overridable Property PageSizeTextHeight As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

ListView 类


ListView.PageSizeTextSize 属性

ListViewPageSizeTextSize 属性

获取和设置数据页加载文本大小

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual float PageSizeTextSize { get; set; }
Public Overridable Property PageSizeTextSize As Single
    Get
    Set

返回值

类型：Single
参见

引用

ListView 类


ListView.RaisePositionChanged 属性

ListViewRaisePositionChanged 属性

获取和设置是否触发滚动时位置变化事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaisePositionChanged { get; set; }
Public Property RaisePositionChanged As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

ListView 类


ListView.RaiseReachEnd 属性

ListViewRaiseReachEnd 属性

获取和设置是否可触发上划底部事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaiseReachEnd { get; set; }
Public Property RaiseReachEnd As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

ListView 类


ListView.RaiseRefresh 属性

ListViewRaiseRefresh 属性

获取和设置是否可触发下拉刷新事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaiseRefresh { get; set; }
Public Property RaiseRefresh As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

ListView 类


ListView.Rows 属性

ListViewRows 属性

获取ListViewRowCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRowCollection Rows { get; }
Public ReadOnly Property Rows As ListViewRowCollection
    Get

返回值

类型：ListViewRowCollection
参见

引用

ListView 类


ListView.ScrollEnabled 属性

ListViewScrollEnabled 属性

获取和设置一个值，该值指示是否启用容器滚动。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ScrollEnabled { get; set; }
Public Property ScrollEnabled As Boolean
    Get
    Set

返回值

类型：Boolean
备注
5.0版本后支持
参见

引用

ListView 类


ListView.ShowSplitLine 属性

ListViewShowSplitLine 属性

获取和设置一个值，该值指示是否显示单元格之间的分隔线

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowSplitLine { get; set; }
Public Property ShowSplitLine As Boolean
    Get
    Set

属性值

类型：Boolean
如果显示，设置为true，否则，设置为false

返回值

类型：Boolean
参见

引用

ListView 类


ListView.SplitLineColor 属性

ListViewSplitLineColor 属性

获取和设置单元格之间的分隔线颜色

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color SplitLineColor { get; set; }
Public Property SplitLineColor As Color
    Get
    Set

返回值

类型：Color
参见

引用

ListView 类


ListView.TemplateControl 属性

ListViewTemplateControl 属性

获取和设置模板控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl TemplateControl { get; set; }
Public Property TemplateControl As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl

实现

ISwebTemplateControlTemplateControl
参见

引用

ListView 类


ListView.TemplateControlName 属性

ListViewTemplateControlName 属性

获取和设置模板控件名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string TemplateControlName { get; set; }
Public Property TemplateControlName As String
    Get
    Set

返回值

类型：String
参见

引用

ListView 类


ListView 方法

ListView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AutoScroll |
公共方法 | DataBind | 数据绑定。
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewRow | 添加行。
公共方法 | NewRow(Object) | 添加行。
公共方法 | NewRow(Object, String, Object) | 添加行。
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate |
公共方法 | ScrollTo | 滚动到指定位置
公共方法 | ScrollToIndex | 滚动到指定行
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll |
公共方法 | UpdateRow | 更新行。
Top
参见

引用

ListView 类


ListView.AutoScroll 方法

ListViewAutoScroll 方法

[缺少 "M:Swebui.Controls.ListView.AutoScroll(Swebui.Controls.AutoScrollParameter)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AutoScroll(
    AutoScrollParameter parameter = null
)
Public Sub AutoScroll (
    Optional parameter As AutoScrollParameter = Nothing
)

参数

parameter (Optional)
类型：Swebui.ControlsAutoScrollParameter

[缺少 "M:Swebui.Controls.ListView.AutoScroll(Swebui.Controls.AutoScrollParameter)" 的 <param name="parameter"/> 文档]

参见

引用

ListView 类


ListView.DataBind 方法

ListViewDataBind 方法

数据绑定。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void DataBind(
    params Object[] params
)
Public Overridable Sub DataBind (
    ParamArray params As Object()
)

参数

params
类型：SystemObject

[缺少 "M:Swebui.Controls.ListView.DataBind(System.Object[])" 的 <param name="params"/> 文档]

实现

ISwebDataBindControlDataBind(Object)
参见

引用

ListView 类


ListView.NewRow 方法

ListViewNewRow 方法

重载列表
 | 名称 | 说明
公共方法 | NewRow | 添加行。
公共方法 | NewRow(Object) | 添加行。
公共方法 | NewRow(Object, String, Object) | 添加行。
Top
参见

引用

ListView 类


ListView.NewRow 方法

ListViewNewRow 方法

添加行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRow NewRow()
Public Function NewRow As ListViewRow

返回值

类型：ListViewRow

[缺少 "M:Swebui.Controls.ListView.NewRow" 的 <returns> 文档]

参见

引用

ListView 类
NewRow 重载


ListView.NewRow 方法 (Object[])

ListViewNewRow 方法 (Object)

添加行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRow NewRow(
    params Object[] params
)
Public Function NewRow (
    ParamArray params As Object()
) As ListViewRow

参数

params
类型：SystemObject
模板参数

返回值

类型：ListViewRow

[缺少 "M:Swebui.Controls.ListView.NewRow(System.Object[])" 的 <returns> 文档]

参见

引用

ListView 类
NewRow 重载


ListView.NewRow 方法 (Object, String, Object[])

ListViewNewRow 方法 (Object, String, Object)

添加行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRow[] NewRow(
    Object dataSource,
    string dataMember,
    params Object[] params
)
Public Function NewRow (
    dataSource As Object,
    dataMember As String,
    ParamArray params As Object()
) As ListViewRow()

参数

dataSource
类型：SystemObject
数据源
dataMember
类型：SystemString
数据源名称
params
类型：SystemObject
模板参数

返回值

类型：ListViewRow

[缺少 "M:Swebui.Controls.ListView.NewRow(System.Object,System.String,System.Object[])" 的 <returns> 文档]

参见

引用

ListView 类
NewRow 重载


ListView.OnDataSourceUpdate 方法

ListViewOnDataSourceUpdate 方法

[缺少 "M:Swebui.Controls.ListView.OnDataSourceUpdate(Swebui.Controls.DataSourceUpdateEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
internal void OnDataSourceUpdate(
    DataSourceUpdateEventArgs e
)
Friend Sub OnDataSourceUpdate (
    e As DataSourceUpdateEventArgs
)

参数

e
类型：Swebui.ControlsDataSourceUpdateEventArgs

[缺少 "M:Swebui.Controls.ListView.OnDataSourceUpdate(Swebui.Controls.DataSourceUpdateEventArgs)" 的 <param name="e"/> 文档]

实现

ISwebDataBindControlOnDataSourceUpdate(DataSourceUpdateEventArgs)
参见

引用

ListView 类


ListView.ScrollTo 方法

ListViewScrollTo 方法

滚动到指定位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ScrollTo(
    float position
)
Public Sub ScrollTo (
    position As Single
)

参数

position
类型：SystemSingle
位置
参见

引用

ListView 类


ListView.ScrollToIndex 方法

ListViewScrollToIndex 方法

滚动到指定行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void ScrollToIndex(
    int index
)
Public Overridable Sub ScrollToIndex (
    index As Integer
)

参数

index
类型：SystemInt32
行索引
参见

引用

ListView 类


ListView.StopAutoScroll 方法

ListViewStopAutoScroll 方法

[缺少 "M:Swebui.Controls.ListView.StopAutoScroll" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void StopAutoScroll()
Public Sub StopAutoScroll
参见

引用

ListView 类


ListView.UpdateRow 方法

ListViewUpdateRow 方法

更新行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void UpdateRow(
    ListViewRow row,
    Object dataSource,
    string dataMember = ""
)
Public Sub UpdateRow (
    row As ListViewRow,
    dataSource As Object,
    Optional dataMember As String = ""
)

参数

row
类型：Swebui.ControlsListViewRow
列表行
dataSource
类型：SystemObject
数据源
dataMember (Optional)
类型：SystemString
数据源名称
参见

引用

ListView 类


ListView 事件

ListView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。
公共事件 | PositionChanged | 在位置变化时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在上划到底部时发生。
公共事件 | Refresh | 在用户下拉刷新时发生。
公共事件 | RowBind | 在行绑定后发生。
公共事件 | RowBinding | 在行绑定时发生。
Top
参见

引用

ListView 类


ListView.DataSourceUpdate 事件

ListViewDataSourceUpdate 事件

在更新数据源时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event DataSourceUpdateEventHandler DataSourceUpdate
Public Event DataSourceUpdate As DataSourceUpdateEventHandler

值

类型：Swebui.ControlsDataSourceUpdateEventHandler
参见

引用

ListView 类


ListView.PositionChanged 事件

ListViewPositionChanged 事件

在位置变化时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ScrollPositionChangedEventHandler PositionChanged
Public Event PositionChanged As ScrollPositionChangedEventHandler

值

类型：Swebui.ControlsScrollPositionChangedEventHandler
备注
只支持竖向滚动
参见

引用

ListView 类


ListView.ReachEnd 事件

ListViewReachEnd 事件

在上划到底部时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler ReachEnd
Public Event ReachEnd As EventHandler

值

类型：SystemEventHandler
参见

引用

ListView 类


ListView.Refresh 事件

ListViewRefresh 事件

在用户下拉刷新时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Refresh
Public Event Refresh As EventHandler

值

类型：SystemEventHandler
参见

引用

ListView 类


ListView.RowBind 事件

ListViewRowBind 事件

在行绑定后发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ListViewTemplateBindEventHandler RowBind
Public Event RowBind As ListViewTemplateBindEventHandler

值

类型：Swebui.ControlsListViewTemplateBindEventHandler
参见

引用

ListView 类


ListView.RowBinding 事件

ListViewRowBinding 事件

在行绑定时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ListViewTemplateBindEventHandler RowBinding
Public Event RowBinding As ListViewTemplateBindEventHandler

值

类型：Swebui.ControlsListViewTemplateBindEventHandler
参见

引用

ListView 类


ListViewRow 类

列表控件行。
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsListViewRow
Swebui.ControlsSectionListViewRow

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewRow : SwebViewTemplateItem
Public Class ListViewRow
    Inherits SwebViewTemplateItem

ListViewRow 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListViewRow | 初始化 ListViewRow 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取和设置区域编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

Swebui.Controls 命名空间


ListViewRow 构造函数

初始化 ListViewRow 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRow()
Public Sub New
参见

引用

ListViewRow 类


ListViewRow 属性

ListViewRow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取和设置区域编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

ListViewRow 类


ListViewRow.SectionID 属性

ListViewRowSectionID 属性

获取和设置区域编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string SectionID { get; set; }
Public Overridable Property SectionID As String
    Get
    Set

返回值

类型：String
备注
参见

引用

ListViewRow 类


ListViewRow 方法

ListViewRow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

ListViewRow 类


ListViewRowCollection 类

列表控件行集合
继承层次
SystemObject
Swebui.ControlsSwebViewCollection ListViewRow
Swebui.ControlsListViewRowCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewRowCollection : SwebViewCollection<ListViewRow>
Public Class ListViewRowCollection
    Inherits SwebViewCollection(Of ListViewRow)

ListViewRowCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListViewRowCollection | 初始化 ListViewRowCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


ListViewRowCollection 构造函数

初始化 ListViewRowCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRowCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.ListViewRowCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

ListViewRowCollection 类


ListViewRowCollection 属性

ListViewRowCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

ListViewRowCollection 类


ListViewRowCollection 方法

ListViewRowCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

ListViewRowCollection 类


ListViewSection 类

列表区域
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsListViewSection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewSection : SwebViewTemplateItem
Public Class ListViewSection
    Inherits SwebViewTemplateItem

ListViewSection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListViewSection | 获取 ListViewSection 实例对象
Top
属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取列表区域编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

Swebui.Controls 命名空间


ListViewSection 构造函数

获取 ListViewSection 实例对象

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSection(
    string sectionId
)
Public Sub New (
    sectionId As String
)

参数

sectionId
类型：SystemString
列表区域编号
参见

引用

ListViewSection 类


ListViewSection 属性

ListViewSection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取列表区域编号
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

ListViewSection 类


ListViewSection.SectionID 属性

ListViewSectionSectionID 属性

获取列表区域编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string SectionID { get; }
Public ReadOnly Property SectionID As String
    Get

返回值

类型：String
参见

引用

ListViewSection 类


ListViewSection 方法

ListViewSection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

ListViewSection 类


ListViewSectionCollection 类

列表区域集合
继承层次
SystemObject
Swebui.ControlsSwebViewCollection ListViewSection
Swebui.ControlsListViewSectionCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewSectionCollection : SwebViewCollection<ListViewSection>
Public Class ListViewSectionCollection
    Inherits SwebViewCollection(Of ListViewSection)

ListViewSectionCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListViewSectionCollection | 初始化 ListViewSectionCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | ItemString | 获取和设置指定区域名称的元素
公共属性 | ItemInt32 | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | (重写 SwebViewCollectionTAdd(T).)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


ListViewSectionCollection 构造函数

初始化 ListViewSectionCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSectionCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.ListViewSectionCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

ListViewSectionCollection 类


ListViewSectionCollection 属性

ListViewSectionCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | ItemString | 获取和设置指定区域名称的元素
公共属性 | ItemInt32 | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

ListViewSectionCollection 类


ListViewSectionCollection.Item 属性

ListViewSectionCollectionItem 属性

重载列表
 | 名称 | 说明
公共属性 | ItemString | 获取和设置指定区域名称的元素
公共属性 | ItemInt32 | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

ListViewSectionCollection 类


ListViewSectionCollection.Item 属性 (String)

ListViewSectionCollectionItem 属性 (String)

获取和设置指定区域名称的元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSection this[
    string sectionId
] { get; set; }
Public Default Property Item (
    sectionId As String
) As ListViewSection
    Get
    Set

参数

sectionId
类型：SystemString

返回值

类型：ListViewSection
参见

引用

ListViewSectionCollection 类
Item 重载


ListViewSectionCollection 方法

ListViewSectionCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | (重写 SwebViewCollectionTAdd(T).)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

ListViewSectionCollection 类


ListViewSectionCollection.Add 方法

ListViewSectionCollectionAdd 方法

[缺少 "M:Swebui.Controls.ListViewSectionCollection.Add(Swebui.Controls.ListViewSection)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override void Add(
    ListViewSection item
)
Public Overrides Sub Add (
    item As ListViewSection
)

参数

item
类型：Swebui.ControlsListViewSection

[缺少 "M:Swebui.Controls.ListViewSectionCollection.Add(Swebui.Controls.ListViewSection)" 的 <param name="item"/> 文档]

参见

引用

ListViewSectionCollection 类


ListViewTemplateBindEventArgs 类

为 ListViewTemplateBindEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsListViewTemplateBindEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewTemplateBindEventArgs : EventArgs
Public Class ListViewTemplateBindEventArgs
    Inherits EventArgs

ListViewTemplateBindEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListViewTemplateBindEventArgs | 初始化 ListViewTemplateBindEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data | 获取绑定数据
公共属性 | Row | 获取绑定行
Top
参见

引用

Swebui.Controls 命名空间


ListViewTemplateBindEventArgs 构造函数

初始化 ListViewTemplateBindEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewTemplateBindEventArgs()
Public Sub New
参见

引用

ListViewTemplateBindEventArgs 类


ListViewTemplateBindEventArgs 属性

ListViewTemplateBindEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data | 获取绑定数据
公共属性 | Row | 获取绑定行
Top
参见

引用

ListViewTemplateBindEventArgs 类


ListViewTemplateBindEventArgs.Data 属性

ListViewTemplateBindEventArgsData 属性

获取绑定数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Data { get; }
Public ReadOnly Property Data As Object
    Get

返回值

类型：Object
参见

引用

ListViewTemplateBindEventArgs 类


ListViewTemplateBindEventArgs.Row 属性

ListViewTemplateBindEventArgsRow 属性

获取绑定行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewRow Row { get; }
Public ReadOnly Property Row As ListViewRow
    Get

返回值

类型：ListViewRow
参见

引用

ListViewTemplateBindEventArgs 类


ListViewTemplateBindEventHandler 委托

一个委托，它表示模板控件绑定过程要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ListViewTemplateBindEventHandler(
    Object sender,
    ListViewTemplateBindEventArgs e
)
Public Delegate Sub ListViewTemplateBindEventHandler (
    sender As Object,
    e As ListViewTemplateBindEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsListViewTemplateBindEventArgs
包含事件数据的 ListViewTemplateBindEventArgs
参见

引用

Swebui.Controls 命名空间


LoadClientDataCallBackHandler 委托

一个委托，它表示客户端完成数据载入时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void LoadClientDataCallBackHandler(
    Object sender,
    ClientDataResultHandlerArgs e
)
Public Delegate Sub LoadClientDataCallBackHandler (
    sender As Object,
    e As ClientDataResultHandlerArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientDataResultHandlerArgs
包含事件数据的 ClientDataResultHandlerArgs
备注
参见

引用

Swebui.Controls 命名空间


LoadClientResourceHandler 委托

一个委托，它表示在载入客户端资源后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void LoadClientResourceHandler(
    Object sender,
    ClientResourceLoadResultArgs e
)
Public Delegate Sub LoadClientResourceHandler (
    sender As Object,
    e As ClientResourceLoadResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientResourceLoadResultArgs
包含事件数据的 ClientResourceArgs
备注
参见

引用

Swebui.Controls 命名空间


LowercaseFirstPropertyExtend 类

[缺少 "T:Swebui.Controls.LowercaseFirstPropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsLowercaseFirstPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class LowercaseFirstPropertyExtend : SwebPropertyExtend
Public Class LowercaseFirstPropertyExtend
    Inherits SwebPropertyExtend

LowercaseFirstPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LowercaseFirstPropertyExtend | 初始化 LowercaseFirstPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


LowercaseFirstPropertyExtend 构造函数

初始化 LowercaseFirstPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public LowercaseFirstPropertyExtend()
Public Sub New
参见

引用

LowercaseFirstPropertyExtend 类


LowercasePropertyExtend 类

[缺少 "T:Swebui.Controls.LowercasePropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsLowercasePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class LowercasePropertyExtend : SwebPropertyExtend
Public Class LowercasePropertyExtend
    Inherits SwebPropertyExtend

LowercasePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LowercasePropertyExtend | 初始化 LowercasePropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


LowercasePropertyExtend 构造函数

初始化 LowercasePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public LowercasePropertyExtend()
Public Sub New
参见

引用

LowercasePropertyExtend 类


MapTagView 类

地理位置标签
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsMapTagView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapTagView : SwebControl, ISwebRenderControl,
    ISwebEventControl
Public Class MapTagView
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl

MapTagView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapTagView | 初始化 MapTagView 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Description | 获取和设置地理位置标签描述
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Latitude | 获取和设置地理位置标签纬度
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Longitude | 获取和设置地理位置经度
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WebKey | 获取和设置高德web服务key
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
事件
 | 名称 | 说明
公共事件 | Press | 在点击地理位置标签时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


MapTagView 构造函数

初始化 MapTagView 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapTagView()
Public Sub New
参见

引用

MapTagView 类


MapTagView 属性

MapTagView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Description | 获取和设置地理位置标签描述
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Latitude | 获取和设置地理位置标签纬度
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Longitude | 获取和设置地理位置经度
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WebKey | 获取和设置高德web服务key
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

MapTagView 类


MapTagView.BorderRadius 属性

MapTagViewBorderRadius 属性

[缺少 "P:Swebui.Controls.MapTagView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MapTagView 类


MapTagView.Description 属性

MapTagViewDescription 属性

获取和设置地理位置标签描述

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Description { get; set; }
Public Property Description As String
    Get
    Set

属性值

类型：String
参见

引用

MapTagView 类


MapTagView.Latitude 属性

MapTagViewLatitude 属性

获取和设置地理位置标签纬度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

MapTagView 类


MapTagView.Longitude 属性

MapTagViewLongitude 属性

获取和设置地理位置经度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

MapTagView 类


MapTagView.Padding 属性

MapTagViewPadding 属性

[缺少 "P:Swebui.Controls.MapTagView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

MapTagView 类


MapTagView.WebKey 属性

MapTagViewWebKey 属性

获取和设置高德web服务key

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string WebKey { get; set; }
Public Property WebKey As String
    Get
    Set

属性值

类型：String
参见

引用

MapTagView 类


MapTagView 方法

MapTagView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
参见

引用

MapTagView 类


MapTagView.OnEventRaised 方法

MapTagViewOnEventRaised 方法

[缺少 "M:Swebui.Controls.MapTagView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.MapTagView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

MapTagView 类


MapTagView 事件

MapTagView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Press | 在点击地理位置标签时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

MapTagView 类


MapTagView.Press 事件

MapTagViewPress 事件

在点击地理位置标签时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler Press
Public Event Press As EventHandler

值

类型：SystemEventHandler
参见

引用

MapTagView 类


MapTrimView 类

地点微调控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsMapTrimView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapTrimView : SwebNativeControl,
    ISwebEventControl
Public Class MapTrimView
    Inherits SwebNativeControl
    Implements ISwebEventControl

MapTrimView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapTrimView | 初始化MapTrimView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Description | 获取和设置地图描述
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoType | 获取和设置地图类型。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Latitude | 获取和设置地图纬度
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Longitude | 获取和设置地图经度
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | LocationChanged | 地图标签移动时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


MapTrimView 构造函数

初始化MapTrimView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapTrimView()
Public Sub New
参见

引用

MapTrimView 类


MapTrimView 属性

MapTrimView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Description | 获取和设置地图描述
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoType | 获取和设置地图类型。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Latitude | 获取和设置地图纬度
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Longitude | 获取和设置地图经度
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

MapTrimView 类


MapTrimView.BackColor 属性

MapTrimViewBackColor 属性

[缺少 "P:Swebui.Controls.MapTrimView.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MapTrimView 类


MapTrimView.Border 属性

MapTrimViewBorder 属性

[缺少 "P:Swebui.Controls.MapTrimView.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

MapTrimView 类


MapTrimView.BorderColor 属性

MapTrimViewBorderColor 属性

[缺少 "P:Swebui.Controls.MapTrimView.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MapTrimView 类


MapTrimView.BorderRadius 属性

MapTrimViewBorderRadius 属性

[缺少 "P:Swebui.Controls.MapTrimView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MapTrimView 类


MapTrimView.BorderStyle 属性

MapTrimViewBorderStyle 属性

[缺少 "P:Swebui.Controls.MapTrimView.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

MapTrimView 类


MapTrimView.Description 属性

MapTrimViewDescription 属性

获取和设置地图描述

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Description { get; set; }
Public Property Description As String
    Get
    Set

属性值

类型：String
参见

引用

MapTrimView 类


MapTrimView.GeoType 属性

MapTrimViewGeoType 属性

获取和设置地图类型。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GeoType GeoType { get; set; }
Public Property GeoType As GeoType
    Get
    Set

属性值

类型：GeoType
参见

引用

MapTrimView 类


MapTrimView.Latitude 属性

MapTrimViewLatitude 属性

获取和设置地图纬度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Latitude { get; set; }
Public Property Latitude As Single
    Get
    Set

属性值

类型：Single
参见

引用

MapTrimView 类


MapTrimView.Longitude 属性

MapTrimViewLongitude 属性

获取和设置地图经度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Longitude { get; set; }
Public Property Longitude As Single
    Get
    Set

属性值

类型：Single
参见

引用

MapTrimView 类


MapTrimView.Padding 属性

MapTrimViewPadding 属性

[缺少 "P:Swebui.Controls.MapTrimView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

MapTrimView 类


MapTrimView 方法

MapTrimView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

MapTrimView 类


MapTrimView 事件

MapTrimView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | LocationChanged | 地图标签移动时触发
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

MapTrimView 类


MapTrimView.LocationChanged 事件

MapTrimViewLocationChanged 事件

地图标签移动时触发

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event MapTrimViewLocationChanged LocationChanged
Public Event LocationChanged As MapTrimViewLocationChanged

值

类型：Swebui.ControlsMapTrimViewLocationChanged
参见

引用

MapTrimView 类


MapTrimViewLocationChanged 委托

一个委托，它表示在地图上的标签移动时需要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void MapTrimViewLocationChanged(
    Object sender,
    MapTrimViewLocationChangedEventArgs e
)
Public Delegate Sub MapTrimViewLocationChanged (
    sender As Object,
    e As MapTrimViewLocationChangedEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsMapTrimViewLocationChangedEventArgs
包含事件数据的MapTrimViewLocationChangedEventArgs
参见

引用

Swebui.Controls 命名空间


MapTrimViewLocationChangedEventArgs 类

为MapTrimViewlocationChanged提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsMapTrimViewLocationChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapTrimViewLocationChangedEventArgs : EventArgs
Public Class MapTrimViewLocationChangedEventArgs
    Inherits EventArgs

MapTrimViewLocationChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapTrimViewLocationChangedEventArgs | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Description | 获取地图上标签的描述
公共属性 | Latitude | 获取地图上标签的纬度
公共属性 | Longitude | 获取地图上标签的经度
Top
参见

引用

Swebui.Controls 命名空间


MapTrimViewLocationChangedEventArgs 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapTrimViewLocationChangedEventArgs(
    float latitude,
    float longitude,
    string description
)
Public Sub New (
    latitude As Single,
    longitude As Single,
    description As String
)

参数

latitude
类型：SystemSingle
地图纬度
longitude
类型：SystemSingle
地图经度
description
类型：SystemString
地图描述
参见

引用

MapTrimViewLocationChangedEventArgs 类


MapTrimViewLocationChangedEventArgs 属性

MapTrimViewLocationChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Description | 获取地图上标签的描述
公共属性 | Latitude | 获取地图上标签的纬度
公共属性 | Longitude | 获取地图上标签的经度
Top
参见

引用

MapTrimViewLocationChangedEventArgs 类


MapTrimViewLocationChangedEventArgs.Description 属性

MapTrimViewLocationChangedEventArgsDescription 属性

获取地图上标签的描述

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Description { get; }
Public ReadOnly Property Description As String
    Get

属性值

类型：String
参见

引用

MapTrimViewLocationChangedEventArgs 类


MapTrimViewLocationChangedEventArgs.Latitude 属性

MapTrimViewLocationChangedEventArgsLatitude 属性

获取地图上标签的纬度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Latitude { get; }
Public ReadOnly Property Latitude As Single
    Get

属性值

类型：Single
参见

引用

MapTrimViewLocationChangedEventArgs 类


MapTrimViewLocationChangedEventArgs.Longitude 属性

MapTrimViewLocationChangedEventArgsLongitude 属性

获取地图上标签的经度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Longitude { get; }
Public ReadOnly Property Longitude As Single
    Get

属性值

类型：Single
参见

引用

MapTrimViewLocationChangedEventArgs 类


MapView 类

地图控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsMapView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapView : SwebNativeControl, ISwebEventControl
Public Class MapView
    Inherits SwebNativeControl
    Implements ISwebEventControl

MapView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapView | 初始化MapView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoType | 获取和设置地图类型。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Routes | 获取地图路径集合。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TagNavigation | 获取和设置点击Tag描述内容时,是否提示跳转导航
公共属性 | Tags | 获取地图标签集合。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
公共属性 | ZoomLevel | 获取和设置地图显示级别
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | SearchRoute | 搜索路径
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | TagClick | 在地图标签被点击时触发。
Top
参见

引用

Swebui.Controls 命名空间


MapView 构造函数

初始化MapView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapView()
Public Sub New
参见

引用

MapView 类


MapView 属性

MapView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoType | 获取和设置地图类型。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Routes | 获取地图路径集合。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TagNavigation | 获取和设置点击Tag描述内容时,是否提示跳转导航
公共属性 | Tags | 获取地图标签集合。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
公共属性 | ZoomLevel | 获取和设置地图显示级别
Top
参见

引用

MapView 类


MapView.BackColor 属性

MapViewBackColor 属性

[缺少 "P:Swebui.Controls.MapView.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MapView 类


MapView.Border 属性

MapViewBorder 属性

[缺少 "P:Swebui.Controls.MapView.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

MapView 类


MapView.BorderColor 属性

MapViewBorderColor 属性

[缺少 "P:Swebui.Controls.MapView.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MapView 类


MapView.BorderRadius 属性

MapViewBorderRadius 属性

[缺少 "P:Swebui.Controls.MapView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MapView 类


MapView.BorderStyle 属性

MapViewBorderStyle 属性

[缺少 "P:Swebui.Controls.MapView.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

MapView 类


MapView.GeoType 属性

MapViewGeoType 属性

获取和设置地图类型。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public GeoType GeoType { get; set; }
Public Property GeoType As GeoType
    Get
    Set

属性值

类型：GeoType
参见

引用

MapView 类


MapView.Padding 属性

MapViewPadding 属性

[缺少 "P:Swebui.Controls.MapView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

MapView 类


MapView.Routes 属性

MapViewRoutes 属性

获取地图路径集合。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewRouteCollection Routes { get; }
Public ReadOnly Property Routes As MapViewRouteCollection
    Get

属性值

类型：MapViewRouteCollection
参见

引用

MapView 类


MapView.TagNavigation 属性

MapViewTagNavigation 属性

获取和设置点击Tag描述内容时,是否提示跳转导航

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool TagNavigation { get; set; }
Public Property TagNavigation As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

MapView 类


MapView.Tags 属性

MapViewTags 属性

获取地图标签集合。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTagCollection Tags { get; }
Public ReadOnly Property Tags As MapViewTagCollection
    Get

属性值

类型：MapViewTagCollection
参见

引用

MapView 类


MapView.ZoomLevel 属性

MapViewZoomLevel 属性

获取和设置地图显示级别

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int ZoomLevel { get; set; }
Public Property ZoomLevel As Integer
    Get
    Set

属性值

类型：Int32
大于等于3，小于等于19
参见

引用

MapView 类


MapView 方法

MapView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | SearchRoute | 搜索路径
Top
参见

引用

MapView 类


MapView.SearchRoute 方法

MapViewSearchRoute 方法

搜索路径

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void SearchRoute(
    MapViewPoint start,
    MapViewPoint stop,
    params MapViewPoint[] waypoint
)
Public Sub SearchRoute (
    start As MapViewPoint,
    stop As MapViewPoint,
    ParamArray waypoint As MapViewPoint()
)

参数

start
类型：Swebui.ControlsMapViewPoint
起始位置
stop
类型：Swebui.ControlsMapViewPoint
结束位置
waypoint
类型：Swebui.ControlsMapViewPoint
途经点，0-16个
参见

引用

MapView 类


MapView 事件

MapView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | TagClick | 在地图标签被点击时触发。
Top
参见

引用

MapView 类


MapView.TagClick 事件

MapViewTagClick 事件

在地图标签被点击时触发。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event MapViewTagClickEventHandler TagClick
Public Event TagClick As MapViewTagClickEventHandler

值

类型：Swebui.ControlsMapViewTagClickEventHandler
参见

引用

MapView 类


MapViewPoint 类

地图坐标
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsMapViewPoint
Swebui.ControlsMapViewTag

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewPoint : SwebViewCollectionItem
Public Class MapViewPoint
    Inherits SwebViewCollectionItem

MapViewPoint 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewPoint(Double, Double) | 构造方法
公共方法 | MapViewPoint(Double, Double, String) | 构造方法
公共方法 | MapViewPoint(Double, Double, String, String) | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Description | 获取坐标描述
公共属性 | ImageUrl | 获取坐标点图标样式,如果给空,则显示默认样式
公共属性 | Latitude | 获取纬度
公共属性 | Longitude | 获取经度
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewPoint 构造函数

重载列表
 | 名称 | 说明
公共方法 | MapViewPoint(Double, Double) | 构造方法
公共方法 | MapViewPoint(Double, Double, String) | 构造方法
公共方法 | MapViewPoint(Double, Double, String, String) | 构造方法
Top
参见

引用

MapViewPoint 类


MapViewPoint 构造函数 (Double, Double)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewPoint(
    double longitude,
    double latitude
)
Public Sub New (
    longitude As Double,
    latitude As Double
)

参数

longitude
类型：SystemDouble
经度
latitude
类型：SystemDouble
纬度
参见

引用

MapViewPoint 类
MapViewPoint 重载


MapViewPoint 构造函数 (Double, Double, String)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewPoint(
    double longitude,
    double latitude,
    string description
)
Public Sub New (
    longitude As Double,
    latitude As Double,
    description As String
)

参数

longitude
类型：SystemDouble
经度
latitude
类型：SystemDouble
纬度
description
类型：SystemString
坐标描述
参见

引用

MapViewPoint 类
MapViewPoint 重载


MapViewPoint 构造函数 (Double, Double, String, String)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewPoint(
    double longitude,
    double latitude,
    string description,
    string imageurl
)
Public Sub New (
    longitude As Double,
    latitude As Double,
    description As String,
    imageurl As String
)

参数

longitude
类型：SystemDouble
经度
latitude
类型：SystemDouble
纬度
description
类型：SystemString
坐标描述
imageurl
类型：SystemString
坐标点图标样式
参见

引用

MapViewPoint 类
MapViewPoint 重载


MapViewPoint 属性

MapViewPoint 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Description | 获取坐标描述
公共属性 | ImageUrl | 获取坐标点图标样式,如果给空,则显示默认样式
公共属性 | Latitude | 获取纬度
公共属性 | Longitude | 获取经度
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

MapViewPoint 类


MapViewPoint.Description 属性

MapViewPointDescription 属性

获取坐标描述

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Description { get; set; }
Public Property Description As String
    Get
    Set

属性值

类型：String
参见

引用

MapViewPoint 类


MapViewPoint.ImageUrl 属性

MapViewPointImageUrl 属性

获取坐标点图标样式,如果给空,则显示默认样式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ImageUrl { get; set; }
Public Property ImageUrl As String
    Get
    Set

属性值

类型：String
参见

引用

MapViewPoint 类


MapViewPoint.Latitude 属性

MapViewPointLatitude 属性

获取纬度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

MapViewPoint 类


MapViewPoint.Longitude 属性

MapViewPointLongitude 属性

获取经度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set

属性值

类型：Double
参见

引用

MapViewPoint 类


MapViewPointCollection 类

地图坐标集合
继承层次
SystemObject
Swebui.ControlsSwebViewCollection MapViewPoint
Swebui.ControlsMapViewPointCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewPointCollection : SwebViewCollection<MapViewPoint>
Public Class MapViewPointCollection
    Inherits SwebViewCollection(Of MapViewPoint)

MapViewPointCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewPointCollection | 初始化 MapViewPointCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewPointCollection 构造函数

初始化 MapViewPointCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewPointCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.MapViewPointCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

MapViewPointCollection 类


MapViewPointCollection 属性

MapViewPointCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

MapViewPointCollection 类


MapViewPointCollection 方法

MapViewPointCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

MapViewPointCollection 类


MapViewRoute 类

地图路径
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsMapViewRoute

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewRoute : SwebViewCollectionItem
Public Class MapViewRoute
    Inherits SwebViewCollectionItem

MapViewRoute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewRoute | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | ID | 获取路径编号
公共属性 | Point | 获取路径坐标集合
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewRoute 构造函数

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewRoute()
Public Sub New
参见

引用

MapViewRoute 类


MapViewRoute 属性

MapViewRoute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ID | 获取路径编号
公共属性 | Point | 获取路径坐标集合
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

MapViewRoute 类


MapViewRoute.ID 属性

MapViewRouteID 属性

获取路径编号

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ID { get; }
Public ReadOnly Property ID As String
    Get

属性值

类型：String
参见

引用

MapViewRoute 类


MapViewRoute.Point 属性

MapViewRoutePoint 属性

获取路径坐标集合

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewPointCollection Point { get; }
Public ReadOnly Property Point As MapViewPointCollection
    Get

属性值

类型：MapViewPointCollection
参见

引用

MapViewRoute 类


MapViewRouteCollection 类

地图路径集合
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase MapViewRoute
Swebui.ControlsMapViewRouteCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewRouteCollection : SwebViewCollectionBase<MapViewRoute>
Public Class MapViewRouteCollection
    Inherits SwebViewCollectionBase(Of MapViewRoute)

MapViewRouteCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewRouteCollection | 初始化 MapViewRouteCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewRouteCollection 构造函数

初始化 MapViewRouteCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewRouteCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.MapViewRouteCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

MapViewRouteCollection 类


MapViewRouteCollection 属性

MapViewRouteCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

MapViewRouteCollection 类


MapViewRouteCollection 方法

MapViewRouteCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

MapViewRouteCollection 类


MapViewTag 类

地图标签
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsMapViewPoint
Swebui.ControlsMapViewTag

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewTag : MapViewPoint
Public Class MapViewTag
    Inherits MapViewPoint

MapViewTag 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewTag(Double, Double) | 构造方法
公共方法 | MapViewTag(Double, Double, String) | 构造方法
公共方法 | MapViewTag(Double, Double, String, String) | 初始化 MapViewTag 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Description | 获取坐标描述 (继承自 MapViewPoint。)
公共属性 | ID | 获取内部编号
公共属性 | ImageUrl | 获取坐标点图标样式,如果给空,则显示默认样式 (继承自 MapViewPoint。)
公共属性 | Latitude | 获取纬度 (继承自 MapViewPoint。)
公共属性 | Longitude | 获取经度 (继承自 MapViewPoint。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewTag 构造函数

重载列表
 | 名称 | 说明
公共方法 | MapViewTag(Double, Double) | 构造方法
公共方法 | MapViewTag(Double, Double, String) | 构造方法
公共方法 | MapViewTag(Double, Double, String, String) | 初始化 MapViewTag 类的一个新实例
Top
参见

引用

MapViewTag 类


MapViewTag 构造函数 (Double, Double)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTag(
    double longitude,
    double latitude
)
Public Sub New (
    longitude As Double,
    latitude As Double
)

参数

longitude
类型：SystemDouble
经度
latitude
类型：SystemDouble
纬度
参见

引用

MapViewTag 类
MapViewTag 重载


MapViewTag 构造函数 (Double, Double, String)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTag(
    double longitude,
    double latitude,
    string description
)
Public Sub New (
    longitude As Double,
    latitude As Double,
    description As String
)

参数

longitude
类型：SystemDouble
经度
latitude
类型：SystemDouble
纬度
description
类型：SystemString
坐标描述
参见

引用

MapViewTag 类
MapViewTag 重载


MapViewTag 构造函数 (Double, Double, String, String)

初始化 MapViewTag 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTag(
    double longitude,
    double latitude,
    string description,
    string imageurl
)
Public Sub New (
    longitude As Double,
    latitude As Double,
    description As String,
    imageurl As String
)

参数

longitude
类型：SystemDouble

[缺少 "M:Swebui.Controls.MapViewTag.#ctor(System.Double,System.Double,System.String,System.String)" 的 <param name="longitude"/> 文档]

latitude
类型：SystemDouble

[缺少 "M:Swebui.Controls.MapViewTag.#ctor(System.Double,System.Double,System.String,System.String)" 的 <param name="latitude"/> 文档]

description
类型：SystemString

[缺少 "M:Swebui.Controls.MapViewTag.#ctor(System.Double,System.Double,System.String,System.String)" 的 <param name="description"/> 文档]

imageurl
类型：SystemString

[缺少 "M:Swebui.Controls.MapViewTag.#ctor(System.Double,System.Double,System.String,System.String)" 的 <param name="imageurl"/> 文档]

参见

引用

MapViewTag 类
MapViewTag 重载


MapViewTag 属性

MapViewTag 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Description | 获取坐标描述 (继承自 MapViewPoint。)
公共属性 | ID | 获取内部编号
公共属性 | ImageUrl | 获取坐标点图标样式,如果给空,则显示默认样式 (继承自 MapViewPoint。)
公共属性 | Latitude | 获取纬度 (继承自 MapViewPoint。)
公共属性 | Longitude | 获取经度 (继承自 MapViewPoint。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

MapViewTag 类


MapViewTag.ID 属性

MapViewTagID 属性

获取内部编号

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ID { get; }
Public ReadOnly Property ID As String
    Get

属性值

类型：String
参见

引用

MapViewTag 类


MapViewTagClickEventArgs 类

为MapViewTagClick提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsMapViewTagClickEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewTagClickEventArgs : EventArgs
Public Class MapViewTagClickEventArgs
    Inherits EventArgs

MapViewTagClickEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewTagClickEventArgs | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Tag | 获取地图上点击的标签。
Top
参见

引用

Swebui.Controls 命名空间


MapViewTagClickEventArgs 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTagClickEventArgs(
    MapViewTag tag
)
Public Sub New (
    tag As MapViewTag
)

参数

tag
类型：Swebui.ControlsMapViewTag
地图标签
参见

引用

MapViewTagClickEventArgs 类


MapViewTagClickEventArgs 属性

MapViewTagClickEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Tag | 获取地图上点击的标签。
Top
参见

引用

MapViewTagClickEventArgs 类


MapViewTagClickEventArgs.Tag 属性

MapViewTagClickEventArgsTag 属性

获取地图上点击的标签。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTag Tag { get; }
Public ReadOnly Property Tag As MapViewTag
    Get

属性值

类型：MapViewTag
参见

引用

MapViewTagClickEventArgs 类


MapViewTagClickEventHandler 委托

一个委托，它表示在地图上的标签被点击时需要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void MapViewTagClickEventHandler(
    Object sender,
    MapViewTagClickEventArgs e
)
Public Delegate Sub MapViewTagClickEventHandler (
    sender As Object,
    e As MapViewTagClickEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsMapViewTagClickEventArgs
包含事件数据的 MapViewTagClickEventArgs
参见

引用

Swebui.Controls 命名空间


MapViewTagCollection 类

地图坐标集合
继承层次
SystemObject
Swebui.ControlsSwebViewCollection MapViewTag
Swebui.ControlsMapViewTagCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MapViewTagCollection : SwebViewCollection<MapViewTag>
Public Class MapViewTagCollection
    Inherits SwebViewCollection(Of MapViewTag)

MapViewTagCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MapViewTagCollection | 初始化 MapViewTagCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


MapViewTagCollection 构造函数

初始化 MapViewTagCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MapViewTagCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.MapViewTagCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

MapViewTagCollection 类


MapViewTagCollection 属性

MapViewTagCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

MapViewTagCollection 类


MapViewTagCollection 方法

MapViewTagCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

MapViewTagCollection 类


Margin 结构

控件边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[SerializableAttribute]
[TypeConverterAttribute(typeof(MarginConverter))]
public struct Margin
<SerializableAttribute>
<TypeConverterAttribute(GetType(MarginConverter))>
Public Structure Margin

Margin 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Margin(Single) | 构造函数
公共方法 | Margin(Single, Single, Single, Single) | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
方法
 | 名称 | 说明
公共方法 | ToString | 转换为字符串形式 (重写 ValueTypeToString.)
Top
运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
字段
名称 | 说明
Empty | 空边距
Top
备注
参见

引用

Swebui.Controls 命名空间


Margin 构造函数

重载列表
 | 名称 | 说明
公共方法 | Margin(Single) | 构造函数
公共方法 | Margin(Single, Single, Single, Single) | 构造函数
Top
参见

引用

Margin 结构


Margin 构造函数 (Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Margin(
    float all
)
Public Sub New (
    all As Single
)

参数

all
类型：SystemSingle
所有边距
备注
参见

引用

Margin 结构
Margin 重载


Margin 构造函数 (Single, Single, Single, Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Margin(
    float left,
    float top,
    float right,
    float bottom
)
Public Sub New (
    left As Single,
    top As Single,
    right As Single,
    bottom As Single
)

参数

left
类型：SystemSingle
左边距
top
类型：SystemSingle
上边距
right
类型：SystemSingle
右边距
bottom
类型：SystemSingle
下边距
备注
参见

引用

Margin 结构
Margin 重载


Margin 属性

Margin 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
参见

引用

Margin 结构


Margin.All 属性

MarginAll 属性

获取或设置所有边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float All { get; set; }
Public Property All As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Margin 结构


Margin.Bottom 属性

MarginBottom 属性

获取或设置下边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Bottom { get; set; }
Public Property Bottom As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Margin 结构


Margin.Left 属性

MarginLeft 属性

获取或设置左边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Left { get; set; }
Public Property Left As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Margin 结构


Margin.Right 属性

MarginRight 属性

获取或设置右边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Right { get; set; }
Public Property Right As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Margin 结构


Margin.Top 属性

MarginTop 属性

获取或设置上边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Top { get; set; }
Public Property Top As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Margin 结构


Margin 方法

Margin 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ToString | 转换为字符串形式 (重写 ValueTypeToString.)
Top
参见

引用

Margin 结构


Margin.ToString 方法

MarginToString 方法

转换为字符串形式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ToString()
Public Overrides Function ToString As String

返回值

类型：String

[缺少 "M:Swebui.Controls.Margin.ToString" 的 <returns> 文档]

参见

引用

Margin 结构


Margin 运算符

Margin 类型公开以下成员。

运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
参见

引用

Margin 结构


Margin.Equality 运算符

MarginEquality 运算符

Implements the operator = operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator ==(
    Margin lhs,
    Margin rhs
)
Public Shared Operator = (
    lhs As Margin,
    rhs As Margin
) As Boolean

参数

lhs
类型：Swebui.ControlsMargin
The LHS.
rhs
类型：Swebui.ControlsMargin
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Margin 结构


Margin.Inequality 运算符

MarginInequality 运算符

Implements the operator <> operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator !=(
    Margin lhs,
    Margin rhs
)
Public Shared Operator <> (
    lhs As Margin,
    rhs As Margin
) As Boolean

参数

lhs
类型：Swebui.ControlsMargin
The LHS.
rhs
类型：Swebui.ControlsMargin
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Margin 结构


Margin 字段

Margin 类型公开以下成员。

字段
名称 | 说明
Empty | 空边距
Top
参见

引用

Margin 结构


Margin.Empty 字段

MarginEmpty 字段

空边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static readonly Margin Empty
Public Shared ReadOnly Empty As Margin

字段值

类型：Margin
参见

引用

Margin 结构


MarginConverter 类

为 Margin 提供类型转换
继承层次
SystemObject
System.ComponentModelTypeConverter
Swebui.ControlsMarginConverter

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class MarginConverter : TypeConverter
Public Class MarginConverter
    Inherits TypeConverter

MarginConverter 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MarginConverter | 初始化 MarginConverter 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
备注
参见

引用

Swebui.Controls 命名空间


MarginConverter 构造函数

初始化 MarginConverter 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public MarginConverter()
Public Sub New
参见

引用

MarginConverter 类


MarginConverter 方法

MarginConverter 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
参见

引用

MarginConverter 类


MarginConverter.CanConvertFrom 方法

MarginConverterCanConvertFrom 方法

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

sourceType
类型：SystemType

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="sourceType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.CanConvertTo 方法

MarginConverterCanConvertTo 方法

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.MarginConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.ConvertFrom 方法

MarginConverterConvertFrom 方法

[缺少 "M:Swebui.Controls.MarginConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.MarginConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.MarginConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.MarginConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.ConvertTo 方法

MarginConverterConvertTo 方法

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="value"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.MarginConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.CreateInstance 方法

MarginConverterCreateInstance 方法

[缺少 "M:Swebui.Controls.MarginConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Public Overrides Function CreateInstance (
    context As ITypeDescriptorContext,
    propertyValues As IDictionary
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="context"/> 文档]

propertyValues
类型：System.CollectionsIDictionary

[缺少 "M:Swebui.Controls.MarginConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="propertyValues"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.MarginConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.GetCreateInstanceSupported 方法

MarginConverterGetCreateInstanceSupported 方法

[缺少 "M:Swebui.Controls.MarginConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetCreateInstanceSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.MarginConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.GetProperties 方法

MarginConverterGetProperties 方法

[缺少 "M:Swebui.Controls.MarginConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="context"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.MarginConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="value"/> 文档]

attributes
类型：SystemAttribute

[缺少 "M:Swebui.Controls.MarginConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="attributes"/> 文档]

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.Controls.MarginConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarginConverter.GetPropertiesSupported 方法

MarginConverterGetPropertiesSupported 方法

[缺少 "M:Swebui.Controls.MarginConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.MarginConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.MarginConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

MarginConverter 类


MarqueeLabel 类

跑马灯效果文本
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsSwebNativeTextControl
Swebui.ControlsMarqueeLabel

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MarqueeLabel : SwebNativeTextControl
Public Class MarqueeLabel
    Inherits SwebNativeTextControl

MarqueeLabel 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MarqueeLabel | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Bold | 获取或设置文本粗体 (重写 SwebNativeTextControlBold.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebNativeTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebNativeTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebNativeTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (重写 SwebNativeTextControlItalic.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | ScrollDuration | 获取与设置文字轮播一页所消耗的时间
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取与设置显示的文字(若想添加组显示，文字中间添加空格) (重写 SwebNativeTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


MarqueeLabel 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MarqueeLabel()
Public Sub New
参见

引用

MarqueeLabel 类


MarqueeLabel 属性

MarqueeLabel 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Bold | 获取或设置文本粗体 (重写 SwebNativeTextControlBold.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebNativeTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebNativeTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebNativeTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (重写 SwebNativeTextControlItalic.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | ScrollDuration | 获取与设置文字轮播一页所消耗的时间
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取与设置显示的文字(若想添加组显示，文字中间添加空格) (重写 SwebNativeTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

MarqueeLabel 类


MarqueeLabel.Bold 属性

MarqueeLabelBold 属性

获取或设置文本粗体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override bool Bold { get; set; }
Public Overrides Property Bold As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

MarqueeLabel 类


MarqueeLabel.Border 属性

MarqueeLabelBorder 属性

[缺少 "P:Swebui.Controls.MarqueeLabel.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

MarqueeLabel 类


MarqueeLabel.BorderColor 属性

MarqueeLabelBorderColor 属性

[缺少 "P:Swebui.Controls.MarqueeLabel.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MarqueeLabel 类


MarqueeLabel.BorderRadius 属性

MarqueeLabelBorderRadius 属性

[缺少 "P:Swebui.Controls.MarqueeLabel.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MarqueeLabel 类


MarqueeLabel.BorderStyle 属性

MarqueeLabelBorderStyle 属性

[缺少 "P:Swebui.Controls.MarqueeLabel.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

MarqueeLabel 类


MarqueeLabel.FontFamily 属性

MarqueeLabelFontFamily 属性

获取和设置控件字体。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string FontFamily { get; set; }
Public Property FontFamily As String
    Get
    Set

属性值

类型：String
参见

引用

MarqueeLabel 类


MarqueeLabel.Italic 属性

MarqueeLabelItalic 属性

获取或设置文本斜体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override bool Italic { get; set; }
Public Overrides Property Italic As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

MarqueeLabel 类


MarqueeLabel.ScrollDuration 属性

MarqueeLabelScrollDuration 属性

获取与设置文字轮播一页所消耗的时间

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int ScrollDuration { get; set; }
Public Property ScrollDuration As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MarqueeLabel 类


MarqueeLabel.Text 属性

MarqueeLabelText 属性

获取与设置显示的文字(若想添加组显示，文字中间添加空格)

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

MarqueeLabel 类


MarqueeLabel 方法

MarqueeLabel 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

MarqueeLabel 类


MarqueeLabel 事件

MarqueeLabel 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

MarqueeLabel 类


MediaState 枚举

视频状态

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum MediaState
Public Enumeration MediaState
成员
成员名称 | 值 | 说明
Pause | 0 | 暂停
Play | 1 | 播放
End | 2 | 结束
Error | 3 | 错误
Replay | 4 | 重播
Time | 5 | 时间点
参见

引用

Swebui.Controls 命名空间


MediaView 类

多媒体控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsMediaView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MediaView : SwebNativeControl, ISwebEventControl
Public Class MediaView
    Inherits SwebNativeControl
    Implements ISwebEventControl

MediaView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MediaView | 初始化MediaView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动播放。
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Repeat | 获取和设置一个值，该值指示是否循环播放。
公共属性 | ResourceDownload | 获取和设置一个值，该值指示是否下载视频后播放。
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Url | 获取和设置媒体源
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Pause | 视频是否暂停
公共方法 | Refresh | 重新加载资源
公共方法 | Seek | 视频跳转至指定时间
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | StateChanged | 视频状态改变后发生。
Top
参见

引用

Swebui.Controls 命名空间


MediaView 构造函数

初始化MediaView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MediaView()
Public Sub New
参见

引用

MediaView 类


MediaView 属性

MediaView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动播放。
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Repeat | 获取和设置一个值，该值指示是否循环播放。
公共属性 | ResourceDownload | 获取和设置一个值，该值指示是否下载视频后播放。
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Url | 获取和设置媒体源
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

MediaView 类


MediaView.AutoPlay 属性

MediaViewAutoPlay 属性

获取和设置一个值，该值指示是否自动播放。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool AutoPlay { get; set; }
Public Property AutoPlay As Boolean
    Get
    Set

属性值

类型：Boolean
设置为 true 自动播放; 否则, false.
参见

引用

MediaView 类


MediaView.BackColor 属性

MediaViewBackColor 属性

[缺少 "P:Swebui.Controls.MediaView.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MediaView 类


MediaView.Border 属性

MediaViewBorder 属性

[缺少 "P:Swebui.Controls.MediaView.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

MediaView 类


MediaView.BorderColor 属性

MediaViewBorderColor 属性

[缺少 "P:Swebui.Controls.MediaView.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MediaView 类


MediaView.BorderRadius 属性

MediaViewBorderRadius 属性

[缺少 "P:Swebui.Controls.MediaView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MediaView 类


MediaView.BorderStyle 属性

MediaViewBorderStyle 属性

[缺少 "P:Swebui.Controls.MediaView.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

MediaView 类


MediaView.Padding 属性

MediaViewPadding 属性

[缺少 "P:Swebui.Controls.MediaView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

MediaView 类


MediaView.Repeat 属性

MediaViewRepeat 属性

获取和设置一个值，该值指示是否循环播放。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Repeat { get; set; }
Public Property Repeat As Boolean
    Get
    Set

属性值

类型：Boolean
设置为 true 循环播放; 否则, false.
参见

引用

MediaView 类


MediaView.ResourceDownload 属性

MediaViewResourceDownload 属性

获取和设置一个值，该值指示是否下载视频后播放。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ResourceDownload { get; set; }
Public Property ResourceDownload As Boolean
    Get
    Set

属性值

类型：Boolean
设置为 true 下载后播放; 否则, false.
参见

引用

MediaView 类


MediaView.Url 属性

MediaViewUrl 属性

获取和设置媒体源

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Url { get; set; }
Public Property Url As String
    Get
    Set

返回值

类型：String
参见

引用

MediaView 类


MediaView 方法

MediaView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | Pause | 视频是否暂停
公共方法 | Refresh | 重新加载资源
公共方法 | Seek | 视频跳转至指定时间
Top
参见

引用

MediaView 类


MediaView.Pause 方法

MediaViewPause 方法

视频是否暂停

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Pause(
    bool ispause
)
Public Sub Pause (
    ispause As Boolean
)

参数

ispause
类型：SystemBoolean
true为暂停视频,false为播放视频
参见

引用

MediaView 类


MediaView.Refresh 方法

MediaViewRefresh 方法

重新加载资源

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh
参见

引用

MediaView 类


MediaView.Seek 方法

MediaViewSeek 方法

视频跳转至指定时间

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Seek(
    int seconds
)
Public Sub Seek (
    seconds As Integer
)

参数

seconds
类型：SystemInt32
单位为s
参见

引用

MediaView 类


MediaView 事件

MediaView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | StateChanged | 视频状态改变后发生。
Top
参见

引用

MediaView 类


MediaView.StateChanged 事件

MediaViewStateChanged 事件

视频状态改变后发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event MediaViewStateChangedEventHandler StateChanged
Public Event StateChanged As MediaViewStateChangedEventHandler

值

类型：Swebui.ControlsMediaViewStateChangedEventHandler
参见

引用

MediaView 类


MediaViewStateChangedEventArgs 类

为StateChanged提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsMediaViewStateChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MediaViewStateChangedEventArgs : EventArgs
Public Class MediaViewStateChangedEventArgs
    Inherits EventArgs

MediaViewStateChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MediaViewStateChangedEventArgs(MediaState) | 获取一个MediaViewStateChangedEventArgs 实例
公共方法 | MediaViewStateChangedEventArgs(MediaState, Int32) | 获取一个MediaViewStateChangedEventArgs 实例
Top
属性
 | 名称 | 说明
公共属性 | State | 获取返回的状态。
公共属性 | Time | 获取视频播放的时间点
Top
参见

引用

Swebui.Controls 命名空间


MediaViewStateChangedEventArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | MediaViewStateChangedEventArgs(MediaState) | 获取一个MediaViewStateChangedEventArgs 实例
公共方法 | MediaViewStateChangedEventArgs(MediaState, Int32) | 获取一个MediaViewStateChangedEventArgs 实例
Top
参见

引用

MediaViewStateChangedEventArgs 类


MediaViewStateChangedEventArgs 构造函数 (MediaState)

获取一个MediaViewStateChangedEventArgs 实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MediaViewStateChangedEventArgs(
    MediaState state
)
Public Sub New (
    state As MediaState
)

参数

state
类型：Swebui.ControlsMediaState
状态
参见

引用

MediaViewStateChangedEventArgs 类
MediaViewStateChangedEventArgs 重载


MediaViewStateChangedEventArgs 构造函数 (MediaState, Int32)

获取一个MediaViewStateChangedEventArgs 实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MediaViewStateChangedEventArgs(
    MediaState state,
    int time
)
Public Sub New (
    state As MediaState,
    time As Integer
)

参数

state
类型：Swebui.ControlsMediaState
状态
time
类型：SystemInt32
视频播放的时间点
参见

引用

MediaViewStateChangedEventArgs 类
MediaViewStateChangedEventArgs 重载


MediaViewStateChangedEventArgs 属性

MediaViewStateChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | State | 获取返回的状态。
公共属性 | Time | 获取视频播放的时间点
Top
参见

引用

MediaViewStateChangedEventArgs 类


MediaViewStateChangedEventArgs.State 属性

MediaViewStateChangedEventArgsState 属性

获取返回的状态。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MediaState State { get; }
Public ReadOnly Property State As MediaState
    Get

属性值

类型：MediaState
参见

引用

MediaViewStateChangedEventArgs 类


MediaViewStateChangedEventArgs.Time 属性

MediaViewStateChangedEventArgsTime 属性

获取视频播放的时间点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int Time { get; }
Public ReadOnly Property Time As Integer
    Get

属性值

类型：Int32
参见

引用

MediaViewStateChangedEventArgs 类


MediaViewStateChangedEventHandler 委托

一个委托，它表示状态改变后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void MediaViewStateChangedEventHandler(
    Object sender,
    MediaViewStateChangedEventArgs e
)
Public Delegate Sub MediaViewStateChangedEventHandler (
    sender As Object,
    e As MediaViewStateChangedEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsMediaViewStateChangedEventArgs
包含事件数据的 MediaViewStateChangedEventArgs
参见

引用

Swebui.Controls 命名空间


MenuItem 类

[缺少 "T:Swebui.Controls.MenuItem" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsMenuItem

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MenuItem : SwebViewCollectionItem, ISwebViewCollectionOwner
Public Class MenuItem
    Inherits SwebViewCollectionItem
    Implements ISwebViewCollectionOwner

MenuItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MenuItem | 初始化 MenuItem 类的一个新实例
公共方法 | MenuItem(String, String) | 初始化 MenuItem 类的一个新实例
公共方法 | MenuItem(String, String, String) | 初始化 MenuItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Icon |
公共属性 | Id | 获取和设置菜单元素编号
公共属性 | Items |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
参见

引用

Swebui.Controls 命名空间


MenuItem 构造函数

重载列表
 | 名称 | 说明
公共方法 | MenuItem | 初始化 MenuItem 类的一个新实例
公共方法 | MenuItem(String, String) | 初始化 MenuItem 类的一个新实例
公共方法 | MenuItem(String, String, String) | 初始化 MenuItem 类的一个新实例
Top
参见

引用

MenuItem 类


MenuItem 构造函数

初始化 MenuItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem()
Public Sub New
参见

引用

MenuItem 类
MenuItem 重载


MenuItem 构造函数 (String, String)

初始化 MenuItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem(
    string id,
    string text
)
Public Sub New (
    id As String,
    text As String
)

参数

id
类型：SystemString

[缺少 "M:Swebui.Controls.MenuItem.#ctor(System.String,System.String)" 的 <param name="id"/> 文档]

text
类型：SystemString

[缺少 "M:Swebui.Controls.MenuItem.#ctor(System.String,System.String)" 的 <param name="text"/> 文档]

参见

引用

MenuItem 类
MenuItem 重载


MenuItem 构造函数 (String, String, String)

初始化 MenuItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem(
    string id,
    string text,
    string icon
)
Public Sub New (
    id As String,
    text As String,
    icon As String
)

参数

id
类型：SystemString

[缺少 "M:Swebui.Controls.MenuItem.#ctor(System.String,System.String,System.String)" 的 <param name="id"/> 文档]

text
类型：SystemString

[缺少 "M:Swebui.Controls.MenuItem.#ctor(System.String,System.String,System.String)" 的 <param name="text"/> 文档]

icon
类型：SystemString

[缺少 "M:Swebui.Controls.MenuItem.#ctor(System.String,System.String,System.String)" 的 <param name="icon"/> 文档]

参见

引用

MenuItem 类
MenuItem 重载


MenuItem 属性

MenuItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Icon |
公共属性 | Id | 获取和设置菜单元素编号
公共属性 | Items |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
参见

引用

MenuItem 类


MenuItem.Icon 属性

MenuItemIcon 属性

[缺少 "P:Swebui.Controls.MenuItem.Icon" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Icon { get; set; }
Public Property Icon As String
    Get
    Set

属性值

类型：String
参见

引用

MenuItem 类


MenuItem.Id 属性

MenuItemId 属性

获取和设置菜单元素编号

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Id { get; set; }
Public Property Id As String
    Get
    Set

属性值

类型：String
参见

引用

MenuItem 类


MenuItem.Items 属性

MenuItemItems 属性

[缺少 "P:Swebui.Controls.MenuItem.Items" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItemCollection Items { get; }
Public ReadOnly Property Items As MenuItemCollection
    Get

属性值

类型：MenuItemCollection
参见

引用

MenuItem 类


MenuItem.Text 属性

MenuItemText 属性

[缺少 "P:Swebui.Controls.MenuItem.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

MenuItem 类


MenuItemCollection 类

[缺少 "T:Swebui.Controls.MenuItemCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase MenuItem
Swebui.ControlsMenuItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MenuItemCollection : SwebViewCollectionBase<MenuItem>
Public Class MenuItemCollection
    Inherits SwebViewCollectionBase(Of MenuItem)

MenuItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


MenuItemCollection 属性

MenuItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

MenuItemCollection 类


MenuItemCollection 方法

MenuItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

MenuItemCollection 类


MenuView 类

菜单控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsMenuView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public sealed class MenuView : SwebControl,
    ISwebRenderControl, ISwebEventControl, ISwebViewCollectionOwner
Public NotInheritable Class MenuView
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl, ISwebViewCollectionOwner

MenuView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MenuView | 初始化MenuView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 设置和获取一级菜单文字颜色
公共属性 | DefaultIcon |
公共属性 | DefaultOpenItem | 设置展开父项
公共属性 | DefaultSelectedItem | 设置选中项
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Fold | 设置和获取是否只展开当前父级菜单
公共属性 | FontSize | 设置和获取MenuView 字体大小
公共属性 | FontWeight | 设置和获取MenuView 父级文字粗细
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Items | 获取菜单元素集合。
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectBackgroundColor | 设置和获取一级菜单选中背景色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SubBackgroundColor | 设置和获取二级及以下菜单背景颜色
公共属性 | SubColor | 设置和获取二级及以下菜单文字颜色
公共属性 | SubFontWeight | 设置和获取MenuView 父级文字粗细
公共属性 | SubSelectBackgroundColor | 设置和获取二级及以下菜单选中背景颜色
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | MenuItemClick |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


MenuView 构造函数

初始化MenuView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuView()
Public Sub New
参见

引用

MenuView 类


MenuView 属性

MenuView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 设置和获取一级菜单文字颜色
公共属性 | DefaultIcon |
公共属性 | DefaultOpenItem | 设置展开父项
公共属性 | DefaultSelectedItem | 设置选中项
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Fold | 设置和获取是否只展开当前父级菜单
公共属性 | FontSize | 设置和获取MenuView 字体大小
公共属性 | FontWeight | 设置和获取MenuView 父级文字粗细
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Items | 获取菜单元素集合。
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelectBackgroundColor | 设置和获取一级菜单选中背景色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SubBackgroundColor | 设置和获取二级及以下菜单背景颜色
公共属性 | SubColor | 设置和获取二级及以下菜单文字颜色
公共属性 | SubFontWeight | 设置和获取MenuView 父级文字粗细
公共属性 | SubSelectBackgroundColor | 设置和获取二级及以下菜单选中背景颜色
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

MenuView 类


MenuView.Color 属性

MenuViewColor 属性

设置和获取一级菜单文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

属性值

类型：Color
参见

引用

MenuView 类


MenuView.DefaultIcon 属性

MenuViewDefaultIcon 属性

[缺少 "P:Swebui.Controls.MenuView.DefaultIcon" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string DefaultIcon { get; set; }
Public Property DefaultIcon As String
    Get
    Set

属性值

类型：String
参见

引用

MenuView 类


MenuView.DefaultOpenItem 属性

MenuViewDefaultOpenItem 属性

设置展开父项

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem DefaultOpenItem { get; set; }
Public Property DefaultOpenItem As MenuItem
    Get
    Set

属性值

类型：MenuItem
参见

引用

MenuView 类


MenuView.DefaultSelectedItem 属性

MenuViewDefaultSelectedItem 属性

设置选中项

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem DefaultSelectedItem { get; set; }
Public Property DefaultSelectedItem As MenuItem
    Get
    Set

属性值

类型：MenuItem
参见

引用

MenuView 类


MenuView.Fold 属性

MenuViewFold 属性

设置和获取是否只展开当前父级菜单

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Fold { get; set; }
Public Property Fold As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

MenuView 类


MenuView.FontSize 属性

MenuViewFontSize 属性

设置和获取MenuView 字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int FontSize { get; set; }
Public Property FontSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

MenuView 类


MenuView.FontWeight 属性

MenuViewFontWeight 属性

设置和获取MenuView 父级文字粗细

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set

属性值

类型：FontWeight
参见

引用

MenuView 类


MenuView.Items 属性

MenuViewItems 属性

获取菜单元素集合。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItemCollection Items { get; }
Public ReadOnly Property Items As MenuItemCollection
    Get

属性值

类型：MenuItemCollection
参见

引用

MenuView 类


MenuView.SelectBackgroundColor 属性

MenuViewSelectBackgroundColor 属性

设置和获取一级菜单选中背景色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectBackgroundColor { get; set; }
Public Property SelectBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MenuView 类


MenuView.SubBackgroundColor 属性

MenuViewSubBackgroundColor 属性

设置和获取二级及以下菜单背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SubBackgroundColor { get; set; }
Public Property SubBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MenuView 类


MenuView.SubColor 属性

MenuViewSubColor 属性

设置和获取二级及以下菜单文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SubColor { get; set; }
Public Property SubColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MenuView 类


MenuView.SubFontWeight 属性

MenuViewSubFontWeight 属性

设置和获取MenuView 父级文字粗细

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public FontWeight SubFontWeight { get; set; }
Public Property SubFontWeight As FontWeight
    Get
    Set

属性值

类型：FontWeight
参见

引用

MenuView 类


MenuView.SubSelectBackgroundColor 属性

MenuViewSubSelectBackgroundColor 属性

设置和获取二级及以下菜单选中背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SubSelectBackgroundColor { get; set; }
Public Property SubSelectBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

MenuView 类


MenuView 方法

MenuView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

MenuView 类


MenuView 事件

MenuView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | MenuItemClick |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

MenuView 类


MenuView.MenuItemClick 事件

MenuViewMenuItemClick 事件

[缺少 "E:Swebui.Controls.MenuView.MenuItemClick" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event MenuViewItemClickEventHandler MenuItemClick
Public Event MenuItemClick As MenuViewItemClickEventHandler

值

类型：Swebui.ControlsMenuViewItemClickEventHandler
参见

引用

MenuView 类


MenuViewItemClickEventArgs 类

[缺少 "T:Swebui.Controls.MenuViewItemClickEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsMenuViewItemClickEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class MenuViewItemClickEventArgs : EventArgs
Public Class MenuViewItemClickEventArgs
    Inherits EventArgs

MenuViewItemClickEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MenuViewItemClickEventArgs | 初始化 MenuViewItemClickEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item |
Top
参见

引用

Swebui.Controls 命名空间


MenuViewItemClickEventArgs 构造函数

初始化 MenuViewItemClickEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuViewItemClickEventArgs()
Public Sub New
参见

引用

MenuViewItemClickEventArgs 类


MenuViewItemClickEventArgs 属性

MenuViewItemClickEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item |
Top
参见

引用

MenuViewItemClickEventArgs 类


MenuViewItemClickEventArgs.Item 属性

MenuViewItemClickEventArgsItem 属性

[缺少 "P:Swebui.Controls.MenuViewItemClickEventArgs.Item" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public MenuItem Item { get; }
Public ReadOnly Property Item As MenuItem
    Get

属性值

类型：MenuItem
参见

引用

MenuViewItemClickEventArgs 类


MenuViewItemClickEventHandler 委托

[缺少 "T:Swebui.Controls.MenuViewItemClickEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void MenuViewItemClickEventHandler(
    Object sender,
    MenuViewItemClickEventArgs e
)
Public Delegate Sub MenuViewItemClickEventHandler (
    sender As Object,
    e As MenuViewItemClickEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsMenuViewItemClickEventArgs
参见

引用

Swebui.Controls 命名空间


MessageBoxButtons 枚举

指定若干常数，用以定义 MessageBox 上将显示哪些按钮

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum MessageBoxButtons
Public Enumeration MessageBoxButtons
成员
成员名称 | 值 | 说明
AbortRetryIgnore | 2 | 该消息框包含“中止”、“重试”和“忽略”按钮。
OK | 0 | 该消息框包含“确定”按钮。
OKCancel | 1 | 该消息框包含“确定”和“取消”按钮。
RetryCancel | 5 | 该消息框包含“重试”和“取消”按钮。
YesNo | 4 | 该消息框包含“是”和“否”按钮。
YesNoCancel | 3 | 该消息框包含“是”、“否”和“取消”按钮。
备注
MessageBox 类使用此枚举。
参见

引用

Swebui.Controls 命名空间


MessageBoxHandler 委托

一个委托，它表示在提示框点击时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void MessageBoxHandler(
    Object sender,
    MessageBoxHandlerArgs args
)
Public Delegate Sub MessageBoxHandler (
    sender As Object,
    args As MessageBoxHandlerArgs
)

参数

sender
类型：SystemObject
事件源
args
类型：Swebui.ControlsMessageBoxHandlerArgs
包含事件数据的 MessageBoxHandlerArgs
备注
参见

引用

Swebui.Controls 命名空间


MessageBoxHandlerArgs 类

为MessageBoxHandler提供数据
继承层次
SystemObject
Swebui.ControlsSwebHandlerArgs
Swebui.ControlsMessageBoxHandlerArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class MessageBoxHandlerArgs : SwebHandlerArgs
Public Class MessageBoxHandlerArgs
    Inherits SwebHandlerArgs

MessageBoxHandlerArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MessageBoxHandlerArgs | 初始化 MessageBoxHandlerArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Args | 获取委托或事件中的可选参数 (继承自 SwebHandlerArgs。)
公共属性 | Index |
公共属性 | Result | 获取消息框按钮点击结果
Top
备注
参见

引用

Swebui.Controls 命名空间


MessageBoxHandlerArgs 构造函数

初始化 MessageBoxHandlerArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public MessageBoxHandlerArgs()
Public Sub New
参见

引用

MessageBoxHandlerArgs 类


MessageBoxHandlerArgs 属性

MessageBoxHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Args | 获取委托或事件中的可选参数 (继承自 SwebHandlerArgs。)
公共属性 | Index |
公共属性 | Result | 获取消息框按钮点击结果
Top
参见

引用

MessageBoxHandlerArgs 类


MessageBoxHandlerArgs.Index 属性

MessageBoxHandlerArgsIndex 属性

[缺少 "P:Swebui.Controls.MessageBoxHandlerArgs.Index" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

属性值

类型：Int32
参见

引用

MessageBoxHandlerArgs 类


MessageBoxHandlerArgs.Result 属性

MessageBoxHandlerArgsResult 属性

获取消息框按钮点击结果

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ShowResult Result { get; }
Public ReadOnly Property Result As ShowResult
    Get

属性值

类型：ShowResult

返回值

类型：ShowResult
备注
参见

引用

MessageBoxHandlerArgs 类


MessageBoxStatic 类

显示可包含文本、按钮（通知并指示用户）的消息框。
继承层次
SystemObject
Swebui.ControlsMessageBoxStatic

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class MessageBoxStatic
Public Class MessageBoxStatic

MessageBoxStatic 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MessageBoxStatic | 初始化 MessageBoxStatic 类的一个新实例
Top
方法
名称 | 说明
GetMessageBoxButtonsArray |
Show(String, String) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、按钮的消息框。
Top
备注
无法创建 MessageBox 类的新实例。要显示消息框，请调用静态（在 Visual Basic 中为 Shared）方法 MessageBox.Show。显示在消息框中的标题、消息、按钮由您传递给该方法的参数确定。
参见

引用

Swebui.Controls 命名空间


MessageBoxStatic 构造函数

初始化 MessageBoxStatic 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public MessageBoxStatic()
Public Sub New
参见

引用

MessageBoxStatic 类


MessageBoxStatic 方法

MessageBoxStatic 类型公开以下成员。

方法
名称 | 说明
GetMessageBoxButtonsArray |
Show(String, String) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、按钮的消息框。
Top
参见

引用

MessageBoxStatic 类


MessageBoxStatic.GetMessageBoxButtonsArray 方法

MessageBoxStaticGetMessageBoxButtonsArray 方法

[缺少 "M:Swebui.Controls.MessageBoxStatic.GetMessageBoxButtonsArray(Swebui.Controls.MessageBoxButtons)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string[] GetMessageBoxButtonsArray(
    MessageBoxButtons buttons
)
Public Shared Function GetMessageBoxButtonsArray (
    buttons As MessageBoxButtons
) As String()

参数

buttons
类型：Swebui.ControlsMessageBoxButtons

[缺少 "M:Swebui.Controls.MessageBoxStatic.GetMessageBoxButtonsArray(Swebui.Controls.MessageBoxButtons)" 的 <param name="buttons"/> 文档]

返回值

类型：String

[缺少 "M:Swebui.Controls.MessageBoxStatic.GetMessageBoxButtonsArray(Swebui.Controls.MessageBoxButtons)" 的 <returns> 文档]

参见

引用

MessageBoxStatic 类


MessageBoxStatic.Show 方法

MessageBoxStaticShow 方法

重载列表
名称 | 说明
Show(String, String) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、按钮的消息框。
Top
参见

引用

MessageBoxStatic 类


MessageBoxStatic.Show 方法 (String, String)

MessageBoxStaticShow 方法 (String, String)

显示具有指定文本的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void Show(
    string sessionID,
    string text
)
Public Shared Sub Show (
    sessionID As String,
    text As String
)

参数

sessionID
类型：SystemString

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String)" 的 <param name="sessionID"/> 文档]

text
类型：SystemString
要在消息框中显示的文本。
备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

MessageBoxStatic 类
Show 重载


MessageBoxStatic.Show 方法 (String, String, MessageBoxHandler, Object)

MessageBoxStaticShow 方法 (String, String, MessageBoxHandler, Object)

显示具有指定文本的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void Show(
    string sessionID,
    string text,
    MessageBoxHandler handler,
    Object args = null
)
Public Shared Sub Show (
    sessionID As String,
    text As String,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

sessionID
类型：SystemString

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="sessionID"/> 文档]

text
类型：SystemString
要在消息框中显示的文本。
handler
类型：Swebui.ControlsMessageBoxHandler

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="handler"/> 文档]

args (Optional)
类型：SystemObject

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="args"/> 文档]

备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

MessageBoxStatic 类
Show 重载


MessageBoxStatic.Show 方法 (String, String, MessageBoxButtons, MessageBoxHandler, Object)

MessageBoxStaticShow 方法 (String, String, MessageBoxButtons, MessageBoxHandler, Object)

显示具有指定文本、按钮的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void Show(
    string sessionID,
    string text,
    MessageBoxButtons buttons,
    MessageBoxHandler handler,
    Object args = null
)
Public Shared Sub Show (
    sessionID As String,
    text As String,
    buttons As MessageBoxButtons,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

sessionID
类型：SystemString

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxButtons,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="sessionID"/> 文档]

text
类型：SystemString
要在消息框中显示的文本。
buttons
类型：Swebui.ControlsMessageBoxButtons
可指定在消息框中显示哪些按钮。
handler
类型：Swebui.ControlsMessageBoxHandler

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxButtons,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="handler"/> 文档]

args (Optional)
类型：SystemObject

[缺少 "M:Swebui.Controls.MessageBoxStatic.Show(System.String,System.String,Swebui.Controls.MessageBoxButtons,Swebui.Controls.MessageBoxHandler,System.Object)" 的 <param name="args"/> 文档]

备注
在消息框中最多可以有三个按钮。
参见

引用

MessageBoxStatic 类
Show 重载


OnPaintDesignArgs 类

为OnPaintDesign提供方法
继承层次
SystemObject
Swebui.ControlsOnPaintDesignArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class OnPaintDesignArgs
Public Class OnPaintDesignArgs

OnPaintDesignArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OnPaintDesignArgs(Graphics, RectangleF) | 初始化 OnPaintDesignArgs 类的一个新实例
公共方法 | OnPaintDesignArgs(Graphics, RectangleF, String) | 初始化 OnPaintDesignArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Bounds | 获取控件绘制区域
公共属性 | Graphics | 获取画笔
公共属性 | OutputPath | 获取输入路径
Top
方法
 | 名称 | 说明
公共方法 | CreatePath |
公共方法 | DrawImage |
Top
参见

引用

Swebui.Controls 命名空间


OnPaintDesignArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | OnPaintDesignArgs(Graphics, RectangleF) | 初始化 OnPaintDesignArgs 类的一个新实例
公共方法 | OnPaintDesignArgs(Graphics, RectangleF, String) | 初始化 OnPaintDesignArgs 类的一个新实例
Top
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs 构造函数 (Graphics, RectangleF)

初始化 OnPaintDesignArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public OnPaintDesignArgs(
    Graphics graphic,
    RectangleF bound
)
Public Sub New (
    graphic As Graphics,
    bound As RectangleF
)

参数

graphic
类型：System.DrawingGraphics

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.#ctor(System.Drawing.Graphics,System.Drawing.RectangleF)" 的 <param name="graphic"/> 文档]

bound
类型：System.DrawingRectangleF

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.#ctor(System.Drawing.Graphics,System.Drawing.RectangleF)" 的 <param name="bound"/> 文档]

参见

引用

OnPaintDesignArgs 类
OnPaintDesignArgs 重载


OnPaintDesignArgs 构造函数 (Graphics, RectangleF, String)

初始化 OnPaintDesignArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public OnPaintDesignArgs(
    Graphics graphics,
    RectangleF bound,
    string outputPath
)
Public Sub New (
    graphics As Graphics,
    bound As RectangleF,
    outputPath As String
)

参数

graphics
类型：System.DrawingGraphics

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.#ctor(System.Drawing.Graphics,System.Drawing.RectangleF,System.String)" 的 <param name="graphics"/> 文档]

bound
类型：System.DrawingRectangleF

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.#ctor(System.Drawing.Graphics,System.Drawing.RectangleF,System.String)" 的 <param name="bound"/> 文档]

outputPath
类型：SystemString

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.#ctor(System.Drawing.Graphics,System.Drawing.RectangleF,System.String)" 的 <param name="outputPath"/> 文档]

参见

引用

OnPaintDesignArgs 类
OnPaintDesignArgs 重载


OnPaintDesignArgs 属性

OnPaintDesignArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Bounds | 获取控件绘制区域
公共属性 | Graphics | 获取画笔
公共属性 | OutputPath | 获取输入路径
Top
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs.Bounds 属性

OnPaintDesignArgsBounds 属性

获取控件绘制区域

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public RectangleF Bounds { get; }
Public ReadOnly Property Bounds As RectangleF
    Get

返回值

类型：RectangleF
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs.Graphics 属性

OnPaintDesignArgsGraphics 属性

获取画笔

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get

返回值

类型：Graphics
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs.OutputPath 属性

OnPaintDesignArgsOutputPath 属性

获取输入路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string OutputPath { get; }
Public ReadOnly Property OutputPath As String
    Get

返回值

类型：String
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs 方法

OnPaintDesignArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CreatePath |
公共方法 | DrawImage |
Top
参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs.CreatePath 方法

OnPaintDesignArgsCreatePath 方法

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.CreatePath(System.Drawing.RectangleF,System.Single)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public GraphicsPath CreatePath(
    RectangleF rect,
    float rectRadius
)
Public Function CreatePath (
    rect As RectangleF,
    rectRadius As Single
) As GraphicsPath

参数

rect
类型：System.DrawingRectangleF

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.CreatePath(System.Drawing.RectangleF,System.Single)" 的 <param name="rect"/> 文档]

rectRadius
类型：SystemSingle

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.CreatePath(System.Drawing.RectangleF,System.Single)" 的 <param name="rectRadius"/> 文档]

返回值

类型：GraphicsPath

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.CreatePath(System.Drawing.RectangleF,System.Single)" 的 <returns> 文档]

参见

引用

OnPaintDesignArgs 类


OnPaintDesignArgs.DrawImage 方法

OnPaintDesignArgsDrawImage 方法

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void DrawImage(
    Object sender,
    RectangleF rect,
    string imageid,
    string imagepath,
    ImageSizeMode sizemode = ImageSizeMode.Zoom
)
Public Sub DrawImage (
    sender As Object,
    rect As RectangleF,
    imageid As String,
    imagepath As String,
    Optional sizemode As ImageSizeMode = ImageSizeMode.Zoom
)

参数

sender
类型：SystemObject

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <param name="sender"/> 文档]

rect
类型：System.DrawingRectangleF

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <param name="rect"/> 文档]

imageid
类型：SystemString

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <param name="imageid"/> 文档]

imagepath
类型：SystemString

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <param name="imagepath"/> 文档]

sizemode (Optional)
类型：Swebui.ControlsImageSizeMode

[缺少 "M:Swebui.Controls.OnPaintDesignArgs.DrawImage(System.Object,System.Drawing.RectangleF,System.String,System.String,Swebui.Controls.ImageSizeMode)" 的 <param name="sizemode"/> 文档]

参见

引用

OnPaintDesignArgs 类


OrientationAlignment 枚举

[缺少 "T:Swebui.Controls.OrientationAlignment" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum OrientationAlignment
Public Enumeration OrientationAlignment
成员
成员名称 | 值 | 说明
Horizontal | 0 | 水平
Vertical | 1 | 垂直
参见

引用

Swebui.Controls 命名空间


Padding 结构

控件内边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[SerializableAttribute]
[TypeConverterAttribute(typeof(PaddingConverter))]
public struct Padding
<SerializableAttribute>
<TypeConverterAttribute(GetType(PaddingConverter))>
Public Structure Padding

Padding 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Padding(Single) | 构造函数
公共方法 | Padding(Single, Single, Single, Single) | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
字段
名称 | 说明
Empty |
Top
备注
参见

引用

Swebui.Controls 命名空间


Padding 构造函数

重载列表
 | 名称 | 说明
公共方法 | Padding(Single) | 构造函数
公共方法 | Padding(Single, Single, Single, Single) | 构造函数
Top
参见

引用

Padding 结构


Padding 构造函数 (Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Padding(
    float all
)
Public Sub New (
    all As Single
)

参数

all
类型：SystemSingle
所有边距
备注
参见

引用

Padding 结构
Padding 重载


Padding 构造函数 (Single, Single, Single, Single)

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Padding(
    float left,
    float top,
    float right,
    float bottom
)
Public Sub New (
    left As Single,
    top As Single,
    right As Single,
    bottom As Single
)

参数

left
类型：SystemSingle
左边距
top
类型：SystemSingle
上边距
right
类型：SystemSingle
右边距
bottom
类型：SystemSingle
下边距
备注
参见

引用

Padding 结构
Padding 重载


Padding 属性

Padding 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | All | 获取或设置所有边距
公共属性 | Bottom | 获取或设置下边距
公共属性 | Left | 获取或设置左边距
公共属性 | Right | 获取或设置右边距
公共属性 | Top | 获取或设置上边距
Top
参见

引用

Padding 结构


Padding.All 属性

PaddingAll 属性

获取或设置所有边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float All { get; set; }
Public Property All As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Padding 结构


Padding.Bottom 属性

PaddingBottom 属性

获取或设置下边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Bottom { get; set; }
Public Property Bottom As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Padding 结构


Padding.Left 属性

PaddingLeft 属性

获取或设置左边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Left { get; set; }
Public Property Left As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Padding 结构


Padding.Right 属性

PaddingRight 属性

获取或设置右边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Right { get; set; }
Public Property Right As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Padding 结构


Padding.Top 属性

PaddingTop 属性

获取或设置上边距

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Top { get; set; }
Public Property Top As Single
    Get
    Set

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

Padding 结构


Padding 方法

Padding 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
参见

引用

Padding 结构


Padding.ToString 方法

PaddingToString 方法

[缺少 "M:Swebui.Controls.Padding.ToString" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ToString()
Public Overrides Function ToString As String

返回值

类型：String

[缺少 "M:Swebui.Controls.Padding.ToString" 的 <returns> 文档]

参见

引用

Padding 结构


Padding 运算符

Padding 类型公开以下成员。

运算符
名称 | 说明
Equality | Implements the operator = operator.
Inequality | Implements the operator <> operator.
Top
参见

引用

Padding 结构


Padding.Equality 运算符

PaddingEquality 运算符

Implements the operator = operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator ==(
    Padding lhs,
    Padding rhs
)
Public Shared Operator = (
    lhs As Padding,
    rhs As Padding
) As Boolean

参数

lhs
类型：Swebui.ControlsPadding
The LHS.
rhs
类型：Swebui.ControlsPadding
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Padding 结构


Padding.Inequality 运算符

PaddingInequality 运算符

Implements the operator <> operator.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static bool operator !=(
    Padding lhs,
    Padding rhs
)
Public Shared Operator <> (
    lhs As Padding,
    rhs As Padding
) As Boolean

参数

lhs
类型：Swebui.ControlsPadding
The LHS.
rhs
类型：Swebui.ControlsPadding
The RHS.

返回值

类型：Boolean
The result of the operator.
参见

引用

Padding 结构


Padding 字段

Padding 类型公开以下成员。

字段
名称 | 说明
Empty |
Top
参见

引用

Padding 结构


Padding.Empty 字段

PaddingEmpty 字段

[缺少 "F:Swebui.Controls.Padding.Empty" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static readonly Padding Empty
Public Shared ReadOnly Empty As Padding

字段值

类型：Padding
参见

引用

Padding 结构


PaddingConverter 类

为 Padding 提供类型转换
继承层次
SystemObject
System.ComponentModelTypeConverter
Swebui.ControlsPaddingConverter

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PaddingConverter : TypeConverter
Public Class PaddingConverter
    Inherits TypeConverter

PaddingConverter 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PaddingConverter | 初始化 PaddingConverter 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
备注
参见

引用

Swebui.Controls 命名空间


PaddingConverter 构造函数

初始化 PaddingConverter 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PaddingConverter()
Public Sub New
参见

引用

PaddingConverter 类


PaddingConverter 方法

PaddingConverter 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
参见

引用

PaddingConverter 类


PaddingConverter.CanConvertFrom 方法

PaddingConverterCanConvertFrom 方法

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

sourceType
类型：SystemType

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="sourceType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.CanConvertTo 方法

PaddingConverterCanConvertTo 方法

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.PaddingConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.ConvertFrom 方法

PaddingConverterConvertFrom 方法

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.ConvertTo 方法

PaddingConverterConvertTo 方法

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="value"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.PaddingConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.CreateInstance 方法

PaddingConverterCreateInstance 方法

[缺少 "M:Swebui.Controls.PaddingConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Public Overrides Function CreateInstance (
    context As ITypeDescriptorContext,
    propertyValues As IDictionary
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="context"/> 文档]

propertyValues
类型：System.CollectionsIDictionary

[缺少 "M:Swebui.Controls.PaddingConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="propertyValues"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.PaddingConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.GetCreateInstanceSupported 方法

PaddingConverterGetCreateInstanceSupported 方法

[缺少 "M:Swebui.Controls.PaddingConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetCreateInstanceSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.PaddingConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.GetProperties 方法

PaddingConverterGetProperties 方法

[缺少 "M:Swebui.Controls.PaddingConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="context"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.PaddingConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="value"/> 文档]

attributes
类型：SystemAttribute

[缺少 "M:Swebui.Controls.PaddingConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="attributes"/> 文档]

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.Controls.PaddingConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PaddingConverter.GetPropertiesSupported 方法

PaddingConverterGetPropertiesSupported 方法

[缺少 "M:Swebui.Controls.PaddingConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.PaddingConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.PaddingConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

PaddingConverter 类


PageSizeLoadMode 枚举

分页数据加载模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PageSizeLoadMode
Public Enumeration PageSizeLoadMode
成员
成员名称 | 值 | 说明
Button | 0 | 底部使用Button来加载分页数据
Scroll | 1 | 使用向上滚动来加载新分页数据
ScrollNoBottom | 2 | 使用向上滚动来加载新分页数据，加载完成后不显示底部
参见

引用

Swebui.Controls 命名空间


PageView 类

页面控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsPageView

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PageView : SwebLayoutControl, ISwebDataBindControl,
    ISwebTemplateControl, ISwebViewCollectionOwner
Public Class PageView
    Inherits SwebLayoutControl
    Implements ISwebDataBindControl, ISwebTemplateControl, ISwebViewCollectionOwner

PageView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageView | 初始化 PageView 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动轮播页面。
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | (重写 SwebLayoutControlDirection.)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Interval | 获取或设置自动轮播间隔时间（以秒为单位）
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | IsLoop | 获取和设置一个值，该值指示是否循环轮播页面。
公共属性 | ItemAlign | (重写 SwebLayoutControlItemAlign.)
公共属性 | JustifyAlign | (重写 SwebLayoutControlJustifyAlign.)
公共属性 | Layout | (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Locked | 获取和设置一个值，该值指示是否锁定页面并且切换页面。
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageIndex | 获取当前页面索引。
公共属性 | Pages | 获取页面集合。
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowIndicator | 获取和设置一个值，该值指示是否显示界面的圆点。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置页面模板控件。
公共属性 | TemplateControlName | 获取和设置页面模板控件名称。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Vertical | 获取和设置一个值，该值指示页面是否垂直滚动。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | (重写 SwebLayoutControlWrap.)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DataBind | 数据绑定。
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewPage | 添加页面。
公共方法 | NewPage(Object) | 添加页面。
公共方法 | NewPage(Object, String, Object) | 添加页面。
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | UpdatePage | 更新页面。
Top
事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。
公共事件 | PageBind | 在页绑定后发生。
公共事件 | PageBinding | 在页绑定时发生。
公共事件 | PageIndexChanged | 在页面索引改变时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


PageView 构造函数

初始化 PageView 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageView()
Public Sub New
参见

引用

PageView 类


PageView 属性

PageView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | AutoPlay | 获取和设置一个值，该值指示是否自动轮播页面。
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取或设置数据源名称
公共属性 | DataSource | 获取或设置表格数据源
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | (重写 SwebLayoutControlDirection.)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Interval | 获取或设置自动轮播间隔时间（以秒为单位）
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | IsLoop | 获取和设置一个值，该值指示是否循环轮播页面。
公共属性 | ItemAlign | (重写 SwebLayoutControlItemAlign.)
公共属性 | JustifyAlign | (重写 SwebLayoutControlJustifyAlign.)
公共属性 | Layout | (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | Locked | 获取和设置一个值，该值指示是否锁定页面并且切换页面。
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageIndex | 获取当前页面索引。
公共属性 | Pages | 获取页面集合。
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowIndicator | 获取和设置一个值，该值指示是否显示界面的圆点。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置页面模板控件。
公共属性 | TemplateControlName | 获取和设置页面模板控件名称。
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Vertical | 获取和设置一个值，该值指示页面是否垂直滚动。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | (重写 SwebLayoutControlWrap.)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

PageView 类


PageView.AutoPlay 属性

PageViewAutoPlay 属性

获取和设置一个值，该值指示是否自动轮播页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool AutoPlay { get; set; }
Public Property AutoPlay As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

PageView 类


PageView.BindMode 属性

PageViewBindMode 属性

获取和设置绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DataBindMode BindMode { get; set; }
Public Property BindMode As DataBindMode
    Get
    Set

返回值

类型：DataBindMode

实现

ISwebDataBindControlBindMode
参见

引用

PageView 类


PageView.DataMember 属性

PageViewDataMember 属性

获取或设置数据源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string DataMember { get; set; }
Public Overridable Property DataMember As String
    Get
    Set

属性值

类型：String

返回值

类型：String

实现

ISwebDataBindControlDataMember
备注
参见

引用

PageView 类


PageView.DataSource 属性

PageViewDataSource 属性

获取或设置表格数据源

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object DataSource { get; set; }
Public Property DataSource As Object
    Get
    Set

属性值

类型：Object

返回值

类型：Object

实现

ISwebDataBindControlDataSource
备注
参见

引用

PageView 类


PageView.Direction 属性

PageViewDirection 属性

[缺少 "P:Swebui.Controls.PageView.Direction" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutDirection Direction { get; set; }
Public Overrides Property Direction As LayoutDirection
    Get
    Set

属性值

类型：LayoutDirection
参见

引用

PageView 类


PageView.Interval 属性

PageViewInterval 属性

获取或设置自动轮播间隔时间（以秒为单位）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set

属性值

类型：Int32
该值不能小于 1，默认值3

返回值

类型：Int32
备注
在Timer运行期间，修改此属性值，必须在Timer重新Start时才生效。 由于计时器组件由客户端触发，间隔时间并不能保证精度。误差时间不能保证。但是计时器组件能保证在网络不通畅的情况下的持续触发Tick事件。
参见

引用

PageView 类


PageView.IsLoop 属性

PageViewIsLoop 属性

获取和设置一个值，该值指示是否循环轮播页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsLoop { get; set; }
Public Property IsLoop As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

PageView 类


PageView.ItemAlign 属性

PageViewItemAlign 属性

[缺少 "P:Swebui.Controls.PageView.ItemAlign" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutItemAlign ItemAlign { get; set; }
Public Overrides Property ItemAlign As LayoutItemAlign
    Get
    Set

属性值

类型：LayoutItemAlign
参见

引用

PageView 类


PageView.JustifyAlign 属性

PageViewJustifyAlign 属性

[缺少 "P:Swebui.Controls.PageView.JustifyAlign" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutJustifyAlign JustifyAlign { get; set; }
Public Overrides Property JustifyAlign As LayoutJustifyAlign
    Get
    Set

属性值

类型：LayoutJustifyAlign
参见

引用

PageView 类


PageView.Layout 属性

PageViewLayout 属性

[缺少 "P:Swebui.Controls.PageView.Layout" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutPosition Layout { get; set; }
Public Overrides Property Layout As LayoutPosition
    Get
    Set

属性值

类型：LayoutPosition
参见

引用

PageView 类


PageView.Locked 属性

PageViewLocked 属性

获取和设置一个值，该值指示是否锁定页面并且切换页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

PageView 类


PageView.PageIndex 属性

PageViewPageIndex 属性

获取当前页面索引。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

PageView 类


PageView.Pages 属性

PageViewPages 属性

获取页面集合。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItemCollection Pages { get; }
Public ReadOnly Property Pages As PageViewItemCollection
    Get

返回值

类型：PageViewItemCollection
参见

引用

PageView 类


PageView.ShowIndicator 属性

PageViewShowIndicator 属性

获取和设置一个值，该值指示是否显示界面的圆点。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowIndicator { get; set; }
Public Property ShowIndicator As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

PageView 类


PageView.TemplateControl 属性

PageViewTemplateControl 属性

获取和设置页面模板控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl TemplateControl { get; set; }
Public Property TemplateControl As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl

实现

ISwebTemplateControlTemplateControl
参见

引用

PageView 类


PageView.TemplateControlName 属性

PageViewTemplateControlName 属性

获取和设置页面模板控件名称。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string TemplateControlName { get; set; }
Public Property TemplateControlName As String
    Get
    Set

返回值

类型：String
参见

引用

PageView 类


PageView.Vertical 属性

PageViewVertical 属性

获取和设置一个值，该值指示页面是否垂直滚动。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Vertical { get; set; }
Public Property Vertical As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

PageView 类


PageView.Wrap 属性

PageViewWrap 属性

[缺少 "P:Swebui.Controls.PageView.Wrap" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutWrap Wrap { get; set; }
Public Overrides Property Wrap As LayoutWrap
    Get
    Set

属性值

类型：LayoutWrap
参见

引用

PageView 类


PageView 方法

PageView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataBind | 数据绑定。
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewPage | 添加页面。
公共方法 | NewPage(Object) | 添加页面。
公共方法 | NewPage(Object, String, Object) | 添加页面。
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | UpdatePage | 更新页面。
Top
参见

引用

PageView 类


PageView.DataBind 方法

PageViewDataBind 方法

数据绑定。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void DataBind(
    params Object[] params
)
Public Sub DataBind (
    ParamArray params As Object()
)

参数

params
类型：SystemObject
模板页构建函数参数

实现

ISwebDataBindControlDataBind(Object)
参见

引用

PageView 类


PageView.NewPage 方法

PageViewNewPage 方法

重载列表
 | 名称 | 说明
公共方法 | NewPage | 添加页面。
公共方法 | NewPage(Object) | 添加页面。
公共方法 | NewPage(Object, String, Object) | 添加页面。
Top
参见

引用

PageView 类


PageView.NewPage 方法

PageViewNewPage 方法

添加页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItem NewPage()
Public Function NewPage As PageViewItem

返回值

类型：PageViewItem

[缺少 "M:Swebui.Controls.PageView.NewPage" 的 <returns> 文档]

参见

引用

PageView 类
NewPage 重载


PageView.NewPage 方法 (Object[])

PageViewNewPage 方法 (Object)

添加页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItem NewPage(
    params Object[] params
)
Public Function NewPage (
    ParamArray params As Object()
) As PageViewItem

参数

params
类型：SystemObject
模板页构建函数参数

返回值

类型：PageViewItem

[缺少 "M:Swebui.Controls.PageView.NewPage(System.Object[])" 的 <returns> 文档]

参见

引用

PageView 类
NewPage 重载


PageView.NewPage 方法 (Object, String, Object[])

PageViewNewPage 方法 (Object, String, Object)

添加页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItem[] NewPage(
    Object dataSource,
    string dataMember,
    params Object[] params
)
Public Function NewPage (
    dataSource As Object,
    dataMember As String,
    ParamArray params As Object()
) As PageViewItem()

参数

dataSource
类型：SystemObject
数据源
dataMember
类型：SystemString
数据源名称
params
类型：SystemObject
模板页构建函数参数

返回值

类型：PageViewItem

[缺少 "M:Swebui.Controls.PageView.NewPage(System.Object,System.String,System.Object[])" 的 <returns> 文档]

参见

引用

PageView 类
NewPage 重载


PageView.OnDataSourceUpdate 方法

PageViewOnDataSourceUpdate 方法

[缺少 "M:Swebui.Controls.PageView.OnDataSourceUpdate(Swebui.Controls.DataSourceUpdateEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
internal void OnDataSourceUpdate(
    DataSourceUpdateEventArgs e
)
Friend Sub OnDataSourceUpdate (
    e As DataSourceUpdateEventArgs
)

参数

e
类型：Swebui.ControlsDataSourceUpdateEventArgs

[缺少 "M:Swebui.Controls.PageView.OnDataSourceUpdate(Swebui.Controls.DataSourceUpdateEventArgs)" 的 <param name="e"/> 文档]

实现

ISwebDataBindControlOnDataSourceUpdate(DataSourceUpdateEventArgs)
参见

引用

PageView 类


PageView.UpdatePage 方法

PageViewUpdatePage 方法

更新页面。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void UpdatePage(
    PageViewItem page,
    Object dataSource,
    string dataMember = ""
)
Public Sub UpdatePage (
    page As PageViewItem,
    dataSource As Object,
    Optional dataMember As String = ""
)

参数

page
类型：Swebui.ControlsPageViewItem
页面
dataSource
类型：SystemObject
数据源
dataMember (Optional)
类型：SystemString
数据源名称
参见

引用

PageView 类


PageView 事件

PageView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。
公共事件 | PageBind | 在页绑定后发生。
公共事件 | PageBinding | 在页绑定时发生。
公共事件 | PageIndexChanged | 在页面索引改变时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

PageView 类


PageView.DataSourceUpdate 事件

PageViewDataSourceUpdate 事件

在更新数据源时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event DataSourceUpdateEventHandler DataSourceUpdate
Public Event DataSourceUpdate As DataSourceUpdateEventHandler

值

类型：Swebui.ControlsDataSourceUpdateEventHandler
参见

引用

PageView 类


PageView.PageBind 事件

PageViewPageBind 事件

在页绑定后发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event PageViewTemplateBindEventHandler PageBind
Public Event PageBind As PageViewTemplateBindEventHandler

值

类型：Swebui.ControlsPageViewTemplateBindEventHandler
参见

引用

PageView 类


PageView.PageBinding 事件

PageViewPageBinding 事件

在页绑定时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event PageViewTemplateBindEventHandler PageBinding
Public Event PageBinding As PageViewTemplateBindEventHandler

值

类型：Swebui.ControlsPageViewTemplateBindEventHandler
参见

引用

PageView 类


PageView.PageIndexChanged 事件

PageViewPageIndexChanged 事件

在页面索引改变时触发。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler PageIndexChanged
Public Event PageIndexChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

PageView 类


PageViewItem 类

页面控件元素。
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsPageViewItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PageViewItem : SwebViewTemplateItem
Public Class PageViewItem
    Inherits SwebViewTemplateItem

PageViewItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageViewItem | 初始化 PageViewItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

Swebui.Controls 命名空间


PageViewItem 构造函数

初始化 PageViewItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItem()
Public Sub New
参见

引用

PageViewItem 类


PageViewItem 属性

PageViewItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

PageViewItem 类


PageViewItem 方法

PageViewItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

PageViewItem 类


PageViewItemCollection 类

页面控件元素集合。
继承层次
SystemObject
Swebui.ControlsSwebViewCollection PageViewItem
Swebui.ControlsPageViewItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PageViewItemCollection : SwebViewCollection<PageViewItem>
Public Class PageViewItemCollection
    Inherits SwebViewCollection(Of PageViewItem)

PageViewItemCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageViewItemCollection | 初始化 PageViewItemCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


PageViewItemCollection 构造函数

初始化 PageViewItemCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItemCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.PageViewItemCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

PageViewItemCollection 类


PageViewItemCollection 属性

PageViewItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

PageViewItemCollection 类


PageViewItemCollection 方法

PageViewItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

PageViewItemCollection 类


PageViewTemplateBindEventArgs 类

为 PageViewTemplateBind 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsPageViewTemplateBindEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PageViewTemplateBindEventArgs : EventArgs
Public Class PageViewTemplateBindEventArgs
    Inherits EventArgs

PageViewTemplateBindEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageViewTemplateBindEventArgs | 初始化 PageViewTemplateBindEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data | 获取绑定数据
公共属性 | Page | 获取绑定行
Top
参见

引用

Swebui.Controls 命名空间


PageViewTemplateBindEventArgs 构造函数

初始化 PageViewTemplateBindEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewTemplateBindEventArgs()
Public Sub New
参见

引用

PageViewTemplateBindEventArgs 类


PageViewTemplateBindEventArgs 属性

PageViewTemplateBindEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data | 获取绑定数据
公共属性 | Page | 获取绑定行
Top
参见

引用

PageViewTemplateBindEventArgs 类


PageViewTemplateBindEventArgs.Data 属性

PageViewTemplateBindEventArgsData 属性

获取绑定数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Data { get; }
Public ReadOnly Property Data As Object
    Get

返回值

类型：Object
参见

引用

PageViewTemplateBindEventArgs 类


PageViewTemplateBindEventArgs.Page 属性

PageViewTemplateBindEventArgsPage 属性

获取绑定行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PageViewItem Page { get; }
Public ReadOnly Property Page As PageViewItem
    Get

返回值

类型：PageViewItem
参见

引用

PageViewTemplateBindEventArgs 类


PageViewTemplateBindEventHandler 委托

一个委托，它表示模板控件绑定过程要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void PageViewTemplateBindEventHandler(
    Object sender,
    PageViewTemplateBindEventArgs e
)
Public Delegate Sub PageViewTemplateBindEventHandler (
    sender As Object,
    e As PageViewTemplateBindEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsPageViewTemplateBindEventArgs
包含事件数据的 PageViewTemplateBindEventArgs
参见

引用

Swebui.Controls 命名空间


Panel 类

Panel 类
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsPanel
Swebui.ControlsTabPageControl

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class Panel : SwebContainerControl
Public Class Panel
    Inherits SwebContainerControl

Panel 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Panel | 初始化 Panel 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage |
公共属性 | BackgroundImagePath |
公共属性 | BackgroundImageRepeatMode |
公共属性 | BackgroundImageSizeMode |
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取和设置是否触发鼠标事件。
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。
公共属性 | RaiseReachEnd | 获取和设置一个值，该值指示是否在Panel可滚动时，当滚动到底部时，触发ReachEnd事件
公共属性 | RaiseRefresh | 获取和设置一个值，该值指示是否在Panel可滚动时，当从顶部向下划动时，是否触发Refresh事件
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Scrollable | 获取和设置一个值，该值指示在子控件超出容器范围时，容器是否可滚动。
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示在Scrollable为true时，是否启用容器滚动。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Touchable | 获取和设置是否触发点击事件。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | AutoScroll |
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ScrollTo(Single, Boolean) | 滚动到指定位置
公共方法 | ScrollTo(Single, Single, Boolean) | 滚动到指定位置
公共方法 | ScrollToBottom | 滚动到ScrollablePanel的底部
公共方法 | ScrollToTop | 滚动到ScrollablePanel的顶部
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll |
Top
事件
 | 名称 | 说明
公共事件 | MouseEnter | 在位置变化时发生。
公共事件 | MouseLeave | 在位置变化时发生。
公共事件 | PositionChanged | 在位置变化时发生。
公共事件 | Press | 在触摸操作激活时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在滚动到底部时发生。
公共事件 | Refresh | 在下拉刷新时发生。
Top
参见

引用

Swebui.Controls 命名空间


Panel 构造函数

初始化 Panel 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Panel()
Public Sub New
参见

引用

Panel 类


Panel 属性

Panel 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage |
公共属性 | BackgroundImagePath |
公共属性 | BackgroundImageRepeatMode |
公共属性 | BackgroundImageSizeMode |
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取和设置是否触发鼠标事件。
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。
公共属性 | RaiseReachEnd | 获取和设置一个值，该值指示是否在Panel可滚动时，当滚动到底部时，触发ReachEnd事件
公共属性 | RaiseRefresh | 获取和设置一个值，该值指示是否在Panel可滚动时，当从顶部向下划动时，是否触发Refresh事件
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Scrollable | 获取和设置一个值，该值指示在子控件超出容器范围时，容器是否可滚动。
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示在Scrollable为true时，是否启用容器滚动。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Touchable | 获取和设置是否触发点击事件。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Panel 类


Panel.BackgroundImage 属性

PanelBackgroundImage 属性

[缺少 "P:Swebui.Controls.Panel.BackgroundImage" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImage { get; set; }
Public Property BackgroundImage As String
    Get
    Set

属性值

类型：String
参见

引用

Panel 类


Panel.BackgroundImagePath 属性

PanelBackgroundImagePath 属性

[缺少 "P:Swebui.Controls.Panel.BackgroundImagePath" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImagePath { get; set; }
Public Property BackgroundImagePath As String
    Get
    Set

属性值

类型：String
参见

引用

Panel 类


Panel.BackgroundImageRepeatMode 属性

PanelBackgroundImageRepeatMode 属性

[缺少 "P:Swebui.Controls.Panel.BackgroundImageRepeatMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ImageRepeatMode BackgroundImageRepeatMode { get; set; }
Public Property BackgroundImageRepeatMode As ImageRepeatMode
    Get
    Set

属性值

类型：ImageRepeatMode
参见

引用

Panel 类


Panel.BackgroundImageSizeMode 属性

PanelBackgroundImageSizeMode 属性

[缺少 "P:Swebui.Controls.Panel.BackgroundImageSizeMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ImageSizeMode BackgroundImageSizeMode { get; set; }
Public Property BackgroundImageSizeMode As ImageSizeMode
    Get
    Set

属性值

类型：ImageSizeMode
参见

引用

Panel 类


Panel.Horizontal 属性

PanelHorizontal 属性

获取和设置一个值，该值指示是否水平滑动

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Horizontal { get; set; }
Public Property Horizontal As Boolean
    Get
    Set

属性值

类型：Boolean
水平滑动设置为 true，否则为 flase

返回值

类型：Boolean
参见

引用

Panel 类


Panel.KeyboardScrollHidden 属性

PanelKeyboardScrollHidden 属性

获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool KeyboardScrollHidden { get; set; }
Public Property KeyboardScrollHidden As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.RaiseMouseEvent 属性

PanelRaiseMouseEvent 属性

获取和设置是否触发鼠标事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaiseMouseEvent { get; set; }
Public Property RaiseMouseEvent As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.RaisePositionChanged 属性

PanelRaisePositionChanged 属性

获取和设置是否触发滚动时位置变化事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaisePositionChanged { get; set; }
Public Property RaisePositionChanged As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.RaiseReachEnd 属性

PanelRaiseReachEnd 属性

获取和设置一个值，该值指示是否在Panel可滚动时，当滚动到底部时，触发ReachEnd事件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaiseReachEnd { get; set; }
Public Property RaiseReachEnd As Boolean
    Get
    Set

返回值

类型：Boolean
备注
必须设置为Scrollable为True
参见

引用

Panel 类


Panel.RaiseRefresh 属性

PanelRaiseRefresh 属性

获取和设置一个值，该值指示是否在Panel可滚动时，当从顶部向下划动时，是否触发Refresh事件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool RaiseRefresh { get; set; }
Public Property RaiseRefresh As Boolean
    Get
    Set

返回值

类型：Boolean
备注
必须设置为Scrollable为True
参见

引用

Panel 类


Panel.Scrollable 属性

PanelScrollable 属性

获取和设置一个值，该值指示在子控件超出容器范围时，容器是否可滚动。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Scrollable { get; set; }
Public Property Scrollable As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.ScrollEnabled 属性

PanelScrollEnabled 属性

获取和设置一个值，该值指示在Scrollable为true时，是否启用容器滚动。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ScrollEnabled { get; set; }
Public Property ScrollEnabled As Boolean
    Get
    Set

返回值

类型：Boolean
备注
5.0版本后支持
参见

引用

Panel 类


Panel.ShowHorizontalScrollBar 属性

PanelShowHorizontalScrollBar 属性

获取和设置一个值，该值指示是否显示水平滚动条。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowHorizontalScrollBar { get; set; }
Public Property ShowHorizontalScrollBar As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.ShowVerticalScrollBar 属性

PanelShowVerticalScrollBar 属性

获取和设置一个值，该值指示是否显示垂直滚动条。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowVerticalScrollBar { get; set; }
Public Property ShowVerticalScrollBar As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel.Touchable 属性

PanelTouchable 属性

获取和设置是否触发点击事件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Touchable { get; set; }
Public Property Touchable As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

Panel 类


Panel 方法

Panel 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AutoScroll |
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ScrollTo(Single, Boolean) | 滚动到指定位置
公共方法 | ScrollTo(Single, Single, Boolean) | 滚动到指定位置
公共方法 | ScrollToBottom | 滚动到ScrollablePanel的底部
公共方法 | ScrollToTop | 滚动到ScrollablePanel的顶部
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll |
Top
参见

引用

Panel 类


Panel.AutoScroll 方法

PanelAutoScroll 方法

[缺少 "M:Swebui.Controls.Panel.AutoScroll(Swebui.Controls.AutoScrollParameter)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AutoScroll(
    AutoScrollParameter parameter = null
)
Public Sub AutoScroll (
    Optional parameter As AutoScrollParameter = Nothing
)

参数

parameter (Optional)
类型：Swebui.ControlsAutoScrollParameter

[缺少 "M:Swebui.Controls.Panel.AutoScroll(Swebui.Controls.AutoScrollParameter)" 的 <param name="parameter"/> 文档]

参见

引用

Panel 类


Panel.ScrollTo 方法

PanelScrollTo 方法

重载列表
 | 名称 | 说明
公共方法 | ScrollTo(Single, Boolean) | 滚动到指定位置
公共方法 | ScrollTo(Single, Single, Boolean) | 滚动到指定位置
Top
参见

引用

Panel 类


Panel.ScrollTo 方法 (Single, Boolean)

PanelScrollTo 方法 (Single, Boolean)

滚动到指定位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ScrollTo(
    float pos,
    bool animation = true
)
Public Sub ScrollTo (
    pos As Single,
    Optional animation As Boolean = true
)

参数

pos
类型：SystemSingle
当前位置
animation (Optional)
类型：SystemBoolean
是否显示动画效果
参见

引用

Panel 类
ScrollTo 重载


Panel.ScrollTo 方法 (Single, Single, Boolean)

PanelScrollTo 方法 (Single, Single, Boolean)

滚动到指定位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ScrollTo(
    float x,
    float y,
    bool animation = true
)
Public Sub ScrollTo (
    x As Single,
    y As Single,
    Optional animation As Boolean = true
)

参数

x
类型：SystemSingle
X坐标
y
类型：SystemSingle
Y坐标
animation (Optional)
类型：SystemBoolean
是否显示动画效果
参见

引用

Panel 类
ScrollTo 重载


Panel.ScrollToBottom 方法

PanelScrollToBottom 方法

滚动到ScrollablePanel的底部

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ScrollToBottom(
    bool animation = true
)
Public Sub ScrollToBottom (
    Optional animation As Boolean = true
)

参数

animation (Optional)
类型：SystemBoolean
是否显示动画效果，可选参数，默认为True
备注
仅在Panel的属性Scrollable设置为True生效
参见

引用

Panel 类


Panel.ScrollToTop 方法

PanelScrollToTop 方法

滚动到ScrollablePanel的顶部

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ScrollToTop(
    bool animation = true
)
Public Sub ScrollToTop (
    Optional animation As Boolean = true
)

参数

animation (Optional)
类型：SystemBoolean
是否显示动画效果
备注
仅在Panel的属性Scrollable设置为True生效，可选参数，默认为True
参见

引用

Panel 类


Panel.StopAutoScroll 方法

PanelStopAutoScroll 方法

[缺少 "M:Swebui.Controls.Panel.StopAutoScroll" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void StopAutoScroll()
Public Sub StopAutoScroll
参见

引用

Panel 类


Panel 事件

Panel 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | MouseEnter | 在位置变化时发生。
公共事件 | MouseLeave | 在位置变化时发生。
公共事件 | PositionChanged | 在位置变化时发生。
公共事件 | Press | 在触摸操作激活时触发。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在滚动到底部时发生。
公共事件 | Refresh | 在下拉刷新时发生。
Top
参见

引用

Panel 类


Panel.MouseEnter 事件

PanelMouseEnter 事件

在位置变化时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebMouseMoveEventHandler MouseEnter
Public Event MouseEnter As SwebMouseMoveEventHandler

值

类型：Swebui.ControlsSwebMouseMoveEventHandler
参见

引用

Panel 类


Panel.MouseLeave 事件

PanelMouseLeave 事件

在位置变化时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebMouseMoveEventHandler MouseLeave
Public Event MouseLeave As SwebMouseMoveEventHandler

值

类型：Swebui.ControlsSwebMouseMoveEventHandler
参见

引用

Panel 类


Panel.PositionChanged 事件

PanelPositionChanged 事件

在位置变化时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ScrollPositionChangedEventHandler PositionChanged
Public Event PositionChanged As ScrollPositionChangedEventHandler

值

类型：Swebui.ControlsScrollPositionChangedEventHandler
备注
只支持竖向滚动
参见

引用

Panel 类


Panel.Press 事件

PanelPress 事件

在触摸操作激活时触发。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event SwebMousePressEventHandler Press
Public Event Press As SwebMousePressEventHandler

值

类型：Swebui.ControlsSwebMousePressEventHandler
参见

引用

Panel 类


Panel.ReachEnd 事件

PanelReachEnd 事件

在滚动到底部时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler ReachEnd
Public Event ReachEnd As EventHandler

值

类型：SystemEventHandler
参见

引用

Panel 类


Panel.Refresh 事件

PanelRefresh 事件

在下拉刷新时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Refresh
Public Event Refresh As EventHandler

值

类型：SystemEventHandler
参见

引用

Panel 类


PDFView 类

PDF控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsPDFView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class PDFView : SwebNativeControl, ISwebResourceControl,
    ISwebResourceDataControl
Public Class PDFView
    Inherits SwebNativeControl
    Implements ISwebResourceControl, ISwebResourceDataControl

PDFView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PDFView | 初始化PDFView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResourceContentType | 获取和设置资源数据类型
公共属性 | ResourceData | 获取和设置图像资源数据
公共属性 | ResourceID | 获取和设置资源编号
公共属性 | ResourceMode | 获取或设置获取图像模式
公共属性 | ResourcePath | 获取或设置图像存储路径
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


PDFView 构造函数

初始化PDFView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public PDFView()
Public Sub New
参见

引用

PDFView 类


PDFView 属性

PDFView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ResourceContentType | 获取和设置资源数据类型
公共属性 | ResourceData | 获取和设置图像资源数据
公共属性 | ResourceID | 获取和设置资源编号
公共属性 | ResourceMode | 获取或设置获取图像模式
公共属性 | ResourcePath | 获取或设置图像存储路径
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

PDFView 类


PDFView.BackColor 属性

PDFViewBackColor 属性

[缺少 "P:Swebui.Controls.PDFView.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

PDFView 类


PDFView.Border 属性

PDFViewBorder 属性

[缺少 "P:Swebui.Controls.PDFView.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

PDFView 类


PDFView.BorderColor 属性

PDFViewBorderColor 属性

[缺少 "P:Swebui.Controls.PDFView.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

PDFView 类


PDFView.BorderRadius 属性

PDFViewBorderRadius 属性

[缺少 "P:Swebui.Controls.PDFView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

PDFView 类


PDFView.BorderStyle 属性

PDFViewBorderStyle 属性

[缺少 "P:Swebui.Controls.PDFView.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

PDFView 类


PDFView.ResourceContentType 属性

PDFViewResourceContentType 属性

获取和设置资源数据类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourceContentType { get; set; }
Public Property ResourceContentType As String
    Get
    Set

属性值

类型：String

实现

ISwebResourceControlResourceContentType
参见

引用

PDFView 类


PDFView.ResourceData 属性

PDFViewResourceData 属性

获取和设置图像资源数据

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public byte[] ResourceData { get; set; }
Public Property ResourceData As Byte()
    Get
    Set

返回值

类型：Byte

实现

ISwebResourceDataControlResourceData
参见

引用

PDFView 类


PDFView.ResourceID 属性

PDFViewResourceID 属性

获取和设置资源编号

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourceID { get; set; }
Public Property ResourceID As String
    Get
    Set

属性值

类型：String

实现

ISwebResourceControlResourceID
参见

引用

PDFView 类


PDFView.ResourceMode 属性

PDFViewResourceMode 属性

获取或设置获取图像模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ResourceMode ResourceMode { get; set; }
Public Property ResourceMode As ResourceMode
    Get
    Set

属性值

类型：ResourceMode
默认为File，代表直接从文件读取，如果设置为Customize，代表可以从自定义的接口中获取图片的二进制数据

返回值

类型：ResourceMode

实现

ISwebResourceControlResourceMode
备注
参见

引用

PDFView 类


PDFView.ResourcePath 属性

PDFViewResourcePath 属性

获取或设置图像存储路径

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string ResourcePath { get; set; }
Public Property ResourcePath As String
    Get
    Set

属性值

类型：String

返回值

类型：String

实现

ISwebResourceControlResourcePath
备注
参见

引用

PDFView 类


PDFView 方法

PDFView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

PDFView 类


PDFView 事件

PDFView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

PDFView 类


PercentageCircle 类

百分比圆形控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsSwebNativeContainerControl
Swebui.ControlsPercentageCircle

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class PercentageCircle : SwebNativeContainerControl
Public Class PercentageCircle
    Inherits SwebNativeContainerControl

PercentageCircle 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PercentageCircle | 初始化PercentageCircle类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | CircleColor | 获取与设置默认百分比进度条颜色
公共属性 | CircleSize | 获取与设置百分比进度条宽度
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 百分比圆形控件默认使用垂直布局 (重写 SwebLayoutControlDirection.)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InnerColor | 获取与设置百分比进度条内部颜色
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 百分比圆形控件默认侧轴居中 (重写 SwebLayoutControlItemAlign.)
公共属性 | JustifyAlign | 百分比圆形控件默认主轴居中 (重写 SwebLayoutControlJustifyAlign.)
公共属性 | Layout | 百分比圆形控件默认使用相对布局 (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取与设置默认百分比进度条比值（0-100）
公共属性 | ValueColor | 获取与设置默认百分比进度条值颜色
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


PercentageCircle 构造函数

初始化PercentageCircle类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public PercentageCircle()
Public Sub New
参见

引用

PercentageCircle 类


PercentageCircle 属性

PercentageCircle 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | CircleColor | 获取与设置默认百分比进度条颜色
公共属性 | CircleSize | 获取与设置百分比进度条宽度
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 百分比圆形控件默认使用垂直布局 (重写 SwebLayoutControlDirection.)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InnerColor | 获取与设置百分比进度条内部颜色
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 百分比圆形控件默认侧轴居中 (重写 SwebLayoutControlItemAlign.)
公共属性 | JustifyAlign | 百分比圆形控件默认主轴居中 (重写 SwebLayoutControlJustifyAlign.)
公共属性 | Layout | 百分比圆形控件默认使用相对布局 (重写 SwebLayoutControlLayout.)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Value | 获取与设置默认百分比进度条比值（0-100）
公共属性 | ValueColor | 获取与设置默认百分比进度条值颜色
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

PercentageCircle 类


PercentageCircle.CircleColor 属性

PercentageCircleCircleColor 属性

获取与设置默认百分比进度条颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CircleColor { get; set; }
Public Property CircleColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

PercentageCircle 类


PercentageCircle.CircleSize 属性

PercentageCircleCircleSize 属性

获取与设置百分比进度条宽度

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float CircleSize { get; set; }
Public Property CircleSize As Single
    Get
    Set

属性值

类型：Single
最小值为2
备注
仅在设计时或第一次加载前设置生效
参见

引用

PercentageCircle 类


PercentageCircle.Direction 属性

PercentageCircleDirection 属性

百分比圆形控件默认使用垂直布局

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutDirection Direction { get; set; }
Public Overrides Property Direction As LayoutDirection
    Get
    Set

属性值

类型：LayoutDirection
参见

引用

PercentageCircle 类


PercentageCircle.InnerColor 属性

PercentageCircleInnerColor 属性

获取与设置百分比进度条内部颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color InnerColor { get; set; }
Public Property InnerColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

PercentageCircle 类


PercentageCircle.ItemAlign 属性

PercentageCircleItemAlign 属性

百分比圆形控件默认侧轴居中

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutItemAlign ItemAlign { get; set; }
Public Overrides Property ItemAlign As LayoutItemAlign
    Get
    Set

属性值

类型：LayoutItemAlign
参见

引用

PercentageCircle 类


PercentageCircle.JustifyAlign 属性

PercentageCircleJustifyAlign 属性

百分比圆形控件默认主轴居中

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutJustifyAlign JustifyAlign { get; set; }
Public Overrides Property JustifyAlign As LayoutJustifyAlign
    Get
    Set

属性值

类型：LayoutJustifyAlign
参见

引用

PercentageCircle 类


PercentageCircle.Layout 属性

PercentageCircleLayout 属性

百分比圆形控件默认使用相对布局

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutPosition Layout { get; set; }
Public Overrides Property Layout As LayoutPosition
    Get
    Set

属性值

类型：LayoutPosition
参见

引用

PercentageCircle 类


PercentageCircle.Value 属性

PercentageCircleValue 属性

获取与设置默认百分比进度条比值（0-100）

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

PercentageCircle 类


PercentageCircle.ValueColor 属性

PercentageCircleValueColor 属性

获取与设置默认百分比进度条值颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ValueColor { get; set; }
Public Property ValueColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

PercentageCircle 类


PercentageCircle 方法

PercentageCircle 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

PercentageCircle 类


PercentageCircle 事件

PercentageCircle 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

PercentageCircle 类


PointerEventType 枚举

控制当前组件是否可以作为触控事件的目标

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PointerEventType
Public Enumeration PointerEventType
成员
成员名称 | 值 | 说明
None | 0 | 发生在本组件与本组件的子组件上的触摸事件都会交给本组件的父组件处理
Auto | 1 | 根据不同组件自动处理
BoxNone | 2 | 发生在本组件显示范围内（但不是子组件显示范围内）的事件交给本组件,在子组件显示范围内交给子组件处理
BoxOnly | 3 | 发生在本组件显示范围内的触摸事件将全部由本组件处理（即使触摸事件发生在本组件的子组件显示范围内）
参见

引用

Swebui.Controls 命名空间


PopPanel 类

[缺少 "T:Swebui.Controls.PopPanel" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsPopPanel

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PopPanel : SwebContainerControl, ISwebViewCollectionOwner
Public Class PopPanel
    Inherits SwebContainerControl
    Implements ISwebViewCollectionOwner

PopPanel 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PopPanel | 初始化 PopPanel 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | PopArrow |
公共属性 | PopControl |
公共属性 | PopControlName |
公共属性 | PopItems |
公共属性 | PopListTheme |
公共属性 | PopPosition |
公共属性 | PopType |
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | Refresh |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | Select |
Top
参见

引用

Swebui.Controls 命名空间


PopPanel 构造函数

初始化 PopPanel 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanel()
Public Sub New
参见

引用

PopPanel 类


PopPanel 属性

PopPanel 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | PopArrow |
公共属性 | PopControl |
公共属性 | PopControlName |
公共属性 | PopItems |
公共属性 | PopListTheme |
公共属性 | PopPosition |
公共属性 | PopType |
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

PopPanel 类


PopPanel.PopArrow 属性

PopPanelPopArrow 属性

[缺少 "P:Swebui.Controls.PopPanel.PopArrow" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool PopArrow { get; set; }
Public Property PopArrow As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

PopPanel 类


PopPanel.PopControl 属性

PopPanelPopControl 属性

[缺少 "P:Swebui.Controls.PopPanel.PopControl" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl PopControl { get; set; }
Public Property PopControl As SwebUserControl
    Get
    Set

属性值

类型：SwebUserControl
参见

引用

PopPanel 类


PopPanel.PopControlName 属性

PopPanelPopControlName 属性

[缺少 "P:Swebui.Controls.PopPanel.PopControlName" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string PopControlName { get; set; }
Public Property PopControlName As String
    Get
    Set

属性值

类型：String
参见

引用

PopPanel 类


PopPanel.PopItems 属性

PopPanelPopItems 属性

[缺少 "P:Swebui.Controls.PopPanel.PopItems" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelItemCollection PopItems { get; }
Public ReadOnly Property PopItems As PopPanelItemCollection
    Get

属性值

类型：PopPanelItemCollection
参见

引用

PopPanel 类


PopPanel.PopListTheme 属性

PopPanelPopListTheme 属性

[缺少 "P:Swebui.Controls.PopPanel.PopListTheme" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelListTheme PopListTheme { get; set; }
Public Property PopListTheme As PopPanelListTheme
    Get
    Set

属性值

类型：PopPanelListTheme
参见

引用

PopPanel 类


PopPanel.PopPosition 属性

PopPanelPopPosition 属性

[缺少 "P:Swebui.Controls.PopPanel.PopPosition" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelPosition PopPosition { get; set; }
Public Property PopPosition As PopPanelPosition
    Get
    Set

属性值

类型：PopPanelPosition
参见

引用

PopPanel 类


PopPanel.PopType 属性

PopPanelPopType 属性

[缺少 "P:Swebui.Controls.PopPanel.PopType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelType PopType { get; set; }
Public Property PopType As PopPanelType
    Get
    Set

属性值

类型：PopPanelType
参见

引用

PopPanel 类


PopPanel 方法

PopPanel 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | Refresh |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

PopPanel 类


PopPanel.ItemAdd 方法

PopPanelItemAdd 方法

[缺少 "M:Swebui.Controls.PopPanel.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanel.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

PopPanel 类


PopPanel.ItemClear 方法

PopPanelItemClear 方法

[缺少 "M:Swebui.Controls.PopPanel.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

PopPanel 类


PopPanel.ItemPropertyChanged 方法

PopPanelItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.PopPanel.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanel.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.PopPanel.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

PopPanel 类


PopPanel.ItemRemove 方法

PopPanelItemRemove 方法

[缺少 "M:Swebui.Controls.PopPanel.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanel.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.PopPanel.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

PopPanel 类


PopPanel.Refresh 方法

PopPanelRefresh 方法

[缺少 "M:Swebui.Controls.PopPanel.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

PopPanel 类


PopPanel 事件

PopPanel 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | Select |
Top
参见

引用

PopPanel 类


PopPanel.Select 事件

PopPanelSelect 事件

[缺少 "E:Swebui.Controls.PopPanel.Select" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event PopPanelItemSelectEventHandler Select
Public Event Select As PopPanelItemSelectEventHandler

值

类型：Swebui.ControlsPopPanelItemSelectEventHandler
参见

引用

PopPanel 类


PopPanelItem 类

[缺少 "T:Swebui.Controls.PopPanelItem" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsPopPanelItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PopPanelItem : SwebViewCollectionItem,
    ISwebViewCollectionOwner
Public Class PopPanelItem
    Inherits SwebViewCollectionItem
    Implements ISwebViewCollectionOwner

PopPanelItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PopPanelItem | 初始化 PopPanelItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Icon |
公共属性 | Id |
公共属性 | Items |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

Swebui.Controls 命名空间


PopPanelItem 构造函数

初始化 PopPanelItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelItem()
Public Sub New
参见

引用

PopPanelItem 类


PopPanelItem 属性

PopPanelItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Icon |
公共属性 | Id |
公共属性 | Items |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
Top
参见

引用

PopPanelItem 类


PopPanelItem.Icon 属性

PopPanelItemIcon 属性

[缺少 "P:Swebui.Controls.PopPanelItem.Icon" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Icon { get; set; }
Public Property Icon As String
    Get
    Set

属性值

类型：String
参见

引用

PopPanelItem 类


PopPanelItem.Id 属性

PopPanelItemId 属性

[缺少 "P:Swebui.Controls.PopPanelItem.Id" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Id { get; set; }
Public Property Id As String
    Get
    Set

属性值

类型：String
参见

引用

PopPanelItem 类


PopPanelItem.Items 属性

PopPanelItemItems 属性

[缺少 "P:Swebui.Controls.PopPanelItem.Items" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelItemCollection Items { get; }
Public ReadOnly Property Items As PopPanelItemCollection
    Get

属性值

类型：PopPanelItemCollection
参见

引用

PopPanelItem 类


PopPanelItem.Text 属性

PopPanelItemText 属性

[缺少 "P:Swebui.Controls.PopPanelItem.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

PopPanelItem 类


PopPanelItem 方法

PopPanelItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

PopPanelItem 类


PopPanelItem.ItemAdd 方法

PopPanelItemItemAdd 方法

[缺少 "M:Swebui.Controls.PopPanelItem.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanelItem.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

PopPanelItem 类


PopPanelItem.ItemClear 方法

PopPanelItemItemClear 方法

[缺少 "M:Swebui.Controls.PopPanelItem.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

PopPanelItem 类


PopPanelItem.ItemPropertyChanged 方法

PopPanelItemItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.PopPanelItem.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanelItem.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.PopPanelItem.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

PopPanelItem 类


PopPanelItem.ItemRemove 方法

PopPanelItemItemRemove 方法

[缺少 "M:Swebui.Controls.PopPanelItem.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.PopPanelItem.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.PopPanelItem.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

PopPanelItem 类


PopPanelItem.Refresh 方法

PopPanelItemRefresh 方法

[缺少 "M:Swebui.Controls.PopPanelItem.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

PopPanelItem 类


PopPanelItemCollection 类

[缺少 "T:Swebui.Controls.PopPanelItemCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase PopPanelItem
Swebui.ControlsPopPanelItemCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PopPanelItemCollection : SwebViewCollectionBase<PopPanelItem>
Public Class PopPanelItemCollection
    Inherits SwebViewCollectionBase(Of PopPanelItem)

PopPanelItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


PopPanelItemCollection 属性

PopPanelItemCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

PopPanelItemCollection 类


PopPanelItemCollection 方法

PopPanelItemCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

PopPanelItemCollection 类


PopPanelItemSelectEventArgs 类

[缺少 "T:Swebui.Controls.PopPanelItemSelectEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsPopPanelItemSelectEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PopPanelItemSelectEventArgs : EventArgs
Public Class PopPanelItemSelectEventArgs
    Inherits EventArgs

PopPanelItemSelectEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PopPanelItemSelectEventArgs | 初始化 PopPanelItemSelectEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item |
Top
参见

引用

Swebui.Controls 命名空间


PopPanelItemSelectEventArgs 构造函数

初始化 PopPanelItemSelectEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelItemSelectEventArgs()
Public Sub New
参见

引用

PopPanelItemSelectEventArgs 类


PopPanelItemSelectEventArgs 属性

PopPanelItemSelectEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item |
Top
参见

引用

PopPanelItemSelectEventArgs 类


PopPanelItemSelectEventArgs.Item 属性

PopPanelItemSelectEventArgsItem 属性

[缺少 "P:Swebui.Controls.PopPanelItemSelectEventArgs.Item" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PopPanelItem Item { get; }
Public ReadOnly Property Item As PopPanelItem
    Get

属性值

类型：PopPanelItem
参见

引用

PopPanelItemSelectEventArgs 类


PopPanelItemSelectEventHandler 委托

[缺少 "T:Swebui.Controls.PopPanelItemSelectEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void PopPanelItemSelectEventHandler(
    Object sender,
    PopPanelItemSelectEventArgs e
)
Public Delegate Sub PopPanelItemSelectEventHandler (
    sender As Object,
    e As PopPanelItemSelectEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsPopPanelItemSelectEventArgs
参见

引用

Swebui.Controls 命名空间


PopPanelListTheme 枚举

[缺少 "T:Swebui.Controls.PopPanelListTheme" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PopPanelListTheme
Public Enumeration PopPanelListTheme
成员
成员名称 | 值 | 说明
Light | 0 |
Dark | 1 |
参见

引用

Swebui.Controls 命名空间


PopPanelPosition 枚举

[缺少 "T:Swebui.Controls.PopPanelPosition" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PopPanelPosition
Public Enumeration PopPanelPosition
成员
成员名称 | 值 | 说明
Top | 0 |
Left | 1 |
Right | 2 |
Bottom | 3 |
参见

引用

Swebui.Controls 命名空间


PopPanelType 枚举

[缺少 "T:Swebui.Controls.PopPanelType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PopPanelType
Public Enumeration PopPanelType
成员
成员名称 | 值 | 说明
Click | 0 |
Hover | 1 |
参见

引用

Swebui.Controls 命名空间


Predicate 枚举

[缺少 "T:Swebui.Controls.Predicate" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum Predicate
Public Enumeration Predicate
成员
成员名称 | 值 | 说明
And | 0 |
Or | 1 |
参见

引用

Swebui.Controls 命名空间


PrintType 枚举

[缺少 "T:Swebui.Controls.PrintType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum PrintType
Public Enumeration PrintType
成员
成员名称 | 值 | 说明
Pdf | 0 |
Html | 1 |
参见

引用

Swebui.Controls 命名空间


Progress 类

进度条控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsProgress

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Progress : SwebBindableControl, ISwebRenderControl
Public Class Progress
    Inherits SwebBindableControl
    Implements ISwebRenderControl

Progress 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Progress | 初始化Progress类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置默认绑定值。 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | TrackColor | 获取和设置进度条颜色。
公共属性 | Value | 获取和设置进度值，该值为Float类型，必须在0和1之间
公共属性 | ValueColor | 获取和设置进度颜色。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Progress 构造函数

初始化Progress类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Progress()
Public Sub New
参见

引用

Progress 类


Progress 属性

Progress 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置默认绑定值。 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | TrackColor | 获取和设置进度条颜色。
公共属性 | Value | 获取和设置进度值，该值为Float类型，必须在0和1之间
公共属性 | ValueColor | 获取和设置进度颜色。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Progress 类


Progress.BackColor 属性

ProgressBackColor 属性

[缺少 "P:Swebui.Controls.Progress.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Progress 类


Progress.BindDisplayValue 属性

ProgressBindDisplayValue 属性

获取和设置默认绑定值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

Progress 类


Progress.Border 属性

ProgressBorder 属性

[缺少 "P:Swebui.Controls.Progress.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

Progress 类


Progress.BorderColor 属性

ProgressBorderColor 属性

[缺少 "P:Swebui.Controls.Progress.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Progress 类


Progress.BorderRadius 属性

ProgressBorderRadius 属性

[缺少 "P:Swebui.Controls.Progress.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Progress 类


Progress.BorderStyle 属性

ProgressBorderStyle 属性

[缺少 "P:Swebui.Controls.Progress.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

Progress 类


Progress.Padding 属性

ProgressPadding 属性

[缺少 "P:Swebui.Controls.Progress.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

Progress 类


Progress.TrackColor 属性

ProgressTrackColor 属性

获取和设置进度条颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TrackColor { get; set; }
Public Property TrackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Progress 类


Progress.Value 属性

ProgressValue 属性

获取和设置进度值，该值为Float类型，必须在0和1之间

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Value { get; set; }
Public Property Value As Single
    Get
    Set

属性值

类型：Single
参见

引用

Progress 类


Progress.ValueColor 属性

ProgressValueColor 属性

获取和设置进度颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ValueColor { get; set; }
Public Property ValueColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Progress 类


Progress 方法

Progress 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Progress 类


Progress 事件

Progress 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Progress 类


PropertyChangedEventArgs 类

Provide event data for PropertyChangedEvent
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsPropertyChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class PropertyChangedEventArgs : EventArgs
Public Class PropertyChangedEventArgs
    Inherits EventArgs

PropertyChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PropertyChangedEventArgs | Instance
Top
属性
 | 名称 | 说明
公共属性 | ChangedSource | ChangedSource
公共属性 | NewValue | NewValue
公共属性 | OldValue | OldValue
公共属性 | PropertyName | PropertyName
Top
参见

引用

Swebui.Controls 命名空间


PropertyChangedEventArgs 构造函数

Instance

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PropertyChangedEventArgs(
    string propName,
    Object oldValue,
    Object newValue
)
Public Sub New (
    propName As String,
    oldValue As Object,
    newValue As Object
)

参数

propName
类型：SystemString
Property Name
oldValue
类型：SystemObject
Old Value
newValue
类型：SystemObject
New Value
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventArgs 属性

PropertyChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ChangedSource | ChangedSource
公共属性 | NewValue | NewValue
公共属性 | OldValue | OldValue
公共属性 | PropertyName | PropertyName
Top
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventArgs.ChangedSource 属性

PropertyChangedEventArgsChangedSource 属性

ChangedSource

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PropertyChangedSource ChangedSource { get; }
Public ReadOnly Property ChangedSource As PropertyChangedSource
    Get

返回值

类型：PropertyChangedSource
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventArgs.NewValue 属性

PropertyChangedEventArgsNewValue 属性

NewValue

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object NewValue { get; }
Public ReadOnly Property NewValue As Object
    Get

返回值

类型：Object
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventArgs.OldValue 属性

PropertyChangedEventArgsOldValue 属性

OldValue

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object OldValue { get; }
Public ReadOnly Property OldValue As Object
    Get

返回值

类型：Object
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventArgs.PropertyName 属性

PropertyChangedEventArgsPropertyName 属性

PropertyName

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get

返回值

类型：String
参见

引用

PropertyChangedEventArgs 类


PropertyChangedEventHandler 委托

Represents the method that will handle the System.ComponentModel.INotifyPropertyChanged.PropertyChanged event raised when a property is changed on a component.

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void PropertyChangedEventHandler(
    Object sender,
    PropertyChangedEventArgs e
)
Public Delegate Sub PropertyChangedEventHandler (
    sender As Object,
    e As PropertyChangedEventArgs
)

参数

sender
类型：SystemObject
The source of the event.
e
类型：Swebui.ControlsPropertyChangedEventArgs
A PropertyChangedEventArgs that contains the event data.
参见

引用

Swebui.Controls 命名空间


PropertyChangedSource 枚举

PropertyChangedSource

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum PropertyChangedSource
Public Enumeration PropertyChangedSource
成员
成员名称 | 值 | 说明
Value | 0 | Changed from ValueSet
Clent | 1 | Changed from Client
参见

引用

Swebui.Controls 命名空间


ReadClientDataCallBackHandler 委托

一个委托，它表示客户端返回读取保存在客户端上的数据时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ReadClientDataCallBackHandler(
    Object sender,
    ClientDataResultHandlerArgs e
)
Public Delegate Sub ReadClientDataCallBackHandler (
    sender As Object,
    e As ClientDataResultHandlerArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientDataResultHandlerArgs
包含事件数据的 ClientDataResultHandlerArgs
备注
参见

引用

Swebui.Controls 命名空间


RelativeSizeFloatPropertyExtend 类

等宽布局float类型扩展属性.
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsRelativeSizeFloatPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class RelativeSizeFloatPropertyExtend : SwebPropertyExtend
Public Class RelativeSizeFloatPropertyExtend
    Inherits SwebPropertyExtend

RelativeSizeFloatPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | RelativeSizeFloatPropertyExtend | 初始化 RelativeSizeFloatPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间
Swebui.ControlsSwebPropertyExtend


RelativeSizeFloatPropertyExtend 构造函数

初始化 RelativeSizeFloatPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public RelativeSizeFloatPropertyExtend()
Public Sub New
参见

引用

RelativeSizeFloatPropertyExtend 类


RelativeSizeIntPropertyExtend 类

等宽布局int类型扩展属性，四舍五入取值
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsRelativeSizeIntPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class RelativeSizeIntPropertyExtend : SwebPropertyExtend
Public Class RelativeSizeIntPropertyExtend
    Inherits SwebPropertyExtend

RelativeSizeIntPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | RelativeSizeIntPropertyExtend | 初始化 RelativeSizeIntPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间
Swebui.ControlsSwebPropertyExtend


RelativeSizeIntPropertyExtend 构造函数

初始化 RelativeSizeIntPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public RelativeSizeIntPropertyExtend()
Public Sub New
参见

引用

RelativeSizeIntPropertyExtend 类


RemoveClientDataCallBackHandler 委托

一个委托，它表示客户端完成数据移除时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void RemoveClientDataCallBackHandler(
    Object sender,
    ClientDataResultHandlerArgs e
)
Public Delegate Sub RemoveClientDataCallBackHandler (
    sender As Object,
    e As ClientDataResultHandlerArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientDataResultHandlerArgs
包含事件数据的 ClientDataResultHandlerArgs
备注
参见

引用

Swebui.Controls 命名空间


RemoveClientResourceHandler 委托

一个委托，它表示在删除客户端资源后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void RemoveClientResourceHandler(
    Object sender,
    ClientResourceRemoveResultArgs e
)
Public Delegate Sub RemoveClientResourceHandler (
    sender As Object,
    e As ClientResourceRemoveResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClientResourceRemoveResultArgs
备注
包含事件数据的 ClientResourceArgs
参见

引用

Swebui.Controls 命名空间


ResourceMode 枚举

资源类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ResourceMode
Public Enumeration ResourceMode
成员
成员名称 | 值 | 说明
File | 0 | 服务端资源文件
Customize | 1 | 自定义，继承自CustomizeResource
Client | 2 | 客户端资源
Data | 3 | 服务端资源数据（二进制）
备注
参见

引用

Swebui.Controls 命名空间


ResourcePropertyExtend 类

资源属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsResourcePropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ResourcePropertyExtend : SwebPropertyExtend
Public Class ResourcePropertyExtend
    Inherits SwebPropertyExtend

ResourcePropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResourcePropertyExtend | 初始化 ResourcePropertyExtend 类的一个新实例
Top
备注
需要属性的控件实现接口ISwebResourceControl
参见

引用

Swebui.Controls 命名空间
Swebui.ControlsSwebPropertyExtend


ResourcePropertyExtend 构造函数

初始化 ResourcePropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResourcePropertyExtend()
Public Sub New
参见

引用

ResourcePropertyExtend 类


ResourceResultArgs 类

API资源数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsResourceResultArgs
Swebui.ControlsBinaryResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ResourceResultArgs : SwebComponentResultArgs
Public Class ResourceResultArgs
    Inherits SwebComponentResultArgs

ResourceResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResourceResultArgs | 初始化 ResourceResultArgs 类的一个新实例
公共方法 | ResourceResultArgs(String) | 初始化 ResourceResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceID | 获取资源编号
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
备注
参见

引用

Swebui.Controls 命名空间


ResourceResultArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | ResourceResultArgs | 初始化 ResourceResultArgs 类的一个新实例
公共方法 | ResourceResultArgs(String) | 初始化 ResourceResultArgs 类的一个新实例
Top
参见

引用

ResourceResultArgs 类


ResourceResultArgs 构造函数

初始化 ResourceResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResourceResultArgs()
Public Sub New
参见

引用

ResourceResultArgs 类
ResourceResultArgs 重载


ResourceResultArgs 构造函数 (String)

初始化 ResourceResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResourceResultArgs(
    string resourceId
)
Public Sub New (
    resourceId As String
)

参数

resourceId
类型：SystemString

[缺少 "M:Swebui.Controls.ResourceResultArgs.#ctor(System.String)" 的 <param name="resourceId"/> 文档]

参见

引用

ResourceResultArgs 类
ResourceResultArgs 重载


ResourceResultArgs 属性

ResourceResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceID | 获取资源编号
Top
参见

引用

ResourceResultArgs 类


ResourceResultArgs.ResourceID 属性

ResourceResultArgsResourceID 属性

获取资源编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string ResourceID { get; }
Public ReadOnly Property ResourceID As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ResourceResultArgs 类


ResourceResultArgs 方法

ResourceResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ResourceResultArgs 类


ResourcesResultArgs 类

资源数据
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsResourcesResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ResourcesResultArgs : SwebComponentResultArgs
Public Class ResourcesResultArgs
    Inherits SwebComponentResultArgs

ResourcesResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResourcesResultArgs | 初始化 ResourcesResultArgs 类的一个新实例
公共方法 | ResourcesResultArgs(String) | 初始化 ResourcesResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceIDs | 获取资源编号
Top
方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


ResourcesResultArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | ResourcesResultArgs | 初始化 ResourcesResultArgs 类的一个新实例
公共方法 | ResourcesResultArgs(String) | 初始化 ResourcesResultArgs 类的一个新实例
Top
参见

引用

ResourcesResultArgs 类


ResourcesResultArgs 构造函数

初始化 ResourcesResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResourcesResultArgs()
Public Sub New
参见

引用

ResourcesResultArgs 类
ResourcesResultArgs 重载


ResourcesResultArgs 构造函数 (String[])

ResourcesResultArgs 构造函数 (String)

初始化 ResourcesResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ResourcesResultArgs(
    string[] resourceIds
)
Public Sub New (
    resourceIds As String()
)

参数

resourceIds
类型：SystemString

[缺少 "M:Swebui.Controls.ResourcesResultArgs.#ctor(System.String[])" 的 <param name="resourceIds"/> 文档]

参见

引用

ResourcesResultArgs 类
ResourcesResultArgs 重载


ResourcesResultArgs 属性

ResourcesResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据 (继承自 SwebComponentResultArgs。)
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
公共属性 | ResourceIDs | 获取资源编号
Top
参见

引用

ResourcesResultArgs 类


ResourcesResultArgs.ResourceIDs 属性

ResourcesResultArgsResourceIDs 属性

获取资源编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string[] ResourceIDs { get; }
Public ReadOnly Property ResourceIDs As String()
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

ResourcesResultArgs 类


ResourcesResultArgs 方法

ResourcesResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

ResourcesResultArgs 类


ResourceType 枚举

资源类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ResourceType
Public Enumeration ResourceType
成员
成员名称 | 值 | 说明
None | -1 | None
Image | 0 | 图像
Audio | 1 | 音频
Document | 2 | 文档
ImageThumb | 3 | 缩微图像
Media | 4 | 媒体
备注
参见

引用

Swebui.Controls 命名空间


ReturnKeyType 枚举

确定返回键的外观

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ReturnKeyType
Public Enumeration ReturnKeyType
成员
成员名称 | 值 | 说明
Default | 9 | 输入法默认
Done | 0 | 完成
Go | 1 | 跳转
Next | 2 | 下一个
Search | 3 | 搜索
Send | 4 | 发送
参见

引用

Swebui.Controls 命名空间


ScrollPositionChangedEventArgs 类

为 ScrollPositionChangedEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsScrollPositionChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ScrollPositionChangedEventArgs : EventArgs
Public Class ScrollPositionChangedEventArgs
    Inherits EventArgs

ScrollPositionChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ScrollPositionChangedEventArgs | 初始化 ScrollPositionChangedEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Position | 获取当前滚动位置
公共属性 | PositionType | 获取滚动类型
Top
参见

引用

Swebui.Controls 命名空间


ScrollPositionChangedEventArgs 构造函数

初始化 ScrollPositionChangedEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ScrollPositionChangedEventArgs()
Public Sub New
参见

引用

ScrollPositionChangedEventArgs 类


ScrollPositionChangedEventArgs 属性

ScrollPositionChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Position | 获取当前滚动位置
公共属性 | PositionType | 获取滚动类型
Top
参见

引用

ScrollPositionChangedEventArgs 类


ScrollPositionChangedEventArgs.Position 属性

ScrollPositionChangedEventArgsPosition 属性

获取当前滚动位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float Position { get; }
Public ReadOnly Property Position As Single
    Get

返回值

类型：Single
参见

引用

ScrollPositionChangedEventArgs 类


ScrollPositionChangedEventArgs.PositionType 属性

ScrollPositionChangedEventArgsPositionType 属性

获取滚动类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ScrollPositionType PositionType { get; }
Public ReadOnly Property PositionType As ScrollPositionType
    Get

返回值

类型：ScrollPositionType
参见

引用

ScrollPositionChangedEventArgs 类


ScrollPositionChangedEventHandler 委托

一个委托，它表示滚动位置化时的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void ScrollPositionChangedEventHandler(
    Object sender,
    ScrollPositionChangedEventArgs e
)
Public Delegate Sub ScrollPositionChangedEventHandler (
    sender As Object,
    e As ScrollPositionChangedEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsScrollPositionChangedEventArgs
包含事件数据的 ScrollPositionChangedEventArgs
参见

引用

Swebui.Controls 命名空间


ScrollPositionType 枚举

位置滚动类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ScrollPositionType
Public Enumeration ScrollPositionType
成员
成员名称 | 值 | 说明
DragBegin | 0 | 开始滚动
DragEnd | 1 | 结束滚动
MomentumEnd | 2 | 划动结束
参见

引用

Swebui.Controls 命名空间


SectionListView 类

区域列表
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsListView
Swebui.ControlsSectionListView

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SectionListView : ListView
Public Class SectionListView
    Inherits ListView

SectionListView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SectionListView | 初始化 SectionListView 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式 (继承自 ListView。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | ColumnNum | 获取和设置列数 (继承自 ListView。)
公共属性 | DataMember | 获取或设置数据源名称 (继承自 ListView。)
公共属性 | DataSource | 获取或设置表格数据源 (继承自 ListView。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FooterControl | 获取和设置页脚控件 (继承自 ListView。)
公共属性 | FooterControlName | 获取和设置页脚控件布局 (继承自 ListView。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HeaderControl | 获取和设置页眉控件 (继承自 ListView。)
公共属性 | HeaderControlName | 获取和设置页眉控件布局 (继承自 ListView。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动 (继承自 ListView。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | (继承自 ListView。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (继承自 ListView。)
公共属性 | PageSize | (重写 ListViewPageSize.)
公共属性 | PageSizeBackColor | (重写 ListViewPageSizeBackColor.)
公共属性 | PageSizeLoadCompleteText | (重写 ListViewPageSizeLoadCompleteText.)
公共属性 | PageSizeLoadMode | 获取和设置PageSize加载模式 (继承自 ListView。)
公共属性 | PageSizeLoadText | (重写 ListViewPageSizeLoadText.)
公共属性 | PageSizeTextColor | (重写 ListViewPageSizeTextColor.)
公共属性 | PageSizeTextHeight | (重写 ListViewPageSizeTextHeight.)
公共属性 | PageSizeTextSize | (重写 ListViewPageSizeTextSize.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。 (继承自 ListView。)
公共属性 | RaiseReachEnd | 获取和设置是否可触发上划底部事件。 (继承自 ListView。)
公共属性 | RaiseRefresh | 获取和设置是否可触发下拉刷新事件。 (继承自 ListView。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Rows | 获取列表行集合
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示是否启用容器滚动。 (继承自 ListView。)
公共属性 | SectionControl | 获取和设置页眉区域控件
公共属性 | SectionControlName | 获取和设置区域控件布局
公共属性 | SectionMember | 获取或设置区域数据源名称
公共属性 | Sections | 获取列表区域集合
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowSplitLine | 获取和设置一个值，该值指示是否显示单元格之间的分隔线 (继承自 ListView。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SplitLineColor | 获取和设置单元格之间的分隔线颜色 (继承自 ListView。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置模板控件。 (继承自 ListView。)
公共属性 | TemplateControlName | 获取和设置模板控件名称 (继承自 ListView。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | AutoScroll | (继承自 ListView。)
公共方法 | DataBind | (重写 ListViewDataBind(Object).)
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewRow | 添加行
公共方法 | NewRow(Object) | 添加行
公共方法 | NewRow(String) | 添加列表行。
公共方法 | NewRow(String, Object) | 添加列表行。
公共方法 | NewRow(Object, String, Object) | 添加行
公共方法 | NewRow(String, Object, String, Object) | 添加列表行。
公共方法 | NewSection(String) | 添加列表区域
公共方法 | NewSection(String, Object) | 添加列表区域
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate | (继承自 ListView。)
公共方法 | ScrollTo | 滚动到指定位置 (继承自 ListView。)
公共方法 | ScrollToIndex | 不支持的方法 (重写 ListViewScrollToIndex(Int32).)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll | (继承自 ListView。)
公共方法 | UpdateRow | 更新行。 (继承自 ListView。)
Top
事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。 (继承自 ListView。)
公共事件 | PositionChanged | 在位置变化时发生。 (继承自 ListView。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在上划到底部时发生。 (继承自 ListView。)
公共事件 | Refresh | 在用户下拉刷新时发生。 (继承自 ListView。)
公共事件 | RowBind | 在行绑定后发生。 (继承自 ListView。)
公共事件 | RowBinding | 在行绑定时发生。 (继承自 ListView。)
Top
参见

引用

Swebui.Controls 命名空间


SectionListView 构造函数

初始化 SectionListView 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListView()
Public Sub New
参见

引用

SectionListView 类


SectionListView 属性

SectionListView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindMode | 获取和设置绑定模式 (继承自 ListView。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | ColumnNum | 获取和设置列数 (继承自 ListView。)
公共属性 | DataMember | 获取或设置数据源名称 (继承自 ListView。)
公共属性 | DataSource | 获取或设置表格数据源 (继承自 ListView。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FooterControl | 获取和设置页脚控件 (继承自 ListView。)
公共属性 | FooterControlName | 获取和设置页脚控件布局 (继承自 ListView。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HeaderControl | 获取和设置页眉控件 (继承自 ListView。)
公共属性 | HeaderControlName | 获取和设置页眉控件布局 (继承自 ListView。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动 (继承自 ListView。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | (继承自 ListView。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (继承自 ListView。)
公共属性 | PageSize | (重写 ListViewPageSize.)
公共属性 | PageSizeBackColor | (重写 ListViewPageSizeBackColor.)
公共属性 | PageSizeLoadCompleteText | (重写 ListViewPageSizeLoadCompleteText.)
公共属性 | PageSizeLoadMode | 获取和设置PageSize加载模式 (继承自 ListView。)
公共属性 | PageSizeLoadText | (重写 ListViewPageSizeLoadText.)
公共属性 | PageSizeTextColor | (重写 ListViewPageSizeTextColor.)
公共属性 | PageSizeTextHeight | (重写 ListViewPageSizeTextHeight.)
公共属性 | PageSizeTextSize | (重写 ListViewPageSizeTextSize.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。 (继承自 ListView。)
公共属性 | RaiseReachEnd | 获取和设置是否可触发上划底部事件。 (继承自 ListView。)
公共属性 | RaiseRefresh | 获取和设置是否可触发下拉刷新事件。 (继承自 ListView。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Rows | 获取列表行集合
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示是否启用容器滚动。 (继承自 ListView。)
公共属性 | SectionControl | 获取和设置页眉区域控件
公共属性 | SectionControlName | 获取和设置区域控件布局
公共属性 | SectionMember | 获取或设置区域数据源名称
公共属性 | Sections | 获取列表区域集合
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowSplitLine | 获取和设置一个值，该值指示是否显示单元格之间的分隔线 (继承自 ListView。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | SplitLineColor | 获取和设置单元格之间的分隔线颜色 (继承自 ListView。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateControl | 获取和设置模板控件。 (继承自 ListView。)
公共属性 | TemplateControlName | 获取和设置模板控件名称 (继承自 ListView。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SectionListView 类


SectionListView.PageSize 属性

SectionListViewPageSize 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int PageSize { get; set; }
Public Overrides Property PageSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SectionListView 类


SectionListView.PageSizeBackColor 属性

SectionListViewPageSizeBackColor 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeBackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Color PageSizeBackColor { get; set; }
Public Overrides Property PageSizeBackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SectionListView 类


SectionListView.PageSizeLoadCompleteText 属性

SectionListViewPageSizeLoadCompleteText 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeLoadCompleteText" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string PageSizeLoadCompleteText { get; set; }
Public Overrides Property PageSizeLoadCompleteText As String
    Get
    Set

属性值

类型：String
参见

引用

SectionListView 类


SectionListView.PageSizeLoadText 属性

SectionListViewPageSizeLoadText 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeLoadText" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string PageSizeLoadText { get; set; }
Public Overrides Property PageSizeLoadText As String
    Get
    Set

属性值

类型：String
参见

引用

SectionListView 类


SectionListView.PageSizeTextColor 属性

SectionListViewPageSizeTextColor 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeTextColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Color PageSizeTextColor { get; set; }
Public Overrides Property PageSizeTextColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SectionListView 类


SectionListView.PageSizeTextHeight 属性

SectionListViewPageSizeTextHeight 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeTextHeight" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int PageSizeTextHeight { get; set; }
Public Overrides Property PageSizeTextHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SectionListView 类


SectionListView.PageSizeTextSize 属性

SectionListViewPageSizeTextSize 属性

[缺少 "P:Swebui.Controls.SectionListView.PageSizeTextSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override float PageSizeTextSize { get; set; }
Public Overrides Property PageSizeTextSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

SectionListView 类


SectionListView.Rows 属性

SectionListViewRows 属性

获取列表行集合

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRowCollection Rows { get; }
Public ReadOnly Property Rows As SectionListViewRowCollection
    Get

返回值

类型：SectionListViewRowCollection
参见

引用

SectionListView 类


SectionListView.SectionControl 属性

SectionListViewSectionControl 属性

获取和设置页眉区域控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl SectionControl { get; set; }
Public Property SectionControl As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl
参见

引用

SectionListView 类


SectionListView.SectionControlName 属性

SectionListViewSectionControlName 属性

获取和设置区域控件布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string SectionControlName { get; set; }
Public Property SectionControlName As String
    Get
    Set

返回值

类型：String
备注
仅在窗体第一次或重新载入时生效，如果设置了SectionControl，那么设置此属性无效
参见

引用

SectionListView 类


SectionListView.SectionMember 属性

SectionListViewSectionMember 属性

获取或设置区域数据源名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string SectionMember { get; set; }
Public Property SectionMember As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

SectionListView 类


SectionListView.Sections 属性

SectionListViewSections 属性

获取列表区域集合

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSectionCollection Sections { get; }
Public ReadOnly Property Sections As ListViewSectionCollection
    Get

返回值

类型：ListViewSectionCollection
参见

引用

SectionListView 类


SectionListView 方法

SectionListView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AutoScroll | (继承自 ListView。)
公共方法 | DataBind | (重写 ListViewDataBind(Object).)
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | NewRow | 添加行
公共方法 | NewRow(Object) | 添加行
公共方法 | NewRow(String) | 添加列表行。
公共方法 | NewRow(String, Object) | 添加列表行。
公共方法 | NewRow(Object, String, Object) | 添加行
公共方法 | NewRow(String, Object, String, Object) | 添加列表行。
公共方法 | NewSection(String) | 添加列表区域
公共方法 | NewSection(String, Object) | 添加列表区域
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
受保护的方法 | OnDataSourceUpdate | (继承自 ListView。)
公共方法 | ScrollTo | 滚动到指定位置 (继承自 ListView。)
公共方法 | ScrollToIndex | 不支持的方法 (重写 ListViewScrollToIndex(Int32).)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll | (继承自 ListView。)
公共方法 | UpdateRow | 更新行。 (继承自 ListView。)
Top
参见

引用

SectionListView 类


SectionListView.DataBind 方法

SectionListViewDataBind 方法

[缺少 "M:Swebui.Controls.SectionListView.DataBind(System.Object[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override void DataBind(
    params Object[] params
)
Public Overrides Sub DataBind (
    ParamArray params As Object()
)

参数

params
类型：SystemObject

[缺少 "M:Swebui.Controls.SectionListView.DataBind(System.Object[])" 的 <param name="params"/> 文档]

参见

引用

SectionListView 类


SectionListView.NewRow 方法

SectionListViewNewRow 方法

重载列表
 | 名称 | 说明
公共方法 | NewRow | 添加行
公共方法 | NewRow(Object) | 添加行
公共方法 | NewRow(String) | 添加列表行。
公共方法 | NewRow(String, Object) | 添加列表行。
公共方法 | NewRow(Object, String, Object) | 添加行
公共方法 | NewRow(String, Object, String, Object) | 添加列表行。
Top
参见

引用

SectionListView 类


SectionListView.NewRow 方法

SectionListViewNewRow 方法

添加行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow NewRow()
Public Function NewRow As SectionListViewRow

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewRow 方法 (Object[])

SectionListViewNewRow 方法 (Object)

添加行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow NewRow(
    params Object[] params
)
Public Function NewRow (
    ParamArray params As Object()
) As SectionListViewRow

参数

params
类型：SystemObject
模板参数

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.Object[])" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewRow 方法 (String)

SectionListViewNewRow 方法 (String)

添加列表行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow NewRow(
    string sectionId
)
Public Function NewRow (
    sectionId As String
) As SectionListViewRow

参数

sectionId
类型：SystemString

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.String)" 的 <param name="sectionId"/> 文档]

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.String)" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewRow 方法 (String, Object[])

SectionListViewNewRow 方法 (String, Object)

添加列表行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow NewRow(
    string sectionId,
    params Object[] params
)
Public Function NewRow (
    sectionId As String,
    ParamArray params As Object()
) As SectionListViewRow

参数

sectionId
类型：SystemString

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.String,System.Object[])" 的 <param name="sectionId"/> 文档]

params
类型：SystemObject
模板参数

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.String,System.Object[])" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewRow 方法 (Object, String, Object[])

SectionListViewNewRow 方法 (Object, String, Object)

添加行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow[] NewRow(
    Object dataSource,
    string dataMember,
    params Object[] params
)
Public Function NewRow (
    dataSource As Object,
    dataMember As String,
    ParamArray params As Object()
) As SectionListViewRow()

参数

dataSource
类型：SystemObject
数据源
dataMember
类型：SystemString
数据源名称
params
类型：SystemObject
模板参数

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.Object,System.String,System.Object[])" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewRow 方法 (String, Object, String, Object[])

SectionListViewNewRow 方法 (String, Object, String, Object)

添加列表行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow[] NewRow(
    string sectionId,
    Object dataSource,
    string dataMember,
    params Object[] params
)
Public Function NewRow (
    sectionId As String,
    dataSource As Object,
    dataMember As String,
    ParamArray params As Object()
) As SectionListViewRow()

参数

sectionId
类型：SystemString
列表区域编号
dataSource
类型：SystemObject
数据源
dataMember
类型：SystemString
数据源名称
params
类型：SystemObject
模板参数

返回值

类型：SectionListViewRow

[缺少 "M:Swebui.Controls.SectionListView.NewRow(System.String,System.Object,System.String,System.Object[])" 的 <returns> 文档]

参见

引用

SectionListView 类
NewRow 重载


SectionListView.NewSection 方法

SectionListViewNewSection 方法

重载列表
 | 名称 | 说明
公共方法 | NewSection(String) | 添加列表区域
公共方法 | NewSection(String, Object) | 添加列表区域
Top
参见

引用

SectionListView 类


SectionListView.NewSection 方法 (String)

SectionListViewNewSection 方法 (String)

添加列表区域

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSection NewSection(
    string sectionId
)
Public Function NewSection (
    sectionId As String
) As ListViewSection

参数

sectionId
类型：SystemString
列表区域编号

返回值

类型：ListViewSection

[缺少 "M:Swebui.Controls.SectionListView.NewSection(System.String)" 的 <returns> 文档]

参见

引用

SectionListView 类
NewSection 重载


SectionListView.NewSection 方法 (String, Object[])

SectionListViewNewSection 方法 (String, Object)

添加列表区域

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSection NewSection(
    string sectionId,
    params Object[] params
)
Public Function NewSection (
    sectionId As String,
    ParamArray params As Object()
) As ListViewSection

参数

sectionId
类型：SystemString
列表区域编号
params
类型：SystemObject
模板参数

返回值

类型：ListViewSection

[缺少 "M:Swebui.Controls.SectionListView.NewSection(System.String,System.Object[])" 的 <returns> 文档]

参见

引用

SectionListView 类
NewSection 重载


SectionListView.ScrollToIndex 方法

SectionListViewScrollToIndex 方法

不支持的方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override void ScrollToIndex(
    int index
)
Public Overrides Sub ScrollToIndex (
    index As Integer
)

参数

index
类型：SystemInt32
索引
参见

引用

SectionListView 类


SectionListView 事件

SectionListView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | DataSourceUpdate | 在更新数据源时发生。 (继承自 ListView。)
公共事件 | PositionChanged | 在位置变化时发生。 (继承自 ListView。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在上划到底部时发生。 (继承自 ListView。)
公共事件 | Refresh | 在用户下拉刷新时发生。 (继承自 ListView。)
公共事件 | RowBind | 在行绑定后发生。 (继承自 ListView。)
公共事件 | RowBinding | 在行绑定时发生。 (继承自 ListView。)
Top
参见

引用

SectionListView 类


SectionListView.ListViewSectionCollectionOwner 类

SectionListViewListViewSectionCollectionOwner 类

[缺少 "T:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSectionListViewListViewSectionCollectionOwner

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ListViewSectionCollectionOwner : ISwebViewCollectionOwner
Public Class ListViewSectionCollectionOwner
    Implements ISwebViewCollectionOwner

SectionListViewListViewSectionCollectionOwner 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SectionListViewListViewSectionCollectionOwner | 初始化 SectionListViewListViewSectionCollectionOwner 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

Swebui.Controls 命名空间


SectionListView.ListViewSectionCollectionOwner 构造函数

SectionListViewListViewSectionCollectionOwner 构造函数

初始化 SectionListViewListViewSectionCollectionOwner 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ListViewSectionCollectionOwner(
    SectionListView owner
)
Public Sub New (
    owner As SectionListView
)

参数

owner
类型：Swebui.ControlsSectionListView

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.#ctor(Swebui.Controls.SectionListView)" 的 <param name="owner"/> 文档]

参见

引用

SectionListViewListViewSectionCollectionOwner 类


ListViewSectionCollectionOwner 方法

SectionListViewListViewSectionCollectionOwner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListView.ListViewSectionCollectionOwner.ItemAdd 方法

SectionListViewListViewSectionCollectionOwnerItemAdd 方法

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListView.ListViewSectionCollectionOwner.ItemClear 方法

SectionListViewListViewSectionCollectionOwnerItemClear 方法

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListView.ListViewSectionCollectionOwner.ItemPropertyChanged 方法

SectionListViewListViewSectionCollectionOwnerItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListView.ListViewSectionCollectionOwner.ItemRemove 方法

SectionListViewListViewSectionCollectionOwnerItemRemove 方法

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListView.ListViewSectionCollectionOwner.Refresh 方法

SectionListViewListViewSectionCollectionOwnerRefresh 方法

[缺少 "M:Swebui.Controls.SectionListView.ListViewSectionCollectionOwner.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

SectionListViewListViewSectionCollectionOwner 类


SectionListViewRow 类

区域列表行
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsListViewRow
Swebui.ControlsSectionListViewRow

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SectionListViewRow : ListViewRow
Public Class SectionListViewRow
    Inherits ListViewRow

SectionListViewRow 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SectionListViewRow | 初始化 SectionListViewRow 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取和设置区域编号 (重写 ListViewRowSectionID.)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

Swebui.Controls 命名空间


SectionListViewRow 构造函数

初始化 SectionListViewRow 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRow()
Public Sub New
参见

引用

SectionListViewRow 类


SectionListViewRow 属性

SectionListViewRow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | SectionID | 获取和设置区域编号 (重写 ListViewRowSectionID.)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

SectionListViewRow 类


SectionListViewRow.SectionID 属性

SectionListViewRowSectionID 属性

获取和设置区域编号

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string SectionID { get; set; }
Public Overrides Property SectionID As String
    Get
    Set

返回值

类型：String
备注
在被添加到一个区域中时，只能设置一次区域编号
参见

引用

SectionListViewRow 类


SectionListViewRow 方法

SectionListViewRow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

SectionListViewRow 类


SectionListViewRowCollection 类

列表区域集合
继承层次
SystemObject
Swebui.ControlsSwebViewCollection SectionListViewRow
Swebui.ControlsSectionListViewRowCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SectionListViewRowCollection : SwebViewCollection<SectionListViewRow>
Public Class SectionListViewRowCollection
    Inherits SwebViewCollection(Of SectionListViewRow)

SectionListViewRowCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SectionListViewRowCollection | 初始化 SectionListViewRowCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

Swebui.Controls 命名空间


SectionListViewRowCollection 构造函数

初始化 SectionListViewRowCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SectionListViewRowCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.SectionListViewRowCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

SectionListViewRowCollection 类


SectionListViewRowCollection 属性

SectionListViewRowCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数 (继承自 SwebViewCollectionT。)
公共属性 | IsReadOnly | 获取元素是否只读 (继承自 SwebViewCollectionT。)
公共属性 | Item | 获取和设置指定索引位置的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

SectionListViewRowCollection 类


SectionListViewRowCollection 方法

SectionListViewRowCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中 (继承自 SwebViewCollectionT。)
公共方法 | Clear | 移除所有元素 (继承自 SwebViewCollectionT。)
公共方法 | Contains | 是否包含指定的元素 (继承自 SwebViewCollectionT。)
公共方法 | CopyTo | 复制元素到指定的集合中 (继承自 SwebViewCollectionT。)
公共方法 | GetEnumerator | 获取枚举器 (继承自 SwebViewCollectionT。)
公共方法 | IndexOf | 获取指定元素的索引 (继承自 SwebViewCollectionT。)
公共方法 | Refresh | 刷新元素 (继承自 SwebViewCollectionT。)
公共方法 | Remove | 移除指定元素 (继承自 SwebViewCollectionT。)
公共方法 | RemoveAt | 移除指定索引的元素 (继承自 SwebViewCollectionT。)
Top
参见

引用

SectionListViewRowCollection 类


SegmentedControl 类

单元控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSegmentedControl

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class SegmentedControl : SwebControl,
    ISwebRenderControl, ISwebEventControl
Public Class SegmentedControl
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl

SegmentedControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SegmentedControl | 初始化SegmentedControl类的一个新实例
Top
属性
名称 | 说明
公共属性 Animation
获取和设置动画
(继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 Bottom
获取和设置控件下边缘距离父控件的距离。
(继承自 SwebControl。)
公共属性 Bounds
获取或设置控件（包括其非工作区元素）的大小和位置。
(继承自 SwebControl。)
公共属性 DesignStyle
获取和设置包括有关控件的样式
(继承自 SwebControlBase。)
公共属性 Enabled
获取或设置一个值，该值指示是否已启用该控件
公共属性 Flex
获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。
(继承自 SwebControl。)
公共属性 Form
获取控件所属的窗体
(继承自 SwebControlBase。)
公共属性 Height
获取或设置控件的高度。
(继承自 SwebControl。)
公共属性 InvokeRequired
获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。
(继承自 SwebControlBase。)
公共属性 IsLoaded
获取一个值，该值表示当前窗口 SwebForm 是否已经载入。
(继承自 SwebControlBase。)
公共属性 Items
获取和设置单元格集合
公共属性 LayoutPercentage
获取和设置布局百分比
(继承自 SwebControl。)
公共属性 Left
获取或设置控件距离容器控件左边缘的 x 坐标。
(继承自 SwebControl。)
公共属性 Location
获取或设置该控件的左上角相对于其容器的左上角的坐标。
(继承自 SwebControl。)
公共属性 LowerLocation
获取或设置该控件的右下角相对于其容器的右下角的坐标
(继承自 SwebControl。)
公共属性 Margin
获取或设置控件边框与边框外控件间隔距离
(继承自 SwebControl。)
公共属性 MaxHeightRate
获取和设置控件最大高度比例
(继承自 SwebControl。)
公共属性 MinHeightRate
获取和设置控件最小高度比例
(继承自 SwebControl。)
公共属性 Name
获取或设置控件的名称。
(继承自 SwebControlBase。)
公共属性 Owner
获取或设置控件的布局控件SwebLayoutControl。
(继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 Parent
获取或设置控件的父控件SwebContainerControl。
(继承自 SwebControlBase。)
公共属性 Portrait
获取和设置一个值，该值指示是否竖向排列。

字段值

类型：
true 竖向排列，false 横向排列，默认false
公共属性 Position
获取和设置布局
(继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 Right
获取和设置控件右边缘距离父控件的距离。
(继承自 SwebControl。)
公共属性 SegmentedBorderRadius
获取和设置节点角度。
公共属性 SelectedBackColor
获取和设置节点选中背景颜色。
公共属性 SelectedColor
获取和设置节点选中前景颜色。
公共属性 SelectedFontSize
获取和设置节点选中字体大小。
公共属性 SelectedIndex
获取和设置选择单元索引
公共属性 SelectedItem
获取选择单元
公共属性 SelfAlign
获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。
(继承自 SwebControl。)
公共属性 SelfLayout
获取和设置控件自身布局。
(继承自 SwebControl。)
公共属性 Size
获取或设置控件的高度和宽度。
(继承自 SwebControl。)
公共属性 TabIndex
获取或设置在控件的容器的控件的 Tab 键顺序。
(继承自 SwebControl。)
公共属性 Tag
获取或设置包含有关控件的数据的对象。
(继承自 SwebControlBase。)
公共属性 Top
获取或设置控件的上边缘的 y 坐标。
(继承自 SwebControl。)
公共属性 UnSelectedBackColor
获取和设置节点未选择背景颜色。
公共属性 UnSelectedColor
获取和设置未节点选择前景颜色。
公共属性 UnSelectedFontSize
获取和设置节点选择字体大小。
公共属性 Visible
获取或设置一个值，该值指示是否显示该控件。
(继承自 SwebControl。)
公共属性 Width
获取或设置控件的宽度。
(继承自 SwebControl。)
公共属性 ZIndex
获取和设置一个值，该值表示在Z轴上的显示顺序。
(继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 选择单元改变时触发回调
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | SelectedIndexChanged | 在单元选择改变时触发。
Top
参见

引用

Swebui.Controls 命名空间


SegmentedControl 构造函数

初始化SegmentedControl类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SegmentedControl()
Public Sub New
参见

引用

SegmentedControl 类


SegmentedControl 属性

SegmentedControl 类型公开以下成员。

属性
名称 | 说明
公共属性 Animation
获取和设置动画
(继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 Bottom
获取和设置控件下边缘距离父控件的距离。
(继承自 SwebControl。)
公共属性 Bounds
获取或设置控件（包括其非工作区元素）的大小和位置。
(继承自 SwebControl。)
公共属性 DesignStyle
获取和设置包括有关控件的样式
(继承自 SwebControlBase。)
公共属性 Enabled
获取或设置一个值，该值指示是否已启用该控件
公共属性 Flex
获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。
(继承自 SwebControl。)
公共属性 Form
获取控件所属的窗体
(继承自 SwebControlBase。)
公共属性 Height
获取或设置控件的高度。
(继承自 SwebControl。)
公共属性 InvokeRequired
获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。
(继承自 SwebControlBase。)
公共属性 IsLoaded
获取一个值，该值表示当前窗口 SwebForm 是否已经载入。
(继承自 SwebControlBase。)
公共属性 Items
获取和设置单元格集合
公共属性 LayoutPercentage
获取和设置布局百分比
(继承自 SwebControl。)
公共属性 Left
获取或设置控件距离容器控件左边缘的 x 坐标。
(继承自 SwebControl。)
公共属性 Location
获取或设置该控件的左上角相对于其容器的左上角的坐标。
(继承自 SwebControl。)
公共属性 LowerLocation
获取或设置该控件的右下角相对于其容器的右下角的坐标
(继承自 SwebControl。)
公共属性 Margin
获取或设置控件边框与边框外控件间隔距离
(继承自 SwebControl。)
公共属性 MaxHeightRate
获取和设置控件最大高度比例
(继承自 SwebControl。)
公共属性 MinHeightRate
获取和设置控件最小高度比例
(继承自 SwebControl。)
公共属性 Name
获取或设置控件的名称。
(继承自 SwebControlBase。)
公共属性 Owner
获取或设置控件的布局控件SwebLayoutControl。
(继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 Parent
获取或设置控件的父控件SwebContainerControl。
(继承自 SwebControlBase。)
公共属性 Portrait
获取和设置一个值，该值指示是否竖向排列。

字段值

类型：
true 竖向排列，false 横向排列，默认false
公共属性 Position
获取和设置布局
(继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 Right
获取和设置控件右边缘距离父控件的距离。
(继承自 SwebControl。)
公共属性 SegmentedBorderRadius
获取和设置节点角度。
公共属性 SelectedBackColor
获取和设置节点选中背景颜色。
公共属性 SelectedColor
获取和设置节点选中前景颜色。
公共属性 SelectedFontSize
获取和设置节点选中字体大小。
公共属性 SelectedIndex
获取和设置选择单元索引
公共属性 SelectedItem
获取选择单元
公共属性 SelfAlign
获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。
(继承自 SwebControl。)
公共属性 SelfLayout
获取和设置控件自身布局。
(继承自 SwebControl。)
公共属性 Size
获取或设置控件的高度和宽度。
(继承自 SwebControl。)
公共属性 TabIndex
获取或设置在控件的容器的控件的 Tab 键顺序。
(继承自 SwebControl。)
公共属性 Tag
获取或设置包含有关控件的数据的对象。
(继承自 SwebControlBase。)
公共属性 Top
获取或设置控件的上边缘的 y 坐标。
(继承自 SwebControl。)
公共属性 UnSelectedBackColor
获取和设置节点未选择背景颜色。
公共属性 UnSelectedColor
获取和设置未节点选择前景颜色。
公共属性 UnSelectedFontSize
获取和设置节点选择字体大小。
公共属性 Visible
获取或设置一个值，该值指示是否显示该控件。
(继承自 SwebControl。)
公共属性 Width
获取或设置控件的宽度。
(继承自 SwebControl。)
公共属性 ZIndex
获取和设置一个值，该值表示在Z轴上的显示顺序。
(继承自 SwebControl。)
Top
参见

引用

SegmentedControl 类


SegmentedControl.BackColor 属性

SegmentedControlBackColor 属性

[缺少 "P:Swebui.Controls.SegmentedControl.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.Border 属性

SegmentedControlBorder 属性

[缺少 "P:Swebui.Controls.SegmentedControl.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

SegmentedControl 类


SegmentedControl.BorderColor 属性

SegmentedControlBorderColor 属性

[缺少 "P:Swebui.Controls.SegmentedControl.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.BorderRadius 属性

SegmentedControlBorderRadius 属性

[缺少 "P:Swebui.Controls.SegmentedControl.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SegmentedControl 类


SegmentedControl.BorderStyle 属性

SegmentedControlBorderStyle 属性

[缺少 "P:Swebui.Controls.SegmentedControl.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

SegmentedControl 类


SegmentedControl.Enabled 属性

SegmentedControlEnabled 属性

获取或设置一个值，该值指示是否已启用该控件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SegmentedControl 类


SegmentedControl.Items 属性

SegmentedControlItems 属性

获取和设置单元格集合

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Items { get; set; }
Public Property Items As String()
    Get
    Set

属性值

类型：String
参见

引用

SegmentedControl 类


SegmentedControl.Padding 属性

SegmentedControlPadding 属性

[缺少 "P:Swebui.Controls.SegmentedControl.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

SegmentedControl 类


SegmentedControl.Portrait 属性

SegmentedControlPortrait 属性

获取和设置一个值，该值指示是否竖向排列。

属性值

类型：Boolean
true 竖向排列，false 横向排列，默认false

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Portrait { get; set; }
Public Property Portrait As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SegmentedControl 类


SegmentedControl.SegmentedBorderRadius 属性

SegmentedControlSegmentedBorderRadius 属性

获取和设置节点角度。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int SegmentedBorderRadius { get; set; }
Public Property SegmentedBorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SegmentedControl 类


SegmentedControl.SelectedBackColor 属性

SegmentedControlSelectedBackColor 属性

获取和设置节点选中背景颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectedBackColor { get; set; }
Public Property SelectedBackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.SelectedColor 属性

SegmentedControlSelectedColor 属性

获取和设置节点选中前景颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.SelectedFontSize 属性

SegmentedControlSelectedFontSize 属性

获取和设置节点选中字体大小。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float SelectedFontSize { get; set; }
Public Property SelectedFontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

SegmentedControl 类


SegmentedControl.SelectedIndex 属性

SegmentedControlSelectedIndex 属性

获取和设置选择单元索引

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int SelectedIndex { get; set; }
Public Property SelectedIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SegmentedControl 类


SegmentedControl.SelectedItem 属性

SegmentedControlSelectedItem 属性

获取选择单元

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string SelectedItem { get; }
Public ReadOnly Property SelectedItem As String
    Get

属性值

类型：String
参见

引用

SegmentedControl 类


SegmentedControl.UnSelectedBackColor 属性

SegmentedControlUnSelectedBackColor 属性

获取和设置节点未选择背景颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color UnSelectedBackColor { get; set; }
Public Property UnSelectedBackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.UnSelectedColor 属性

SegmentedControlUnSelectedColor 属性

获取和设置未节点选择前景颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color UnSelectedColor { get; set; }
Public Property UnSelectedColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SegmentedControl 类


SegmentedControl.UnSelectedFontSize 属性

SegmentedControlUnSelectedFontSize 属性

获取和设置节点选择字体大小。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float UnSelectedFontSize { get; set; }
Public Property UnSelectedFontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

SegmentedControl 类


SegmentedControl 方法

SegmentedControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised | 选择单元改变时触发回调
Top
参见

引用

SegmentedControl 类


SegmentedControl.OnEventRaised 方法

SegmentedControlOnEventRaised 方法

选择单元改变时触发回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.SegmentedControl.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

SegmentedControl 类


SegmentedControl 事件

SegmentedControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | SelectedIndexChanged | 在单元选择改变时触发。
Top
参见

引用

SegmentedControl 类


SegmentedControl.SelectedIndexChanged 事件

SegmentedControlSelectedIndexChanged 事件

在单元选择改变时触发。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler SelectedIndexChanged
Public Event SelectedIndexChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

SegmentedControl 类


ShadowPropertyChangedArgs 类

ShadowPropertyChangedArgs
继承层次
SystemObject
Swebui.ControlsShadowPropertyChangedArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class ShadowPropertyChangedArgs
Public Class ShadowPropertyChangedArgs

ShadowPropertyChangedArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ShadowPropertyChangedArgs | Constructor
Top
属性
 | 名称 | 说明
公共属性 | PreValue | Get PreValue
公共属性 | ShadowProperty | Get ShadowProperty
Top
参见

引用

Swebui.Controls 命名空间


ShadowPropertyChangedArgs 构造函数

Constructor

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ShadowPropertyChangedArgs(
    SwebShadowProperty shadownProperty,
    Object preValue
)
Public Sub New (
    shadownProperty As SwebShadowProperty,
    preValue As Object
)

参数

shadownProperty
类型：Swebui.ControlsSwebShadowProperty

[缺少 "M:Swebui.Controls.ShadowPropertyChangedArgs.#ctor(Swebui.Controls.SwebShadowProperty,System.Object)" 的 <param name="shadownProperty"/> 文档]

preValue
类型：SystemObject

[缺少 "M:Swebui.Controls.ShadowPropertyChangedArgs.#ctor(Swebui.Controls.SwebShadowProperty,System.Object)" 的 <param name="preValue"/> 文档]

参见

引用

ShadowPropertyChangedArgs 类


ShadowPropertyChangedArgs 属性

ShadowPropertyChangedArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PreValue | Get PreValue
公共属性 | ShadowProperty | Get ShadowProperty
Top
参见

引用

ShadowPropertyChangedArgs 类


ShadowPropertyChangedArgs.PreValue 属性

ShadowPropertyChangedArgsPreValue 属性

Get PreValue

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object PreValue { get; }
Public ReadOnly Property PreValue As Object
    Get

返回值

类型：Object
参见

引用

ShadowPropertyChangedArgs 类


ShadowPropertyChangedArgs.ShadowProperty 属性

ShadowPropertyChangedArgsShadowProperty 属性

Get ShadowProperty

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebShadowProperty ShadowProperty { get; }
Public ReadOnly Property ShadowProperty As SwebShadowProperty
    Get

返回值

类型：SwebShadowProperty
参见

引用

ShadowPropertyChangedArgs 类


ShowResult 枚举

指定标识符以指示的返回值。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ShowResult
Public Enumeration ShowResult
成员
成员名称 | 值 | 说明
Abort | 0 | 返回值是 Abort（通常由标签为“中止”的按钮发送）。
Cancel | 1 | 返回值是 Cancel（通常由标签为“取消”的按钮发送）。
Ignore | 2 | 返回值是 Ignore（通常由标签为“忽略”的按钮发送）。
No | 3 | 返回值是 No（通常由标签为“否”的按钮发送）。
None | 4 | 返回了 Nothing。
OK | 5 | 返回值是 OK（通常由标签为“确定”的按钮发送）。
Retry | 6 | 返回值是 Retry（通常由标签为“重试”的按钮发送）。
Yes | 7 | 返回值是 Yes（通常由标签为“是”的按钮发送）。
备注
MessageBox.ShowResult 属性和 Form.ShowResult 方法使用此枚举。
参见

引用

Swebui.Controls 命名空间


SignatureView 类

签字控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsSignatureView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class SignatureView : SwebNativeControl,
    ISwebEventControl
Public Class SignatureView
    Inherits SwebNativeControl
    Implements ISwebEventControl

SignatureView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SignatureView | 初始化SignatureView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | StrokeColor | 获取与设置线条颜色
公共属性 | StrokeWidth | 获取与设置线条粗细
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | Clear | 清除
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
公共方法 | Save | 保存
Top
事件
 | 名称 | 说明
公共事件 | OnSignatureImageSave | 在客户端返回签字数据时发生
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SignatureView 构造函数

初始化SignatureView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SignatureView()
Public Sub New
参见

引用

SignatureView 类


SignatureView 属性

SignatureView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | StrokeColor | 获取与设置线条颜色
公共属性 | StrokeWidth | 获取与设置线条粗细
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SignatureView 类


SignatureView.StrokeColor 属性

SignatureViewStrokeColor 属性

获取与设置线条颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color StrokeColor { get; set; }
Public Property StrokeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SignatureView 类


SignatureView.StrokeWidth 属性

SignatureViewStrokeWidth 属性

获取与设置线条粗细

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float StrokeWidth { get; set; }
Public Property StrokeWidth As Single
    Get
    Set

属性值

类型：Single
参见

引用

SignatureView 类


SignatureView 方法

SignatureView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clear | 清除
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
公共方法 | Save | 保存
Top
参见

引用

SignatureView 类


SignatureView.Clear 方法

SignatureViewClear 方法

清除

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Clear()
Public Sub Clear
参见

引用

SignatureView 类


SignatureView.OnEventRaised 方法

SignatureViewOnEventRaised 方法

[缺少 "M:Swebui.Controls.SignatureView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.SignatureView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

SignatureView 类


SignatureView.Save 方法

SignatureViewSave 方法

保存

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Save()
Public Sub Save
参见

引用

SignatureView 类


SignatureView 事件

SignatureView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | OnSignatureImageSave | 在客户端返回签字数据时发生
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SignatureView 类


SignatureView.OnSignatureImageSave 事件

SignatureViewOnSignatureImageSave 事件

在客户端返回签字数据时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event BinaryResultCallBackHandler OnSignatureImageSave
Public Event OnSignatureImageSave As BinaryResultCallBackHandler

值

类型：Swebui.ControlsBinaryResultCallBackHandler
参见

引用

SignatureView 类


Slide 类

滚动条控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSlide

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Slide : SwebBindableControl, ISwebRenderControl,
    ISwebEventControl
Public Class Slide
    Inherits SwebBindableControl
    Implements ISwebRenderControl, ISwebEventControl

Slide 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Slide | 初始化 Slide 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enable | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HandleColor | 获取和设置滑块颜色。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxValue | 获取和设置滚动条最大值。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MinValue | 获取和设置滚动条最小值。
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | Step | 获取和设置滚动条移动最小值。
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | TrackColor | 获取和设置滚动条颜色。
公共属性 | Value | 获取和设置滚动条值。
公共属性 | ValueColor | 获取和设置进度颜色。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在滚动条值改变时发生。
Top
参见

引用

Swebui.Controls 命名空间


Slide 构造函数

初始化 Slide 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Slide()
Public Sub New
参见

引用

Slide 类


Slide 属性

Slide 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enable | 获取或设置一个值，该值指示是否已启用该控件。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | HandleColor | 获取和设置滑块颜色。
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxValue | 获取和设置滚动条最大值。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MinValue | 获取和设置滚动条最小值。
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | Step | 获取和设置滚动条移动最小值。
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | TrackColor | 获取和设置滚动条颜色。
公共属性 | Value | 获取和设置滚动条值。
公共属性 | ValueColor | 获取和设置进度颜色。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Slide 类


Slide.BackColor 属性

SlideBackColor 属性

[缺少 "P:Swebui.Controls.Slide.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Slide 类


Slide.BindDisplayValue 属性

SlideBindDisplayValue 属性

[缺少 "P:Swebui.Controls.Slide.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

Slide 类


Slide.Border 属性

SlideBorder 属性

[缺少 "P:Swebui.Controls.Slide.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

Slide 类


Slide.BorderColor 属性

SlideBorderColor 属性

[缺少 "P:Swebui.Controls.Slide.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Slide 类


Slide.BorderRadius 属性

SlideBorderRadius 属性

[缺少 "P:Swebui.Controls.Slide.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Slide 类


Slide.BorderStyle 属性

SlideBorderStyle 属性

[缺少 "P:Swebui.Controls.Slide.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

Slide 类


Slide.Enable 属性

SlideEnable 属性

获取或设置一个值，该值指示是否已启用该控件。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Enable { get; set; }
Public Property Enable As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

Slide 类


Slide.HandleColor 属性

SlideHandleColor 属性

获取和设置滑块颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color HandleColor { get; set; }
Public Property HandleColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Slide 类


Slide.MaxValue 属性

SlideMaxValue 属性

获取和设置滚动条最大值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float MaxValue { get; set; }
Public Property MaxValue As Single
    Get
    Set

属性值

类型：Single
参见

引用

Slide 类


Slide.MinValue 属性

SlideMinValue 属性

获取和设置滚动条最小值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float MinValue { get; set; }
Public Property MinValue As Single
    Get
    Set

属性值

类型：Single
参见

引用

Slide 类


Slide.Padding 属性

SlidePadding 属性

[缺少 "P:Swebui.Controls.Slide.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

Slide 类


Slide.Step 属性

SlideStep 属性

获取和设置滚动条移动最小值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Step { get; set; }
Public Property Step As Single
    Get
    Set

属性值

类型：Single
参见

引用

Slide 类


Slide.TrackColor 属性

SlideTrackColor 属性

获取和设置滚动条颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TrackColor { get; set; }
Public Property TrackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Slide 类


Slide.Value 属性

SlideValue 属性

获取和设置滚动条值。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float Value { get; set; }
Public Property Value As Single
    Get
    Set

属性值

类型：Single
参见

引用

Slide 类


Slide.ValueColor 属性

SlideValueColor 属性

获取和设置进度颜色。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ValueColor { get; set; }
Public Property ValueColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Slide 类


Slide 方法

Slide 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Slide 类


Slide 事件

Slide 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ValueChanged | 在滚动条值改变时发生。
Top
参见

引用

Slide 类


Slide.ValueChanged 事件

SlideValueChanged 事件

在滚动条值改变时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

Slide 类


SortOrderType 枚举

排序类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum SortOrderType
Public Enumeration SortOrderType
成员
成员名称 | 值 | 说明
None | 0 |
Ascending | 1 |
Descending | 2 |
参见

引用

Swebui.Controls 命名空间


StreamingType 枚举

流媒体类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum StreamingType
Public Enumeration StreamingType
成员
成员名称 | 值 | 说明
Media | 0 | 点播
Live | 1 | 直播
备注
参见

引用

Swebui.Controls 命名空间


StringArrayPropertyExtend 类

字符串数组属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsStringArrayPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class StringArrayPropertyExtend : SwebPropertyExtend
Public Class StringArrayPropertyExtend
    Inherits SwebPropertyExtend

StringArrayPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | StringArrayPropertyExtend | 初始化 StringArrayPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


StringArrayPropertyExtend 构造函数

初始化 StringArrayPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public StringArrayPropertyExtend()
Public Sub New
参见

引用

StringArrayPropertyExtend 类


Svg 类

SVG
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSvg

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Svg : SwebControl, ISwebRenderControl
Public Class Svg
    Inherits SwebControl
    Implements ISwebRenderControl

Svg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Svg | 初始化 Svg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Content | 获取与设置SVG内容
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Svg 构造函数

初始化 Svg 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Svg()
Public Sub New
参见

引用

Svg 类


Svg 属性

Svg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Content | 获取与设置SVG内容
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Svg 类


Svg.Content 属性

SvgContent 属性

获取与设置SVG内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Content { get; set; }
Public Property Content As String
    Get
    Set

属性值

类型：String
参见

引用

Svg 类


Svg 方法

Svg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Svg 类


Svg 事件

Svg 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Svg 类


SwebActionButton 类

[缺少 "T:Swebui.Controls.SwebActionButton" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebActionButton

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class SwebActionButton
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class SwebActionButton

SwebActionButton 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebActionButton | 初始化 SwebActionButton 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Active |
公共属性 | AutoInactive |
公共属性 | ButtonSpacing |
公共属性 | Enabled |
公共属性 | ImageSize |
公共属性 | Items |
公共属性 | ItemSize |
公共属性 | MainButton |
公共属性 | OffsetX |
公共属性 | OffsetY |
公共属性 | TouchOpacity |
Top
参见

引用

Swebui.Controls 命名空间


SwebActionButton 构造函数

初始化 SwebActionButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebActionButton(
    SwebForm form
)
Public Sub New (
    form As SwebForm
)

参数

form
类型：Swebui.ControlsSwebForm

[缺少 "M:Swebui.Controls.SwebActionButton.#ctor(Swebui.Controls.SwebForm)" 的 <param name="form"/> 文档]

参见

引用

SwebActionButton 类


SwebActionButton 属性

SwebActionButton 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Active |
公共属性 | AutoInactive |
公共属性 | ButtonSpacing |
公共属性 | Enabled |
公共属性 | ImageSize |
公共属性 | Items |
公共属性 | ItemSize |
公共属性 | MainButton |
公共属性 | OffsetX |
公共属性 | OffsetY |
公共属性 | TouchOpacity |
Top
参见

引用

SwebActionButton 类


SwebActionButton.Active 属性

SwebActionButtonActive 属性

[缺少 "P:Swebui.Controls.SwebActionButton.Active" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebActionButton 类


SwebActionButton.AutoInactive 属性

SwebActionButtonAutoInactive 属性

[缺少 "P:Swebui.Controls.SwebActionButton.AutoInactive" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool AutoInactive { get; set; }
Public Property AutoInactive As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebActionButton 类


SwebActionButton.ButtonSpacing 属性

SwebActionButtonButtonSpacing 属性

[缺少 "P:Swebui.Controls.SwebActionButton.ButtonSpacing" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ButtonSpacing { get; set; }
Public Property ButtonSpacing As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebActionButton.Enabled 属性

SwebActionButtonEnabled 属性

[缺少 "P:Swebui.Controls.SwebActionButton.Enabled" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebActionButton 类


SwebActionButton.ImageSize 属性

SwebActionButtonImageSize 属性

[缺少 "P:Swebui.Controls.SwebActionButton.ImageSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ImageSize { get; set; }
Public Property ImageSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebActionButton.Items 属性

SwebActionButtonItems 属性

[缺少 "P:Swebui.Controls.SwebActionButton.Items" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionButtonItemCollection Items { get; }
Public ReadOnly Property Items As ActionButtonItemCollection
    Get

属性值

类型：ActionButtonItemCollection
参见

引用

SwebActionButton 类


SwebActionButton.ItemSize 属性

SwebActionButtonItemSize 属性

[缺少 "P:Swebui.Controls.SwebActionButton.ItemSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int ItemSize { get; set; }
Public Property ItemSize As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebActionButton.MainButton 属性

SwebActionButtonMainButton 属性

[缺少 "P:Swebui.Controls.SwebActionButton.MainButton" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ActionMainButton MainButton { get; }
Public ReadOnly Property MainButton As ActionMainButton
    Get

属性值

类型：ActionMainButton
参见

引用

SwebActionButton 类


SwebActionButton.OffsetX 属性

SwebActionButtonOffsetX 属性

[缺少 "P:Swebui.Controls.SwebActionButton.OffsetX" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int OffsetX { get; set; }
Public Property OffsetX As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebActionButton.OffsetY 属性

SwebActionButtonOffsetY 属性

[缺少 "P:Swebui.Controls.SwebActionButton.OffsetY" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int OffsetY { get; set; }
Public Property OffsetY As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebActionButton.TouchOpacity 属性

SwebActionButtonTouchOpacity 属性

[缺少 "P:Swebui.Controls.SwebActionButton.TouchOpacity" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int TouchOpacity { get; set; }
Public Property TouchOpacity As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebActionButton 类


SwebBindableControl 类

数据绑定控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebBindableControl : SwebControl,
    ISwebDataBindableControl
Public MustInherit Class SwebBindableControl
    Inherits SwebControl
    Implements ISwebDataBindableControl

SwebBindableControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebBindableControl | 初始化 SwebBindableControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示
公共属性 | BindMode | 获取绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。
公共属性 | DisplayMember | 获取和设置显示绑定字段。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
 | SharedBindData | 数据绑定
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsBarcodeView
Swebui.ControlsButton
Swebui.ControlsChooseDatePicker
Swebui.ControlsDatePicker
Swebui.ControlsFontIcon
Swebui.ControlsImage
Swebui.ControlsProgress
Swebui.ControlsSlide
Swebui.ControlsSwebCheckedControlBase
Swebui.ControlsSwebTextControl


SwebBindableControl 构造函数

初始化 SwebBindableControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebBindableControl()
Public Sub New
参见

引用

SwebBindableControl 类


SwebBindableControl 属性

SwebBindableControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。
公共属性 | BindDisplayValue | 获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示
公共属性 | BindMode | 获取绑定模式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。
公共属性 | DisplayMember | 获取和设置显示绑定字段。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebBindableControl 类


SwebBindableControl.BindDataValue 属性

SwebBindableControlBindDataValue 属性

获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Object BindDataValue { get; set; }
Public Overridable Property BindDataValue As Object
    Get
    Set

返回值

类型：Object

实现

ISwebBindableControlBindDataValue
参见

引用

SwebBindableControl 类


SwebBindableControl.BindDisplayValue 属性

SwebBindableControlBindDisplayValue 属性

获取和设置一个值，该值用于指定根据 DisplayMember 做数据绑定时的值。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract Object BindDisplayValue { get; set; }
Public MustOverride Property BindDisplayValue As Object
    Get
    Set

返回值

类型：Object

实现

ISwebBindableControlBindDisplayValue
参见

引用

SwebBindableControl 类


SwebBindableControl.BindDisplayValueGone 属性

SwebBindableControlBindDisplayValueGone 属性

获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool BindDisplayValueGone { get; set; }
Public Property BindDisplayValueGone As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

SwebBindableControl 类


SwebBindableControl.BindMode 属性

SwebBindableControlBindMode 属性

获取绑定模式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DataBindMode BindMode { get; set; }
Public Property BindMode As DataBindMode
    Get
    Set

返回值

类型：DataBindMode

实现

ISwebDataBindableControlBindMode
参见

引用

SwebBindableControl 类


SwebBindableControl.DataMember 属性

SwebBindableControlDataMember 属性

获取和设置值绑定字段。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DataMember { get; set; }
Public Property DataMember As String
    Get
    Set

返回值

类型：String

实现

ISwebBindableControlDataMember
参见

引用

SwebBindableControl 类


SwebBindableControl.DisplayFormat 属性

SwebBindableControlDisplayFormat 属性

获取和设置根据 DisplayMember 做数据绑定时的格式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string DisplayFormat { get; set; }
Public Overridable Property DisplayFormat As String
    Get
    Set

返回值

类型：String

实现

ISwebBindableControlDisplayFormat
参见

引用

SwebBindableControl 类


SwebBindableControl.DisplayMember 属性

SwebBindableControlDisplayMember 属性

获取和设置显示绑定字段。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DisplayMember { get; set; }
Public Property DisplayMember As String
    Get
    Set

返回值

类型：String

实现

ISwebBindableControlDisplayMember
参见

引用

SwebBindableControl 类


SwebBindableControl 方法

SwebBindableControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
 | SharedBindData | 数据绑定
Top
参见

引用

SwebBindableControl 类


SwebBindableControl.BindData 方法

SwebBindableControlBindData 方法

数据绑定

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual bool BindData(
    Object data
)
Public Overridable Function BindData (
    data As Object
) As Boolean

参数

data
类型：SystemObject
绑定的数据

返回值

类型：Boolean
返回一个值，该值指示是否已经对data进行了绑定，如果返回True，调用此方法的数据绑定操作不再对data进行处理，否则进行处理。

实现

ISwebBindableControlBindData(Object)
参见

引用

SwebBindableControl 类


SwebBindableControl.SharedBindData 方法

SwebBindableControlSharedBindData 方法

数据绑定

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void SharedBindData(
    Object data,
    ISwebBindableControl ctl
)
Public Shared Sub SharedBindData (
    data As Object,
    ctl As ISwebBindableControl
)

参数

data
类型：SystemObject
绑定的数据
ctl
类型：Swebui.ControlsISwebBindableControl
绑定的控件
参见

引用

SwebBindableControl 类


SwebBindableControl 事件

SwebBindableControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebBindableControl 类


SwebCheckedControlBase 类

[缺少 "T:Swebui.Controls.SwebCheckedControlBase" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebCheckedControlBase
Swebui.ControlsCheckBox
Swebui.ControlsSwitch

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract class SwebCheckedControlBase : SwebBindableControl,
    ISwebEventControl
Public MustInherit Class SwebCheckedControlBase
    Inherits SwebBindableControl
    Implements ISwebEventControl

SwebCheckedControlBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebCheckedControlBase | 初始化 SwebCheckedControlBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled |
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | CheckedChanged |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebCheckedControlBase 构造函数

初始化 SwebCheckedControlBase 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SwebCheckedControlBase()
Public Sub New
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase 属性

SwebCheckedControlBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (重写 SwebBindableControlDisplayFormat.)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled |
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase.BindDisplayValue 属性

SwebCheckedControlBaseBindDisplayValue 属性

[缺少 "P:Swebui.Controls.SwebCheckedControlBase.BindDisplayValue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase.Checked 属性

SwebCheckedControlBaseChecked 属性

获取或设置选择状态

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase.DisplayFormat 属性

SwebCheckedControlBaseDisplayFormat 属性

[缺少 "P:Swebui.Controls.SwebCheckedControlBase.DisplayFormat" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string DisplayFormat { get; set; }
Public Overrides Property DisplayFormat As String
    Get
    Set

属性值

类型：String
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase.Enabled 属性

SwebCheckedControlBaseEnabled 属性

[缺少 "P:Swebui.Controls.SwebCheckedControlBase.Enabled" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase 方法

SwebCheckedControlBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase 事件

SwebCheckedControlBase 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | CheckedChanged |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebCheckedControlBase 类


SwebCheckedControlBase.CheckedChanged 事件

SwebCheckedControlBaseCheckedChanged 事件

[缺少 "E:Swebui.Controls.SwebCheckedControlBase.CheckedChanged" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler CheckedChanged
Public Event CheckedChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

SwebCheckedControlBase 类


SwebClientAuidoExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientAuidoExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientAuidoExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientAuidoExtension

SwebClientAuidoExtension 类型公开以下成员。

方法
名称 | 说明
PlayAudio | 播放音频
StopAudio | 停止播放音频
Top
参见

引用

Swebui.Controls 命名空间


SwebClientAuidoExtension 方法

SwebClientAuidoExtension 类型公开以下成员。

方法
名称 | 说明
PlayAudio | 播放音频
StopAudio | 停止播放音频
Top
参见

引用

SwebClientAuidoExtension 类


SwebClientAuidoExtension.PlayAudio 方法

SwebClientAuidoExtensionPlayAudio 方法

播放音频

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void PlayAudio(
    this SwebClientInfo info,
    string url,
    ResultHandler handler = null
)
<ExtensionAttribute>
Public Shared Sub PlayAudio (
    info As SwebClientInfo,
    url As String,
    Optional handler As ResultHandler = Nothing
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientAuidoExtension.PlayAudio(Swebui.SwebClientInfo,System.String,Swebui.ResultHandler)" 的 <param name="info"/> 文档]

url
类型：SystemString
音频url
handler (Optional)
类型：SwebuiResultHandler
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientAuidoExtension 类


SwebClientAuidoExtension.StopAudio 方法

SwebClientAuidoExtensionStopAudio 方法

停止播放音频

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void StopAudio(
    this SwebClientInfo info,
    ResultHandler handler = null
)
<ExtensionAttribute>
Public Shared Sub StopAudio (
    info As SwebClientInfo,
    Optional handler As ResultHandler = Nothing
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientAuidoExtension.StopAudio(Swebui.SwebClientInfo,Swebui.ResultHandler)" 的 <param name="info"/> 文档]

handler (Optional)
类型：SwebuiResultHandler
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientAuidoExtension 类


SwebClientCameraExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientCameraExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientCameraExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientCameraExtension

SwebClientCameraExtension 类型公开以下成员。

方法
名称 | 说明
Camera | 提供系统接口拍照
Top
参见

引用

Swebui.Controls 命名空间


SwebClientCameraExtension 方法

SwebClientCameraExtension 类型公开以下成员。

方法
名称 | 说明
Camera | 提供系统接口拍照
Top
参见

引用

SwebClientCameraExtension 类


SwebClientCameraExtension.Camera 方法

SwebClientCameraExtensionCamera 方法

提供系统接口拍照

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void Camera(
    this SwebClientInfo info,
    CameraMethod method,
    string filename = "",
    int compressedPixel = 1280,
    int quality = 60,
    CameraQialityMode cameraQialityMode = CameraQialityMode.Original,
    int number = 9,
    SwebClientCameraExtensionHandlerRPC handler = null
)
<ExtensionAttribute>
Public Shared Sub Camera (
    info As SwebClientInfo,
    method As CameraMethod,
    Optional filename As String = "",
    Optional compressedPixel As Integer = 1280,
    Optional quality As Integer = 60,
    Optional cameraQialityMode As CameraQialityMode = CameraQialityMode.Original,
    Optional number As Integer = 9,
    Optional handler As SwebClientCameraExtensionHandlerRPC = Nothing
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientCameraExtension.Camera(Swebui.SwebClientInfo,Swebui.Controls.CameraMethod,System.String,System.Int32,System.Int32,Swebui.Controls.CameraQialityMode,System.Int32,Swebui.Controls.SwebClientCameraExtension.HandlerRPC)" 的 <param name="info"/> 文档]

method
类型：Swebui.ControlsCameraMethod
拍照模式
filename (Optional)
类型：SystemString
上传图片或视频的名称
compressedPixel (Optional)
类型：SystemInt32
图片压缩像素值
quality (Optional)
类型：SystemInt32
图片压缩质量
cameraQialityMode (Optional)
类型：Swebui.ControlsCameraQialityMode
上传模式
number (Optional)
类型：SystemInt32
上传图片的最大值
handler (Optional)
类型：Swebui.ControlsSwebClientCameraExtensionHandlerRPC
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientCameraExtension 类


SwebClientCameraExtension.HandlerRPC 委托

SwebClientCameraExtensionHandlerRPC 委托

一个委托，它表示在上传后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void HandlerRPC(
    Object sender,
    BinaryResultArgs e
)
Public Delegate Sub HandlerRPC (
    sender As Object,
    e As BinaryResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsBinaryResultArgs
参见

引用

Swebui.Controls 命名空间


SwebClientClipBoardExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientClipBoardExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientClipBoardExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientClipBoardExtension

SwebClientClipBoardExtension 类型公开以下成员。

方法
名称 | 说明
GetClipBoard | 获取粘贴板内容
SetClipBoard | 设置粘贴板内容
Top
参见

引用

Swebui.Controls 命名空间


SwebClientClipBoardExtension 方法

SwebClientClipBoardExtension 类型公开以下成员。

方法
名称 | 说明
GetClipBoard | 获取粘贴板内容
SetClipBoard | 设置粘贴板内容
Top
参见

引用

SwebClientClipBoardExtension 类


SwebClientClipBoardExtension.GetClipBoard 方法

SwebClientClipBoardExtensionGetClipBoard 方法

获取粘贴板内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void GetClipBoard(
    this SwebClientInfo info,
    SwebClientClipBoardExtensionClipboardResultHandler handler
)
<ExtensionAttribute>
Public Shared Sub GetClipBoard (
    info As SwebClientInfo,
    handler As SwebClientClipBoardExtensionClipboardResultHandler
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientClipBoardExtension.GetClipBoard(Swebui.SwebClientInfo,Swebui.Controls.SwebClientClipBoardExtension.ClipboardResultHandler)" 的 <param name="info"/> 文档]

handler
类型：Swebui.ControlsSwebClientClipBoardExtensionClipboardResultHandler
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientClipBoardExtension 类


SwebClientClipBoardExtension.SetClipBoard 方法

SwebClientClipBoardExtensionSetClipBoard 方法

设置粘贴板内容

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void SetClipBoard(
    this SwebClientInfo info,
    string data,
    ResultHandler handler = null
)
<ExtensionAttribute>
Public Shared Sub SetClipBoard (
    info As SwebClientInfo,
    data As String,
    Optional handler As ResultHandler = Nothing
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientClipBoardExtension.SetClipBoard(Swebui.SwebClientInfo,System.String,Swebui.ResultHandler)" 的 <param name="info"/> 文档]

data
类型：SystemString
文本内容
handler (Optional)
类型：SwebuiResultHandler
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientClipBoardExtension 类


SwebClientClipBoardExtension.ClipboardResultHandler 委托

SwebClientClipBoardExtensionClipboardResultHandler 委托

一个委托，它表示粘贴板回调时要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void ClipboardResultHandler(
    Object sender,
    ClipboardResultArgs e
)
Public Delegate Sub ClipboardResultHandler (
    sender As Object,
    e As ClipboardResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsClipboardResultArgs
参见

引用

Swebui.Controls 命名空间


SwebClientEJControlExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientEJControlExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientEJControlExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientEJControlExtension

SwebClientEJControlExtension 类型公开以下成员。

方法
名称 | 说明
SetEJControlTheme | 设置EJ2控件Theme
Top
参见

引用

Swebui.Controls 命名空间


SwebClientEJControlExtension 方法

SwebClientEJControlExtension 类型公开以下成员。

方法
名称 | 说明
SetEJControlTheme | 设置EJ2控件Theme
Top
参见

引用

SwebClientEJControlExtension 类


SwebClientEJControlExtension.SetEJControlTheme 方法

SwebClientEJControlExtensionSetEJControlTheme 方法

设置EJ2控件Theme

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void SetEJControlTheme(
    this SwebClientInfo info,
    EJTheme eJTheme
)
<ExtensionAttribute>
Public Shared Sub SetEJControlTheme (
    info As SwebClientInfo,
    eJTheme As EJTheme
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientEJControlExtension.SetEJControlTheme(Swebui.SwebClientInfo,Swebui.Controls.EJTheme)" 的 <param name="info"/> 文档]

eJTheme
类型：Swebui.ControlsEJTheme

[缺少 "M:Swebui.Controls.SwebClientEJControlExtension.SetEJControlTheme(Swebui.SwebClientInfo,Swebui.Controls.EJTheme)" 的 <param name="eJTheme"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientEJControlExtension 类


SwebClientFileExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientFileExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientFileExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientFileExtension

SwebClientFileExtension 类型公开以下成员。

方法
名称 | 说明
FileDownload(SwebClientInfo, String) | 下载文件
FileDownload(SwebClientInfo, String, String) | 下载文件
FileUpload | 上传文件
Top
参见

引用

Swebui.Controls 命名空间


SwebClientFileExtension 方法

SwebClientFileExtension 类型公开以下成员。

方法
名称 | 说明
FileDownload(SwebClientInfo, String) | 下载文件
FileDownload(SwebClientInfo, String, String) | 下载文件
FileUpload | 上传文件
Top
参见

引用

SwebClientFileExtension 类


SwebClientFileExtension.FileDownload 方法

SwebClientFileExtensionFileDownload 方法

重载列表
名称 | 说明
FileDownload(SwebClientInfo, String) | 下载文件
FileDownload(SwebClientInfo, String, String) | 下载文件
Top
参见

引用

SwebClientFileExtension 类


SwebClientFileExtension.FileDownload 方法 (SwebClientInfo, String)

SwebClientFileExtensionFileDownload 方法 (SwebClientInfo, String)

下载文件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void FileDownload(
    this SwebClientInfo info,
    string url
)
<ExtensionAttribute>
Public Shared Sub FileDownload (
    info As SwebClientInfo,
    url As String
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientFileExtension.FileDownload(Swebui.SwebClientInfo,System.String)" 的 <param name="info"/> 文档]

url
类型：SystemString
文件url

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientFileExtension 类
FileDownload 重载


SwebClientFileExtension.FileDownload 方法 (SwebClientInfo, String, String)

SwebClientFileExtensionFileDownload 方法 (SwebClientInfo, String, String)

下载文件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void FileDownload(
    this SwebClientInfo info,
    string resourceID,
    string resourcePath
)
<ExtensionAttribute>
Public Shared Sub FileDownload (
    info As SwebClientInfo,
    resourceID As String,
    resourcePath As String
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientFileExtension.FileDownload(Swebui.SwebClientInfo,System.String,System.String)" 的 <param name="info"/> 文档]

resourceID
类型：SystemString
资源名称
resourcePath
类型：SystemString
资源路径

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientFileExtension 类
FileDownload 重载


SwebClientFileExtension.FileUpload 方法

SwebClientFileExtensionFileUpload 方法

上传文件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void FileUpload(
    this SwebClientInfo info,
    FileUploadHandler handler
)
<ExtensionAttribute>
Public Shared Sub FileUpload (
    info As SwebClientInfo,
    handler As FileUploadHandler
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientFileExtension.FileUpload(Swebui.SwebClientInfo,Swebui.Controls.FileUploadHandler)" 的 <param name="info"/> 文档]

handler
类型：Swebui.ControlsFileUploadHandler
委托回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientFileExtension 类


SwebClientGPSExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientGPSExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientGPSExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientGPSExtension

SwebClientGPSExtension 类型公开以下成员。

方法
名称 | 说明
GetGps | GPS
Top
参见

引用

Swebui.Controls 命名空间


SwebClientGPSExtension 方法

SwebClientGPSExtension 类型公开以下成员。

方法
名称 | 说明
GetGps | GPS
Top
参见

引用

SwebClientGPSExtension 类


SwebClientGPSExtension.GetGps 方法

SwebClientGPSExtensionGetGps 方法

GPS

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void GetGps(
    this SwebClientInfo info,
    GpsCallBackHandler handler,
    bool requestLocation = false,
    string amapKey = ""
)
<ExtensionAttribute>
Public Shared Sub GetGps (
    info As SwebClientInfo,
    handler As GpsCallBackHandler,
    Optional requestLocation As Boolean = false,
    Optional amapKey As String = ""
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientGPSExtension.GetGps(Swebui.SwebClientInfo,Swebui.Controls.GpsCallBackHandler,System.Boolean,System.String)" 的 <param name="info"/> 文档]

handler
类型：Swebui.ControlsGpsCallBackHandler
委托回调
requestLocation (Optional)
类型：SystemBoolean
是否请求坐标点信息
amapKey (Optional)
类型：SystemString
高德WebKey

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientGPSExtension 类


SwebClientJsEvalExtension 类

SwebClientJsExtension
继承层次
SystemObject
Swebui.ControlsSwebClientJsEvalExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientJsEvalExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientJsEvalExtension

SwebClientJsEvalExtension 类型公开以下成员。

方法
名称 | 说明
JSAppend | 附加脚本
JSAppendUrl | 附加脚本文件
JSEval | 执行Js代码
Top
参见

引用

Swebui.Controls 命名空间


SwebClientJsEvalExtension 方法

SwebClientJsEvalExtension 类型公开以下成员。

方法
名称 | 说明
JSAppend | 附加脚本
JSAppendUrl | 附加脚本文件
JSEval | 执行Js代码
Top
参见

引用

SwebClientJsEvalExtension 类


SwebClientJsEvalExtension.JSAppend 方法

SwebClientJsEvalExtensionJSAppend 方法

附加脚本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void JSAppend(
    this SwebClientInfo info,
    string jsId,
    string jsCode,
    ResultHandler handler = null,
    JScriptType jsType = JScriptType.Script,
    JScriptAppendType jsAppendType = JScriptAppendType.Body
)
<ExtensionAttribute>
Public Shared Sub JSAppend (
    info As SwebClientInfo,
    jsId As String,
    jsCode As String,
    Optional handler As ResultHandler = Nothing,
    Optional jsType As JScriptType = JScriptType.Script,
    Optional jsAppendType As JScriptAppendType = JScriptAppendType.Body
)

参数

info
类型：SwebuiSwebClientInfo
客户端
jsId
类型：SystemString
js编号
jsCode
类型：SystemString
js代码
handler (Optional)
类型：SwebuiResultHandler
回调
jsType (Optional)
类型：Swebui.ControlsJScriptType
js类型
jsAppendType (Optional)
类型：Swebui.ControlsJScriptAppendType
js添加类型

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientJsEvalExtension 类


SwebClientJsEvalExtension.JSAppendUrl 方法

SwebClientJsEvalExtensionJSAppendUrl 方法

附加脚本文件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void JSAppendUrl(
    this SwebClientInfo info,
    string jsId,
    string jsSrc,
    ResultHandler handler = null,
    JScriptType jsType = JScriptType.Script,
    JScriptAppendType jsAppendType = JScriptAppendType.Body
)
<ExtensionAttribute>
Public Shared Sub JSAppendUrl (
    info As SwebClientInfo,
    jsId As String,
    jsSrc As String,
    Optional handler As ResultHandler = Nothing,
    Optional jsType As JScriptType = JScriptType.Script,
    Optional jsAppendType As JScriptAppendType = JScriptAppendType.Body
)

参数

info
类型：SwebuiSwebClientInfo
客户端
jsId
类型：SystemString
js编号
jsSrc
类型：SystemString
js文件
handler (Optional)
类型：SwebuiResultHandler
回调
jsType (Optional)
类型：Swebui.ControlsJScriptType
js类型
jsAppendType (Optional)
类型：Swebui.ControlsJScriptAppendType
js添加类型

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientJsEvalExtension 类


SwebClientJsEvalExtension.JSEval 方法

SwebClientJsEvalExtensionJSEval 方法

执行Js代码

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void JSEval(
    this SwebClientInfo info,
    string jscode,
    ResultHandler handler = null
)
<ExtensionAttribute>
Public Shared Sub JSEval (
    info As SwebClientInfo,
    jscode As String,
    Optional handler As ResultHandler = Nothing
)

参数

info
类型：SwebuiSwebClientInfo
客户端
jscode
类型：SystemString
js代码
handler (Optional)
类型：SwebuiResultHandler
回调

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientJsEvalExtension 类


SwebClientPrintExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientPrintExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientPrintExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientPrintExtension
方法
名称 | 说明
Print(SwebClientInfo) | 打印当前窗体
Print(SwebClientInfo, String, PrintType) | 打印
Top
参见

引用

Swebui.Controls 命名空间


SwebClientPrintExtension 方法

方法
名称 | 说明
Print(SwebClientInfo) | 打印当前窗体
Print(SwebClientInfo, String, PrintType) | 打印
Top
参见

引用

SwebClientPrintExtension 类


SwebClientPrintExtension.Print 方法

SwebClientPrintExtensionPrint 方法

重载列表
名称 | 说明
Print(SwebClientInfo) | 打印当前窗体
Print(SwebClientInfo, String, PrintType) | 打印
Top
参见

引用

SwebClientPrintExtension 类


SwebClientPrintExtension.Print 方法 (SwebClientInfo)

SwebClientPrintExtensionPrint 方法 (SwebClientInfo)

打印当前窗体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void Print(
    this SwebClientInfo info
)
<ExtensionAttribute>
Public Shared Sub Print (
    info As SwebClientInfo
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientPrintExtension.Print(Swebui.SwebClientInfo)" 的 <param name="info"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientPrintExtension 类
Print 重载


SwebClientPrintExtension.Print 方法 (SwebClientInfo, String, PrintType)

SwebClientPrintExtensionPrint 方法 (SwebClientInfo, String, PrintType)

打印

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void Print(
    this SwebClientInfo info,
    string url,
    PrintType type
)
<ExtensionAttribute>
Public Shared Sub Print (
    info As SwebClientInfo,
    url As String,
    type As PrintType
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientPrintExtension.Print(Swebui.SwebClientInfo,System.String,Swebui.Controls.PrintType)" 的 <param name="info"/> 文档]

url
类型：SystemString
文件url
type
类型：Swebui.ControlsPrintType
文件类型

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientPrintExtension 类
Print 重载


SwebClientRedirectUrlExtension 类

构造函数
继承层次
SystemObject
Swebui.ControlsSwebClientRedirectUrlExtension

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static class SwebClientRedirectUrlExtension
<ExtensionAttribute>
Public NotInheritable Class SwebClientRedirectUrlExtension

SwebClientRedirectUrlExtension 类型公开以下成员。

方法
名称 | 说明
RedirectUrl |
Top
参见

引用

Swebui.Controls 命名空间


SwebClientRedirectUrlExtension 方法

SwebClientRedirectUrlExtension 类型公开以下成员。

方法
名称 | 说明
RedirectUrl |
Top
参见

引用

SwebClientRedirectUrlExtension 类


SwebClientRedirectUrlExtension.RedirectUrl 方法

SwebClientRedirectUrlExtensionRedirectUrl 方法

[缺少 "M:Swebui.Controls.SwebClientRedirectUrlExtension.RedirectUrl(Swebui.SwebClientInfo,System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public static void RedirectUrl(
    this SwebClientInfo info,
    string url,
    bool newTab = false
)
<ExtensionAttribute>
Public Shared Sub RedirectUrl (
    info As SwebClientInfo,
    url As String,
    Optional newTab As Boolean = false
)

参数

info
类型：SwebuiSwebClientInfo

[缺少 "M:Swebui.Controls.SwebClientRedirectUrlExtension.RedirectUrl(Swebui.SwebClientInfo,System.String,System.Boolean)" 的 <param name="info"/> 文档]

url
类型：SystemString
网页地址
newTab (Optional)
类型：SystemBoolean
是否打开新的Tab标签

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SwebClientInfo 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SwebClientRedirectUrlExtension 类


SwebComponent 类

组件基类
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebComponent
Swebui.ControlsAnimation
Swebui.Controls.DropdownAlertDropdownAlert
Swebui.ControlsTimer
Swebui.ControlsTTS

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebComponent : Component
Public MustInherit Class SwebComponent
    Inherits Component

SwebComponent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Form | 获取组件所属窗体
公共属性 | Name | 获取或设置控件的名称。
公共属性 | Parent | 获取控件的父控件SwebParentControl。
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebComponent 属性

SwebComponent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Form | 获取组件所属窗体
公共属性 | Name | 获取或设置控件的名称。
公共属性 | Parent | 获取控件的父控件SwebParentControl。
Top
参见

引用

SwebComponent 类


SwebComponent.Form 属性

SwebComponentForm 属性

获取组件所属窗体

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebForm Form { get; }
Public ReadOnly Property Form As SwebForm
    Get

返回值

类型：SwebForm
参见

引用

SwebComponent 类


SwebComponent.Name 属性

SwebComponentName 属性

获取或设置控件的名称。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Name { get; set; }
Public Property Name As String
    Get
    Set

属性值

类型：String
控件的名称。默认值为空字符串 ("")。
备注
Name 属性可以在运行时使用，以按名称而不是按类型和编程名称计算对象。由于 Name 属性返回 String 类型，所以可以在 Case 式的逻辑语句中进行计算（在 Visual Basic 中是 Select 语句，在 C# 和 C++ 中是 switch 语句）。
参见

引用

SwebComponent 类


SwebComponent.Parent 属性

SwebComponentParent 属性

获取控件的父控件SwebParentControl。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebParentControl Parent { get; }
Public ReadOnly Property Parent As SwebParentControl
    Get

属性值

类型：SwebParentControl
一个 SwebParentControl 对象，它表示控件的父控件。
备注
参见

引用

SwebComponent 类


SwebComponentCollection 类

Sweb组件集合
继承层次
SystemObject
Swebui.ControlsSwebComponentCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebComponentCollection : IList
Public Class SwebComponentCollection
    Implements IList

SwebComponentCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebComponentCollection | 初始化 Form.ComponnetControlCollection 类的新实例。
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合中 Control 对象的总数。
公共属性 | IsFixedSize |
公共属性 | IsReadOnly | 获取一个值，通过该值指示该控件集合是否为只读。
公共属性 | IsSynchronized |
公共属性 | Item | 指示集合中指定索引位置的 SwebComponent。
公共属性 | SyncRoot |
Top
方法
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebComponent) | 将控件添加到窗体中。
公共方法 | AddRange | 将控件对象数组添加到集合中。
公共方法 | Clear | 从集合中移除所有控件。
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebComponent) | 确定指定控件是否为集合的成员。
公共方法 | CopyTo |
公共方法 | GetEnumerator | 返回一个可用于循环访问控件集合的枚举数。
公共方法 | IndexOf | 查找指定控件位置
公共方法 | Remove | 从窗体中移除控件。
公共方法 | RemoveAt | 在指定的索引位置从控件集合移除控件。
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebComponentCollection 构造函数

初始化 Form.ComponnetControlCollection 类的新实例。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebComponentCollection(
    SwebParentControl _owner
)
Public Sub New (
    _owner As SwebParentControl
)

参数

_owner
类型：Swebui.ControlsSwebParentControl

[缺少 "M:Swebui.Controls.SwebComponentCollection.#ctor(Swebui.Controls.SwebParentControl)" 的 <param name="_owner"/> 文档]

备注
参见

引用

SwebComponentCollection 类


SwebComponentCollection 属性

SwebComponentCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合中 Control 对象的总数。
公共属性 | IsFixedSize |
公共属性 | IsReadOnly | 获取一个值，通过该值指示该控件集合是否为只读。
公共属性 | IsSynchronized |
公共属性 | Item | 指示集合中指定索引位置的 SwebComponent。
公共属性 | SyncRoot |
Top
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Count 属性

SwebComponentCollectionCount 属性

获取集合中 Control 对象的总数。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32
集合中的 Control 对象总数。

实现

ICollectionCount
备注
Count 属性包含分配给集合的 Control 对象数。可以将 Count 属性值用作循环上限以循环访问集合。
参见

引用

SwebComponentCollection 类


SwebComponentCollection.IsFixedSize 属性

SwebComponentCollectionIsFixedSize 属性

[缺少 "P:Swebui.Controls.SwebComponentCollection.IsFixedSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get

属性值

类型：Boolean

实现

IListIsFixedSize
参见

引用

SwebComponentCollection 类


SwebComponentCollection.IsReadOnly 属性

SwebComponentCollectionIsReadOnly 属性

获取一个值，通过该值指示该控件集合是否为只读。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

属性值

类型：Boolean
如果该控件集合为只读，则为 true；否则为 false。

实现

IListIsReadOnly
备注
参见

引用

SwebComponentCollection 类


SwebComponentCollection.IsSynchronized 属性

SwebComponentCollectionIsSynchronized 属性

[缺少 "P:Swebui.Controls.SwebComponentCollection.IsSynchronized" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

属性值

类型：Boolean

实现

ICollectionIsSynchronized
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Item 属性

SwebComponentCollectionItem 属性

指示集合中指定索引位置的 SwebComponent。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebComponent this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As SwebComponent
    Get
    Set

参数

index
类型：SystemInt32
要从控件集合中检索的控件索引。

属性值

类型：SwebComponent
位于控件集合内指定索引位置的 SwebComponent。
备注
参见

引用

SwebComponentCollection 类


SwebComponentCollection.SyncRoot 属性

SwebComponentCollectionSyncRoot 属性

[缺少 "P:Swebui.Controls.SwebComponentCollection.SyncRoot" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

属性值

类型：Object

实现

ICollectionSyncRoot
参见

引用

SwebComponentCollection 类


SwebComponentCollection 方法

SwebComponentCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebComponent) | 将控件添加到窗体中。
公共方法 | AddRange | 将控件对象数组添加到集合中。
公共方法 | Clear | 从集合中移除所有控件。
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebComponent) | 确定指定控件是否为集合的成员。
公共方法 | CopyTo |
公共方法 | GetEnumerator | 返回一个可用于循环访问控件集合的枚举数。
公共方法 | IndexOf | 查找指定控件位置
公共方法 | Remove | 从窗体中移除控件。
公共方法 | RemoveAt | 在指定的索引位置从控件集合移除控件。
Top
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Add 方法

SwebComponentCollectionAdd 方法

重载列表
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebComponent) | 将控件添加到窗体中。
Top
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Add 方法 (Object)

SwebComponentCollectionAdd 方法 (Object)

添加控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Add(
    Object value
)
Public Function Add (
    value As Object
) As Integer

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebComponentCollection.Add(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebComponentCollection.Add(System.Object)" 的 <returns> 文档]

实现

IListAdd(Object)
备注
参见

引用

SwebComponentCollection 类
Add 重载


SwebComponentCollection.Add 方法 (SwebComponent)

SwebComponentCollectionAdd 方法 (SwebComponent)

将控件添加到窗体中。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Add(
    SwebComponent value
)
Public Function Add (
    value As SwebComponent
) As Integer

参数

value
类型：Swebui.ControlsSwebComponent
要添加到窗体中的 Control。

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebComponentCollection.Add(Swebui.Controls.SwebComponent)" 的 <returns> 文档]

备注
可以使用此方法将控件添加到窗体中。如果要将一组已经创建的控件添加到窗体中，请使用 ControlCollection.AddRange 方法。
参见

引用

SwebComponentCollection 类
Add 重载


SwebComponentCollection.AddRange 方法

SwebComponentCollectionAddRange 方法

将控件对象数组添加到集合中。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AddRange(
    SwebComponent[] ctls
)
Public Sub AddRange (
    ctls As SwebComponent()
)

参数

ctls
类型：Swebui.ControlsSwebComponent
要添加到集合的 Control 对象的数组。
备注
将 controls 数组中包含的 Control 对象追加到集合的结尾。 可以使用 AddRange 方法将一组 Control 对象迅速添加到集合，而不是通过使用 Add 方法将每个 Control 手动添加到集合中。 若要移除以前添加的 Control，请使用 Remove、RemoveAt 或 Clear 方法。
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Clear 方法

SwebComponentCollectionClear 方法

从集合中移除所有控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Clear()
Public Sub Clear

实现

IListClear
备注
可以使用 Clear 方法从父控件中移除整个控件集合。 若要从集合中移除单个控件，请使用 Remove 或 RemoveAt 方法。 若要向集合中添加新的 Control 对象，请使用 Add 或 AddRange 方法。
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Contains 方法

SwebComponentCollectionContains 方法

重载列表
 | 名称 | 说明
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebComponent) | 确定指定控件是否为集合的成员。
Top
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Contains 方法 (Object)

SwebComponentCollectionContains 方法 (Object)

判断是否包含控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    Object value
)
Public Function Contains (
    value As Object
) As Boolean

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebComponentCollection.Contains(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebComponentCollection.Contains(System.Object)" 的 <returns> 文档]

实现

IListContains(Object)
备注
参见

引用

SwebComponentCollection 类
Contains 重载


SwebComponentCollection.Contains 方法 (SwebComponent)

SwebComponentCollectionContains 方法 (SwebComponent)

确定指定控件是否为集合的成员。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    SwebComponent value
)
Public Function Contains (
    value As SwebComponent
) As Boolean

参数

value
类型：Swebui.ControlsSwebComponent
要在集合中定位的 SwebComponent。

返回值

类型：Boolean
如果 Control 是集合的成员，则为 true；否则为 false。
备注
参见

引用

SwebComponentCollection 类
Contains 重载


SwebComponentCollection.CopyTo 方法

SwebComponentCollectionCopyTo 方法

[缺少 "M:Swebui.Controls.SwebComponentCollection.CopyTo(System.Array,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)

参数

array
类型：SystemArray

[缺少 "M:Swebui.Controls.SwebComponentCollection.CopyTo(System.Array,System.Int32)" 的 <param name="array"/> 文档]

index
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebComponentCollection.CopyTo(System.Array,System.Int32)" 的 <param name="index"/> 文档]

实现

ICollectionCopyTo(Array, Int32)
参见

引用

SwebComponentCollection 类


SwebComponentCollection.GetEnumerator 方法

SwebComponentCollectionGetEnumerator 方法

返回一个可用于循环访问控件集合的枚举数。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

返回值

类型：IEnumerator
一个 IEnumerator 对象，它表示控件集合。

实现

IEnumerableGetEnumerator
备注
参见

引用

SwebComponentCollection 类


SwebComponentCollection.IndexOf 方法

SwebComponentCollectionIndexOf 方法

查找指定控件位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int IndexOf(
    Object value
)
Public Function IndexOf (
    value As Object
) As Integer

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebComponentCollection.IndexOf(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebComponentCollection.IndexOf(System.Object)" 的 <returns> 文档]

实现

IListIndexOf(Object)
备注
参见

引用

SwebComponentCollection 类


SwebComponentCollection.Remove 方法

SwebComponentCollectionRemove 方法

从窗体中移除控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Remove(
    SwebComponent value
)
Public Sub Remove (
    value As SwebComponent
)

参数

value
类型：Swebui.ControlsSwebComponent
要从窗体中移除的 SwebComponent。
备注
可以使用此方法移除窗体中不再需要的控件。如果要在移除某控件后显示它，将需要使用 Add 方法将该控件重新添加到窗体中。若要使控件保留在窗体上但不显示，请使用该控件的 Visible 属性。
参见

引用

SwebComponentCollection 类


SwebComponentCollection.RemoveAt 方法

SwebComponentCollectionRemoveAt 方法

在指定的索引位置从控件集合移除控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32
要移除的 Control 的索引值。

实现

IListRemoveAt(Int32)
备注
参见

引用

SwebComponentCollection 类


SwebComponentOnResultHandler 委托

一个委托，它表示在组件结果回调后要调用的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void SwebComponentOnResultHandler(
    Object sender,
    SwebComponentResultArgs e
)
Public Delegate Sub SwebComponentOnResultHandler (
    sender As Object,
    e As SwebComponentResultArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsSwebComponentResultArgs
包含事件数据的 ComponentResultArgs
参见

引用

Swebui.Controls 命名空间


SwebComponentResultArgs 类

组件调用结果
继承层次
SystemObject
SwebuiResultArgs
Swebui.ControlsSwebComponentResultArgs
Swebui.ControlsClientResourceResultArgs
Swebui.ControlsGPSResultArgs
Swebui.ControlsResourceResultArgs
Swebui.ControlsResourcesResultArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebComponentResultArgs : ResultArgs
Public Class SwebComponentResultArgs
    Inherits ResultArgs

SwebComponentResultArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebComponentResultArgs | 初始化 SwebComponentResultArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
方法
 | 名称 | 说明
 | CreateErrorResultT | 创建错误结果
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

Swebui.Controls 命名空间


SwebComponentResultArgs 构造函数

初始化 SwebComponentResultArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebComponentResultArgs()
Public Sub New
参见

引用

SwebComponentResultArgs 类


SwebComponentResultArgs 属性

SwebComponentResultArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | args | 获取和设置附加数据
公共属性 | error | 获取和设置错误信息 (继承自 ResultArgs。)
公共属性 | errorCode | 获取和设置错误信息编号 (继承自 ResultArgs。)
公共属性 | isError | 获取一个值，该值指示是否在接口调用结果中包含错误信息 (继承自 ResultArgs。)
Top
参见

引用

SwebComponentResultArgs 类


SwebComponentResultArgs.args 属性

SwebComponentResultArgsargs 属性

获取和设置附加数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object args { get; set; }
Public Property args As Object
    Get
    Set

返回值

类型：Object
参见

引用

SwebComponentResultArgs 类


SwebComponentResultArgs 方法

SwebComponentResultArgs 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateErrorResultT | 创建错误结果
公共方法 | setErrorInfo | 设置错误信息 (继承自 ResultArgs。)
Top
参见

引用

SwebComponentResultArgs 类


SwebComponentResultArgs.CreateErrorResult(T) 方法

SwebComponentResultArgsCreateErrorResultT 方法

创建错误结果

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static T CreateErrorResult<T>(
    int errorcode,
    string errorinfo,
    Object args
)
where T : SwebComponentResultArgs

Public Shared Function CreateErrorResult(Of T As SwebComponentResultArgs) (
    errorcode As Integer,
    errorinfo As String,
    args As Object
) As T

参数

errorcode
类型：SystemInt32
错误编号
errorinfo
类型：SystemString
错误信息
args
类型：SystemObject
附加参数

类型参数

T
结果类型

返回值

类型：T

[缺少 "M:Swebui.Controls.SwebComponentResultArgs.CreateErrorResult``1(System.Int32,System.String,System.Object)" 的 <returns> 文档]

参见

引用

SwebComponentResultArgs 类


SwebContainerControl 类

容器控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsPanel
Swebui.ControlsPopPanel
Swebui.ControlsSwebNativeContainerControl
Swebui.ControlsSwebParentControl
Swebui.ControlsTabPageView

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebContainerControl : SwebLayoutControl
Public Class SwebContainerControl
    Inherits SwebLayoutControl

SwebContainerControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebContainerControl | 初始化 SwebContainerControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebContainerControl 构造函数

初始化 SwebContainerControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebContainerControl()
Public Sub New
参见

引用

SwebContainerControl 类


SwebContainerControl 属性

SwebContainerControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebContainerControl 类


SwebContainerControl.Controls 属性

SwebContainerControlControls 属性

获取包含在控件内的控件的集合。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControlCollection Controls { get; }
Public ReadOnly Property Controls As SwebControlCollection
    Get

属性值

类型：SwebControlCollection
一个 SwebControlCollection，它表示控件内包含的控件的集合。
备注
参见

引用

SwebContainerControl 类


SwebContainerControl 方法

SwebContainerControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

SwebContainerControl 类


SwebContainerControl 事件

SwebContainerControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebContainerControl 类


SwebControl 类

控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebControl : SwebControlBase
Public Class SwebControl
    Inherits SwebControlBase

SwebControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebControl | 初始化 SwebControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画
公共属性 | BackColor | 获取或设置控件的背景色。
公共属性 | Border | 获取或设置控件边框
公共属性 | BorderColor | 获取或设置控件边框颜色
公共属性 | BorderRadius | 获取和设置控件边框角度
公共属性 | BorderStyle | 获取和设置控件边框线样式
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例
公共属性 | MinHeightRate | 获取和设置控件最小高度比例
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。
公共属性 | SelfLayout | 获取和设置控件自身布局。
公共属性 | Size | 获取或设置控件的高度和宽度。
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。
公共属性 | Width | 获取或设置控件的宽度。
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
备注
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsCalendar
Swebui.ControlsEditer
Swebui.ControlsGridView
Swebui.ControlsLine
Swebui.ControlsMapTagView
Swebui.ControlsMenuView
Swebui.ControlsSegmentedControl
Swebui.ControlsSvg
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsTreeSelect
Swebui.ControlsWebView


SwebControl 构造函数

初始化 SwebControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl()
Public Sub New
参见

引用

SwebControl 类


SwebControl 属性

SwebControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画
公共属性 | BackColor | 获取或设置控件的背景色。
公共属性 | Border | 获取或设置控件边框
公共属性 | BorderColor | 获取或设置控件边框颜色
公共属性 | BorderRadius | 获取和设置控件边框角度
公共属性 | BorderStyle | 获取和设置控件边框线样式
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例
公共属性 | MinHeightRate | 获取和设置控件最小高度比例
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。
公共属性 | SelfLayout | 获取和设置控件自身布局。
公共属性 | Size | 获取或设置控件的高度和宽度。
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。
公共属性 | Width | 获取或设置控件的宽度。
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。
Top
参见

引用

SwebControl 类


SwebControl.Animation 属性

SwebControlAnimation 属性

获取和设置动画

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string Animation { get; set; }
Public Overridable Property Animation As String
    Get
    Set

返回值

类型：String
参见

引用

SwebControl 类


SwebControl.BackColor 属性

SwebControlBackColor 属性

获取或设置控件的背景色。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set

属性值

类型：Color
表示控件背景色的 Color。
备注
BackColor 属性为环境属性。环境属性是一种控件属性，如果不设置，就会从父控件中检索该属性。 例如，默认情况下，Button 与其父级 Form 一样具有相同的 BackColor。。
参见

引用

SwebControl 类


SwebControl.Border 属性

SwebControlBorder 属性

获取或设置控件边框

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Border Border { get; set; }
Public Overridable Property Border As Border
    Get
    Set

属性值

类型：Border

返回值

类型：Border
备注
参见

引用

SwebControl 类


SwebControl.BorderColor 属性

SwebControlBorderColor 属性

获取或设置控件边框颜色

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Color BorderColor { get; set; }
Public Overridable Property BorderColor As Color
    Get
    Set

属性值

类型：Color

返回值

类型：Color
备注
参见

引用

SwebControl 类


SwebControl.BorderRadius 属性

SwebControlBorderRadius 属性

获取和设置控件边框角度

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int BorderRadius { get; set; }
Public Overridable Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
表示控件边框角度的 int

返回值

类型：Int32
参见

引用

SwebControl 类


SwebControl.BorderStyle 属性

SwebControlBorderStyle 属性

获取和设置控件边框线样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual BorderStyle BorderStyle { get; set; }
Public Overridable Property BorderStyle As BorderStyle
    Get
    Set

返回值

类型：BorderStyle
参见

引用

SwebControl 类


SwebControl.Bottom 属性

SwebControlBottom 属性

获取和设置控件下边缘距离父控件的距离。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Bottom { get; set; }
Public Overridable Property Bottom As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

SwebControl 类


SwebControl.Bounds 属性

SwebControlBounds 属性

获取或设置控件（包括其非工作区元素）的大小和位置。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
    Get
    Set

属性值

类型：Rectangle
一个 Rectangle，它表示控件（包括其非工作区元素）的大小和位置。
备注
参见

引用

SwebControl 类


SwebControl.Flex 属性

SwebControlFlex 属性

获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Flex { get; set; }
Public Overridable Property Flex As Integer
    Get
    Set

属性值

类型：Int32
正整数

返回值

类型：Int32
备注
Flex > 1 : 比例因子 flex = 0 : 根据控件自身的Width和Height确定Size
参见

引用

SwebControl 类


SwebControl.Height 属性

SwebControlHeight 属性

获取或设置控件的高度。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Height { get; set; }
Public Overridable Property Height As Integer
    Get
    Set

属性值

类型：Int32
控件的高度（以像素为单位）。
备注
对 Height 和 Top 属性值所做的更改导致该控件的 Bottom 属性值更改。
参见

引用

SwebControl 类


SwebControl.LayoutPercentage 属性

SwebControlLayoutPercentage 属性

获取和设置布局百分比

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutPercentage LayoutPercentage { get; set; }
Public Overridable Property LayoutPercentage As LayoutPercentage
    Get
    Set

返回值

类型：LayoutPercentage
参见

引用

SwebControl 类


SwebControl.Left 属性

SwebControlLeft 属性

获取或设置控件距离容器控件左边缘的 x 坐标。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Left { get; set; }
Public Overridable Property Left As Integer
    Get
    Set

属性值

类型：Int32
控件的左边缘的 x 坐标。
备注
Left 属性值等效于控件的 Location 属性值的 Point.X 属性。 对 Width 和 Left 属性值所做的更改导致该控件的 Right 属性值更改。
参见

引用

SwebControl 类


SwebControl.Location 属性

SwebControlLocation 属性

获取或设置该控件的左上角相对于其容器的左上角的坐标。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Point Location { get; set; }
Public Overridable Property Location As Point
    Get
    Set

属性值

类型：Point
Point，它表示控件的左上角相对于其容器的左上角。
备注
由于 Point 类是值类型（在 Visual Basic 中是 Structure，在 C# 中是 struct），它按传值方式返回，意思是说访问该属性返回控件的左上点的副本。因此，调整从该属性返回的 Point 对象的 X 或 Y 属性将不影响控件的 Left、Right、Top 或 Bottom 属性值。若要调整这些属性，请分别设置每个属性值，或用新的 Point 对象设置 Location 属性。 如果 Control 是 Form，那么 Location 属性值表示 Form 的左上角（以屏幕坐标表示）。
参见

引用

SwebControl 类


SwebControl.LowerLocation 属性

SwebControlLowerLocation 属性

获取或设置该控件的右下角相对于其容器的右下角的坐标

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Point LowerLocation { get; set; }
Public Overridable Property LowerLocation As Point
    Get
    Set

返回值

类型：Point
参见

引用

SwebControl 类


SwebControl.Margin 属性

SwebControlMargin 属性

获取或设置控件边框与边框外控件间隔距离

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Margin Margin { get; set; }
Public Overridable Property Margin As Margin
    Get
    Set

属性值

类型：Margin

返回值

类型：Margin
备注
参见

引用

SwebControl 类


SwebControl.MaxHeightRate 属性

SwebControlMaxHeightRate 属性

获取和设置控件最大高度比例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int MaxHeightRate { get; set; }
Public Overridable Property MaxHeightRate As Integer
    Get
    Set

属性值

类型：Int32
0到100区间

返回值

类型：Int32
备注
设置为0取消当前设置
参见

引用

SwebControl 类


SwebControl.MinHeightRate 属性

SwebControlMinHeightRate 属性

获取和设置控件最小高度比例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int MinHeightRate { get; set; }
Public Overridable Property MinHeightRate As Integer
    Get
    Set

属性值

类型：Int32
0到100区间

返回值

类型：Int32
备注
设置为0取消当前设置
参见

引用

SwebControl 类


SwebControl.Padding 属性

SwebControlPadding 属性

获取或设置控件边框与边框内控件间隔距离

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Padding Padding { get; set; }
Public Overridable Property Padding As Padding
    Get
    Set

属性值

类型：Padding

返回值

类型：Padding
备注
参见

引用

SwebControl 类


SwebControl.Position 属性

SwebControlPosition 属性

获取和设置布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutPosition Position { get; }
Public Overridable ReadOnly Property Position As LayoutPosition
    Get

返回值

类型：LayoutPosition
参见

引用

SwebControl 类


SwebControl.Right 属性

SwebControlRight 属性

获取和设置控件右边缘距离父控件的距离。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Right { get; set; }
Public Overridable Property Right As Integer
    Get
    Set

返回值

类型：Int32
参见

引用

SwebControl 类


SwebControl.SelfAlign 属性

SwebControlSelfAlign 属性

获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutSelfAlign SelfAlign { get; set; }
Public Overridable Property SelfAlign As LayoutSelfAlign
    Get
    Set

返回值

类型：LayoutSelfAlign
备注
参见

引用

SwebControl 类


SwebControl.SelfLayout 属性

SwebControlSelfLayout 属性

获取和设置控件自身布局。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutSelfPosition SelfLayout { get; set; }
Public Overridable Property SelfLayout As LayoutSelfPosition
    Get
    Set

返回值

类型：LayoutSelfPosition
参见

引用

SwebControl 类


SwebControl.Size 属性

SwebControlSize 属性

获取或设置控件的高度和宽度。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set

属性值

类型：Size
Size 对象，它表示控件的高度和宽度。
备注
由于 Size 类是值类型（在 Visual Basic 中是 Structure，在 C# 中是 struct），它按传值方式返回，意思是说访问该属性返回控件的大小的副本。因此，调整从该属性返回的 Size 对象的 Width 或 Height 属性将不影响控件的 Width 或 Height。若要调整控件的 Width 或 Height，必须设置控件的 Width 或 Height 属性，或用新的 Size 对象设置 Size 属性。
参见

引用

SwebControl 类


SwebControl.TabIndex 属性

SwebControlTabIndex 属性

获取或设置在控件的容器的控件的 Tab 键顺序。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int TabIndex { get; set; }
Public Overridable Property TabIndex As Integer
    Get
    Set

属性值

类型：Int32
控件在其容器的按 Tab 键顺序包括的控件集内的索引值。
备注
Tab 索引可由任何大于等于零的有效整数组成，越小的数字在 Tab 键顺序中越靠前。 为了按 Tab 键顺序包括控件，其 TabStop 属性必须设置为 true。
参见

引用

SwebControl 类


SwebControl.Top 属性

SwebControlTop 属性

获取或设置控件的上边缘的 y 坐标。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Top { get; set; }
Public Overridable Property Top As Integer
    Get
    Set

属性值

类型：Int32
控件的上边缘的 y 坐标。
备注
Top 属性值等效于控件的 Location 属性值的 Point.Y 属性。 对 Height 和 Top 属性值所做的更改导致该控件的 Bottom 属性值更改。
参见

引用

SwebControl 类


SwebControl.Visible 属性

SwebControlVisible 属性

获取或设置一个值，该值指示是否显示该控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set

属性值

类型：Boolean
如果显示该控件，则为 true，否则为 false。默认为 true。
备注
参见

引用

SwebControl 类


SwebControl.Width 属性

SwebControlWidth 属性

获取或设置控件的宽度。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int Width { get; set; }
Public Overridable Property Width As Integer
    Get
    Set

属性值

类型：Int32
控件的宽度。
备注
对 Width 和 Left 属性值所做的更改导致该控件的 Right 属性值更改。
参见

引用

SwebControl 类


SwebControl.ZIndex 属性

SwebControlZIndex 属性

获取和设置一个值，该值表示在Z轴上的显示顺序。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int ZIndex { get; set; }
Public Overridable Property ZIndex As Integer
    Get
    Set

属性值

类型：Int32
表示在Z轴上的显示顺序的 Int

返回值

类型：Int32
备注
Z 索引可由任何大于等于零的有效整数组成，在重叠的控件中，Z轴顺序越大，显示越靠前。
参见

引用

SwebControl 类


SwebControl 方法

SwebControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

SwebControl 类


SwebControl 事件

SwebControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebControl 类


SwebControlBase 类

控件基类
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebControlBase : Component,
    INotifyPropertyChanged, ISwebControl
Public Class SwebControlBase
    Inherits Component
    Implements INotifyPropertyChanged, ISwebControl

SwebControlBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebControlBase | 初始化 SwebControlBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DesignStyle | 获取和设置包括有关控件的样式
公共属性 | Form | 获取控件所属的窗体
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。
公共属性 | Name | 获取或设置控件的名称。
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。
公共属性 | RenderID |
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值
公共方法 | Invoke(Delegate) |
公共方法 | Invoke(Delegate, Object) |
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes
Top
字段
名称 | 说明
ConstBackColorDefault |
ConstBoolFalse |
ConstBoolTrue |
ConstBorderDefault |
ConstBorderRadiusDefault |
ConstFontSizeDefault |
ConstFontSizeStrDefault |
ConstForeColorDefault |
ConstMarginDefault |
ConstPaddingDefault |
ConstVisibleDefault |
SharedBackColorDefault |
SharedBorderColorDefault |
SharedForeColorDefault |
Top
参见

引用

Swebui.Controls 命名空间


SwebControlBase 构造函数

初始化 SwebControlBase 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControlBase()
Public Sub New
参见

引用

SwebControlBase 类


SwebControlBase 属性

SwebControlBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DesignStyle | 获取和设置包括有关控件的样式
公共属性 | Form | 获取控件所属的窗体
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。
公共属性 | Name | 获取或设置控件的名称。
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。
公共属性 | RenderID |
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。
Top
参见

引用

SwebControlBase 类


SwebControlBase.DesignStyle 属性

SwebControlBaseDesignStyle 属性

获取和设置包括有关控件的样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string DesignStyle { get; set; }
Public Overridable Property DesignStyle As String
    Get
    Set

属性值

类型：String
一个 String，它包含有关控件的样式。默认为空。

返回值

类型：String
参见

引用

SwebControlBase 类


SwebControlBase.Form 属性

SwebControlBaseForm 属性

获取控件所属的窗体

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebForm Form { get; }
Public ReadOnly Property Form As SwebForm
    Get

返回值

类型：SwebForm
参见

引用

SwebControlBase 类


SwebControlBase.InvokeRequired 属性

SwebControlBaseInvokeRequired 属性

获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool InvokeRequired { get; }
Public ReadOnly Property InvokeRequired As Boolean
    Get

返回值

类型：Boolean
参见

引用

SwebControlBase 类


SwebControlBase.IsLoaded 属性

SwebControlBaseIsLoaded 属性

获取一个值，该值表示当前窗口 SwebForm 是否已经载入。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsLoaded { get; }
Public ReadOnly Property IsLoaded As Boolean
    Get

属性值

类型：Boolean
true,代表已经载入,false代表未载入
备注
参见

引用

SwebControlBase 类


SwebControlBase.Name 属性

SwebControlBaseName 属性

获取或设置控件的名称。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Name { get; set; }
Public Property Name As String
    Get
    Set

属性值

类型：String
控件的名称。默认值为空字符串 ("")。

实现

ISwebControlName
备注
Name 属性可以在运行时使用，以按名称而不是按类型和编程名称计算对象。由于 Name 属性返回 String 类型，所以可以在 Case 式的逻辑语句中进行计算（在 Visual Basic 中是 Select 语句，在 C# 和 C++ 中是 switch 语句）。
参见

引用

SwebControlBase 类


SwebControlBase.Owner 属性

SwebControlBaseOwner 属性

获取或设置控件的布局控件SwebLayoutControl。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebLayoutControl Owner { get; }
Public ReadOnly Property Owner As SwebLayoutControl
    Get

属性值

类型：SwebLayoutControl
一个 SwebLayoutControl 对象，它表示控件的父控件。
备注
在使用SwebLayoutControl作为父控件时，子控件必须使用Owner才能获取到父控件
参见

引用

SwebControlBase 类


SwebControlBase.Parent 属性

SwebControlBaseParent 属性

获取或设置控件的父控件SwebContainerControl。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebContainerControl Parent { get; }
Public ReadOnly Property Parent As SwebContainerControl
    Get

属性值

类型：SwebContainerControl
一个 SwebContainerControl 对象，它表示控件的父控件。
备注
参见

引用

SwebControlBase 类


SwebControlBase.RenderID 属性

SwebControlBaseRenderID 属性

[缺少 "P:Swebui.Controls.SwebControlBase.RenderID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string RenderID { get; }
Public ReadOnly Property RenderID As String
    Get

属性值

类型：String
参见

引用

SwebControlBase 类


SwebControlBase.Tag 属性

SwebControlBaseTag 属性

获取或设置包含有关控件的数据的对象。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

属性值

类型：Object
一个 Object，它包含有关控件的数据。默认为空引用（Visual Basic 中为 Nothing）。
备注
从 Object 类派生的任何类型都可以分配给该属性。 Tag为弱引用 WeakReference
参见

引用

SwebControlBase 类


SwebControlBase 方法

SwebControlBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值
公共方法 | Invoke(Delegate) |
公共方法 | Invoke(Delegate, Object) |
Top
参见

引用

SwebControlBase 类


SwebControlBase.GetPropertyInitialValue 方法

SwebControlBaseGetPropertyInitialValue 方法

根据属性名称获取STML协议中的属性默认值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object GetPropertyInitialValue(
    string propName
)
Public Function GetPropertyInitialValue (
    propName As String
) As Object

参数

propName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebControlBase.GetPropertyInitialValue(System.String)" 的 <param name="propName"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebControlBase.GetPropertyInitialValue(System.String)" 的 <returns> 文档]

参见

引用

SwebControlBase 类


SwebControlBase.Invoke 方法

SwebControlBaseInvoke 方法

重载列表
 | 名称 | 说明
公共方法 | Invoke(Delegate) |
公共方法 | Invoke(Delegate, Object) |
Top
参见

引用

SwebControlBase 类


SwebControlBase.Invoke 方法 (Delegate)

SwebControlBaseInvoke 方法 (Delegate)

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Invoke(
    Delegate method
)
Public Function Invoke (
    method As Delegate
) As Object

参数

method
类型：SystemDelegate

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate)" 的 <param name="method"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate)" 的 <returns> 文档]

参见

引用

SwebControlBase 类
Invoke 重载


SwebControlBase.Invoke 方法 (Delegate, Object[])

SwebControlBaseInvoke 方法 (Delegate, Object)

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate,System.Object[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Invoke(
    Delegate method,
    params Object[] args
)
Public Function Invoke (
    method As Delegate,
    ParamArray args As Object()
) As Object

参数

method
类型：SystemDelegate

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate,System.Object[])" 的 <param name="method"/> 文档]

args
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate,System.Object[])" 的 <param name="args"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebControlBase.Invoke(System.Delegate,System.Object[])" 的 <returns> 文档]

参见

引用

SwebControlBase 类
Invoke 重载


SwebControlBase 事件

SwebControlBase 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes
Top
参见

引用

SwebControlBase 类


SwebControlBase.PropertyChanged 事件

SwebControlBasePropertyChanged 事件

Occurs when a property value changes

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

值

类型：Swebui.ControlsPropertyChangedEventHandler

实现

INotifyPropertyChangedPropertyChanged
参见

引用

SwebControlBase 类


SwebControlBase 字段

SwebControlBase 类型公开以下成员。

字段
名称 | 说明
ConstBackColorDefault |
ConstBoolFalse |
ConstBoolTrue |
ConstBorderDefault |
ConstBorderRadiusDefault |
ConstFontSizeDefault |
ConstFontSizeStrDefault |
ConstForeColorDefault |
ConstMarginDefault |
ConstPaddingDefault |
ConstVisibleDefault |
SharedBackColorDefault |
SharedBorderColorDefault |
SharedForeColorDefault |
Top
参见

引用

SwebControlBase 类


SwebControlBase.ConstBackColorDefault 字段

SwebControlBaseConstBackColorDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstBackColorDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string ConstBackColorDefault = "Transparent"
Public Const ConstBackColorDefault As String = "Transparent"

字段值

类型：String
参见

引用

SwebControlBase 类


SwebControlBase.ConstBoolFalse 字段

SwebControlBaseConstBoolFalse 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstBoolFalse" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const bool ConstBoolFalse = false
Public Const ConstBoolFalse As Boolean = False

字段值

类型：Boolean
参见

引用

SwebControlBase 类


SwebControlBase.ConstBoolTrue 字段

SwebControlBaseConstBoolTrue 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstBoolTrue" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const bool ConstBoolTrue = true
Public Const ConstBoolTrue As Boolean = True

字段值

类型：Boolean
参见

引用

SwebControlBase 类


SwebControlBase.ConstBorderDefault 字段

SwebControlBaseConstBorderDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstBorderDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const int ConstBorderDefault = 0
Public Const ConstBorderDefault As Integer = 0

字段值

类型：Int32
参见

引用

SwebControlBase 类


SwebControlBase.ConstBorderRadiusDefault 字段

SwebControlBaseConstBorderRadiusDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstBorderRadiusDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const int ConstBorderRadiusDefault = 0
Public Const ConstBorderRadiusDefault As Integer = 0

字段值

类型：Int32
参见

引用

SwebControlBase 类


SwebControlBase.ConstFontSizeDefault 字段

SwebControlBaseConstFontSizeDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstFontSizeDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const float ConstFontSizeDefault = 13f
Public Const ConstFontSizeDefault As Single = 13F

字段值

类型：Single
参见

引用

SwebControlBase 类


SwebControlBase.ConstFontSizeStrDefault 字段

SwebControlBaseConstFontSizeStrDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstFontSizeStrDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string ConstFontSizeStrDefault = "13"
Public Const ConstFontSizeStrDefault As String = "13"

字段值

类型：String
参见

引用

SwebControlBase 类


SwebControlBase.ConstForeColorDefault 字段

SwebControlBaseConstForeColorDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstForeColorDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const string ConstForeColorDefault = "Black"
Public Const ConstForeColorDefault As String = "Black"

字段值

类型：String
参见

引用

SwebControlBase 类


SwebControlBase.ConstMarginDefault 字段

SwebControlBaseConstMarginDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstMarginDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const int ConstMarginDefault = 0
Public Const ConstMarginDefault As Integer = 0

字段值

类型：Int32
参见

引用

SwebControlBase 类


SwebControlBase.ConstPaddingDefault 字段

SwebControlBaseConstPaddingDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstPaddingDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const int ConstPaddingDefault = 0
Public Const ConstPaddingDefault As Integer = 0

字段值

类型：Int32
参见

引用

SwebControlBase 类


SwebControlBase.ConstVisibleDefault 字段

SwebControlBaseConstVisibleDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.ConstVisibleDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public const bool ConstVisibleDefault = true
Public Const ConstVisibleDefault As Boolean = True

字段值

类型：Boolean
参见

引用

SwebControlBase 类


SwebControlBase.SharedBackColorDefault 字段

SwebControlBaseSharedBackColorDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.SharedBackColorDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Color SharedBackColorDefault
Public Shared SharedBackColorDefault As Color

字段值

类型：Color
参见

引用

SwebControlBase 类


SwebControlBase.SharedBorderColorDefault 字段

SwebControlBaseSharedBorderColorDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.SharedBorderColorDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Color SharedBorderColorDefault
Public Shared SharedBorderColorDefault As Color

字段值

类型：Color
参见

引用

SwebControlBase 类


SwebControlBase.SharedForeColorDefault 字段

SwebControlBaseSharedForeColorDefault 字段

[缺少 "F:Swebui.Controls.SwebControlBase.SharedForeColorDefault" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Color SharedForeColorDefault
Public Shared SharedForeColorDefault As Color

字段值

类型：Color
参见

引用

SwebControlBase 类


SwebControlCollection 类

控件集合
继承层次
SystemObject
Swebui.ControlsSwebControlCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebControlCollection : IList,
    ICollection, IEnumerable
Public Class SwebControlCollection
    Implements IList, ICollection, IEnumerable

SwebControlCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebControlCollection | 初始化 SwebControlCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合中 Control 对象的总数。
公共属性 | IsFixedSize |
公共属性 | IsReadOnly | 获取一个值，通过该值指示该控件集合是否为只读。
公共属性 | IsSynchronized |
公共属性 | ItemInt32 | 指示集合中指定索引位置的 SwebControl。
公共属性 | ItemString | 指示集合中指定名称的 SwebControl。
公共属性 | SyncRoot |
Top
方法
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebControl) | 将控件添加到窗体中。
公共方法 | AddRange | 将控件对象数组添加到集合中。
公共方法 | Clear | 从集合中移除所有控件。
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebControl) | 确定指定控件是否为集合的成员。
公共方法 | CopyTo |
公共方法 | Find | 根据控件的 Smobiler.PC.Control.Name 属性搜索控件并返回匹配项。
公共方法 | FindByRenderID | 根据控件的 Smobiler.PC.Control.RenderID 属性搜索控件并返回匹配项。
公共方法 | GetEnumerator | 返回一个可用于循环访问控件集合的枚举数。
公共方法 | IndexOf | 查找指定控件位置
公共方法 | Remove(String) | 从窗体中移除指定名称的控件。
公共方法 | Remove(SwebControl) | 从窗体中移除控件。
公共方法 | RemoveAt | 在指定的索引位置从控件集合移除控件。
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebControlCollection 构造函数

初始化 SwebControlCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControlCollection()
Public Sub New
参见

引用

SwebControlCollection 类


SwebControlCollection 属性

SwebControlCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合中 Control 对象的总数。
公共属性 | IsFixedSize |
公共属性 | IsReadOnly | 获取一个值，通过该值指示该控件集合是否为只读。
公共属性 | IsSynchronized |
公共属性 | ItemInt32 | 指示集合中指定索引位置的 SwebControl。
公共属性 | ItemString | 指示集合中指定名称的 SwebControl。
公共属性 | SyncRoot |
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Count 属性

SwebControlCollectionCount 属性

获取集合中 Control 对象的总数。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32
集合中的 Control 对象总数。

实现

ICollectionCount
备注
Count 属性包含分配给集合的 Control 对象数。可以将 Count 属性值用作循环上限以循环访问集合。
参见

引用

SwebControlCollection 类


SwebControlCollection.IsFixedSize 属性

SwebControlCollectionIsFixedSize 属性

[缺少 "P:Swebui.Controls.SwebControlCollection.IsFixedSize" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get

属性值

类型：Boolean

实现

IListIsFixedSize
参见

引用

SwebControlCollection 类


SwebControlCollection.IsReadOnly 属性

SwebControlCollectionIsReadOnly 属性

获取一个值，通过该值指示该控件集合是否为只读。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

属性值

类型：Boolean
如果该控件集合为只读，则为 true；否则为 false。

实现

IListIsReadOnly
备注
参见

引用

SwebControlCollection 类


SwebControlCollection.IsSynchronized 属性

SwebControlCollectionIsSynchronized 属性

[缺少 "P:Swebui.Controls.SwebControlCollection.IsSynchronized" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

属性值

类型：Boolean

实现

ICollectionIsSynchronized
参见

引用

SwebControlCollection 类


SwebControlCollection.Item 属性

SwebControlCollectionItem 属性

重载列表
 | 名称 | 说明
公共属性 | ItemInt32 | 指示集合中指定索引位置的 SwebControl。
公共属性 | ItemString | 指示集合中指定名称的 SwebControl。
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Item 属性 (Int32)

SwebControlCollectionItem 属性 (Int32)

指示集合中指定索引位置的 SwebControl。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As SwebControl
    Get
    Set

参数

index
类型：SystemInt32
要从控件集合中检索的控件索引。

属性值

类型：SwebControl
位于控件集合内指定索引位置的 SwebControl。
备注
参见

引用

SwebControlCollection 类
Item 重载


SwebControlCollection.Item 属性 (String)

SwebControlCollectionItem 属性 (String)

指示集合中指定名称的 SwebControl。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As SwebControl
    Get
    Set

参数

name
类型：SystemString
要从控件集合中检索的控件名称。

返回值

类型：SwebControl
位于控件集合内指定名称的 SwebControl。
参见

引用

SwebControlCollection 类
Item 重载


SwebControlCollection.SyncRoot 属性

SwebControlCollectionSyncRoot 属性

[缺少 "P:Swebui.Controls.SwebControlCollection.SyncRoot" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

属性值

类型：Object

实现

ICollectionSyncRoot
参见

引用

SwebControlCollection 类


SwebControlCollection 方法

SwebControlCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebControl) | 将控件添加到窗体中。
公共方法 | AddRange | 将控件对象数组添加到集合中。
公共方法 | Clear | 从集合中移除所有控件。
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebControl) | 确定指定控件是否为集合的成员。
公共方法 | CopyTo |
公共方法 | Find | 根据控件的 Smobiler.PC.Control.Name 属性搜索控件并返回匹配项。
公共方法 | FindByRenderID | 根据控件的 Smobiler.PC.Control.RenderID 属性搜索控件并返回匹配项。
公共方法 | GetEnumerator | 返回一个可用于循环访问控件集合的枚举数。
公共方法 | IndexOf | 查找指定控件位置
公共方法 | Remove(String) | 从窗体中移除指定名称的控件。
公共方法 | Remove(SwebControl) | 从窗体中移除控件。
公共方法 | RemoveAt | 在指定的索引位置从控件集合移除控件。
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Add 方法

SwebControlCollectionAdd 方法

重载列表
 | 名称 | 说明
公共方法 | Add(Object) | 添加控件
公共方法 | Add(SwebControl) | 将控件添加到窗体中。
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Add 方法 (Object)

SwebControlCollectionAdd 方法 (Object)

添加控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Add(
    Object value
)
Public Function Add (
    value As Object
) As Integer

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebControlCollection.Add(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebControlCollection.Add(System.Object)" 的 <returns> 文档]

实现

IListAdd(Object)
备注
参见

引用

SwebControlCollection 类
Add 重载


SwebControlCollection.Add 方法 (SwebControl)

SwebControlCollectionAdd 方法 (SwebControl)

将控件添加到窗体中。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Add(
    SwebControl value
)
Public Function Add (
    value As SwebControl
) As Integer

参数

value
类型：Swebui.ControlsSwebControl
要添加到窗体中的 Control。

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebControlCollection.Add(Swebui.Controls.SwebControl)" 的 <returns> 文档]

备注
可以使用此方法将控件添加到窗体中。如果要将一组已经创建的控件添加到窗体中，请使用 ControlCollection.AddRange 方法。
参见

引用

SwebControlCollection 类
Add 重载


SwebControlCollection.AddRange 方法

SwebControlCollectionAddRange 方法

将控件对象数组添加到集合中。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AddRange(
    SwebControl[] ctls
)
Public Sub AddRange (
    ctls As SwebControl()
)

参数

ctls
类型：Swebui.ControlsSwebControl
要添加到集合的 Control 对象的数组。
备注
将 controls 数组中包含的 Control 对象追加到集合的结尾。 可以使用 AddRange 方法将一组 Control 对象迅速添加到集合，而不是通过使用 Add 方法将每个 Control 手动添加到集合中。 若要移除以前添加的 Control，请使用 Remove、RemoveAt 或 Clear 方法。
参见

引用

SwebControlCollection 类


SwebControlCollection.Clear 方法

SwebControlCollectionClear 方法

从集合中移除所有控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Clear()
Public Sub Clear

实现

IListClear
备注
可以使用 Clear 方法从父控件中移除整个控件集合。 若要从集合中移除单个控件，请使用 Remove 或 RemoveAt 方法。 若要向集合中添加新的 Control 对象，请使用 Add 或 AddRange 方法。
参见

引用

SwebControlCollection 类


SwebControlCollection.Contains 方法

SwebControlCollectionContains 方法

重载列表
 | 名称 | 说明
公共方法 | Contains(Object) | 判断是否包含控件
公共方法 | Contains(SwebControl) | 确定指定控件是否为集合的成员。
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Contains 方法 (Object)

SwebControlCollectionContains 方法 (Object)

判断是否包含控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    Object value
)
Public Function Contains (
    value As Object
) As Boolean

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebControlCollection.Contains(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebControlCollection.Contains(System.Object)" 的 <returns> 文档]

实现

IListContains(Object)
备注
参见

引用

SwebControlCollection 类
Contains 重载


SwebControlCollection.Contains 方法 (SwebControl)

SwebControlCollectionContains 方法 (SwebControl)

确定指定控件是否为集合的成员。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    SwebControl value
)
Public Function Contains (
    value As SwebControl
) As Boolean

参数

value
类型：Swebui.ControlsSwebControl
要在集合中定位的 SwebControl。

返回值

类型：Boolean
如果 Control 是集合的成员，则为 true；否则为 false。
备注
参见

引用

SwebControlCollection 类
Contains 重载


SwebControlCollection.CopyTo 方法

SwebControlCollectionCopyTo 方法

[缺少 "M:Swebui.Controls.SwebControlCollection.CopyTo(System.Array,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)

参数

array
类型：SystemArray

[缺少 "M:Swebui.Controls.SwebControlCollection.CopyTo(System.Array,System.Int32)" 的 <param name="array"/> 文档]

index
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebControlCollection.CopyTo(System.Array,System.Int32)" 的 <param name="index"/> 文档]

实现

ICollectionCopyTo(Array, Int32)
参见

引用

SwebControlCollection 类


SwebControlCollection.Find 方法

SwebControlCollectionFind 方法

根据控件的 Smobiler.PC.Control.Name 属性搜索控件并返回匹配项。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl Find(
    string name,
    bool childControl = false
)
Public Function Find (
    name As String,
    Optional childControl As Boolean = false
) As SwebControl

参数

name
类型：SystemString
控件名称
childControl (Optional)
类型：SystemBoolean
是否在子控件中查找

返回值

类型：SwebControl
查找到的控件，若不存在指定控件的名称，返回null
备注
参见

引用

SwebControlCollection 类


SwebControlCollection.FindByRenderID 方法

SwebControlCollectionFindByRenderID 方法

根据控件的 Smobiler.PC.Control.RenderID 属性搜索控件并返回匹配项。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl FindByRenderID(
    int rid,
    bool childControl = false
)
Public Function FindByRenderID (
    rid As Integer,
    Optional childControl As Boolean = false
) As SwebControl

参数

rid
类型：SystemInt32
控件渲染编号
childControl (Optional)
类型：SystemBoolean
是否在子控件中查找

返回值

类型：SwebControl
查找到的控件，若不存在指定控件的名称，返回null
备注
参见

引用

SwebControlCollection 类


SwebControlCollection.GetEnumerator 方法

SwebControlCollectionGetEnumerator 方法

返回一个可用于循环访问控件集合的枚举数。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

返回值

类型：IEnumerator
一个 IEnumerator 对象，它表示控件集合。

实现

IEnumerableGetEnumerator
备注
参见

引用

SwebControlCollection 类


SwebControlCollection.IndexOf 方法

SwebControlCollectionIndexOf 方法

查找指定控件位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int IndexOf(
    Object value
)
Public Function IndexOf (
    value As Object
) As Integer

参数

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebControlCollection.IndexOf(System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebControlCollection.IndexOf(System.Object)" 的 <returns> 文档]

实现

IListIndexOf(Object)
备注
参见

引用

SwebControlCollection 类


SwebControlCollection.Remove 方法

SwebControlCollectionRemove 方法

重载列表
 | 名称 | 说明
公共方法 | Remove(String) | 从窗体中移除指定名称的控件。
公共方法 | Remove(SwebControl) | 从窗体中移除控件。
Top
参见

引用

SwebControlCollection 类


SwebControlCollection.Remove 方法 (String)

SwebControlCollectionRemove 方法 (String)

从窗体中移除指定名称的控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Remove(
    string name
)
Public Sub Remove (
    name As String
)

参数

name
类型：SystemString
要从窗体中移除的 SwebControl 名称
备注
可以使用此方法移除窗体中不再需要的控件。如果要在移除某控件后显示它，将需要使用 Add 方法将该控件重新添加到窗体中。若要使控件保留在窗体上但不显示，请使用该控件的 Visible 属性。
参见

引用

SwebControlCollection 类
Remove 重载


SwebControlCollection.Remove 方法 (SwebControl)

SwebControlCollectionRemove 方法 (SwebControl)

从窗体中移除控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Remove(
    SwebControl value
)
Public Sub Remove (
    value As SwebControl
)

参数

value
类型：Swebui.ControlsSwebControl
要从窗体中移除的 SwebControl。
备注
可以使用此方法移除窗体中不再需要的控件。如果要在移除某控件后显示它，将需要使用 Add 方法将该控件重新添加到窗体中。若要使控件保留在窗体上但不显示，请使用该控件的 Visible 属性。
参见

引用

SwebControlCollection 类
Remove 重载


SwebControlCollection.RemoveAt 方法

SwebControlCollectionRemoveAt 方法

在指定的索引位置从控件集合移除控件。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32
要移除的 Control 的索引值。

实现

IListRemoveAt(Int32)
备注
参见

引用

SwebControlCollection 类


SwebControlEventArgs 类

[缺少 "T:Swebui.Controls.SwebControlEventArgs" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebControlEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebControlEventArgs
Public Class SwebControlEventArgs

SwebControlEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EventArgs |
公共属性 | EventName |
Top
参见

引用

Swebui.Controls 命名空间


SwebControlEventArgs 属性

SwebControlEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EventArgs |
公共属性 | EventName |
Top
参见

引用

SwebControlEventArgs 类


SwebControlEventArgs.EventArgs 属性

SwebControlEventArgsEventArgs 属性

[缺少 "P:Swebui.Controls.SwebControlEventArgs.EventArgs" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Dictionary<string, Object> EventArgs { get; set; }
Public Property EventArgs As Dictionary(Of String, Object)
    Get
    Set

属性值

类型：Dictionary String, Object
参见

引用

SwebControlEventArgs 类


SwebControlEventArgs.EventName 属性

SwebControlEventArgsEventName 属性

[缺少 "P:Swebui.Controls.SwebControlEventArgs.EventName" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string EventName { get; set; }
Public Property EventName As String
    Get
    Set

属性值

类型：String
参见

引用

SwebControlEventArgs 类


SwebControlStyleAttribute 类

控件样式描述声明
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebControlStyleAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebControlStyleAttribute : Attribute
Public Class SwebControlStyleAttribute
    Inherits Attribute

SwebControlStyleAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebControlStyleAttribute | 初始化 SwebControlStyleAttribute 类的一个新实例
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebControlStyleAttribute 构造函数

初始化 SwebControlStyleAttribute 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControlStyleAttribute()
Public Sub New
参见

引用

SwebControlStyleAttribute 类


SwebEditerChangedHandle 委托

一个委托，它表示内容改变时的回调

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void SwebEditerChangedHandle(
    Object sender,
    EditerChangedEventArgs e
)
Public Delegate Sub SwebEditerChangedHandle (
    sender As Object,
    e As EditerChangedEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsEditerChangedEventArgs
参见

引用

Swebui.Controls 命名空间


SwebForm 类

窗体
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsSwebParentControl
Swebui.ControlsSwebForm

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebForm : SwebParentControl
Public Class SwebForm
    Inherits SwebParentControl

SwebForm 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebForm | 初始化 SwebForm 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ActionButton |
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | 获取和设置窗体背景图片
公共属性 | BackgroundImagePath | 获取或设置窗体背景图片路径
公共属性 | BackgroundImageSizeMode | 获取和设置窗体背景图片显示样式
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | (重写 SwebControlBottom.)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Client | 获取客户端变量
公共属性 | Components | 获取包含在组件内的组件的集合。 (继承自 SwebParentControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | (重写 SwebControlBaseDesignStyle.)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Drawer | 获取和设置侧边栏控件
公共属性 | DrawerName | 获取和设置侧边栏控件名称
公共属性 | DrawerPosition | 获取和设置侧边栏出现在屏幕上的位置
公共属性 | DrawerWidth | 获取和设置侧边栏宽度
公共属性 | EnableMirrorPattern | 获取和设置一个值，该值指示会话存在 Mirror 时，当前窗体是否启用手势图形解锁界面
公共属性 | EnableRenderLoading | 获取和设置一个值，该值指示是否开启渲染时的加载状态。
公共属性 | Flex | (重写 SwebControlFlex.)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | (重写 SwebControlLayoutPercentage.)
公共属性 | Left | (重写 SwebControlLeft.)
公共属性 | Location | (重写 SwebControlLocation.)
公共属性 | LowerLocation | (重写 SwebControlLowerLocation.)
公共属性 | Margin | (重写 SwebControlMargin.)
公共属性 | MaxHeightRate | (重写 SwebControlMaxHeightRate.)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。 (继承自 SwebParentControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Orientation | 获取和设置窗体横竖屏状态
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | (重写 SwebControlPosition.)
公共属性 | RelativeScreenSize | 获取相对屏幕密度宽度
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | (重写 SwebControlRight.)
公共属性 | SelfAlign | (重写 SwebControlSelfAlign.)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Session | 获取VT应用程序提供的当前 Session 对象。
公共属性 | ShowResult | 获取或设置窗体的对话框结果。 (继承自 SwebParentControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | Statusbar | 获取和设置窗体状态栏。
公共属性 | TabIndex | (重写 SwebControlTabIndex.)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | (重写 SwebControlTop.)
公共属性 | Visible | (重写 SwebControlVisible.)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | (重写 SwebControlZIndex.)
Top
方法
 | 名称 | 说明
公共方法 | Close | 关闭当前窗体。
公共方法 | CloseDrawer | 关闭侧边栏
公共方法 | CloseLoadingScreen | 关闭加载页面
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | LoadClientData | 添加或修改客户端数据
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | OpenDrawer | 打开侧边栏
公共方法 | ReadClientData | 获取客户端数据
公共方法 | RemoveClientData | 删除客户端数据
公共方法 | Show(SwebForm, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
公共方法 | Show(SwebForm, Boolean, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowLoadingScreen | 显示加载页面
公共方法 | ShowLoadingScreen(String) | 显示加载页面
公共方法 | ShowLoadingScreen(String, Boolean) | 显示加载页面
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast (继承自 SwebParentControl。)
Top
事件
 | 名称 | 说明
公共事件 | ActionButtonPress |
公共事件 | Activated | 在使用代码激活或用户激活窗体时发生
公共事件 | ClientDataLoaded | 在载入客户端数据时发生。
公共事件 | ClientDataReaded | 在获取客户端数据时发生
公共事件 | ClientDataRemoved | 在删除客户端数据时发生。
公共事件 | Closed | 在关闭窗体后发生。
公共事件 | Closing | 在关闭窗体时发生。
公共事件 | CustomCallBack |
公共事件 | Deactivate | 在窗体失去焦点成为不活动窗体时发生。
公共事件 | KeyDown | 在客户端点击实体按键时发生。
公共事件 | Load | 在父容器控件第一次显示前发生。 (继承自 SwebParentControl。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebForm 构造函数

初始化 SwebForm 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebForm()
Public Sub New
参见

引用

SwebForm 类


SwebForm 属性

SwebForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ActionButton |
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | 获取和设置窗体背景图片
公共属性 | BackgroundImagePath | 获取或设置窗体背景图片路径
公共属性 | BackgroundImageSizeMode | 获取和设置窗体背景图片显示样式
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | (重写 SwebControlBottom.)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Client | 获取客户端变量
公共属性 | Components | 获取包含在组件内的组件的集合。 (继承自 SwebParentControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | (重写 SwebControlBaseDesignStyle.)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Drawer | 获取和设置侧边栏控件
公共属性 | DrawerName | 获取和设置侧边栏控件名称
公共属性 | DrawerPosition | 获取和设置侧边栏出现在屏幕上的位置
公共属性 | DrawerWidth | 获取和设置侧边栏宽度
公共属性 | EnableMirrorPattern | 获取和设置一个值，该值指示会话存在 Mirror 时，当前窗体是否启用手势图形解锁界面
公共属性 | EnableRenderLoading | 获取和设置一个值，该值指示是否开启渲染时的加载状态。
公共属性 | Flex | (重写 SwebControlFlex.)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | (重写 SwebControlLayoutPercentage.)
公共属性 | Left | (重写 SwebControlLeft.)
公共属性 | Location | (重写 SwebControlLocation.)
公共属性 | LowerLocation | (重写 SwebControlLowerLocation.)
公共属性 | Margin | (重写 SwebControlMargin.)
公共属性 | MaxHeightRate | (重写 SwebControlMaxHeightRate.)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。 (继承自 SwebParentControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Orientation | 获取和设置窗体横竖屏状态
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | (重写 SwebControlPosition.)
公共属性 | RelativeScreenSize | 获取相对屏幕密度宽度
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | (重写 SwebControlRight.)
公共属性 | SelfAlign | (重写 SwebControlSelfAlign.)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Session | 获取VT应用程序提供的当前 Session 对象。
公共属性 | ShowResult | 获取或设置窗体的对话框结果。 (继承自 SwebParentControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | Statusbar | 获取和设置窗体状态栏。
公共属性 | TabIndex | (重写 SwebControlTabIndex.)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | (重写 SwebControlTop.)
公共属性 | Visible | (重写 SwebControlVisible.)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | (重写 SwebControlZIndex.)
Top
参见

引用

SwebForm 类


SwebForm.ActionButton 属性

SwebFormActionButton 属性

[缺少 "P:Swebui.Controls.SwebForm.ActionButton" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebActionButton ActionButton { get; }
Public ReadOnly Property ActionButton As SwebActionButton
    Get

属性值

类型：SwebActionButton
参见

引用

SwebForm 类


SwebForm.BackgroundImage 属性

SwebFormBackgroundImage 属性

获取和设置窗体背景图片

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImage { get; set; }
Public Property BackgroundImage As String
    Get
    Set

返回值

类型：String
参见

引用

SwebForm 类


SwebForm.BackgroundImagePath 属性

SwebFormBackgroundImagePath 属性

获取或设置窗体背景图片路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImagePath { get; set; }
Public Property BackgroundImagePath As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebForm 类


SwebForm.BackgroundImageSizeMode 属性

SwebFormBackgroundImageSizeMode 属性

获取和设置窗体背景图片显示样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ImageSizeMode BackgroundImageSizeMode { get; set; }
Public Property BackgroundImageSizeMode As ImageSizeMode
    Get
    Set

返回值

类型：ImageSizeMode
参见

引用

SwebForm 类


SwebForm.Border 属性

SwebFormBorder 属性

[缺少 "P:Swebui.Controls.SwebForm.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

SwebForm 类


SwebForm.BorderColor 属性

SwebFormBorderColor 属性

[缺少 "P:Swebui.Controls.SwebForm.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SwebForm 类


SwebForm.BorderRadius 属性

SwebFormBorderRadius 属性

[缺少 "P:Swebui.Controls.SwebForm.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.BorderStyle 属性

SwebFormBorderStyle 属性

[缺少 "P:Swebui.Controls.SwebForm.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

SwebForm 类


SwebForm.Bottom 属性

SwebFormBottom 属性

[缺少 "P:Swebui.Controls.SwebForm.Bottom" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int Bottom { get; set; }
Public Overrides Property Bottom As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.Client 属性

SwebFormClient 属性

获取客户端变量

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebClientInfo Client { get; }
Public ReadOnly Property Client As SwebClientInfo
    Get

返回值

类型：SwebClientInfo
参见

引用

SwebForm 类


SwebForm.DesignStyle 属性

SwebFormDesignStyle 属性

[缺少 "P:Swebui.Controls.SwebForm.DesignStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string DesignStyle { get; set; }
Public Overrides Property DesignStyle As String
    Get
    Set

属性值

类型：String
参见

引用

SwebForm 类


SwebForm.Drawer 属性

SwebFormDrawer 属性

获取和设置侧边栏控件

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl Drawer { get; set; }
Public Property Drawer As SwebUserControl
    Get
    Set

返回值

类型：SwebUserControl
参见

引用

SwebForm 类


SwebForm.DrawerName 属性

SwebFormDrawerName 属性

获取和设置侧边栏控件名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string DrawerName { get; set; }
Public Property DrawerName As String
    Get
    Set

返回值

类型：String
备注
仅在窗体第一次或重新载入时生效，如果设置了DrawerControl，那么设置此属性无效
参见

引用

SwebForm 类


SwebForm.DrawerPosition 属性

SwebFormDrawerPosition 属性

获取和设置侧边栏出现在屏幕上的位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public DrawerPosition DrawerPosition { get; set; }
Public Property DrawerPosition As DrawerPosition
    Get
    Set

返回值

类型：DrawerPosition
参见

引用

SwebForm 类


SwebForm.DrawerWidth 属性

SwebFormDrawerWidth 属性

获取和设置侧边栏宽度

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int DrawerWidth { get; set; }
Public Property DrawerWidth As Integer
    Get
    Set

属性值

类型：Int32
默认为0

返回值

类型：Int32
参见

引用

SwebForm 类


SwebForm.EnableMirrorPattern 属性

SwebFormEnableMirrorPattern 属性

获取和设置一个值，该值指示会话存在 Mirror 时，当前窗体是否启用手势图形解锁界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool EnableMirrorPattern { get; set; }
Public Property EnableMirrorPattern As Boolean
    Get
    Set

属性值

类型：Boolean
默认为True

返回值

类型：Boolean
备注
当设置为True时，必须设置Client.Pattern.Password中的密码值，才能会话修复时显示手势图形解锁界面。
参见

引用

SwebForm 类


SwebForm.EnableRenderLoading 属性

SwebFormEnableRenderLoading 属性

获取和设置一个值，该值指示是否开启渲染时的加载状态。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool EnableRenderLoading { get; set; }
Public Property EnableRenderLoading As Boolean
    Get
    Set

属性值

类型：Boolean
默认为True

返回值

类型：Boolean
备注
客户端开启Loading界面时，分为两种情况，一种是向服务端发出请求，但是请求没有结束时，会处于Loading状态，另外一种是界面渲染在没有完成时也会处于Loading状态，此属性可以关闭界面渲染的Loading，仅用于在界面上加载了过多的数据，防止出现体验上的卡顿（仅在界面第一次或重新加载时生效）
参见

引用

SwebForm 类


SwebForm.Flex 属性

SwebFormFlex 属性

[缺少 "P:Swebui.Controls.SwebForm.Flex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int Flex { get; set; }
Public Overrides Property Flex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.LayoutPercentage 属性

SwebFormLayoutPercentage 属性

[缺少 "P:Swebui.Controls.SwebForm.LayoutPercentage" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutPercentage LayoutPercentage { get; set; }
Public Overrides Property LayoutPercentage As LayoutPercentage
    Get
    Set

属性值

类型：LayoutPercentage
参见

引用

SwebForm 类


SwebForm.Left 属性

SwebFormLeft 属性

[缺少 "P:Swebui.Controls.SwebForm.Left" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int Left { get; set; }
Public Overrides Property Left As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.Location 属性

SwebFormLocation 属性

[缺少 "P:Swebui.Controls.SwebForm.Location" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Point Location { get; set; }
Public Overrides Property Location As Point
    Get
    Set

属性值

类型：Point
参见

引用

SwebForm 类


SwebForm.LowerLocation 属性

SwebFormLowerLocation 属性

[缺少 "P:Swebui.Controls.SwebForm.LowerLocation" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Point LowerLocation { get; set; }
Public Overrides Property LowerLocation As Point
    Get
    Set

属性值

类型：Point
参见

引用

SwebForm 类


SwebForm.Margin 属性

SwebFormMargin 属性

[缺少 "P:Swebui.Controls.SwebForm.Margin" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Margin Margin { get; set; }
Public Overrides Property Margin As Margin
    Get
    Set

属性值

类型：Margin
参见

引用

SwebForm 类


SwebForm.MaxHeightRate 属性

SwebFormMaxHeightRate 属性

[缺少 "P:Swebui.Controls.SwebForm.MaxHeightRate" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int MaxHeightRate { get; set; }
Public Overrides Property MaxHeightRate As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.Orientation 属性

SwebFormOrientation 属性

获取和设置窗体横竖屏状态

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public FormOrientation Orientation { get; set; }
Public Property Orientation As FormOrientation
    Get
    Set

返回值

类型：FormOrientation
参见

引用

SwebForm 类


SwebForm.Position 属性

SwebFormPosition 属性

[缺少 "P:Swebui.Controls.SwebForm.Position" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutPosition Position { get; }
Public Overrides ReadOnly Property Position As LayoutPosition
    Get

属性值

类型：LayoutPosition
参见

引用

SwebForm 类


SwebForm.RelativeScreenSize 属性

SwebFormRelativeScreenSize 属性

获取相对屏幕密度宽度

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public float RelativeScreenSize { get; }
Public ReadOnly Property RelativeScreenSize As Single
    Get

属性值

类型：Single

返回值

类型：Single
备注
参见

引用

SwebForm 类


SwebForm.Right 属性

SwebFormRight 属性

[缺少 "P:Swebui.Controls.SwebForm.Right" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int Right { get; set; }
Public Overrides Property Right As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.SelfAlign 属性

SwebFormSelfAlign 属性

[缺少 "P:Swebui.Controls.SwebForm.SelfAlign" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override LayoutSelfAlign SelfAlign { get; set; }
Public Overrides Property SelfAlign As LayoutSelfAlign
    Get
    Set

属性值

类型：LayoutSelfAlign
参见

引用

SwebForm 类


SwebForm.Session 属性

SwebFormSession 属性

获取VT应用程序提供的当前 Session 对象。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebSessionState Session { get; }
Public ReadOnly Property Session As SwebSessionState
    Get

属性值

类型：SwebSessionState
备注
当用户在应用程序中从一SwebForm移动到另一SwebForm时，存储在 Session 对象中的变量不会被放弃 建议用来存放相对终端的全局变量。
参见

引用

SwebForm 类


SwebForm.Statusbar 属性

SwebFormStatusbar 属性

获取和设置窗体状态栏。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbar Statusbar { get; set; }
Public Property Statusbar As SwebFormStatusbar
    Get
    Set

返回值

类型：SwebFormStatusbar
备注
对状态栏的修改，仅在设计时、窗体第一次加载、窗体重新加载时生效
参见

引用

SwebForm 类


SwebForm.TabIndex 属性

SwebFormTabIndex 属性

[缺少 "P:Swebui.Controls.SwebForm.TabIndex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int TabIndex { get; set; }
Public Overrides Property TabIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.Top 属性

SwebFormTop 属性

[缺少 "P:Swebui.Controls.SwebForm.Top" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int Top { get; set; }
Public Overrides Property Top As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm.Visible 属性

SwebFormVisible 属性

[缺少 "P:Swebui.Controls.SwebForm.Visible" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool Visible { get; set; }
Public Overrides Property Visible As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebForm 类


SwebForm.ZIndex 属性

SwebFormZIndex 属性

[缺少 "P:Swebui.Controls.SwebForm.ZIndex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int ZIndex { get; set; }
Public Overrides Property ZIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

SwebForm 类


SwebForm 方法

SwebForm 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Close | 关闭当前窗体。
公共方法 | CloseDrawer | 关闭侧边栏
公共方法 | CloseLoadingScreen | 关闭加载页面
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | LoadClientData | 添加或修改客户端数据
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | OpenDrawer | 打开侧边栏
公共方法 | ReadClientData | 获取客户端数据
公共方法 | RemoveClientData | 删除客户端数据
公共方法 | Show(SwebForm, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
公共方法 | Show(SwebForm, Boolean, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowLoadingScreen | 显示加载页面
公共方法 | ShowLoadingScreen(String) | 显示加载页面
公共方法 | ShowLoadingScreen(String, Boolean) | 显示加载页面
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast (继承自 SwebParentControl。)
Top
参见

引用

SwebForm 类


SwebForm.Close 方法

SwebFormClose 方法

关闭当前窗体。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Close()
Public Sub Close
备注
窗体关闭后，关闭在该对象内创建的所有资源并且处置该窗体。可以防止在运行时窗体关闭，方法是处理 Closing 事件， 并设置作为参数传递给事件处理方法的 CancelEventArgs 的 Cancel 属性。如果要关闭的窗体是VT应用程序的启动窗体，则该VT应用程序结束。
参见

引用

SwebForm 类


SwebForm.CloseDrawer 方法

SwebFormCloseDrawer 方法

关闭侧边栏

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CloseDrawer()
Public Sub CloseDrawer
参见

引用

SwebForm 类


SwebForm.CloseLoadingScreen 方法

SwebFormCloseLoadingScreen 方法

关闭加载页面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CloseLoadingScreen()
Public Sub CloseLoadingScreen
备注
参见

引用

SwebForm 类


SwebForm.LoadClientData 方法

SwebFormLoadClientData 方法

添加或修改客户端数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void LoadClientData(
    string key,
    string value,
    LoadClientDataCallBackHandler handler = null,
    int timeout = 0,
    bool asyncawait = false
)
Public Sub LoadClientData (
    key As String,
    value As String,
    Optional handler As LoadClientDataCallBackHandler = Nothing,
    Optional timeout As Integer = 0,
    Optional asyncawait As Boolean = false
)

参数

key
类型：SystemString
键
value
类型：SystemString
值
handler (Optional)
类型：Swebui.ControlsLoadClientDataCallBackHandler
在客户端保存数据完成后的回调
timeout (Optional)
类型：SystemInt32
超时时间，默认为0，为0时代表永不超时，大于0时，到达指定的超时时间后会自动触发handler，单位为秒
asyncawait (Optional)
类型：SystemBoolean
同步等待，是否在客户端未返回结果时，使客户端处于等待状态（会在客户端显示一个Loading的状态，用户不可操作客户端上的控件）
备注
参见

引用

SwebForm 类


SwebForm.OpenDrawer 方法

SwebFormOpenDrawer 方法

打开侧边栏

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void OpenDrawer()
Public Sub OpenDrawer
参见

引用

SwebForm 类


SwebForm.ReadClientData 方法

SwebFormReadClientData 方法

获取客户端数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ReadClientData(
    string key,
    ReadClientDataCallBackHandler handler = null,
    int timeout = 0,
    bool asyncawait = false
)
Public Sub ReadClientData (
    key As String,
    Optional handler As ReadClientDataCallBackHandler = Nothing,
    Optional timeout As Integer = 0,
    Optional asyncawait As Boolean = false
)

参数

key
类型：SystemString
键
handler (Optional)
类型：Swebui.ControlsReadClientDataCallBackHandler
在后客户端读取数据完成的回调，获取客户端返回的数据需要在handler中处理
timeout (Optional)
类型：SystemInt32
超时时间，默认为0，为0时代表永不超时，大于0时，到达指定的超时时间后会自动触发handler，单位为秒
asyncawait (Optional)
类型：SystemBoolean
同步等待，是否在客户端未返回结果时，使客户端处于等待状态（会在客户端显示一个Loading的状态，用户不可操作客户端上的控件）
备注
参见

引用

SwebForm 类


SwebForm.RemoveClientData 方法

SwebFormRemoveClientData 方法

删除客户端数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveClientData(
    string key,
    RemoveClientDataCallBackHandler handler = null,
    int timeout = 0,
    bool asyncawait = false
)
Public Sub RemoveClientData (
    key As String,
    Optional handler As RemoveClientDataCallBackHandler = Nothing,
    Optional timeout As Integer = 0,
    Optional asyncawait As Boolean = false
)

参数

key
类型：SystemString
键
handler (Optional)
类型：Swebui.ControlsRemoveClientDataCallBackHandler
在客户端删除数据完成后的回调
timeout (Optional)
类型：SystemInt32
超时时间，默认为0，为0时代表永不超时，大于0时，到达指定的超时时间后会自动触发handler，单位为秒
asyncawait (Optional)
类型：SystemBoolean
同步等待，是否在客户端未返回结果时，使客户端处于等待状态（会在客户端显示一个Loading的状态，用户不可操作客户端上的控件）
备注
参见

引用

SwebForm 类


SwebForm.Show 方法

SwebFormShow 方法

重载列表
 | 名称 | 说明
公共方法 | Show(SwebForm, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
公共方法 | Show(SwebForm, Boolean, FormRedirectCallBackEventHandler, Object) | 跳转指定窗体
Top
参见

引用

SwebForm 类


SwebForm.Show 方法 (SwebForm, FormRedirectCallBackEventHandler, Object)

SwebFormShow 方法 (SwebForm, FormRedirectCallBackEventHandler, Object)

跳转指定窗体

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    SwebForm form,
    FormRedirectCallBackEventHandler callback = null,
    Object args = null
)
Public Sub Show (
    form As SwebForm,
    Optional callback As FormRedirectCallBackEventHandler = Nothing,
    Optional args As Object = Nothing
)

参数

form
类型：Swebui.ControlsSwebForm
跳转的窗体
callback (Optional)
类型：Swebui.ControlsFormRedirectCallBackEventHandler
跳转窗体关闭后回调委托
args (Optional)
类型：SystemObject
可选参数
备注
获取跳转窗体关闭后的回调处理，请实现委托FormRedirectCallBackEventHandler
参见

引用

SwebForm 类
Show 重载


SwebForm.Show 方法 (SwebForm, Boolean, FormRedirectCallBackEventHandler, Object)

SwebFormShow 方法 (SwebForm, Boolean, FormRedirectCallBackEventHandler, Object)

跳转指定窗体

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    SwebForm form,
    bool moveClose,
    FormRedirectCallBackEventHandler callback = null,
    Object args = null
)
Public Sub Show (
    form As SwebForm,
    moveClose As Boolean,
    Optional callback As FormRedirectCallBackEventHandler = Nothing,
    Optional args As Object = Nothing
)

参数

form
类型：Swebui.ControlsSwebForm
跳转的窗体
moveClose
类型：SystemBoolean
跳转的窗体是否可以左滑关闭，false不关闭，true关闭
callback (Optional)
类型：Swebui.ControlsFormRedirectCallBackEventHandler
跳转窗体关闭后回调委托
args (Optional)
类型：SystemObject
可选参数
备注
获取跳转窗体关闭后的回调处理，请实现委托FormRedirectCallBackEventHandler
参见

引用

SwebForm 类
Show 重载


SwebForm.ShowLoadingScreen 方法

SwebFormShowLoadingScreen 方法

重载列表
 | 名称 | 说明
公共方法 | ShowLoadingScreen | 显示加载页面
公共方法 | ShowLoadingScreen(String) | 显示加载页面
公共方法 | ShowLoadingScreen(String, Boolean) | 显示加载页面
Top
参见

引用

SwebForm 类


SwebForm.ShowLoadingScreen 方法

SwebFormShowLoadingScreen 方法

显示加载页面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowLoadingScreen()
Public Sub ShowLoadingScreen
参见

引用

SwebForm 类
ShowLoadingScreen 重载


SwebForm.ShowLoadingScreen 方法 (String)

SwebFormShowLoadingScreen 方法 (String)

显示加载页面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowLoadingScreen(
    string message
)
Public Sub ShowLoadingScreen (
    message As String
)

参数

message
类型：SystemString
显示加载信息
参见

引用

SwebForm 类
ShowLoadingScreen 重载


SwebForm.ShowLoadingScreen 方法 (String, Boolean)

SwebFormShowLoadingScreen 方法 (String, Boolean)

显示加载页面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowLoadingScreen(
    string message,
    bool realtime
)
Public Sub ShowLoadingScreen (
    message As String,
    realtime As Boolean
)

参数

message
类型：SystemString
显示加载信息
realtime
类型：SystemBoolean
设置一个值，该值指示加载页面即时显示，还是在会话完成后显示
备注
参见

引用

SwebForm 类
ShowLoadingScreen 重载


SwebForm 事件

SwebForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | ActionButtonPress |
公共事件 | Activated | 在使用代码激活或用户激活窗体时发生
公共事件 | ClientDataLoaded | 在载入客户端数据时发生。
公共事件 | ClientDataReaded | 在获取客户端数据时发生
公共事件 | ClientDataRemoved | 在删除客户端数据时发生。
公共事件 | Closed | 在关闭窗体后发生。
公共事件 | Closing | 在关闭窗体时发生。
公共事件 | CustomCallBack |
公共事件 | Deactivate | 在窗体失去焦点成为不活动窗体时发生。
公共事件 | KeyDown | 在客户端点击实体按键时发生。
公共事件 | Load | 在父容器控件第一次显示前发生。 (继承自 SwebParentControl。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebForm 类


SwebForm.ActionButtonPress 事件

SwebFormActionButtonPress 事件

[缺少 "E:Swebui.Controls.SwebForm.ActionButtonPress" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ActionButtonPressEventHandler ActionButtonPress
Public Event ActionButtonPress As ActionButtonPressEventHandler

值

类型：Swebui.ControlsActionButtonPressEventHandler
参见

引用

SwebForm 类


SwebForm.Activated 事件

SwebFormActivated 事件

在使用代码激活或用户激活窗体时发生

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Activated
Public Event Activated As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebForm 类


SwebForm.ClientDataLoaded 事件

SwebFormClientDataLoaded 事件

在载入客户端数据时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event LoadClientDataCallBackHandler ClientDataLoaded
Public Event ClientDataLoaded As LoadClientDataCallBackHandler

值

类型：Swebui.ControlsLoadClientDataCallBackHandler
备注
如果LoadClientData方法中的handler声明了委托实例或匿名方法，那么这个事件不会被触发。
参见

引用

SwebForm 类


SwebForm.ClientDataReaded 事件

SwebFormClientDataReaded 事件

在获取客户端数据时发生

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event ReadClientDataCallBackHandler ClientDataReaded
Public Event ClientDataReaded As ReadClientDataCallBackHandler

值

类型：Swebui.ControlsReadClientDataCallBackHandler
备注
如果ReadClientData方法中的handler声明了委托实例或匿名方法，那么这个事件不会被触发。
参见

引用

SwebForm 类


SwebForm.ClientDataRemoved 事件

SwebFormClientDataRemoved 事件

在删除客户端数据时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event RemoveClientDataCallBackHandler ClientDataRemoved
Public Event ClientDataRemoved As RemoveClientDataCallBackHandler

值

类型：Swebui.ControlsRemoveClientDataCallBackHandler
备注
如果RemoveClientData方法中的handler声明了委托实例或匿名方法，那么这个事件不会被触发。
参见

引用

SwebForm 类


SwebForm.Closed 事件

SwebFormClosed 事件

在关闭窗体后发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Closed
Public Event Closed As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebForm 类


SwebForm.Closing 事件

SwebFormClosing 事件

在关闭窗体时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event CancelEventHandler Closing
Public Event Closing As CancelEventHandler

值

类型：System.ComponentModelCancelEventHandler
备注
在窗体关闭时，Closing 事件发生。在窗体关闭后，将释放在该对象内创建的所有资源并处置该窗体。 如果取消此事件，则该窗体保持打开状态。若要取消窗体的关闭操作，请将传递给事件处理程序的 CancelEventArgs 的 Cancel 属性设置为 true。
参见

引用

SwebForm 类


SwebForm.CustomCallBack 事件

SwebFormCustomCallBack 事件

[缺少 "E:Swebui.Controls.SwebForm.CustomCallBack" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event CustomCallBackEventHandler CustomCallBack
Public Event CustomCallBack As CustomCallBackEventHandler

值

类型：Swebui.ControlsCustomCallBackEventHandler
参见

引用

SwebForm 类


SwebForm.Deactivate 事件

SwebFormDeactivate 事件

在窗体失去焦点成为不活动窗体时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Deactivate
Public Event Deactivate As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebForm 类


SwebForm.KeyDown 事件

SwebFormKeyDown 事件

在客户端点击实体按键时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event KeyDownEventHandler KeyDown
Public Event KeyDown As KeyDownEventHandler

值

类型：Swebui.ControlsKeyDownEventHandler
备注
参见

引用

SwebForm 类


SwebFormStatusbar 结构

窗体状态栏

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
[SerializableAttribute]
[TypeConverterAttribute(typeof(SwebFormStatusbarConverter))]
public struct SwebFormStatusbar
<SerializableAttribute>
<TypeConverterAttribute(GetType(SwebFormStatusbarConverter))>
Public Structure SwebFormStatusbar

SwebFormStatusbar 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle) | 创建 SwebFormStatusbar 实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color) | 初始化 SwebFormStatusbar 类的一个新实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color, Boolean) | 初始化 SwebFormStatusbar 类的一个新实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color, Boolean, Boolean) | 初始化 SwebFormStatusbar 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BackColor | 获取或设置窗体状态栏背景色。
公共属性 | BarHidden | 获取或设置一个值，该值指示是否隐藏状态栏。
公共属性 | BarStyle | 获取或设置窗体状态栏样式。
 | Empty | 获取空的状态栏
公共属性 | Translucent | 获取和设置一个值，该值指示是否采用沉浸式状态栏。
Top
方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
字段
名称 | 说明
DefaultBackColor |
DefaultBarStyle |
Top
参见

引用

Swebui.Controls 命名空间


SwebFormStatusbar 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle) | 创建 SwebFormStatusbar 实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color) | 初始化 SwebFormStatusbar 类的一个新实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color, Boolean) | 初始化 SwebFormStatusbar 类的一个新实例
公共方法 | SwebFormStatusbar(SwebFormStatusbarStyle, Color, Boolean, Boolean) | 初始化 SwebFormStatusbar 类的一个新实例
Top
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar 构造函数 (SwebFormStatusbarStyle)

创建 SwebFormStatusbar 实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbar(
    SwebFormStatusbarStyle barStyle
)
Public Sub New (
    barStyle As SwebFormStatusbarStyle
)

参数

barStyle
类型：Swebui.ControlsSwebFormStatusbarStyle
参见

引用

SwebFormStatusbar 结构
SwebFormStatusbar 重载


SwebFormStatusbar 构造函数 (SwebFormStatusbarStyle, Color)

初始化 SwebFormStatusbar 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbar(
    SwebFormStatusbarStyle barStyle,
    Color backcolor
)
Public Sub New (
    barStyle As SwebFormStatusbarStyle,
    backcolor As Color
)

参数

barStyle
类型：Swebui.ControlsSwebFormStatusbarStyle

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color)" 的 <param name="barStyle"/> 文档]

backcolor
类型：System.DrawingColor

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color)" 的 <param name="backcolor"/> 文档]

参见

引用

SwebFormStatusbar 结构
SwebFormStatusbar 重载


SwebFormStatusbar 构造函数 (SwebFormStatusbarStyle, Color, Boolean)

初始化 SwebFormStatusbar 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbar(
    SwebFormStatusbarStyle barStyle,
    Color backcolor,
    bool translucent
)
Public Sub New (
    barStyle As SwebFormStatusbarStyle,
    backcolor As Color,
    translucent As Boolean
)

参数

barStyle
类型：Swebui.ControlsSwebFormStatusbarStyle

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean)" 的 <param name="barStyle"/> 文档]

backcolor
类型：System.DrawingColor

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean)" 的 <param name="backcolor"/> 文档]

translucent
类型：SystemBoolean

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean)" 的 <param name="translucent"/> 文档]

参见

引用

SwebFormStatusbar 结构
SwebFormStatusbar 重载


SwebFormStatusbar 构造函数 (SwebFormStatusbarStyle, Color, Boolean, Boolean)

初始化 SwebFormStatusbar 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbar(
    SwebFormStatusbarStyle barStyle,
    Color backcolor,
    bool translucent,
    bool barHidden
)
Public Sub New (
    barStyle As SwebFormStatusbarStyle,
    backcolor As Color,
    translucent As Boolean,
    barHidden As Boolean
)

参数

barStyle
类型：Swebui.ControlsSwebFormStatusbarStyle

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean,System.Boolean)" 的 <param name="barStyle"/> 文档]

backcolor
类型：System.DrawingColor

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean,System.Boolean)" 的 <param name="backcolor"/> 文档]

translucent
类型：SystemBoolean

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean,System.Boolean)" 的 <param name="translucent"/> 文档]

barHidden
类型：SystemBoolean

[缺少 "M:Swebui.Controls.SwebFormStatusbar.#ctor(Swebui.Controls.SwebFormStatusbarStyle,System.Drawing.Color,System.Boolean,System.Boolean)" 的 <param name="barHidden"/> 文档]

参见

引用

SwebFormStatusbar 结构
SwebFormStatusbar 重载


SwebFormStatusbar 属性

SwebFormStatusbar 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BackColor | 获取或设置窗体状态栏背景色。
公共属性 | BarHidden | 获取或设置一个值，该值指示是否隐藏状态栏。
公共属性 | BarStyle | 获取或设置窗体状态栏样式。
 | Empty | 获取空的状态栏
公共属性 | Translucent | 获取和设置一个值，该值指示是否采用沉浸式状态栏。
Top
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.BackColor 属性

SwebFormStatusbarBackColor 属性

获取或设置窗体状态栏背景色。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Color BackColor { get; }
Public ReadOnly Property BackColor As Color
    Get

属性值

类型：Color
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.BarHidden 属性

SwebFormStatusbarBarHidden 属性

获取或设置一个值，该值指示是否隐藏状态栏。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool BarHidden { get; }
Public ReadOnly Property BarHidden As Boolean
    Get

属性值

类型：Boolean

返回值

类型：Boolean
备注
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.BarStyle 属性

SwebFormStatusbarBarStyle 属性

获取或设置窗体状态栏样式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbarStyle BarStyle { get; }
Public ReadOnly Property BarStyle As SwebFormStatusbarStyle
    Get

属性值

类型：SwebFormStatusbarStyle
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.Empty 属性

SwebFormStatusbarEmpty 属性

获取空的状态栏

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebFormStatusbar Empty { get; }
Public Shared ReadOnly Property Empty As SwebFormStatusbar
    Get

返回值

类型：SwebFormStatusbar
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.Translucent 属性

SwebFormStatusbarTranslucent 属性

获取和设置一个值，该值指示是否采用沉浸式状态栏。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Translucent { get; }
Public ReadOnly Property Translucent As Boolean
    Get

返回值

类型：Boolean
备注
Android5.0以下不支持
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar 方法

SwebFormStatusbar 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ToString | (重写 ValueTypeToString.)
Top
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.ToString 方法

SwebFormStatusbarToString 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbar.ToString" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ToString()
Public Overrides Function ToString As String

返回值

类型：String

[缺少 "M:Swebui.Controls.SwebFormStatusbar.ToString" 的 <returns> 文档]

参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar 字段

SwebFormStatusbar 类型公开以下成员。

字段
名称 | 说明
DefaultBackColor |
DefaultBarStyle |
Top
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.DefaultBackColor 字段

SwebFormStatusbarDefaultBackColor 字段

[缺少 "F:Swebui.Controls.SwebFormStatusbar.DefaultBackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static Color DefaultBackColor
Public Shared DefaultBackColor As Color

字段值

类型：Color
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbar.DefaultBarStyle 字段

SwebFormStatusbarDefaultBarStyle 字段

[缺少 "F:Swebui.Controls.SwebFormStatusbar.DefaultBarStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebFormStatusbarStyle DefaultBarStyle
Public Shared DefaultBarStyle As SwebFormStatusbarStyle

字段值

类型：SwebFormStatusbarStyle
参见

引用

SwebFormStatusbar 结构


SwebFormStatusbarConverter 类

为SwebFormStatusbar提供类型转换
继承层次
SystemObject
System.ComponentModelTypeConverter
Swebui.ControlsSwebFormStatusbarConverter

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebFormStatusbarConverter : TypeConverter
Public Class SwebFormStatusbarConverter
    Inherits TypeConverter

SwebFormStatusbarConverter 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebFormStatusbarConverter | 初始化 SwebFormStatusbarConverter 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
参见

引用

Swebui.Controls 命名空间


SwebFormStatusbarConverter 构造函数

初始化 SwebFormStatusbarConverter 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebFormStatusbarConverter()
Public Sub New
参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter 方法

SwebFormStatusbarConverter 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CanConvertFrom | (重写 TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
公共方法 | CanConvertTo | (重写 TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
公共方法 | ConvertFrom | (重写 TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
公共方法 | ConvertTo | (重写 TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
公共方法 | CreateInstance | (重写 TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
公共方法 | GetCreateInstanceSupported | (重写 TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
公共方法 | GetProperties | (重写 TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
公共方法 | GetPropertiesSupported | (重写 TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.CanConvertFrom 方法

SwebFormStatusbarConverterCanConvertFrom 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

sourceType
类型：SystemType

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="sourceType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.CanConvertTo 方法

SwebFormStatusbarConverterCanConvertTo 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="context"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.ConvertFrom 方法

SwebFormStatusbarConverterConvertFrom 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <param name="value"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.ConvertTo 方法

SwebFormStatusbarConverterConvertTo 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="context"/> 文档]

culture
类型：System.GlobalizationCultureInfo

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="culture"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="value"/> 文档]

destinationType
类型：SystemType

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <param name="destinationType"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.CreateInstance 方法

SwebFormStatusbarConverterCreateInstance 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Public Overrides Function CreateInstance (
    context As ITypeDescriptorContext,
    propertyValues As IDictionary
) As Object

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="context"/> 文档]

propertyValues
类型：System.CollectionsIDictionary

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <param name="propertyValues"/> 文档]

返回值

类型：Object

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.CreateInstance(System.ComponentModel.ITypeDescriptorContext,System.Collections.IDictionary)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.GetCreateInstanceSupported 方法

SwebFormStatusbarConverterGetCreateInstanceSupported 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetCreateInstanceSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetCreateInstanceSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.GetProperties 方法

SwebFormStatusbarConverterGetProperties 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="context"/> 文档]

value
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="value"/> 文档]

attributes
类型：SystemAttribute

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <param name="attributes"/> 文档]

返回值

类型：PropertyDescriptorCollection

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetProperties(System.ComponentModel.ITypeDescriptorContext,System.Object,System.Attribute[])" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarConverter.GetPropertiesSupported 方法

SwebFormStatusbarConverterGetPropertiesSupported 方法

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

参数

context
类型：System.ComponentModelITypeDescriptorContext

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <param name="context"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebFormStatusbarConverter.GetPropertiesSupported(System.ComponentModel.ITypeDescriptorContext)" 的 <returns> 文档]

参见

引用

SwebFormStatusbarConverter 类


SwebFormStatusbarStyle 枚举

窗体状态栏样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum SwebFormStatusbarStyle
Public Enumeration SwebFormStatusbarStyle
成员
成员名称 | 值 | 说明
Default | 0 | 系统默认样式
Light | 1 | 浅色样式
Dark | 2 | 深色样式
参见

引用

Swebui.Controls 命名空间


SwebHandlerArgs 类

HandlerArgs基类
继承层次
SystemObject
Swebui.ControlsSwebHandlerArgs
Swebui.ControlsMessageBoxHandlerArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebHandlerArgs
Public MustInherit Class SwebHandlerArgs

SwebHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Args | 获取委托或事件中的可选参数
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebHandlerArgs 属性

SwebHandlerArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Args | 获取委托或事件中的可选参数
Top
参见

引用

SwebHandlerArgs 类


SwebHandlerArgs.Args 属性

SwebHandlerArgsArgs 属性

获取委托或事件中的可选参数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Args { get; }
Public ReadOnly Property Args As Object
    Get

属性值

类型：Object

返回值

类型：Object
备注
参见

引用

SwebHandlerArgs 类


SwebLayoutControl 类

布局控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsListView
Swebui.ControlsPageView
Swebui.ControlsSwebContainerControl
Swebui.ControlsTreeView

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebLayoutControl : SwebControl
Public Class SwebLayoutControl
    Inherits SwebControl

SwebLayoutControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebLayoutControl | 初始化 SwebLayoutControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。
公共属性 | Layout | 获取和设置布局
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面
公共方法 | FindByRenderID |
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebLayoutControl 构造函数

初始化 SwebLayoutControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebLayoutControl()
Public Sub New
参见

引用

SwebLayoutControl 类


SwebLayoutControl 属性

SwebLayoutControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。
公共属性 | Layout | 获取和设置布局
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebLayoutControl 类


SwebLayoutControl.Direction 属性

SwebLayoutControlDirection 属性

获取和设置容器主轴方向。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutDirection Direction { get; set; }
Public Overridable Property Direction As LayoutDirection
    Get
    Set

返回值

类型：LayoutDirection
参见

引用

SwebLayoutControl 类


SwebLayoutControl.ItemAlign 属性

SwebLayoutControlItemAlign 属性

获取和设置布局控件内元素在侧轴上的对齐方式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutItemAlign ItemAlign { get; set; }
Public Overridable Property ItemAlign As LayoutItemAlign
    Get
    Set

返回值

类型：LayoutItemAlign
参见

引用

SwebLayoutControl 类


SwebLayoutControl.JustifyAlign 属性

SwebLayoutControlJustifyAlign 属性

获取和设置布局控件内元素在主轴上的对齐方式。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutJustifyAlign JustifyAlign { get; set; }
Public Overridable Property JustifyAlign As LayoutJustifyAlign
    Get
    Set

返回值

类型：LayoutJustifyAlign
参见

引用

SwebLayoutControl 类


SwebLayoutControl.Layout 属性

SwebLayoutControlLayout 属性

获取和设置布局

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutPosition Layout { get; set; }
Public Overridable Property Layout As LayoutPosition
    Get
    Set

返回值

类型：LayoutPosition
参见

引用

SwebLayoutControl 类


SwebLayoutControl.Overflow 属性

SwebLayoutControlOverflow 属性

获取和设置容器布局覆盖范围

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutOverflow Overflow { get; set; }
Public Overridable Property Overflow As LayoutOverflow
    Get
    Set

返回值

类型：LayoutOverflow
参见

引用

SwebLayoutControl 类


SwebLayoutControl.PointerEvent 属性

SwebLayoutControlPointerEvent 属性

获取和设置控制当前组件是否可以作为触控事件的目标

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public PointerEventType PointerEvent { get; set; }
Public Property PointerEvent As PointerEventType
    Get
    Set

返回值

类型：PointerEventType
参见

引用

SwebLayoutControl 类


SwebLayoutControl.Wrap 属性

SwebLayoutControlWrap 属性

获取和设置子控件如果超出容器空间时，是否换行。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual LayoutWrap Wrap { get; set; }
Public Overridable Property Wrap As LayoutWrap
    Get
    Set

返回值

类型：LayoutWrap
参见

引用

SwebLayoutControl 类


SwebLayoutControl 方法

SwebLayoutControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面
公共方法 | FindByRenderID |
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面
Top
参见

引用

SwebLayoutControl 类


SwebLayoutControl.DestroyDialog 方法

SwebLayoutControlDestroyDialog 方法

销毁弹出用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void DestroyDialog(
    SwebUserControl control
)
Public Sub DestroyDialog (
    control As SwebUserControl
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
参见

引用

SwebLayoutControl 类


SwebLayoutControl.FindByRenderID 方法

SwebLayoutControlFindByRenderID 方法

[缺少 "M:Swebui.Controls.SwebLayoutControl.FindByRenderID(System.Int32,System.Boolean)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebControl FindByRenderID(
    int rid,
    bool child
)
Public Function FindByRenderID (
    rid As Integer,
    child As Boolean
) As SwebControl

参数

rid
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebLayoutControl.FindByRenderID(System.Int32,System.Boolean)" 的 <param name="rid"/> 文档]

child
类型：SystemBoolean

[缺少 "M:Swebui.Controls.SwebLayoutControl.FindByRenderID(System.Int32,System.Boolean)" 的 <param name="child"/> 文档]

返回值

类型：SwebControl

[缺少 "M:Swebui.Controls.SwebLayoutControl.FindByRenderID(System.Int32,System.Boolean)" 的 <returns> 文档]

参见

引用

SwebLayoutControl 类


SwebLayoutControl.OnBindValueUpdate 方法

SwebLayoutControlOnBindValueUpdate 方法

[缺少 "M:Swebui.Controls.SwebLayoutControl.OnBindValueUpdate(Swebui.Controls.ISwebDataBindableControl)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void OnBindValueUpdate(
    ISwebDataBindableControl ctl
)
Public Overridable Sub OnBindValueUpdate (
    ctl As ISwebDataBindableControl
)

参数

ctl
类型：Swebui.ControlsISwebDataBindableControl

[缺少 "M:Swebui.Controls.SwebLayoutControl.OnBindValueUpdate(Swebui.Controls.ISwebDataBindableControl)" 的 <param name="ctl"/> 文档]

参见

引用

SwebLayoutControl 类


SwebLayoutControl.ShowContextDialog 方法

SwebLayoutControlShowContextDialog 方法

弹出上下文用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowContextDialog(
    SwebUserControl control
)
Public Sub ShowContextDialog (
    control As SwebUserControl
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
参见

引用

SwebLayoutControl 类


SwebLayoutControl.ShowDialog 方法

SwebLayoutControlShowDialog 方法

重载列表
 | 名称 | 说明
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面
Top
参见

引用

SwebLayoutControl 类


SwebLayoutControl.ShowDialog 方法 (SwebUserControl, EventHandler)

SwebLayoutControlShowDialog 方法 (SwebUserControl, EventHandler)

弹出用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowDialog(
    SwebUserControl control,
    EventHandler closedHandler = null
)
Public Sub ShowDialog (
    control As SwebUserControl,
    Optional closedHandler As EventHandler = Nothing
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
closedHandler (Optional)
类型：SystemEventHandler

[缺少 "M:Swebui.Controls.SwebLayoutControl.ShowDialog(Swebui.Controls.SwebUserControl,System.EventHandler)" 的 <param name="closedHandler"/> 文档]

备注
在不再使用弹出用户控件界面时，使用DestroyDialog方法销毁，否则会常驻客户端内存
默认的DialogOptions为：
JustifyAlign = Center,
Padding = 20,
BackColor = 200,128,128,128,
AnimationType = None,
TouchClosed = true
参见

引用

SwebLayoutControl 类
ShowDialog 重载


SwebLayoutControl.ShowDialog 方法 (SwebUserControl, DialogOptions, EventHandler)

SwebLayoutControlShowDialog 方法 (SwebUserControl, DialogOptions, EventHandler)

弹出用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowDialog(
    SwebUserControl control,
    DialogOptions options,
    EventHandler closedHandler = null
)
Public Sub ShowDialog (
    control As SwebUserControl,
    options As DialogOptions,
    Optional closedHandler As EventHandler = Nothing
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
options
类型：Swebui.ControlsDialogOptions
弹出框设置
closedHandler (Optional)
类型：SystemEventHandler

[缺少 "M:Swebui.Controls.SwebLayoutControl.ShowDialog(Swebui.Controls.SwebUserControl,Swebui.Controls.DialogOptions,System.EventHandler)" 的 <param name="closedHandler"/> 文档]

备注
在不再使用弹出用户控件界面时，使用DestroyDialog方法销毁，否则会常驻客户端内存
默认的DialogOptions为：
JustifyAlign = Center,
Padding = 20,
BackColor = 200,128,128,128,
AnimationType = None,
TouchClosed = true
参见

引用

SwebLayoutControl 类
ShowDialog 重载


SwebLayoutControl.ShowModal 方法

SwebLayoutControlShowModal 方法

重载列表
 | 名称 | 说明
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面
Top
参见

引用

SwebLayoutControl 类


SwebLayoutControl.ShowModal 方法 (SwebUserControl)

SwebLayoutControlShowModal 方法 (SwebUserControl)

弹出用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowModal(
    SwebUserControl control
)
Public Sub ShowModal (
    control As SwebUserControl
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
备注
ShowModal一次仅能显示一个用户控件界面，并不能叠加显示，如果需要叠加显示，请使用ShowDialog方法
默认的DialogOptions为：
JustifyAlign = Center,
Padding = 20,
BackColor = 200,128,128,128,
AnimationType = None,
TouchClosed = true
参见

引用

SwebLayoutControl 类
ShowModal 重载


SwebLayoutControl.ShowModal 方法 (SwebUserControl, DialogOptions)

SwebLayoutControlShowModal 方法 (SwebUserControl, DialogOptions)

弹出用户控件界面

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void ShowModal(
    SwebUserControl control,
    DialogOptions options
)
Public Sub ShowModal (
    control As SwebUserControl,
    options As DialogOptions
)

参数

control
类型：Swebui.ControlsSwebUserControl
用户控件
options
类型：Swebui.ControlsDialogOptions
弹出框设置
备注
ShowModal一次仅能显示一个用户控件界面，并不能叠加显示，如果需要叠加显示，请使用ShowDialog方法
默认的DialogOptions为：
JustifyAlign = Center,
Padding = 20,
BackColor = 200,128,128,128,
AnimationType = None,
TouchClosed = true
参见

引用

SwebLayoutControl 类
ShowModal 重载


SwebLayoutControl 事件

SwebLayoutControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebLayoutControl 类


SwebListViewTemplateItem 类

[缺少 "T:Swebui.Controls.SwebListViewTemplateItem" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsSwebListViewTemplateItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebListViewTemplateItem : SwebViewTemplateItem
Public MustInherit Class SwebListViewTemplateItem
    Inherits SwebViewTemplateItem

SwebListViewTemplateItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

Swebui.Controls 命名空间


SwebListViewTemplateItem 属性

SwebListViewTemplateItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例 (继承自 SwebViewTemplateItem。)
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

SwebListViewTemplateItem 类


SwebListViewTemplateItem 方法

SwebListViewTemplateItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据 (继承自 SwebViewTemplateItem。)
Top
参见

引用

SwebListViewTemplateItem 类


SwebMessageBox 类

显示可包含文本、按钮（通知并指示用户）的消息框。
继承层次
SystemObject
Swebui.ControlsSwebMessageBox

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public sealed class SwebMessageBox
Public NotInheritable Class SwebMessageBox

SwebMessageBox 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebMessageBox | 初始化 SwebMessageBox 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Position | 获取和设置消息框显示位置。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (重写 ObjectEquals(Object).)
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType |
公共方法 | Show(String) | 显示具有指定文本的消息框。
公共方法 | Show(String, String) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
公共方法 | Show(String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本和按钮的消息框。
公共方法 | Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮的消息框。
公共方法 | Show(String, String, String, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮和默认按钮的消息框。
公共方法 | ToString | (重写 ObjectToString.)
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebMessageBox 构造函数

初始化 SwebMessageBox 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMessageBox(
    SwebParentControl parentControl
)
Public Sub New (
    parentControl As SwebParentControl
)

参数

parentControl
类型：Swebui.ControlsSwebParentControl

[缺少 "M:Swebui.Controls.SwebMessageBox.#ctor(Swebui.Controls.SwebParentControl)" 的 <param name="parentControl"/> 文档]

参见

引用

SwebMessageBox 类


SwebMessageBox 属性

SwebMessageBox 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Position | 获取和设置消息框显示位置。
Top
参见

引用

SwebMessageBox 类


SwebMessageBox.Position 属性

SwebMessageBoxPosition 属性

获取和设置消息框显示位置。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMessageBoxPosition Position { get; set; }
Public Property Position As SwebMessageBoxPosition
    Get
    Set

返回值

类型：SwebMessageBoxPosition
备注
在Position设置为Bottom时，默认会添加一个取消的按钮，在用户点击取消按钮时，结果中的Index为-1，Result为ShowResult.None
参见

引用

SwebMessageBox 类


SwebMessageBox 方法

SwebMessageBox 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (重写 ObjectEquals(Object).)
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType |
公共方法 | Show(String) | 显示具有指定文本的消息框。
公共方法 | Show(String, String) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
公共方法 | Show(String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本和按钮的消息框。
公共方法 | Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮的消息框。
公共方法 | Show(String, String, String, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮和默认按钮的消息框。
公共方法 | ToString | (重写 ObjectToString.)
Top
参见

引用

SwebMessageBox 类


SwebMessageBox.Equals 方法

SwebMessageBoxEquals 方法

[缺少 "M:Swebui.Controls.SwebMessageBox.Equals(System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

参数

obj
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebMessageBox.Equals(System.Object)" 的 <param name="obj"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebMessageBox.Equals(System.Object)" 的 <returns> 文档]

参见

引用

SwebMessageBox 类


SwebMessageBox.GetHashCode 方法

SwebMessageBoxGetHashCode 方法

[缺少 "M:Swebui.Controls.SwebMessageBox.GetHashCode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebMessageBox.GetHashCode" 的 <returns> 文档]

参见

引用

SwebMessageBox 类


SwebMessageBox.GetType 方法

SwebMessageBoxGetType 方法

[缺少 "M:Swebui.Controls.SwebMessageBox.GetType" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Type GetType()
Public Function GetType As Type

返回值

类型：Type

[缺少 "M:Swebui.Controls.SwebMessageBox.GetType" 的 <returns> 文档]

参见

引用

SwebMessageBox 类


SwebMessageBox.Show 方法

SwebMessageBoxShow 方法

重载列表
 | 名称 | 说明
公共方法 | Show(String) | 显示具有指定文本的消息框。
公共方法 | Show(String, String) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, MessageBoxHandler, Object) | 显示具有指定文本的消息框。
公共方法 | Show(String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本和按钮的消息框。
公共方法 | Show(String, String, MessageBoxHandler, Object) | 显示具有指定文本和标题的消息框。
公共方法 | Show(String, String, MessageBoxButtons, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮的消息框。
公共方法 | Show(String, String, String, MessageBoxHandler, Object) | 显示具有指定文本、标题、按钮和默认按钮的消息框。
Top
参见

引用

SwebMessageBox 类


SwebMessageBox.Show 方法 (String)

SwebMessageBoxShow 方法 (String)

显示具有指定文本的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text
)
Public Sub Show (
    text As String
)

参数

text
类型：SystemString
要在消息框中显示的文本。
备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, String)

SwebMessageBoxShow 方法 (String, String)

显示具有指定文本和标题的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    string caption
)
Public Sub Show (
    text As String,
    caption As String
)

参数

text
类型：SystemString
要在消息框中显示的文本。
caption
类型：SystemString
要在消息框的标题栏中显示的文本。
备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, MessageBoxHandler, Object)

SwebMessageBoxShow 方法 (String, MessageBoxHandler, Object)

显示具有指定文本的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    MessageBoxHandler handler,
    Object args = null
)
Public Sub Show (
    text As String,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

text
类型：SystemString
要在消息框中显示的文本。
handler
类型：Swebui.ControlsMessageBoxHandler
消息回调
args (Optional)
类型：SystemObject
扩展数据
备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, MessageBoxButtons, MessageBoxHandler, Object)

SwebMessageBoxShow 方法 (String, MessageBoxButtons, MessageBoxHandler, Object)

显示具有指定文本和按钮的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    MessageBoxButtons buttons,
    MessageBoxHandler handler,
    Object args = null
)
Public Sub Show (
    text As String,
    buttons As MessageBoxButtons,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

text
类型：SystemString
要在消息框中显示的文本。
buttons
类型：Swebui.ControlsMessageBoxButtons
可指定在消息框中显示哪些按钮。
handler
类型：Swebui.ControlsMessageBoxHandler
消息回调
args (Optional)
类型：SystemObject
扩展数据
备注
在消息框中最多可以有三个按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, String, MessageBoxHandler, Object)

SwebMessageBoxShow 方法 (String, String, MessageBoxHandler, Object)

显示具有指定文本和标题的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    string caption,
    MessageBoxHandler handler,
    Object args = null
)
Public Sub Show (
    text As String,
    caption As String,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

text
类型：SystemString
要在消息框中显示的文本。
caption
类型：SystemString
要在消息框的标题栏中显示的文本。
handler
类型：Swebui.ControlsMessageBoxHandler
消息回调
args (Optional)
类型：SystemObject
扩展数据
备注
默认情况下，消息框显示一个 OK 按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, String, MessageBoxButtons, MessageBoxHandler, Object)

SwebMessageBoxShow 方法 (String, String, MessageBoxButtons, MessageBoxHandler, Object)

显示具有指定文本、标题、按钮的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    string caption,
    MessageBoxButtons buttons,
    MessageBoxHandler handler,
    Object args = null
)
Public Sub Show (
    text As String,
    caption As String,
    buttons As MessageBoxButtons,
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

text
类型：SystemString
要在消息框中显示的文本。
caption
类型：SystemString
要在消息框的标题栏中显示的文本。
buttons
类型：Swebui.ControlsMessageBoxButtons
可指定在消息框中显示哪些按钮。
handler
类型：Swebui.ControlsMessageBoxHandler
消息回调
args (Optional)
类型：SystemObject
扩展数据
备注
在消息框中最多可以有三个按钮。
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.Show 方法 (String, String, String[], MessageBoxHandler, Object)

SwebMessageBoxShow 方法 (String, String, String, MessageBoxHandler, Object)

显示具有指定文本、标题、按钮和默认按钮的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Show(
    string text,
    string caption,
    string[] buttons,
    MessageBoxHandler handler,
    Object args = null
)
Public Sub Show (
    text As String,
    caption As String,
    buttons As String(),
    handler As MessageBoxHandler,
    Optional args As Object = Nothing
)

参数

text
类型：SystemString
要在消息框中显示的文本
caption
类型：SystemString
要在消息框的标题栏中显示的文本
buttons
类型：SystemString
可指定在消息框中显示哪些按钮
handler
类型：Swebui.ControlsMessageBoxHandler
消息回调
args (Optional)
类型：SystemObject
扩展数据
参见

引用

SwebMessageBox 类
Show 重载


SwebMessageBox.ToString 方法

SwebMessageBoxToString 方法

[缺少 "M:Swebui.Controls.SwebMessageBox.ToString" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override string ToString()
Public Overrides Function ToString As String

返回值

类型：String

[缺少 "M:Swebui.Controls.SwebMessageBox.ToString" 的 <returns> 文档]

参见

引用

SwebMessageBox 类


SwebMessageBoxPosition 枚举

消息框显示位置

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum SwebMessageBoxPosition
Public Enumeration SwebMessageBoxPosition
成员
成员名称 | 值 | 说明
Default | 0 | 默认显示位置
Bottom | 1 | 底部显示
参见

引用

Swebui.Controls 命名空间


SwebMethodAttribute 类

方法特性
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebMethodAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebMethodAttribute : Attribute
Public Class SwebMethodAttribute
    Inherits Attribute

SwebMethodAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebMethodAttribute | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Method | 获取RPC方法名称
Top
参见

引用

Swebui.Controls 命名空间


SwebMethodAttribute 构造函数

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMethodAttribute(
    string methodName
)
Public Sub New (
    methodName As String
)

参数

methodName
类型：SystemString
RPC方法名称
参见

引用

SwebMethodAttribute 类


SwebMethodAttribute 属性

SwebMethodAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Method | 获取RPC方法名称
Top
参见

引用

SwebMethodAttribute 类


SwebMethodAttribute.Method 属性

SwebMethodAttributeMethod 属性

获取RPC方法名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Method { get; }
Public ReadOnly Property Method As String
    Get

返回值

类型：String
参见

引用

SwebMethodAttribute 类


SwebModuleAttribute 类

模板特性
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebModuleAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebModuleAttribute : Attribute
Public Class SwebModuleAttribute
    Inherits Attribute

SwebModuleAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebModuleAttribute | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Module | 获取组件或控件模板名称
Top
参见

引用

Swebui.Controls 命名空间


SwebModuleAttribute 构造函数

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebModuleAttribute(
    string moduleName
)
Public Sub New (
    moduleName As String
)

参数

moduleName
类型：SystemString
组件或控件模板名称
参见

引用

SwebModuleAttribute 类


SwebModuleAttribute 属性

SwebModuleAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Module | 获取组件或控件模板名称
Top
参见

引用

SwebModuleAttribute 类


SwebModuleAttribute.Module 属性

SwebModuleAttributeModule 属性

获取组件或控件模板名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Module { get; }
Public ReadOnly Property Module As String
    Get

返回值

类型：String
参见

引用

SwebModuleAttribute 类


SwebMouseMoveEventArgs 类

为 SwebMouseMoveEventHandler 绑定提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsSwebMousePressEventArgs
Swebui.ControlsSwebMouseMoveEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebMouseMoveEventArgs : SwebMousePressEventArgs
Public Class SwebMouseMoveEventArgs
    Inherits SwebMousePressEventArgs

SwebMouseMoveEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebMouseMoveEventArgs | 初始化 SwebMouseMoveEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Height | (继承自 SwebMousePressEventArgs。)
公共属性 | Left | (继承自 SwebMousePressEventArgs。)
公共属性 | Position | 移动方向
公共属性 | Top | (继承自 SwebMousePressEventArgs。)
公共属性 | Width | (继承自 SwebMousePressEventArgs。)
公共属性 | X | (继承自 SwebMousePressEventArgs。)
公共属性 | Y | (继承自 SwebMousePressEventArgs。)
Top
方法
名称 | 说明
Create |
Top
参见

引用

Swebui.Controls 命名空间


SwebMouseMoveEventArgs 构造函数

初始化 SwebMouseMoveEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMouseMoveEventArgs()
Public Sub New
参见

引用

SwebMouseMoveEventArgs 类


SwebMouseMoveEventArgs 属性

SwebMouseMoveEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Height | (继承自 SwebMousePressEventArgs。)
公共属性 | Left | (继承自 SwebMousePressEventArgs。)
公共属性 | Position | 移动方向
公共属性 | Top | (继承自 SwebMousePressEventArgs。)
公共属性 | Width | (继承自 SwebMousePressEventArgs。)
公共属性 | X | (继承自 SwebMousePressEventArgs。)
公共属性 | Y | (继承自 SwebMousePressEventArgs。)
Top
参见

引用

SwebMouseMoveEventArgs 类


SwebMouseMoveEventArgs.Position 属性

SwebMouseMoveEventArgsPosition 属性

移动方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMouseMovePosition Position { get; }
Public ReadOnly Property Position As SwebMouseMovePosition
    Get

属性值

类型：SwebMouseMovePosition
参见

引用

SwebMouseMoveEventArgs 类


SwebMouseMoveEventArgs 方法

SwebMouseMoveEventArgs 类型公开以下成员。

方法
名称 | 说明
Create |
Top
参见

引用

SwebMouseMoveEventArgs 类


SwebMouseMoveEventArgs.Create 方法

SwebMouseMoveEventArgsCreate 方法

[缺少 "M:Swebui.Controls.SwebMouseMoveEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebMouseMoveEventArgs Create(
    Dictionary<string, Object> eventArgs
)
Public Shared Function Create (
    eventArgs As Dictionary(Of String, Object)
) As SwebMouseMoveEventArgs

参数

eventArgs
类型：System.Collections.GenericDictionary String, Object

[缺少 "M:Swebui.Controls.SwebMouseMoveEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="eventArgs"/> 文档]

返回值

类型：SwebMouseMoveEventArgs

[缺少 "M:Swebui.Controls.SwebMouseMoveEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <returns> 文档]

参见

引用

SwebMouseMoveEventArgs 类


SwebMouseMoveEventHandler 委托

一个委托，它表示鼠标移动时的方法。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void SwebMouseMoveEventHandler(
    Object sender,
    SwebMouseMoveEventArgs e
)
Public Delegate Sub SwebMouseMoveEventHandler (
    sender As Object,
    e As SwebMouseMoveEventArgs
)

参数

sender
类型：SystemObject
事件源
e
类型：Swebui.ControlsSwebMouseMoveEventArgs
包含事件数据的 SwebMouseMoveEventArgs
参见

引用

Swebui.Controls 命名空间


SwebMouseMovePosition 枚举

鼠标移动方式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum SwebMouseMovePosition
Public Enumeration SwebMouseMovePosition
成员
成员名称 | 值 | 说明
Left | 3 | 左
Top | 0 | 上
Right | 1 | 右
Bottom | 2 | 下
参见

引用

Swebui.Controls 命名空间


SwebMousePressEventArgs 类

[缺少 "T:Swebui.Controls.SwebMousePressEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsSwebMousePressEventArgs
Swebui.ControlsSwebMouseMoveEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebMousePressEventArgs : EventArgs
Public Class SwebMousePressEventArgs
    Inherits EventArgs

SwebMousePressEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebMousePressEventArgs | 初始化 SwebMousePressEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Height |
公共属性 | Left |
公共属性 | Top |
公共属性 | Width |
公共属性 | X |
公共属性 | Y |
Top
方法
名称 | 说明
Create |
Top
参见

引用

Swebui.Controls 命名空间


SwebMousePressEventArgs 构造函数

初始化 SwebMousePressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMousePressEventArgs()
Public Sub New
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs 属性

SwebMousePressEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Height |
公共属性 | Left |
公共属性 | Top |
公共属性 | Width |
公共属性 | X |
公共属性 | Y |
Top
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Height 属性

SwebMousePressEventArgsHeight 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.Height" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Left 属性

SwebMousePressEventArgsLeft 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.Left" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Left { get; }
Public ReadOnly Property Left As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Top 属性

SwebMousePressEventArgsTop 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.Top" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Top { get; }
Public ReadOnly Property Top As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Width 属性

SwebMousePressEventArgsWidth 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.Width" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.X 属性

SwebMousePressEventArgsX 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.X" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int X { get; }
Public ReadOnly Property X As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Y 属性

SwebMousePressEventArgsY 属性

[缺少 "P:Swebui.Controls.SwebMousePressEventArgs.Y" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get

属性值

类型：Int32
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs 方法

SwebMousePressEventArgs 类型公开以下成员。

方法
名称 | 说明
Create |
Top
参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventArgs.Create 方法

SwebMousePressEventArgsCreate 方法

[缺少 "M:Swebui.Controls.SwebMousePressEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static SwebMousePressEventArgs Create(
    Dictionary<string, Object> eventArgs
)
Public Shared Function Create (
    eventArgs As Dictionary(Of String, Object)
) As SwebMousePressEventArgs

参数

eventArgs
类型：System.Collections.GenericDictionary String, Object

[缺少 "M:Swebui.Controls.SwebMousePressEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="eventArgs"/> 文档]

返回值

类型：SwebMousePressEventArgs

[缺少 "M:Swebui.Controls.SwebMousePressEventArgs.Create(System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <returns> 文档]

参见

引用

SwebMousePressEventArgs 类


SwebMousePressEventHandler 委托

[缺少 "T:Swebui.Controls.SwebMousePressEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public delegate void SwebMousePressEventHandler(
    Object sender,
    SwebMousePressEventArgs e
)
Public Delegate Sub SwebMousePressEventHandler (
    sender As Object,
    e As SwebMousePressEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsSwebMousePressEventArgs
参见

引用

Swebui.Controls 命名空间


SwebNativeContainerControl 类

原生容器控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsSwebNativeContainerControl
Swebui.ControlsPercentageCircle

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebNativeContainerControl : SwebContainerControl
Public Class SwebNativeContainerControl
    Inherits SwebContainerControl

SwebNativeContainerControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebNativeContainerControl | 初始化 SwebNativeContainerControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebNativeContainerControl 构造函数

初始化 SwebNativeContainerControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebNativeContainerControl()
Public Sub New
参见

引用

SwebNativeContainerControl 类


SwebNativeContainerControl 属性

SwebNativeContainerControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebNativeContainerControl 类


SwebNativeContainerControl 方法

SwebNativeContainerControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

SwebNativeContainerControl 类


SwebNativeContainerControl 事件

SwebNativeContainerControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebNativeContainerControl 类


SwebNativeControl 类

原生控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebNativeControl : SwebControl
Public Class SwebNativeControl
    Inherits SwebControl

SwebNativeControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebNativeControl | 初始化 SwebNativeControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsECharts
Swebui.ControlsHTMLView
Swebui.ControlsMapTrimView
Swebui.ControlsMapView
Swebui.ControlsMediaView
Swebui.ControlsPDFView
Swebui.ControlsSignatureView
Swebui.ControlsSwebNativeTextControl


SwebNativeControl 构造函数

初始化 SwebNativeControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebNativeControl()
Public Sub New
参见

引用

SwebNativeControl 类


SwebNativeControl 属性

SwebNativeControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebNativeControl 类


SwebNativeControl 方法

SwebNativeControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

SwebNativeControl 类


SwebNativeControl 事件

SwebNativeControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebNativeControl 类


SwebNativeTextControl 类

文本控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebNativeControl
Swebui.ControlsSwebNativeTextControl
Swebui.ControlsMarqueeLabel

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract class SwebNativeTextControl : SwebNativeControl
Public MustInherit Class SwebNativeTextControl
    Inherits SwebNativeControl

SwebNativeTextControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebNativeTextControl | 初始化 SwebNativeTextControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebNativeTextControl 构造函数

初始化 SwebNativeTextControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SwebNativeTextControl()
Public Sub New
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl 属性

SwebNativeTextControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.Bold 属性

SwebNativeTextControlBold 属性

获取或设置文本粗体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract bool Bold { get; set; }
Public MustOverride Property Bold As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.FontSize 属性

SwebNativeTextControlFontSize 属性

获取或设置控件字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.ForeColor 属性

SwebNativeTextControlForeColor 属性

获取或设置控件的前景色，用于显示文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.HorizontalAlignment 属性

SwebNativeTextControlHorizontalAlignment 属性

获取或设置控件水平方向

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set

属性值

类型：HorizontalAlignment
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.Italic 属性

SwebNativeTextControlItalic 属性

获取或设置文本斜体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract bool Italic { get; set; }
Public MustOverride Property Italic As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl.Text 属性

SwebNativeTextControlText 属性

[缺少 "P:Swebui.Controls.SwebNativeTextControl.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract string Text { get; set; }
Public MustOverride Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl 方法

SwebNativeTextControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

SwebNativeTextControl 类


SwebNativeTextControl 事件

SwebNativeTextControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebNativeTextControl 类


SwebParentControl 类

父容器控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsSwebParentControl
Swebui.ControlsSwebForm
Swebui.ControlsSwebUserControl

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebParentControl : SwebContainerControl
Public Class SwebParentControl
    Inherits SwebContainerControl

SwebParentControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebParentControl | 初始化 SwebParentControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Components | 获取包含在组件内的组件的集合。
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowResult | 获取或设置窗体的对话框结果。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast
Top
事件
 | 名称 | 说明
公共事件 | Load | 在父容器控件第一次显示前发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebParentControl 构造函数

初始化 SwebParentControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebParentControl()
Public Sub New
参见

引用

SwebParentControl 类


SwebParentControl 属性

SwebParentControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Components | 获取包含在组件内的组件的集合。
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowResult | 获取或设置窗体的对话框结果。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebParentControl 类


SwebParentControl.Components 属性

SwebParentControlComponents 属性

获取包含在组件内的组件的集合。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebComponentCollection Components { get; }
Public ReadOnly Property Components As SwebComponentCollection
    Get

属性值

类型：SwebComponentCollection
一个 SwebComponentCollection，它表示组件内包含的组件的集合。
备注
参见

引用

SwebParentControl 类


SwebParentControl.MessageBox 属性

SwebParentControlMessageBox 属性

显示可包含文本、按钮（通知并指示用户）的消息框。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebMessageBox MessageBox { get; }
Public ReadOnly Property MessageBox As SwebMessageBox
    Get

属性值

类型：SwebMessageBox

返回值

类型：SwebMessageBox
备注
参见

引用

SwebParentControl 类


SwebParentControl.ShowResult 属性

SwebParentControlShowResult 属性

获取或设置窗体的对话框结果。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ShowResult ShowResult { get; set; }
Public Property ShowResult As ShowResult
    Get
    Set

属性值

类型：ShowResult
默认值:ShowResult.None
备注
参见

引用

SwebParentControl 类


SwebParentControl 方法

SwebParentControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast
Top
参见

引用

SwebParentControl 类


SwebParentControl.Toast 方法

SwebParentControlToast 方法

显示Toast

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Toast(
    string message,
    ToastLength length = ToastLength.SHORT
)
Public Sub Toast (
    message As String,
    Optional length As ToastLength = ToastLength.SHORT
)

参数

message
类型：SystemString
消息文本
length (Optional)
类型：Swebui.ControlsToastLength
信息的存续期间，默认为短期间
备注
参见

引用

SwebParentControl 类


SwebParentControl 事件

SwebParentControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Load | 在父容器控件第一次显示前发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebParentControl 类


SwebParentControl.Load 事件

SwebParentControlLoad 事件

在父容器控件第一次显示前发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Load
Public Event Load As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebParentControl 类


SwebProperty 类

控件属性
继承层次
SystemObject
Swebui.ControlsSwebProperty
Swebui.ControlsSwebStyleProperty

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebProperty
Public Class SwebProperty

SwebProperty 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebProperty(String, Object) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend, String) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend, String, Object) | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | DefaultValue | 获取属性默认值
公共属性 | HasSetValue | 获取一个值，该值指示是否已经设置了属性值
公共属性 | Name | 获取和设置属性名
公共属性 | PreValue | 获取上一次属性设置的值
公共属性 | Value | 获取和设置属性值
Top
方法
 | 名称 | 说明
公共方法 | GetValueT |
公共方法 | SetValue | 设置属性值，但是不触发RPC更新属性
Top
参见

引用

Swebui.Controls 命名空间


SwebProperty 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebProperty(String, Object) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend, String) | 构造方法
公共方法 | SwebProperty(String, Object, SwebPropertyExtend, String, Object) | 构造方法
Top
参见

引用

SwebProperty 类


SwebProperty 构造函数 (String, Object)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebProperty(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
参见

引用

SwebProperty 类
SwebProperty 重载


SwebProperty 构造函数 (String, Object, SwebPropertyExtend)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
参见

引用

SwebProperty 类
SwebProperty 重载


SwebProperty 构造函数 (String, Object, SwebPropertyExtend, String)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend,
    string cpropName
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend,
    cpropName As String
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
cpropName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebProperty.#ctor(System.String,System.Object,Swebui.Controls.SwebPropertyExtend,System.String)" 的 <param name="cpropName"/> 文档]

参见

引用

SwebProperty 类
SwebProperty 重载


SwebProperty 构造函数 (String, Object, SwebPropertyExtend, String, Object)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend,
    string cpropName,
    Object defaultValue
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend,
    cpropName As String,
    defaultValue As Object
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
cpropName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebProperty.#ctor(System.String,System.Object,Swebui.Controls.SwebPropertyExtend,System.String,System.Object)" 的 <param name="cpropName"/> 文档]

defaultValue
类型：SystemObject
属性默认值
参见

引用

SwebProperty 类
SwebProperty 重载


SwebProperty 属性

SwebProperty 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultValue | 获取属性默认值
公共属性 | HasSetValue | 获取一个值，该值指示是否已经设置了属性值
公共属性 | Name | 获取和设置属性名
公共属性 | PreValue | 获取上一次属性设置的值
公共属性 | Value | 获取和设置属性值
Top
参见

引用

SwebProperty 类


SwebProperty.DefaultValue 属性

SwebPropertyDefaultValue 属性

获取属性默认值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object DefaultValue { get; }
Public ReadOnly Property DefaultValue As Object
    Get

返回值

类型：Object
参见

引用

SwebProperty 类


SwebProperty.HasSetValue 属性

SwebPropertyHasSetValue 属性

获取一个值，该值指示是否已经设置了属性值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool HasSetValue { get; }
Public ReadOnly Property HasSetValue As Boolean
    Get

返回值

类型：Boolean
参见

引用

SwebProperty 类


SwebProperty.Name 属性

SwebPropertyName 属性

获取和设置属性名

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Name { get; }
Public ReadOnly Property Name As String
    Get

返回值

类型：String
参见

引用

SwebProperty 类


SwebProperty.PreValue 属性

SwebPropertyPreValue 属性

获取上一次属性设置的值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object PreValue { get; }
Public ReadOnly Property PreValue As Object
    Get

返回值

类型：Object
参见

引用

SwebProperty 类


SwebProperty.Value 属性

SwebPropertyValue 属性

获取和设置属性值

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

返回值

类型：Object
参见

引用

SwebProperty 类


SwebProperty 方法

SwebProperty 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetValueT |
公共方法 | SetValue | 设置属性值，但是不触发RPC更新属性
Top
参见

引用

SwebProperty 类


SwebProperty.GetValue(T) 方法

SwebPropertyGetValueT 方法

[缺少 "M:Swebui.Controls.SwebProperty.GetValue``1" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public T GetValue<T>()

Public Function GetValue(Of T) As T

类型参数

T

[缺少 "M:Swebui.Controls.SwebProperty.GetValue``1" 的 <typeparam name="T"/> 文档]

返回值

类型：T

[缺少 "M:Swebui.Controls.SwebProperty.GetValue``1" 的 <returns> 文档]

参见

引用

SwebProperty 类


SwebProperty.SetValue 方法

SwebPropertySetValue 方法

设置属性值，但是不触发RPC更新属性

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void SetValue(
    Object value
)
Public Sub SetValue (
    value As Object
)

参数

value
类型：SystemObject
属性值
参见

引用

SwebProperty 类


SwebPropertyBindAttribute 类

属性绑定特性
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebPropertyBindAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public sealed class SwebPropertyBindAttribute : Attribute
Public NotInheritable Class SwebPropertyBindAttribute
    Inherits Attribute

SwebPropertyBindAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebPropertyBindAttribute | 初始化 SwebPropertyBindAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BindType | 获取和设置绑定类型
Top
参见

引用

Swebui.Controls 命名空间


SwebPropertyBindAttribute 构造函数

初始化 SwebPropertyBindAttribute 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebPropertyBindAttribute(
    SwebPropertyBindType bindType
)
Public Sub New (
    bindType As SwebPropertyBindType
)

参数

bindType
类型：Swebui.ControlsSwebPropertyBindType

[缺少 "M:Swebui.Controls.SwebPropertyBindAttribute.#ctor(Swebui.Controls.SwebPropertyBindType)" 的 <param name="bindType"/> 文档]

参见

引用

SwebPropertyBindAttribute 类


SwebPropertyBindAttribute 属性

SwebPropertyBindAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindType | 获取和设置绑定类型
Top
参见

引用

SwebPropertyBindAttribute 类


SwebPropertyBindAttribute.BindType 属性

SwebPropertyBindAttributeBindType 属性

获取和设置绑定类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebPropertyBindType BindType { get; set; }
Public Property BindType As SwebPropertyBindType
    Get
    Set

返回值

类型：SwebPropertyBindType
参见

引用

SwebPropertyBindAttribute 类


SwebPropertyBindType 枚举

绑定类型

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum SwebPropertyBindType
Public Enumeration SwebPropertyBindType
成员
成员名称 | 值 | 说明
Context | 1 | 上下文
FixValue | 2 | 固定值
SelectObject | 4 | 选择关键字
Language | 8 | 语言
Schema | 16 | 数据字典
参见

引用

Swebui.Controls 命名空间


SwebPropertyExtend 类

属性扩展
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebPropertyExtend
Public MustInherit Class SwebPropertyExtend
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsColorPropertyExtend
Swebui.ControlsDatePropertyExtend
Swebui.ControlsEnablePropertyExtend
Swebui.ControlsFontBoldPropertyExtend
Swebui.ControlsFontItalicPropertyExtend
Swebui.ControlsFontScalingPropertyExtend
Swebui.ControlsFontSizePropertyExtend
Swebui.ControlsImageSizeModePropertyExtend
Swebui.ControlsLowercaseFirstPropertyExtend
Swebui.ControlsLowercasePropertyExtend
Swebui.ControlsRelativeSizeFloatPropertyExtend
Swebui.ControlsRelativeSizeIntPropertyExtend
Swebui.ControlsResourcePropertyExtend
Swebui.ControlsStringArrayPropertyExtend
Swebui.ControlsSwebViewStringCollectionPropertyExtend
Swebui.ControlsTreeSelectNodeCollectionPropertyExtend


SwebPropertyStyleAttribute 类

属性样式
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebPropertyStyleAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebPropertyStyleAttribute : Attribute
Public Class SwebPropertyStyleAttribute
    Inherits Attribute

SwebPropertyStyleAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebPropertyStyleAttribute | 初始化 SwebPropertyStyleAttribute 类的一个新实例
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebPropertyStyleAttribute 构造函数

初始化 SwebPropertyStyleAttribute 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebPropertyStyleAttribute()
Public Sub New
参见

引用

SwebPropertyStyleAttribute 类


SwebShadowProperty 类

SwebShadowProperty
继承层次
SystemObject
Swebui.ControlsSwebShadowProperty

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebShadowProperty
Public Class SwebShadowProperty

SwebShadowProperty 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebShadowProperty | Constructor
Top
属性
 | 名称 | 说明
公共属性 | PropertyName | Get PropertyName
公共属性 | PropertyValue | Get PropertyValue
Top
参见

引用

Swebui.Controls 命名空间


SwebShadowProperty 构造函数

Constructor

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebShadowProperty(
    string propName,
    Object propValue
)
Public Sub New (
    propName As String,
    propValue As Object
)

参数

propName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebShadowProperty.#ctor(System.String,System.Object)" 的 <param name="propName"/> 文档]

propValue
类型：SystemObject

[缺少 "M:Swebui.Controls.SwebShadowProperty.#ctor(System.String,System.Object)" 的 <param name="propValue"/> 文档]

参见

引用

SwebShadowProperty 类


SwebShadowProperty 属性

SwebShadowProperty 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PropertyName | Get PropertyName
公共属性 | PropertyValue | Get PropertyValue
Top
参见

引用

SwebShadowProperty 类


SwebShadowProperty.PropertyName 属性

SwebShadowPropertyPropertyName 属性

Get PropertyName

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get

返回值

类型：String
参见

引用

SwebShadowProperty 类


SwebShadowProperty.PropertyValue 属性

SwebShadowPropertyPropertyValue 属性

Get PropertyValue

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object PropertyValue { get; set; }
Public Property PropertyValue As Object
    Get
    Set

返回值

类型：Object
参见

引用

SwebShadowProperty 类


SwebStyleProperty 类

控件样式属性
继承层次
SystemObject
Swebui.ControlsSwebProperty
Swebui.ControlsSwebStyleProperty

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebStyleProperty : SwebProperty
Public Class SwebStyleProperty
    Inherits SwebProperty

SwebStyleProperty 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebStyleProperty(String, Object) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend, String) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend, String, Object) | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | DefaultValue | 获取属性默认值 (继承自 SwebProperty。)
公共属性 | HasSetValue | 获取一个值，该值指示是否已经设置了属性值 (继承自 SwebProperty。)
公共属性 | Name | 获取和设置属性名 (继承自 SwebProperty。)
公共属性 | PreValue | 获取上一次属性设置的值 (继承自 SwebProperty。)
公共属性 | Value | 获取和设置属性值 (继承自 SwebProperty。)
Top
方法
 | 名称 | 说明
公共方法 | GetValueT | (继承自 SwebProperty。)
公共方法 | SetValue | 设置属性值，但是不触发RPC更新属性 (继承自 SwebProperty。)
Top
参见

引用

Swebui.Controls 命名空间


SwebStyleProperty 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebStyleProperty(String, Object) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend, String) | 构造方法
公共方法 | SwebStyleProperty(String, Object, SwebPropertyExtend, String, Object) | 构造方法
Top
参见

引用

SwebStyleProperty 类


SwebStyleProperty 构造函数 (String, Object)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebStyleProperty(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
参见

引用

SwebStyleProperty 类
SwebStyleProperty 重载


SwebStyleProperty 构造函数 (String, Object, SwebPropertyExtend)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebStyleProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
参见

引用

SwebStyleProperty 类
SwebStyleProperty 重载


SwebStyleProperty 构造函数 (String, Object, SwebPropertyExtend, String)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebStyleProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend,
    string cpropName
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend,
    cpropName As String
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
cpropName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebStyleProperty.#ctor(System.String,System.Object,Swebui.Controls.SwebPropertyExtend,System.String)" 的 <param name="cpropName"/> 文档]

参见

引用

SwebStyleProperty 类
SwebStyleProperty 重载


SwebStyleProperty 构造函数 (String, Object, SwebPropertyExtend, String, Object)

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebStyleProperty(
    string name,
    Object value,
    SwebPropertyExtend propertyExtend,
    string cpropName,
    Object defaultValue
)
Public Sub New (
    name As String,
    value As Object,
    propertyExtend As SwebPropertyExtend,
    cpropName As String,
    defaultValue As Object
)

参数

name
类型：SystemString
属性名称
value
类型：SystemObject
属性值
propertyExtend
类型：Swebui.ControlsSwebPropertyExtend
属性扩展
cpropName
类型：SystemString

[缺少 "M:Swebui.Controls.SwebStyleProperty.#ctor(System.String,System.Object,Swebui.Controls.SwebPropertyExtend,System.String,System.Object)" 的 <param name="cpropName"/> 文档]

defaultValue
类型：SystemObject
属性默认值
参见

引用

SwebStyleProperty 类
SwebStyleProperty 重载


SwebStyleProperty 属性

SwebStyleProperty 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultValue | 获取属性默认值 (继承自 SwebProperty。)
公共属性 | HasSetValue | 获取一个值，该值指示是否已经设置了属性值 (继承自 SwebProperty。)
公共属性 | Name | 获取和设置属性名 (继承自 SwebProperty。)
公共属性 | PreValue | 获取上一次属性设置的值 (继承自 SwebProperty。)
公共属性 | Value | 获取和设置属性值 (继承自 SwebProperty。)
Top
参见

引用

SwebStyleProperty 类


SwebStyleProperty 方法

SwebStyleProperty 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetValueT | (继承自 SwebProperty。)
公共方法 | SetValue | 设置属性值，但是不触发RPC更新属性 (继承自 SwebProperty。)
Top
参见

引用

SwebStyleProperty 类


SwebTextControl 类

文本控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebTextControl
Swebui.ControlsAutoComplete
Swebui.ControlsComboBox
Swebui.ControlsLabel
Swebui.ControlsTextBox

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract class SwebTextControl : SwebBindableControl
Public MustInherit Class SwebTextControl
    Inherits SwebBindableControl

SwebTextControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebTextControl | 初始化 SwebTextControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebTextControl 构造函数

初始化 SwebTextControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SwebTextControl()
Public Sub New
参见

引用

SwebTextControl 类


SwebTextControl 属性

SwebTextControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (重写 SwebBindableControlBindDisplayValue.)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取或设置控件字体大小
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebTextControl 类


SwebTextControl.BindDisplayValue 属性

SwebTextControlBindDisplayValue 属性

获取和设置绑定控件默认绑定值

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Object BindDisplayValue { get; set; }
Public Overrides Property BindDisplayValue As Object
    Get
    Set

属性值

类型：Object
参见

引用

SwebTextControl 类


SwebTextControl.Bold 属性

SwebTextControlBold 属性

获取或设置文本粗体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebTextControl 类


SwebTextControl.FontSize 属性

SwebTextControlFontSize 属性

获取或设置控件字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

SwebTextControl 类


SwebTextControl.ForeColor 属性

SwebTextControlForeColor 属性

获取或设置控件的前景色，用于显示文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

SwebTextControl 类


SwebTextControl.HorizontalAlignment 属性

SwebTextControlHorizontalAlignment 属性

获取或设置控件水平方向

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public HorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set

属性值

类型：HorizontalAlignment
参见

引用

SwebTextControl 类


SwebTextControl.Italic 属性

SwebTextControlItalic 属性

获取或设置文本斜体

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

SwebTextControl 类


SwebTextControl.Text 属性

SwebTextControlText 属性

[缺少 "P:Swebui.Controls.SwebTextControl.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public abstract string Text { get; set; }
Public MustOverride Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

SwebTextControl 类


SwebTextControl 方法

SwebTextControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

SwebTextControl 类


SwebTextControl 事件

SwebTextControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebTextControl 类


SwebTypeAttribute 类

类型特性
继承层次
SystemObject
SystemAttribute
Swebui.ControlsSwebTypeAttribute

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebTypeAttribute : Attribute
Public Class SwebTypeAttribute
    Inherits Attribute

SwebTypeAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebTypeAttribute | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Type | 获取类型名称
Top
参见

引用

Swebui.Controls 命名空间


SwebTypeAttribute 构造函数

构造方法

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebTypeAttribute(
    string typeName
)
Public Sub New (
    typeName As String
)

参数

typeName
类型：SystemString
类型名称
参见

引用

SwebTypeAttribute 类


SwebTypeAttribute 属性

SwebTypeAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Type | 获取类型名称
Top
参见

引用

SwebTypeAttribute 类


SwebTypeAttribute.Type 属性

SwebTypeAttributeType 属性

获取类型名称

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Type { get; }
Public ReadOnly Property Type As String
    Get

返回值

类型：String
参见

引用

SwebTypeAttribute 类


SwebUserControl 类

自定义控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsSwebParentControl
Swebui.ControlsSwebUserControl

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebUserControl : SwebParentControl
Public Class SwebUserControl
    Inherits SwebParentControl

SwebUserControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebUserControl | 初始化 SwebUserControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | 获取和设置窗体背景图片
公共属性 | BackgroundImagePath | 获取或设置窗体背景图片路径
公共属性 | BackgroundImageSizeMode | 获取和设置窗体背景图片显示样式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Components | 获取包含在组件内的组件的集合。 (继承自 SwebParentControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignSize | 获取和设置自定义控件在设计时的大小
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JS | 获取和设置Javascript脚本
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。 (继承自 SwebParentControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。
公共属性 | ShowResult | 获取或设置窗体的对话框结果。 (继承自 SwebParentControl。)
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateData | 获取模板数据
公共属性 | TemplateItem | 获取模板对象
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | Close | 自定义控件在Dialog显示时，调用Close会关闭当前Dialog 自定义控件被设置为窗体的LeftDrawer时，调用Close会关闭当前窗体的LeftDrawer 其它模式下调用无效
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (重写 SwebLayoutControlOnBindValueUpdate(ISwebDataBindableControl).)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast (继承自 SwebParentControl。)
Top
事件
 | 名称 | 说明
公共事件 | Load | 在父容器控件第一次显示前发生。 (继承自 SwebParentControl。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


SwebUserControl 构造函数

初始化 SwebUserControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl()
Public Sub New
参见

引用

SwebUserControl 类


SwebUserControl 属性

SwebUserControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | 获取和设置窗体背景图片
公共属性 | BackgroundImagePath | 获取或设置窗体背景图片路径
公共属性 | BackgroundImageSizeMode | 获取和设置窗体背景图片显示样式
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Components | 获取包含在组件内的组件的集合。 (继承自 SwebParentControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignSize | 获取和设置自定义控件在设计时的大小
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JS | 获取和设置Javascript脚本
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MessageBox | 显示可包含文本、按钮（通知并指示用户）的消息框。 (继承自 SwebParentControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。
公共属性 | ShowResult | 获取或设置窗体的对话框结果。 (继承自 SwebParentControl。)
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TemplateData | 获取模板数据
公共属性 | TemplateItem | 获取模板对象
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

SwebUserControl 类


SwebUserControl.BackgroundImage 属性

SwebUserControlBackgroundImage 属性

获取和设置窗体背景图片

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImage { get; set; }
Public Property BackgroundImage As String
    Get
    Set

返回值

类型：String
参见

引用

SwebUserControl 类


SwebUserControl.BackgroundImagePath 属性

SwebUserControlBackgroundImagePath 属性

获取或设置窗体背景图片路径

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string BackgroundImagePath { get; set; }
Public Property BackgroundImagePath As String
    Get
    Set

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebUserControl 类


SwebUserControl.BackgroundImageSizeMode 属性

SwebUserControlBackgroundImageSizeMode 属性

获取和设置窗体背景图片显示样式

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ImageSizeMode BackgroundImageSizeMode { get; set; }
Public Property BackgroundImageSizeMode As ImageSizeMode
    Get
    Set

返回值

类型：ImageSizeMode
参见

引用

SwebUserControl 类


SwebUserControl.DesignSize 属性

SwebUserControlDesignSize 属性

获取和设置自定义控件在设计时的大小

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Size DesignSize { get; set; }
Public Property DesignSize As Size
    Get
    Set

返回值

类型：Size
备注
自定义控件在使用时，由于相对布局，导致如果设置了控件的Size属性，在实际使用这个自定义控件时，会导致大小不一致，所以为了使用Flex或者不指定实际宽度和宽度时，也能对自定义控件进行设计，需要设置设计时的大小。
参见

引用

SwebUserControl 类


SwebUserControl.Horizontal 属性

SwebUserControlHorizontal 属性

获取和设置一个值，该值指示是否水平滑动

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Horizontal { get; set; }
Public Property Horizontal As Boolean
    Get
    Set

属性值

类型：Boolean
水平滑动设置为 true，否则为 flase

返回值

类型：Boolean
参见

引用

SwebUserControl 类


SwebUserControl.JS 属性

SwebUserControlJS 属性

获取和设置Javascript脚本

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual string JS { get; set; }
Public Overridable Property JS As String
    Get
    Set

返回值

类型：String
备注
仅在窗体第一次或重新加载时生效
参见

引用

SwebUserControl 类


SwebUserControl.KeyboardScrollHidden 属性

SwebUserControlKeyboardScrollHidden 属性

获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool KeyboardScrollHidden { get; set; }
Public Property KeyboardScrollHidden As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

SwebUserControl 类


SwebUserControl.ShowHorizontalScrollBar 属性

SwebUserControlShowHorizontalScrollBar 属性

获取和设置一个值，该值指示是否显示水平滚动条。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowHorizontalScrollBar { get; set; }
Public Property ShowHorizontalScrollBar As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

SwebUserControl 类


SwebUserControl.ShowVerticalScrollBar 属性

SwebUserControlShowVerticalScrollBar 属性

获取和设置一个值，该值指示是否显示垂直滚动条。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ShowVerticalScrollBar { get; set; }
Public Property ShowVerticalScrollBar As Boolean
    Get
    Set

返回值

类型：Boolean
参见

引用

SwebUserControl 类


SwebUserControl.TemplateData 属性

SwebUserControlTemplateData 属性

获取模板数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object TemplateData { get; set; }
Public Property TemplateData As Object
    Get
    Set

返回值

类型：Object
备注
TemplateData 使用弱引用 WeakReference
参见

引用

SwebUserControl 类


SwebUserControl.TemplateItem 属性

SwebUserControlTemplateItem 属性

获取模板对象

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewTemplateItem TemplateItem { get; set; }
Public Property TemplateItem As SwebViewTemplateItem
    Get
    Set

返回值

类型：SwebViewTemplateItem
备注
TemplateItem 使用弱引用 WeakReference
参见

引用

SwebUserControl 类


SwebUserControl 方法

SwebUserControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Close | 自定义控件在Dialog显示时，调用Close会关闭当前Dialog 自定义控件被设置为窗体的LeftDrawer时，调用Close会关闭当前窗体的LeftDrawer 其它模式下调用无效
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (重写 SwebLayoutControlOnBindValueUpdate(ISwebDataBindableControl).)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | Toast | 显示Toast (继承自 SwebParentControl。)
Top
参见

引用

SwebUserControl 类


SwebUserControl.Close 方法

SwebUserControlClose 方法

自定义控件在Dialog显示时，调用Close会关闭当前Dialog 自定义控件被设置为窗体的LeftDrawer时，调用Close会关闭当前窗体的LeftDrawer 其它模式下调用无效

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Close()
Public Sub Close
参见

引用

SwebUserControl 类


SwebUserControl.OnBindValueUpdate 方法

SwebUserControlOnBindValueUpdate 方法

[缺少 "M:Swebui.Controls.SwebUserControl.OnBindValueUpdate(Swebui.Controls.ISwebDataBindableControl)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public override void OnBindValueUpdate(
    ISwebDataBindableControl ctl
)
Public Overrides Sub OnBindValueUpdate (
    ctl As ISwebDataBindableControl
)

参数

ctl
类型：Swebui.ControlsISwebDataBindableControl

[缺少 "M:Swebui.Controls.SwebUserControl.OnBindValueUpdate(Swebui.Controls.ISwebDataBindableControl)" 的 <param name="ctl"/> 文档]

参见

引用

SwebUserControl 类


SwebUserControl 事件

SwebUserControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Load | 在父容器控件第一次显示前发生。 (继承自 SwebParentControl。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

SwebUserControl 类


SwebViewCollection(T) 类

SwebViewCollectionT 类

元素集合基类
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionT
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewCollection<T> : IList<T>
where T : SwebViewCollectionItem

Public Class SwebViewCollection(Of T As SwebViewCollectionItem)
    Implements IList(Of T)

类型参数

T
元素类型

SwebViewCollectionT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewCollectionT | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数
公共属性 | IsReadOnly | 获取元素是否只读
公共属性 | Item | 获取和设置指定索引位置的元素
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中
公共方法 | Clear | 移除所有元素
公共方法 | Contains | 是否包含指定的元素
公共方法 | CopyTo | 复制元素到指定的集合中
公共方法 | GetEnumerator | 获取枚举器
公共方法 | IndexOf | 获取指定元素的索引
公共方法 | Refresh | 刷新元素
公共方法 | Remove | 移除指定元素
公共方法 | RemoveAt | 移除指定索引的元素
Top
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionT
Swebui.ControlsListViewRowCollection
Swebui.ControlsListViewSectionCollection
Swebui.ControlsMapViewPointCollection
Swebui.ControlsMapViewTagCollection
Swebui.ControlsPageViewItemCollection
Swebui.ControlsSectionListViewRowCollection


SwebViewCollection(T) 构造函数

SwebViewCollectionT 构造函数

构造函数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner
集合拥有者
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T) 属性

SwebViewCollectionT 属性

SwebViewCollectionT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count | 获取集合元素数
公共属性 | IsReadOnly | 获取元素是否只读
公共属性 | Item | 获取和设置指定索引位置的元素
Top
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Count 属性

SwebViewCollectionTCount 属性

获取集合元素数

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

返回值

类型：Int32

实现

ICollectionTCount
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).IsReadOnly 属性

SwebViewCollectionTIsReadOnly 属性

获取元素是否只读

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

返回值

类型：Boolean

实现

ICollectionTIsReadOnly
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Item 属性

SwebViewCollectionTItem 属性

获取和设置指定索引位置的元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

参数

index
类型：SystemInt32

返回值

类型：T

实现

IListTItemInt32
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T) 方法

SwebViewCollectionT 方法

SwebViewCollectionT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加元素到集合中
公共方法 | Clear | 移除所有元素
公共方法 | Contains | 是否包含指定的元素
公共方法 | CopyTo | 复制元素到指定的集合中
公共方法 | GetEnumerator | 获取枚举器
公共方法 | IndexOf | 获取指定元素的索引
公共方法 | Refresh | 刷新元素
公共方法 | Remove | 移除指定元素
公共方法 | RemoveAt | 移除指定索引的元素
Top
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Add 方法

SwebViewCollectionTAdd 方法

添加元素到集合中

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Add(
    T item
)
Public Overridable Sub Add (
    item As T
)

参数

item
类型：T
添加到集合中的元素

实现

ICollectionTAdd(T)
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Clear 方法

SwebViewCollectionTClear 方法

移除所有元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Clear()
Public Overridable Sub Clear

实现

ICollectionTClear
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Contains 方法

SwebViewCollectionTContains 方法

是否包含指定的元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

参数

item
类型：T
元素

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewCollection`1.Contains(`0)" 的 <returns> 文档]

实现

ICollectionTContains(T)
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).CopyTo 方法

SwebViewCollectionTCopyTo 方法

复制元素到指定的集合中

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)

参数

array
类型：T

[缺少 "M:Swebui.Controls.SwebViewCollection`1.CopyTo(`0[],System.Int32)" 的 <param name="array"/> 文档]

arrayIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebViewCollection`1.CopyTo(`0[],System.Int32)" 的 <param name="arrayIndex"/> 文档]

实现

ICollectionTCopyTo(T, Int32)
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).GetEnumerator 方法

SwebViewCollectionTGetEnumerator 方法

获取枚举器

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

返回值

类型：IEnumerator T

[缺少 "M:Swebui.Controls.SwebViewCollection`1.GetEnumerator" 的 <returns> 文档]

实现

IEnumerableTGetEnumerator
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).IndexOf 方法

SwebViewCollectionTIndexOf 方法

获取指定元素的索引

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

参数

item
类型：T
元素

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebViewCollection`1.IndexOf(`0)" 的 <returns> 文档]

实现

IListTIndexOf(T)
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Refresh 方法

SwebViewCollectionTRefresh 方法

刷新元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).Remove 方法

SwebViewCollectionTRemove 方法

移除指定元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean

参数

item
类型：T
元素

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewCollection`1.Remove(`0)" 的 <returns> 文档]

实现

ICollectionTRemove(T)
参见

引用

SwebViewCollectionT 类


SwebViewCollection(T).RemoveAt 方法

SwebViewCollectionTRemoveAt 方法

移除指定索引的元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebViewCollection`1.RemoveAt(System.Int32)" 的 <param name="index"/> 文档]

实现

IListTRemoveAt(Int32)
参见

引用

SwebViewCollectionT 类


SwebViewCollectionBase(T) 类

SwebViewCollectionBaseT 类

继承自CollectionBase的集合
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBaseT
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewCollectionBase<T> : CollectionBase
where T : SwebViewCollectionItem

Public Class SwebViewCollectionBase(Of T As SwebViewCollectionItem)
    Inherits CollectionBase

类型参数

T

[缺少 "T:Swebui.Controls.SwebViewCollectionBase`1" 的 <typeparam name="T"/> 文档]

SwebViewCollectionBaseT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewCollectionBaseT | 初始化 SwebViewCollectionBaseT 类的一个新实例
公共方法 | SwebViewCollectionBaseT(ISwebViewCollectionOwner) | 初始化 SwebViewCollectionBaseT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素
公共方法 | AddRange | 添加集合元素数组
公共方法 | Clear | 清除元素集合
公共方法 | Contains | 判断是否存在给定集合元素
公共方法 | IndexOf | 获取指定集合元素的索引
公共方法 | Refresh | 对数据进行刷新
公共方法 | Remove | 删除指定集合元素
公共方法 | RemoveAt | 删除指定索引位置的集合元素
Top
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBaseT
Swebui.ControlsActionButtonItemCollection
Swebui.ControlsAnimationItemCollection
Swebui.ControlsComboBoxItemCollection
Swebui.ControlsGridViewColumnCollection
Swebui.ControlsMapViewRouteCollection
Swebui.ControlsMenuItemCollection
Swebui.ControlsPopPanelItemCollection
Swebui.ControlsTreeSelectNodeCollection
Swebui.ControlsTreeViewNodeCollection


SwebViewCollectionBase(T) 构造函数

SwebViewCollectionBaseT 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebViewCollectionBaseT | 初始化 SwebViewCollectionBaseT 类的一个新实例
公共方法 | SwebViewCollectionBaseT(ISwebViewCollectionOwner) | 初始化 SwebViewCollectionBaseT 类的一个新实例
Top
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T) 构造函数

SwebViewCollectionBaseT 构造函数

初始化 SwebViewCollectionBaseT 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollectionBase()
Public Sub New
参见

引用

SwebViewCollectionBaseT 类
SwebViewCollectionBaseT 重载


SwebViewCollectionBase(T) 构造函数 (ISwebViewCollectionOwner)

SwebViewCollectionBaseT 构造函数 (ISwebViewCollectionOwner)

初始化 SwebViewCollectionBaseT 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollectionBase(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

SwebViewCollectionBaseT 类
SwebViewCollectionBaseT 重载


SwebViewCollectionBase(T) 属性

SwebViewCollectionBaseT 属性

SwebViewCollectionBaseT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素
Top
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Item 属性

SwebViewCollectionBaseTItem 属性

获取指定索引集合元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public T this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As T
    Get

参数

index
类型：SystemInt32
索引

属性值

类型：T

返回值

类型：T
备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T) 方法

SwebViewCollectionBaseT 方法

SwebViewCollectionBaseT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素
公共方法 | AddRange | 添加集合元素数组
公共方法 | Clear | 清除元素集合
公共方法 | Contains | 判断是否存在给定集合元素
公共方法 | IndexOf | 获取指定集合元素的索引
公共方法 | Refresh | 对数据进行刷新
公共方法 | Remove | 删除指定集合元素
公共方法 | RemoveAt | 删除指定索引位置的集合元素
Top
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Add 方法

SwebViewCollectionBaseTAdd 方法

添加集合元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Add(
    T item
)
Public Overridable Sub Add (
    item As T
)

参数

item
类型：T
集合元素
备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).AddRange 方法

SwebViewCollectionBaseTAddRange 方法

添加集合元素数组

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void AddRange(
    T[] items
)
Public Overridable Sub AddRange (
    items As T()
)

参数

items
类型：T
集合元素数组
备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Clear 方法

SwebViewCollectionBaseTClear 方法

清除元素集合

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Clear()
Public Overridable Sub Clear
备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Contains 方法

SwebViewCollectionBaseTContains 方法

判断是否存在给定集合元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual bool Contains(
    T item
)
Public Overridable Function Contains (
    item As T
) As Boolean

参数

item
类型：T

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.Contains(`0)" 的 <param name="item"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.Contains(`0)" 的 <returns> 文档]

备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).IndexOf 方法

SwebViewCollectionBaseTIndexOf 方法

获取指定集合元素的索引

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual int IndexOf(
    T item
)
Public Overridable Function IndexOf (
    item As T
) As Integer

参数

item
类型：T

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.IndexOf(`0)" 的 <param name="item"/> 文档]

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.IndexOf(`0)" 的 <returns> 文档]

备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Refresh 方法

SwebViewCollectionBaseTRefresh 方法

对数据进行刷新

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Refresh()
Public Overridable Sub Refresh
备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).Remove 方法

SwebViewCollectionBaseTRemove 方法

删除指定集合元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void Remove(
    T item
)
Public Overridable Sub Remove (
    item As T
)

参数

item
类型：T

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.Remove(`0)" 的 <param name="item"/> 文档]

备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionBase(T).RemoveAt 方法

SwebViewCollectionBaseTRemoveAt 方法

删除指定索引位置的集合元素

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32

[缺少 "M:Swebui.Controls.SwebViewCollectionBase`1.RemoveAt(System.Int32)" 的 <param name="index"/> 文档]

备注
参见

引用

SwebViewCollectionBaseT 类


SwebViewCollectionItem 类

集合元素
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
更多...

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewCollectionItem
Public Class SwebViewCollectionItem

SwebViewCollectionItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewCollectionItem | 初始化 SwebViewCollectionItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Tag | 获取和设置Tag
Top
参见

引用

Swebui.Controls 命名空间
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsAnimationItem
Swebui.ControlsComboBoxItem
Swebui.ControlsGridViewColumn
Swebui.ControlsMapViewPoint
Swebui.ControlsMapViewRoute
Swebui.ControlsMenuItem
Swebui.ControlsPopPanelItem
Swebui.ControlsSwebViewCollectionShadowItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsTreeSelectNode
Swebui.ControlsTreeViewNode


SwebViewCollectionItem 构造函数

初始化 SwebViewCollectionItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollectionItem()
Public Sub New
参见

引用

SwebViewCollectionItem 类


SwebViewCollectionItem 属性

SwebViewCollectionItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Tag | 获取和设置Tag
Top
参见

引用

SwebViewCollectionItem 类


SwebViewCollectionItem.Tag 属性

SwebViewCollectionItemTag 属性

获取和设置Tag

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

属性值

类型：Object
The tag.
参见

引用

SwebViewCollectionItem 类


SwebViewCollectionShadowItem 类

SwebViewCollectionShadowItem
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewCollectionShadowItem
Swebui.ControlsActionButtonBase

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewCollectionShadowItem : SwebViewCollectionItem
Public Class SwebViewCollectionShadowItem
    Inherits SwebViewCollectionItem

SwebViewCollectionShadowItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewCollectionShadowItem | 初始化 SwebViewCollectionShadowItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

Swebui.Controls 命名空间


SwebViewCollectionShadowItem 构造函数

初始化 SwebViewCollectionShadowItem 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewCollectionShadowItem()
Public Sub New
参见

引用

SwebViewCollectionShadowItem 类


SwebViewCollectionShadowItem 属性

SwebViewCollectionShadowItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

SwebViewCollectionShadowItem 类


SwebViewDictionary(TKey, TValue) 类

SwebViewDictionaryTKey, TValue 类

字典元素
继承层次
SystemObject
Swebui.ControlsSwebViewDictionaryTKey, TValue

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    IDictionary

Public Class SwebViewDictionary(Of TKey, TValue)
    Implements IDictionary(Of TKey, TValue), IDictionary

类型参数

TKey
Key
TValue
Value

SwebViewDictionaryTKey, TValue 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewDictionaryTKey, TValue | 初始化 SwebViewDictionaryTKey, TValue 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count |
受保护的属性 | ItemObject |
公共属性 | ItemTKey |
公共属性 | Keys |
公共属性 | Values |
Top
方法
 | 名称 | 说明
公共方法 | Add |
公共方法 | Clear |
公共方法 | ContainsKey |
公共方法 | GetEnumerator |
公共方法 | Remove |
公共方法 | TryGetValue |
Top
参见

引用

Swebui.Controls 命名空间


SwebViewDictionary(TKey, TValue) 构造函数

SwebViewDictionaryTKey, TValue 构造函数

初始化 SwebViewDictionaryTKey, TValue 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewDictionary()
Public Sub New
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue) 属性

SwebViewDictionaryTKey, TValue 属性

SwebViewDictionaryTKey, TValue 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count |
受保护的属性 | ItemObject |
公共属性 | ItemTKey |
公共属性 | Keys |
公共属性 | Values |
Top
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Count 属性

SwebViewDictionaryTKey, TValueCount 属性

[缺少 "P:Swebui.Controls.SwebViewDictionary`2.Count" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

属性值

类型：Int32

实现

ICollectionTCount
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Item 属性

SwebViewDictionaryTKey, TValueItem 属性

重载列表
 | 名称 | 说明
受保护的属性 | ItemObject |
公共属性 | ItemTKey |
Top
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Item 属性 (Object)

SwebViewDictionaryTKey, TValueItem 属性 (Object)

[缺少 "P:Swebui.Controls.SwebViewDictionary`2.Item(System.Object)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
internal Object this[
    Object 02
] { get; set; }
Friend Default Property Item (
    02 As Object
) As Object
    Get
    Set

参数

02
类型：SystemObject

属性值

类型：Object

实现

IDictionaryItemObject
参见

引用

SwebViewDictionaryTKey, TValue 类
Item 重载


SwebViewDictionary(TKey, TValue).Item 属性 (TKey)

SwebViewDictionaryTKey, TValueItem 属性 (TKey)

[缺少 "P:Swebui.Controls.SwebViewDictionary`2.Item(`0)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set

参数

key
类型：TKey

属性值

类型：TValue

实现

IDictionaryTKey, TValueItemTKey
参见

引用

SwebViewDictionaryTKey, TValue 类
Item 重载


SwebViewDictionary(TKey, TValue).Keys 属性

SwebViewDictionaryTKey, TValueKeys 属性

[缺少 "P:Swebui.Controls.SwebViewDictionary`2.Keys" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get

属性值

类型：ICollection TKey

实现

IDictionaryTKey, TValueKeys
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Values 属性

SwebViewDictionaryTKey, TValueValues 属性

[缺少 "P:Swebui.Controls.SwebViewDictionary`2.Values" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get

属性值

类型：ICollection TValue

实现

IDictionaryTKey, TValueValues
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue) 方法

SwebViewDictionaryTKey, TValue 方法

SwebViewDictionaryTKey, TValue 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add |
公共方法 | Clear |
公共方法 | ContainsKey |
公共方法 | GetEnumerator |
公共方法 | Remove |
公共方法 | TryGetValue |
Top
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Add 方法

SwebViewDictionaryTKey, TValueAdd 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Add(`0,`1)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)

参数

key
类型：TKey

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Add(`0,`1)" 的 <param name="key"/> 文档]

value
类型：TValue

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Add(`0,`1)" 的 <param name="value"/> 文档]

实现

IDictionaryTKey, TValueAdd(TKey, TValue)
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Clear 方法

SwebViewDictionaryTKey, TValueClear 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Clear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Clear()
Public Sub Clear

实现

ICollectionTClear
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).ContainsKey 方法

SwebViewDictionaryTKey, TValueContainsKey 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.ContainsKey(`0)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean

参数

key
类型：TKey

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.ContainsKey(`0)" 的 <param name="key"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.ContainsKey(`0)" 的 <returns> 文档]

实现

IDictionaryTKey, TValueContainsKey(TKey)
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).GetEnumerator 方法

SwebViewDictionaryTKey, TValueGetEnumerator 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.GetEnumerator" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

返回值

类型：IEnumerator

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.GetEnumerator" 的 <returns> 文档]

实现

IEnumerableGetEnumerator
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).Remove 方法

SwebViewDictionaryTKey, TValueRemove 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Remove(`0)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean

参数

key
类型：TKey

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Remove(`0)" 的 <param name="key"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.Remove(`0)" 的 <returns> 文档]

实现

IDictionaryTKey, TValueRemove(TKey)
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewDictionary(TKey, TValue).TryGetValue 方法

SwebViewDictionaryTKey, TValueTryGetValue 方法

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.TryGetValue(`0,`1@)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool TryGetValue(
    TKey key,
    ref TValue value
)
Public Function TryGetValue (
    key As TKey,
    ByRef value As TValue
) As Boolean

参数

key
类型：TKey

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.TryGetValue(`0,`1@)" 的 <param name="key"/> 文档]

value
类型：TValue

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.TryGetValue(`0,`1@)" 的 <param name="value"/> 文档]

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewDictionary`2.TryGetValue(`0,`1@)" 的 <returns> 文档]

实现

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
参见

引用

SwebViewDictionaryTKey, TValue 类


SwebViewObjectCollectionBase(T) 类

SwebViewObjectCollectionBaseT 类

单对象集合
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewObjectCollectionBaseT
Swebui.ControlsSwebViewStringCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebViewObjectCollectionBase<T> : CollectionBase

Public MustInherit Class SwebViewObjectCollectionBase(Of T)
    Inherits CollectionBase

类型参数

T
对象类型

SwebViewObjectCollectionBaseT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewObjectCollectionBaseT | 初始化 SwebViewObjectCollectionBaseT 类的一个新实例
公共方法 | SwebViewObjectCollectionBaseT(ISwebViewObjectCollectionOwner) | 初始化 SwebViewObjectCollectionBaseT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取根据指定索引的字符串
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加字符串
公共方法 | AddRange(IEnumerable) | 添加字符串集合
公共方法 | AddRange(T) |
公共方法 | Clear | 清空字符串列表
公共方法 | Contains | 获取是否包含指定字符串
公共方法 | IndexOf | 获取指定字符串的索引
公共方法 | Refresh |
公共方法 | Remove | 删除指定编号的字符串
公共方法 | RemoveAt | 删除指定索引的字符串
公共方法 | ToList |
Top
参见

引用

Swebui.Controls 命名空间


SwebViewObjectCollectionBase(T) 构造函数

SwebViewObjectCollectionBaseT 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebViewObjectCollectionBaseT | 初始化 SwebViewObjectCollectionBaseT 类的一个新实例
公共方法 | SwebViewObjectCollectionBaseT(ISwebViewObjectCollectionOwner) | 初始化 SwebViewObjectCollectionBaseT 类的一个新实例
Top
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T) 构造函数

SwebViewObjectCollectionBaseT 构造函数

初始化 SwebViewObjectCollectionBaseT 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewObjectCollectionBase()
Public Sub New
参见

引用

SwebViewObjectCollectionBaseT 类
SwebViewObjectCollectionBaseT 重载


SwebViewObjectCollectionBase(T) 构造函数 (ISwebViewObjectCollectionOwner)

SwebViewObjectCollectionBaseT 构造函数 (ISwebViewObjectCollectionOwner)

初始化 SwebViewObjectCollectionBaseT 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewObjectCollectionBase(
    ISwebViewObjectCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewObjectCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewObjectCollectionOwner

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.#ctor(Swebui.Controls.ISwebViewObjectCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

SwebViewObjectCollectionBaseT 类
SwebViewObjectCollectionBaseT 重载


SwebViewObjectCollectionBase(T) 属性

SwebViewObjectCollectionBaseT 属性

SwebViewObjectCollectionBaseT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取根据指定索引的字符串
Top
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).Item 属性

SwebViewObjectCollectionBaseTItem 属性

获取根据指定索引的字符串

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

参数

index
类型：SystemInt32
索引

属性值

类型：T

返回值

类型：T
备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T) 方法

SwebViewObjectCollectionBaseT 方法

SwebViewObjectCollectionBaseT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加字符串
公共方法 | AddRange(IEnumerable) | 添加字符串集合
公共方法 | AddRange(T) |
公共方法 | Clear | 清空字符串列表
公共方法 | Contains | 获取是否包含指定字符串
公共方法 | IndexOf | 获取指定字符串的索引
公共方法 | Refresh |
公共方法 | Remove | 删除指定编号的字符串
公共方法 | RemoveAt | 删除指定索引的字符串
公共方法 | ToList |
Top
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).Add 方法

SwebViewObjectCollectionBaseTAdd 方法

添加字符串

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Add(
    T item
)
Public Sub Add (
    item As T
)

参数

item
类型：T
字符串
备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).AddRange 方法

SwebViewObjectCollectionBaseTAddRange 方法

重载列表
 | 名称 | 说明
公共方法 | AddRange(IEnumerable) | 添加字符串集合
公共方法 | AddRange(T) |
Top
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).AddRange 方法 (IEnumerable)

SwebViewObjectCollectionBaseTAddRange 方法 (IEnumerable)

添加字符串集合

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AddRange(
    IEnumerable items
)
Public Sub AddRange (
    items As IEnumerable
)

参数

items
类型：System.CollectionsIEnumerable
字符串集合
备注
参见

引用

SwebViewObjectCollectionBaseT 类
AddRange 重载


SwebViewObjectCollectionBase(T).AddRange 方法 (T[])

SwebViewObjectCollectionBaseTAddRange 方法 (T)

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.AddRange(`0[])" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void AddRange(
    T[] items
)
Public Sub AddRange (
    items As T()
)

参数

items
类型：T

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.AddRange(`0[])" 的 <param name="items"/> 文档]

参见

引用

SwebViewObjectCollectionBaseT 类
AddRange 重载


SwebViewObjectCollectionBase(T).Clear 方法

SwebViewObjectCollectionBaseTClear 方法

清空字符串列表

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Clear()
Public Sub Clear
备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).Contains 方法

SwebViewObjectCollectionBaseTContains 方法

获取是否包含指定字符串

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

参数

item
类型：T
字符串

返回值

类型：Boolean

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.Contains(`0)" 的 <returns> 文档]

备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).IndexOf 方法

SwebViewObjectCollectionBaseTIndexOf 方法

获取指定字符串的索引

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

参数

item
类型：T
字符串

返回值

类型：Int32

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.IndexOf(`0)" 的 <returns> 文档]

备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).Refresh 方法

SwebViewObjectCollectionBaseTRefresh 方法

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).Remove 方法

SwebViewObjectCollectionBaseTRemove 方法

删除指定编号的字符串

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Remove(
    T value
)
Public Sub Remove (
    value As T
)

参数

value
类型：T
索引
备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).RemoveAt 方法

SwebViewObjectCollectionBaseTRemoveAt 方法

删除指定索引的字符串

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

参数

index
类型：SystemInt32
索引
备注
参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewObjectCollectionBase(T).ToList 方法

SwebViewObjectCollectionBaseTToList 方法

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.ToList" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public List<T> ToList()
Public Function ToList As List(Of T)

返回值

类型：List T

[缺少 "M:Swebui.Controls.SwebViewObjectCollectionBase`1.ToList" 的 <returns> 文档]

参见

引用

SwebViewObjectCollectionBaseT 类


SwebViewStringCollection 类

字符串列表类
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewObjectCollectionBase String
Swebui.ControlsSwebViewStringCollection

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewStringCollection : SwebViewObjectCollectionBase<string>
Public Class SwebViewStringCollection
    Inherits SwebViewObjectCollectionBase(Of String)

SwebViewStringCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewStringCollection | 初始化 SwebViewStringCollection 类的一个新实例
公共方法 | SwebViewStringCollection(ISwebViewObjectCollectionOwner) | 初始化 SwebViewStringCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取根据指定索引的字符串 (继承自 SwebViewObjectCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | AddRange(IEnumerable) | 添加字符串集合 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | AddRange(T) | (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Clear | 清空字符串列表 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Contains | 获取是否包含指定字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | IndexOf | 获取指定字符串的索引 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Refresh | (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Remove | 删除指定编号的字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引的字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | ToList | (继承自 SwebViewObjectCollectionBaseT。)
Top
运算符
名称 | 说明
(ListString to SwebViewStringCollection) |
(String to SwebViewStringCollection) |
(SwebViewStringCollection to String) |
(SwebViewStringCollection to ListString) |
Top
备注
参见

引用

Swebui.Controls 命名空间


SwebViewStringCollection 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebViewStringCollection | 初始化 SwebViewStringCollection 类的一个新实例
公共方法 | SwebViewStringCollection(ISwebViewObjectCollectionOwner) | 初始化 SwebViewStringCollection 类的一个新实例
Top
参见

引用

SwebViewStringCollection 类


SwebViewStringCollection 构造函数

初始化 SwebViewStringCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewStringCollection()
Public Sub New
参见

引用

SwebViewStringCollection 类
SwebViewStringCollection 重载


SwebViewStringCollection 构造函数 (ISwebViewObjectCollectionOwner)

初始化 SwebViewStringCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewStringCollection(
    ISwebViewObjectCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewObjectCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewObjectCollectionOwner

[缺少 "M:Swebui.Controls.SwebViewStringCollection.#ctor(Swebui.Controls.ISwebViewObjectCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

SwebViewStringCollection 类
SwebViewStringCollection 重载


SwebViewStringCollection 属性

SwebViewStringCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取根据指定索引的字符串 (继承自 SwebViewObjectCollectionBaseT。)
Top
参见

引用

SwebViewStringCollection 类


SwebViewStringCollection 方法

SwebViewStringCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | AddRange(IEnumerable) | 添加字符串集合 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | AddRange(T) | (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Clear | 清空字符串列表 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Contains | 获取是否包含指定字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | IndexOf | 获取指定字符串的索引 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Refresh | (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | Remove | 删除指定编号的字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引的字符串 (继承自 SwebViewObjectCollectionBaseT。)
公共方法 | ToList | (继承自 SwebViewObjectCollectionBaseT。)
Top
参见

引用

SwebViewStringCollection 类


SwebViewStringCollection 类型转换

运算符
名称 | 说明
(ListString to SwebViewStringCollection) |
(String to SwebViewStringCollection) |
(SwebViewStringCollection to String) |
(SwebViewStringCollection to ListString) |
Top
参见

引用

SwebViewStringCollection 类


SwebViewStringCollection Implicit 转换运算符

SwebViewStringCollection 转换运算符

重载列表
名称 | 说明
(ListString to SwebViewStringCollection) |
(String to SwebViewStringCollection) |
(SwebViewStringCollection to String) |
(SwebViewStringCollection to ListString) |
Top
参见

引用

SwebViewStringCollection 类


SwebViewStringCollection Implicit 转换 (List(String) to SwebViewStringCollection)

SwebViewStringCollection 转换 (ListString to SwebViewStringCollection)

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.Collections.Generic.List{System.String})~Swebui.Controls.SwebViewStringCollection" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static implicit operator SwebViewStringCollection (
    List<string> strArray
)
Public Shared Widening Operator CType (
    strArray As List(Of String)
) As SwebViewStringCollection

参数

strArray
类型：System.Collections.GenericList String

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.Collections.Generic.List{System.String})~Swebui.Controls.SwebViewStringCollection" 的 <param name="strArray"/> 文档]

返回值

类型：SwebViewStringCollection

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.Collections.Generic.List{System.String})~Swebui.Controls.SwebViewStringCollection" 的 <returns> 文档]

参见

引用

SwebViewStringCollection 类
重载


SwebViewStringCollection Implicit 转换 (String[] to SwebViewStringCollection)

SwebViewStringCollection 转换 (String to SwebViewStringCollection)

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.String[])~Swebui.Controls.SwebViewStringCollection" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static implicit operator SwebViewStringCollection (
    string[] strArray
)
Public Shared Widening Operator CType (
    strArray As String()
) As SwebViewStringCollection

参数

strArray
类型：SystemString

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.String[])~Swebui.Controls.SwebViewStringCollection" 的 <param name="strArray"/> 文档]

返回值

类型：SwebViewStringCollection

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(System.String[])~Swebui.Controls.SwebViewStringCollection" 的 <returns> 文档]

参见

引用

SwebViewStringCollection 类
重载


SwebViewStringCollection Implicit 转换 (SwebViewStringCollection to String[])

SwebViewStringCollection 转换 (SwebViewStringCollection to String)

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.String[]" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static implicit operator string[] (
    SwebViewStringCollection stringCollection
)
Public Shared Widening Operator CType (
    stringCollection As SwebViewStringCollection
) As String()

参数

stringCollection
类型：Swebui.ControlsSwebViewStringCollection

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.String[]" 的 <param name="stringCollection"/> 文档]

返回值

类型：String

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.String[]" 的 <returns> 文档]

参见

引用

SwebViewStringCollection 类
重载


SwebViewStringCollection Implicit 转换 (SwebViewStringCollection to List(String))

SwebViewStringCollection 转换 (SwebViewStringCollection to ListString)

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.Collections.Generic.List{System.String}" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static implicit operator List<string> (
    SwebViewStringCollection stringCollection
)
Public Shared Widening Operator CType (
    stringCollection As SwebViewStringCollection
) As List(Of String)

参数

stringCollection
类型：Swebui.ControlsSwebViewStringCollection

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.Collections.Generic.List{System.String}" 的 <param name="stringCollection"/> 文档]

返回值

类型：List String

[缺少 "M:Swebui.Controls.SwebViewStringCollection.op_Implicit(Swebui.Controls.SwebViewStringCollection)~System.Collections.Generic.List{System.String}" 的 <returns> 文档]

参见

引用

SwebViewStringCollection 类
重载


SwebViewStringCollectionPropertyExtend 类

[缺少 "T:Swebui.Controls.SwebViewStringCollectionPropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsSwebViewStringCollectionPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebViewStringCollectionPropertyExtend : SwebPropertyExtend
Public Class SwebViewStringCollectionPropertyExtend
    Inherits SwebPropertyExtend

SwebViewStringCollectionPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebViewStringCollectionPropertyExtend | 初始化 SwebViewStringCollectionPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


SwebViewStringCollectionPropertyExtend 构造函数

初始化 SwebViewStringCollectionPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebViewStringCollectionPropertyExtend()
Public Sub New
参见

引用

SwebViewStringCollectionPropertyExtend 类


SwebViewTemplateItem 类

模板类
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsSwebViewTemplateItem
Swebui.ControlsListViewRow
Swebui.ControlsListViewSection
Swebui.ControlsPageViewItem
Swebui.ControlsSwebListViewTemplateItem

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebViewTemplateItem : SwebViewCollectionItem
Public MustInherit Class SwebViewTemplateItem
    Inherits SwebViewCollectionItem

SwebViewTemplateItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据
Top
参见

引用

Swebui.Controls 命名空间


SwebViewTemplateItem 属性

SwebViewTemplateItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Control | 获取模板控件实例
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
Top
参见

引用

SwebViewTemplateItem 类


SwebViewTemplateItem.Control 属性

SwebViewTemplateItemControl 属性

获取模板控件实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebUserControl Control { get; }
Public ReadOnly Property Control As SwebUserControl
    Get

返回值

类型：SwebUserControl
参见

引用

SwebViewTemplateItem 类


SwebViewTemplateItem 方法

SwebViewTemplateItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DataUpdate | 更新数据
Top
参见

引用

SwebViewTemplateItem 类


SwebViewTemplateItem.DataUpdate 方法

SwebViewTemplateItemDataUpdate 方法

更新数据

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public virtual void DataUpdate(
    Object dataSource,
    string dataMember = ""
)
Public Overridable Sub DataUpdate (
    dataSource As Object,
    Optional dataMember As String = ""
)

参数

dataSource
类型：SystemObject
数据源
dataMember (Optional)
类型：SystemString
数据源名称
参见

引用

SwebViewTemplateItem 类


Switch 类

开关控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebCheckedControlBase
Swebui.ControlsSwitch

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class Switch : SwebCheckedControlBase, ISwebRenderControl,
    ISwebEventControl
Public Class Switch
    Inherits SwebCheckedControlBase
    Implements ISwebRenderControl, ISwebEventControl

Switch 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Switch | 初始化Switch类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (继承自 SwebCheckedControlBase。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态 (继承自 SwebCheckedControlBase。)
公共属性 | CheckedColor | 获取和设置Checked为true的颜色
公共属性 | CircleColor | 获取和设置圆点颜色
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (继承自 SwebCheckedControlBase。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | (继承自 SwebCheckedControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | UnCheckedColor | 获取和设置Checked为false的颜色
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
事件
 | 名称 | 说明
公共事件 | CheckedChanged | (继承自 SwebCheckedControlBase。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


Switch 构造函数

初始化Switch类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Switch()
Public Sub New
参见

引用

Switch 类


Switch 属性

Switch 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | (重写 SwebControlBackColor.)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | (继承自 SwebCheckedControlBase。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Border | (重写 SwebControlBorder.)
公共属性 | BorderColor | (重写 SwebControlBorderColor.)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | (重写 SwebControlBorderStyle.)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Checked | 获取或设置选择状态 (继承自 SwebCheckedControlBase。)
公共属性 | CheckedColor | 获取和设置Checked为true的颜色
公共属性 | CircleColor | 获取和设置圆点颜色
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | (继承自 SwebCheckedControlBase。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Enabled | (继承自 SwebCheckedControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | UnCheckedColor | 获取和设置Checked为false的颜色
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

Switch 类


Switch.BackColor 属性

SwitchBackColor 属性

[缺少 "P:Swebui.Controls.Switch.BackColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Switch 类


Switch.Border 属性

SwitchBorder 属性

[缺少 "P:Swebui.Controls.Switch.Border" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Border Border { get; set; }
Public Overrides Property Border As Border
    Get
    Set

属性值

类型：Border
参见

引用

Switch 类


Switch.BorderColor 属性

SwitchBorderColor 属性

[缺少 "P:Swebui.Controls.Switch.BorderColor" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Color BorderColor { get; set; }
Public Overrides Property BorderColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Switch 类


Switch.BorderRadius 属性

SwitchBorderRadius 属性

[缺少 "P:Swebui.Controls.Switch.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

Switch 类


Switch.BorderStyle 属性

SwitchBorderStyle 属性

[缺少 "P:Swebui.Controls.Switch.BorderStyle" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set

属性值

类型：BorderStyle
参见

引用

Switch 类


Switch.CheckedColor 属性

SwitchCheckedColor 属性

获取和设置Checked为true的颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CheckedColor { get; set; }
Public Property CheckedColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Switch 类


Switch.CircleColor 属性

SwitchCircleColor 属性

获取和设置圆点颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CircleColor { get; set; }
Public Property CircleColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Switch 类


Switch.UnCheckedColor 属性

SwitchUnCheckedColor 属性

获取和设置Checked为false的颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color UnCheckedColor { get; set; }
Public Property UnCheckedColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

Switch 类


Switch 方法

Switch 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
Top
参见

引用

Switch 类


Switch 事件

Switch 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | CheckedChanged | (继承自 SwebCheckedControlBase。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Switch 类


TabPageControl 类

[缺少 "T:Swebui.Controls.TabPageControl" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsPanel
Swebui.ControlsTabPageControl

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TabPageControl : Panel
Public Class TabPageControl
    Inherits Panel

TabPageControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TabPageControl | 初始化 TabPageControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | (继承自 Panel。)
公共属性 | BackgroundImagePath | (继承自 Panel。)
公共属性 | BackgroundImageRepeatMode | (继承自 Panel。)
公共属性 | BackgroundImageSizeMode | (继承自 Panel。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | (重写 SwebControlFlex.)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动 (继承自 Panel。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。 (继承自 Panel。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | (重写 SwebControlLocation.)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取和设置是否触发鼠标事件。 (继承自 Panel。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。 (继承自 Panel。)
公共属性 | RaiseReachEnd | 获取和设置一个值，该值指示是否在Panel可滚动时，当滚动到底部时，触发ReachEnd事件 (继承自 Panel。)
公共属性 | RaiseRefresh | 获取和设置一个值，该值指示是否在Panel可滚动时，当从顶部向下划动时，是否触发Refresh事件 (继承自 Panel。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Scrollable | 获取和设置一个值，该值指示在子控件超出容器范围时，容器是否可滚动。 (继承自 Panel。)
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示在Scrollable为true时，是否启用容器滚动。 (继承自 Panel。)
公共属性 | SelfAlign | (重写 SwebControlSelfAlign.)
公共属性 | SelfLayout | (重写 SwebControlSelfLayout.)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。 (继承自 Panel。)
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。 (继承自 Panel。)
公共属性 | Size | (重写 SwebControlSize.)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Title |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Touchable | 获取和设置是否触发点击事件。 (继承自 Panel。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | AutoScroll | (继承自 Panel。)
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ScrollTo(Single, Boolean) | 滚动到指定位置 (继承自 Panel。)
公共方法 | ScrollTo(Single, Single, Boolean) | 滚动到指定位置 (继承自 Panel。)
公共方法 | ScrollToBottom | 滚动到ScrollablePanel的底部 (继承自 Panel。)
公共方法 | ScrollToTop | 滚动到ScrollablePanel的顶部 (继承自 Panel。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll | (继承自 Panel。)
Top
事件
 | 名称 | 说明
公共事件 | MouseEnter | 在位置变化时发生。 (继承自 Panel。)
公共事件 | MouseLeave | 在位置变化时发生。 (继承自 Panel。)
公共事件 | PositionChanged | 在位置变化时发生。 (继承自 Panel。)
公共事件 | Press | 在触摸操作激活时触发。 (继承自 Panel。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在滚动到底部时发生。 (继承自 Panel。)
公共事件 | Refresh | 在下拉刷新时发生。 (继承自 Panel。)
Top
参见

引用

Swebui.Controls 命名空间


TabPageControl 构造函数

初始化 TabPageControl 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TabPageControl()
Public Sub New
参见

引用

TabPageControl 类


TabPageControl 属性

TabPageControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BackgroundImage | (继承自 Panel。)
公共属性 | BackgroundImagePath | (继承自 Panel。)
公共属性 | BackgroundImageRepeatMode | (继承自 Panel。)
公共属性 | BackgroundImageSizeMode | (继承自 Panel。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | (重写 SwebControlFlex.)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | Horizontal | 获取和设置一个值，该值指示是否水平滑动 (继承自 Panel。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | KeyboardScrollHidden | 获取和设置一个值，该值指示用户拖拽滚动视图的时候，是否要隐藏软键盘。 (继承自 Panel。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | (重写 SwebControlLocation.)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RaiseMouseEvent | 获取和设置是否触发鼠标事件。 (继承自 Panel。)
公共属性 | RaisePositionChanged | 获取和设置是否触发滚动时位置变化事件。 (继承自 Panel。)
公共属性 | RaiseReachEnd | 获取和设置一个值，该值指示是否在Panel可滚动时，当滚动到底部时，触发ReachEnd事件 (继承自 Panel。)
公共属性 | RaiseRefresh | 获取和设置一个值，该值指示是否在Panel可滚动时，当从顶部向下划动时，是否触发Refresh事件 (继承自 Panel。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Scrollable | 获取和设置一个值，该值指示在子控件超出容器范围时，容器是否可滚动。 (继承自 Panel。)
公共属性 | ScrollEnabled | 获取和设置一个值，该值指示在Scrollable为true时，是否启用容器滚动。 (继承自 Panel。)
公共属性 | SelfAlign | (重写 SwebControlSelfAlign.)
公共属性 | SelfLayout | (重写 SwebControlSelfLayout.)
公共属性 | ShowHorizontalScrollBar | 获取和设置一个值，该值指示是否显示水平滚动条。 (继承自 Panel。)
公共属性 | ShowVerticalScrollBar | 获取和设置一个值，该值指示是否显示垂直滚动条。 (继承自 Panel。)
公共属性 | Size | (重写 SwebControlSize.)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Title |
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Touchable | 获取和设置是否触发点击事件。 (继承自 Panel。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

TabPageControl 类


TabPageControl.Flex 属性

TabPageControlFlex 属性

[缺少 "P:Swebui.Controls.TabPageControl.Flex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int Flex { get; set; }
Public Overrides Property Flex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

TabPageControl 类


TabPageControl.Location 属性

TabPageControlLocation 属性

[缺少 "P:Swebui.Controls.TabPageControl.Location" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Point Location { get; set; }
Public Overrides Property Location As Point
    Get
    Set

属性值

类型：Point
参见

引用

TabPageControl 类


TabPageControl.SelfAlign 属性

TabPageControlSelfAlign 属性

[缺少 "P:Swebui.Controls.TabPageControl.SelfAlign" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutSelfAlign SelfAlign { get; set; }
Public Overrides Property SelfAlign As LayoutSelfAlign
    Get
    Set

属性值

类型：LayoutSelfAlign
参见

引用

TabPageControl 类


TabPageControl.SelfLayout 属性

TabPageControlSelfLayout 属性

[缺少 "P:Swebui.Controls.TabPageControl.SelfLayout" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override LayoutSelfPosition SelfLayout { get; set; }
Public Overrides Property SelfLayout As LayoutSelfPosition
    Get
    Set

属性值

类型：LayoutSelfPosition
参见

引用

TabPageControl 类


TabPageControl.Size 属性

TabPageControlSize 属性

[缺少 "P:Swebui.Controls.TabPageControl.Size" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set

属性值

类型：Size
参见

引用

TabPageControl 类


TabPageControl.Title 属性

TabPageControlTitle 属性

[缺少 "P:Swebui.Controls.TabPageControl.Title" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Title { get; set; }
Public Property Title As String
    Get
    Set

属性值

类型：String
参见

引用

TabPageControl 类


TabPageControl 方法

TabPageControl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AutoScroll | (继承自 Panel。)
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | ScrollTo(Single, Boolean) | 滚动到指定位置 (继承自 Panel。)
公共方法 | ScrollTo(Single, Single, Boolean) | 滚动到指定位置 (继承自 Panel。)
公共方法 | ScrollToBottom | 滚动到ScrollablePanel的底部 (继承自 Panel。)
公共方法 | ScrollToTop | 滚动到ScrollablePanel的顶部 (继承自 Panel。)
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | StopAutoScroll | (继承自 Panel。)
Top
参见

引用

TabPageControl 类


TabPageControl 事件

TabPageControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | MouseEnter | 在位置变化时发生。 (继承自 Panel。)
公共事件 | MouseLeave | 在位置变化时发生。 (继承自 Panel。)
公共事件 | PositionChanged | 在位置变化时发生。 (继承自 Panel。)
公共事件 | Press | 在触摸操作激活时触发。 (继承自 Panel。)
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | ReachEnd | 在滚动到底部时发生。 (继承自 Panel。)
公共事件 | Refresh | 在下拉刷新时发生。 (继承自 Panel。)
Top
参见

引用

TabPageControl 类


TabPageIndicator 枚举

[缺少 "T:Swebui.Controls.TabPageIndicator" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum TabPageIndicator
Public Enumeration TabPageIndicator
成员
成员名称 | 值 | 说明
None | 0 | 无显示标识
Title | 1 | 标题显示标识
Title2 | 2 | 标题显示标识(样式1)
Title3 | 3 | 标题显示标识(样式2)
Tab | 4 | 标题显示标识显示在下方
参见

引用

Swebui.Controls 命名空间


TabPageView 类

单元页面控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsSwebContainerControl
Swebui.ControlsTabPageView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TabPageView : SwebContainerControl,
    ISwebRenderControl, ISwebEventControl
Public Class TabPageView
    Inherits SwebContainerControl
    Implements ISwebRenderControl, ISwebEventControl

TabPageView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TabPageView | 初始化TabPageView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageIndex | 获取显示Page页索引
公共属性 | PageIndicator | 获取和设置显示标识样式
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Titles | 获取和设置标题集合
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | OnEventRaised |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | PageChanged |
公共事件 | PageClosed |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


TabPageView 构造函数

初始化TabPageView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TabPageView()
Public Sub New
参见

引用

TabPageView 类


TabPageView 属性

TabPageView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Controls | 获取包含在控件内的控件的集合。 (继承自 SwebContainerControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | PageIndex | 获取显示Page页索引
公共属性 | PageIndicator | 获取和设置显示标识样式
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Titles | 获取和设置标题集合
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

TabPageView 类


TabPageView.PageIndex 属性

TabPageViewPageIndex 属性

获取显示Page页索引

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

TabPageView 类


TabPageView.PageIndicator 属性

TabPageViewPageIndicator 属性

获取和设置显示标识样式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TabPageIndicator PageIndicator { get; set; }
Public Property PageIndicator As TabPageIndicator
    Get
    Set

属性值

类型：TabPageIndicator
参见

引用

TabPageView 类


TabPageView.Titles 属性

TabPageViewTitles 属性

获取和设置标题集合

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Titles { get; set; }
Public Property Titles As String()
    Get
    Set

属性值

类型：String
参见

引用

TabPageView 类


TabPageView 方法

TabPageView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | OnEventRaised |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

TabPageView 类


TabPageView.OnEventRaised 方法

TabPageViewOnEventRaised 方法

[缺少 "M:Swebui.Controls.TabPageView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.TabPageView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

TabPageView 类


TabPageView 事件

TabPageView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PageChanged |
公共事件 | PageClosed |
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

TabPageView 类


TabPageView.PageChanged 事件

TabPageViewPageChanged 事件

[缺少 "E:Swebui.Controls.TabPageView.PageChanged" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event TabPageViewChangedEventHandler PageChanged
Public Event PageChanged As TabPageViewChangedEventHandler

值

类型：Swebui.ControlsTabPageViewChangedEventHandler
参见

引用

TabPageView 类


TabPageView.PageClosed 事件

TabPageViewPageClosed 事件

[缺少 "E:Swebui.Controls.TabPageView.PageClosed" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event TabPageViewClosedEventHandler PageClosed
Public Event PageClosed As TabPageViewClosedEventHandler

值

类型：Swebui.ControlsTabPageViewClosedEventHandler
参见

引用

TabPageView 类


TabPageViewChangedEventArgs 类

[缺少 "T:Swebui.Controls.TabPageViewChangedEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsTabPageViewChangedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TabPageViewChangedEventArgs : EventArgs
Public Class TabPageViewChangedEventArgs
    Inherits EventArgs

TabPageViewChangedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TabPageViewChangedEventArgs | 初始化 TabPageViewChangedEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | PageIndex |
Top
参见

引用

Swebui.Controls 命名空间


TabPageViewChangedEventArgs 构造函数

初始化 TabPageViewChangedEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TabPageViewChangedEventArgs()
Public Sub New
参见

引用

TabPageViewChangedEventArgs 类


TabPageViewChangedEventArgs 属性

TabPageViewChangedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PageIndex |
Top
参见

引用

TabPageViewChangedEventArgs 类


TabPageViewChangedEventArgs.PageIndex 属性

TabPageViewChangedEventArgsPageIndex 属性

[缺少 "P:Swebui.Controls.TabPageViewChangedEventArgs.PageIndex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get

属性值

类型：Int32
参见

引用

TabPageViewChangedEventArgs 类


TabPageViewChangedEventHandler 委托

[缺少 "T:Swebui.Controls.TabPageViewChangedEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void TabPageViewChangedEventHandler(
    Object sender,
    TabPageViewChangedEventArgs e
)
Public Delegate Sub TabPageViewChangedEventHandler (
    sender As Object,
    e As TabPageViewChangedEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsTabPageViewChangedEventArgs
参见

引用

Swebui.Controls 命名空间


TabPageViewClosedEventArgs 类

[缺少 "T:Swebui.Controls.TabPageViewClosedEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsTabPageViewClosedEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TabPageViewClosedEventArgs : EventArgs
Public Class TabPageViewClosedEventArgs
    Inherits EventArgs

TabPageViewClosedEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TabPageViewClosedEventArgs | 初始化 TabPageViewClosedEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | PageControl |
公共属性 | PageIndex |
Top
参见

引用

Swebui.Controls 命名空间


TabPageViewClosedEventArgs 构造函数

初始化 TabPageViewClosedEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TabPageViewClosedEventArgs()
Public Sub New
参见

引用

TabPageViewClosedEventArgs 类


TabPageViewClosedEventArgs 属性

TabPageViewClosedEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PageControl |
公共属性 | PageIndex |
Top
参见

引用

TabPageViewClosedEventArgs 类


TabPageViewClosedEventArgs.PageControl 属性

TabPageViewClosedEventArgsPageControl 属性

[缺少 "P:Swebui.Controls.TabPageViewClosedEventArgs.PageControl" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SwebControl PageControl { get; }
Public ReadOnly Property PageControl As SwebControl
    Get

属性值

类型：SwebControl
参见

引用

TabPageViewClosedEventArgs 类


TabPageViewClosedEventArgs.PageIndex 属性

TabPageViewClosedEventArgsPageIndex 属性

[缺少 "P:Swebui.Controls.TabPageViewClosedEventArgs.PageIndex" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get

属性值

类型：Int32
参见

引用

TabPageViewClosedEventArgs 类


TabPageViewClosedEventHandler 委托

[缺少 "T:Swebui.Controls.TabPageViewClosedEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void TabPageViewClosedEventHandler(
    Object sender,
    TabPageViewClosedEventArgs e
)
Public Delegate Sub TabPageViewClosedEventHandler (
    sender As Object,
    e As TabPageViewClosedEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsTabPageViewClosedEventArgs
参见

引用

Swebui.Controls 命名空间


TextBox 类

文本框控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebBindableControl
Swebui.ControlsSwebTextControl
Swebui.ControlsTextBox

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TextBox : SwebTextControl, ISwebRenderControl,
    ISwebEventControl
Public Class TextBox
    Inherits SwebTextControl
    Implements ISwebRenderControl, ISwebEventControl

TextBox 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TextBox | 初始化TextBox类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxLength | 获取或设置文本框中最多允许的字符数。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Multiline | 获取或设置是否多行显示
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | ReadOnly | 获取或设置文本框是否只读
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ReturnKeyType | 获取和设置确定返回键的外观
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SecurityMode | 获取或设置一个值，该值指示是否密文显示.
公共属性 | SelectOnFocus | 获取和设置一个值，该值指示当获得焦点的时候，文字是否会被选中
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取和设置控件文本 (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | ValueType | 获取和设置输入值类型。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WaterMarkText | 获取或设置文本框水印颜色
公共属性 | WaterMarkTextColor | 获取或设置文本框水印颜色
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | GoToBlur | 使控件失去焦点
公共方法 | GoToFocus | 使控件获取焦点
公共方法 | GoToSelect | 选中文本
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | SubmitEditing | 在虚拟键盘中点击“确认/返回/搜索”按键时发生。
公共事件 | TextChanged | 在Text属性改变时发生
公共事件 | TouchEnter | 在触摸进入控件时发生
公共事件 | TouchLeave | 在触摸进入控件时发生。
Top
参见

引用

Swebui.Controls 命名空间


TextBox 构造函数

初始化TextBox类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TextBox()
Public Sub New
参见

引用

TextBox 类


TextBox 属性

TextBox 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | BindDataValue | 获取和设置一个值，该值用于指定根据 DataMember 做数据绑定时的值。 (继承自 SwebBindableControl。)
公共属性 | BindDisplayValue | 获取和设置绑定控件默认绑定值 (继承自 SwebTextControl。)
公共属性 | BindDisplayValueGone | 获取和设置一个值，该值指示是否根据BindDisplayValue的值判断是否隐藏显示 (继承自 SwebBindableControl。)
公共属性 | BindMode | 获取绑定模式 (继承自 SwebBindableControl。)
公共属性 | Bold | 获取或设置文本粗体 (继承自 SwebTextControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DataMember | 获取和设置值绑定字段。 (继承自 SwebBindableControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | DisplayFormat | 获取和设置根据 DisplayMember 做数据绑定时的格式。 (继承自 SwebBindableControl。)
公共属性 | DisplayMember | 获取和设置显示绑定字段。 (继承自 SwebBindableControl。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontFamily | 获取和设置控件字体。
公共属性 | FontSize | 获取或设置控件字体大小 (继承自 SwebTextControl。)
公共属性 | ForeColor | 获取或设置控件的前景色，用于显示文本 (继承自 SwebTextControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | HorizontalAlignment | 获取或设置控件水平方向 (继承自 SwebTextControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | Italic | 获取或设置文本斜体 (继承自 SwebTextControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxLength | 获取或设置文本框中最多允许的字符数。
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Multiline | 获取或设置是否多行显示
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | ReadOnly | 获取或设置文本框是否只读
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | ReturnKeyType | 获取和设置确定返回键的外观
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SecurityMode | 获取或设置一个值，该值指示是否密文显示.
公共属性 | SelectOnFocus | 获取和设置一个值，该值指示当获得焦点的时候，文字是否会被选中
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Text | 获取和设置控件文本 (重写 SwebTextControlText.)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | ValueType | 获取和设置输入值类型。
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | WaterMarkText | 获取或设置文本框水印颜色
公共属性 | WaterMarkTextColor | 获取或设置文本框水印颜色
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

TextBox 类


TextBox.FontFamily 属性

TextBoxFontFamily 属性

获取和设置控件字体。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string FontFamily { get; set; }
Public Property FontFamily As String
    Get
    Set

属性值

类型：String
参见

引用

TextBox 类


TextBox.MaxLength 属性

TextBoxMaxLength 属性

获取或设置文本框中最多允许的字符数。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int MaxLength { get; set; }
Public Property MaxLength As Integer
    Get
    Set

属性值

类型：Int32
文本框中最多允许的字符数。默认值为 0，表示未设置该属性。
参见

引用

TextBox 类


TextBox.Multiline 属性

TextBoxMultiline 属性

获取或设置是否多行显示

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Multiline { get; set; }
Public Property Multiline As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TextBox 类


TextBox.ReadOnly 属性

TextBoxReadOnly 属性

获取或设置文本框是否只读

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TextBox 类


TextBox.ReturnKeyType 属性

TextBoxReturnKeyType 属性

获取和设置确定返回键的外观

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ReturnKeyType ReturnKeyType { get; set; }
Public Property ReturnKeyType As ReturnKeyType
    Get
    Set

属性值

类型：ReturnKeyType
参见

引用

TextBox 类


TextBox.SecurityMode 属性

TextBoxSecurityMode 属性

获取或设置一个值，该值指示是否密文显示.

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool SecurityMode { get; set; }
Public Property SecurityMode As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TextBox 类


TextBox.SelectOnFocus 属性

TextBoxSelectOnFocus 属性

获取和设置一个值，该值指示当获得焦点的时候，文字是否会被选中

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool SelectOnFocus { get; set; }
Public Property SelectOnFocus As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TextBox 类


TextBox.Text 属性

TextBoxText 属性

获取和设置控件文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

TextBox 类


TextBox.ValueType 属性

TextBoxValueType 属性

获取和设置输入值类型。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TextBoxValueType ValueType { get; set; }
Public Property ValueType As TextBoxValueType
    Get
    Set

属性值

类型：TextBoxValueType
参见

引用

TextBox 类


TextBox.WaterMarkText 属性

TextBoxWaterMarkText 属性

获取或设置文本框水印颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string WaterMarkText { get; set; }
Public Property WaterMarkText As String
    Get
    Set

属性值

类型：String
参见

引用

TextBox 类


TextBox.WaterMarkTextColor 属性

TextBoxWaterMarkTextColor 属性

获取或设置文本框水印颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color WaterMarkTextColor { get; set; }
Public Property WaterMarkTextColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TextBox 类


TextBox 方法

TextBox 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindData | 数据绑定 (继承自 SwebBindableControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | GoToBlur | 使控件失去焦点
公共方法 | GoToFocus | 使控件获取焦点
公共方法 | GoToSelect | 选中文本
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
Top
参见

引用

TextBox 类


TextBox.GoToBlur 方法

TextBoxGoToBlur 方法

使控件失去焦点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void GoToBlur()
Public Sub GoToBlur
参见

引用

TextBox 类


TextBox.GoToFocus 方法

TextBoxGoToFocus 方法

使控件获取焦点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void GoToFocus()
Public Sub GoToFocus
参见

引用

TextBox 类


TextBox.GoToSelect 方法

TextBoxGoToSelect 方法

选中文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void GoToSelect()
Public Sub GoToSelect
参见

引用

TextBox 类


TextBox.OnEventRaised 方法

TextBoxOnEventRaised 方法

[缺少 "M:Swebui.Controls.TextBox.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.TextBox.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

TextBox 类


TextBox 事件

TextBox 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
公共事件 | SubmitEditing | 在虚拟键盘中点击“确认/返回/搜索”按键时发生。
公共事件 | TextChanged | 在Text属性改变时发生
公共事件 | TouchEnter | 在触摸进入控件时发生
公共事件 | TouchLeave | 在触摸进入控件时发生。
Top
参见

引用

TextBox 类


TextBox.SubmitEditing 事件

TextBoxSubmitEditing 事件

在虚拟键盘中点击“确认/返回/搜索”按键时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler SubmitEditing
Public Event SubmitEditing As EventHandler

值

类型：SystemEventHandler
参见

引用

TextBox 类


TextBox.TextChanged 事件

TextBoxTextChanged 事件

在Text属性改变时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler TextChanged
Public Event TextChanged As EventHandler

值

类型：SystemEventHandler
参见

引用

TextBox 类


TextBox.TouchEnter 事件

TextBoxTouchEnter 事件

在触摸进入控件时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler TouchEnter
Public Event TouchEnter As EventHandler

值

类型：SystemEventHandler
参见

引用

TextBox 类


TextBox.TouchLeave 事件

TextBoxTouchLeave 事件

在触摸进入控件时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event EventHandler TouchLeave
Public Event TouchLeave As EventHandler

值

类型：SystemEventHandler
参见

引用

TextBox 类


TextBoxValueType 枚举

TextBox 输入值类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum TextBoxValueType
Public Enumeration TextBoxValueType
成员
成员名称 | 值 | 说明
Default | 0 | 任何信息
Number | 1 | 只能数字
参见

引用

Swebui.Controls 命名空间


TextDecorationLineType 枚举

文本修饰要使用的线条类型

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum TextDecorationLineType
Public Enumeration TextDecorationLineType
成员
成员名称 | 值 | 说明
None | 0 | 规定文本修饰没有线条
Underline | 1 | 规定文本的下方将显示一条线
Line_through | 2 | 规定文本的中间将显示一条线
参见

引用

Swebui.Controls 命名空间


Timer 类

计时器组件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebComponent
Swebui.ControlsTimer

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class Timer : SwebComponent
Public Class Timer
    Inherits SwebComponent

Timer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Timer | 初始化 Timer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Enabled | 获取一个值，该值指示计时器是否正在运行
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Interval | 获取或设置触发Tick事件的间隔时间（以秒为单位）
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
方法
 | 名称 | 说明
公共方法 | Start | 启动计时器
公共方法 | Stop | 停止计时器
Top
事件
 | 名称 | 说明
公共事件 | Tick | 当指定的计时器间隔已过去而且计时器处于启用状态时发生。
Top
备注
由客户端触发，仅在客户端前台或存活状态下可用
参见

引用

Swebui.Controls 命名空间


Timer 构造函数

初始化 Timer 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Timer()
Public Sub New
参见

引用

Timer 类


Timer 属性

Timer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Enabled | 获取一个值，该值指示计时器是否正在运行
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Interval | 获取或设置触发Tick事件的间隔时间（以秒为单位）
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
参见

引用

Timer 类


Timer.Enabled 属性

TimerEnabled 属性

获取一个值，该值指示计时器是否正在运行

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get

属性值

类型：Boolean
如果计时器当前处于启用状态，则为 true；否则为 false。默认值为 false。

返回值

类型：Boolean
备注
参见

引用

Timer 类


Timer.Interval 属性

TimerInterval 属性

获取或设置触发Tick事件的间隔时间（以秒为单位）

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set

属性值

类型：Int32
该值不能小于 1

返回值

类型：Int32
备注
在Timer运行期间，修改此属性值，必须在Timer重新Start时才生效。 由于计时器组件由客户端触发，间隔时间并不能保证精度。误差时间不能保证。但是计时器组件能保证在网络不通畅的情况下的持续触发Tick事件。
参见

引用

Timer 类


Timer 方法

Timer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Start | 启动计时器
公共方法 | Stop | 停止计时器
Top
参见

引用

Timer 类


Timer.Start 方法

TimerStart 方法

启动计时器

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Start()
Public Sub Start
备注
参见

引用

Timer 类


Timer.Stop 方法

TimerStop 方法

停止计时器

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public void Stop()
Public Sub Stop
备注
参见

引用

Timer 类


Timer 事件

Timer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Tick | 当指定的计时器间隔已过去而且计时器处于启用状态时发生。
Top
参见

引用

Timer 类


Timer.Tick 事件

TimerTick 事件

当指定的计时器间隔已过去而且计时器处于启用状态时发生。

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler Tick
Public Event Tick As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

Timer 类


ToastLength 枚举

Toast存续期间

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum ToastLength
Public Enumeration ToastLength
成员
成员名称 | 值 | 说明
SHORT | 0 | 短期间
LONG | 1 | 长期间
备注
参见

引用

Swebui.Controls 命名空间


ToggledButton 类

[缺少 "T:Swebui.Controls.ToggledButton" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsToggledButton

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class ToggledButton
Public Class ToggledButton

ToggledButton 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ToggledButton | 初始化 ToggledButton 类的一个新实例
公共方法 | ToggledButton(ListEditerFontStyle) | 初始化 ToggledButton 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

Swebui.Controls 命名空间


ToggledButton 构造函数

重载列表
 | 名称 | 说明
公共方法 | ToggledButton | 初始化 ToggledButton 类的一个新实例
公共方法 | ToggledButton(ListEditerFontStyle) | 初始化 ToggledButton 类的一个新实例
Top
参见

引用

ToggledButton 类


ToggledButton 构造函数

初始化 ToggledButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ToggledButton()
Public Sub New
参见

引用

ToggledButton 类
ToggledButton 重载


ToggledButton 构造函数 (List(EditerFontStyle))

ToggledButton 构造函数 (ListEditerFontStyle)

初始化 ToggledButton 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public ToggledButton(
    List<EditerFontStyle> data
)
Public Sub New (
    data As List(Of EditerFontStyle)
)

参数

data
类型：System.Collections.GenericList EditerFontStyle

[缺少 "M:Swebui.Controls.ToggledButton.#ctor(System.Collections.Generic.List{Swebui.Controls.EditerFontStyle})" 的 <param name="data"/> 文档]

参见

引用

ToggledButton 类
ToggledButton 重载


ToggledButton 属性

ToggledButton 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data |
Top
参见

引用

ToggledButton 类


ToggledButton.Data 属性

ToggledButtonData 属性

[缺少 "P:Swebui.Controls.ToggledButton.Data" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public List<EditerFontStyle> Data { get; }
Public ReadOnly Property Data As List(Of EditerFontStyle)
    Get

属性值

类型：List EditerFontStyle
参见

引用

ToggledButton 类


TreeSelect 类

下拉列表控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsTreeSelect

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeSelect : SwebControl, ISwebRenderControl,
    ISwebEventControl, ISwebViewCollectionOwner
Public Class TreeSelect
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl, ISwebViewCollectionOwner

TreeSelect 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeSelect | 初始化 TreeSelect 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | DefaultValue | 获取和设置默认选中项
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Disabled | 获取和设置是否禁用控件
公共属性 | DropDownHeight |
公共属性 | ExpandAll | 获取和设置是否展开所有节点
公共属性 | FilterTreeNode | 获取和设置是否显示搜索框
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | LeafOnly | 获取和设置是否选中的行只显示子节点
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | ListBackgroundColor | 获取和设置下拉框背景颜色
公共属性 | ListColor | 获取和设置下拉框文字颜色
公共属性 | ListFontSize | 获取和设置下拉框字体大小
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxTagCount | 获取和设置显示框内标签的最大数量
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Multiple | 获取和设置是否多选
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Nodes | 获取和设置节点集合
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 获取和设置水印文本
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TagBackgroundColor | 获取和设置显示框开启多选后标签背景颜色
公共属性 | TagColor | 获取和设置显示框开启多选后标签文字颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnEventRaised |
公共方法 | Refresh |
Top
事件
 | 名称 | 说明
公共事件 | Press | 在点击时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


TreeSelect 构造函数

初始化 TreeSelect 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelect()
Public Sub New
参见

引用

TreeSelect 类


TreeSelect 属性

TreeSelect 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | DefaultValue | 获取和设置默认选中项
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Disabled | 获取和设置是否禁用控件
公共属性 | DropDownHeight |
公共属性 | ExpandAll | 获取和设置是否展开所有节点
公共属性 | FilterTreeNode | 获取和设置是否显示搜索框
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | LeafOnly | 获取和设置是否选中的行只显示子节点
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | ListBackgroundColor | 获取和设置下拉框背景颜色
公共属性 | ListColor | 获取和设置下拉框文字颜色
公共属性 | ListFontSize | 获取和设置下拉框字体大小
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MaxTagCount | 获取和设置显示框内标签的最大数量
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Multiple | 获取和设置是否多选
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Nodes | 获取和设置节点集合
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Placeholder | 获取和设置水印文本
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | TagBackgroundColor | 获取和设置显示框开启多选后标签背景颜色
公共属性 | TagColor | 获取和设置显示框开启多选后标签文字颜色
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

TreeSelect 类


TreeSelect.Color 属性

TreeSelectColor 属性

获取和设置文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeSelect 类


TreeSelect.DefaultValue 属性

TreeSelectDefaultValue 属性

获取和设置默认选中项

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] DefaultValue { get; set; }
Public Property DefaultValue As String()
    Get
    Set

属性值

类型：String
参见

引用

TreeSelect 类


TreeSelect.Disabled 属性

TreeSelectDisabled 属性

获取和设置是否禁用控件

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Disabled { get; set; }
Public Property Disabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TreeSelect 类


TreeSelect.DropDownHeight 属性

TreeSelectDropDownHeight 属性

[缺少 "P:Swebui.Controls.TreeSelect.DropDownHeight" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int DropDownHeight { get; set; }
Public Property DropDownHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

TreeSelect 类


TreeSelect.ExpandAll 属性

TreeSelectExpandAll 属性

获取和设置是否展开所有节点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ExpandAll { get; set; }
Public Property ExpandAll As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TreeSelect 类


TreeSelect.FilterTreeNode 属性

TreeSelectFilterTreeNode 属性

获取和设置是否显示搜索框

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool FilterTreeNode { get; set; }
Public Property FilterTreeNode As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TreeSelect 类


TreeSelect.FontSize 属性

TreeSelectFontSize 属性

获取和设置字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

TreeSelect 类


TreeSelect.LeafOnly 属性

TreeSelectLeafOnly 属性

获取和设置是否选中的行只显示子节点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool LeafOnly { get; set; }
Public Property LeafOnly As Boolean
    Get
    Set

属性值

类型：Boolean
备注
此属性不支持动态修改。（设置False，若选中全部子项，点击事件中返回父级ID；设置True，点击事件中返回子项ID）
参见

引用

TreeSelect 类


TreeSelect.ListBackgroundColor 属性

TreeSelectListBackgroundColor 属性

获取和设置下拉框背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ListBackgroundColor { get; set; }
Public Property ListBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeSelect 类


TreeSelect.ListColor 属性

TreeSelectListColor 属性

获取和设置下拉框文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ListColor { get; set; }
Public Property ListColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeSelect 类


TreeSelect.ListFontSize 属性

TreeSelectListFontSize 属性

获取和设置下拉框字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float ListFontSize { get; set; }
Public Property ListFontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

TreeSelect 类


TreeSelect.MaxTagCount 属性

TreeSelectMaxTagCount 属性

获取和设置显示框内标签的最大数量

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int MaxTagCount { get; set; }
Public Property MaxTagCount As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

TreeSelect 类


TreeSelect.Multiple 属性

TreeSelectMultiple 属性

获取和设置是否多选

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool Multiple { get; set; }
Public Property Multiple As Boolean
    Get
    Set

属性值

类型：Boolean
备注
此属性不支持动态修改
参见

引用

TreeSelect 类


TreeSelect.Nodes 属性

TreeSelectNodes 属性

获取和设置节点集合

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNodeCollection Nodes { get; }
Public ReadOnly Property Nodes As TreeSelectNodeCollection
    Get

属性值

类型：TreeSelectNodeCollection
参见

引用

TreeSelect 类


TreeSelect.Placeholder 属性

TreeSelectPlaceholder 属性

获取和设置水印文本

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Placeholder { get; set; }
Public Property Placeholder As String
    Get
    Set

属性值

类型：String
参见

引用

TreeSelect 类


TreeSelect.TagBackgroundColor 属性

TreeSelectTagBackgroundColor 属性

获取和设置显示框开启多选后标签背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TagBackgroundColor { get; set; }
Public Property TagBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeSelect 类


TreeSelect.TagColor 属性

TreeSelectTagColor 属性

获取和设置显示框开启多选后标签文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color TagColor { get; set; }
Public Property TagColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeSelect 类


TreeSelect 方法

TreeSelect 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnEventRaised |
公共方法 | Refresh |
Top
参见

引用

TreeSelect 类


TreeSelect.ItemAdd 方法

TreeSelectItemAdd 方法

[缺少 "M:Swebui.Controls.TreeSelect.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelect.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

TreeSelect 类


TreeSelect.ItemClear 方法

TreeSelectItemClear 方法

[缺少 "M:Swebui.Controls.TreeSelect.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

TreeSelect 类


TreeSelect.ItemPropertyChanged 方法

TreeSelectItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.TreeSelect.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelect.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.TreeSelect.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

TreeSelect 类


TreeSelect.ItemRemove 方法

TreeSelectItemRemove 方法

[缺少 "M:Swebui.Controls.TreeSelect.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelect.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.TreeSelect.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

TreeSelect 类


TreeSelect.OnEventRaised 方法

TreeSelectOnEventRaised 方法

[缺少 "M:Swebui.Controls.TreeSelect.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.TreeSelect.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

TreeSelect 类


TreeSelect.Refresh 方法

TreeSelectRefresh 方法

[缺少 "M:Swebui.Controls.TreeSelect.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

TreeSelect 类


TreeSelect 事件

TreeSelect 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Press | 在点击时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

TreeSelect 类


TreeSelect.Press 事件

TreeSelectPress 事件

在点击时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event TreeSelectTreeSelectOnPressEventHandler Press
Public Event Press As TreeSelectTreeSelectOnPressEventHandler

值

类型：Swebui.ControlsTreeSelectTreeSelectOnPressEventHandler
备注
参见

引用

TreeSelect 类


TreeSelect.TreeSelectOnPressEventHandler 委托

TreeSelectTreeSelectOnPressEventHandler 委托

[缺少 "T:Swebui.Controls.TreeSelect.TreeSelectOnPressEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void TreeSelectOnPressEventHandler(
    Object sender,
    TreeSelectPressEventArgs args
)
Public Delegate Sub TreeSelectOnPressEventHandler (
    sender As Object,
    args As TreeSelectPressEventArgs
)

参数

sender
类型：SystemObject
args
类型：Swebui.ControlsTreeSelectPressEventArgs
参见

引用

Swebui.Controls 命名空间


TreeSelectNode 类

[缺少 "T:Swebui.Controls.TreeSelectNode" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsTreeSelectNode

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeSelectNode : SwebViewCollectionItem,
    ISwebViewCollectionOwner
Public Class TreeSelectNode
    Inherits SwebViewCollectionItem
    Implements ISwebViewCollectionOwner

TreeSelectNode 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeSelectNode | 初始化 TreeSelectNode 类的一个新实例
公共方法 | TreeSelectNode(String, String) | 初始化 TreeSelectNode 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Nodes |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TreeID |
Top
方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

Swebui.Controls 命名空间


TreeSelectNode 构造函数

重载列表
 | 名称 | 说明
公共方法 | TreeSelectNode | 初始化 TreeSelectNode 类的一个新实例
公共方法 | TreeSelectNode(String, String) | 初始化 TreeSelectNode 类的一个新实例
Top
参见

引用

TreeSelectNode 类


TreeSelectNode 构造函数

初始化 TreeSelectNode 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNode()
Public Sub New
参见

引用

TreeSelectNode 类
TreeSelectNode 重载


TreeSelectNode 构造函数 (String, String)

初始化 TreeSelectNode 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNode(
    string treeID,
    string text
)
Public Sub New (
    treeID As String,
    text As String
)

参数

treeID
类型：SystemString

[缺少 "M:Swebui.Controls.TreeSelectNode.#ctor(System.String,System.String)" 的 <param name="treeID"/> 文档]

text
类型：SystemString

[缺少 "M:Swebui.Controls.TreeSelectNode.#ctor(System.String,System.String)" 的 <param name="text"/> 文档]

参见

引用

TreeSelectNode 类
TreeSelectNode 重载


TreeSelectNode 属性

TreeSelectNode 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Nodes |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TreeID |
Top
参见

引用

TreeSelectNode 类


TreeSelectNode.Nodes 属性

TreeSelectNodeNodes 属性

[缺少 "P:Swebui.Controls.TreeSelectNode.Nodes" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNodeCollection Nodes { get; }
Public ReadOnly Property Nodes As TreeSelectNodeCollection
    Get

属性值

类型：TreeSelectNodeCollection
参见

引用

TreeSelectNode 类


TreeSelectNode.Text 属性

TreeSelectNodeText 属性

[缺少 "P:Swebui.Controls.TreeSelectNode.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

TreeSelectNode 类


TreeSelectNode.TreeID 属性

TreeSelectNodeTreeID 属性

[缺少 "P:Swebui.Controls.TreeSelectNode.TreeID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string TreeID { get; set; }
Public Property TreeID As String
    Get
    Set

属性值

类型：String
参见

引用

TreeSelectNode 类


TreeSelectNode 方法

TreeSelectNode 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

TreeSelectNode 类


TreeSelectNode.ItemAdd 方法

TreeSelectNodeItemAdd 方法

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

TreeSelectNode 类


TreeSelectNode.ItemClear 方法

TreeSelectNodeItemClear 方法

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

TreeSelectNode 类


TreeSelectNode.ItemPropertyChanged 方法

TreeSelectNodeItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

TreeSelectNode 类


TreeSelectNode.ItemRemove 方法

TreeSelectNodeItemRemove 方法

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.TreeSelectNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

TreeSelectNode 类


TreeSelectNode.Refresh 方法

TreeSelectNodeRefresh 方法

[缺少 "M:Swebui.Controls.TreeSelectNode.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

TreeSelectNode 类


TreeSelectNodeCollection 类

[缺少 "T:Swebui.Controls.TreeSelectNodeCollection" 的 <summary> 文档]

继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase TreeSelectNode
Swebui.ControlsTreeSelectNodeCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeSelectNodeCollection : SwebViewCollectionBase<TreeSelectNode>
Public Class TreeSelectNodeCollection
    Inherits SwebViewCollectionBase(Of TreeSelectNode)

TreeSelectNodeCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeSelectNodeCollection | 初始化 TreeSelectNodeCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


TreeSelectNodeCollection 构造函数

初始化 TreeSelectNodeCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNodeCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.TreeSelectNodeCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

TreeSelectNodeCollection 类


TreeSelectNodeCollection 属性

TreeSelectNodeCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

TreeSelectNodeCollection 类


TreeSelectNodeCollection 方法

TreeSelectNodeCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

TreeSelectNodeCollection 类


TreeSelectNodeCollectionPropertyExtend 类

[缺少 "T:Swebui.Controls.TreeSelectNodeCollectionPropertyExtend" 的 <summary> 文档]

继承层次
SystemObject
Swebui.ControlsSwebPropertyExtend
Swebui.ControlsTreeSelectNodeCollectionPropertyExtend

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeSelectNodeCollectionPropertyExtend : SwebPropertyExtend
Public Class TreeSelectNodeCollectionPropertyExtend
    Inherits SwebPropertyExtend

TreeSelectNodeCollectionPropertyExtend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeSelectNodeCollectionPropertyExtend | 初始化 TreeSelectNodeCollectionPropertyExtend 类的一个新实例
Top
参见

引用

Swebui.Controls 命名空间


TreeSelectNodeCollectionPropertyExtend 构造函数

初始化 TreeSelectNodeCollectionPropertyExtend 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectNodeCollectionPropertyExtend()
Public Sub New
参见

引用

TreeSelectNodeCollectionPropertyExtend 类


TreeSelectPressEventArgs 类

为TreeSelect提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsTreeSelectPressEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeSelectPressEventArgs : EventArgs
Public Class TreeSelectPressEventArgs
    Inherits EventArgs

TreeSelectPressEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeSelectPressEventArgs | 初始化 TreeSelectPressEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsSelected | 当前项是否选中
公共属性 | Selections | 所有选中项ID
公共属性 | TreeID | 当前项ID
Top
参见

引用

Swebui.Controls 命名空间


TreeSelectPressEventArgs 构造函数

初始化 TreeSelectPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeSelectPressEventArgs(
    string treeid,
    bool select,
    string[] values
)
Public Sub New (
    treeid As String,
    select As Boolean,
    values As String()
)

参数

treeid
类型：SystemString

[缺少 "M:Swebui.Controls.TreeSelectPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="treeid"/> 文档]

select
类型：SystemBoolean

[缺少 "M:Swebui.Controls.TreeSelectPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="select"/> 文档]

values
类型：SystemString

[缺少 "M:Swebui.Controls.TreeSelectPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="values"/> 文档]

参见

引用

TreeSelectPressEventArgs 类


TreeSelectPressEventArgs 属性

TreeSelectPressEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsSelected | 当前项是否选中
公共属性 | Selections | 所有选中项ID
公共属性 | TreeID | 当前项ID
Top
参见

引用

TreeSelectPressEventArgs 类


TreeSelectPressEventArgs.IsSelected 属性

TreeSelectPressEventArgsIsSelected 属性

当前项是否选中

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get

属性值

类型：Boolean
参见

引用

TreeSelectPressEventArgs 类


TreeSelectPressEventArgs.Selections 属性

TreeSelectPressEventArgsSelections 属性

所有选中项ID

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Selections { get; }
Public ReadOnly Property Selections As String()
    Get

属性值

类型：String
参见

引用

TreeSelectPressEventArgs 类


TreeSelectPressEventArgs.TreeID 属性

TreeSelectPressEventArgsTreeID 属性

当前项ID

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string TreeID { get; }
Public ReadOnly Property TreeID As String
    Get

属性值

类型：String
参见

引用

TreeSelectPressEventArgs 类


TreeView 类

树形菜单控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsSwebLayoutControl
Swebui.ControlsTreeView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeView : SwebLayoutControl, ISwebRenderControl,
    ISwebEventControl, ISwebViewCollectionOwner
Public Class TreeView
    Inherits SwebLayoutControl
    Implements ISwebRenderControl, ISwebEventControl, ISwebViewCollectionOwner

TreeView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeView | 初始化TreeView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | CountBackgroundColor | 获取和设置尾部文本背景颜色
公共属性 | CountColor | 获取和设置尾部文本颜色
公共属性 | CountFontSize | 获取和设置尾部文本字体大小
公共属性 | DefaultValue | 获取和设置默认选中行
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | ExpandAll | 获取和设置是否展开所有节点
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Nodes | 获取treeView控件中的根节点
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | RowHeight | 获取和设置行高
公共属性 | SelectBackgroundColor | 获取和设置选中行背景颜色
公共属性 | SelectColor | 获取和设置选中行文字颜色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowCheckBox | 设置和获取一个值，该值指示是否显示可选中框
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | Refresh |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
事件
 | 名称 | 说明
公共事件 | Press | 在点击时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


TreeView 构造函数

初始化TreeView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeView()
Public Sub New
参见

引用

TreeView 类


TreeView 属性

TreeView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | 获取和设置控件边框角度 (继承自 SwebControl。)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | Color | 获取和设置文字颜色
公共属性 | CountBackgroundColor | 获取和设置尾部文本背景颜色
公共属性 | CountColor | 获取和设置尾部文本颜色
公共属性 | CountFontSize | 获取和设置尾部文本字体大小
公共属性 | DefaultValue | 获取和设置默认选中行
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Direction | 获取和设置容器主轴方向。 (继承自 SwebLayoutControl。)
公共属性 | ExpandAll | 获取和设置是否展开所有节点
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | FontSize | 获取和设置字体大小
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | ItemAlign | 获取和设置布局控件内元素在侧轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | JustifyAlign | 获取和设置布局控件内元素在主轴上的对齐方式。 (继承自 SwebLayoutControl。)
公共属性 | Layout | 获取和设置布局 (继承自 SwebLayoutControl。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Nodes | 获取treeView控件中的根节点
公共属性 | Overflow | 获取和设置容器布局覆盖范围 (继承自 SwebLayoutControl。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | 获取或设置控件边框与边框内控件间隔距离 (继承自 SwebControl。)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | PointerEvent | 获取和设置控制当前组件是否可以作为触控事件的目标 (继承自 SwebLayoutControl。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | RowHeight | 获取和设置行高
公共属性 | SelectBackgroundColor | 获取和设置选中行背景颜色
公共属性 | SelectColor | 获取和设置选中行文字颜色
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | ShowCheckBox | 设置和获取一个值，该值指示是否显示可选中框
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | Wrap | 获取和设置子控件如果超出容器空间时，是否换行。 (继承自 SwebLayoutControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

TreeView 类


TreeView.Color 属性

TreeViewColor 属性

获取和设置文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeView 类


TreeView.CountBackgroundColor 属性

TreeViewCountBackgroundColor 属性

获取和设置尾部文本背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CountBackgroundColor { get; set; }
Public Property CountBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeView 类


TreeView.CountColor 属性

TreeViewCountColor 属性

获取和设置尾部文本颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CountColor { get; set; }
Public Property CountColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeView 类


TreeView.CountFontSize 属性

TreeViewCountFontSize 属性

获取和设置尾部文本字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float CountFontSize { get; set; }
Public Property CountFontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

TreeView 类


TreeView.DefaultValue 属性

TreeViewDefaultValue 属性

获取和设置默认选中行

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] DefaultValue { get; set; }
Public Property DefaultValue As String()
    Get
    Set

属性值

类型：String
参见

引用

TreeView 类


TreeView.ExpandAll 属性

TreeViewExpandAll 属性

获取和设置是否展开所有节点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ExpandAll { get; set; }
Public Property ExpandAll As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TreeView 类


TreeView.FontSize 属性

TreeViewFontSize 属性

获取和设置字体大小

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set

属性值

类型：Single
参见

引用

TreeView 类


TreeView.Nodes 属性

TreeViewNodes 属性

获取treeView控件中的根节点

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewNodeCollection Nodes { get; }
Public ReadOnly Property Nodes As TreeViewNodeCollection
    Get

属性值

类型：TreeViewNodeCollection
参见

引用

TreeView 类


TreeView.RowHeight 属性

TreeViewRowHeight 属性

获取和设置行高

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int RowHeight { get; set; }
Public Property RowHeight As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

TreeView 类


TreeView.SelectBackgroundColor 属性

TreeViewSelectBackgroundColor 属性

获取和设置选中行背景颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectBackgroundColor { get; set; }
Public Property SelectBackgroundColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeView 类


TreeView.SelectColor 属性

TreeViewSelectColor 属性

获取和设置选中行文字颜色

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SelectColor { get; set; }
Public Property SelectColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

TreeView 类


TreeView.ShowCheckBox 属性

TreeViewShowCheckBox 属性

设置和获取一个值，该值指示是否显示可选中框

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ShowCheckBox { get; set; }
Public Property ShowCheckBox As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

TreeView 类


TreeView 方法

TreeView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | DestroyDialog | 销毁弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | FindByRenderID | (继承自 SwebLayoutControl。)
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | OnBindValueUpdate | (继承自 SwebLayoutControl。)
公共方法 | Refresh |
公共方法 | ShowContextDialog | 弹出上下文用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowDialog(SwebUserControl, DialogOptions, EventHandler) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
公共方法 | ShowModal(SwebUserControl, DialogOptions) | 弹出用户控件界面 (继承自 SwebLayoutControl。)
Top
参见

引用

TreeView 类


TreeView.ItemAdd 方法

TreeViewItemAdd 方法

[缺少 "M:Swebui.Controls.TreeView.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeView.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

TreeView 类


TreeView.ItemClear 方法

TreeViewItemClear 方法

[缺少 "M:Swebui.Controls.TreeView.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

TreeView 类


TreeView.ItemPropertyChanged 方法

TreeViewItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.TreeView.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeView.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.TreeView.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

TreeView 类


TreeView.ItemRemove 方法

TreeViewItemRemove 方法

[缺少 "M:Swebui.Controls.TreeView.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeView.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.TreeView.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

TreeView 类


TreeView.Refresh 方法

TreeViewRefresh 方法

[缺少 "M:Swebui.Controls.TreeView.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

TreeView 类


TreeView 事件

TreeView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Press | 在点击时发生。
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

TreeView 类


TreeView.Press 事件

TreeViewPress 事件

在点击时发生。

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event TreeViewTreeViewOnPressEventHandler Press
Public Event Press As TreeViewTreeViewOnPressEventHandler

值

类型：Swebui.ControlsTreeViewTreeViewOnPressEventHandler
备注
参见

引用

TreeView 类


TreeView.TreeViewOnPressEventHandler 委托

TreeViewTreeViewOnPressEventHandler 委托

[缺少 "T:Swebui.Controls.TreeView.TreeViewOnPressEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void TreeViewOnPressEventHandler(
    Object sender,
    TreeViewOnPressEventArgs e
)
Public Delegate Sub TreeViewOnPressEventHandler (
    sender As Object,
    e As TreeViewOnPressEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsTreeViewOnPressEventArgs
参见

引用

Swebui.Controls 命名空间


TreeViewNode 类

属性菜单节点
继承层次
SystemObject
Swebui.ControlsSwebViewCollectionItem
Swebui.ControlsTreeViewNode

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeViewNode : SwebViewCollectionItem,
    ISwebViewCollectionOwner
Public Class TreeViewNode
    Inherits SwebViewCollectionItem
    Implements ISwebViewCollectionOwner

TreeViewNode 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeViewNode | 初始化 TreeViewNode 类的一个新实例
公共方法 | TreeViewNode(String, String) | 初始化 TreeViewNode 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Count |
公共属性 | Nodes |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TreeID |
Top
方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

Swebui.Controls 命名空间


TreeViewNode 构造函数

重载列表
 | 名称 | 说明
公共方法 | TreeViewNode | 初始化 TreeViewNode 类的一个新实例
公共方法 | TreeViewNode(String, String) | 初始化 TreeViewNode 类的一个新实例
Top
参见

引用

TreeViewNode 类


TreeViewNode 构造函数

初始化 TreeViewNode 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewNode()
Public Sub New
参见

引用

TreeViewNode 类
TreeViewNode 重载


TreeViewNode 构造函数 (String, String)

初始化 TreeViewNode 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewNode(
    string treeID,
    string text
)
Public Sub New (
    treeID As String,
    text As String
)

参数

treeID
类型：SystemString

[缺少 "M:Swebui.Controls.TreeViewNode.#ctor(System.String,System.String)" 的 <param name="treeID"/> 文档]

text
类型：SystemString

[缺少 "M:Swebui.Controls.TreeViewNode.#ctor(System.String,System.String)" 的 <param name="text"/> 文档]

参见

引用

TreeViewNode 类
TreeViewNode 重载


TreeViewNode 属性

TreeViewNode 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Count |
公共属性 | Nodes |
公共属性 | Tag | 获取和设置Tag (继承自 SwebViewCollectionItem。)
公共属性 | Text |
公共属性 | TreeID |
Top
参见

引用

TreeViewNode 类


TreeViewNode.Count 属性

TreeViewNodeCount 属性

[缺少 "P:Swebui.Controls.TreeViewNode.Count" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Count { get; set; }
Public Property Count As String
    Get
    Set

属性值

类型：String
参见

引用

TreeViewNode 类


TreeViewNode.Nodes 属性

TreeViewNodeNodes 属性

[缺少 "P:Swebui.Controls.TreeViewNode.Nodes" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewNodeCollection Nodes { get; }
Public ReadOnly Property Nodes As TreeViewNodeCollection
    Get

属性值

类型：TreeViewNodeCollection
参见

引用

TreeViewNode 类


TreeViewNode.Text 属性

TreeViewNodeText 属性

[缺少 "P:Swebui.Controls.TreeViewNode.Text" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Text { get; set; }
Public Property Text As String
    Get
    Set

属性值

类型：String
参见

引用

TreeViewNode 类


TreeViewNode.TreeID 属性

TreeViewNodeTreeID 属性

[缺少 "P:Swebui.Controls.TreeViewNode.TreeID" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string TreeID { get; set; }
Public Property TreeID As String
    Get
    Set

属性值

类型：String
参见

引用

TreeViewNode 类


TreeViewNode 方法

TreeViewNode 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ItemAdd |
公共方法 | ItemClear |
公共方法 | ItemPropertyChanged |
公共方法 | ItemRemove |
公共方法 | Refresh |
Top
参见

引用

TreeViewNode 类


TreeViewNode.ItemAdd 方法

TreeViewNodeItemAdd 方法

[缺少 "M:Swebui.Controls.TreeViewNode.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemAdd(
    SwebViewCollectionItem item
)
Public Sub ItemAdd (
    item As SwebViewCollectionItem
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeViewNode.ItemAdd(Swebui.Controls.SwebViewCollectionItem)" 的 <param name="item"/> 文档]

实现

ISwebViewCollectionOwnerItemAdd(SwebViewCollectionItem)
参见

引用

TreeViewNode 类


TreeViewNode.ItemClear 方法

TreeViewNodeItemClear 方法

[缺少 "M:Swebui.Controls.TreeViewNode.ItemClear" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemClear()
Public Sub ItemClear

实现

ISwebViewCollectionOwnerItemClear
参见

引用

TreeViewNode 类


TreeViewNode.ItemPropertyChanged 方法

TreeViewNodeItemPropertyChanged 方法

[缺少 "M:Swebui.Controls.TreeViewNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemPropertyChanged(
    SwebViewCollectionItem item,
    ShadowPropertyChangedArgs e
)
Public Sub ItemPropertyChanged (
    item As SwebViewCollectionItem,
    e As ShadowPropertyChangedArgs
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeViewNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="item"/> 文档]

e
类型：Swebui.ControlsShadowPropertyChangedArgs

[缺少 "M:Swebui.Controls.TreeViewNode.ItemPropertyChanged(Swebui.Controls.SwebViewCollectionItem,Swebui.Controls.ShadowPropertyChangedArgs)" 的 <param name="e"/> 文档]

实现

ISwebViewCollectionOwnerItemPropertyChanged(SwebViewCollectionItem, ShadowPropertyChangedArgs)
参见

引用

TreeViewNode 类


TreeViewNode.ItemRemove 方法

TreeViewNodeItemRemove 方法

[缺少 "M:Swebui.Controls.TreeViewNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void ItemRemove(
    SwebViewCollectionItem item,
    int itemIndex
)
Public Sub ItemRemove (
    item As SwebViewCollectionItem,
    itemIndex As Integer
)

参数

item
类型：Swebui.ControlsSwebViewCollectionItem

[缺少 "M:Swebui.Controls.TreeViewNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="item"/> 文档]

itemIndex
类型：SystemInt32

[缺少 "M:Swebui.Controls.TreeViewNode.ItemRemove(Swebui.Controls.SwebViewCollectionItem,System.Int32)" 的 <param name="itemIndex"/> 文档]

实现

ISwebViewCollectionOwnerItemRemove(SwebViewCollectionItem, Int32)
参见

引用

TreeViewNode 类


TreeViewNode.Refresh 方法

TreeViewNodeRefresh 方法

[缺少 "M:Swebui.Controls.TreeViewNode.Refresh" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Refresh()
Public Sub Refresh

实现

ISwebViewCollectionOwnerRefresh
参见

引用

TreeViewNode 类


TreeViewNodeCollection 类

树形菜单控件节点集合
继承层次
SystemObject
System.CollectionsCollectionBase
Swebui.ControlsSwebViewCollectionBase TreeViewNode
Swebui.ControlsTreeViewNodeCollection

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeViewNodeCollection : SwebViewCollectionBase<TreeViewNode>
Public Class TreeViewNodeCollection
    Inherits SwebViewCollectionBase(Of TreeViewNode)

TreeViewNodeCollection 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeViewNodeCollection | 初始化 TreeViewNodeCollection 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

Swebui.Controls 命名空间


TreeViewNodeCollection 构造函数

初始化 TreeViewNodeCollection 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewNodeCollection(
    ISwebViewCollectionOwner owner
)
Public Sub New (
    owner As ISwebViewCollectionOwner
)

参数

owner
类型：Swebui.ControlsISwebViewCollectionOwner

[缺少 "M:Swebui.Controls.TreeViewNodeCollection.#ctor(Swebui.Controls.ISwebViewCollectionOwner)" 的 <param name="owner"/> 文档]

参见

引用

TreeViewNodeCollection 类


TreeViewNodeCollection 属性

TreeViewNodeCollection 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 获取指定索引集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

TreeViewNodeCollection 类


TreeViewNodeCollection 方法

TreeViewNodeCollection 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 添加集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | AddRange | 添加集合元素数组 (继承自 SwebViewCollectionBaseT。)
公共方法 | Clear | 清除元素集合 (继承自 SwebViewCollectionBaseT。)
公共方法 | Contains | 判断是否存在给定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | IndexOf | 获取指定集合元素的索引 (继承自 SwebViewCollectionBaseT。)
公共方法 | Refresh | 对数据进行刷新 (继承自 SwebViewCollectionBaseT。)
公共方法 | Remove | 删除指定集合元素 (继承自 SwebViewCollectionBaseT。)
公共方法 | RemoveAt | 删除指定索引位置的集合元素 (继承自 SwebViewCollectionBaseT。)
Top
参见

引用

TreeViewNodeCollection 类


TreeViewOnPressEventArgs 类

为TreeView提供数据
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsTreeViewOnPressEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TreeViewOnPressEventArgs : EventArgs
Public Class TreeViewOnPressEventArgs
    Inherits EventArgs

TreeViewOnPressEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TreeViewOnPressEventArgs | 初始化 TreeViewOnPressEventArgs 类的一个新实例
公共方法 | TreeViewOnPressEventArgs(String) | 初始化 TreeViewOnPressEventArgs 类的一个新实例
公共方法 | TreeViewOnPressEventArgs(String, Boolean, String) | 初始化 TreeViewOnPressEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsSelected | 当前项是否选中
公共属性 | Selections | 所有选中项ID
公共属性 | TreeID | 当前项ID
Top
参见

引用

Swebui.Controls 命名空间


TreeViewOnPressEventArgs 构造函数

重载列表
 | 名称 | 说明
公共方法 | TreeViewOnPressEventArgs | 初始化 TreeViewOnPressEventArgs 类的一个新实例
公共方法 | TreeViewOnPressEventArgs(String) | 初始化 TreeViewOnPressEventArgs 类的一个新实例
公共方法 | TreeViewOnPressEventArgs(String, Boolean, String) | 初始化 TreeViewOnPressEventArgs 类的一个新实例
Top
参见

引用

TreeViewOnPressEventArgs 类


TreeViewOnPressEventArgs 构造函数

初始化 TreeViewOnPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewOnPressEventArgs()
Public Sub New
参见

引用

TreeViewOnPressEventArgs 类
TreeViewOnPressEventArgs 重载


TreeViewOnPressEventArgs 构造函数 (String)

初始化 TreeViewOnPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewOnPressEventArgs(
    string treeid
)
Public Sub New (
    treeid As String
)

参数

treeid
类型：SystemString

[缺少 "M:Swebui.Controls.TreeViewOnPressEventArgs.#ctor(System.String)" 的 <param name="treeid"/> 文档]

参见

引用

TreeViewOnPressEventArgs 类
TreeViewOnPressEventArgs 重载


TreeViewOnPressEventArgs 构造函数 (String, Boolean, String[])

TreeViewOnPressEventArgs 构造函数 (String, Boolean, String)

初始化 TreeViewOnPressEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TreeViewOnPressEventArgs(
    string treeid,
    bool select,
    string[] values
)
Public Sub New (
    treeid As String,
    select As Boolean,
    values As String()
)

参数

treeid
类型：SystemString

[缺少 "M:Swebui.Controls.TreeViewOnPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="treeid"/> 文档]

select
类型：SystemBoolean

[缺少 "M:Swebui.Controls.TreeViewOnPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="select"/> 文档]

values
类型：SystemString

[缺少 "M:Swebui.Controls.TreeViewOnPressEventArgs.#ctor(System.String,System.Boolean,System.String[])" 的 <param name="values"/> 文档]

参见

引用

TreeViewOnPressEventArgs 类
TreeViewOnPressEventArgs 重载


TreeViewOnPressEventArgs 属性

TreeViewOnPressEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsSelected | 当前项是否选中
公共属性 | Selections | 所有选中项ID
公共属性 | TreeID | 当前项ID
Top
参见

引用

TreeViewOnPressEventArgs 类


TreeViewOnPressEventArgs.IsSelected 属性

TreeViewOnPressEventArgsIsSelected 属性

当前项是否选中

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get

属性值

类型：Boolean
参见

引用

TreeViewOnPressEventArgs 类


TreeViewOnPressEventArgs.Selections 属性

TreeViewOnPressEventArgsSelections 属性

所有选中项ID

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string[] Selections { get; }
Public ReadOnly Property Selections As String()
    Get

属性值

类型：String
参见

引用

TreeViewOnPressEventArgs 类


TreeViewOnPressEventArgs.TreeID 属性

TreeViewOnPressEventArgsTreeID 属性

当前项ID

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string TreeID { get; }
Public ReadOnly Property TreeID As String
    Get

属性值

类型：String
参见

引用

TreeViewOnPressEventArgs 类


TTS 类

文字转语音控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebComponent
Swebui.ControlsTTS

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class TTS : SwebComponent
Public Class TTS
    Inherits SwebComponent

TTS 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TTS | 获取一个TTS实例
Top
属性
 | 名称 | 说明
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
方法
 | 名称 | 说明
公共方法 | Speak | 播放
公共方法 | Stop | 停止
Top
参见

引用

Swebui.Controls 命名空间


TTS 构造函数

获取一个TTS实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public TTS()
Public Sub New
参见

引用

TTS 类


TTS 属性

TTS 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
Top
参见

引用

TTS 类


TTS 方法

TTS 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Speak | 播放
公共方法 | Stop | 停止
Top
参见

引用

TTS 类


TTS.Speak 方法

TTSSpeak 方法

播放

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Speak(
    string text,
    TTSLanguage language,
    float rate,
    SwebComponentOnResultHandler handler = null
)
Public Sub Speak (
    text As String,
    language As TTSLanguage,
    rate As Single,
    Optional handler As SwebComponentOnResultHandler = Nothing
)

参数

text
类型：SystemString
播放的内容
language
类型：Swebui.ControlsTTSLanguage
播放内容的语言 zh:中文, en:英文
rate
类型：SystemSingle
播放的语速 范围:0.1-2(1为正常语速)
handler (Optional)
类型：Swebui.ControlsSwebComponentOnResultHandler
结果回调，可选参数，默认为null
参见

引用

TTS 类


TTS.Stop 方法

TTSStop 方法

停止

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Stop(
    SwebComponentOnResultHandler handler = null
)
Public Sub Stop (
    Optional handler As SwebComponentOnResultHandler = Nothing
)

参数

handler (Optional)
类型：Swebui.ControlsSwebComponentOnResultHandler
结果回调，可选参数，默认为null
参见

引用

TTS 类


TTSLanguage 枚举

TTS语言

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum TTSLanguage
Public Enumeration TTSLanguage
成员
成员名称 | 值 | 说明
zh | 0 | 中文
en | 1 | 英文
参见

引用

Swebui.Controls 命名空间


VerticalAlignment 枚举

垂直方向

命名空间： Swebui.Controls
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public enum VerticalAlignment
Public Enumeration VerticalAlignment
成员
成员名称 | 值 | 说明
Top | 0 | 上
Center | 1 | 中
Bottom | 2 | 下
备注
参见

引用

Swebui.Controls 命名空间


WebView 类

网页控件
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebControlBase
Swebui.ControlsSwebControl
Swebui.ControlsWebView

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class WebView : SwebControl, ISwebRenderControl,
    ISwebEventControl
Public Class WebView
    Inherits SwebControl
    Implements ISwebRenderControl, ISwebEventControl

WebView 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebView | 初始化WebView类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoLocationEnabled | 获取和设置一个值，该值指示是否允许浏览器获取位置信息
公共属性 | Headers | 获取和设置Web头
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MixedContentMode | 获取和设置混合内容模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | ScalesPageToFit | 获取和设置一个值，该值指示是否要把网页缩放到适应视图的大小，以及是否允许用户改变缩放比例
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Url | 获取和设置网页地址
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
公共方法 | PostMessage | 向浏览器发送消息
Top
事件
 | 名称 | 说明
公共事件 | OnLoad | 在WebView加载完成时发生
公共事件 | OnMessage | 在WebView控件返回消息时发生
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

Swebui.Controls 命名空间


WebView 构造函数

初始化WebView类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public WebView()
Public Sub New
参见

引用

WebView 类


WebView 属性

WebView 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Animation | 获取和设置动画 (继承自 SwebControl。)
公共属性 | BackColor | 获取或设置控件的背景色。 (继承自 SwebControl。)
公共属性 | Border | 获取或设置控件边框 (继承自 SwebControl。)
公共属性 | BorderColor | 获取或设置控件边框颜色 (继承自 SwebControl。)
公共属性 | BorderRadius | (重写 SwebControlBorderRadius.)
公共属性 | BorderStyle | 获取和设置控件边框线样式 (继承自 SwebControl。)
公共属性 | Bottom | 获取和设置控件下边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | Bounds | 获取或设置控件（包括其非工作区元素）的大小和位置。 (继承自 SwebControl。)
公共属性 | DesignStyle | 获取和设置包括有关控件的样式 (继承自 SwebControlBase。)
公共属性 | Flex | 获取和设置一个值，该值代表FlexGrow和FlexShrink的组合。 (继承自 SwebControl。)
公共属性 | Form | 获取控件所属的窗体 (继承自 SwebControlBase。)
公共属性 | GeoLocationEnabled | 获取和设置一个值，该值指示是否允许浏览器获取位置信息
公共属性 | Headers | 获取和设置Web头
公共属性 | Height | 获取或设置控件的高度。 (继承自 SwebControl。)
公共属性 | InvokeRequired | 获取一个值，该值指示在更新UI属性时，是否使用使用UI线程委托。 (继承自 SwebControlBase。)
公共属性 | IsLoaded | 获取一个值，该值表示当前窗口 SwebForm 是否已经载入。 (继承自 SwebControlBase。)
公共属性 | LayoutPercentage | 获取和设置布局百分比 (继承自 SwebControl。)
公共属性 | Left | 获取或设置控件距离容器控件左边缘的 x 坐标。 (继承自 SwebControl。)
公共属性 | Location | 获取或设置该控件的左上角相对于其容器的左上角的坐标。 (继承自 SwebControl。)
公共属性 | LowerLocation | 获取或设置该控件的右下角相对于其容器的右下角的坐标 (继承自 SwebControl。)
公共属性 | Margin | 获取或设置控件边框与边框外控件间隔距离 (继承自 SwebControl。)
公共属性 | MaxHeightRate | 获取和设置控件最大高度比例 (继承自 SwebControl。)
公共属性 | MinHeightRate | 获取和设置控件最小高度比例 (继承自 SwebControl。)
公共属性 | MixedContentMode | 获取和设置混合内容模式
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebControlBase。)
公共属性 | Owner | 获取或设置控件的布局控件SwebLayoutControl。 (继承自 SwebControlBase。)
公共属性 | Padding | (重写 SwebControlPadding.)
公共属性 | Parent | 获取或设置控件的父控件SwebContainerControl。 (继承自 SwebControlBase。)
公共属性 | Position | 获取和设置布局 (继承自 SwebControl。)
公共属性 | RenderID | (继承自 SwebControlBase。)
公共属性 | Right | 获取和设置控件右边缘距离父控件的距离。 (继承自 SwebControl。)
公共属性 | ScalesPageToFit | 获取和设置一个值，该值指示是否要把网页缩放到适应视图的大小，以及是否允许用户改变缩放比例
公共属性 | SelfAlign | 获取和设置一个值，该值代表覆盖容器侧轴的对齐方式。 (继承自 SwebControl。)
公共属性 | SelfLayout | 获取和设置控件自身布局。 (继承自 SwebControl。)
公共属性 | Size | 获取或设置控件的高度和宽度。 (继承自 SwebControl。)
公共属性 | TabIndex | 获取或设置在控件的容器的控件的 Tab 键顺序。 (继承自 SwebControl。)
公共属性 | Tag | 获取或设置包含有关控件的数据的对象。 (继承自 SwebControlBase。)
公共属性 | Top | 获取或设置控件的上边缘的 y 坐标。 (继承自 SwebControl。)
公共属性 | Url | 获取和设置网页地址
公共属性 | Visible | 获取或设置一个值，该值指示是否显示该控件。 (继承自 SwebControl。)
公共属性 | Width | 获取或设置控件的宽度。 (继承自 SwebControl。)
公共属性 | ZIndex | 获取和设置一个值，该值表示在Z轴上的显示顺序。 (继承自 SwebControl。)
Top
参见

引用

WebView 类


WebView.BorderRadius 属性

WebViewBorderRadius 属性

[缺少 "P:Swebui.Controls.WebView.BorderRadius" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override int BorderRadius { get; set; }
Public Overrides Property BorderRadius As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

WebView 类


WebView.GeoLocationEnabled 属性

WebViewGeoLocationEnabled 属性

获取和设置一个值，该值指示是否允许浏览器获取位置信息

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool GeoLocationEnabled { get; set; }
Public Property GeoLocationEnabled As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

WebView 类


WebView.Headers 属性

WebViewHeaders 属性

获取和设置Web头

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public SwebViewDictionary<string, string> Headers { get; }
Public ReadOnly Property Headers As SwebViewDictionary(Of String, String)
    Get

属性值

类型：SwebViewDictionary String, String
参见

引用

WebView 类


WebView.MixedContentMode 属性

WebViewMixedContentMode 属性

获取和设置混合内容模式

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public WebViewMixedContentMode MixedContentMode { get; set; }
Public Property MixedContentMode As WebViewMixedContentMode
    Get
    Set

属性值

类型：WebViewMixedContentMode
参见

引用

WebView 类


WebView.Padding 属性

WebViewPadding 属性

[缺少 "P:Swebui.Controls.WebView.Padding" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public override Padding Padding { get; set; }
Public Overrides Property Padding As Padding
    Get
    Set

属性值

类型：Padding
参见

引用

WebView 类


WebView.ScalesPageToFit 属性

WebViewScalesPageToFit 属性

获取和设置一个值，该值指示是否要把网页缩放到适应视图的大小，以及是否允许用户改变缩放比例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public bool ScalesPageToFit { get; set; }
Public Property ScalesPageToFit As Boolean
    Get
    Set

属性值

类型：Boolean
参见

引用

WebView 类


WebView.Url 属性

WebViewUrl 属性

获取和设置网页地址

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Url { get; set; }
Public Property Url As String
    Get
    Set

属性值

类型：String
参见

引用

WebView 类


WebView 方法

WebView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPropertyInitialValue | 根据属性名称获取STML协议中的属性默认值 (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate) | (继承自 SwebControlBase。)
公共方法 | Invoke(Delegate, Object) | (继承自 SwebControlBase。)
公共方法 | OnEventRaised |
公共方法 | PostMessage | 向浏览器发送消息
Top
参见

引用

WebView 类


WebView.OnEventRaised 方法

WebViewOnEventRaised 方法

[缺少 "M:Swebui.Controls.WebView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void OnEventRaised(
    SwebControlEventArgs args
)
Public Sub OnEventRaised (
    args As SwebControlEventArgs
)

参数

args
类型：Swebui.ControlsSwebControlEventArgs

[缺少 "M:Swebui.Controls.WebView.OnEventRaised(Swebui.Controls.SwebControlEventArgs)" 的 <param name="args"/> 文档]

实现

ISwebEventControlOnEventRaised(SwebControlEventArgs)
参见

引用

WebView 类


WebView.PostMessage 方法

WebViewPostMessage 方法

向浏览器发送消息

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void PostMessage(
    string msg
)
Public Sub PostMessage (
    msg As String
)

参数

msg
类型：SystemString
消息内容
备注
需要在当前浏览器界面上的js中注册message事件，在function的msg为当前PostMessage的参数。 window.document.addEventListener('message', function (msg) {})
参见

引用

WebView 类


WebView 事件

WebView 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | OnLoad | 在WebView加载完成时发生
公共事件 | OnMessage | 在WebView控件返回消息时发生
公共事件 | PropertyChanged | Occurs when a property value changes (继承自 SwebControlBase。)
Top
参见

引用

WebView 类


WebView.OnLoad 事件

WebViewOnLoad 事件

在WebView加载完成时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event WebViewWebViewOnLoadEventHandler OnLoad
Public Event OnLoad As WebViewWebViewOnLoadEventHandler

值

类型：Swebui.ControlsWebViewWebViewOnLoadEventHandler
参见

引用

WebView 类


WebView.OnMessage 事件

WebViewOnMessage 事件

在WebView控件返回消息时发生

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public event WebViewWebViewMessageEventHandler OnMessage
Public Event OnMessage As WebViewWebViewMessageEventHandler

值

类型：Swebui.ControlsWebViewWebViewMessageEventHandler
参见

引用

WebView 类


WebView.WebViewMessageEventHandler 委托

WebViewWebViewMessageEventHandler 委托

[缺少 "T:Swebui.Controls.WebView.WebViewMessageEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void WebViewMessageEventHandler(
    Object sender,
    WebViewMessageEventArgs e
)
Public Delegate Sub WebViewMessageEventHandler (
    sender As Object,
    e As WebViewMessageEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsWebViewMessageEventArgs
参见

引用

Swebui.Controls 命名空间


WebView.WebViewOnLoadEventHandler 委托

WebViewWebViewOnLoadEventHandler 委托

[缺少 "T:Swebui.Controls.WebView.WebViewOnLoadEventHandler" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public delegate void WebViewOnLoadEventHandler(
    Object sender,
    WebViewOnLoadEventArgs e
)
Public Delegate Sub WebViewOnLoadEventHandler (
    sender As Object,
    e As WebViewOnLoadEventArgs
)

参数

sender
类型：SystemObject
e
类型：Swebui.ControlsWebViewOnLoadEventArgs
参见

引用

Swebui.Controls 命名空间


WebViewMessageEventArgs 类

[缺少 "T:Swebui.Controls.WebViewMessageEventArgs" 的 <summary> 文档]

继承层次
SystemObject
SystemEventArgs
Swebui.ControlsWebViewMessageEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class WebViewMessageEventArgs : EventArgs
Public Class WebViewMessageEventArgs
    Inherits EventArgs

WebViewMessageEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebViewMessageEventArgs | 初始化 WebViewMessageEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Message |
Top
参见

引用

Swebui.Controls 命名空间


WebViewMessageEventArgs 构造函数

初始化 WebViewMessageEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public WebViewMessageEventArgs(
    string msg
)
Public Sub New (
    msg As String
)

参数

msg
类型：SystemString

[缺少 "M:Swebui.Controls.WebViewMessageEventArgs.#ctor(System.String)" 的 <param name="msg"/> 文档]

参见

引用

WebViewMessageEventArgs 类


WebViewMessageEventArgs 属性

WebViewMessageEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Message |
Top
参见

引用

WebViewMessageEventArgs 类


WebViewMessageEventArgs.Message 属性

WebViewMessageEventArgsMessage 属性

[缺少 "P:Swebui.Controls.WebViewMessageEventArgs.Message" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Message { get; }
Public ReadOnly Property Message As String
    Get

属性值

类型：String
参见

引用

WebViewMessageEventArgs 类


WebViewMixedContentMode 枚举

[缺少 "T:Swebui.Controls.WebViewMixedContentMode" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum WebViewMixedContentMode
Public Enumeration WebViewMixedContentMode
成员
成员名称 | 值 | 说明
Never | 0 | WebView不允许一个安全的站点（https）去加载非安全的站点内容（http）
Always | 1 | WebView允许在一个安全的站点（Https）里加载非安全的站点内容（Http）
Compatibility | 2 | 当涉及到混合式内容时，WebView会尝试去兼容最新Web浏览器的风格。一些不安全的内容（Http）能被加载到一个安全的站点上（Https），而其他类型的内容将会被阻塞。
参见

引用

Swebui.Controls 命名空间


WebViewOnLoadEventArgs 类

为 WebViewOnLoadEvent 提供数据。
继承层次
SystemObject
SystemEventArgs
Swebui.ControlsWebViewOnLoadEventArgs

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class WebViewOnLoadEventArgs : EventArgs
Public Class WebViewOnLoadEventArgs
    Inherits EventArgs

WebViewOnLoadEventArgs 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebViewOnLoadEventArgs | 初始化 WebViewOnLoadEventArgs 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Url |
Top
参见

引用

Swebui.Controls 命名空间


WebViewOnLoadEventArgs 构造函数

初始化 WebViewOnLoadEventArgs 类的一个新实例

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public WebViewOnLoadEventArgs(
    string url
)
Public Sub New (
    url As String
)

参数

url
类型：SystemString

[缺少 "M:Swebui.Controls.WebViewOnLoadEventArgs.#ctor(System.String)" 的 <param name="url"/> 文档]

参见

引用

WebViewOnLoadEventArgs 类


WebViewOnLoadEventArgs 属性

WebViewOnLoadEventArgs 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Url |
Top
参见

引用

WebViewOnLoadEventArgs 类


WebViewOnLoadEventArgs.Url 属性

WebViewOnLoadEventArgsUrl 属性

[缺少 "P:Swebui.Controls.WebViewOnLoadEventArgs.Url" 的 <summary> 文档]

命名空间： Swebui.Controls
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Url { get; }
Public ReadOnly Property Url As String
    Get

属性值

类型：String
参见

引用

WebViewOnLoadEventArgs 类


Swebui.Controls.DropdownAlert 命名空间

[缺少 "N:Swebui.Controls.DropdownAlert" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | DropdownAlert | 顶部动态弹出提示
枚举
 | 枚举 | 说明
公共枚举 | DropdownAlertType | 下拉警告类型


DropdownAlert 类

顶部动态弹出提示
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Swebui.ControlsSwebComponent
Swebui.Controls.DropdownAlertDropdownAlert

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public class DropdownAlert : SwebComponent
Public Class DropdownAlert
    Inherits SwebComponent

DropdownAlert 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DropdownAlert | 获取一个DropdownAlert的实例
Top
属性
 | 名称 | 说明
公共属性 | CloseInterval | 获取与设置alert显示时间（毫秒）
公共属性 | CustomColor | 获取与设置custom模式下背景颜色
公共属性 | CustomImage | 获取与设置custom模式下的图片
公共属性 | ErrorColor | 获取与设置error模式下背景颜色
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | InfoColor | 获取与设置info模式下背景颜色
公共属性 | Message | 获取与设置内容行文本内容
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
公共属性 | SuccessColor | 获取与设置success模式下背景颜色
公共属性 | Title | 获取与设置标题行文本内容
公共属性 | Type | 获取与设置显示alert的类型
公共属性 | WarnColor | 获取与设置warn模式下背景颜色
Top
方法
 | 名称 | 说明
公共方法 | Show | 显示下拉警告框
Top
参见

引用

Swebui.Controls.DropdownAlert 命名空间


DropdownAlert 构造函数

获取一个DropdownAlert的实例

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DropdownAlert()
Public Sub New
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert 属性

DropdownAlert 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CloseInterval | 获取与设置alert显示时间（毫秒）
公共属性 | CustomColor | 获取与设置custom模式下背景颜色
公共属性 | CustomImage | 获取与设置custom模式下的图片
公共属性 | ErrorColor | 获取与设置error模式下背景颜色
公共属性 | Form | 获取组件所属窗体 (继承自 SwebComponent。)
公共属性 | InfoColor | 获取与设置info模式下背景颜色
公共属性 | Message | 获取与设置内容行文本内容
公共属性 | Name | 获取或设置控件的名称。 (继承自 SwebComponent。)
公共属性 | Parent | 获取控件的父控件SwebParentControl。 (继承自 SwebComponent。)
公共属性 | SuccessColor | 获取与设置success模式下背景颜色
公共属性 | Title | 获取与设置标题行文本内容
公共属性 | Type | 获取与设置显示alert的类型
公共属性 | WarnColor | 获取与设置warn模式下背景颜色
Top
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.CloseInterval 属性

DropdownAlertCloseInterval 属性

获取与设置alert显示时间（毫秒）

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public int CloseInterval { get; set; }
Public Property CloseInterval As Integer
    Get
    Set

属性值

类型：Int32
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.CustomColor 属性

DropdownAlertCustomColor 属性

获取与设置custom模式下背景颜色

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color CustomColor { get; set; }
Public Property CustomColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.CustomImage 属性

DropdownAlertCustomImage 属性

获取与设置custom模式下的图片

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string CustomImage { get; set; }
Public Property CustomImage As String
    Get
    Set

属性值

类型：String
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.ErrorColor 属性

DropdownAlertErrorColor 属性

获取与设置error模式下背景颜色

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color ErrorColor { get; set; }
Public Property ErrorColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.InfoColor 属性

DropdownAlertInfoColor 属性

获取与设置info模式下背景颜色

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color InfoColor { get; set; }
Public Property InfoColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.Message 属性

DropdownAlertMessage 属性

获取与设置内容行文本内容

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Message { get; set; }
Public Property Message As String
    Get
    Set

属性值

类型：String
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.SuccessColor 属性

DropdownAlertSuccessColor 属性

获取与设置success模式下背景颜色

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color SuccessColor { get; set; }
Public Property SuccessColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.Title 属性

DropdownAlertTitle 属性

获取与设置标题行文本内容

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public string Title { get; set; }
Public Property Title As String
    Get
    Set

属性值

类型：String
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.Type 属性

DropdownAlertType 属性

获取与设置显示alert的类型

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public DropdownAlertType Type { get; set; }
Public Property Type As DropdownAlertType
    Get
    Set

属性值

类型：DropdownAlertType
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.WarnColor 属性

DropdownAlertWarnColor 属性

获取与设置warn模式下背景颜色

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public Color WarnColor { get; set; }
Public Property WarnColor As Color
    Get
    Set

属性值

类型：Color
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert 方法

DropdownAlert 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Show | 显示下拉警告框
Top
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlert.Show 方法

DropdownAlertShow 方法

显示下拉警告框

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public void Show()
Public Sub Show
参见

引用

DropdownAlert 类
Swebui.Controls.DropdownAlert 命名空间


DropdownAlertType 枚举

下拉警告类型

命名空间： Swebui.Controls.DropdownAlert
程序集： Swebui.Controls (在 Swebui.Controls.dll 中) 版本：1.0.0
语法
C#
VB
复制
public enum DropdownAlertType
Public Enumeration DropdownAlertType
成员
成员名称 | 值 | 说明
info | 0 | info
warn | 1 | warn
error | 2 | error
success | 3 | success
custom | 4 | custom
参见

引用

Swebui.Controls.DropdownAlert 命名空间


Swebui.ManagedThreading 命名空间

Swebui Managed Threading
类
 | 类 | 说明
公共类 | SwebManagedThread | 托管Threading.Thread
公共类 | SwebManagedThreadBase | 托管线程基类
公共类 | SwebManagedThreadingTimer | 托管ThreadingTimer
公共类 | SwebManagedTimer | 托管Timers.Timer


SwebManagedThread 类

托管Threading.Thread
继承层次
SystemObject
Swebui.ManagedThreadingSwebManagedThreadBase
Swebui.ManagedThreadingSwebManagedThread

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebManagedThread : SwebManagedThreadBase
Public Class SwebManagedThread
    Inherits SwebManagedThreadBase

SwebManagedThread 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebManagedThread(Thread, String) | 构造函数
公共方法 | SwebManagedThread(Thread, String, String) | 构造函数
公共方法 | SwebManagedThread(Thread, String, String, String) | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedThread | 获取Threading.Thread
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
方法
名称 | 说明
SetUnManagedThread | 设置线程为会话模式
Top
事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
备注
参见

引用

Swebui.ManagedThreading 命名空间


SwebManagedThread 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebManagedThread(Thread, String) | 构造函数
公共方法 | SwebManagedThread(Thread, String, String) | 构造函数
公共方法 | SwebManagedThread(Thread, String, String, String) | 构造函数
Top
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThread 构造函数 (Thread, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThread(
    Thread managedObject,
    string name
)
Public Sub New (
    managedObject As Thread,
    name As String
)

参数

managedObject
类型：System.ThreadingThread
托管线程
name
类型：SystemString
名称
参见

引用

SwebManagedThread 类
SwebManagedThread 重载
Swebui.ManagedThreading 命名空间


SwebManagedThread 构造函数 (Thread, String, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThread(
    Thread managedObject,
    string name,
    string sessionid
)
Public Sub New (
    managedObject As Thread,
    name As String,
    sessionid As String
)

参数

managedObject
类型：System.ThreadingThread
托管线程
name
类型：SystemString
名称
sessionid
类型：SystemString
会话编号
参见

引用

SwebManagedThread 类
SwebManagedThread 重载
Swebui.ManagedThreading 命名空间


SwebManagedThread 构造函数 (Thread, String, String, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThread(
    Thread managedObject,
    string name,
    string sessionid,
    string sessionform
)
Public Sub New (
    managedObject As Thread,
    name As String,
    sessionid As String,
    sessionform As String
)

参数

managedObject
类型：System.ThreadingThread
托管线程
name
类型：SystemString
名称
sessionid
类型：SystemString
会话编号
sessionform
类型：SystemString
窗体
参见

引用

SwebManagedThread 类
SwebManagedThread 重载
Swebui.ManagedThreading 命名空间


SwebManagedThread 属性

SwebManagedThread 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedThread | 获取Threading.Thread
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThread.ManagedThread 属性

SwebManagedThreadManagedThread 属性

获取Threading.Thread

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Thread ManagedThread { get; }
Public ReadOnly Property ManagedThread As Thread
    Get

属性值

类型：Thread

返回值

类型：Thread
备注
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThread 方法

SwebManagedThread 类型公开以下成员。

方法
名称 | 说明
SetUnManagedThread | 设置线程为会话模式
Top
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThread.SetUnManagedThread 方法

SwebManagedThreadSetUnManagedThread 方法

设置线程为会话模式

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void SetUnManagedThread(
    Thread td,
    string sessionid
)
Public Shared Sub SetUnManagedThread (
    td As Thread,
    sessionid As String
)

参数

td
类型：System.ThreadingThread
线程
sessionid
类型：SystemString
会话编号
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThread 事件

SwebManagedThread 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedThread 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 类

托管线程基类
继承层次
SystemObject
Swebui.ManagedThreadingSwebManagedThreadBase
Swebui.ManagedThreadingSwebManagedThread
Swebui.ManagedThreadingSwebManagedThreadingTimer
Swebui.ManagedThreadingSwebManagedTimer

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public abstract class SwebManagedThreadBase
Public MustInherit Class SwebManagedThreadBase

SwebManagedThreadBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebManagedThreadBase(Object, String) | 初始化 SwebManagedThreadBase 类的一个新实例
公共方法 | SwebManagedThreadBase(Object, String, String) | 初始化 SwebManagedThreadBase 类的一个新实例
公共方法 | SwebManagedThreadBase(Object, String, String, String) | 初始化 SwebManagedThreadBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象
公共属性 | Name | 托管对象名称
Top
方法
名称 | 说明
GetThreadSessionID | 获取线程会话编号
SetThreadSession | 设置线程会话编号
Top
事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生
公共事件 | FormClosed | 在窗体关闭后发生
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生
Top
备注
参见

引用

Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebManagedThreadBase(Object, String) | 初始化 SwebManagedThreadBase 类的一个新实例
公共方法 | SwebManagedThreadBase(Object, String, String) | 初始化 SwebManagedThreadBase 类的一个新实例
公共方法 | SwebManagedThreadBase(Object, String, String, String) | 初始化 SwebManagedThreadBase 类的一个新实例
Top
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 构造函数 (Object, String)

初始化 SwebManagedThreadBase 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadBase(
    Object managedObject,
    string name
)
Public Sub New (
    managedObject As Object,
    name As String
)

参数

managedObject
类型：SystemObject

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String)" 的 <param name="name"/> 文档]

参见

引用

SwebManagedThreadBase 类
SwebManagedThreadBase 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 构造函数 (Object, String, String)

初始化 SwebManagedThreadBase 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadBase(
    Object managedObject,
    string name,
    string sessionid
)
Public Sub New (
    managedObject As Object,
    name As String,
    sessionid As String
)

参数

managedObject
类型：SystemObject

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String)" 的 <param name="name"/> 文档]

sessionid
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String)" 的 <param name="sessionid"/> 文档]

参见

引用

SwebManagedThreadBase 类
SwebManagedThreadBase 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 构造函数 (Object, String, String, String)

初始化 SwebManagedThreadBase 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadBase(
    Object managedObject,
    string name,
    string sessionid,
    string sessionform
)
Public Sub New (
    managedObject As Object,
    name As String,
    sessionid As String,
    sessionform As String
)

参数

managedObject
类型：SystemObject

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String,System.String)" 的 <param name="name"/> 文档]

sessionid
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String,System.String)" 的 <param name="sessionid"/> 文档]

sessionform
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.#ctor(System.Object,System.String,System.String,System.String)" 的 <param name="sessionform"/> 文档]

参见

引用

SwebManagedThreadBase 类
SwebManagedThreadBase 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 属性

SwebManagedThreadBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象
公共属性 | Name | 托管对象名称
Top
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.ManagedObject 属性

SwebManagedThreadBaseManagedObject 属性

托管对象

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Object ManagedObject { get; }
Public ReadOnly Property ManagedObject As Object
    Get

属性值

类型：Object

返回值

类型：Object
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.Name 属性

SwebManagedThreadBaseName 属性

托管对象名称

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public string Name { get; }
Public ReadOnly Property Name As String
    Get

属性值

类型：String

返回值

类型：String
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 方法

SwebManagedThreadBase 类型公开以下成员。

方法
名称 | 说明
GetThreadSessionID | 获取线程会话编号
SetThreadSession | 设置线程会话编号
Top
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.GetThreadSessionID 方法

SwebManagedThreadBaseGetThreadSessionID 方法

获取线程会话编号

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static string GetThreadSessionID()
Public Shared Function GetThreadSessionID As String

返回值

类型：String

[缺少 "M:Swebui.ManagedThreading.SwebManagedThreadBase.GetThreadSessionID" 的 <returns> 文档]

参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.SetThreadSession 方法

SwebManagedThreadBaseSetThreadSession 方法

设置线程会话编号

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public static void SetThreadSession(
    string sessionid
)
Public Shared Sub SetThreadSession (
    sessionid As String
)

参数

sessionid
类型：SystemString
会话编号
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase 事件

SwebManagedThreadBase 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生
公共事件 | FormClosed | 在窗体关闭后发生
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生
Top
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.FormActivated 事件

SwebManagedThreadBaseFormActivated 事件

当使用代码激活或用户激活窗体时发生

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler FormActivated
Public Event FormActivated As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.FormClosed 事件

SwebManagedThreadBaseFormClosed 事件

在窗体关闭后发生

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler FormClosed
Public Event FormClosed As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.FormDeactivate 事件

SwebManagedThreadBaseFormDeactivate 事件

当窗体失去焦点成为不活动窗体时发生

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler FormDeactivate
Public Event FormDeactivate As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadBase.SessionStoped 事件

SwebManagedThreadBaseSessionStoped 事件

在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public event EventHandler SessionStoped
Public Event SessionStoped As EventHandler

值

类型：SystemEventHandler
备注
参见

引用

SwebManagedThreadBase 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 类

托管ThreadingTimer
继承层次
SystemObject
Swebui.ManagedThreadingSwebManagedThreadBase
Swebui.ManagedThreadingSwebManagedThreadingTimer

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebManagedThreadingTimer : SwebManagedThreadBase
Public Class SwebManagedThreadingTimer
    Inherits SwebManagedThreadBase

SwebManagedThreadingTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebManagedThreadingTimer(Timer, String) | 构造函数
公共方法 | SwebManagedThreadingTimer(Timer, String, String) | 构造函数
公共方法 | SwebManagedThreadingTimer(Timer, String, String, String) | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedTimer | 获取Threading.Timer
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
备注
参见

引用

Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebManagedThreadingTimer(Timer, String) | 构造函数
公共方法 | SwebManagedThreadingTimer(Timer, String, String) | 构造函数
公共方法 | SwebManagedThreadingTimer(Timer, String, String, String) | 构造函数
Top
参见

引用

SwebManagedThreadingTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 构造函数 (Timer, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadingTimer(
    Timer managedObject,
    string name
)
Public Sub New (
    managedObject As Timer,
    name As String
)

参数

managedObject
类型：System.ThreadingTimer
托管时间
name
类型：SystemString
托管名称
参见

引用

SwebManagedThreadingTimer 类
SwebManagedThreadingTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 构造函数 (Timer, String, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadingTimer(
    Timer managedObject,
    string name,
    string sessionid
)
Public Sub New (
    managedObject As Timer,
    name As String,
    sessionid As String
)

参数

managedObject
类型：System.ThreadingTimer
托管时间
name
类型：SystemString
托管名称
sessionid
类型：SystemString
会话编号
参见

引用

SwebManagedThreadingTimer 类
SwebManagedThreadingTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 构造函数 (Timer, String, String, String)

构造函数

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedThreadingTimer(
    Timer managedObject,
    string name,
    string sessionid,
    string sessionform
)
Public Sub New (
    managedObject As Timer,
    name As String,
    sessionid As String,
    sessionform As String
)

参数

managedObject
类型：System.ThreadingTimer
托管时间
name
类型：SystemString
托管名称
sessionid
类型：SystemString
会话编号
sessionform
类型：SystemString
会话窗体
参见

引用

SwebManagedThreadingTimer 类
SwebManagedThreadingTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 属性

SwebManagedThreadingTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedTimer | 获取Threading.Timer
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedThreadingTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer.ManagedTimer 属性

SwebManagedThreadingTimerManagedTimer 属性

获取Threading.Timer

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Timer ManagedTimer { get; }
Public ReadOnly Property ManagedTimer As Timer
    Get

属性值

类型：Timer

返回值

类型：Timer
备注
参见

引用

SwebManagedThreadingTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedThreadingTimer 事件

SwebManagedThreadingTimer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedThreadingTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedTimer 类

托管Timers.Timer
继承层次
SystemObject
Swebui.ManagedThreadingSwebManagedThreadBase
Swebui.ManagedThreadingSwebManagedTimer

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public class SwebManagedTimer : SwebManagedThreadBase
Public Class SwebManagedTimer
    Inherits SwebManagedThreadBase

SwebManagedTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SwebManagedTimer(Timer, String) | 初始化 SwebManagedTimer 类的一个新实例
公共方法 | SwebManagedTimer(Timer, String, String) | 初始化 SwebManagedTimer 类的一个新实例
公共方法 | SwebManagedTimer(Timer, String, String, String) | 初始化 SwebManagedTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedTimer | 获取Timers.Timer
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
备注
参见

引用

Swebui.ManagedThreading 命名空间


SwebManagedTimer 构造函数

重载列表
 | 名称 | 说明
公共方法 | SwebManagedTimer(Timer, String) | 初始化 SwebManagedTimer 类的一个新实例
公共方法 | SwebManagedTimer(Timer, String, String) | 初始化 SwebManagedTimer 类的一个新实例
公共方法 | SwebManagedTimer(Timer, String, String, String) | 初始化 SwebManagedTimer 类的一个新实例
Top
参见

引用

SwebManagedTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedTimer 构造函数 (Timer, String)

初始化 SwebManagedTimer 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedTimer(
    Timer managedObject,
    string name
)
Public Sub New (
    managedObject As Timer,
    name As String
)

参数

managedObject
类型：System.TimersTimer

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String)" 的 <param name="name"/> 文档]

参见

引用

SwebManagedTimer 类
SwebManagedTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedTimer 构造函数 (Timer, String, String)

初始化 SwebManagedTimer 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedTimer(
    Timer managedObject,
    string name,
    string sessionid
)
Public Sub New (
    managedObject As Timer,
    name As String,
    sessionid As String
)

参数

managedObject
类型：System.TimersTimer

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String)" 的 <param name="name"/> 文档]

sessionid
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String)" 的 <param name="sessionid"/> 文档]

参见

引用

SwebManagedTimer 类
SwebManagedTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedTimer 构造函数 (Timer, String, String, String)

初始化 SwebManagedTimer 类的一个新实例

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public SwebManagedTimer(
    Timer managedObject,
    string name,
    string sessionid,
    string sessionform
)
Public Sub New (
    managedObject As Timer,
    name As String,
    sessionid As String,
    sessionform As String
)

参数

managedObject
类型：System.TimersTimer

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String,System.String)" 的 <param name="managedObject"/> 文档]

name
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String,System.String)" 的 <param name="name"/> 文档]

sessionid
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String,System.String)" 的 <param name="sessionid"/> 文档]

sessionform
类型：SystemString

[缺少 "M:Swebui.ManagedThreading.SwebManagedTimer.#ctor(System.Timers.Timer,System.String,System.String,System.String)" 的 <param name="sessionform"/> 文档]

参见

引用

SwebManagedTimer 类
SwebManagedTimer 重载
Swebui.ManagedThreading 命名空间


SwebManagedTimer 属性

SwebManagedTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ManagedObject | 托管对象 (继承自 SwebManagedThreadBase。)
公共属性 | ManagedTimer | 获取Timers.Timer
公共属性 | Name | 托管对象名称 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedTimer.ManagedTimer 属性

SwebManagedTimerManagedTimer 属性

获取Timers.Timer

命名空间： Swebui.ManagedThreading
程序集： Swebui.Core (在 Swebui.Core.dll 中) 版本：1.0.133.17134+2c49d126d464232ac9a5157f96561862d8e39182
语法
C#
VB
复制
public Timer ManagedTimer { get; }
Public ReadOnly Property ManagedTimer As Timer
    Get

属性值

类型：Timer

返回值

类型：Timer
备注
参见

引用

SwebManagedTimer 类
Swebui.ManagedThreading 命名空间


SwebManagedTimer 事件

SwebManagedTimer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | FormActivated | 当使用代码激活或用户激活窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormClosed | 在窗体关闭后发生 (继承自 SwebManagedThreadBase。)
公共事件 | FormDeactivate | 当窗体失去焦点成为不活动窗体时发生 (继承自 SwebManagedThreadBase。)
公共事件 | SessionStoped | 在用户重新连接、用户会话过期、代码中未捕获的异常触发Dump、通过其他方式停止会话等情况时发生 (继承自 SwebManagedThreadBase。)
Top
参见

引用

SwebManagedTimer 类
Swebui.ManagedThreading 命名空间